Subject: R: Last Call Expired: <draft-ietf-ipfix-flow-selection-tech-14.txt>

From: "Salvatore D'Antonio" <[email-masked]>
Date: Tue, 9 Apr 2013 17:40:03 +0200

Dear all,

A new version of the Internet Draft on Flow Selection Techniques has been submitted. It contains the following changes:

-          A new section illustrating the difference between Intermediate Flow Selection Process and Intermediate Selection Process has been added,

-          The sentence "In order to be compliant with this document, at least the Property  Match Filtering MUST be implemented." has been removed in Section 1,

-          “MUST” has been replaced with “SHOULD” in Section 5.1,

-          “The flowSelectorAlgorithm registry is maintained by IANA." has been replaced with “IANA is requested to create the flowSelectorAlgorithm registry.”

-          The sentence "The registry can be updated when specifications of the new  technique(s) and any new Information Elements are provided." has been removed since it did not clarify how the registry will be managed.

-           Section 6.1.1 “Property Match Filtering” has been changed by adding some text on how Property Match Filtering can be  used by an Intermediate Flow Selection Process in the Metering Process, in the  Exporting Process and within an IPFIX Mediator.

Best regards,

Salvatore

Da: Benoit Claise [mailto:[email-masked]] 
Inviato: lunedì 8 aprile 2013 15:21
A: [email-masked]
Cc: [email-masked]
Oggetto: Fwd: Last Call Expired: <draft-ietf-ipfix-flow-selection-tech-14.txt>

Dear authors,

The IETF last call has finished.
Can you please update your draft based on the feedback received.
Then I will progress it.

Regards, Benoit

-------- Original Message -------- 

Subject: 

Last Call Expired: <draft-ietf-ipfix-flow-selection-tech-14.txt>

Date: 

Mon, 01 Apr 2013 00:28:46 -0700

From: 

DraftTracker Mail System  <mailto:[email-masked]> <[email-masked]>

To: 

[email-masked], [email-masked], [email-masked]

CC: 

[email-masked]

Please DO NOT reply to this email.
 
I-D: <draft-ietf-ipfix-flow-selection-tech-14.txt>
ID Tracker URL: http://datatracker.ietf.org/doc/draft-ietf-ipfix-flow-selection-tech/
 
IETF Last Call has ended, and the state has been changed to
Waiting for AD Go-Ahead.

 

  _____  

Nessun virus nel messaggio.
Controllato da AVG - www.avg.com
Versione: 2013.0.3272 / Database dei virus: 3162/6231 - Data di rilascio: 07/04/2013

******************************************************************************	

IL MERITO DEGLI STUDENTI VIENE RICONOSCIUTO

Il 5 per mille all'Universita' degli Studi di Napoli "Parthenope" incrementa le borse di studio agli studenti - codice fiscale 80018240632

http://www.uniparthenope.it/index.php/5xmille 

http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille

Questa informativa e' inserita in automatico dal sistema al fine esclusivo della realizzazione dei fini istituzionali dell'ente.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 15 Apr 2013 11:42:47 +0200

Salvatore
>
> Dear all,
>
> A new version of the Internet Draft on Flow Selection Techniques has 
> been submitted. It contains the following changes:
>
> -A new section illustrating the difference between Intermediate Flow 
> Selection Process and Intermediate Selection Process has been added,
>
> -The sentence "In order to be compliant with this document, at least 
> the Property  Match Filtering MUST be implemented." has been removed 
> in Section 1,
>
> -“MUST” has been replaced with “SHOULD” in Section 5.1,
>
Actually, the feedback was:

    In Section 1:

       "In order to be compliant with this document, at least the Property
        Match Filtering MUST be implemented."

    The above text is repeated in Section 5.1.  I suggest removing this
    sentence as it does not seem related to scope.

    My reading of the "MUST" is that it is being used for compliance
    instead of the reasons described in RFC 2119.  I suggest reviewing
    the usage of RFC 2119 key words in Section 5.1.

So the solution is not to change MUST to SHOULD.
The question is whether "MUST" versus "must" must be used.
I understand the concern. For compliance reason with the PSAMP RFC 5475 
(which is closely related) ...

        7 <http://tools.ietf.org/html/rfc5475#section-7>. Parameters for
        the Description of Selection Techniques

        This section gives an overview of different alternative selection
        schemes and their required parameters.  In order to be compliant with
        PSAMP, at least one of proposed schemes MUST be implemented.

... I would keep the initial "MUST" from the previous draft version.

> -“The flowSelectorAlgorithm registry is maintained by IANA." has been 
> replaced with “IANA is requested to create the flowSelectorAlgorithm 
> registry.”
>
> -The sentence "The registry can be updated when specifications of the 
> new  technique(s) and any new Information Elements are provided." has 
> been removed since it did not clarify how the registry will be managed.
>
> - Section 6.1.1 “Property Match Filtering” has been changed by adding 
> some text on how Property Match Filtering can be  used by an 
> Intermediate Flow Selection Process in the Metering Process, in the 
>  Exporting Process and within an IPFIX Mediator.
>
When publishing a new version, please correct this editorial issue.

  " ... and Flow duration. in
    the An example is the selection of the largest ..."

> Best regards,
>
> Salvatore
>
> *Da:*Benoit Claise [mailto:[email-masked]]
> *Inviato:* lunedì 8 aprile 2013 15:21
> *A:* [email-masked]
> *Cc:* [email-masked]
> *Oggetto:* Fwd: Last Call Expired: 
> <draft-ietf-ipfix-flow-selection-tech-14.txt>
>
> Dear authors,
>
> *Subject: *
> *Date: *
> *From: *
> DraftTracker Mail System <[email-masked]> 
> <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, 
> [email-masked] 
> <mailto:[email-masked]>
>
> *CC: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>
>
> ID Tracker URL:http://datatracker.ietf.org/doc/draft-ietf-ipfix-flow-selection-tech/
>   
> ------------------------------------------------------------------------
>
> Controllato da AVG - www.avg.com <http://www.avg.com>
> *******************************************************************************************************
>
> Il 5 per mille all'Università degli Studi di Napoli 
> "Parthenope"incrementa le borse di studio agli studenti - codice 
> fiscale *80018240632*
>
> _http://www.uniparthenope.it/index.php/5xmille_
>
> _http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille_
>
>
> Questa informativa è inserita in automatico dal sistema al fine 
> esclusivo della realizzazione dei fini istituzionali dell'ente.
>
>
>
>
> *******************************************************************************************************
>
> Il 5 per mille all'Università degli Studi di Napoli 
> "Parthenope"incrementa le borse di studio agli studenti - codice 
> fiscale *80018240632*
>
> _http://www.uniparthenope.it/index.php/5xmille_
>
> _http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille_
>
>
> Questa informativa è inserita in automatico dal sistema al fine 
> esclusivo della realizzazione dei fini istituzionali dell'ente.
>
>
>

---

From: "Salvatore D'Antonio" <[email-masked]>
Date: Sun, 21 Apr 2013 02:06:14 +0200

Dear Benoit, all

I submitted v16 of the Internet Draft.

I modified section 9.1.1 on the maintenance of the flowSelectorAlgorithm registry and fixed the editorial issue in section  6.1.1

I have also used MUST in section 6.1

Best regards,

Salvatore

Da: Benoit Claise [mailto:[email-masked]] 
Inviato: lunedì 15 aprile 2013 11:43
A: Salvatore D'Antonio
Cc: [email-masked]; [email-masked]; 'S Moonesamy'; [email-masked]; [email-masked]; 'Joel M. Halpern'; 'A. Jean Mahoney'; 'General Area Review Team'; 'IETF discussion list'; [email-masked]; [email-masked]
Oggetto: Re: R: Last Call Expired: <draft-ietf-ipfix-flow-selection-tech-14.txt>

Salvatore

Dear all,

In Section 1: 

The above text is repeated in Section 5.1.  I suggest removing this sentence as it does not seem related to scope. 

My reading of the "MUST" is that it is being used for compliance instead of the reasons described in RFC 2119.  I suggest reviewing the usage of RFC 2119 key words in Section 5.1. 

So the solution is not to change MUST to SHOULD.
The question is whether "MUST" versus "must" must be used.
I understand the concern. For compliance reason with the PSAMP RFC 5475 (which is closely related) ...

 <http://tools.ietf.org/html/rfc5475#section-7> 7.  Parameters for the Description of Selection Techniques

 

Best regards,

Salvatore

Dear authors,

Regards, Benoit

-------- Original Message -------- 

Subject: 

Date: 

From: 

To: 

CC: 

[email-masked]

 

 

  _____  

Il 5 per mille all'Università degli Studi di Napoli "Parthenope"incrementa le borse di studio agli studenti - codice fiscale 80018240632 

 <http://www.uniparthenope.it/index.php/5xmille> http://www.uniparthenope.it/index.php/5xmille 

 <http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille> http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille

Questa informativa è inserita in automatico dal sistema al fine esclusivo della realizzazione dei fini istituzionali dell'ente.

Il 5 per mille all'Università degli Studi di Napoli "Parthenope"incrementa le borse di studio agli studenti - codice fiscale 80018240632 

 <http://www.uniparthenope.it/index.php/5xmille> http://www.uniparthenope.it/index.php/5xmille 

 <http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille> http://www.uniparthenope.it/index.php/it/avvisi-sito-di-ateneo/2943-la-parthenope-premia-il-tuo-voto-di-diploma-ed-il-tuo-imegno-con-i-proventi-del-5-per-mille

Questa informativa è inserita in automatico dal sistema al fine esclusivo della realizzazione dei fini istituzionali dell'ente.