Subject: (Former) IETF Chair Interview

From: Russ Housley <[email-masked]>
Date: Fri, 5 Apr 2013 14:14:51 -0400

This was recorded in January 2013, when I was the IETF Chair.  It was not released until March 20th, when I was no longer IETF Chair

It is 15 minutes.  It is not aimed at a technical crowd.

Russ

---

From: Russ Housley <[email-masked]>
Date: Fri, 5 Apr 2013 14:17:48 -0400

http://www.youtube.com/watch?v=CH65RbOSrZ8