Subject: Re: Less Corporate Diversity

From: joel jaeggli <[email-masked]>
Date: Thu, 04 Apr 2013 09:55:39 -0700

this late  but I thought I'd comment on one part of it.

On 3/20/13 3:36 PM, Jari Arkko wrote:
> I think it is mostly market forces and historical reasons, and the development of the IETF to focus on more particular core aspects of the Internet (like routing) as opposed to what the small shops might work on.
>
> But I think we are missing a bit of the point in this discussion. I do not feel that we need to prove we are somehow "no worse" than industry average. The point is that *if* we had more diversity along many of the discussed lines, we'd be far better off. For instance, having people from multiple organisations provide input to a last would be preferable to just a few. Similarly with the other dimensions of diversity. When I talked to some of the ISOC fellows last week, I realised peering is very different on different continents.
Different doesn't generally mean good, in the peering case.

There are plenty of examples of monopoly PTTs or regulators engaging in 
behavior that impacts the usability of or availability of traffic 
exchange, there's all sorts of market failures, and there's deliberately 
uncompetitive practices from some of the participants. so when we look 
at the diversity of experience for network operators not all the 
diversity is a happy place.
>   Even if there may be less economic activity on networking on those continents, it would be good for us to understand the real situations around the world, as opposed to thinking the whole world is like where we live. Diversity = good in most cases, and increasing that goodness should be the goal.
>
> Jari
>
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 4 Apr 2013 20:22:22 +0300

Joel,

> There are plenty of examples of monopoly PTTs or regulators engaging in behavior that impacts the usability of or availability of traffic exchange, there's all sorts of market failures, and there's deliberately uncompetitive practices from some of the participants. so when we look at the diversity of experience for network operators not all the diversity is a happy place.

I agree, of course. And the Internet community needs to work on getting to a better situation where such breakage exists. (My point on the diversity thread was that it is good to understand what the situations are in the world, not that those situations themselves are necessarily always good…)

Jari

---

From: Keith Moore <[email-masked]>
Date: Sat, 06 Apr 2013 11:12:47 -0400

On 03/23/2013 02:27 AM, Bob Hinden wrote:
> To raise this discussion up a bit, I can think two other related reasons why there may be less corporate diversity in the IETF.
>
> The first is that it's possible to build applications and businesses that take advantage of the Internet without having to come to the IETF to standardize anything.  The work of the IETF (and related organizations like W3C, IEEE, etc.) have made this possible.  A success problem so to speak.
>
> The second is that it's very hard to make changes at the IP and transport layers and have them be deployed in scale given middle boxes.  Many organizations have stopped trying and focus on making things work on top of http.  This also doesn't require coming to the IETF.

Perhaps not, but the extensive proliferation of middle boxes is arguably 
due to various failures within IETF, such as the failure to promote 
end-to-end security or the failure to extend the Internet architecture 
to accommodate legitimate needs of networks.

Keith