Subject: review of draft-crocker-id-adoption-05

From: Andrew Sullivan <[email-masked]>
Date: Fri, 3 Jan 2014 11:48:53 -0500

Dear colleagues,

I have read draft-crocker-id-adoption-05.

I'm not opposed to publication, though I confess I'm a little uneasy
with it.  This is yet another process document that, no matter how
much the text protests otherwise, will probably be used as a club in
some future contentious WG discussion to try to beat opponents into
submission.  If we want to publish this sort of thing, however, this
document is probably fine.  I have one small issue.

In section 5.2, there is this:

   a single, strong specification.  The detailed discussions to merge
   are better held in a design team than amidst the dynamics of an open
   working group mailing list.

I think it would be better to alter that to "…to merge are often
better held…".  I agree that for practical purposes things don't
always need to be thrashed out on the general list, but sometimes the
wider debate (or the very small active population of a WG) means that
a design team is a bad choice, and I don't want this text to give
people an excuse to try to take things "into the back room" when they
shouldn't.

I'll send some nits to the author directly.

Best regards,

A
-- 
Andrew Sullivan
[email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 3 Jan 2014 17:23:51 -0000

Hello Andrew,

[The aside] 

>  This is yet another process document that, no matter how
> submission.  

At the moment we don't seem to be able to move for fear of clubbing WGs at some future unspecified time.
And at the same time we have WG chairs saying "please give us a bit of general guidance on some topics". 
So we might handle this by putting it on a wiki instead, but I think the community like to be able to read about "stuff". And our mode of publication (to date) has been the RFC not the wiki.

I'm in general in favor of encouraging people to have some backbone if they feel they are being clubbed, and not to cry out that they might be clubbed in the future.

I think I would have a different view if the I-D was proposing rules and regulations without fully examining the consequences.

[And the technical bit]

> better held…". 

That is a good suggestion, IMHO.

Thanks,
Adrian

---

From: Michael Richardson <[email-masked]>
Date: Fri, 03 Jan 2014 22:43:38 -0500

> And at the same time we have WG chairs saying "please give us a bit of general guidance on some topics".

I read the document, and I find it useful.
So, as a guide to chairs, I think that all of the work/text has value.

This document is going forward as Informational rather than BCP.
While it represents some kind of consensus (and if it's the consensus of the
IESG as to how the IESG wants things done, that's important to know), I think
it's important that it's a guideline.

As such it doesn't have any force to club WG chairs.
But at the same time, having no force, I wonder at the value of putting this
into any place other than the wg-chairs wiki.

--
Michael Richardson <[email-masked]>, Sandelman Software Works