Subject: Re: Concerns about draft-moonesamy-ietf-conduct-3184bis-05 becoming a Best Current Practice

From: S Moonesamy <[email-masked]>
Date: Wed, 01 Jan 2014 10:47:07 -0800

Hi Russ,
At 07:48 31-12-2013, Russ Housley wrote:
>The IETF develops open standards for one global Internet, providing 
>maximum interoperability and scalability, and avoiding specialized 
>protocols in different places.

The concern is about whether to have text in the document for the 
above.  This is the third statement in Section 2:

   "3. IETF participants devise solutions for the Internet that meet the
       needs of diverse technical and operational environments."

The sentence which is not in the draft is:

   "The goal of the IETF is to maintain and enhance a working, viable,
    scalable, global Internet, and the problems we encounter are
    genuinely very difficult."

The comment from Adrian Farrel is as follows:

   "I pointed out that 3184 predated the mission statement in 3935 
and that it would
    be "better" (IMHO) to align this revision with the consensus 
mission statement
    than to define the purpose of the IETF as an aside in this document."

The goal of the IETF is currently described as follows:

   "The goal of the IETF is to make the Internet work better."

I read it as a simple statement.  The reader may ask: "what do you 
mean by that?"  This is where the discussion gets into the mission statement:

   "The mission of the IETF is to produce high quality, relevant
    technical and engineering documents that influence the way people
    design, use, and manage the Internet in such a way as to make the
    Internet work better."

An alternative might be:

    3. IETF participants devise solutions for the Internet that meet the
       needs of diverse technical and operational environments.

       The mission of the IETF is to produce high quality, relevant
       technical and engineering documents that influence the way people
       design, use, and manage the Internet in such a way as to make the
       Internet work better.  The IETF puts its emphasis on technical
       competence, rough consensus and individual participation, and needs
       to be open to competent input from any source.

       IETF participants use their best engineering judgment to find the
       best solution for the whole Internet, not just the best solution
       for any particular network, technology, vendor, or user.  While we
       all have ideas that may stand improvement from time to time, no
       one shall ever knowingly contribute advice or text that would make
       a standard technically inferior.

>BCP 79 is the proper reference.
>
>Following the IPR rules is an obligation for all IETF 
>participants.  It was in RFC 3184, and I think we need to keep in 
>this document.

The text in RFC 3184 is as follows:

   "We follow the intellectual property guidelines outlined in BCP 9."

In my opinion that text does not fit under the third statement.  An 
alternative, which was suggested, is to have it under another 
guideline.  The comment mentions that it is an obligation and I agree 
with that.  The point being discussed is that the obligation has to 
be kept in this document because it was in RFC 3184.  The document 
has been described as being about personal conduct and personal 
interaction.  The document does not discuss about rules.

The Note Well is used to direct people to BCP 79.  A person attending 
a working group session will be told about the Note Well.  A person 
subscribing to an IETF mailing list will be sent a pointer to the 
Note Well.  I suggest leaving it to the Note Well to list the rules 
as it has not been argued that the Note Well is inadequate.

Regards,
S. Moonesamy

---

From: Russ Housley <[email-masked]>
Date: Thu, 2 Jan 2014 16:43:41 -0500

>      a standard technically inferior.

This proposed text is an improvement, but I would be much happier with the addition of one word to the first sentence:  ... devise solutions for the global Internet ...

>> Following the IPR rules is an obligation for all IETF participants.  It was in RFC 3184, and I think we need to keep in this document.
> 
> In my opinion that text does not fit under the third statement.  An alternative, which was suggested, is to have it under another guideline.  The comment mentions that it is an obligation and I agree with that.  The point being discussed is that the obligation has to be kept in this document because it was in RFC 3184.  The document has been described as being about personal conduct and personal interaction.  The document does not discuss about rules.

Disclosure of IPR that you know about is personal conduct.

> The Note Well is used to direct people to BCP 79.  A person attending a working group session will be told about the Note Well.  A person subscribing to an IETF mailing list will be sent a pointer to the Note Well.  I suggest leaving it to the Note Well to list the rules as it has not been argued that the Note Well is inadequate.

RFC 3184 included a sentence telling people about the expected conduct regarding IPR disclosure.  I strongly believe that 3184 should do the same.

Russ

---

From: S Moonesamy <[email-masked]>
Date: Thu, 02 Jan 2014 23:36:11 -0800

Hi Russ,
At 13:43 02-01-2014, Russ Housley wrote:
>This proposed text is an improvement, but I would be much happier 
>with the addition of one word to the first sentence:  ... devise 
>solutions for the global Internet ...

With the above suggestion, the third statement could be as follows:

    3. IETF participants devise solutions for the global Internet that
       meet the needs of diverse technical and operational environments.

> > The Note Well is used to direct people to BCP 79.  A person 
> attending a working group session will be told about the Note 
> Well.  A person subscribing to an IETF mailing list will be sent a 
> pointer to the Note Well.  I suggest leaving it to the Note Well to 
> list the rules as it has not been argued that the Note Well is inadequate.
>
>RFC 3184 included a sentence telling people about the expected 
>conduct regarding IPR disclosure.  I strongly believe that 3184 
>should do the same.

I'll consider this concern as unresolved.  The Area Directors can 
review the comments and recommend how to resolve the concern.

Regards,
S. Moonesamy

---

From: Ted Lemon <[email-masked]>
Date: Fri, 3 Jan 2014 07:54:39 -0500

On Jan 3, 2014, at 2:36 AM, S Moonesamy <[email-masked]> wrote:
> I'll consider this concern as unresolved.  The Area Directors can review the comments and recommend how to resolve the concern.

We are not the Encyclopedia Britannica.   I think Russ' suggestion makes sense.

---

From: Randy Bush <[email-masked]>
Date: Fri, 03 Jan 2014 10:55:30 -1000

> review the comments and recommend how to resolve the concern.

consider this message a formal objection and support of russ's change
request.

randy

---

From: Sean Turner <[email-masked]>
Date: Fri, 3 Jan 2014 18:08:53 -0500

>      meet the needs of diverse technical and operational environments.

Adding an informative reference RFC 3935 would also probably do it.

>> RFC 3184 included a sentence telling people about the expected conduct regarding IPR disclosure.  I strongly believe that 3184 should do the same.

We spend so much time on this and it’s really unfun to have to scold folks on this issue so for me this is a +1 to adding something in about expected conduct regarding IPR disclosures.

spt

---

From: S Moonesamy <[email-masked]>
Date: Fri, 03 Jan 2014 15:39:37 -0800

Hi Sean, Russ,
At 15:08 03-01-2014, Sean Turner wrote:
>We spend so much time on this and it's really unfun to have to scold 
>folks on this issue so for me this is a +1 to adding something in 
>about expected conduct regarding IPR disclosures.

Here is text which can be inserted in the last paragraph of Section 2:

   We follow the intellectual property guidelines outlined in BCP 79.
   IETF participants read the relevant Internet-Drafts ...

Regards,
S. Moonesamy

---

From: Jari Arkko <[email-masked]>
Date: Sat, 4 Jan 2014 09:03:56 +0100

I think the text you SM and Russ discussed for the "global" issue is fine, and supported by the discussion. (Although I have to say, the word "whole" later in that section already did it for me; I did not consider the fix critical. But I think the document is better with the fix.)

>      meet the needs of diverse technical and operational environments.

I'm also happy to have the IPR rules referenced, again as discussed by you SM and Russ and supported by discussion.

>  IETF participants read the relevant Internet-Drafts …

And I think the suggestion from Dave was also worthwhile and supported by discussion:

>      ... All participants, particularly those with English as a first
>      language, attempt to accommodate the needs of other participants
>      by communicating clearly, including speaking slowly and limiting
>      the use of slang. …

Finally, you should use data tracker URLs as Russ suggested.

I do think though that for the rest, we are beyond the stage where additional editing provides useful results. I think SM's text is good, easily understandable, and ready to go. 

Jari