Subject: Call for Review of draft-iab-doi-01.txt, "Assigning Digital Object Identifiers to RFCs"

From: IAB Chair <[email-masked]>
Date: Tue, 4 Mar 2014 09:37:50 -0500

This is a call for review of "Assigning Digital Object Identifiers
to RFCs" prior to potential approval as an IAB stream RFC.

The document is available for inspection here:
https://datatracker.ietf.org/doc/draft-iab-doi/

The Call for Review will last until 2 April 2014.
Normally, we ask for comments to go to the IAB mail list, but for
this document, it is more appropriate to use the RFC Interest list.
Please send comments to [email-masked]. 

On behalf of the IAB,
Russ Housley
IAB Chair

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 4 Mar 2014 15:07:07 +0000

> Please send comments to [email-masked]. 

Question on the document. I'm in favor of DOIs based on what I understand the benefits to be, but it seems to me that the benefit is stated in a manner that isn't very clear. 

The statement, in the final paragraph of the introduction, is that it makes an RFC easier to search and to cite. I believe that this is true for a specific constituency, which is to say "academics". The use of a DOI makes it easier for them to get academic credit for having written an RFC in the sense of publishing a peer-reviewed paper, and it makes it easier for them to find such papers. 

Do I have the benefit down correctly? Are there other benefits, or other constituencies?

To my way of thinking, adding a sentence or two in the introduction making the benefit specific would be a good thing. I'm not opposed to publication as it stands, but I think the clarity would be beneficial.

---

From: Riccardo Bernardini <[email-masked]>
Date: Tue, 4 Mar 2014 16:30:54 +0100

> Do I have the benefit down correctly? Are there other benefits, or other constituencies?

My 0.02 about the utility of DOI.  Just this morning I had a
discussion  about DOI with a colleague of mine...

We were talking about the publication database at our university.
Currently we have to insert the data about our publications (title,
journal, authors and so on...) "by hand" with a serious chance of
errors and duplication and a consequent overhead for checking and
correction.  I said that a more robust system would require only the
specification of the DOI that would be used to retrieve automatically
all the metadata associated with the work  (I understand that this is
possible, although I never tried it).  My colleague objected that not
everything has a DOI, so that a "special case interface" should
provided anyway.

So, in my opinion the major advantage of attaching DOIs to RFCs is not
the fact that it makes it easier to find the RFC (although that is
nice too), but the possibility of getting automatically the meta-data
associated with it and the fact that in application cases as the one
described above RFCs can be handled as any other type of
technical/scientific publication.

We could live without it, of course, but I think that in the long run
it will prove convenient.

Riccardo

---

From: Ted Lemon <[email-masked]>
Date: Tue, 4 Mar 2014 15:34:45 +0000

> technical/scientific publication.

This observation is also true of Wikipedia—you type one DOI and get all the attributions, rather than having to manually enter a possibly rather large amount of data into a rather ugly markup language.

---

From: mohammed serrhini <[email-masked]>
Date: Tue, 04 Mar 2014 22:12:42 +0400

I strongly agree wth
Serrhini Mohammed
Facutly of sciences Oujda Morocco

Вторник,  4 марта 2014, 15:34 UTC от Ted Lemon <[email-masked]>:
>On Mar 4, 2014, at 3:30 PM, Riccardo Bernardini < [email-masked] > wrote:

С уважением,
mohammed serrhini
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 4 Mar 2014 23:31:42 -0000

>I said that a more robust system would require only the
>possible, although I never tried it).

Yes, it's true.  Every DOI is a URL like http://dx.doi.org/10.123456/foo.bar.
If you fetch it up normally it redirects you to the document, typically a
page at the publisher with the abstract and a link to buy it, or in our case
links to the RFC in various forms.

If you fetch it and ask for "Accept: text/bibliography; style=bibtex" or
application/json, you get the bibliographic data in bibtex or JSON.  It's
pretty handy.

R's,
John