Subject: Two official work languages is smarter (was Re: IETF working language

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 9 Mar 2014 16:37:56 +0000

Bonjour,

I agree with Mohammed totally. I recommend allowing another second official
language will solve a lot of native English speakers problems.

Comments below

AB

On Sunday, March 9, 2014, Ted Lemon wrote:

> On Mar 8, 2014, at 8:02 PM, mohammed serrhini <[email-masked]<javascript:;>>
> wrote:
> > I think their exclusion is not fair
> > the effort must be made by the latter because he has put himself in
> the skin of the other
> > and must to ask him self , what happen in the case if native language is
> the official language IETF is not English
>
> One of the frustrations of life is that even if we recognize that
> something is unfair, there may be limited possibilities for addressing the
> unfairness.   It was once the case that French was the language of
> diplomacy, and an attempt was made to formulate an artificial language,
> Esperanto, for use by diplomats as a new "lingua franca."

Not only diplomats but the French language is more sensitive and polite
language which has nice feelings.

>
> For better or for worse, the Internet broke that process (I don't think
> there was much hope for Esperanto anyway).   So what do we do now?

The answer to your Qs is let us Speak French, and write and read in French.
Programming in one language is poor programming, IETF SHOULD become smarter
and it SHOULD be able to write and read in French.

>  Try to revive Esperanto as a language for expressing standards?   Choose
> a different language, so as to change the lucky recipient of privilege?
>
> Thanks

> I can't speak for other IETFers, but I am keenly aware of the unfairness
> of the current situation.   But the only thing I know how to do to fix it
> is to help people for whom english is not their first language to
> participate in english anyway.

That is one side solving, so you help non native speakers what about
helping native English speakers that complaint a lot about English grammar
and non sense of IETF participants that speak IETF language.

IETF language is using English right but it is not the same way Americans
use it but it is the worlds use of English.

> There is a lot of interest within the IETF in doing this--it's not just me.

I add to your interest. There were a great person I meat in IETF that is
volunteering translation to French language.

> If you have ideas for how to change this, please share them with us.

I always do share my ideas but some native English readers use their
receiving problem to put down ideas just because of few grammar mistakes.

> But the mere fact that I as a native english speaker happen to be
> privileged at the moment is a fact with which I am already painfully
> familiar (although no doubt much less painfully than the non-native english
> speakers).
>
> If other IETFers are not aware of this, it would be good if they could
> wake up to it.   I would certainly advise native-english-speaking IETFers
> to really exercise patience when communicating with non-native speakers,
> keeping in mind exactly what you, Mohammed, have said: that the situation
> is unfair, and it is incumbent on those of us in the privileged position to
> do our best to help those who are not.

I said many times that IETF needs to solve the problem and happy to get
support.

>
> But is that all we can do?   And if we do it to the best of our ability,
> will it be enough?

No, we need another official language to give more freedom. It will make
native English readers more respecting to whom chosen their language in
future work or discussion. Usually when I discuss in IETF my target readers
are European participants first and then all other regions.

> And, I hate to say it, given that not everybody will see it the way you do
> or the way I do, what else can we do?
>
> Do French language makes us better communicators and better programmers
with a new language.

AB

---

From: Russ Housley <[email-masked]>
Date: Sun, 9 Mar 2014 13:17:26 -0400

The IETF had a discussion about languages while Harald was chair.  In my opinion, every dimension of the issues was discussed at that time.  I do not think that anything new has been raised for use to reopen the discussion.

Russ

On Mar 9, 2014, at 12:37 PM, Abdussalam Baryun wrote:

> Bonjour,
> 
> I agree with Mohammed totally. I recommend allowing another second official language will solve a lot of native English speakers problems. 
> 
> Comments below
> 
> AB
> 
> On Mar 8, 2014, at 8:02 PM, mohammed serrhini <[email-masked]> wrote:
> > the effort must be made by the latter because he has put himself in the skin of the other
> > and must to ask him self , what happen in the case if native language is the official language IETF is not English
> 
> One of the frustrations of life is that even if we recognize that something is unfair, there may be limited possibilities for addressing the unfairness.   It was once the case that French was the language of diplomacy, and an attempt was made to formulate an artificial language, Esperanto, for use by diplomats as a new "lingua franca."
> 
> Not only diplomats but the French language is more sensitive and polite language which has nice feelings.  
> 
> For better or for worse, the Internet broke that process (I don't think there was much hope for Esperanto anyway).   So what do we do now?  
> 
> The answer to your Qs is let us Speak French, and write and read in French. Programming in one language is poor programming, IETF SHOULD become smarter and it SHOULD be able to write and read in French. 
>  
>  Try to revive Esperanto as a language for expressing standards?   Choose a different language, so as to change the lucky recipient of privilege?
> 
> Thanks
>  
> I can't speak for other IETFers, but I am keenly aware of the unfairness of the current situation.   But the only thing I know how to do to fix it is to help people for whom english is not their first language to participate in english anyway.   
> 
> That is one side solving, so you help non native speakers what about helping native English speakers that complaint a lot about English grammar and non sense of IETF participants that speak IETF language. 
> 
> IETF language is using English right but it is not the same way Americans use it but it is the worlds use of English. 
>  
> There is a lot of interest within the IETF in doing this—it's not just me.
> 
> I add to your interest. There were a great person I meat in IETF that is volunteering translation to French language. 
> 
> 
> I always do share my ideas but some native English readers use their receiving problem to put down ideas just because of few grammar mistakes. 
>  
> But the mere fact that I as a native english speaker happen to be privileged at the moment is a fact with which I am already painfully familiar (although no doubt much less painfully than the non-native english speakers).
> 
> If other IETFers are not aware of this, it would be good if they could wake up to it.   I would certainly advise native-english-speaking IETFers to really exercise patience when communicating with non-native speakers, keeping in mind exactly what you, Mohammed, have said: that the situation is unfair, and it is incumbent on those of us in the privileged position to do our best to help those who are not.
> 
> I said many times that IETF needs to solve the problem and happy to get support. 
>  
> 
> But is that all we can do?   And if we do it to the best of our ability, will it be enough?   
> 
> No, we need another official language to give more freedom. It will make native English readers more respecting to whom chosen their language in future work or discussion. Usually when I discuss in IETF my target readers are European participants first and then all other regions. 
>  
> And, I hate to say it, given that not everybody will see it the way you do or the way I do, what else can we do?
> 
> Do French language makes us better communicators and better programmers with a new language.  
> 
> AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 9 Mar 2014 17:28:53 +0000

Bonjour Russ

If there is no pointer to such discussion then I believe there were no
discussion at all. However, I will raise this issue very seriously again.

Please provide me with information so I can comment on it, because you
mentioned that it was discussed in every dimension and I think it is only
the American dimensions.

AB

On Sunday, March 9, 2014, Russ Housley wrote:

> The IETF had a discussion about languages while Harald was chair.  In my
> opinion, every dimension of the issues was discussed at that time.  I do
> not think that anything new has been raised for use to reopen the
> discussion.
>
> Russ
>
>
> I agree with Mohammed totally. I recommend allowing another second
> official language will solve a lot of native English speakers problems.
>
> Comments below
>
> AB
>
> The answer to your Qs is let us Speak French, and write and read in
> French. Programming in one language is poor programming, IETF SHOULD become
> smarter and it SHOULD be able to write and read in French.
>
>

---

From: Ted Lemon <[email-masked]>
Date: Sun, 9 Mar 2014 14:05:27 -0400

I don't think the discussion is practical.   If we are all going to learn a new language, why not Chinese?   French is actually very easy for people who speak Indo-European languages, but no easier for Chinese or Japanese speakers.

In any case, I think one of the reasons why e.g. Finnish and Swedish participation is so good in the IETF is that in both countries English is learned from an early age.   Whether that's fair or not, it's very practical.   We can't all learn each others' languages, because there are too many of them.   So it makes sense to pick a language, and the unfairness that comes from picking a language seems unavoidable.   I don't see how picking a second language would help.   It would still be unfair to just as many people—the only difference would be that a few more people would in some sense be privileged.

So I think that whatever accommodation successfully occurs, it will be an accommodation involving people being more patient and understanding, not IETF participants as a group learning more languages.

---

From: Ted Lemon <[email-masked]>
Date: Sun, 9 Mar 2014 14:07:58 -0400

On Mar 9, 2014, at 2:05 PM, Ted Lemon <[email-masked]> wrote:
> If we are all going to learn a new language, why not Chinese?

(BTW, there's a certain irony in the use of "Chinese" to refer to a single language, of which I am well aware, but the commonality to the writing system is really what I consider most important.)

---

From: Russ Housley <[email-masked]>
Date: Sun, 9 Mar 2014 14:09:42 -0400

AB:

Harald Alvestrand, a Norwegian, was IETF Chair when this discussion took place.  He made the consensus call.

I find you assertion that the discussion only considered American dimensions quite an insult to all that participated in the IETF at the time.

Russ

On Mar 9, 2014, at 1:28 PM, Abdussalam Baryun wrote:

> Bonjour Russ
> 
> If there is no pointer to such discussion then I believe there were no discussion at all. However, I will raise this issue very seriously again. 
> 
> Please provide me with information so I can comment on it, because you mentioned that it was discussed in every dimension and I think it is only the American dimensions. 
> 
> AB
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 9 Mar 2014 18:46:34 +0000

Bonjour Russ,

I am sorry, and I did not mean any insult, most of IETF meeting are not in
Europe but most IETF meetings are in America. Therefore, my reason was that
the decisions and dimensions discussed are mostly American dimensions. I
may be wrong, and I never say I am right. However, when I ask why IETF most
meetings are in America, the reply is always : because the majority
participants are from America (that means the majority participants are
English language speakers and readers).

To encourage the demography change and developing diversity of the IETF it
is important to reduce meetings in America to balance in all the world
regions and then hope to open the subject of two languages again to see the
results.

AB

On Sunday, March 9, 2014, Russ Housley wrote:

> I find you assertion that the discussion only considered American
> dimensions quite an insult to all that participated in the IETF at the time.
>
> Russ
>
>
> If

---

From: Gordon Lennox <[email-masked]>
Date: Sun, 9 Mar 2014 20:30:11 +0100

On 9 Mar, 2014, at 19:46, Abdussalam Baryun <[email-masked]> wrote:

> I am sorry, and I did not mean any insult, most of IETF meeting are not in Europe but most IETF meetings are in America. 

Greetings,

What you have stated  is patently not true. It was true some time ago. But not now.

When I started to participate we had two meetings per year in North America (and that meant mostly the US) and a meeting in Europe or Asia on alternate years. 

That has clearly and obviously changed. Just look at where we have been in more recent years. Just look where we plan to go.

I think it is good that the IETF has evolved. And I think it will continue to do so.

But personally I hope we do not go down the ICANN and choose places where those who wish to contribute find it difficult to participate.

Regards,

Gordon

---

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Sun, 9 Mar 2014 19:34:39 +0000

I understand that in international discussions the number of official languages is normally either one or six?

Stewart

Sent from my iPad

On 9 Mar 2014, at 18:46, "Abdussalam Baryun" <[email-masked]<mailto:[email-masked]>> wrote:

Bonjour Russ,

I am sorry, and I did not mean any insult, most of IETF meeting are not in Europe but most IETF meetings are in America. Therefore, my reason was that the decisions and dimensions discussed are mostly American dimensions. I may be wrong, and I never say I am right. However, when I ask why IETF most meetings are in America, the reply is always : because the majority participants are from America (that means the majority participants are English language speakers and readers).

To encourage the demography change and developing diversity of the IETF it is important to reduce meetings in America to balance in all the world regions and then hope to open the subject of two languages again to see the results.

AB

Russ

Bonjour Russ

AB

Russ

Bonjour,

Comments below

AB

Thanks

If

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 09 Mar 2014 20:46:17 +0100

On 03/09/2014 07:46 PM, Abdussalam Baryun wrote:
> Bonjour Russ,
>
> I am sorry, and I did not mean any insult, most of IETF meeting are 
> not in Europe but most IETF meetings are in America.

If someone wants respect for their opinions, the first order of business 
is that they get their facts straight.

 From IETF 80 to IETF 89 (10 meetings), IETF 80, 82, 83, 87 and 89 were 
outside America.
 From IETF 70 to IETF 79 (10 meetings), IETF 72, 75, 76, 78 and 79 were 
outside America.

Unless some time period before 2007 is the subject of discussion, the 
word "most" has no basis.

        Harald, a non-native-English speaker

---

From: John C Klensin <[email-masked]>
Date: Sun, 09 Mar 2014 16:25:11 -0400

--On Sunday, 09 March, 2014 14:07 -0400 Ted Lemon
<[email-masked]> wrote:

> (BTW, there's a certain irony in the use of "Chinese" to refer
> to a single language, of which I am well aware, but the
> commonality to the writing system is really what I consider
> most important.)

Because of that irony, switching to "Chinese" might help us
eliminate the need for decision-making in f2f meetings and move
things back to the mailing lists.  Of course, so would anything
else that doesn't involve very high quality,
technically-sensitive, parallel translation.  Some people who
have experienced attempts at the latter claim it is impossible
- a recent piece about translation of literature in the NY Times
is helpful in understanding the problem but, especially for
literature, while language translates more or less well, culture
rarely translates at all.   Sometimes technical literature works
better, but, because the precision requirements are often
higher, sometimes not.

   john

---

From: Gordon Lennox <[email-masked]>
Date: Sun, 9 Mar 2014 21:27:25 +0100

On 9 Mar, 2014, at 19:46, Abdussalam Baryun <[email-masked]> wrote:

> ... and then hope to open the subject of two languages again to see the results. 

There is a quote that seems to be associated with multiple people and so I guess there is more than a grain of common truth in it:

"The single biggest problem in communication is the illusion that it has taken place."

or

"The biggest problem with communication is the illusion that it has occurred."

Anyway those who know me know that I have spent a significant part of my career in multi-lingual environments and a large part of my life living in a country, Belgium, that has its own language problem.  I have spent a lot of time working with translators and interpreters, preparing documents for translation and speaking through interpreters, reading translated documents and listening through interpreters. So way too much personal experience.

Language is only a part of the communication problem and not even the most important part. It is much more about a desire and willingness to communicate. It is more about the ability to communicate.

If people just want to communicate then there are options. Here I am thinking more of native speakers. Think of the wider audience. Keep your language simple and correct - maybe especially when the idea is difficult. International English is not quite the same as the English spoken in London or New York, for example, and never will be. 

So RFC 7154 and all that.

However if people really think it is important and really want to go down the formal language route then there is always the ITU.

Gordon

PS If we do need to choose two languages then, because I spent a long time in Belgium and despite Belgium having three official languages, I propose Dutch and French. ;-),

---

From: Jelte Jansen <[email-masked]>
Date: Sun, 9 Mar 2014 20:54:15 +0000

On 03/09/2014 08:27 PM, Gordon Lennox wrote:
> 
> PS If we do need to choose two languages then, because I spent a long
> time in Belgium and despite Belgium having three official languages, I
> propose Dutch and French. ;-),

Oooh. Dutch please!

My first knee-jerk reaction to a required IELTS score (I had never heard
of this, by the way) was "Sure. As long as english-only participants are
required to be fluent in a second language, just to know how hard it can
be'.

Having had the privilege of growing up in a country where foreign
languages are taught very early, I like to think I do pretty well
myself, even if I have to search for words now an then. But now that I
think about it, I *am* bothered sometimes by contributions that are hard
to parse. Bad use of language is one part of that. Bad articulation is
another. Superhuman speed ('the ekr') is a third.

In the latter two cases, a simple request can improve things a lot. The
first one is a bit harder, but I also don't think that committing to
multiple languages helps in the matter. It's a lot of overhead and I
don't think it scales very well.

However, perhaps there is something we can do; I'm not sure what form it
should take, but one thing could be for people to help each other out
with their english, e.g. some service where one can make requests 'I'm
having a hard time explaining this in english, and I do better in Dutch,
is there someone that can help me out?', or vice versa 'I am fluent in
Spanish and English and I can help someone who is struggling a bit'.
This could be for documents, or as support in presentations/discussions.

These are things that sometimes occur naturally as a wg is working on a
draft, but perhaps it might be possible to lend the process a hand.

Jelte

---

From: Juliao Braga <[email-masked]>
Date: Sun, 09 Mar 2014 18:27:34 -0300

Yes, good solution. With the Ombusdpersons, the IETF can create a group
of volunteers who act as mentors for non-native English (particularly)
when they make a mistake that eventually bother some participants or
demonstrate the need for a follow up for some time.

[]s, Julião

---

From: Scott Brim <[email-masked]>
Date: Sun, 9 Mar 2014 17:56:13 -0400

> demonstrate the need for a follow up for some time.

The ombudsperson is for harassment problems, not for mentoring.

Some Working Groups already have informal assistance available for
non-English speakers. Talk to your WG chairs.

Occasionally we discuss formalizing this kind of help IETF-wide.  However,
since the main goal is better communication in technical activity, I
believe it is best to keep it organized at the level of an Area. If you are
interested in better organizing help in writing or editing drafts or email,
you could ask your ADs about it.

By the way, many native English speakers need help with their writing as
well.

---

From: Gordon Lennox <[email-masked]>
Date: Sun, 9 Mar 2014 23:03:23 +0100

> Oooh. Dutch please!

I remember folk in EFTA - http://www.efta.int/about-efta/the-efta-states - saying that having English as their only working language was good because nobody had it as their first language.

Gordon

---

From: Arturo Servin <[email-masked]>
Date: Sun, 9 Mar 2014 15:17:26 -0700

> non-English speakers. Talk to your WG chairs.

In one draft with only non-native speakers where I participate we got a
very nice review as part of this assistance (well, I guess, the reviewer is
an English major and a grammarian.) It would help the draft to be more
understandable and us, as non-native will learn a bit more how to write
better. A win-win in my point of view and a plausible way forward to
improve drafts in the IETF.

/as

---

From: Michael Richardson <[email-masked]>
Date: Sun, 09 Mar 2014 19:34:13 -0400

> another. Superhuman speed ('the ekr') is a third.

The EKR problem is not speed, but rather buffer overrun followed by
repeated re-transmissions using some kind multipath tcp.

I find mumbling/lack of articulation among all speakers (both foreign and
native) to be a bigger challenge to understanding.

While I do computer work regularly in french and with francophones,
I've discovered that few native quebecois know what a clavier is.
"le keyboard" is what is used regularly.  Aside from a few nice phrases whose
nuance is lost ("j'ai d'autra chats a fouetter"), there is little to gain
From being multilingual, and much to lose.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting for hire =-

---

From: Andrew Sullivan <[email-masked]>
Date: Sun, 9 Mar 2014 22:12:47 -0400

On Sun, Mar 09, 2014 at 04:37:56PM +0000, Abdussalam Baryun wrote:
> I recommend allowing another second official

Why stop at two?  I think we should simply dispense with the idea that
we need an official language.  That way, we can talk past each other
without any undue effort on anyone's part.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Narelle <[email-masked]>
Date: Mon, 10 Mar 2014 13:28:14 +1100

On Mon, Mar 10, 2014 at 5:05 AM, Ted Lemon <[email-masked]> wrote:
> I don't think the discussion is practical.   If we are all going to learn a new language, why
> not Chinese?   French is actually very easy for people who speak Indo-European
> languages, but no easier for Chinese or Japanese speakers.

English has become the lingua franca of modern business. Until that
changes, the only thing that will be introduced by introducing a
variety of languages is cost and litigation/time. Look at the ITU,
look at multilingual jusrisdictions eg Quebec and Belgium. A great
example is the NZ/Aotearoa Waitangi Treaty between the Maori and the
English. Discrepancies in translation keep them in the courts, as gee
it turns out the Maori didn't agree to as much as the English thought
they did.

imho the only suitable new language to introduce would be symbolic
logic. That would be the only truly useful form for ietf work.
Otherwise, all that would be introduced by introducing other natural
languages is an even greater diversity of interpretation, rather than
an increase in the diversity of input. It is better to support those
from diverse backgrounds in contributing to the discussion in the
first place.

regards

-- 

Narelle Clark
[email-masked]

---

From: Kathleen Moriarty <[email-masked]>
Date: Sun, 9 Mar 2014 22:57:50 -0400

As an FYI to those that have not had the pleasure of an ITU-T meeting (2 stories under the ground for 2 weeks), only the plenary has translators, study group meetings are held in English.  Documents are only translated after final publication.  

It is common for SDOs to hold their meetings in English.

Best regards,
Kathleen 

Sent from my iPhone

> On Mar 9, 2014, at 3:34 PM, "Stewart Bryant (stbryant)" <[email-masked]> wrote:
> 
> On 9 Mar 2014, at 18:46, "Abdussalam Baryun" <[email-masked]> wrote:
> 
>> Bonjour Russ,
>>

---

From: Chaitanya Dhareshwar <[email-masked]>
Date: Mon, 10 Mar 2014 09:11:16 +0530

Good point A, in fact the internet being representative of an infinitely
vast variety of languages the Internet Engineering Task Force should
reflect this flexibility. While English can remain the primary language for
documentation the IETF itself should be language agnostic.

Best,

*Chaitanya Dhareshwar*

Linkedin <http://in.linkedin.com/in/chaitanyabd> | Blog <http://cbd.vcio.in> |
Skype: chaitanyabd
Mobile: +91.9820760253

---

From: joel jaeggli <[email-masked]>
Date: Sun, 09 Mar 2014 22:22:13 -0700

> demonstrate the need for a follow up for some time.

IMHO the ombudman or persons fulling that role serve a different need.

There is a fairly recently minted thread between IESG members, the edu
team and the RFC editor aimed at mentoring and peer activity around
draft language review. This has a fairly narrow aspirations, e.g. from
the IESG vantage point, more readable drafts get better review ,earlier.
Effort around producing better drafts is not unique to authors whose
primary language is not english.

---

From: "Russ White" <[email-masked]>
Date: Mon, 10 Mar 2014 01:38:24 -0400

> >> If we are all going to learn a new language, why not Chinese?

I would suggest Koine Greek. It's a very precise language, and almost no-one
already knows it, so we'd all be on an equal footing (except for a few stray
old theology majors here and there -- it would, at least, make Sue and I
happy).  (if you can't tell, this is a joke)

I think what's going on in LACNIC is a prime example of what we should do --
cultivate  groups of people by giving them a strong forum that intentionally
crosses the language barrier. Perhaps, by participating in a more local
forum, they will gain the confidence needed to stand at the mic or present
or write a draft without feeling foolish (lots of people with really good
English skills feel like they don't have good English skills). It helps to
stand in a smaller forum and talk at the mic in a more mixed group of
people, just to get used to actually being there and doing it.

Another thing we could do is to help folks who have a real desire to improve
their English skills, especially on the writing side. There are an awful lot
of native English speakers in our community who could use the help, as well,
so maybe having some process where a draft writer could ask for a volunteer
to help specifically with grammar and style issues before publishing would
be helpful -- an open list where folks could ask for help, be paired with an
"editor," and then go off list to do the actual work. 

Anyway, just a couple of possible ideas.

:-)

Russ

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 10 Mar 2014 06:04:30 +0000

I read in an article, that if someone shall learn ONE new language, it's JavaScript...

Regards,

Christer

Sent from my Sony Ericsson Xperia arc S

:-)

Russ

---

From: <[email-masked]>
Date: Mon, 10 Mar 2014 07:13:11 +0000

> I read in an article, that if someone shall learn ONE new language, it's JavaScript...

and then all networking code can be written using http://socket.io/  now there are sockets for Javascript!

riiiiight.

Lloyd Wood
http://about.me/lloydwood

---

From: <[email-masked]>
Date: Mon, 10 Mar 2014 07:17:08 +0000

When living in France, I first thought the word for computer was 'putain',
because that's what everyone yelled whenever a problem occurred.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of Michael Richardson [[email-masked]]
Sent: 09 March 2014 23:34
To: IETF Mailing List
Subject: Re: Two official work languages is smarter (was Re: IETF working language

---

From: Dick Franks <[email-masked]>
Date: Sun, 9 Mar 2014 19:20:32 +0000

The USW website lists you as a research student.

The resolution of this long-settled topic can be found in the public
archive of IETF mailing lists.  Any competent researcher should be able to
find it.

________________________

On 9 March 2014 18:46, Abdussalam Baryun <[email-masked]> wrote:

>> > and must to ask him self , what happen in the case if native language
>> is the official language IETF is not English
>>

---

From: <[email-masked]>
Date: Mon, 10 Mar 2014 10:18:41 +0000

> IETF SHOULD become smarter and it SHOULD be able to write and read in French.

And yet, it should also be more inclusive, and support diversity. 

Have you considered how those goals are at odds?

Je ne sais pas vraiment comment beaucoup plus de ce que je peux prendre.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of Abdussalam Baryun [[email-masked]]
Sent: 09 March 2014 16:37
To: Ted Lemon
Cc: IETF
Subject: Two official work languages is smarter (was Re: IETF working language

Bonjour,

Comments below

AB

Thanks

AB

---

From: Ted Lemon <[email-masked]>
Date: Mon, 10 Mar 2014 06:47:45 -0400

> Je ne sais pas vraiment comment beaucoup plus de ce que je peux prendre.

Quel est le son d'une seule main qui applaudit?

---

From: <[email-masked]>
Date: Mon, 10 Mar 2014 11:10:14 +0000

Pas le plus grand film australien.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: Ted Lemon [[email-masked]]
Sent: 10 March 2014 10:47
To: Wood L  Dr (Electronic Eng)
Cc: [email-masked]
Subject: Re: Two official work languages is smarter (was Re: IETF working language

---

From: Scott Brim <[email-masked]>
Date: Mon, 10 Mar 2014 07:13:38 -0400

The biggest burden of multiple official languages in the ITU imho is not
professional translation in meetings (although infrastructure needs would
severely limit where we could meet), it's the process for publishing
documents. Subject matter experts and translators need to ensure that all
translations say exactly what was agreed to, with the same nuances. You
think the RFC editor process takes time now?
On Mar 9, 2014 10:58 PM, "Kathleen Moriarty" <
[email-masked]> wrote:

> As an FYI to those that have not had the pleasure of an ITU-T meeting (2
> stories under the ground for 2 weeks), only the plenary has translators,
> study group meetings are held in English.  Documents are only translated
> after final publication.
>
>  I am sorry, and I did not mean any insult, most of IETF meeting are not
> in Europe but most IETF meetings are in America. Therefore, my reason was
> that the decisions and dimensions discussed are mostly American dimensions.
> I may be wrong, and I never say I am right. However, when I ask why IETF
> most meetings are in America, the reply is always : because the majority
>  To encourage the demography change and developing diversity of the IETF
> it is important to reduce meetings in America to balance in all the world
>>  IETF language is using English right but it is not the same way
>> Americans use it but it is the worlds use of English.
>>
>>
>>  I add to your interest. There were a great person I meat in IETF that
>> is volunteering translation to French language.
>>
>>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 10 Mar 2014 14:55:32 +0200

In practical terms. I walk into a room discussing (just picking a wg or bof
at random) "tunneling compressed multiplexed traffic".  Suppose I knew
anything about this and had some slides:
 - what language would those slides be in?
 - what language would the draft that the slides are talking about be in?
 - In what language am I talking about the draft or the slides?
 - The people running to the mike telling me that I, in fact, do not know
anything about this, what language do they speak?

If the answer to all these questions is English, what does this flexibility
mean?
If the answer is that there will be a whole bunch of languages, how are we
going to communicate?

English is not my native language, but I don't see an alternative. People
all over the world learn English as a second language. More so than any
other language. Unless you want to get us all speaking Esperanto or lojban,
English is the most practical.

Yoav

On Mon, Mar 10, 2014 at 5:41 AM, Chaitanya Dhareshwar <[email-masked]

> Linkedin <http://in.linkedin.com/in/chaitanyabd> | Blog<http://cbd.vcio.in> |
> Skype: chaitanyabd
> Mobile: +91.9820760253
>
>

---

From: "Klaas Wierenga (kwiereng)" <[email-masked]>
Date: Mon, 10 Mar 2014 13:04:08 +0000

On 10 Mar 2014, at 13:55, Yoav Nir <[email-masked]> wrote:

> In practical terms. I walk into a room discussing (just picking a wg or bof at random) "tunneling compressed multiplexed traffic".  Suppose I knew anything about this and had some slides:
>  - The people running to the mike telling me that I, in fact, do not know anything about this, what language do they speak?
> 
> If the answer to all these questions is English, what does this flexibility mean?
> If the answer is that there will be a whole bunch of languages, how are we going to communicate?
> 
> English is not my native language, but I don't see an alternative. People all over the world learn English as a second language. More so than any other language. Unless you want to get us all speaking Esperanto or lojban, English is the most practical.
> 

Yes, very much agree. English is and should be the language for the foreseeable future. I think Harald quoted the relevant parts of the RFC on this. 

Klaas

> Yoav
> 
> 
> 
> On Mon, Mar 10, 2014 at 5:41 AM, Chaitanya Dhareshwar <[email-masked]> wrote:
> Good point A, in fact the internet being representative of an infinitely vast variety of languages the Internet Engineering Task Force should reflect this flexibility. While English can remain the primary language for documentation the IETF itself should be language agnostic. 
> 
> Best,
> 
> Chaitanya Dhareshwar
> 
> Linkedin | Blog | Skype: chaitanyabd
> Mobile: +91.9820760253
> 
> 
> On Mon, Mar 10, 2014 at 7:42 AM, Andrew Sullivan <[email-masked]> wrote:

---

From: Riccardo Bernardini <[email-masked]>
Date: Mon, 10 Mar 2014 14:04:28 +0100

> English is the most practical.

+1.  English is not my native language neither, but I do not see any
other practical solutions (Esperanto jokes aside).

Riccardo

---

From: <[email-masked]>
Date: Mon, 10 Mar 2014 13:03:14 +0000

>  - The people running to the mike telling me that I, in fact, do not
> know anything about this, what language do they speak?

in my experience, Californian.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of Yoav Nir [[email-masked]]
Sent: 10 March 2014 12:55
To: Chaitanya Dhareshwar
Cc: IETF Discuss
Subject: Re: Stopping at two (was: Two official work languages is smarter)

Yoav

On Mon, Mar 10, 2014 at 5:41 AM, Chaitanya Dhareshwar <[email-masked]<mailto:[email-masked]>> wrote:
Good point A, in fact the internet being representative of an infinitely vast variety of languages the Internet Engineering Task Force should reflect this flexibility. While English can remain the primary language for documentation the IETF itself should be language agnostic.

Best,

Chaitanya Dhareshwar

Linkedin<http://in.linkedin.com/in/chaitanyabd> | Blog<http://cbd.vcio.in> | Skype: chaitanyabd
Mobile: +91.9820760253<tel:%2B91.9820760253>

On Mon, Mar 10, 2014 at 7:42 AM, Andrew Sullivan <[email-masked]<mailto:[email-masked]>> wrote:

Best regards,

A

--
Andrew Sullivan
[email-masked]<mailto:[email-masked]>

---

From: Juliao Braga <[email-masked]>
Date: Mon, 10 Mar 2014 10:26:51 -0300

+1

I think this question of English or no, in the IETF is an outdated issue.

On the other hand, if a non-native English writes or speaks something is
natural that some mistakes are made. The native English should have a
little patience. If we lack patience (or cooperation), and the question
is relevant to the IETF, I think the big loser is the IETF.

And, I repeat my last post correcting the possible confusion with the
Ombudsperson:

If the problems created by non-native English are so great as well (I
don't think it is), then recommend a solution : ... the IETF can create
a group of volunteers who act as mentors for non-native English (
particularly ) when they make a mistake that eventually bother some
participants or demonstrate the need for a follow up for some time. But,
it seems that this mechanism already exists, as has been said here in
the list .

Incidentally, I witnessed people IETF initiatives in this direction,
anonymously. This gave great results.

Em 10/03/2014 09:55, Yoav Nir escreveu:
> English is not my native language, but I don't see an alternative.
> People all over the world learn English as a second language. More so
> than any other language. Unless you want to get us all speaking
> Esperanto or lojban, English is the most practical.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 10 Mar 2014 09:29:53 -0400

> not think that anything new has been raised for use to reopen the

I don't think that is a helpful approach. Rather too often in IETF process
it turns out that there is never a time to raise an issue. It is either too
early or too late.

>From a practical point of view any proposal to use more than one language
would have to propose a mechanism for providing translation between them.
This would require the proposal to consider both the cost of providing the
translators and identifying a group of translators that is capable of
meeting IETF needs.

Leaving aside the cost issue, there simply isn't any group of interpreters
that is going to be able to provide simultaneous live translation of IETF
working group activities. I don't think any of us want to work from
prepared remarks submitted to the translators in advance.

I know that there are translators who can and do provide such services at
technical conferences, I worked with them when I helped kill COMDEX by
giving the keynote address at the last COMDEX in Brazil. But a keynote
address is a very different matter to a working group discussion on the
interpretation of the criticality bit in X.509.

-- 
Website: http://hallambaker.com/

---

From: Jari Arkko <[email-masked]>
Date: Mon, 10 Mar 2014 17:55:47 +0200

All:

We have had a previous discussion about the languages at the IETF. At this time I see no reason to re-open that discussion. As with any topic in a working group, at some point we make a decision and avoid re-discussing the same issues again.

(And this is obviously not a comment against various educational materials, tutorials, and helpful side discussions and the like, which often are available in several languages. Work on those is very much appreciated. If you have energy to work on those, please do! And such energy is probably better put on those efforts than continuing this or other similar threads. We do have, as Randy points out, also some Internet technology development to do.)

Jari

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 11 Mar 2014 21:55:45 +0100

Bonjour,

This subject line caught my eye as messages carrying it worked their way through my spam filters, so I thought I'd see how the discussion started. But I couldn't really find any logical starting point, it seems to have landed at ietf@ietf fully formed.

So what exactly are we arguing for and against...?

> PS If we do need to choose two languages then, because I spent a long time in Belgium and despite Belgium having three official languages, I propose Dutch and French. ;-),

Betekent dit dat ik naast Nederlands ook Frans moet leren, of is één van beide voldoende?

Evidente la sola vera internacia lingvo estas Esperanto.

Tschüss,

Iljitsch

---

From: Dave Cridland <[email-masked]>
Date: Tue, 11 Mar 2014 21:13:28 +0000

> Betekent dit dat ik naast Nederlands ook Frans moet leren, of is één van
Cisco a publié un module français gratuit, mais vous devez le télécharger
directement.

Dave.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 11 Mar 2014 22:28:30 +0100

> Cisco a publié un module français gratuit, mais vous devez le télécharger directement.

Mais je n'ai pas de contrat de service Cisco valide...  :-(

Iljitsch

---

From: Solarus <[email-masked]>
Date: Tue, 11 Mar 2014 22:33:17 +0100

> http://about.me/lloydwood
Je suis français et je me demande ce que donneraient des mails en
français à l'IETF. Ceux qui comprennent le français n'auront aucun
problème et ceux dont c'est la langue maternelle seront avantagés. Le
problème reste le même.
A mon avis , si vous devez choisir une deuxième langue choisir une
langue avec des locuteurs natifs n'est pas la bonne solution, nous
devons essayer l'esperanto ou le simple english.

I'm french and I'm wondering about mails in french at the IETF. People
who speaks french could understand and people which are native french
speaker will be advantaged.
In my opinion, if you have to choice a second language, chose a language
with no native speakers as esperanto or simple english.

Cordialement
Best Regards

Solarus

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 11 Mar 2014 17:57:34 -0400

Ha' Suq nongtaH Dogh van Segh yIjatlh reH.

godwin chut: reH qabna'Daj vay' Ha' tlhIngan yIlo'

---

From: Daniel Karrenberg <[email-masked]>
Date: Tue, 11 Mar 2014 23:41:56 +0100

valide sultan .....

----------
Sent from a hand held device.

> On 11.03.2014, at 22:28, Iljitsch van Beijnum <[email-masked]> wrote:
>

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 12 Mar 2014 01:12:50 +0100

Don't we already have two languages used in the IETF, and even for editing RFCs - English and American: https://www.rfc-editor.org/rfcfaq.html#british

;)

> On 11 mars 2014, at 22:33, Solarus <[email-masked]> wrote:
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Mar 2014 20:44:48 -0400

> valide sultan .....

Valar dohaeris.

---

From: Douglas Otis <[email-masked]>
Date: Tue, 11 Mar 2014 18:11:10 -0700

> Don't we already have two languages used in the IETF, and even for editing RFCs - English and American: https://www.rfc-editor.org/rfcfaq.html#british

Dear Thomas,

If we made better use of technology, we might use restful Asterick.org servers where each member is assigned their own extension to automatically convert language into text messaging, voice translations, and even video signing to fully support those handicapped by remote participation with different native languages. :^)

I have had a hard time understanding someone speaking with an East London accent.  I might even ask whether they could say it again in German.  At least it then becomes possible to look up a word being missed.  It also seems words tend to merge the nearer to the equator the speaker resides.  Even small distances seem perceptible.

Many of us would have an impossible time handling tonal languages simply because our ears are unable to hear the differences because our sound recognition settles in at about 3 months of age.  Of course, getting old also causes loss of higher frequencies which may make some female voices difficult to hear within a noisy background.  It seems technology could benefit everyone.

Regards,
Douglas Otis

Life is a dream, from which we must all awake.

---

From: John C Klensin <[email-masked]>
Date: Wed, 12 Mar 2014 09:37:13 -0400

--On Monday, March 10, 2014 07:13 -0400 Scott Brim
<[email-masked]> wrote:

> The biggest burden of multiple official languages in the ITU
> imho is not professional translation in meetings (although
> infrastructure needs would severely limit where we could
> meet), it's the process for publishing documents. Subject
> matter experts and translators need to ensure that all
> translations say exactly what was agreed to, with the same
> nuances. You think the RFC editor process takes time now?

Exactly.
Same problem in most ISO TCs.  There, for particularly sensitive
standards, it is common for the relevant bodies to waive
translation altogether, publishing only in English.  That has
been caused, at least in part, by its often taking months, and
sometimes years, to agree on authoritative translations that
have exactly the same meaning and interpretations in all of the
translations.

   john

---

From: Loa Andersson <[email-masked]>
Date: Wed, 12 Mar 2014 15:00:06 +0100

Folks,

> have exactly the same meaning and interpretations in all of the

Agree with John, can we close this now and agree that ONE official
work language is smarter thean TWO?

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 19 Mar 2014 17:33:34 -0400

> From: Juliao Braga <[email-masked]>

> demonstrate the need for a follow up for some time.

This sounds like a genuinely useful proposal.

Currently, I suspect most non-native-speakers are in practice mentored
by other people from the same organization.  This would work in
practice, but it only solves the problem for people from organizations
large enough to send multiple people to the IETF.

Dale

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 19 Mar 2014 19:18:01 -0400

> From: Harald Alvestrand <[email-masked]>
> 

The data is more malleable than it first appears.  When I read AB's
first message, I tallied that over the last 5 years (15 meetings), the
IETF met in North America 6 times out of 15, which is exactly the 2/5
ratio that (IIRC) we are trying to achieve.  But when I looked at my
list again, I saw that within the last 2 years, 4 out of 6 meetings
were in North America, which is well over our desired ratio.  And as
Harald notes, over the last 10 meetings, the ratio is 5 out of 10.

So the appearances depend on precisely what time horizon one is
looking at, which will depend greatly on when one started
participating.

There is an additional complexity that the IETF does not have a free
hand choosing meeting sites; it is much easier to choose a site that
is near companies that are willing to sponsor (subsidize) a meeting.

Dale