Subject: Some Comments for Tutorial slides presented in IETF 89

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 5 Mar 2014 06:51:40 +0100

Dear Scott Bradner,

Thanks for your training, and I enjoyed it even though I listen to it
before two years remotely in other previous meetings. You were very
inspiring us and encouraging us to participate, thanks. I asked you in the
end some questions and I got the answers but I thought it will be nice if I
give my comments and review on this list to possibly help the future
attendees.

Review date: 05.03.2014.
Document Presentation date: 02.03.2014.
Document: Bradner, 2014, IETF Structure and Internet Standards Process,
IETF 89, London.
Reviewed by Abdussalam.

Summary: The presentation is a tutorial base and it may be said it is a new
comer orientation, however, the reviewer believes that it is training to
help new participant to engage and join. The review is based on that the
document is for training new participants in IETF activities. The number of
slide (S) or pages of the document is 60 slides/pages, it maybe long for 2
hour tutorial, however, it is considering many important issues of IETF and
also considers active participants understandings. There are few
difficulties for new comer to understand, but below comment points try to
improve.

The title: IETF structure and Internet Standards Process.

AB1- I recommend the title to be amended to: What is IETF,
objectives, structure, processes and policies.  For simplicity and to guide
audience to important main points.

AB2- the tutorial did not mention the IETF vision, but yes it mentioned the
purposes. The vision is very important to any new customer or new
participant. Many old participant in IETF may still forget the main vision
of IETF.

AB3- Slide 6, IETF purpose. I suggest to add the words (Internet
Community). So one of most important activity is that IETF serves that
community.

AB4- Slides 4, 10 and 37, are confusing. In S4 it says IETF has no members,
but in S10 it says IESG members and other body members, also in S37 shows
that IESG is part of IETF. That may mean that IETF has members, so we
cannot say as in S4 that IETF has no members.

AB5- the slides consider how the IETF WG is created but not how IETF areas
are created. I don't think it is right that IESG should only be responsible
for creating IETF areas. The community should have voice in creating or
changing IETF areas.

I hope in future that each 5 years we get a message from IESG saying
IETF areas structure proposal (renew same, or restructure). That can be
done in one meeting may be better than the list.

AB5- Slide 5, shows f2f (i.e. face to face) attendance of participants
which increased between 1996 to 2002, in average above 2000. That is a 8
year duration with many meetings per year (totally about 24 f2f event) with
numbers of about 2000 attendees and then decreased after 2002 becoming in
average above 1000 and less than 1500 attendees. IMHO, the community had
not continued to attend because of possible difficulties or high
probability of waste time, with slow production, also the diversity problem
that still IETF needs to fix.

AB6- recommend that slides 35 and 36 to be in the start slides. The role
and scope of IETF is the first important issue to think of by new comers
and how to compare IETF to ITU. So think it is better flow of tutorial to
make both 35 and 36 beside slide 6 (i.e.  IETF purpose).

AB7- in the tutorial on Sunday there was not enough time in the
end organised for new comers to ask questions only about 10 minutes.
Usually in tutorials the aim and objectives are two way communication, and
more Q&A interaction. I hope that IETF future meeting tutorials consider
timing of tutorial to achieve better objectives and more new
comer understanding.

Overall, it was a great tutorial and I think all enjoyed it, but this
message is just to add above feedback for future better understanding. I
may be wrong in some points, but could not keep it for myself, just wanted
to share my thoughts, and like to see others comment.

Best Regards
Abdussalam Baryun

---

From: <[email-masked]>
Date: Wed, 5 Mar 2014 06:11:25 +0000

> AB5- Slide 5, shows f2f (i.e. face to face) attendance of participants which increased between 1996 to 2002, in average above 2000.
> That is a 8 year duration with many meetings per year (totally about 24 f2f event) with numbers of about 2000 attendees and then
> decreased after 2002 becoming in average above 1000 and less than 1500 attendees. IMHO, the community had not continued to attend
> because of possible difficulties or high probability of waste time, with slow production, also the diversity problem that still IETF needs to fix. 

3 meetings per year. 8 years. Yes, about 24 meetings.

The pre-Y2K upgrade/replacement  tech frenzy that halted as everyone locked down for Y2K, combined with
the Internet bubble bursting as the economy slowed, had nothing to do with the community not having budget to attend meetings, then?

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of Abdussalam Baryun [[email-masked]]
Sent: 05 March 2014 05:51
To: [email-masked]
Cc: ietf
Subject: Some Comments for Tutorial slides presented in IETF 89

Dear Scott Bradner,

Thanks for your training, and I enjoyed it even though I listen to it before two years remotely in other previous meetings. You were very inspiring us and encouraging us to participate, thanks. I asked you in the end some questions and I got the answers but I thought it will be nice if I give my comments and review on this list to possibly help the future attendees.

Review date: 05.03.2014.
Document Presentation date: 02.03.2014.
Document: Bradner, 2014, IETF Structure and Internet Standards Process, IETF 89, London.
Reviewed by Abdussalam.

Summary: The presentation is a tutorial base and it may be said it is a new comer orientation, however, the reviewer believes that it is training to help new participant to engage and join. The review is based on that the document is for training new participants in IETF activities. The number of slide (S) or pages of the document is 60 slides/pages, it maybe long for 2 hour tutorial, however, it is considering many important issues of IETF and also considers active participants understandings. There are few difficulties for new comer to understand, but below comment points try to improve.

AB1- I recommend the title to be amended to: What is IETF, objectives, structure, processes and policies.  For simplicity and to guide audience to important main points.

AB2- the tutorial did not mention the IETF vision, but yes it mentioned the purposes. The vision is very important to any new customer or new participant. Many old participant in IETF may still forget the main vision of IETF.

AB3- Slide 6, IETF purpose. I suggest to add the words (Internet Community). So one of most important activity is that IETF serves that community.

AB4- Slides 4, 10 and 37, are confusing. In S4 it says IETF has no members, but in S10 it says IESG members and other body members, also in S37 shows that IESG is part of IETF. That may mean that IETF has members, so we cannot say as in S4 that IETF has no members.

AB5- the slides consider how the IETF WG is created but not how IETF areas are created. I don't think it is right that IESG should only be responsible for creating IETF areas. The community should have voice in creating or changing IETF areas.

I hope in future that each 5 years we get a message from IESG saying IETF areas structure proposal (renew same, or restructure). That can be done in one meeting may be better than the list.

AB5- Slide 5, shows f2f (i.e. face to face) attendance of participants which increased between 1996 to 2002, in average above 2000. That is a 8 year duration with many meetings per year (totally about 24 f2f event) with numbers of about 2000 attendees and then decreased after 2002 becoming in average above 1000 and less than 1500 attendees. IMHO, the community had not continued to attend because of possible difficulties or high probability of waste time, with slow production, also the diversity problem that still IETF needs to fix.

AB6- recommend that slides 35 and 36 to be in the start slides. The role and scope of IETF is the first important issue to think of by new comers and how to compare IETF to ITU. So think it is better flow of tutorial to make both 35 and 36 beside slide 6 (i.e.  IETF purpose).

AB7- in the tutorial on Sunday there was not enough time in the end organised for new comers to ask questions only about 10 minutes. Usually in tutorials the aim and objectives are two way communication, and more Q&A interaction. I hope that IETF future meeting tutorials consider timing of tutorial to achieve better objectives and more new comer understanding.

Overall, it was a great tutorial and I think all enjoyed it, but this message is just to add above feedback for future better understanding. I may be wrong in some points, but could not keep it for myself, just wanted to share my thoughts, and like to see others comment.

Best Regards
Abdussalam Baryun

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 5 Mar 2014 07:54:04 +0000

> for creating IETF areas. The community should have voice in creating or
The community has (or at least is supposed to have) a voice in any such
change.  As I understand it, there are actually very few things the IESG is
allowed to do without consulting participants.

> done in one meeting may be better than the list.

I don't think setting a specific interval when such changes are allowed to
be introduced or affirmed is useful.

> that still IETF needs to fix.

I have to agree with Lloyd; I don't think those are the causes.

-MSK

---

From: Barry Leiba <[email-masked]>
Date: Wed, 5 Mar 2014 10:01:14 +0000

> that IESG is part of IETF. That may mean that IETF has members, so we cannot
> say as in S4 that IETF has no members.

There's no conflict here, and your last sentence doesn't follow from the rest.

The IETF has "participants", not members.  You are a participant,
simply because you participate.  You didn't have to do anything to
become a member -- you don't have to pay anything, you don't have to
work for a member company, and so on.

The IETF has a set of administrative bodies that manage its process.
Those bodies have members, appointed from the set of IETF participants
through a defined process.

The IETF has no members.  The administrative bodies do.

Barry

---

From: James Polk <[email-masked]>
Date: Wed, 05 Mar 2014 04:17:01 -0600

At 01:54 AM 3/5/2014, Murray S. Kucherawy wrote:
>On Wed, Mar 5, 2014 at 5:51 AM, Abdussalam Baryun 
><<mailto:[email-masked]>[email-masked]> wrote:
>
>AB5- the slides consider how the IETF WG is created but not how IETF 
>areas are created. I don't think it is right that IESG should only 
>be responsible for creating IETF areas.

then who should be responsible?

>The community should have voice in creating or changing IETF areas.

it does, but not to a person. There is a structure based IMO on 
manageability and sanity.

>The community has (or at least is supposed to have) a voice in any 
>such change.  As I understand it, there are actually very few things 
>the IESG is allowed to do without consulting participants.

+1

>IETF areas structure proposal (renew same, or restructure). That can 
>be done in one meeting may be better than the list.
>
>
>I don't think setting a specific interval when such changes are 
>allowed to be introduced or affirmed is useful.

a 5 year interval is an entirely arbitrary number. You put any 10 
active participants in a room and ask just this 1 question and you'll 
probably get 15 answers, with none being the same, i.e., good luck 
with that... !

>AB5- Slide 5, shows f2f (i.e. face to face) attendance of 
>participants which increased between 1996 to 2002, in average above 
>2000. That is a 8 year duration with many meetings per year (totally 
>about 24 f2f event) with numbers of about 2000 attendees and then 
>decreased after 2002 becoming in average above 1000 and less than 
>1500 attendees. IMHO, the community had not continued to attend 
>because of possible difficulties or high probability of waste time, 
>with slow production, also the diversity problem that still IETF needs to fix.
>
>

this is how a single slide with a few numbers can be taken COMPLETELY 
out of context and force a particular curious person into reverse 
engineering reasons for a meaning for those numbers based on one 
persons preconceived baggage (i.e., personal history)'

sorry for the rant... in short, I generally agree with Lloyd, 
although give my more time and/or more slide room, and I could easily 
expand the list of reasons, none being what you offered Abdussalam.

James

---

From: Jari Arkko <[email-masked]>
Date: Wed, 5 Mar 2014 14:20:48 +0000

Regarding the 5-year review of the area structure - I believe the IESG makes the decision of how it organises the areas, number of ADs, and so on - obviously any bigger change would be extensively discussed with the community as well. We did that when RAI was added, for instance.

Although I don't think we'd wait for the next 5-year review if an issue came up. We'd try to deal with it there and then.

And just for the record, we do continuously discuss potential changes and the need for them. We have been discussing whether there are potential structural changes to the IESG that would help attract more future candidates, lower AD workload, for instance. (But that has been a difficult answer to find. So far one of the conclusions seems to be that adding more ADs will not help that problem.)

Jari

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 05 Mar 2014 10:17:07 -0600

> And just for the record, we do continuously discuss potential changes and the need for them. We have been discussing whether there are potential structural changes to the IESG that would help attra…

What Jari said.

On timing - most adjustments to the area structure in recent years 
happened when the IESG can include the changes in structure in the AD 
job descriptions that the IESG sends to NOMCOM.

For instance, when the User Services Area was collapsed to a single 
working group, the IESG said NOMCOM didn't have to provide an AD.

Last year, those instructions went to NOMCOM at the end of July. I'd 
expect the timing this year to be similar, although I'm not responsible 
for anything except the specific description of the TSV AD position, in 
concert with my co-AD, so don't know for sure.

Spencer

---

From: Måns Nilsson <[email-masked]>
Date: Thu, 6 Mar 2014 00:59:33 +0100

> that still IETF needs to fix.

dot.com.bubble.burst

That is quite enough as explanation. The 49th in San Diego still is the
largest one in terms of participants. And it was quite crazy because of
its sheer size. And, of course, the glögg. BTDTGTTS.

I think it is a safe bet to couple participant numbers to the amount
of big spender VC being thrown over the industry, and that in turn is
related to the general state of economy in the world. Possibly out of
scope for the IETF to fix.
-- 
Måns Nilsson     primary/secondary/besserwisser/machina
MN-1334-RIPE                             +46 705 989668
Tex SEX!  The HOME of WHEELS!  The dripping of COFFEE!!  Take me to
Minnesota but don't EMBARRASS me!!