Subject: RE: Overlays and encapsulations (was Re: Engineering discussions )

From: Russ White <[email-masked]>
Date: Mon, 10 Mar 2014 09:26:01 -0700

Sorry for the top post.

I suspect part if it is human nature; we like completely specified solutions, rather than referential ones.

It often seems like all these tunnel types serve individually useful purposes, but that we've also simply failed to reuse much if anything, making implementation more difficult. Its seems, to me, that could live with a few generic tunnel types, rather than a thousand specialized ones, but the cat already seems to be out if the bag (?).

:-)

Russ

-----Original Message-----
From: "Alia Atlas" <[email-masked]>
Sent: ‎3/‎9/‎2014 3:14 PM
To: "Eric Gray" <[email-masked]>
Cc: "'IETF' ([email-masked])" <[email-masked]>
Subject: Re: Overlays and encapsulations (was Re: Engineering discussions )

Eric,

On Sun, Mar 9, 2014 at 6:02 PM, Eric Gray <[email-masked]> wrote:

Alia,
 
                I assume that this is a change of subject in part to demonstrate that we
can in fact have a technical discussion on this list.  J
 
                But the question is a reasonable example whether that is the case or not.

It's something that struck me as being interesting to discuss and having general appeal and
benefiting from the perspective of many areas.  :-) 
 
                IMO, two of the biggest drivers for this work in the IETF are location and 
identity separation, and converged networking.
 
                Just as examples, the work being looked into in NVo3 is one example of 
one aspect of the first case (where end-user or server application locations are
being separated from specific network entry points or physical servers accessible 
using IP addresses, for example) and both PWE3 and L2VPN are two currently 
active examples of the second case (where – for instance – Ethernet traffic is to
be carried over an IP network).

Yes, I agree that identity separation is a driver.   I'm not as persuaded that converged 
networking is driving new overlays and encapsulations - just b/c pseudo-wires have been
around for about 10 years.  
 
                I think the problems these examples are solving are self-evident.  That
may not be true for other cases.

I'm, of course, more interested in whether there are common drivers and whether all the
solutions need to be point solutions or are more generalizable.

Alia

--
Eric
 
From: ietf [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Sunday, March 09, 2014 5:34 PM
To: heasley
Cc: Dave Crocker; IETF Disgust
Subject: Overlays and encapsulations (was Re: Engineering discussions )
 
In the last few years, there seems to be a drive towards overlays and additional
packet encapsulations.  What problems do you see these as solving?  Is there a
more focused way to consider the drivers and downsides?
 
Thoughts?
 
Alia
 
On Sun, Mar 9, 2014 at 5:29 PM, heasley <[email-masked]> wrote:
Sun, Mar 09, 2014 at 11:10:27AM +0000, Dave Crocker:
> The phrasing of your suggestion presumes that you are currently
> prevented from having those discussions.  But of course you aren't.

I believe the point is to separate general technical discussion from the
general everything else discussion, such as the draft-how-not-to-be-a-
wanker discussion, so that those here just for the technical aspects of
IETF need not wade through it.  Which I support.

---

From: Randy Bush <[email-masked]>
Date: Mon, 10 Mar 2014 17:42:37 +0100

> It often seems like all these tunnel types serve individually useful
> purposes, but that we've also simply failed to reuse much if anything,
> making implementation more difficult. Its seems, to me, that could
> live with a few generic tunnel types, rather than a thousand
> specialized ones, but the cat already seems to be out if the bag (?).

we used to repeat a mantra along the lines of reliable ip transport
reinvention only shows that tcp (this year's version, of course <g>) is
sufficient and a good compromise among the many constraints.

that philosophy never took hold in the encaps space.  a tecnoloogy for
every need.  how much was real need and how much career/market building
is left to the judgement of the observer.

randy