Subject: Re: Guiding the Evolution of the IANA Protocol Parameter Registries

From: Geoff Huston <[email-masked]>
Date: Thu, 13 Mar 2014 06:51:31 +1100

Hi,

In reading this was was interested to understand what changed from the presentation at the ietf (http://www.ietf.org/proceedings/89/slides/slides-89-igovupdate-0.pdf) and what stayed (more or less) the same? So what follows below is my take on the edits following the IETF session in order to understand how the feedback from the meeting was incorporated into this announcement.

Principle 6 is almost there, but I still find myself voicing a note of dissent - in so far as it avoids mentioning copyright or any similar term relating to intellectual property but instead states their availability and the ability to include registry contents into other works without permission.

My concern rests in observations related to previous handovers of this function in past times. Relating this to today, in my understanding were the IAB to exercise its ability under RFC6220 and re-designate a protocol parameter registry operator it is logically necessary for the previous registry operator to cooperate and synchronise the movement of registry to the new operator. It's hard to set this out this obligation as a principle, but any observer of the first few months of operation of Network Solutions taking over the registry role from the  previous operator back then in the early 90's would've been painfully aware of a certain hiatus in service. 

Now all this could be finessed (in my view) by a stronger statement in principle 6 about the intellectual property of the contents of the protocol parameter registries, and the principle that while the registry operator is given license to modify these registries in line with the directions from the IETF, the contents of these (modified) registries remains the intellectual property of the IETF and not the property of the registry operator. 

But I have the sense that assertions of copyright and intellectual property appear to be concepts that are too "strong" for this enumeration of principles. Why is this?

Kind regards,

  Geoff

> 
> Principles Guiding the Evolution of the IANA Protocol Parameter Registries
> 
> These principles must be taken together.  Ordering is not significant.
> 
> 1.  The IETF protocol parameter registry function has been and continues
> to be capably provided by the Internet technical community.
> 
> The strength and stability of the function and its foundation within the
> Internet technical community are both important given how critical
> protocol parameters are to the proper functioning of IETF protocols.
> 
> We think the structures that sustain the protocol parameter registry
> function needs be strong enough that they can be offered independently by
> the Internet technical community, without the need for backing from
> external parties.  And we believe we largely are there already, although
> the system can be strengthened further, and continuous improvements are
> being made.
> 

unchanged

removed:
The administration of the protocol parameters function by ICANN is working well for the Internet and the IETF.

We are pleased with the publication and maintenance of the protocol parameter function and the coordination of the evaluation of registration requests through the IANA function provided by ICANN.

> 2. The protocol parameter registry function requires openness,
> transparency, and accountability.
> 
> Existing documentation of how the function is administered and overseen
> is good [RFC2860,RFC6220].  Further articulation and clarity may be
> beneficial.  It is important that the whole Internet community can
> understand how the function works, and that the processes for registering
> parameters and holding those who oversee the protocol parameter function
> accountable for following those processes are understood by all
> interested parties.  We are committed to making improvements here if
> necessary.

unchanged

> 
> 3. Any contemplated changes to the protocol parameter registry function
> should respect existing Internet community agreements.

(was: ... should use the current RFCs and model as the starting point.)

> 
> The protocol parameter registry is working well.  The existing Memorandum
> of Understanding [RFC2860] defines "the technical work to be carried out
> by the Internet Assigned Numbers Authority on behalf of the Internet
> Engineering Task Force and the Internet Research Task Force."  Any
> modifications to the protocol parameter registry function should be made
> using the IETF process to update RFC 6220 and other relevant RFCs.  Put
> quite simply: evolution, not revolution.
> 

more or less the same

> 4. The Internet architecture requires and receives capable service by 
> Internet registries.
> 
> The stability of the Internet depends on capable provision of not just
> IETF protocol parameters, but IP numbers, domain names, and other
> registries.  Furthermore, DNS and IPv4/IPv6 are IETF-defined protocols.
> Thus we expect the role of the IETF in standards development, architectural
> guidance, and allocation of certain name/number parameters to continue.
> IP multicast addresses and special-use DNS names are two examples where
> close coordination is needed.  The IETF will continue to coordinate with
> ICANN, the RIRs, and other parties that are mutually invested in the
> continued smooth operation of the Internet registries. We fully
> understand the need to work together.
> 

unchanged

> 5. The IETF will continue management of the protocol parameter registry
> function as an integral component of the IETF standards process and the
> use of resulting protocols.

change "its direction and stewardship" to "management"

> 
> RFC 6220 specifies the role and function of the protocol parameters
> registry, which is critical to IETF standards processes and IETF
> protocols.  The IAB, on behalf of the IETF, has the responsibility to
> define and manage the relationship with the protocol registry operator
> role.  This responsibility includes the selection and management of the
> protocol parameter registry operator, as well as management of the
> parameter registration process and the guidelines for parameter
> allocation.
> 

this is altered wording

(used to read: "RFC 6220 specifies the role and function of the protocol
parameters registry, which is critical to IETF standards processes
and IETF protocols. We see no need to revisit or reconsider our
current approach with regard to protocol parameters, including the
ability to delegate operational responsibility for registries to other
organizations."_

> 6. The protocol parameters registries are provided as a public service.
> 
> Directions for the creation of protocol parameter registries and the
> policies for subsequent additions and updates are specified in RFCs.
> The protocol parameters registries are available to everyone, and they
> are published in a form that allows their contents to be included in
> other works without further permission.  These works include, but are
> not limited to, implementations of Internet protocols and their
> associated documentation.
> 

unchanged

> An important observation: The administration of the protocol parameter
> registry functions by ICANN is working well for the Internet and the
> IETF.  We are pleased with the publication and maintenance of the
> protocol parameter registries and the coordination of the evaluation of
> registration requests through the IANA function provided by ICANN.
> 

this was the second principle

> [RFC2860] http://www.rfc-editor.org/rfc/rfc2860.txt
> [RFC6220]  http://www.rfc-editor.org/rfc/rfc6220.txt
> [IAB1] http://www.iab.org/wp-content/IAB-uploads/2011/03/2009-06-08-IAB-NTIA-NOI-final.pdf
> [IAB2] http://www.iab.org/wp-content/IAB-uploads/2011/07/IANA-IAB-FNOI-2011.pdf
>

---

From: Steve Crocker <[email-masked]>
Date: Wed, 12 Mar 2014 16:07:31 -0400

Geoff, et al,

I made a statement in the igovupdate session and I’ll reiterate here in the spirit of using the list as the definitive record and not the face to face session.

ICANN has NO intellectual property interests in the material it publishes.  My understanding of copyright law is that copyright attaches to the creator of content, irrespective of whether they register that copyright.  (There is utility in registering copyrights  I am not enough of expert to expound on those details, nor do I think they’re relevant to this discussion.)

During the discussion in the igovupdate session I heard brief mention of possible issues regarding various RFCs and registries over the years.  These pertained to various government agencies and others, but did not involve ICANN.

If the community desires a formal document saying what I’ve said above, I will personally shepherd it through our system.

Let me address two other points, one that is mentioned below and one that is entirely separate.

I believe the scenario of moving the protocol parameter registries to another operator has already been explored.  I am given to understand that the IETF has conducted exercises that mirror these registries.  I am not familiar with the details.  The IAOC is probably the best group to say more about this.  In any case, I don’t think would be problematic and as a matter of good business practice we will cooperate with any reasonable exercise or demonstration to provide that assurance.

Something that occurred to me during the discussion which I have not seen mentioned before is the following.  All of us follow the principle that the information created by the IETF is available to anyone, anywhere, without cost.  What would happen if the IETF changes its position and requires IANA to either restrict its distribution of information and/or charge for it?  I think we’d have to think carefully about that.  Would the IETF be willing to assert as part of its principles that it won’t do such a thing?

Thanks,

Steve Crocker
Chair, ICANN Board of Directors

---

From: Geoff Huston <[email-masked]>
Date: Thu, 13 Mar 2014 07:50:28 +1100

Hi Steve,

Firstly I should reiterate that this is not about ICANN. I agree wholeheartedly with the "important observation" in Russ's posting, and I am very heartened to read your undertaking relating to ICANN having no intellectual property interests in the material it publishes in this role as protocol parameter registry operator. For me, it was very welcome as a statement at the meeting, and equally welcome as a statement here, and, while I can only speak personally, I would like to sincerely extend my thanks for making this undertaking.

My posting was not about the specific, but about the principle. I believe it to be incumbent on the IETF to clearly state the principle, namely that the operator of a protocol parameter registry is doing so at the specific behest of the IETF, and as an agent of the IETF. All intellectual property rights in the content of the registries remains that of the IETF, and does not vest with the registry operator. This is desire that I believe is entirely consistent with your undertaking that ICANN as a protocol parameter registry operator makes no such claim, however I suppose I am wanting this to be a principle that applies generally.

As to folk changing their mind in the future, its true that the future is a constant source of surprise to us, and statements that include terms such as "never" or "forever" are constantly being mocked by the unfolding of time. But I don't think we need to cross every bridge here - we can at best set forth our values and principles on the day and hope that our successors at least consider what we were trying to achieve and why we thought it to be important as they make their changes to suit their world. These principles appear to be an earnest effort in that direction.

kind regards,

   Geoff

---

From: Steve Crocker <[email-masked]>
Date: Wed, 12 Mar 2014 16:56:08 -0400

Geoff,

Thanks.  No argument.  It was interesting to me as I was speaking during the session and asserting that we have no claim to the intellectual property that we (ICANN) might find ourselves having quite strong feelings if we were told we had to implement restrictive policies.  It’s not a scenario that, to my knowledge, has ever come up before, but I think it fits into your general framework of espousing principles.

Steve

On Mar 12, 2014, at 4:50 PM, Geoff Huston <[email-masked]> wrote:

> _______________________________________________
> Internetgovtech mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/internetgovtech

---

From: Eliot Lear <[email-masked]>
Date: Wed, 12 Mar 2014 22:13:51 +0100

Geoff,

Thanks for your comments.  so that we understand what we are talking
about, here is the principle in question:

> The protocol parameters registries are provided as a public service.
>

Your specific complaint is that we mention neither copyright or
trademark.  To me those two legal points are implementation of the above
principle.  We should do what is necessary to see that the parameters
are published so that all are free to use them.  Whether that implies
copyrights, trademarks, contracts, or what have you is for the lawyers
to sort.  What I like is that Steve is carrying forward in his words and
actions this idea that anyone can access this stuff, a point that he
worked with others to establish in the RFC series.  That's leadership!

Eliot

---

From: Jari Arkko <[email-masked]>
Date: Wed, 12 Mar 2014 23:44:30 +0200

> principle. 

This is how I read it as well.

Jari

---

From: <[email-masked]>
Date: Wed, 12 Mar 2014 21:59:47 +0000

> All intellectual property rights in the content of the registries remains that of the IETF,

Since IETF is an ISOC activity, and ISOC is the organisation that will be involved in intellectual property disputes (see RFC2031) isn't that really ISOC ownership?

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of Geoff Huston [[email-masked]]
Sent: 12 March 2014 20:50
To: Steve Crocker
Cc: [email-masked]; [email-masked] Mailing List
Subject: Re: Guiding the Evolution of the IANA Protocol Parameter Registries

Hi Steve,

kind regards,

   Geoff

---

From: Geoff Huston <[email-masked]>
Date: Thu, 13 Mar 2014 16:23:56 +1100

Weaving the web of wording around various RFCs and the distinctions between the IASA, the IAOC and the IETF, I have absolutely no idea whether a) the IETF itself is an ISOC activity per se and b) issues about the intellectual property rights associated with the protocol parameter registry contents vest with any of the preceding bodies. But I thought we were talking principles, and the principle I was espousing was that all intellectual property rights in the content of the protocol parameters registries remains with the IETF, and does not vest with the registry operator. I guess I'm treading on the toes of an historic US position that in the past appeared to be that the intellectual property rights of the IANA protocol parameter registries that were operated under the terms of contracts with variously ARPA, DARPA and the NSF vested with the USG in some fashion, and its a question that we appear to want to avoid as there has never been any statements from the NTIA that expressly disclaim this, and noone appears to want to press the point.

I personally am in favour of a stronger statement of principle from the IETF in this area, but I'm just one voice, and I sense from the posts for Jari and Eliot that they are unwilling to head further in this direction - fair enough.

regards,

  Geoff

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 13 Mar 2014 06:40:48 +0100

> I personally am in favour of a stronger statement of principle from the IETF in this area, but I'm just one voice, and I sense from the posts for Jari and Eliot that they are unwilling to head furt…

FWIW, I support Geoff here, given the history we have seen not only in
direct IETF history but also in other Internet related registries (for
example various TLD-registries).

That said, I at the same time agree with Jari and Eliot that the over
all goal is in the principles. That finding a solution "is implementation".

So, I just would like to have a stronger statement so this is not forgotten.

The copyright for a parameter and its assigments should stay with
whatever organization "owns" that parameter. Not belong to whoever acts
as the care taker of the registry.

That ICANN also say they do not have any interest as the operator in IPR
for the registry is good, but if the registry operator changes, IPR
issues I absolutely would like to see in the agreement(s).

I am because of that of course sort of happy with what Jari and Eliot
stated. This can be found in the principles.

Just do not forget about it...

   Patrik

---

From: Eliot Lear <[email-masked]>
Date: Thu, 13 Mar 2014 07:34:42 +0100

Pindar,

On 3/13/14, 6:47 AM, Pindar Wong wrote:
> fwiw also be mindful of
>
> http://en.wikipedia.org/wiki/Sui_generis_database_right
>
> p.
>
>

Indeed.  But I do think there is probably an additional word or two we
can say about seeing that any intellectual property that exists in the
parameters stays with the IETF, for the purpose of making it available
to all.

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 13 Mar 2014 22:01:23 +1300

> parameters stays with the IETF, for the purpose of making it available

For everything assigned since the IETF/IANA MoU was ratified in
March 2000, we could certainly make that assertion, and presumably
vest the IPR in the IETF Trust. For assignments prior to March
2000, I think things are less clear. IANAL.

   Brian

---

From: Jefsey <[email-masked]>
Date: Thu, 13 Mar 2014 01:54:59 +0100

At 21:50 12/03/2014, Geoff Huston wrote:
>But I don't think we need to cross every bridge here - we can at 
>best set forth our values and principles on the day and hope that 
>our successors at least consider what we were trying to achieve and 
>why we thought it to be important as they make their changes to suit 
>their world. These principles appear to be an earnest effort in that direction.

Geoff,
as such I am afraid they do not belong to the internet. RFC 1958 
defines the principles of the Internet architecture. The first of 
these principles is the principle of constant change: "The principle 
of constant change is perhaps the only principle of the Internet that 
should survive indefinitely".

It seems that this principle invalidates your entire claim as what 
you want to protect (IETF protocols) is based on the idea that they 
are published to be continously adapted. This puts them outside of 
any copyright (as something being used, supported, parametered, etc.) 
but fully subject to initial author rights?
jfc

---

From: Pindar Wong <[email-masked]>
Date: Thu, 13 Mar 2014 13:47:35 +0800

fwiw also be mindful of

p.

On Thu, Mar 13, 2014 at 1:40 PM, Patrik Fältström <[email-masked]> wrote:

> > I personally am in favour of a stronger statement of principle from the
> IETF in this area, but I'm just one voice, and I sense from the posts for
> Jari and Eliot that they are unwilling to head further in this direction -
> fair enough.
>

---

From: Pindar Wong <[email-masked]>
Date: Thu, 13 Mar 2014 07:16:29 +0800

see

http://trustee.ietf.org/docs/IETF-Copyright-FAQ.pdf

p.

On Thu, Mar 13, 2014 at 5:59 AM, <[email-masked]> wrote:

> Since IETF is an ISOC activity, and ISOC is the organisation that will be
> involved in intellectual property disputes (see RFC2031) isn't that really
> ISOC ownership?
>
> Lloyd Wood
> Firstly I should reiterate that this is not about ICANN. I agree
> wholeheartedly with the "important observation" in Russ's posting, and I am
> very heartened to read your undertaking relating to ICANN having no
> intellectual property interests in the material it publishes in this role
> as protocol parameter registry operator. For me, it was very welcome as a
> statement at the meeting, and equally welcome as a statement here, and,
> while I can only speak personally, I would like to sincerely extend my
> thanks for making this undertaking.
>
> My posting was not about the specific, but about the principle. I believe
> it to be incumbent on the IETF to clearly state the principle, namely that
> the operator of a protocol parameter registry is doing so at the specific
> behest of the IETF, and as an agent of the IETF. All intellectual property
> rights in the content of the registries remains that of the IETF, and does
> not vest with the registry operator. This is desire that I believe is
> entirely consistent with your undertaking that ICANN as a protocol
> parameter registry operator makes no such claim, however I suppose I am
> wanting this to be a principle that applies generally.
>
> As to folk changing their mind in the future, its true that the future is
> a constant source of surprise to us, and statements that include terms such
> as "never" or "forever" are constantly being mocked by the unfolding of
> time. But I don't think we need to cross every bridge here - we can at best
> set forth our values and principles on the day and hope that our successors
> at least consider what we were trying to achieve and why we thought it to
> be important as they make their changes to suit their world. These
> principles appear to be an earnest effort in that direction.
>
> kind regards,
>
>    Geoff
>
>
> > I made a statement in the igovupdate session and I'll reiterate here in
> the spirit of using the list as the definitive record and not the face to
> face session.
> >
> > ICANN has NO intellectual property interests in the material it
> publishes.  My understanding of copyright law is that copyright attaches to
> the creator of content, irrespective of whether they register that
> copyright.  (There is utility in registering copyrights  I am not enough of
> expert to expound on those details, nor do I think they're relevant to this
> discussion.)
> >
> > During the discussion in the igovupdate session I heard brief mention of
> possible issues regarding various RFCs and registries over the years.
>  These pertained to various government agencies and others, but did not
> involve ICANN.
> >
> > If the community desires a formal document saying what I've said above,
> I will personally shepherd it through our system.
> >
> > I believe the scenario of moving the protocol parameter registries to
> another operator has already been explored.  I am given to understand that
> the IETF has conducted exercises that mirror these registries.  I am not
> familiar with the details.  The IAOC is probably the best group to say more
> about this.  In any case, I don't think would be problematic and as a
> matter of good business practice we will cooperate with any reasonable
> exercise or demonstration to provide that assurance.
> >
> > Something that occurred to me during the discussion which I have not
> seen mentioned before is the following.  All of us follow the principle
> that the information created by the IETF is available to anyone, anywhere,
> without cost.  What would happen if the IETF changes its position and
> requires IANA to either restrict its distribution of information and/or
> charge for it?  I think we'd have to think carefully about that.  Would the
> IETF be willing to assert as part of its principles that it won't do such a
> thing?
> >
> > Thanks,
> >
> > Steve Crocker

---

From: Pindar Wong <[email-masked]>
Date: Thu, 13 Mar 2014 14:49:07 +0800

On Thu, Mar 13, 2014 at 2:34 PM, Eliot Lear <[email-masked]> wrote:

> Indeed.  But I do think there is probably an additional word or two we can
> say about seeing that any intellectual property that exists in the
> parameters stays with the IETF, for the purpose of making it available to
> all.
>

Agreed. I merely raise this to support both Geoff and Patrik's point that
perhaps extra clarity at the level of principle might be especially helpful
in this  inherently muddy area that comprises the territorially demarcated
Intellectual Property  space.

In turns out that after some 7 years of operational experience with the
then Creative Commons licence suite --  that 'Sui generis database rights'
were particularly unhelpful (when you're actually trying to legally licence
your rights away) and one of the principle drivers behind the development
of the Creative Commons (4.0) Licence suite.  The gory details fwiw are
here:-

http://wiki.creativecommons.org/4.0/Sui_generis_database_rights

p.

---

From: Michael StJohns <[email-masked]>
Date: Fri, 14 Mar 2014 16:49:08 -0400

At 01:23 AM 3/13/2014, Geoff Huston wrote:
>. But I thought we were talking principles, and the principle I was espousing was that all intellectual property rights in the content of the protocol parameters registries remains with the IETF, and does not vest with the registry operator. I guess I'm treading on the toes of an historic US position that in the past appeared to be that the intellectual property rights of the IANA protocol parameter registries that were operated under the terms of contracts with variously ARPA, DARPA and the NSF vested with the USG in some fashion, and its a question that we appear to want to avoid as there has never been any statements from the NTIA that expressly disclaim this, and noone appears to want to press the point.

There's this legal concept of a "quitclaim" that might be useful here.  It can be used by anyone, especially in cases where there may be an appearance of (legal) interest, but where the actual facts aren't firmly established.

Webster has it as:

>
>quit·claim
>
>
>
>transitive verb \ kwit- kl m\
>:  to release or relinquish a legal claim to; especially :  to release a claim to or convey by a quitclaim deed 
> quitclaim noun 

Maybe the right answer is to simply ask for quitclaims from the US Gov't, and from ICANN, (and others?) with respect to any and all IPR, copyright claims, etc they may hold, if any,  in the protocol parameters registry to be resolved or transferred to or for the benefit of the IETF trust.  At least then we'd know rather than continuing to dance around it.  The quid pro quo might be a quitclaim from us for similar interests in the DNS and IP registries.

Mike