Subject: ICANN NomCom and ICANN Leadership Positions

From: Russ Mundy <[email-masked]>
Date: Wed, 5 Mar 2014 20:16:34 +0000

For those at the IETF-89 Administrative Plenary,  Jari mentioned that the IETF has a delegate on the ICANN NomCom (I happen to be filling that this year).  In this role, I wanted to let folks know that this is the primary time for people to express interest in volunteering to serve in various ICANN leadership positions.  I have participated in IETF and ICANN for a number of years, I have seen how important it is to have people with both competitance and interest in working toward improving the Internet in leadership in both IETF and ICANN - now is the time of year for folks to think about doing this in the ICANN realm.

I could go into a batch of details of about the ICANN organizations or positions that are being selected by the ICANN NomCom but it's probably best for folks to look at the web page for the details.  That web page is:

https://www.icann.org/en/groups/nomcom/2014

If anyone is interested in helping make the Internet better by serving in ICANN, please look at the above web site or catch up with me in the halls at IETF-89 (I'll probably be the only one wearing a green ICANN cap for the rest of the week at the meeting :-) or send me email (or all the above). 

Russ Mundy
IAB/IETF Delegate to ICANN NomCom

---

From: Russ Mundy <[email-masked]>
Date: Sun, 23 Mar 2014 15:31:29 -0400

As the IAB/IETF rep to the ICANN NomCom this year, I wanted to let folks know that ICANN's 49th Public Meeting is underway so, if you'd like to know more about the ICANN meetings, this would be a good time follow the activities remotely or in person.  The meeting website is at:

http://singapore49.icann.org/

and most meetings support remote participation.

For folks that may have become more interested in ICANN since the NTIA press release on 14 March announcing their tasking of ICANN with developing a proposal transition NTIA IANA related roles to another activity, the process begins at ICANN 49 - remember, remote participation is encouraged.

Also, for those that are considering how they can improve the Internet and ICANN, this is a great time to consider applying for an ICANN leadership position through the NomCom. The website for this information is at:

If anyone has questions or would like further details, please drop me email at mundyATtislabs.com or send your questions to [email-masked]

Russ Mundy

Begin forwarded message:

> From: Russ Mundy <[email-masked]>
> Subject: ICANN NomCom and ICANN Leadership Positions
> Date: March 5, 2014 3:16:34 PM EST
> To: [email-masked]
> Cc: Russ Mundy <[email-masked]>
> 
> 
>