Subject: Re: Confidentiality (was - Re: Nomcom feedback to appointees not up for renewal)

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 1 Apr 2015 14:05:32 +0000

On 3/26/15, 6:08 PM, "Mary Barnes" <[email-masked]<mailto:[email-masked]>> wrote:
[MB] Because some of the information could inadvertently leak who provided …

IMHO this is another important part of the IETF maturing as an organization, much like the anti-harrassment code a few years ago. This is about leadership development and investing in our selected leaders (ADs in this case).

It always seemed strange to me the few times I was on NomCom that feedback could not be provided to candidates up for renewal. What it sets up is a situation where someone can be blissfully unaware they could/should be doing something different until such time as they are basically fired. That is obviously not the right thing for the person involved, can create a lot of negative feelings that will last for years, and it is extremely inefficient organizationally given the ramp-up / learning time for someone new.

I can certainly understand the confidentiality concerns Mary raises, primarily because the feedback the NomCom seeks is explicitly not intended to go beyond the NomCom. Were that to be the case, the nature of the feedback would likely change – possibly for the worse. What the IETF may need are some new tools to solve this problem, perhaps such as:

1 – After the NomCom appointments are announced, email any commenters (anyone that submitted feedback online or that the NomCom interviewed) asking if they wanted to submit any anonymous feedback to the selected or not-selected people. That could be aggregated by someone externally. Typically when a private company does this names may be removed and any vitriolic / non-constructive comments are dropped. And in cases of not-selected people there may be some really good stuff there too that could help them better prepare to be a fit next time around since it can identify areas for growth.

2 – Send out a mini-feedback form (aka "5 minute feedback") to the WG chairs and active I-D authors in an Area following each IETF meeting (and maybe other ADs/IAB). Have a small # of questions on a 5-point scale and some free-form ones asking stuff like “what could I have done better in my role?” and “what am I doing well that I should keep doing / do more of?”. These are good “bit-sized” bits of feedback for people.

3 – Annually, send out a longer 360-review kind of form to WG chairs/ADs/etc. that is a bit more in-depth.

4 – Discuss leadership development as a process and how to make best use of these kinds of tools above at the annual IESG retreat.

- Jason

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Apr 2015 07:55:03 +1300

On 02/04/2015 03:05, Livingood, Jason wrote:
...
> 3 – Annually, send out a longer 360-review kind of form to WG chairs/ADs/etc. that is a bit more in-depth.

When I first worked for IBM, they still operated a 360 review, where
everybody got to see anonymized comments from a few colleagues, the
boss, and underlings. I found it very helpful. Also, when writing
comments on others, you *know* that they will be passed on, so there
is a strong incentive to be polite and objective and to write in a style
that is not easily identifiable.

I never understood why IBM dropped the scheme, but I always suspected
that some of the senior bosses didn't appreciate knowing what underlings
really thought. That is of course the best reason for doing such reviews.

We're smart enough to make a 360 review process almost completely
automated and genuinely anonymous.

   Brian

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 01 Apr 2015 21:02:00 +0100

Hiya,

> automated and genuinely anonymous.

A bunch of iesg folk liked this idea so we've put it on the agenda
for our retreat in early May. We'll get back after that.

If folks have more specific suggestions then I guess send 'em here
to the general list, or to some IESG member if you prefer that.

S.