Subject: Possible 6LoWPAN dispatch type deprecation and re-use for route over purposes

From: Thierry LYS <[email-masked]>
Date: Tue, 28 Apr 2015 11:07:44 +0200

Dear Michael, Ines, Samita, Gabriel, Pascal, Thomas,

We recently discovered that there are ongoing discussions to re-use the 
6LoWPAN dispatch type assigned by IANA for Mesh-Under routing (as 
specified in RFC 4944) for Route-Over purposes.

As one of the biggest 6LoWPAN network operators (35 million smart meters 
to be deployed in France - first deployments have started) and considering 
other massive roll-outs on progress in Asia with the G3-PLC technology 
(using the 6LoWPAN/IPv6 mechanisms), we are deeply concerned by the 
deprecation of this dispatch type with respect to the sustainablility of 
the IPv6 framework considering potential long-term evolutions in our IP 
telco architecture. We would like to draw your attention to the fact that 
the lifespan of smart meters (minimum of 20 years - garanteed by the 
manufacturer), and more generally smart grid connected devices, are not to 
be compared with the much shorter lifespans of consumer electronics. 

We strongly disagree with making any modifications endangering backwards 
compatibility with already deployed 6LoWPAN/IPv6 systems and hope that 
IETF will discourage this as well. 
We suggest that one of the alternate solutions, already proposed by the 
interested parties, should be prefered (as the overhead generated is 
comparable).

Thank you very much for your consideration,

Best regards,

Thierry Lys, Cédric Chauvenet and Cédric Lavenu

>We're also sending this email to [email-masked] as it doesn't immediately 
appear clear where to discuss this, as there are many possible WGs that 
might be relevant, but also that this concerns deprecation of IANA 
allocations which have been made through IETF consensus, making this list 
possibly relevant.
> G3-PLC protocol is also known as Recommendation ITU-T G.9903 (available 
for download on ITU web site)

 Thierry Lys
 Metering Division
 Building Crysalis - 345 Avenue Georges Clémenceau - 92000 Nanterre - 
France
 Tel : +33 (0)1 81 97 67 77

---

From: Ralph Droms <[email-masked]>
Date: Wed, 29 Apr 2015 16:13:01 -0400

Thank you for calling the attention of the IETF to the use of the 6LoWPAN mesh-under dispatch code in G3-PLC.

The formal method for providing information like this to the IETF is through a Liaison Statement from the relevant standards organization (perhaps G3-PLC Alliance in this case?) submitted at http://datatracker.ietf.org/liaison/add/?incoming

It would be helpful to include explicit reference(s) to text in specifications that define the use of the 6LoWPAN dispatch header (https://www.iana.org/assignments/_6lowpan-parameters/_6lowpan-parameters.xhtml).

- Ralph Droms
  Member, IAB

> On Apr 28, 2015, at 5:07 AM, Thierry LYS <[email-masked]> wrote:
> 
> We recently discovered that there are ongoing discussions to re-use the 6LoWPAN dispatch type assigned by IANA for Mesh-Under routing (as specified in RFC 4944) for Route-Over purposes. 
> 
> As one of the biggest 6LoWPAN network operators (35 million smart meters to be deployed in France - first deployments have started) and considering other massive roll-outs on progress in Asia with the G3-PLC technology (using the 6LoWPAN/IPv6 mechanisms), we are deeply concerned by the deprecation of this dispatch type with respect to the sustainablility of the IPv6 framework considering potential long-term evolutions in our IP telco architecture. We would like to draw your attention to the fact that the lifespan of smart meters (minimum of 20 years - garanteed by the manufacturer), and more generally smart grid connected devices, are not to be compared with the much shorter lifespans of consumer electronics. 
> 
> We strongly disagree with making any modifications endangering backwards compatibility with already deployed 6LoWPAN/IPv6 systems and hope that IETF will discourage this as well. 
> We suggest that one of the alternate solutions, already proposed by the interested parties, should be prefered (as the overhead generated is comparable). 
> 
> 
> >We're also sending this email to [email-masked] as it doesn't immediately appear clear where to discuss this, as there are many possible WGs that might be relevant, but also that this concerns deprecation of IANA allocations which have been made through IETF consensus, making this list possibly relevant. 
> > G3-PLC protocol is also known as Recommendation ITU-T G.9903 (available for download on ITU web site)
>  	 Thierry Lys
> Metering Division
> Building Crysalis - 345 Avenue Georges Clémenceau - 92000 Nanterre - France

---

From: Ralph Droms <[email-masked]>
Date: Wed, 29 Apr 2015 17:37:46 -0400

Thierry - to be clear, your input is important to the IETF and will be considered in any future work on the IETF 6LoWPAN specifications.  Thank you for that valuable input.

It would be very helpful to the IETF to receive  input in a Liaison Statement in addition to the input in your e-mail.

- Ralph

---

From: Michael Richardson <[email-masked]>
Date: Thu, 30 Apr 2015 15:21:25 -0400

Thierry LYS <[email-masked]> wrote:
    > We recently discovered that there are ongoing discussions to re-use
    > the 6LoWPAN dispatch type assigned by IANA for Mesh-Under routing (as

    > As one of the biggest 6LoWPAN network operators (35 million smart
    > meters to be deployed in France - first deployments have started) and
    > considering other massive roll-outs on progress in Asia with the
    > G3-PLC technology (using the 6LoWPAN/IPv6 mechanisms), we are deeply

I tried to google for G3-PLC, got to:
    www.g3-plc.com which redirected me to:  http://107.170.210.217/
which is clearly a very much non-IPv6 compatible address for an entity that
is supposed to be deploying millions of IPv6 devices... this really does not
inspire confidence in me...

I knew what PLC was, but not how G3-PLC differs... can you clarify that it is
in fact a mesh-under technology?  What is the mesh protocol, and where is it
defined?

Can you clarify if G3-PLS is in fact using both mesh-under and route-over
technologies at the same time?

The proposed changes do not deprecate anything; they really just make
mesh-under and route-over unable to operate in the same PANID.

Having said that, I am not in favour with doing even that, but I want to make
sure that people clearly understand how minimal the impact.

As Ralph said, *PLEASE* respond via a Liason statement as that we can get
this into the right records.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-