Subject: Gen-ART review of draft-ietf-v6ops-cidr-prefix-01

From: "Black, David" <[email-masked]>
Date: Mon, 20 Apr 2015 23:54:43 +0000

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-v6ops-cidr-prefix-01
Reviewer: David Black
Review Date: April 20, 2015
IETF LC End Date: April 20, 2015

Summary: This draft is basically ready for publication, but has nits that
	should be fixed before publication.

This is a short crisp draft on behavior of CIDR prefixes in IPv6 forwarding
with respect to the /64 boundary in IPv6 addresses.  It's clear, well explained
easy to understand, plus refreshingly short.  Nicely done!

Major issues: (none)

Minor issues: (none)

Nits/editorial comments: Ok, I found a nit ... and so did idnits ;-).

-- Abstract

   Hardware and software
   algorithms should therefore impose no rules on prefix length, but
   implement longest-match-first on prefixes of any valid length.

"algorithms" isn't the right word.
I suggest "implementations of routing and forwarding"

idnits pointed out that: A later version (-06) exists of
     draft-ietf-opsec-v6-05

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: <[email-masked]>
Date: Tue, 21 Apr 2015 05:28:53 +0000

Hi David,

Thank you for the review. 

A new version is available online:

http://tools.ietf.org/html/draft-ietf-v6ops-cidr-prefix-02 

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-cidr-prefix-02 

Cheers,
Med

> -----Message d'origine-----
> De : Black, David [mailto:[email-masked]]
> Envoyé : mardi 21 avril 2015 01:55
> À : BOUCADAIR Mohamed IMT/OLN; [email-masked]; [email-masked];
> General Area Review Team ([email-masked])
> Cc : [email-masked]; [email-masked]; Black, David
> Objet : Gen-ART review of draft-ietf-v6ops-cidr-prefix-01
>