Subject: Non-Terminal Room (was: [93all] IETF 93 Network Information – Prague, Czech Republic)

From: Stefan Winter <[email-masked]>
Date: Sat, 18 Jul 2015 22:38:31 +0200

Hello,

> Please note that this terminal room has no terminals[...]

In the interest of sanity, and in a continuing quest to kill all
oxymorons, we should really not call it a terminal room then.

As an hommage to John Backus, the "Non-Terminal Room" comes to mind.

Greetings,

Stefan Winter

> , PCs, or other user-accessible machines. It is simply a place to get power, wired Internet access, help desk support, or print documents.
>
> When using the Ethernet connections in the Terminal Room, IPv4 addressing is provided via DHCP. Please use Dynamic Auto-configuration for IPv6. A stateless DHCPv6 server or RDNSS will provide network information. To cut down on the mess, ethernet cables have not been installed to every seat in the Terminal Room. If you need a cable, please ask at the Help Desk.
>
> Please note that at the request of the IETF Chair, demonstrations are no longer permitted in the Terminal Room.
>
> === Help Desk ===
> A help desk is being provided and will be staffed the following hours:
>
> || Sunday       || 16:00 to 19:00 ||
> || Monday       ||  8:00 to 20:00 ||
> || Tuesday      ||  8:00 to 18:00 ||
> || Wednesday ||  8:00 to 20:00 ||
> || Thursday     ||  8:00 to 20:00 ||
> || Friday          ||  8:00 to 15:00 ||
>
> == NOC and Ticketing ==
>
> There are several ways to communicate with the NOC staff.
> * Submit a new trouble ticket via the http://tickets.meeting.ietf.org/newticket interface. Filling in the following fields: "My MAC Address", "My Current Location", and "My OS" may expedite ticket processing. If you have an existing account on http://tools.ietf.org you can use your established credentials (email address and tools password) to log in at http://tickets.meeting.ietf.org/login .
> * Send an email to [email-masked] with as much detail regarding your issue and configuration as possible.
> * If you're on site and need direct network assistance (i.e - you have no network) please go to the helpdesk, which is located in the Terminal Room.
> * Use the Jabber room at noc @ jabber.ietf.org to report issues or communicate with the NOC.
>
> You can also use trac to review outstanding tickets before reporting an issue or to update outstanding tickets.
>
> === External Connectivity ===
>
> The IETF 93 network connects to the Internet via a 10Gb/s link provided by CZ.NIC and a 1Gb/s link from Dial Telecom. The IETF uses 31.133.128.0/18, 31.130.224.0/20 and 130.129.0.0/16 for IPv4 and 2001:67c:1230::/46, 2001:67c:370::/48 and 2001:df8::/32 for IPv6. We are supplying bandwidth for the conference space, as well as wireless and wired connections in the guest rooms.
>
> == Meeting Room Wireless ==
>
> An 802.11 a/g/n/ac wireless network is provided throughout the venue on both the 2.4 and 5 GHz bands, in conjunction with IPv4 and IPv6 addressing options.
>
> The main “ietf” wireless network is now encrypted; when prompted for credentials, enter ietf for both the username and password.
>
> Here’s a quick summary of the new network layout:
>
>
> || SSID             || Description                                                            || Encrypted || Frequencies  || IP Versions                     ||
> || ietf                || Our default network                                                || yes           || 5Ghz only      || v4 and v6                       ||
> || ietf-legacy     || For legacy and unencrypted use                           || no             || 2.4 and 5Ghz || v4 and v6                       ||
> || ietf-2.4ONLY || An encrypted network for 2.4Ghz users                || yes           || 2.4Ghz only    || v4 and v6                       ||
> || ietf-v6ONLY  || For users wanting a pure IPv6                               || yes           || 5Ghz only      || v6 only                            ||
> || ietf-nat64       || IPv6 stack with NAT64 to access IPv4 resources || yes           || 5Ghz only      || v6 with NAT64 & DNS64 ||
> || eduroam       || educational users                                                   || yes           || 2.4 and 5Ghz || v4 and v6                        ||
>
> All networks marked as encrypted will offer layer 2 security. This is done using WPA enterprise with 802.1X (PEAP or TTLS) authentication and AES or TKIP encryption. As usual, we are all using the same credentials (user “ietf”, password “ietf”), yet each user will get unique session encryption keys. Our Radius authentication servers use a certificate that you can verify by going to this page: https://www.ietf.org/registration/MeetingWiki/wiki/92net
>
> See the following archived email from Chris Elliot for an in-depth explanation of the changes made to the wireless configuration. http://www.ietf.org/mail-archive/web/92all/current/msg00009.html
>
> Note: Some users are having problems using Intel Centrino cards and the IETF network. Please see https://tickets.meeting.ietf.org/wiki/CentrinoIssue
>
> == Guest Room Access ==
>
> The IETF Network is being extended to the guest rooms in the Hilton. *Note* that while we are using the IETF meeting network for Internet connectivity, we are using the hotel's infrastructure (Ruckus access points) for the delivery to the guest rooms, so there are limits to the improvements we can effect.  We recommend using the wired connection if you experience poor connectivity in your guest room.
>
> Wired:
> 	IPv4 and IPv6 and provided via the wired connection in your room. Due to architectural limitations, inbound TCP connections from the Internet may not be available on the in-room wired connection.
>
> Wireless:
> 	In the guest room areas you should find the “ietf-hotel” SSID.  This network is 2.4GHz/5GHz and is being delivered via the Hilton's Ruckus access points. We encourage heavy users and/or those having poor coverage to use the wired connection.
>
> == Support ==
>
> If you have trouble using any of the Public or Guest Room services, please try to switch to the hotel SSIDs ("hhonors") or the hotel wired port.  If that doesn’t work, please contact the Hilton support as listed in your room. If things are working fine on the hotel offerings but not on the IETF SSIDs/ports, please do contact us in the Terminal Room (Amsterdam) or via tickets @ meeting.ietf.org  and we’ll be glad to help!
>
>
> == Printing ==
>
> There is a printer in the Terminal Room and is available to all IETF users. The printer is an HP Officejet Pro 8620 and is accessible via LPD, Bonjour, standard TCP/IP on port 9100.  The hostname for it is term-printer.meeting.ietf.org.
>
>
> || Name || Model || Capabilities || IPv4 Address|| IPv6 Address || Notes || Drivers ||
> ||term-printer.meeting.ietf.org || HP Officejet Pro 8620 || Inkjet w/Duplexer || 31.133.128.18 || 2001:67c:370:128:a65d:36ff:fe32:44ba || Bonjour name: // term-printer // || [http://support.hp.com/us-en/product/HP-Officejet-Pro-8620-e-All-in-One-Printer-series/5367611/drivers Printer Drivers] ||
>
> === Instructions for Mac OS X using Bonjour auto-setup (DNS-Based Service Discovery) ===
> (Note that this method is not available if you have configured an explicit DNS search list. Please see below for [https://tickets.meeting.ietf.org/wiki/IETF91network#InstructionsforMacOSXusingmanualconfiguration the manual configuration instructions].
> 1. Open System Preferences -> Print & Fax -> "+" below printer list
> 2. Choose "Default" in the top-menu.
> 3. You should see the printers discovered by Bonjour. Pick the right one.
> 4. Enjoy hassle-free printing.
>
> === Instructions for Mac OS X using manual configuration ===
> 1. Open System Preferences -> Print & Fax -> "+" below printer list
> 2. Select the "IP" icon at the top of window
> 3. Select the "HP Jetdirect - Socket" from the drop down
> 4. Enter "term-printer.meeting.ietf.org" in the Address field.  Leave the Queue field blank.
> 5. ''Print Using'' should autopopulate
> 6. Click Add
>
> === Instructions for Windows 7===
> 1. If you haven't printed on the selected printer before, you may need to download and install the driver using one of the links above.
> 2. When you come to the installer page asking you to choose the "Network Type" -- choose "Wired (Ethernet)."
> 3. If you get the "Unable to Find the Printer" page, simply enter the IP address of the printer {31.133.128.18} in the box in the bottom-right corner and click "Search."
> 4. Ignore the "The Printer and Computer are Connected to Different Routers" message and select "Next."
> 5. The driver will finish it's installation and you *should* see a "Successful Network Installation" message.
> 6. The fax feature is *NOT* enabled, so you may cancel the fax installation portion.
> 7. Registering the printer is not necessary.
> 8. You're printer is now ready to use, and you can find it by going to ''Start -> Devices and Printers''. No need to print a test page.
>
>
> === Instructions for Windows using HP printing framework ===
> 1. Download HP Universal Print Driver for Windows (see above)
> 2. Select "Dynamic installation" and wait until all drivers are copied (takes about 5-10 minutes)
> 3. Add printers by using their IP addresses in "control panel" appearing when select Start -> Settings -> Printers & faxes -> "HP Universal Printing PS" -> Properties
>
> === HP Eprint
> 1. Find the printer's email address on a label pasted to the printer.
> 2. Email the document to that address.
> 3. Retrieve your print out from the Terminal Room
>
> === Scanning Services ===
> 1. In a browser (Firefox appears to be the only browser that renders the pages properly) go to: http://term-printer.meeting.ietf.org/
> 2. Select the "Scan" tab located at the top of the page.
> 3. Select Document Type "PDF" in the drop-down menu
> 4. Place pages to be scanned face-up in the page feeder on top of the printer.
> 5. Press "Start Scan" on the web page.
> 6. Once the Scan has completed a window to the right will display the PDF contents of the scan.
> 7. Using the scroll bar in the Image Preview - Scroll to the right and select the "Download" button
>
>
> == Services ==
>
> The following network services are provided:
>
> || Service || Address                                                     || Notes                                                                                                    ||
> || SMTP   || smtp.meeting.ietf.org                                || Will provide SMTP relay for anything within the IETF network             ||
> || NTP      || ntp.meeting.ietf.org                                   || A stratum 2 time service is provided via IPv4 and IPv6 unicast           ||
> || DNS      || ns1.meeting.ietf.org ns2.meeting.ietf.org || Validating recursive resolvers. The domain name is meeting.ietf.org. ||
>
> These services are being provided from both of the following servers:
> 31.130.229.6 / [2001:67c:370:229::6]
> or
> 31.130.229.7 / [2001:67c:370:229::7]
>
> == Geolocation ==
> There is a geolocation feed published here: http://noc.ietf.org/geo/google.csv
> Geolocation service for temporary networks is often hit or miss. Suggestions/assistance is welcomed.
>
> == MAC Privacy @IETF93 ==
>
>
> After doing MAC Privacy trials at IETF91 in Honolulu and IETF92 in Dallas, we are transitioning to this being a standard service on the IETF network. It will operate on the all the IETF meeting networks, so no special SSID will be broadcast. Users participating in the service will be assigned a shorter DHCP lease. Note that this time there is also support for some mobile devices.
>
> Instructions and tools to automatically randomize the MAC address used by the Wi-Fi interface of your device can be found (for several OSes) at:
>
>  * https://oruga.it.uc3m.es/802-privacy/index.php/MAC_address_change_tutorial
>
> More information about the IEEE 802 Privacy group and instructions about how to join the discussion list can be found at the IEEE 802 Privacy SG site:
>
>  * http://www.ieee802.org/PrivRecsg/
>
> == Thanks ==
> The terminal room and IETF network are made possible by the generous contributions by a number of companies and by the tireless efforts of our volunteer team. If you see any of these people in the halls, please be sure to thank them for all their work!
>
>
> Contributors:
> * Juniper Networks
> * Cisco
>
> Connectivity:
> * CZ.NIC
> * Dial Telecom
>
> Volunteers:
> * Hirochika Asai (WIDE)
> * Joe Clarke (Cisco)
> * Chris Elliott
> * Bill Fenner (Arista)
> * Joel Jaeggli (Fastly)
> * Bill Jensen (University of Wisconsin –Madison)
> * Hans Kuhn (NSRC)
> * Warren Kumari (Google)
> * Lucy Lynch (NSRC)
> * Jim Martin (Internet Systems Consortium)
> * Ryo Nakamura (WIDE - in absentia)
> * Karen O'Donoghue (ISOC)
> * Clemens Schrimpe
> * Bjoern A. Zeeb
>
> Staff:
> * Aaron Nelson
> * James Dishongh
> * Colin Doyle
> * Nick Kukich
> * Edward !McNair
> * Con Reilly
>
>
> _______________________________________________
> 93all mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/93all

---

From: John C Klensin <[email-masked]>
Date: Sat, 18 Jul 2015 16:43:54 -0400

--On Saturday, 18 July, 2015 22:38 +0200 Stefan Winter
<[email-masked]> wrote:

> In the interest of sanity, and in a continuing quest to kill
> all oxymorons, we should really not call it a terminal room
> then.

Of course, perhaps it is the place you go to get terminated.  :-(

   john

---

From: Warren Kumari <[email-masked]>
Date: Sat, 18 Jul 2015 22:54:51 +0200

No, it is simply always the very last room in the line..
W

On Saturday, July 18, 2015, John C Klensin <[email-masked]> wrote:

> <[email-masked] <javascript:;>> wrote:
>
> > Hello,
> >

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Vinayak Hegde <[email-masked]>
Date: Sun, 19 Jul 2015 03:09:07 +0530

It is where the network cables terminate and stay resident (Old DOS
programmers will get the joke :).

-- Vinayak

On Sun, Jul 19, 2015 at 2:08 AM, Stefan Winter <[email-masked]> wrote:
> In the interest of sanity, and in a continuing quest to kill all oxymorons,
> we should really not call it a terminal room then.
>
> , PCs, or other user-accessible machines. It is simply a place to get power,
> wired Internet access, help desk support, or print documents.
>
> When using the Ethernet connections in the Terminal Room, IPv4 addressing is
> provided via DHCP. Please use Dynamic Auto-configuration for IPv6. A
> stateless DHCPv6 server or RDNSS will provide network information. To cut
> down on the mess, ethernet cables have not been installed to every seat in
> the Terminal Room. If you need a cable, please ask at the Help Desk.
>
> * Submit a new trouble ticket via the
> http://tickets.meeting.ietf.org/newticket interface. Filling in the
> following fields: "My MAC Address", "My Current Location", and "My OS" may
> expedite ticket processing. If you have an existing account on
> http://tools.ietf.org you can use your established credentials (email
> address and tools password) to log in at
> http://tickets.meeting.ietf.org/login .
> * Send an email to [email-masked] with as much detail regarding
> your issue and configuration as possible.
> * If you're on site and need direct network assistance (i.e - you have no
> network) please go to the helpdesk, which is located in the Terminal Room.
> The IETF 93 network connects to the Internet via a 10Gb/s link provided by
> CZ.NIC and a 1Gb/s link from Dial Telecom. The IETF uses 31.133.128.0/18,
> 31.130.224.0/20 and 130.129.0.0/16 for IPv4 and 2001:67c:1230::/46,
> 2001:67c:370::/48 and 2001:df8::/32 for IPv6. We are supplying bandwidth for
> the conference space, as well as wireless and wired connections in the guest
> rooms.
>
> An 802.11 a/g/n/ac wireless network is provided throughout the venue on both
> the 2.4 and 5 GHz bands, in conjunction with IPv4 and IPv6 addressing
> options.
>
> The main “ietf” wireless network is now encrypted; when prompted for
> credentials, enter ietf for both the username and password.
>
> || SSID             || Description
> || Encrypted || Frequencies  || IP Versions                     ||
> All networks marked as encrypted will offer layer 2 security. This is done
> using WPA enterprise with 802.1X (PEAP or TTLS) authentication and AES or
> TKIP encryption. As usual, we are all using the same credentials (user
> “ietf”, password “ietf”), yet each user will get unique session encryption
> keys. Our Radius authentication servers use a certificate that you can
> verify by going to this page:
> https://www.ietf.org/registration/MeetingWiki/wiki/92net
>
> See the following archived email from Chris Elliot for an in-depth
> explanation of the changes made to the wireless configuration.
> http://www.ietf.org/mail-archive/web/92all/current/msg00009.html
>
> Note: Some users are having problems using Intel Centrino cards and the IETF
> network. Please see https://tickets.meeting.ietf.org/wiki/CentrinoIssue
>
> == Guest Room Access ==
>
> The IETF Network is being extended to the guest rooms in the Hilton. *Note*
> that while we are using the IETF meeting network for Internet connectivity,
> we are using the hotel's infrastructure (Ruckus access points) for the
> delivery to the guest rooms, so there are limits to the improvements we can
> effect.  We recommend using the wired connection if you experience poor
> connectivity in your guest room.
>
> Wired:
> 	IPv4 and IPv6 and provided via the wired connection in your room. Due to
> architectural limitations, inbound TCP connections from the Internet may not
> be available on the in-room wired connection.
>
> Wireless:
> 	In the guest room areas you should find the “ietf-hotel” SSID.  This
> network is 2.4GHz/5GHz and is being delivered via the Hilton's Ruckus access
> points. We encourage heavy users and/or those having poor coverage to use
> the wired connection.
>
> == Support ==
>
> If you have trouble using any of the Public or Guest Room services, please
> try to switch to the hotel SSIDs ("hhonors") or the hotel wired port.  If
> that doesn’t work, please contact the Hilton support as listed in your room.
> If things are working fine on the hotel offerings but not on the IETF
> SSIDs/ports, please do contact us in the Terminal Room (Amsterdam) or via
> tickets @ meeting.ietf.org  and we’ll be glad to help!
>
>
> == Printing ==
>
> There is a printer in the Terminal Room and is available to all IETF users.
> The printer is an HP Officejet Pro 8620 and is accessible via LPD, Bonjour,
> standard TCP/IP on port 9100.  The hostname for it is
> term-printer.meeting.ietf.org.
>
>
> ||term-printer.meeting.ietf.org || HP Officejet Pro 8620 || Inkjet
> w/Duplexer || 31.133.128.18 || 2001:67c:370:128:a65d:36ff:fe32:44ba ||
> Bonjour name: // term-printer // ||
> [http://support.hp.com/us-en/product/HP-Officejet-Pro-8620-e-All-in-One-Printer-series/5367611/drivers
> Printer Drivers] ||
>
> (Note that this method is not available if you have configured an explicit
> DNS search list. Please see below for
> [https://tickets.meeting.ietf.org/wiki/IETF91network#InstructionsforMacOSXusingmanualconfiguration
> the manual configuration instructions].
> 1. If you haven't printed on the selected printer before, you may need to
> download and install the driver using one of the links above.
> 3. If you get the "Unable to Find the Printer" page, simply enter the IP
> address of the printer {31.133.128.18} in the box in the bottom-right corner
> and click "Search."
> 5. The driver will finish it's installation and you *should* see a
> "Successful Network Installation" message.
> 8. You're printer is now ready to use, and you can find it by going to
> ''Start -> Devices and Printers''. No need to print a test page.
>
>
> 3. Add printers by using their IP addresses in "control panel" appearing
> when select Start -> Settings -> Printers & faxes -> "HP Universal Printing
> PS" -> Properties
>
> === HP Eprint
> 1. In a browser (Firefox appears to be the only browser that renders the
> pages properly) go to: http://term-printer.meeting.ietf.org/
> || Service || Address                                                     ||
> Notes
> ||
> || SMTP   || smtp.meeting.ietf.org                                || Will
> provide SMTP relay for anything within the IETF network             ||
> || NTP      || ntp.meeting.ietf.org                                   || A
> stratum 2 time service is provided via IPv4 and IPv6 unicast           ||
> || DNS      || ns1.meeting.ietf.org ns2.meeting.ietf.org || Validating
> recursive resolvers. The domain name is meeting.ietf.org. ||
>
> After doing MAC Privacy trials at IETF91 in Honolulu and IETF92 in Dallas,
> we are transitioning to this being a standard service on the IETF network.
> It will operate on the all the IETF meeting networks, so no special SSID
> will be broadcast. Users participating in the service will be assigned a
> shorter DHCP lease. Note that this time there is also support for some
> mobile devices.
>
> Instructions and tools to automatically randomize the MAC address used by
> the Wi-Fi interface of your device can be found (for several OSes) at:
>
>  *
> https://oruga.it.uc3m.es/802-privacy/index.php/MAC_address_change_tutorial
>
> More information about the IEEE 802 Privacy group and instructions about how
> to join the discussion list can be found at the IEEE 802 Privacy SG site:
>
> The terminal room and IETF network are made possible by the generous
> contributions by a number of companies and by the tireless efforts of our
> volunteer team. If you see any of these people in the halls, please be sure
> to thank them for all their work!
>
>
> Contributors:
> * Juniper Networks
> * Cisco
>
> Connectivity:
> * CZ.NIC
> * Dial Telecom
>
> Volunteers:
> * Hirochika Asai (WIDE)
> * Joe Clarke (Cisco)
> * Chris Elliott
> * Bill Fenner (Arista)
> * Joel Jaeggli (Fastly)

---

From: Ted Lemon <[email-masked]>
Date: Sat, 18 Jul 2015 18:19:50 -0400

> No, it is simply always the very last room in the line..
Indeed, if you don't have a terminal room, you get ringing, which 
corrupts packets and leads to bad latency.

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 19 Jul 2015 08:34:19 +0200

> corrupts packets and leads to bad latency.
/me briefly considers whether "ringing" can be applied to the vision of
IETF oldtimers restlessly pacing back and forth in the corridor looking
for the terminal room....

-- 
Surveillance is pervasive. Go Dark.

---

From: t.p. <[email-masked]>
Date: Mon, 20 Jul 2015 09:44:24 +0100

----- Original Message -----
From: "Vinayak Hegde" <[email-masked]>
To: "Stefan Winter" <[email-masked]>
Cc: "IETF Discussion Mailing List" <[email-masked]>
Sent: Saturday, July 18, 2015 10:39 PM

<tp>

I think that you will find that TSR is a few decades older than DOS; you
may be showing your youth:-)

Tom Petch

-- Vinayak

> In the interest of sanity, and in a continuing quest to kill all
oxymorons,
> Please note that at the request of the IETF Chair, demonstrations are
no
> longer permitted in the Terminal Room.
>
> === Help Desk ===
> You can also use trac to review outstanding tickets before reporting
an
> issue or to update outstanding tickets.
>
> || ietf                || Our default network
> || yes           || 5Ghz only      || v4 and v6
||
> || ietf-legacy     || For legacy and unencrypted use
> || no             || 2.4 and 5Ghz || v4 and v6
||
> || ietf-2.4ONLY || An encrypted network for 2.4Ghz users
||
> yes           || 2.4Ghz only    || v4 and v6                       ||
> || ietf-v6ONLY  || For users wanting a pure IPv6
> || yes           || 5Ghz only      || v6 only
||
> || ietf-nat64       || IPv6 stack with NAT64 to access IPv4 resources
|| yes
> || 5Ghz only      || v6 with NAT64 & DNS64 ||
> || eduroam       || educational users
> || yes           || 2.4 and 5Ghz || v4 and v6
||
> network. Please see
https://tickets.meeting.ietf.org/wiki/CentrinoIssue
> || Name || Model || Capabilities || IPv4 Address|| IPv6 Address ||
Notes ||
> Drivers ||
[http://support.hp.com/us-en/product/HP-Officejet-Pro-8620-e-All-in-One-
Printer-series/5367611/drivers
> Printer Drivers] ||
>
> === Instructions for Mac OS X using Bonjour auto-setup (DNS-Based
Service
> Discovery) ===
[https://tickets.meeting.ietf.org/wiki/IETF91network#InstructionsforMacO
SXusingmanualconfiguration
> 4. Enter "term-printer.meeting.ietf.org" in the Address field.  Leave
the
> Queue field blank.
> 2. When you come to the installer page asking you to choose the
"Network
> Type" -- choose "Wired (Ethernet)."
> 4. Ignore the "The Printer and Computer are Connected to Different
Routers"
> message and select "Next."
> 6. The fax feature is *NOT* enabled, so you may cancel the fax
installation
> portion.
> 6. Once the Scan has completed a window to the right will display the
PDF
> contents of the scan.
> || Service || Address
||
> the Wi-Fi interface of your device can be found (for several OSes) at:
https://oruga.it.uc3m.es/802-privacy/index.php/MAC_address_change_tutori
al

---

From: Joe Abley <[email-masked]>
Date: Mon, 20 Jul 2015 13:59:02 +0200

> As an hommage to John Backus, the "Non-Terminal Room" comes to mind.

... and when there's nobody in it, remember that a label separator
does not imply delegation.

Joe