Subject: Gen-ART LC review of draft-bradner-iaoc-terms-01

From: Peter Yee <[email-masked]>
Date: Tue, 28 Jul 2015 14:15:54 -0700

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Please resolve these comments along with any other Last Call comments you
may receive.

Document: draft-bradner-iaoc-terms-01
Reviewer: Peter Yee
Review Date: Jul-28-2015
IETF LC End Date: Jul-27-2015
IESG Telechat date: TBD

Summary: This draft is almost ready for publication as a BCP but has an
open issue, described in the review. [Ready with issues]

The draft updates BCP 101 to fix some issues around the beginning and end
of IAOC terms and how they relate to the first meeting of each IAOC cycle.

Major issues: None

Minor issues: 

The draft causes the IAOC chair’s term to end with the commencement of the
IAOC meeting occurring at the first IETF meeting of the year.  The new
chair is selected during the meeting.  That being the case, who chairs the
meeting and declares the results of the election?

Nits:

Page 2, last paragraph, last sentence: change the second occurrence of
“IETF” to “IAOC”.  I believe that is what was meant.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 28 Jul 2015 17:19:55 -0400

thanks - I will be updating this in the net few days

Scott

> On Jul 28, 2015, at 5:15 PM, Peter Yee <[email-masked]> wrote:
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 28 Jul 2015 17:22:57 -0400

ps - the answer to your question is that the IAD does

Scott

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Jul 2015 18:02:17 -0400

> ps - the answer to your question is that the IAD does

Scott,

Strikes me as a bad plan to ever have an employee of the IAOC
Chair one of its meetings, just as having a President of a
company who is an ex-officio member of that company's board
chair meetings of the Board, especially meetings that might make
decisions that could affect her.  While I can't imagine this
being an actual problem with the IAOC, it could have a bad odor.

Suggestion: Let the person who has chaired the IAOC for the
previous months chair the meeting unless there is a problem
(e.g., not there) or conflict (e.g., candidate for another year
as chair) and otherwise let the IAOC select an interim chair
from the voting membership, using whatever mechanism they like,
and to serve until the new/incoming chair is selected and
seated.  If the IAOC cannot easily reach agreement on who should
act as chair for the length of time it takes to hold an
election, I think it would be a sign of problems that your
document, probably wisely, do not address.

     john

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 28 Jul 2015 18:23:50 -0400

fwiw - based on your & Dave’s previous comments I am removing this level of detail from the draft 
and just saying that the IAOC will develop processes for the transition and elections

I can also say that the processes will be subject to public comment before adoption

that said, I see problems with having the previous chair run the elections in almost all cases
if the previous chairs term is up they would not likely be in the meeting and if the term is
not up the person, more often than not, will be running for an additional term.

and then you have the kind of thing that happened at the last chair election:

———
Tobias, as Acting IAOC Chair, opened the IAOC meeting on 2015-04-28
at 10:26 AM London UK time.

Tobias stated that the first order of business is to elect the IAOC
Chair, and nominations are now open. Scott nominated Tobias. There
were no other nominations. Tobias indicated his willingness to
serve, and stated that he had no conflicts. The term would expire in
March of 2016.  Tobias left the room to facilitate discussion. 
Tobias was called back in the room

Ray closed discussions and called the question. The motion on the
floor is to elect Tobias as IAOC Chair.  There was no additional
discussion. There were no abstentions, and no objections. Tobias was
unanimously elected IAOC Chair.

Jari Arkko [YES]
Lou Berger [YES]
Scott Bradner [YES]
Kathy Brown [YES]
Tobias Gondrom [YES]
Benson Schliesser [YES]
Andrew Sullivan [YES]
——

but lets discuss options for this later

Scott

> On Jul 28, 2015, at 6:02 PM, John C Klensin <[email-masked]> wrote:
> 
> 
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Jul 2015 23:00:20 -0400

--On Tuesday, July 28, 2015 18:23 -0400 "Scott O. Bradner"
<[email-masked]> wrote:

> fwiw - based on your & Dave's previous comments I am
> removing this level of detail from the draft  and just saying
> that the IAOC will develop processes for the transition and
> elections

I think that makes more sense.

> that said, I see problems with having the previous chair run
> the elections in almost all cases if the previous chairs term
> is up they would not likely be in the meeting and if the term
> is not up the person, more often than not, will be running for
> an additional term.
>...

More as an observation than something I think should be written
specifically into the document, but, at least until other things
change, there are guaranteed to be three people on the IAOC who
are not going to be the next Chair (can't remember whether BCP
101 prohibits it, but I think we can count on busy schedules and
other commitments if it does not) and who either have, or soon
will have, lots of experience chairing meetings) -- the IETF
Chair, the IAB Chair, and the ISOC President (in no particular
order).  Any of them could be drafted as interim Chair for the
purpose of chairing a meeting to select a regular Chair without
any of the concerns associated with your scenario.

    john

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Jul 2015 18:43:04 +1200

> any of the concerns associated with your scenario.

I'm on travel so cannot consult my copy of Roberts Rules, but I
assume there is a conventional solution to this problem, which
certainly isn't unique to the IAOC. (I'm not outraged by the IAD
acting temporarily as a non-voting chair, if no other solution
offers itself.)

    Brian

---

From: "Scott O. Bradner" <[email-masked]>
Date: Wed, 29 Jul 2015 05:23:43 -0400

those 3 people plus the ISOC appointed IAOC member can not be chair

asking one of these does make sense - but I think that should not be in this “update BCP 101” document

fwiw - Ray has been actually running the process for at least as long as I’ve been on the IAOC
that does not mean that he should continue to do so, it is just a factoid

Scott

> On Jul 28, 2015, at 11:00 PM, John C Klensin <[email-masked]> wrote:
> 
> 
>

---

From: John Curran <[email-masked]>
Date: Wed, 29 Jul 2015 06:17:44 -0400

On Jul 29, 2015, at 2:43 AM, Brian E Carpenter <[email-masked]> wrote:
> certainly isn't unique to the IAOC.

Nor I, but it is approximately as follows - 

Whomever convened the meeting steps forward at the appropriate time,
calls the meeting to order, and moves that a specific person who is present
act as the chairman of meeting.  A second is required, and upon second
(and confirmation by the nominated person that they are willing to chair), 
the party that made the motion then puts it to assembly for a vote.  The 
one who is elected then takes over as chair of the meeting at that point, 
and proceeds by announcing first order of business on the agenda.

/John

---

From: John C Klensin <[email-masked]>
Date: Wed, 29 Jul 2015 08:17:20 -0400

--On Wednesday, July 29, 2015 05:23 -0400 "Scott O. Bradner"
<[email-masked]> wrote:

> asking one of these does make sense - but I think that should
> not be in this "update BCP 101" document

Agree on the document.

> fwiw - Ray has been actually running the process for at least
> as long as I've been on the IAOC that does not mean that he
> should continue to do so, it is just a factoid

To be clear, while I think the optics are bad, as long as it is
Ray, I don't have a problem.  But I don't want to see anything
written into a spec that would have to be adjusted or undone if
Ray's successor had a different personality or set of skills.
So, again, saying nothing, or explicitly leaving it up to the
IAOC each time, seems appropriate to me.

    john

---

From: Bob Hinden <[email-masked]>
Date: Wed, 29 Jul 2015 09:15:02 -0700

> On Jul 28, 2015, at 11:43 PM, Brian E Carpenter <[email-masked]> wrote:
> 

I think it might better if the process is that the election of the IAOC chair by the IAOC is the first order of business at the first IETF meeting of each year and that it is the IADs responsibility to run the election.  That is, the IAD is not the acting chair, just runs the election.

Bob