Subject: ehip and shutup lists

From: "John Levine" <[email-masked]>
Date: 25 Nov 2015 22:00:15 -0000

These two lists were just announced in the past couple of days, and
neither has any traffic yet other than the announcements.

They are about more or less the same thing, ehip about hiding info in
mail headers, shutup about not recording mail trace information.

I have my doubts about the wisdom of both, but it seems to me that it
would make sense to pick one list and close the other down since it'll
be the same people arguing about the same issues on both.

R's,
John

---

From: John C Klensin <[email-masked]>
Date: Wed, 25 Nov 2015 19:04:39 -0500

--On Wednesday, November 25, 2015 22:00 +0000 John Levine
<[email-masked]> wrote:

> These two lists were just announced in the past couple of
> days, and neither has any traffic yet other than the
> announcements.
> 
> They are about more or less the same thing, ehip about hiding
> info in mail headers, shutup about not recording mail trace
> information.

I wasn't able to even figure that much out from the
announcement.  I guessed that "SMTP headers" might mean
SMTP-provided trace header fields, but I can come up with
alternate theories and I got "hiding" not "not recording".  I
did write the list managers about that, but have not yet gotten
a reply.

> I have my doubts about the wisdom of both, but it seems to me
> that it would make sense to pick one list and close the other
> down since it'll be the same people arguing about the same
> issues on both.

Agreed.  There is another reason as well.  If the intent is to
hide trace and normal (nominally UA-UA) mail header fields in
transit, it is almost certain that the same or closely-related
mechanisms will need to be used, at least unless the plan is to
replace Internet mail's "envelope and header" model with
separate outer envelope, trace envelope, and header model
(perhaps separating part of all of the latter from message
content by more than a blank line) similar to the P1/P2/P3
abstraction in X.400-series email.  

If the shut-up intent is either to not record trace fields or to
create and move to that more complex envelope structure, I, for
one, would prefer to have that discussion on the SMTP list,
where the right set of people are watching.

best,
   john

---

From: "ComKal Networks" <[email-masked]>
Date: Thu, 26 Nov 2015 11:03:57 +0800 (WST)

Hi John,

> be the same people arguing about the same issues on both.

It sounds like both are closely related so it does seem silly
to have two lists but the bit about not recording mail trace
to my way of thinking is dangerous (+ annoying to sysadmins)
and really only of benefit to one group of people.

I also agree with the other John, looks to me like it should
be apart of the SMTP list, no need to make two more lists.

Cheers
Ian Manners
ComKal Networks Australia

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 26 Nov 2015 13:19:50 +0000

John/John,

> did write the list managers about that, but have not yet gotten
The two mailing lists are about related, but not exactly the same work.

draft-josefsson-email-received-privacy

My understanding is that ehip is mostly to work on 
draft-wchuang-grunion-01 ("S/MIME Proxy Forwarding"). "shutup" is for 
charter discussions and hopefully for the subsequent WG related to 
personal information reduction in the Received header fields 
(draft-josefsson-email-received-privacy) and encryption of other 
sensitive header fields when using S/MIME/OpenPGP 
(https://modernpgp.org/memoryhole/).
> abstraction in X.400-series email.
I think this would be a perfect topic to discuss on the shutup@ mailing 
list. So please subscribe and let's discuss this topic there.
> where the right set of people are watching.
I think notifying people on the SMTP mailing list is a good idea, but I 
think the chartering discussion would be better done on a separate 
mailing list.

Best Regards,
Alexey

---

From: Eric Burger <[email-masked]>
Date: Sun, 29 Nov 2015 08:05:35 -0500

It is not like the SMTP list is overflowing with traffic. I just looked, and ietf-smtp is averaging less than one message per month.

I would suggest sending a message to both the ehip and shutup lists saying they will be shut down and the discussion will move (start?) to the ietf-smtp list. You might also hint that people should /review/ the ietf-smtp list before suggesting we take out all diagnostics from email transport ;-).

Then, after two weeks, shut down the ehip and shutup lists.

> On Nov 26, 2015, at 8:19 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> John/John,
> 
> My understanding is that ehip is mostly to work on draft-wchuang-grunion-01 ("S/MIME Proxy Forwarding"). "shutup" is for charter discussions and hopefully for the subsequent WG related to personal information reduction in the Received header fields (draft-josefsson-email-received-privacy) and encryption of other sensitive header fields when using S/MIME/OpenPGP (https://modernpgp.org/memoryhole/).
> I think this would be a perfect topic to discuss on the shutup@ mailing list. So please subscribe and let's discuss this topic there.
> I think notifying people on the SMTP mailing list is a good idea, but I think the chartering discussion would be better done on a separate mailing list.
> 
> Best Regards,
> Alexey

---

From: [email-masked]
Date: Sun, 29 Nov 2015 08:16:49 -0800 (PST)

> It is not like the SMTP list is overflowing with traffic. I just looked, and
> ietf-smtp is averaging less than one message per month.

> I would suggest sending a message to both the ehip and shutup lists saying
> they will be shut down and the discussion will move (start?) to the ietf-smtp
> list. You might also hint that people should /review/ the ietf-smtp list before
> suggesting we take out all diagnostics from email transport ;-).

Good point.

> Then, after two weeks, shut down the ehip and shutup lists.

+1. These proposals have suffered tremendously from a lack of review from an
operational perspective; having the discussion on the ietf-smtp may help
solve this problem.

				Ned

---

From: Rich Kulawiec <[email-masked]>
Date: Mon, 30 Nov 2015 08:19:25 -0500

On Sun, Nov 29, 2015 at 08:05:35AM -0500, Eric Burger wrote:
> I would suggest sending a message to both the ehip and shutup lists
> saying they will be shut down and the discussion will move (start?) to
> the ietf-smtp list.
>[snip]

I concur strongly: these are discussions that should take place on
ieft-smtp and should involve people with lengthy experience actually
running mail systems of different shapes, sizes, and architectures.

---rsk

---

From: Eliot Lear <[email-masked]>
Date: Mon, 30 Nov 2015 14:24:06 +0100

Hi,

> operational perspective; having the discussion on the ietf-smtp may help

+1.  Please can we merge things a bit?

Eliot