Subject: Hackathon IPR rules

From: "Miaofuyou (Miao Fuyou)" <[email-masked]>
Date: Wed, 4 Nov 2015 08:20:03 +0000

Thanks for the Trust to work on the Hackathon IPR rules. Will we have a documented guideline based on the rules set in the Trust report?

The rules says "participants are free to work on any code during an IETF event", how could this be actualized if a Hackathon open source project is member based?

Miao

---

From: Jari Arkko <[email-masked]>
Date: Wed, 4 Nov 2015 17:34:30 +0900

> Thanks for the Trust to work on the Hackathon IPR rules. Will we have a documented guideline based on the rules set in the Trust report?

Yes. The current rules in effect for the hackathon that we just had were here:
https://www.ietf.org/registration/MeetingWiki/wiki/94hackathon#ipr_and_code_contribution_guideline

But the Trust will provide a more formal version of these rules.

> The rules says "participants are free to work on any code during an IETF event", how could this be actualized if a Hackathon open source project is member based?

Maybe that’s an area where the Trust can write the text more clearly :-)

The intent of the language was that from IETF perspective we are not limiting what the participants can work on. And we are not demanding any rights or the sort for what their code contributions are within the hackathon. But of course, projects exist that do not allow just anybody to make changes or even see the code. That’s fine, but of course the participants may be required by their organisations, projects, or laws to not break those rules.

In other words, the IETF sets no limit or demand on what code people work on, but obviously many projects in the world set their own demands, and complying to those if you work on them is probably advisable :-)

Jari

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 4 Nov 2015 17:38:53 +0900

Hello, Miao.

In brief: This statement is from the perspective of the IETF only. We don't
mean to imply that the IETF will take care of non-IETF policy, rules, etc.
Merely that the IETF will not create additional limitations.

I think we will make this more clear (and explicit), as we take steps to
implement the policy.

-Benson