Subject: Re: Last Call: <draft-santesson-auth-context-extension-09.txt> (Authentication Context Certificate Extension) to Proposed Standard

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 17 Nov 2015 10:34:27 -0500

The draft below was sent through last call as Proposed Standard, which
was intended, but the document header was listed as informational.  If
there is no issue changing the header and proceeding as proposed
standard, we'll go ahead with that.  Please let me know if there is a
problem and we'll put it through as informational, it was marked
correctly everywhere else and did go through the 4 week last call
process.

Thank you,
Kathleen

> Subject: Last Call: <draft-santesson-auth-context-extension-09.txt>
> (Authentication Context Certificate Extension) to Proposed Standard
> Date: Tue, 29 Sep 2015 15:08:19 -0700
> From: The IESG <[email-masked]>
> Reply-To: [email-masked]
> To: IETF-Announce <[email-masked]>
>
>
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Authentication Context Certificate Extension'
>   <draft-santesson-auth-context-extension-09.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2015-10-27. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
>
> Abstract
>
>
>    This document defines an extension to certificates according to
>    [RFC5280]. The extension defined in this document holds data about
>    how the certificate subject was authenticated by the Certification
>    Authority that issued the certificate in which this extension appears
>
>    This document also defines one data structure for inclusion in this
>    Extension. The data structure is designed to hold information when
>    the subject is authenticated using a SAML assertion [SAML].
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-santesson-auth-context-extension/
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/doc/draft-santesson-auth-context-extension/ballot/
>
>
> No IPR declarations have been submitted directly on this I-D.
>
> Note: The editorial comments in the shepherd report have been addressed.
>  These will be removed/updated in a future version of the shepherd
> report, but I didn't want to hold up processing of this draft any further.
>
>
>
>

-- 

Best regards,
Kathleen

---

From: Scott Bradner <[email-masked]>
Date: Tue, 17 Nov 2015 10:41:39 -0500

process-wise I think you are fine as long as it was last-called for the status you now intend

the general issue is addressed in 2026

   The IESG is not bound by the action recommended when the
   specification was submitted.  For example, the IESG may decide to
   consider the specification for publication in a different category
   than that requested.  If the IESG determines this before the Last-
   Call is issued then the Last-Call should reflect the IESG's view.
   The IESG could also decide to change the publication category based
   on the response to a Last-Call. If this decision would result in a
   specification being published at a "higher" level than the original
   Last-Call was for, a new Last-Call should be issued indicating the
   IESG recommendation. In addition, the IESG may decide to recommend
   the formation of a new Working Group in the case of significant
   controversy in response to a Last-Call for specification not
   originating from an IETF Working Group.

any you are on the right side of that discussion

Scott

> On Nov 17, 2015, at 10:34 AM, Kathleen Moriarty <[email-masked]> wrote:
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 17 Nov 2015 10:44:27 -0500

> process-wise I think you are fine as long as it was last-called for the

Great, that what I was thinking, but wanted to make this error known
to be on the safe side.

Thanks,
Kathleen
> On Nov 17, 2015, at 10:34 AM, Kathleen Moriarty
> <[email-masked]> wrote:
>

-- 

Best regards,
Kathleen

---

From: Russ Housley <[email-masked]>
Date: Tue, 17 Nov 2015 11:27:48 -0500

I have no objection to the change from Information to Standards Track.  However, there are some errors in the ASN.1 modules that need to be corrected.

The module in Appendix A.1 uses the 1988 syntax, and it imports but never uses the Extension type.  Removing the IMPORT statement altogether will resolve this problem.

The module in Appendix A.2 uses the 2008 syntax, and the IMPORT statement is missing the ending semi-colon.

In addition, the Appendix A.2 should contain an extension set similar to the ones in RFC 5912.  I suggest something like:

   ElegnamndenCertExtensions EXTENSION ::= {
       ext-AuthenticationContext, ... }

Russ