Subject: fetching IETF/IRTF material programmatically

From: Dirk Kutscher <[email-masked]>
Date: Thu, 19 Nov 2015 17:33:47 +0000

Hello,

I have written a little IETF material scraping tool that I thought could be useful for other people, too.

Here is the description:

I sometimes have the need to grab the recent available material (slides, drafts etc.) for an IETF WG or IRTF RG for later offline work, e.g., when jumping on a plane, train etc.

I hacked a simple shell script that would do that for me: get-ietf-material

# Usage: get-ietf-material <meetingnr> <groupname>
# Example: get-ietf-material 94 icnrg

It tries to fetch slides, agendae, minutes, charter, drafts and stores everything under <meetingnr>/<groupname>.
Fair warning: There is no meaningful error processing.

It's based on wget and uses time stamping to avoid fetching things multiple times, so could be run periodically.

Available here:
https://github.com/dku/ietf-tools

It's possible that there are better tools available - please let me know if you aware of anything.

Cheers,
Dirk

--
Dr. Dirk Kutscher | NEC Laboratories Europe, Chief Researcher
http://dirk-kutscher.info/
phone: +49 6221 4342 203 | fax: +49 6221 4342 155 | lab webpage: www.neclab.eu<http://www.neclab.eu/>

NEC Europe Ltd | Registered Office: Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB | Registered in England 2832014

---

From: "Paul Hoffman" <[email-masked]>
Date: Thu, 19 Nov 2015 09:58:25 -0800

> know if you aware of anything.

A related tool (I won't say "better") is a CLI tool for opening drafts 
and RFCs, Datatracker pages, and so on:
    http://trac.tools.ietf.org/tools/ietf-cli/

--Paul Hoffman

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 19 Nov 2015 19:10:30 +0000

Thanks -- that's good to know.

It's definitely related but seems to address fetching RFCs and IDs only.

Cheers,
Dirk

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Donnerstag, 19. November 2015 18:58
> To: Dirk Kutscher
> Cc: [email-masked]
> Subject: Re: fetching IETF/IRTF material programmatically
> 
> A related tool (I won't say "better") is a CLI tool for opening drafts and RFCs,
> Datatracker pages, and so on: