Subject: "We did not know" is not a good excuse

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 7 Apr 2016 00:34:53 +0100

One might assume that a step in the selection of a location is to look at some
advice for travellers.
One such source of information is the US State Department. (Not the source of
all wisdom, but a source of some information.)

https://travel.state.gov/content/passports/en/country/singapore.html has a
sizeable section on LGBT rights and associate issues.

Yes, this is hard to get right and people make mistakes.
Yes, move on.

How do we move on so:
- this problem stops being a problem for IETF 100
- this problem does not recur

Adrian

---

From: Dave Crocker <[email-masked]>
Date: Wed, 6 Apr 2016 19:19:10 -0700

> How do we move on so:
...
> - this problem does not recur

What you probably do not mean is 'we do not go to Singapore again.

What you probably /do/ mean is that further venue selections avoid 
places that effectively serve to exclude participation by various 
constituencies.  Or at least, that is what I hope you mean, because it 
has broader utility.

So I'll repeat what I said at the virtual microphone:

    If the community wishes meeting venue selection to refrain from 
choosing specific places, the community needs to develop that list.

Anything less specific leaves too much to interpretation, which 
guarantees that similar errors will recur.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Melinda Shore <[email-masked]>
Date: Wed, 6 Apr 2016 18:38:47 -0800

> guarantees that similar errors will recur.

The situation in Singapore goes well beyond being vaguely
homophobic, to actively criminalizing the families of some
IETF participants.  This is not simply a matter of same-sex
marriage not being legal there, or of the country lacking
anti-discrimination laws.

I am not surprised that any given person might not be
familiar with the situation in Singapore and/or did not
think to check out the human rights situation, but I am
quite surprised that that was the case with a fair-sized
blob of people.  I do think that having broader diversity
among various bodies would make a terrific difference but
from my own experience I tend to think the economics of the
situation make that rather more difficult than loading up
the I* committees with people who share a number of demographic
traits.

Melinda

---

From: Harish Pillay <[email-masked]>
Date: Thu, 7 Apr 2016 11:12:06 +0800

> anti-discrimination laws.

I would like to ask for validation and citation of what you are
saying above. I live in Singapore and yes, we do have the archaic
rules on our books (Section 377A of the Penal Code -
https://en.wikipedia.org/wiki/Section_377A_of_the_Penal_Code_%28Singapore%29)
This is a rule we inherited from our British colonial days.

I don't agree with that section, but it is there.

There are ongoing debates on withdrawing Section 377A and it
will happen eventually. It is a matter of time.

If there is any "active criminalizing" then how would this annual
event called pinkdot.sg (http://pinkdot.sg/) happen? The next
pinkdot.sg is on 4th June 2016. But, as it has been
in Singapore so far, open and honest dialogue is used to get to
a favourable resolution. It is still work in progress though.

So, let's keep discussions based on facts please.

Harish

---

From: Melinda Shore <[email-masked]>
Date: Wed, 6 Apr 2016 19:48:19 -0800

> will happen eventually. It is a matter of time.

Well, it was upheld by your courts as recently as late 2014, and
it is by no means the only anti-gay law on the books in Singapore.

Melinda

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 7 Apr 2016 05:32:17 +0100

Dave,

> constituencies. 

What I mean, and I have no reason to doubt the good intentions and diligence of
the IAOC and Meetings Committee, is that we need to avoid situations where:

- the IAOC is unaware of the strength of feeling in the community on a selection
issue
- the IAOC is unaware of travel issues for a particular venue
- the community is surprised by the choice of venue
- the venue, host, sponsor, IAOC, IETF, are embarrassed by the reaction to a
venue announcement

It may be true that the community could provide a list of vetoed and approved
locations for the Meetings Committee to work with. That is a possible approach.
Another approach might be for the Meetings Committee to suggest some venues and
see what the community feels (this has happened before with a poll on some
venues that Ray sent to the community).

But I want to spec the problem, not engineer a solution. I trust the IAOC to
develop a solution to the problem that works with the other issues they have to
handle. And I trust them to bring the solution forward soon.

Adrian

---

From: Harish Pillay <[email-masked]>
Date: Thu, 7 Apr 2016 13:18:25 +0800

> it is by no means the only anti-gay law on the books in Singapore.

No different from the many other anti-gay laws on books in many
countries including the US. Important thing is, in the Singapore
context, that even though it is in the books, it is NOT enforced
in any aggressive nor wanton manner.

Harish

---

From: Melinda Shore <[email-masked]>
Date: Wed, 6 Apr 2016 21:33:27 -0800

On 4/6/16 9:18 PM, Harish Pillay wrote:
> countries including the US.

Actually, it is.  Our Supreme Court has been striking down
anti-gay legislation, not upholding it.  Right now it is the
law in Singapore that sexual contact between consenting adult
men is a criminal act.  The best way to clarify that Singapore
doesn't really mean it is to get rid of the law, along with
your other miscellaneous anti-gay laws.

I live in Alaska, so I'm certainly sympathetic to the problem
of living in a place you love that does some things that are
very wrong and that are difficult to explain to people not from
there, and the embarrassment that sometimes goes with that.
But my own feeling is that the best way to deal with those
situations is to own them and to work for change.  I respect your
feelings about your country but I will not be attending a
meeting in Singapore unless the laws change.

Melinda

---

From: Harish Pillay <[email-masked]>
Date: Thu, 7 Apr 2016 13:58:24 +0800

> your other miscellaneous anti-gay laws.

There has not been, to the best of my knowledge, *anyone* who
has been charged in court under that rule (which I think is the
only rule there is) unless it was based on a report made by
one of the parties involved and it is usually under that offense
of rape or by parents (of minors involved). No one is going around
looking into bedrooms to see what is happening.

Again, no one who has participated in the pinkdot.sg event has,
to the best of my knowledge, been charged or penalised for
their orientation.

> meeting in Singapore unless the laws change.

It is a pity that you won't attend. I respect your stand and
principle. I feel that you are unfortunately making this more
of an issue than it really is in Singapore. Yes, we have prudes
(exclusively the religious sort[0]) who make it their problem
what consenting adults do based on their interpretation of
some fairy tale :-).

Singapore is far from perfect and we have our peculiarities. But
so does every society and country.

I would strongly encourage you to come to Singapore. I would
be more than happy to welcome you here. We need keep the
channels open and not closed. Then, and only then, will things
change for the better.

Harish
[0] http://news.asiaone.com/news/singapore/gay-lifestyle-against-bible-says-council-churches

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 03:53:08 -0400

--On Wednesday, April 06, 2016 19:19 -0700 Dave Crocker
<[email-masked]> wrote:

> What you probably /do/ mean is that further venue selections
> avoid places that effectively serve to exclude participation
> by various constituencies.  Or at least, that is what I hope
> you mean, because it has broader utility.
> 
>     If the community wishes meeting venue selection to refrain
> from choosing specific places, the community needs to develop
> that list.
> 
> Anything less specific leaves too much to interpretation,
> which guarantees that similar errors will recur.

Dave,

Thanks for clarifying.  I agreed with what I thought you said at
the virtual microphone.   I disagree with the above.

If the issue is "come up with firm criteria, including what
issues are showstoppers", then I think that is a
nearly-reasonable expectation.   I would still expect the IAOC
to do some diligent investigation and propose a list for
community discussion, just as we have similar expectations for
WGs, but I think some list could be developed.  

FWIW, I think the "showstopper" idea borrows heavily from what
Pete had to say last night.   If the community decides that some
conditions (or lack thereof, make a particular venue, city, or
country unacceptable,  I don't think the community should hear
about how the 1-1-1 rule, or whatever replaces it, required
making tradeoffs or balancing issues.   Put differently, I see
that "rule" as more of a guideline: if we cannot find acceptable
venues in a particular region without compromising important
principles, then we go to that region less often (or even not at
all), not drop those principles in the interest of balance.

And, as others have said, this is precisely why some of us have
been very concerned about the lack of openness, transparency,
and meaningful consultation by the Meetings Committee and IAOC.

On the other hand, if you meant, as the quoted text above seems
to indicate, that the community needs to come up with a list of
banned "specific places", with the Meetings Committee treating
everywhere else as OK, I think that is an unreasonable
expectation.  Not only do I think the community expects the
Meetings Committee and IAOC to do the research and be
consultative (see Adrian's notes) but, if the only firm rule is
"specific excluded places" and everything else is "a balance",
with balancing factors sorted out in secrecy, then it seems to
me that our history suggests that "1-1-1" or "nice vacation spot
for spouses and families" is likely to outweigh what I hope most
of us would agree are important principles.

best,
     john

p.s. I think the question about Singapore is not "do we go back
a second time" but "do we go at all".  However long and painful
the contract negotiation process was, the costs of renegotiating
or extricating ourselves _are_ a matter of tradeoffs or
"balance".  Of course, it is probably impossible to predict what
the state of their laws, and enforcement of those laws, might be
a year and a half out, but that is at least as much an argument
against suggestions that we should be working even more than
three years out than it is that going to a place with odious
laws and a history of brutal enforcement of what they choose to
enforce is a matter of "balancing" assorted factors.

---

From: <[email-masked]>
Date: Thu, 7 Apr 2016 08:20:20 +0000 (UTC)

> IETF participants.

And e.g. Papua New Guinea is the same. If you have a work
trip there, don't take your family there. Not least because
it's rather more violent than Singapore. But do go to
Singapore for the shopping. If members of your family have
a tendency towards shoplifting, I suspect shopping in
Singapore may be a bad idea for them. (While the
shopping in Port Moresby is _terrible_. Really limited
selections. And you need armed guards. And, oh, the
food. Locals have a sweet tooth. The diabetic and
gluten-intolerant members of your family will have
problems.)

Really, just don't take your family on work trips.
It's simply more trouble than it's worth. Either
they're bored, thrown in jail for shoplifting because
they're bored, or complaining incessantly that Minnesota
is too cold once they run out of boring interconnected
malls to shoplift from. (While in Port Moresby, the knives
come out early, and the shoplifter never gets bored. Or
reaches jail. Or a hospital. Which is perhaps just as
well.)

On a related note, nuclear weapons exist to endanger
the lives of most IETF participants. And their families.
I believe that the IETF should be actively boycotting
all countries with nuclear weapons. 

Singapore, to my knowledge, does not have a nuclear
arsenal and hasn't invaded any other countries to
endanger families' lives recently, so I'm okay with
Singapore.

I really want to know exactly what the IETF's declared
stances are on nuclear weapons, on armed proliferation, and
on state belligerency on the international stage by
warriors that endanger families.

The IETF should be showing we care by boycotting those
countries that do not meet our exacting standards in this
regard. They won't get our money or suffer our complaints
about their poor hotel and wifi service, and their revenue
and funding of their military-industrial complexes will
suffer greatly while their hotel services fail to improve
at all as a result of not receiving the enlightened
supportive criticism that comes from our high expectations.

Jari, can we get a workgroup set up with a list of RFC
position statements as target deliverables to get this
started? (Also, if we can get something out repudiating
IS-IS's existence as a routing protocol and denying that
we endorse it or its spread, that would no doubt be
well-received by everyone who has never heard of or
used IS-IS, and quite a few who have.)

thanks

L.
Lloyd Wood [email-masked] http://about.me/lloydwood

---

From: Dave Crocker <[email-masked]>
Date: Thu, 7 Apr 2016 08:07:40 -0700

> venues that Ray sent to the community).

A practical issue is that announcing a venue before there is a contract 
in place for the meeting site impairs our ability to negotiate the 
contract.  And I'll suggest that this is not an issue that one should 
try to 'game', such as by trying to obscure the choice by floating 
various venue possibilities or otherwise hoping that we haven't signaled 
the choice to a specific city/hotel.

Rather, the way to deal with the choice of acceptable/unacceptable 
countries or cities is for the IETF community to develop lists 
reflecting the range of choices.

The IETF's established set of regions is Eastern/Southeastern Asia, 
North America, Europe.  For each of these, the total list of countries 
is relatively small, so that a priori consideration and assessment by 
the IETF community ought to be feasible.

(Other regions fall into the asterisk realm of 1:1:1:* and are already 
subject to prior discussion with the IETF community.)

d/
-- 

   Dave Crocker

---

From: Ted Lemon <[email-masked]>
Date: Thu, 7 Apr 2016 12:23:38 -0300

Dave, how would it complicate the negotiation process to simply say "we are
considering the following cities for future IETFs: does anybody know of an
issue that they want to raise with any of these?"   We don't have to say
when, or how definite.   It's hard to see how this would cause
problems--can you explain?

I'm not objecting to just making an exhaustive list; I just am not
convinced that it would really make any difference, particularly since
things change.   E.g., I suspect that the IETF that was scheduled for
Charlotte, NC, is no longer in the offing... :}

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 7 Apr 2016 17:30:42 +0100

> On 7 Apr 2016, at 16:07, Dave Crocker <[email-masked]> wrote:
> 
>  And I'll suggest that this is not an issue that one should try to 'game', such as by trying to obscure the choice by floating various venue possibilities or otherwise hoping that we haven't signaled the choice to a specific city/hotel.

Such a process served us well in getting feedback on members of the I* until recently.

I would have thought that it would pick up problems of the type that was identified last night without compromising our commercial position too badly.

Stewart

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 12:34:21 -0400

--On Thursday, April 07, 2016 12:23 -0300 Ted Lemon
<[email-masked]> wrote:

> Dave, how would it complicate the negotiation process to
> simply say "we are considering the following cities for future
> IETFs: does anybody know of an issue that they want to raise
> with any of these?"   We don't have to say when, or how
> definite.   It's hard to see how this would cause

Exactly.  Singapore may be a special case because it is a
"city=country" one but, other than Luxembourg, there are
relatively few others of those that are likely candidates for
discussion.   I'm not suggesting supplying padding, but I assume
that there are multiple places that might be considered in any
of those regions (and even countries between them) and
identifying a list of them and asking the question Ted suggests
should not be an issue.

I also can't imagine why doing that would get in the way of
negotiations, at least unless the process has turned into "let's
go to Timbuktu, now let's start negotiating with hotels there".
Independent of other issues with that city, I'd suggest that, if
the model comes down to that, we'd be in bad trouble for other
reasons, so I assume it hasn't.   It would be better if cities
were eliminated before a call for proposals was issued but, even
if one were issued that included several cities, I don't see
huge problems if some candidate venues were eliminated because
we decided their cities or countries were off-limits: it would
really be no different from a solicitation and contracting
standpoint than eliminating one because our preliminary
investigations concluded that adequate connectivity was
impossible for that city.

    john

---

From: Dave Crocker <[email-masked]>
Date: Thu, 7 Apr 2016 09:37:57 -0700

> I would have thought that it would pick up problems of the type that was identified last night without compromising our commercial position too badly.

Stewart,  if you are referring to the gaming that used to be done, when 
soliciting information about nomcom candidates, by padding the list of 
names with various non-candidates, in my experience on several nomcoms, 
no it did not work well at all.

d/

-- 

   Dave Crocker

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 7 Apr 2016 18:15:07 +0100

> contract.

We are engineering.
But I will break a rule and go there.

I don't see that saying "we are considering Hong Kong, Singapore, and Manila"
reduces our ability to negotiate in Singapore. Maybe it even strengthens it.

But there we go. Looks like sometimes we may need to pay a price to get what we
want. The loss on cancelation may be greater than the loss on negotiation.

Adrian

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 7 Apr 2016 17:29:48 +0000

> On Apr 6, 2016, at 8:34 PM, [email-masked] wrote:
> 
> How do we move on so:

That would be a very relevant conversation on [email-masked].

---

From: Stefan Winter <[email-masked]>
Date: Thu, 7 Apr 2016 14:35:18 -0300

Hi,

> discussion.

Not that it adds particularly much to the discussion at hand, but would
you please note that the country of Luxembourg has 2,586.4 km^2 /
998 sq mi surface, while the city of Luxembourg is just one out of
multiple cities in the country.

If you are looking for area surface matches between a country and its
(only) city, you may rather want to look in the general direction of the
country Monacco and its city Monte Carlo (different name, same thing -
how's that for a special case!).

(Now waiting for someone from Monacco to correct me about my ignorance
of throwing both into one bowl)

Greetings,

Stefan Winter

>    I'm not suggesting supplying padding, but I assume

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 13:41:02 -0400

Stafan,

My apologies... bad example.   I was, however, thinking less of
the city area to country area ratio than about the "probably
only one plausible city in the country to hold an IETF-sized
meeting" issue.    I should have been more clear about that or
chosen a better example (or, more likely, both).  

     john

--On Thursday, April 07, 2016 14:35 -0300 Stefan Winter
<[email-masked]> wrote:

>>> simply say "we are considering the following cities for
>>> future IETFs: does anybody know of an issue that they want
>>> to raise with any of these?"   We don't have to say when, or
>>> how definite.   It's hard to see how this would cause
> Not that it adds particularly much to the discussion at hand,
> but would you please note that the country of Luxembourg has
> 2,586.4 km^2 / 998 sq mi surface, while the city of Luxembourg
> is just one out of multiple cities in the country.
> 
> If you are looking for area surface matches between a country
> and its (only) city, you may rather want to look in the
> general direction of the country Monacco and its city Monte
> Carlo (different name, same thing - how's that for a special
> case!).
> 
> (Now waiting for someone from Monacco to correct me about my
> ignorance of throwing both into one bowl)

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 7 Apr 2016 19:31:01 +0100

On 07/04/2016 17:37, Dave Crocker wrote:
>>>   And I'll suggest that this is not an issue that one should try to 
>>> 'game', such as by trying to obscure the choice by floating various 
>>> venue possibilities or otherwise hoping that we haven't signaled the 
>>> choice to a specific city/hotel.
>>
>> I would have thought that it would pick up problems of the type that 
>> was identified last night without compromising our commercial 
>> position too badly.
>
>
> Stewart,  if you are referring to the gaming that used to be done, 
> when soliciting information about nomcom candidates, by padding the 
> list of names with various non-candidates, in my experience on several 
> nomcoms, no it did not work well at all.
>
> d/
>
>

Of course one's mileage may vary. Whilst I prefer the new system, my 
recollection from the two Nomcoms I served on was that the padded 
systems worked well enough.

The padding is somewhat different in this case because the padding may 
actually be not fully researched candidates and the input may mean that 
you avoid additional work reviewing a city that would otherwise be 
dropped at a later stage.

Stewart

---

From: "John Levine" <[email-masked]>
Date: 7 Apr 2016 20:38:11 -0000

>chosen a better example (or, more likely, both).  

Unless the country is so small that there's only one plausible meeting
hotel, that still doesn't strike me as a problem.

So if they said they were thinking about the Bahamas, that could be a
problem, anywhere else, not so much.

R's,
John

---

From: Dave Crocker <[email-masked]>
Date: Thu, 7 Apr 2016 13:51:43 -0700

> hotel, that still doesn't strike me as a problem.

IETF meeting venue requirements are sufficiently unusual that, in fact, 
there often are /very/ few choices within many countries.

d/

-- 

   Dave Crocker

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 7 Apr 2016 17:41:08 +0000

>want. The loss on cancelation may be greater than the loss on negotiation.

There have been periodic surveys after meetings, and there have certainly been questions in there regarding potential sites with a means of adding comments.

It seems like this practice should continue.

	Tony

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 18:25:23 -0400

--On Thursday, April 07, 2016 17:41 +0000 "HANSEN, TONY L"
<[email-masked]> wrote:

>> But there we go. Looks like sometimes we may need to pay a
>> price to get what we want. The loss on cancelation may be
>> greater than the loss on negotiation.
> 
> 
> There have been periodic surveys after meetings, and there
> have certainly been questions in there regarding potential
> sites with a means of adding comments.
> 
> 

Of course, those periodic surveys have been available to meeting
attendees and have not picked up any information or preferences
those who did not show up in person for one reason or another
might have.

---

From: Lee Howard <[email-masked]>
Date: Sun, 10 Apr 2016 11:19:34 -0300

>the choice to a specific city/hotel.

I¹m still unsure about the proposal, but in the case of Asia, and when
we¹re negotiating contracts for multiple meetings often well in advance,
you could practically list all countries that have cities large enough to
host.
We¹re considering meetings in
Seoul
Singapore
Hong Kong
Beijing
Nanjing
Xi¹an
Shanghai
Tokyo
Yokohama
Kyoto
Fukushima
Jakarta
Bangkok
Mumbai
(and so on and so on)

Build a matrix of mandatory and desired features and evaluate each
potential destination¹s qualifications. Some are too specific (one roof)
to list before hotel negotiations begin, but others (accessibility by
disability, two-flight rule, other political climate, safety, multiple
hotels, etc.) can be evaluated very early in the process. In doing so,
that information remains on the record, and can be updated later.

>the IETF community ought to be feasible.

Right, although I¹d like to include cities because some countries are
acceptable (Japan) but some cities within them may not be (Fukushima).

>subject to prior discussion with the IETF community.)

Lee