Subject: Re: Proposed New Note Well

From: Pete Resnick <[email-masked]>
Date: Wed, 6 Apr 2016 19:33:50 -0300

Two things, neither earth-shattering:

1. Jari did say he thought it was still too long. The second paragraph 
(mentioning the patent policy) seems duplicative with what's in the 
second bullet and the list at the bottom. And of course the top-level 
message should be that first bullet: You have to follow all of the 
rules. Let's just strike the second paragraph.

2. In addition to the pointer to the documents at the bottom (which I 
presume will be links when this thing appears in HTML), it would be 
great to have a link to https://www.ietf.org/ombudsteam placed next to 
the line regarding anti-harassment procedures. That'll let people also 
find the IESG Statement and other info.

pr

On 21 Mar 2016, at 13:51, IESG Secretary wrote:

> Note Well
>
> This is a reminder of IETF policies in effect on various topics such 
> as
> patents or code of conduct. It is only meant to point you in the right
> direction. Exceptions may apply.
>
> The IETF's patent policy and the definition of an IETF "contribution"
> and "participation" are set forth in BCP 79; please read it carefully.
>
> As a reminder:
>
> • By participating in the IETF, you agree to follow IETF processes 
> and
>   policies.
> • If you are aware that any IETF contribution is covered by patents 
> or
>   patent applications that are owned or controlled by you or your
>   sponsor, you must disclose that fact, or not participate in the
>   discussion.
> • As a participant in any IETF activity you acknowledge that 
> written,
>   audio and video records of meetings may be made public.
> • Personal information that you provide to IETF will be handled in
>   accordance with the IETF Privacy Statement.
>
> Definitive information is in the documents listed below and other IETF
> BCPs. For advice, please talk to WG chairs or ADs:
> ​
> BCP 9 (Internet Standards Process)
> ​BCP 25 (Working Group processes)
> BCP 25 (Anti-Harassment Procedures)
> BCP 54 (Code of Conduct)
> ​BCP 78 (Copyright)
> ​BCP 79 (Patents, Participation)
> TBD (Privacy)

-- 
Pete Resnick <http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Scott Bradner <[email-masked]>
Date: Wed, 6 Apr 2016 18:37:36 -0400

imo - the 2nd pp is not duplicative - consider that the whole current note we’ll is just covering “what is a contribution”
and the question of what “participating”” is has been a contentious issue for a long time

Scott

> On Apr 6, 2016, at 6:33 PM, Pete Resnick <[email-masked]> wrote:
> 
> Jari did say he thought it was still too long. The second paragraph (mentioning the patent policy) seems duplicative with what's in the second bullet and the list at the bottom. And of course the top-level message should be that first bullet: You have to follow all of the rules. Let's just strike the second paragraph.
> 
> In addition to the pointer to the documents at the bottom (which I presume will be links when this thing appears in HTML), it would be great to have a link to https://www.ietf.org/ombudsteam <https://www.ietf.org/ombudsteam> placed next to the line regarding anti-harassment procedures. That'll let people also find the IESG Statement and other info.
> 
> pr
> 
> This is a reminder of IETF policies in effect on various topics such as
> • By participating in the IETF, you agree to follow IETF processes and
> policies.
> • If you are aware that any IETF contribution is covered by patents or
> • As a participant in any IETF activity you acknowledge that written,
> Pete Resnick http://www.qualcomm.com/~presnick/ <http://www.qualcomm.com/%7Epresnick/>

---

From: Tim Chown <[email-masked]>
Date: Thu, 7 Apr 2016 00:02:12 +0100

> In addition to the pointer to the documents at the bottom (which I presume will be links when this thing appears in HTML), it would be great to have a link to https://www.ietf.org/ombudsteam <https…
I agree. And it would be good if it could fit legibly on a single slide, for use in the WG chair slide decks, even if it’s something that in reality gets all the attention of a pre-flight safety video.

As a slight aside, I noticed this week that at least one WG used the proposed template rather than the (I think!) current one. While the direction of the new text  looks fine, we should probably be careful about what we’re using if it’s not yet official.

Tim

---

From: Pete Resnick <[email-masked]>
Date: Thu, 7 Apr 2016 00:27:20 -0300

How about if we changed the description of BCP 79:

BCP 79 (Patent Policy, definitions of "Participation" and 
"Contribution")

?

pr

On 6 Apr 2016, at 19:37, Scott Bradner wrote:

> imo - the 2nd pp is not duplicative - consider that the whole current 
> note we’ll is just covering “what is a contribution”
>> Jari did say he thought it was still too long. The second paragraph 
>> In addition to the pointer to the documents at the bottom (which I 
>> great to have a link to https://www.ietf.org/ombudsteam 
>> <https://www.ietf.org/ombudsteam> placed next to the line regarding 
>> anti-harassment procedures. That'll let people also find the IESG 
>> Statement and other info.
>>
>> pr
>>

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 08:50:24 -0400

Pete,

I think that would be an improvement, but I see a slightly
different tension that we probably need to deal with explicitly.
If we really want "short", e.g., fitting on one slide in big
letters, then the Note Well can be reduced to something like...

	"The IETF has a collection of policies.   As with a
	shrink-wrap license, you are responsible for all of them
	the moment you start participating or contributing, or
	interacting with other participants, in any way and can
	get yourself and your organization into big trouble for
	violating them.  An introduction to those policies and
	links to the details can be found at <link>."

If it seems to be useful, one more sentence to the effect that,
if one has questions after reading through the policies,
contact... could be added, but that might (should) be in
whatever is at the end of the link anyway.

IIR, a very brief statement of that sort is where this "Note
Well" stuff started.  It has gotten bloated as its mission has
crept toward explaining or enumerating the policies and the IETF
has become more policy-laden.

If we actually care about an on-screen version, a list of a
half-dozen or more links just isn't going to do it anyway.  It
won't be displayed long enough to copy it down.  That is
actually a reasonable guideline -- anything that requires
someone to look at material later, rather than being
read/listened to and absorbed, needs to be reduced to NTE one
link or reference or it won't be written down/ remembered.

In a way, we are going to end up with two Note Wells, one for
slide display and quick reminders (like registration forms) and
something else for posting, circulation in writing, and the
target of the reference/link in the first.  I fear that is
inevitable and that we should be adapting to it rather than
pretending we can create a one-screen document that covers
everything.

     john

--On Thursday, April 07, 2016 00:27 -0300 Pete Resnick
<[email-masked]> wrote:

>...

>> imo - the 2nd pp is not duplicative - consider that the whole
>> current  note we'll is just covering "what is a
>> contribution" and the question of what
>> "participating"" is has been a  contentious issue for a
>> long time