Subject: Re: [Recentattendees] Remote Participation for IETF 95: Meetecho Details

From: Rich Kulawiec <[email-masked]>
Date: Fri, 1 Apr 2016 03:25:06 -0400

On Thu, Mar 31, 2016 at 02:29:15PM -0400, John C Klensin wrote:
> A registration requirement for remote participants is a major
> policy change and one for people who merely want to passively
> observe is something I believe the community has several times
> concluded is inappropriate given privacy, etc., concerns.  So,
> who made this decision and how?  Unless the answer involves a
> community discussion and Last Call or equivalent process that I
> missed (and apparently Melinda did too), if the answer to "who
> decided" involves anyone in the IETF Leadership, would they
> please offer to resign?

I strongly concur.  Nobody should have to surrender *any* form
of personal identification merely to passively observe.

---rsk

---

From: Tobias Gondrom <[email-masked]>
Date: Fri, 01 Apr 2016 11:22:51 +0200

> of personal identification merely to passively observe.

Dear rsk and John,

please excuse my brevity, as I am currently in transit to BA with only 
very limited Internet. So I will need to answer in more detail later.

At first to the question who is responsible: as the chair of the IAOC, 
in the end I am responsible for the actions of the IAOC which includes 
the implementation of the registration for Meetecho (all other remote 
participation tools do not require registration). But I hope you will 
allow for some conversations before you call for my head.

As you know over the last few years, we have made great strides in 
enhancing the remote participation capability to give remote attendees a 
full mirror of local attendees, to a level where you can have full 
active attendance through meetecho, incl. remote presentations, 
comments, questions and so on. With the goal to allow full active remote 
participation capabilities mirroring what we have now for the people who 
attend in person. Is it perfect yet, no, but we are moving towards that 
goal.

The registration of _active_ remote participants has been discussed 
within the IAOC for operational purposes and also to mirror the existing 
IETF process for remote contributions. However, it was not clear when 
this would be feasible from a technical standpoint.
I admit that the current implementation is not as as intended and in 
fact while voicing the intent we did not know when in the timeframe of 
2016 - 2018 it would be possible. And it would have been good to consult 
the community beforehand we execute this step. In some ways our 
operations team did move on the intent a bit faster than expected for 
Meetecho, which can also be considered my fault as I did not explicitly 
halt them and require and spell out the process to do before we take 
this step and did not push for explicitly mandate strong testing of the 
interface before it goes live.

Once I arrive in Buenos Aires, I will review the situation with our IAD 
and the Meetecho team about what they implemented the last few days.

To rsk's comment: please understand that the registration intent is for 
active remote participants. All standalone audio streams are still 
available during sessions. I understand that the current implementation 
for the Meetecho registration may deviate from the intent to sign-up the 
active remote participants. I will need to talk with the Meetecho and 
operations team to understand the scope.

I shall come back to you on all the details as soon as I arrive in 
Buenos Aires and get a chance to discuss with our tech teams.

I apologies for any inconveniences and will be looking forward to seeing 
you all in BA.

Best regards, Tobias (IAOC chair)

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 1 Apr 2016 11:57:20 +0200

Le 31/03/2016 20:17, Ray Pelletier a écrit :
> Melinda
>
>> On Mar 30, 2016, at 8:37 PM, Melinda Shore
>> <[email-masked]> wrote:
>>
>>> On 3/30/16 12:22 PM, IETF Secretariat wrote: 1. Individuals are
>>> required to register for the meeting to observe or participate
>>> via Meetecho.
>>
>> I'm not sure I understand this correctly.  Does this mean that
>> somebody is going to have to register after the meeting to be able
>> to watch archived recordings?
>
> No. All sessions will be available on YouTube, likely within a day or
> so after the session.

If you (meetecho) are able to make it available as it is recorded
without any further delay, I can ensure that many TV VOD services will
be interested (first TV archives were week-after, then day-after, and
recently hour-after).

People in the room, but behind language fences, too can take advantage
of such an immediate archive.  Oftentimes they dont understand at first
what's said, but have connected equipment at hand such as laptop
computers and cameras - ability to replay the last 3 seconds, or so, can
enhance their participation experience, and not last relieve the scribe
efforts.

The network supports it.

Alex

>
>> That doesn't seem correct.  If it's not correct, why does someone
>> have to register to passively watch a session?
>
> All onsite attendees register, even those who passively watching a
> session.  It will also provide an opportunity to survey remote
> attendees to improve the service.
>
>> Will the standalone audio streams still be available during
>> sessions?
>
> Yes, no changes there.
>
> Ray
>>
>> Melinda
>>
>
>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 1 Apr 2016 11:12:49 +0100

John,

On 01/04/16 01:28, John C Klensin wrote:
> However, I think
> there has been a significant breach of community norms and
> expectations about openness, consultation, and transparence. 

I agree that requiring registration of remote attendees
without having announced that was a mistake.

I agree with those who've said that it might be reasonable
to require remote attendees who want to be in the meetecho
queue-thing to have registered. But even so, that ought be
a thing gets announced ahead of time. Personally I doubt
that such registration is really needed even for the queue
thing, but I'm willing to believe there may be an anti-DoS
benefit there somewhere. That one can ask questions in the
jabber room without registering for the IETF meeting is IMO
just fine.)

So yeah, I think someone (I dunno who) made a mistake. I
expect it's not fixable for this meeting, but can be fixed
for next time.

Having an easier registration experience for those who do
want to register as remote attendees is also something to
fix.

>  I
> also don't know if that failure was by "the community selected
> committee members" or if some staff member is making decisions
> without adequate supervision, but it is a problem either way and
> I hope that whomever is involved will take the situation
> seriously, explain the source or reason for the disconnect to
> the community, and evaluate (along with the community) whether
> they really want to do whatever job they are doing.

That last is just over-reaction and nowhere near justified. I
figure someone made a smallish mistake, nobody died, it can be
and will be fixed. IMO taking the situation seriously requires
us to not over-react in such ways.

Cheers,
S.

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 Apr 2016 11:47:23 -0400

--On Friday, April 01, 2016 11:12 +0100 Stephen Farrell
<[email-masked]> wrote:

>...

See below.  However, some of this (and my reaction) is OBE given
Tobias's note, so I'll save a longer and more detailed response
for another time.
 
> jabber room without registering for the IETF meeting is IMO

To reprise part of the discussion the last time the community
discussed this, there are IPR and (while the IETF continues to
ignore them and hope there will never be a problem)
competitiveness/ antitrust issues that suggest that we should,
to the extent possible, know who is participating in and
influencing our decisions (see the recent threads about IPR/Note
Well revisions).   That point of view suggests registration for
Jabber participants too.  There are tradeoffs with that line of
reasoning (presumably including those that cause your doubts),
but they are exactly why an open community discussion is needed.

> expect it's not fixable for this meeting, but can be fixed

See below.  Because of the tradeoffs, I'm less worried about
what the decision is than that we discuss it openly and
carefully.

> want to register as remote attendees is also something to

As Dave Crocker pointed out, fine-tuning the details is a
different problem and something we can improve as we go along.
Certainly I would have preferred that things have been
sufficiently thought out to get them closer to right the first
time, but so it goes.  On the other hand, it is clearly the
IAD's and IAOC's responsibility to be sure that a change is
really ready before deploying it.  As Tobias acknowledges, that
didn't work this time.

>> without adequate supervision, but it is a problem either way
>> and I hope that whomever is involved will take the situation

> us to not over-react in such ways.

Well, maybe. I think we should probably defer the rest of this
discussion until Tobias gets to BA and is able to consider the
situation and explain in more detail.  However, I recall a long
series of difficulties with the IASA failing to come up to
expectations for transparency and disclosure that seemed very
clear when BCP 101 was deployed.  That pattern can't be blamed
on Tobias because it started long before he go onto the IAOC.
However, I believe that every IAOC member appointed by the IETF
community has two sets of responsibilities -- to be sure the
administrative side of things is run properly and responsibly
and to operate a transparent process with the community kept
informed and that is responsive to community discussions and
conclusions.   

It is a huge oversimplification, but, whether we are talking
about this issue with changes in registration policy, questions
about meeting site selection and criteria, late and/or
uninformative minutes, posting of contracts, or other issues, it
appears to me that there has been enough of a pattern that it
really is time for IAOC members to carefully examine whether
they, and the people and systems for whom they are responsible,
are really as committed to the transparency, openness,
consultation, and responsiveness of their role as they are to
simple prudent financial management... and for the community to
start requiring that they be accountable if IASA behavior is not
consistent with those principles.

If you think _that_ is an overreaction, I suppose we will just
have to disagree.

    best,
     john

---

From: Jari Arkko <[email-masked]>
Date: Fri, 1 Apr 2016 13:12:58 -0300

For what it is worth, I do think changing the registration requirement without discussion or even an announcement was a mistake. I’m sorry.

I do have a personal opinion in this topic, and it is that just like in the physical meeting, I mostly want to know who I am talking to. That shouldn’t be a hard requirement, however, just like it isn’t in, say, list discussion. And I certainly agree that when you are only observing there’s even less requirement to do so. However, this is a complex matter involving, for instance, IPR, note wells, ability to get feedback from participants, understand who participates in the IETF, possibly an evolving IETF meeting fee model (see draft-arkko-ietf-trends-and-observations), privacy, and probably a few other aspects as well.

I think we should have that discussion (again, but the world is evolving), and see where we end up. And the above was just my opinion, I’m sure we’ll have other opinions.

In the meantime (and with most of my leadership team members on airplanes), I’ve asked if we can change the requirement to a recommendation, and no longer require registration. Meetecho is working on it. Also, the secretariat  is changing the registration page so that it doesn’t ask unnecessary questions from remote participants from those that want to register.

Overall IAOC transparency question is worth another thread, I think.

Jari

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 Apr 2016 13:25:24 -0400

Jari,

Many thanks, both for your note generally and for the request to
undo the registration requirement for this meeting if that is
possible.   Given that and as the person whose outrage at the
situation touched off these threads, I'd like to suggest that we
dial back the discussion now and trust Jari (and, as
appropriate, Tobias) to organize a more focused discussion as
soon as they consider appropriate and feasible.  

Unfortunately, it sometimes does require a mistake and
mini-crisis to bring fundamental issues to the front of the
queue.

thanks again,
    john

--On Friday, April 01, 2016 13:12 -0300 Jari Arkko
<[email-masked]> wrote:

> For what it is worth, I do think changing the registration
> requirement without discussion or even an announcement was a
> mistake. I'm sorry.
> 
> I do have a personal opinion in this topic, and it is that
> just like in the physical meeting, I mostly want to know who I
> am talking to. That shouldn't be a hard requirement,
> however, just like it isn't in, say, list discussion. And I
> certainly agree that when you are only observing there's
> even less requirement to do so. However, this is a complex
> matter involving, for instance, IPR, note wells, ability to
> get feedback from participants, understand who participates in
> the IETF, possibly an evolving IETF meeting fee model (see
> draft-arkko-ietf-trends-and-observations), privacy, and
> probably a few other aspects as well.
> 
> I think we should have that discussion (again, but the world
> is evolving), and see where we end up. And the above was just
> my opinion, I'm sure we'll have other opinions.
> 
> In the meantime (and with most of my leadership team members
> on airplanes), I've asked if we can change the requirement
> to a recommendation, and no longer require registration.
> Meetecho is working on it. Also, the secretariat  is changing
> the registration page so that it doesn't ask unnecessary
> questions from remote participants from those that want to
> register.
>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 1 Apr 2016 19:31:11 +0100

> Overall IAOC transparency question is worth another thread, I think.

I reckon I do agree with you and John on that. It's pretty
easy for well intended folks to end up not being transparent
and well worth spending a bit of time/effort on seeing if
we can match current expectations met elsewhere whilst also
being efficient with all the myriad of IAOC stuff that is being
done well.

S.