Subject: Concerns about Singapore

From: Jari Arkko <[email-masked]>
Date: Thu, 7 Apr 2016 12:31:20 -0300

Ted,

As you’ve seen from Leslie’s message, the IAOC has taken very seriously the concerns you expressed in the plenary about Singapore.

I think we all thought we were sensitive to these types of issues, but clearly we weren’t. Sorry.

I know that I am personally still in the education phase about the situation. But I wanted to follow-up with two points from an IETF perspective. First, the ability of our participants to enter our meetings without concerns is of crucial importance for us. And second, as the IAOC determines in more detail what our options are, I wanted to say that we want to communicate that assessment to the IETF community and work with the community to determine what the best path forward with IETF #100 is.

In addition, the longer term process about explicit documentation of community’s wishes regarding the meetings selection process and requirements is already in progress. The MTGVENUE BOF will be meeting today Thursday at 16:20 in Pacifico A. Everybody, please contribute to that.

Jari Arkko, IETF Chair

---

From: Adam Roach <[email-masked]>
Date: Thu, 7 Apr 2016 14:12:01 -0300

> In addition, the longer term process about explicit documentation of community’s wishes regarding the meetings selection process and requirements is already in progress. The MTGVENUE BOF will be me…

Indeed, venue selection appears to be something people care deeply 
about, for a variety of reasons. I will point out that the current draft 
being discussed later today 
(https://tools.ietf.org/html/draft-baker-mtgvenue-iaoc-venue-selection-process-01) 
does squarely address the issue under discussion in section 3.1, under 
the section marked "Inclusiveness." Selection of venues that exclude 
participation based on sexual orientation is explicitly proscribed by 
name in the existing proposal.

/a

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 7 Apr 2016 14:29:36 -0400

Jari,

On Thu, Apr 07, 2016 at 12:31:20PM -0300, Jari Arkko wrote:
> I know that I am personally still in the education phase about the
> situation. But I wanted to follow-up with two points from an IETF
> perspective. First, the ability of our participants to enter our meetings
> without concerns is of crucial importance for us.

As I'm unclear whether I'll be free for mtgvenue, I'll make my statement
here:

The legal environments of the various countries we consider for venues
obviously must be a general consideration for our selection criteria.  For
most considerations, these are "here are thing you do not do - they are not
legal".

For this particular issue, the consideration is whether the people themselves
are the thing that is illegal.

While I am unclear on the full legal status of lgbt persons as "illegal
people" within the proposed venue, the laws on the books are obviously
unfriendly.  However, I'll note that even countries that contribute a large
number of our participants have laws on their books that may be similarly
negative and yet are generally known to not be enforced.  This includes the
US and India.

I am happy to see that this consideration is being given discussion.

-- Jeff (one of the impacted parties)

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 7 Apr 2016 15:30:42 -0300

+1

I am happy to see that LGBT inclusiveness taken seriously by the IETF. But
looking at the law on the books in black and white, would be doing a
disservice to a large region of the world (with a large number of Internet
users).

Dhruv (Impacted on 2 fronts)

---

From: Leif Johansson <[email-masked]>
Date: Thu, 7 Apr 2016 21:12:00 +0200

On 2016-04-07 20:30, Dhruv Dhody wrote:
> +1 
> 
> I am happy to see that LGBT inclusiveness taken seriously by the IETF.
> But looking at the law on the books in black and white, would be doing a
> disservice to a large region of the world (with a large number of
> Internet users). 

I don't parse that actually.

How is reading the law of Singapore "doing disservice to a large region
of the world?"

I don't think "yes but many who live in Singapore are nice people"
nor "yes but those laws are hardly ever applied" are useful arguments
in this discussion but maybe thats just me...

I am pretty sure that Ted (to pick a random example) would be able to
travel to Singapore for an IETF and be /personally/ quite safe because
as you say the laws of the land would be selectively applied.

That is always the problem of selectively applied laws: they are used
when it is convenient... and are often used to intimidate. That is why
censorship is often self-administered in countries where there are
censorship laws "on the books".

	Cheers Leif

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 7 Apr 2016 16:41:43 -0300

Hi Leif,

> I don't parse that actually.

​Sorry if I was not clear.
​

> How is reading the law of Singapore "doing disservice to a large region

​No, I meant that IETF would be doing a disservice to a large part of the
world (that has on its books these laws). We need to have a nuanced
approach and this being another factor in a multitude of factors. Having a
blanket rule that the IETF will not go to any such place is something
I disagree with.

> censorship laws "on the books".

​I agree with you. I understand this well, as an openly gay person, living
in a country with such laws​ on the book.
I hope these laws go away but till then, having a blanket rule against
taking IETF to a big part of the world is something I find wrong.

Thanks!
Dhruv

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 7 Apr 2016 15:44:59 -0400

> How is reading the law of Singapore "doing disservice to a large region

I think the idea is that a literal interpretation of archaic laws in
many places would give you a wrong impression.

Let me give a small example. I assume most of the attendees at this
meeting flew into Argentina and brought with them at least one laptop
with a vale over $300 USD. It seems there is an Argentine law
requiring you to file a customs declaration on entry and imposing a
50% duty on the value of what you bring in over $300 USD. This seems
somewhat onerous since almost everyone at this meeting has a laptop
worth more than $300. But from my observations as EZE, the Argentina
authorities do not care if you have filled out this form and thousands
of people stream through a day completely ignoring it. The authorities
will take it from you if you filled it out but don't seem to even look
at it very closely... So it seems to be no problem for IETF meeting
attendees.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

>....

---

From: Leif Johansson <[email-masked]>
Date: Thu, 7 Apr 2016 21:51:28 +0200

> ​No, I meant that IETF would be doing a disservice to a large part of
> the world (that has on its books these laws). We need to have a nuanced
> approach and this being another factor in a multitude of factors. Having
> a blanket rule that the IETF will not go to any such place is something
> I disagree with.   
>  
> 

Where do you draw the line then?

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 7 Apr 2016 22:00:40 +0200 (CEST)

> Where do you draw the line then?

I think it's impossible to draw a firm line. Most of it is grey area.

I'm sure I could come up with arguments why we should not go to USA or 
Sweden for our meetings, because neither place if perfect.

There are numerous very "offensive" (or replace with "weird" or some other 
word) laws on the books in most countries, and I do think we have to look 
at how those laws are applied as part of our process in deciding where to 
go.

There are no perfect places to go. There are bad and less bad ones.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 7 Apr 2016 17:08:02 -0300

> On 07 Apr 2016, at 17:00, Mikael Abrahamsson <[email-masked]> wrote:
> 
> I'm sure I could come up with arguments why we should not go to USA or Sweden for our meetings, because neither place if perfect.

Right. And since Leif mentioned censorship, let me note that IETF already held a meeting in a country where censorship, and Internet censorship in particular, is commonplace.

> 
> There are numerous very "offensive" (or replace with "weird" or some other word) laws on the books in most countries, and I do think we have to look at how those laws are applied as part of our process in deciding where to go.

Yes, and speaking of myself, I am prepared, to a reasonable degree, to adjust my behaviour to those laws (and cultural habits as well).

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: David Conrad <[email-masked]>
Date: Thu, 7 Apr 2016 17:20:22 -0300

> ​No, I meant that IETF would be doing a disservice to a large part of the world (that has on its books these laws).

For reference:

http://76crimes.com/76-countries-where-homosexuality-is-illegal/

(haven't verified, but I read it on the Internet so it must be true)

Regards,
-drc

---

From: Melinda Shore <[email-masked]>
Date: Thu, 7 Apr 2016 12:45:00 -0800

I've been thinking quite a bit about that line, and I think that in a lot
of those marginal cases it comes down to questions about public
accommodation and the ability to move freely.  It seems to me that when
there's a legitimate question about whether or not our participants will be
able to check into a meeting hotel with his or her family, were have a
problem that goes beyond individual conscience.

Melinda

---

From: Leif Johansson <[email-masked]>
Date: Thu, 7 Apr 2016 22:48:49 +0200

> I think it's impossible to draw a firm line. Most of it is grey area.

there are some things none of us would be ok with I think

finding endless examples of "yeah but what about laws against jaywalking
over here in Podunk" doesn't help as we are trying to determine what is
clearly beyond the pale.

> Sweden for our meetings, because neither place if perfect.

prove it :-)

---

From: Laurent Ciavaglia <[email-masked]>
Date: Thu, 7 Apr 2016 23:19:38 +0200

On 07/04/2016 22:00, EXT Mikael Abrahamsson wrote:
> There are no perfect places to go.
Except Minneapolis. ;)

-- Laurent.

---

From: Leif Johansson <[email-masked]>
Date: Thu, 7 Apr 2016 18:22:13 -0300

Skickat från min iPhone

> 7 apr. 2016 kl. 18:19 skrev Laurent Ciavaglia <[email-masked]>:
> 

+1

---

From: Laurent Ciavaglia <[email-masked]>
Date: Thu, 7 Apr 2016 23:22:56 +0200

On 07/04/2016 22:48, EXT Leif Johansson wrote:
[...]
>> Sweden for our meetings, because neither place if perfect.

death penalty.
firearm death rate.
D. Trump

--Laurent.

---

From: Jared Mauch <[email-masked]>
Date: Thu, 7 Apr 2016 17:23:47 -0400

> On Apr 7, 2016, at 5:22 PM, Leif Johansson <[email-masked]> wrote:
> 

lutefisk availability is the tie breaking criteria for mtgvenue?

---

From: Yoav Nir <[email-masked]>
Date: Thu, 7 Apr 2016 18:24:35 -0300

>> Sweden for our meetings, because neither place if perfect.

Here’s a picture of Swedish Minister for Culture Lena Adelsohn Liljeroth cutting a cake:

http://assets.vice.com/content-images/contentimage/no-slug/4d991c394e90d21b560107314ce36105.jpg

What do I win?

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 7 Apr 2016 23:27:54 +0200

+1

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 18:33:36 -0400

>> There are no perfect places to go.

If it were, the frequency with which we have been back there in
recent years might act as confirmation of the maxim that the
perfect is the enemy of the good.   I assume there are other
reasons, perhaps even better ones.

   john

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Apr 2016 18:56:55 -0400

Hi.

Thinking about Pete's comments (with which I agree), and some
other comments made late in the BOF, an observation:

There are lots of places in the world with archaic laws
affecting personal behavior and relationships that we generally
find unacceptable.  In some of those places, they are not
enforced, have not been enforced for decades (or much longer),
and it is clear that any attempt to enforce them would result in
political outrage even though it is hard to get rid of them.  In
other places, they either are enforced or their enforcement is
only a matter of a small shift in the political winds or some
politician or lae enforcement entity looking for an excuse to
harass an individual or group.

Places where the problem is tied to laws or rules created
recently have to be treated as part of the second group, at
least until a _lot_ of experience accumulates.

The two cases may be hard to distinguish from a distance, but
they are very different.  In the first case, we might well want
to avoid meeting there, and make a statement about our reasons
for doing so, in order to join with others to create economic of
social pressure for change.  Or we might want to deliberately go
there in order to be supportive of local communities.  Getting
that choice right depends on input from people who are local and
listening to that input very carefully.  IMO, it is also a
decision that should be made openly and in consultation with the
IETF community and not in secret by a non-transparent IAOC
and/or Meetings Committee, both because that is the right thing
to do and because whatever message we want to deliver is likely
to be much more effective if it has clear community support.

The second, especially if it puts members of our community (or
anyone who attends with them) at risk of criminal or other types
of harsh treatment, falls into Pete's category that I would
describe as "don't even think about it" (at least I hope that is
consistent with his remarks).  I actually have mixed feelings
about Ted's suggestion that everyone else leave their families
home too.  On the one hand, it would help make a point and
spread the pain around.  On the other, it would seem a far
better option for everyone who is concerned about the problem
--and everyone who can be educated enough between now and
meeting 100 to care-- to stay home and participate remotely.  If
that were to wreck the budget or cause other real pain to either
the venue or the IAOC, I think we could at least be assured that
it wouldn't happen again.   But I really hope that we can make
whatever changes are needed to prevent us from _ever_ getting to
that point.

Note that I have not expressed an opinion above about whether
Singapore, or anywhere else that we are scheduled to go or might
contemplate, falls into the first category, the second, or, in
other cases, neither.  I don't have enough information, someone
local has said what amounts to "first category" and I think we
need to put some community effort into figuring that out.
What upset me is that the situation there caught us by surprise
but I think we need to move past that, figure out what to do
about that meeting, and, most important, make sure we learn from
the situations, both in terms of not repeating mistakes and
about the value of sufficient transparency that the IAOC can
obtain and take advantage of community knowledge.

    john

---

From: Ted Lemon <[email-masked]>
Date: Thu, 7 Apr 2016 20:10:05 -0300

Supposedly we never have very good attendance in Minneapolis because it
doesn't pull in tourists. :)

---

From: Dave Crocker <[email-masked]>
Date: Thu, 7 Apr 2016 16:18:45 -0700

On 4/7/2016 3:56 PM, John C Klensin wrote:
> they are very different.

I'm going to suggest that, in practical terms for the IETF, it doesn't 
matter.

It doesn't matter because none of the theory or formal issues can be 
reliably and accurately applied for issues of social concern.

What matters is whatever the community decides it cares about at the 
time we are looking at the area.

Here's my logic:

    While some regions -- especially Asia -- have been challenging for 
finding venues, we already have an extensive track-record of finding 
places the community deems acceptable.  Consequently, we have safe 
harbors to fall back on, for each of the 3 regions we regularly visit.

    So when a new country or city is being considered -- and by new, I 
think I mean 'we have never been there', but perhaps we need to leave 
room for reconsideration of previously-visited places? -- we float the 
general countries and maybe cities to the community and wait for support 
and objections.

Whatever criteria the community chooses to apply at that time are the 
relevant criteria.  No theory or modeling or documentation or even 
consistency -- and especially no guessing and no errors by an anointed 
body -- are required.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Ted Lemon <[email-masked]>
Date: Thu, 7 Apr 2016 20:21:22 -0300

I was a little puzzled to hear that Yokohama didn't meet the food
requirements, by the way.   I ate more than half my meals from the
excellent nearby grocery store.   Would like to go back there agian!

On Thu, Apr 7, 2016 at 8:18 PM, Dave Crocker <[email-masked]> wrote:

> What matters is whatever the community decides it cares about at the time
> we are looking at the area.
>
>
> Here's my logic:
>
> finding venues, we already have an extensive track-record of finding places
> the community deems acceptable.  Consequently, we have safe harbors to fall
> back on, for each of the 3 regions we regularly visit.
>
> think I mean 'we have never been there', but perhaps we need to leave room
> for reconsideration of previously-visited places? -- we float the general
> countries and maybe cities to the community and wait for support and
> objections.
>
>
> consistency -- and especially no guessing and no errors by an anointed body
> -- are required.
>
>
> d/
>
> --
>
>   Dave Crocker

---

From: Randy Bush <[email-masked]>
Date: Thu, 07 Apr 2016 22:18:15 -0300

> D. Trump

add difficulty of getting visas for many folk

randy

---

From: Leif Johansson <[email-masked]>
Date: Fri, 8 Apr 2016 03:25:32 +0200

>>> Sweden for our meetings, because neither place if perfect.

I was talking about Sweden :-)

We just watch the shamu show from our side of the atlantic

---

From: Leif Johansson <[email-masked]>
Date: Fri, 8 Apr 2016 03:31:47 +0200

> http://assets.vice.com/content-images/contentimage/no-slug/4d991c394e90d21b560107314ce36105.jpg

she got voted out so you could hire her off of the ex-politician
consultant pool

---

From: Christian Hopps <[email-masked]>
Date: Thu, 7 Apr 2016 23:58:41 -0400

> On Apr 7, 2016, at 4:08 PM, Ladislav Lhotka <[email-masked]> wrote:
> 

I actually did not attend that meeting for this very reason. I am very proud to be a part of IETF and the open and inclusive process in which we work. I found it very odd, and disheartening that this site was chosen, and skipped it in protest.

Chris.

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 8 Apr 2016 06:57:43 -0300

> On 07 Apr 2016, at 22:45, John G. Scudder <[email-masked]> wrote:
> 
> On Apr 7, 2016, at 5:08 PM, Ladislav Lhotka <[email-masked]> wrote:
> It's wonderful for you if you are always able to do so. Not everyone has that luxury. I don't think I can say this better, so I'll

I didn't say I am always able to do so. For example, if Canada (again) introduced visa for Czech citizens, I won't go there. 

>  just quote:
> 
> On Apr 7, 2016, at 3:29 PM, Jeffrey Haas <[email-masked]> wrote:

I haven't studied the Singapore laws, but the US State Department summary says:

   The Penal Code criminalizes any “act of gross indecency” ...

which I understand as behaviour, not people themselves.

Lada

> --John

---

From: <[email-masked]>
Date: Fri, 8 Apr 2016 10:38:11 +0000 (UTC)

On a positive note:

Pope Francis urges greater acceptance of homosexuals, non-traditional families  
http://edition.cnn.com/2016/04/08/europe/vatican-pope-family/index.html?adkey=bn
 
Thanks,

Nalini Elkins
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

________________________________
From: Dhruv Dhody <[email-masked]>
To: Leif Johansson <[email-masked]> 
Cc: "[email-masked] Discussion" <[email-masked]>
Sent: Thursday, April 7, 2016 12:41 PM
Subject: Re: Concerns about Singapore

Hi Leif, 

>How is reading the law of Singapore "doing disservice to a large region

​No, I meant that IETF would be doing a disservice to a large part of the world (that has on its books these laws). We need to have a nuanced approach and this being another factor in a multitude of factors. Having a blanket rule that the IETF will not go to any such place is something I disagree with.   

>censorship laws "on the books".

​I agree with you. I understand this well, as an openly gay person, living in a country with such laws​ on the book. 
I hope these laws go away but till then, having a blanket rule against taking IETF to a big part of the world is something I find wrong. 

Thanks! 
Dhruv

---

From: Yoav Nir <[email-masked]>
Date: Fri, 8 Apr 2016 07:45:33 -0300

> On 8 Apr 2016, at 7:38 AM, <[email-masked]> <[email-masked]> wrote:
> 
> On a positive note:
> 

That’s fine, but I don’t think the Vatican has a good venue for us. :-)

Yoav

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 08 Apr 2016 04:20:25 -0700 (PDT)

I found this website very interesting in terms of what to expect on
the ground in Singapore with respect to the issue at hand:

http://www.utopia-asia.com/tipssing.htm

Ole

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office:  +1 415-550-9433
Cell:    +1 415-370-4628
docomo: (090) 3337-9311
Web: protocoljournal.org
E-mail: [email-masked]

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 8 Apr 2016 13:20:21 +0200 (CEST)

>> There are no perfect places to go.

http://www.dumblaws.com/laws/united-states/minnesota

"It is illegal to sleep naked."
"Oral sex is prohibited."

---

From: Jari Arkko <[email-masked]>
Date: Fri, 8 Apr 2016 08:22:00 -0300

>   So when a new country or city is being considered -- and by new, I think I mean 'we have never been there', but perhaps we need to leave room for reconsideration of previously-visited places? -- we float the general countries and maybe cities to the community and wait for support and objections.
> 
> 
> Whatever criteria the community chooses to apply at that time are the relevant criteria.  No theory or modeling or documentation or even consistency -- and especially no guessing and no errors by an anointed body -- are required.

This would certainly work for me. There is obviously the question of calling what the result of the community discussion is, but I would view the community discussion as informing the decision by the meetings committee and the IAOC, i.e., the purpose of the crowdsourcing is to uncover issues that a smaller set of people might not catch, and then we have a better basis for the final decision.

(Speaking personally, not representing IAOC or other opinions.)

Jari

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 08 Apr 2016 04:28:18 -0700 (PDT)

On Thu, 7 Apr 2016, Christian Hopps wrote:

> I actually did not attend that meeting for this very reason. I am 
> very proud to be a part of IETF and the open and inclusive process 
> in which we work. I found it very odd, and disheartening that this 
> site was chosen, and skipped it in protest.
> 
> Chris.
> 

Christian,

I am sorry to hear that. Our "open and inclusive process" comprises 
many participants from China who have traditionally faced harsh and 
unpredictable visa problems in North America. In fairness to them, we 
held that meeting in Beijing. Note that we did so following an 
extensive discussion on the IETF mailing list and after negotiating 
the removal of a rather ominous hotel clause, as well as an unfiltered
network in the meeting venue.

I will just add that "engagement" is often seen as a better strategy
than "boycott" in many circles, but we don't need to have that debate
here and now :-)

Ole

---

From: Anne-Marie Eklund-Löwinder <[email-masked]>
Date: Fri, 8 Apr 2016 11:28:48 +0000

> -----Ursprungligt meddelande-----
> Från: ietf [mailto:[email-masked]] För Mikael Abrahamsson
> Skickat: den 8 april 2016 13:20
> Till: Laurent Ciavaglia <[email-masked]>
> Kopia: [email-masked] Discussion <[email-masked]>
> Ämne: Re: Concerns about Singapore
> 

Well, if you start to dance spontaneously on a restaurant in Sweden you are in trouble. It's a law against that.
If guests start spontaneous dance in a tavern or bar without dance permission the owners must stop that at once, otherwise the owner will get a fine. Most recently in November 2014 a tavern in the city of Gävle got a warning after the police had secretly filmed guests that moved suspiciously to the music.

The law is from the 1920ies or so. No one bothered to change it.

Anne-Marie

Anne-Marie Eklund Löwinder
Chief Information Security Officer, IIS
Direct: +46 8 452 35 17 | Mobile: +46 734 31 53 10 | https://www.iis.se/en/
[email-masked]  | @amelsec

---

From: Dirk-Willem van Gulik <[email-masked]>
Date: Fri, 8 Apr 2016 13:33:19 +0200

> On 08 Apr 2016, at 13:20, Mikael Abrahamsson <[email-masked]> wrote:
> 
> "Oral sex is prohibited.”

Speaking of Minneapolis and the 40something IETF there - around 98 or 99; before EAR was changed - and I had to travel to a country with laws so arcane that it regulated cryptography.  And being asked to justify why on earth one could not do IETFs in safe & sensible countries.

Dw.

---

From: Paul Wouters <[email-masked]>
Date: Fri, 8 Apr 2016 09:26:59 -0300

> On Apr 8, 2016, at 07:45, Yoav Nir <[email-masked]> wrote:
> 
> 

But we could adopt the Conclave model of decision making! 

Paul

---

From: "Patrik Fältström" <[email-masked]>
Date: Fri, 08 Apr 2016 14:31:43 +0200

> The law is from the 1920ies or so. No one bothered to change it.

This legislation is now to be removed.

The parliament of Sweden is discussing the issue on April 14 2016.

   paf

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Apr 2016 09:32:29 -0400

> Right. And since Leif mentioned censorship, let me note that IETF
    > already held a meeting in a country where censorship, and Internet
    > censorship in particular, is commonplace.

yes, we tried that.  My impression is that there were two changes we made,
one was known in advance (closed network), the other was unknown (badges
being checked).
I'm not sure we were happy with either result.  I didn't go to Beijing.

    > Yes, and speaking of myself, I am prepared, to a reasonable degree, to
    > adjust my behaviour to those laws (and cultural habits as well).

I'm pretty sure that I won't make it for simple reasons of economy.
I think it's a pretty expensive city, and I'm not clear that there are
three-star options.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 8 Apr 2016 09:39:14 -0400

> than "boycott" in many circles, but we don't need to have that debate

This also covers much of my opinion.  In the absence of outright impact to
safety, it's better to engage.  Such engagement might imply an inquiry by
the IETF (potentially via either IAOC, IAB or whatever portion of IETF
"management" is deemed appropriate) to the host government as to the
concerns of the IETF for the welfare of its membership.

Laws and social norms shift at speeds even slower than our RFC process.  But
similarly, legal consensus is shaped by participation.  "We're concerned,
could you please clarify" may help refine the opinion of the host government
while simultaneously clarifying membership welfare issues.

-- Jeff

---

From: Ted Lemon <[email-masked]>
Date: Fri, 8 Apr 2016 10:53:48 -0300

There is another side to this, although I don't disagree with either of you
on the China observation.

The other side is this: it's tempting to say that since in the U.S. up
until recently, gay rights weren't a thing, and yet we held meetings in the
U.S., the same should apply elsewhere.   However, consider this: until
fairly recently, in the United States, if your spouse happened to be the
same sex, and got ill, or if a child got ill, there was a very, very real
chance that you would not only be excluded from making decisions about
their health options, you might be prevented from even being in the same
room with them.

This was something we tolerated in meeting venues because we didn't really
have a choice until fairly recently, other than simply restricting our
meetings to Europe and perhaps some parts of Asia.

Now that this is no longer an issue at least legally in the U.S., it would
be a backslide to go to a place where it still is an issue, even though we
tolerated this risk in the past.   I am fortunate enough to be married to
someone for whom this risk does not exist for me at present (although it
would have in the past, since she is from a different religious heritage
than I).   It breaks my heart to hear stories of the horror that gay
couples have gone through because of discrimination of this sort and other
sorts.   I am not okay with being party to that happening in the future.

I agree that engagement is important, but let us bear in mind the risks we
are asking our friends and colleagues to bear when we have this discussion.

---

From: Stefan Winter <[email-masked]>
Date: Fri, 8 Apr 2016 11:07:58 -0300

Hi,

> There are no perfect places to go. Except Minneapolis. ;)

Too many LGBT unfriendlies there as well, it seems. For some reason, I
get what I consider spam, but others might not about "Minnesota for
Marriage". Luckily, their website is currently down for maintenance. And
I don't think anyone wants or the content warrants a forward of their
pamphlets.

Stefan

---

From: Andrew Allen <[email-masked]>
Date: Fri, 8 Apr 2016 14:30:28 +0000

Only goes to show that all laws should have a time to live timer value!

Sent from my BlackBerry 10 smartphone.
  Original Message
From: Patrik Fältström
Sent: Friday, April 8, 2016 09:32
To: Anne-Marie Eklund-Löwinder
Cc: [email-masked] Discussion
Subject: Re: Concerns about Singapore

   paf

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Apr 2016 10:38:56 -0400

> network in the meeting venue.

Yes, and we did this openly, and I don't feel we did the same thing here.
And there were still surprises, I'm told.

I was very surprised at the announcement for 100.
I kinda thought we should go back to San Diego as for IETF 1.
(well. Maybe IETF101 should be same as IETF 1... maybe IETF 100 should be
same as IETF 0, and be entirely virtual...)

(I didn't go because I generally have funds for two IETFs a year,
and given the hassle, and my concerns about what I would eat, it was simpler
to skip.  I skipped BA for a combination of economic, but primarily family reasons)

---

From: "Toerless Eckert (eckert)" <[email-masked]>
Date: Fri, 8 Apr 2016 14:40:55 +0000

There is a difference between regulating behavior for everyone equally and regulating it selectively based on who you are - and can not or should not need to change.

Sent from my Samsung Captivate Glide on AT&T

Mikael Abrahamsson <[email-masked]> wrote:

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Apr 2016 10:43:42 -0400

> http://www.utopia-asia.com/tipssing.htm

An interesting read.

I think you have been there a few times?
Could a person stay in Skudai (Malaysia), and travel in every day for our meetings?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Dave Crocker <[email-masked]>
Date: Fri, 8 Apr 2016 07:46:48 -0700

> Could a person stay in Skudai (Malaysia), and travel in every day for our meetings?

That's a suburb of Johor, just into Malaysia from Singapore, so I 
believe the answer is yes, though I don't know what the transit times 
will be or whether it's a fully reliable path.  The two countries 
sometimes make that border awkward.

d/

-- 

   Dave Crocker

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 8 Apr 2016 11:45:23 -0300

+1

ray
> On Apr 8, 2016, at 8:22 AM, Jari Arkko <[email-masked]> wrote:
> 
>

---

From: Andrew Allen <[email-masked]>
Date: Fri, 8 Apr 2016 15:05:14 +0000

According to the Web link posted earlier Malaysia has similar laws.

Sent from my BlackBerry 10 smartphone.
  Original Message
From: Dave Crocker
Sent: Friday, April 8, 2016 11:47
To: Michael Richardson; Ole Jacobsen
Reply To: [email-masked]
Cc: [email-masked] Discussion
Subject: Re: Concerns about Singapore

d/

--

   Dave Crocker

---

From: Scott Bradner <[email-masked]>
Date: Fri, 8 Apr 2016 11:14:33 -0400

some on the IAOC wanted to go back to SD for IETF 100 but the facilities were not available 
at the right time

Scott

> On Apr 8, 2016, at 10:38 AM, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: Yoav Nir <[email-masked]>
Date: Fri, 8 Apr 2016 12:30:59 -0300

And I can’t enter Malaysia at all.

> On 8 Apr 2016, at 12:05 PM, Andrew Allen <[email-masked]> wrote:
>

---

From: Tim Chown <[email-masked]>
Date: Fri, 8 Apr 2016 16:34:41 +0100

> some on the IAOC wanted to go back to SD for IETF 100 but the facilities were not available 

Ah, I was expecting the plenary drumroll to reveal just this - IETF100 at San Diego. 

A shame it couldn't happen, but perhaps an indicator we do need to keep planning 3-4 years out.

And for the right venue, we should be able to slide the dates forwards/back a week or two. 

Tim

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 8 Apr 2016 12:50:53 -0300

Tim,

> On Apr 8, 2016, at 12:34 PM, Tim Chown <[email-masked]> wrote:
> 

We aggressively pursued venues in San Diego, including the possibly of shifting dates before 
and after the scheduled calendar dates.  The rule is we don’t change those dates, but there
was a willingness to consider that for IETF 100.  

San Diego is one of the most popular venues in the US, so it turned out that around our dates 
there were already city-wide events that made it impossible to secure a venue and necessary 
overflow hotels.

Ray

---

From: Mary Barnes <[email-masked]>
Date: Fri, 8 Apr 2016 11:01:26 -0500

> to skip.  I skipped BA for a combination of economic, but primarily family
[MB] You would have had no concerns whatsoever about what to eat in
Beijing.  I ended up with basically a private chef (Chef Eric) who I would
ask for when I went to eat at the hotel restaurant and he would prepare
whatever I wanted (gluten free). Although, I honestly have no desire
whatsoever to go back to Beijing due to the air quality - we got really
lucky the week we were there - you could actually see mountains.[/MB]

---

From: [email-masked] (Martin Rex)
Date: Fri, 8 Apr 2016 18:38:05 +0200 (CEST)

Anne-Marie Eklund-Löwinder wrote:
> 
> Well, if you start to dance spontaneously on a restaurant in Sweden
> you are in trouble. It's a law against that.
> 

IETF 83rd was in Paris, France, March 25-30, 2012

At that time there still was a law on the books that women
walking in public in Paris in trousers/pants (rather than dress or skirt)
could be taken into custody by the police.

http://www.telegraph.co.uk/news/worldnews/europe/france/9845545/Women-in-Paris-finally-allowed-to-wear-trousers.html

Did any women wearing pants in public during IETF 83rd in Paris
got taken into custody by the police?

-Martin

---

From: Dave Crocker <[email-masked]>
Date: Fri, 8 Apr 2016 10:34:22 -0700

> And I can’t enter Malaysia at all.

In practical terms, that's mostly correct.  In formal terms, it's not.

The Meetings Committee looked carefully at Malaysia's formal 
requirements for an Israeli to get a Visa.  There /is/ a procedure.  But 
it's quite onerous and far beyond anything we felt tolerable for an IETF 
meeting.

However I also know of cases in which the MY gov't has expedited access 
for Israelis, but it was a special and big deal and, again, 
inappropriate for the IETF to pursue, IMO.

d/

-- 

   Dave Crocker

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 8 Apr 2016 16:15:15 +0000

I stayed the week after the Beijing meeting. The day we left was the first day the air quality measures went off the charts for the instruments that were being used at that time. I was disappointed by how windy it was the day we went to the Forbidden City, but later decided that it was a really good thing because the air quality was so much better.

Tony

From: ietf <[email-masked]<mailto:[email-masked]>> on behalf of Mary Barnes <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 8, 2016 at 12:01 PM
To: Michael Richardson <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]> Discussion" <[email-masked]<mailto:[email-masked]>>
Subject: Re: China

MB] … Although, I honestly have no desire whatsoever to go back to Beijing due to the air quality - we got really lucky the week we were there - you could actually see mountains.[/MB]

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 08 Apr 2016 10:50:26 -0700 (PDT)

> And I can’t enter Malaysia at all.

Not completely true, but the obstacles to entry are unfairly high
for your one country which is why we have no plans to go there until
that process is fully streamlined etc, and yes, we would ask the
community first :-)

Ole

---

From: David Morris <[email-masked]>
Date: Fri, 8 Apr 2016 11:08:51 -0700 (PDT)

I understand from a family memember who made that crossing multiple times
recently, a 3 hour delay is not unusual.

On Fri, 8 Apr 2016, Dave Crocker wrote:

> That's a suburb of Johor, just into Malaysia from Singapore, so I believe the
> answer is yes, though I don't know what the transit times will be or whether
> it's a fully reliable path.  The two countries sometimes make that border
> awkward.
>
> d/
>
> --
>
>   Dave Crocker
> ----------
> This email has been scanned for spam and viruses by Proofpoint Essentials.
> Visit the following link to report this email as spam:
> https://us1.proofpointessentials.com/index01.php?mod_id=11&mod_option=logitem&mail_id=ZYUcyKuA1vKX&rid=113885848&report=1
>

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 08 Apr 2016 11:10:58 -0700 (PDT)

On Fri, 8 Apr 2016, Ted Lemon wrote:

> There is another side to this, although I don't disagree with either 
> of you on the China observation.

[snip] 

> It breaks my heart to hear stories of the horror that gay couples 
> have gone through because of discrimination of this sort and other 
> I agree that engagement is important, but let us bear in mind the 
> risks we are asking our friends and colleagues to bear when we have 
> this discussion.
> 

Right, well I have heard those stories too, but I have not heard them 
in relation to visitors in Singapore. If you look at the statements
on the US State Department website, there is, as has been pointed out,
a section regarding LGBT laws and practices. The absense of warnings
related to medical care does of course neither mean that it isn't
potentially a problem nor that we should not investigate this further.

I know that this is going to sound like an excuse and it certainly 
isn't meant to be, we did miss this topic and we should have brought
it to the community for review. However, the fact that this issue
has not been "flagged" by sister organizations such as ICANN (4 
meetings in Singapore) and APRICOT (2 meetings) at least suggests
that it isn't a frequently encountered problem. 

Ole

---

From: Melinda Shore <[email-masked]>
Date: Fri, 8 Apr 2016 10:17:32 -0800

> that it isn't a frequently encountered problem.

Might be a lot more informative to talk to glbt travel specialists.
Why that may not have crossed the mind of the IAOC that this may be a
useful thing to do is left as an exercise, &c.

Melinda

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 08 Apr 2016 11:24:02 -0700 (PDT)

> useful thing to do is left as an exercise, &c.

Point taken and I am sure that is one of the many lessons we have 
learned from this process.

Ole

---

From: Melinda Shore <[email-masked]>
Date: Fri, 8 Apr 2016 10:53:46 -0800

> learned from this process.

Also, I think it's almost certainly the case that any large company
has someone in their travel office who's looked at this issue (and
related ones), and that it might be worth trying to engage one of those
folks first.

Melinda

---

From: Michael Richardson <[email-masked]>
Date: Fri, 08 Apr 2016 15:48:35 -0400

> According to the Web link posted earlier Malaysia has similar laws.

Yes, I wasn't suggesting it because of laws, but rather because I thought it
might have a larger variety of price ranges in hotels.

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 7 Apr 2016 22:45:14 -0300

> Yes, and speaking of myself, I am prepared, to a reasonable degree, to adjust my behaviour to those laws (and cultural habits as well).

It's wonderful for you if you are always able to do so. Not everyone has that luxury. I don't think I can say this better, so I'll just quote:

--John

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 08 Apr 2016 13:19:14 -0700 (PDT)

Michael,

Check your favorite hotel booking site. There are plenty of
reasonable hotels in Singapore, and it is a small city with
very good and very inexpensive transportation options including
a metro system and reasonable taxis.

I have only one real complaint: it's too hot and humid for my
liking, but then again I could also describe Singapore as a
very large air-conditioned shopping center disguised as a country :-)

Ole

Ole J. Jacobsen
Editor and Publisher

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 8 Apr 2016 20:57:19 +0000

Hi,

[This note is sent as part of the Facilitators experiment, to maximize the effectiveness of discussions at the IETF-Discussion mailing list]

As this thread started with the concerns express during the plenary about Singapore as a meeting venue, I wanted to summarize the arguments, and refocus and redirect the discussion:

Several details on both the letter and the practicality of the Singapore law that discriminates agains LGBTQ, and its implications, followed these community-expressed concerns. A number of suggestions, recommendations, and additional pieces of information about other countries and locations were also shared.

The IAOC and its Meetings Committee acknowledged the issue, and shared a two-point plan at [1].

Meeting venue selection and its associated criteria is naturally a relevant and most important topic for the community. At this point, the most effective channel for providing input and discussion is at the MTGVENUE mailing list [2] [3], following the MTGVENUE BoF. That would ensure feedback and requirements are appropriately captured.

Thanks!

— Carlos.

[1] https://mailarchive.ietf.org/arch/msg/ietf/hKwBYOwPkE6VTA4mxxf00NTLLF0
[2] https://www.ietf.org/mailman/listinfo/mtgvenue
[3] mailto:[email-masked]

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Fri, 8 Apr 2016 21:18:10 +0000

> But we could adopt the Conclave model of decision making!

We already have running code on that. It's called "the Nomcom".

---

From: Harish Pillay <[email-masked]>
Date: Sat, 9 Apr 2016 09:22:12 +0800

> That's a suburb of Johor, just into Malaysia from Singapore, so I believe
> the answer is yes, though I don't know what the transit times will be or
> whether it's a fully reliable path.  The two countries sometimes make that
> border awkward.
>
> d/
>
> --
>
>   Dave Crocker

Doable, but you'd need to take one of two landlinks - the Causeway or
the Second Link. I have colleagues who live in Johor Bahru (the capital
of Johor where Skudai) who commute daily.

Harish

---

From: Harish Pillay <[email-masked]>
Date: Sat, 9 Apr 2016 09:24:31 +0800

> recently, a 3 hour delay is not unusual.

it is very variable. There are live video feeds of both the land crossing:

http://www.onemotoring.com.sg/publish/onemotoring/en/on_the_roads/traffic_cameras0/tuas.html

that can be used as reference and guide.

Harish

---

From: Harish Pillay <[email-masked]>
Date: Sat, 9 Apr 2016 09:32:39 +0800

> And I can’t enter Malaysia at all.

<tongue-in-cheek>
unless you say you are a mexican:
http://www.haaretz.com/a-deep-dark-secret-love-affair-1.128671
</tongue-in-cheek>

In the 1967 when Singapore introduced National Service, the Singapore Armed
Forces looked to Israel for training and related assistance. Those who came here
were labeled "Mexicans". I recall my Dad mentioning that to me back then and
later confirmed in memoirs of some of the Singapore cabinet ministers
from that era.

Harish

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 09 Apr 2016 08:05:42 +0200

However San Diego venue is not downtown, which seems it was the main excuse to avoid having it in Madrid, despite the public connections (several bus lines and cheap taxi) between the Madrid venue and downtown is by far much better than San Diego.

Regards,
Jordi

---

From: Ray Pelletier <[email-masked]>
Date: Sat, 9 Apr 2016 04:51:33 -0300

Jordi

San Diego has changed.

There is a Convention Center downtown surrounded by hotels.

We would not have to be down near the marina and isolated.

Ray
> On Apr 9, 2016, at 3:05 AM, JORDI PALET MARTINEZ <[email-masked]> wrote:
>

---

From: Stewart Bryant <[email-masked]>
Date: Sat, 9 Apr 2016 09:06:08 +0100

Oh, shame, I liked it by the marina.

Stewart

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 09 Apr 2016 04:40:58 -0700 (PDT)

On Sat, 9 Apr 2016, JORDI PALET MARTINEZ wrote:

> However San Diego venue is not downtown, which seems it was the main 
> excuse to avoid having it in Madrid, despite the public connections 
> (several bus lines and cheap taxi) between the Madrid venue and 
> downtown is by far much better than San Diego.
> 
> Regards,
> Jordi
> 

There is more than one venue in San Diego.

---

From: Randy Bush <[email-masked]>
Date: Sat, 09 Apr 2016 09:05:22 -0300

> yes, we tried that.  My impression is that there were two changes we
> made, one was known in advance (closed network)

the ietf network in beijing was open as normal, thanks to the work of
many.  it had registration, as had maastricht.  and we have passwording
now.

> the other was unknown (badges being checked)

cf. rfid discussion in hiroshima.  checking badges has a varied history.
beijing was conservative.

randy

---

From: Randy Bush <[email-masked]>
Date: Sat, 09 Apr 2016 09:06:39 -0300

> And I can’t enter Malaysia at all.

what you mean is that the malaysians have you go through a visa process
as the emericans do to the chinese, ...

randy

---

From: Randy Bush <[email-masked]>
Date: Sat, 09 Apr 2016 09:08:01 -0300

> I have only one real complaint: it's too hot and humid for my liking,
> but then again I could also describe Singapore as a very large
> air-conditioned shopping center disguised as a country :-)

bingo

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 09 Apr 2016 05:47:52 -0700 (PDT)

Randy,

Sorry, no that is not what he means. Malaysia has no diplomatic 
relations with Israel and it is thus not possible for him to apply
for a visa through the normal process (embassy, consulate, fee,
sticker in passport, etc).

There *are* ways for a group to apply to for exceptions, but this
cannot in any way be compared to visas from or to China.

Ole

Ole J. Jacobsen
Editor and Publisher

---

From: John C Klensin <[email-masked]>
Date: Sat, 09 Apr 2016 09:49:55 -0400

>> very large air-conditioned shopping center disguised as a

Is that very different from describing downtown Minneapolis (at
the wrong time of year) as a very large heated shopping mall and
hotel complex disguised as a city?

  john

---

From: Yoav Nir <[email-masked]>
Date: Sat, 9 Apr 2016 11:12:42 -0300

> On 9 Apr 2016, at 9:06 AM, Randy Bush <[email-masked]> wrote:
> 
> as the emericans do to the chinese, …

No. The Americans do that to me as well. But any Israeli and Chinese is eligible for a US visa unless the embassy official suspects that you are going to use this visa to enter the US and work there illegally. Israelis can get a Malaysia visit only on a special-case basis. Mostly when a sporting event of conference threatens to not meet there unless they allow everyone to visit.

Not even close to being the same thing.

Yoav

---

From: Andrew Allen <[email-masked]>
Date: Sat, 9 Apr 2016 15:53:03 +0000

My few pesos worth on this topic.

The website link provided also identifies 13 US states ‎where such laws still exists on the books and although due to a 2003 Supreme Court decision people are no longer prosecuted for violations there have according to the site still been arrests under these laws.

Two of the state's listed (Florida and Texas) were locations for 2 of the last 3 IETF meetings hosted in the USA.

‎Are we now saying that these13 US States are also now off the list of possible locations even though we have had several meetings in some of these states without any issues?

‎I think as a basic  principle we should ensure that meeting locations are accessible to all the community and no one should be denied attendance because of who they are, their race,  orientation, religion, politics  or where they are from etc.

It is however a little different if the location's  laws bar certain personal activities including for example what substances you ingest that may be legal in some places and not others or different laws regarding the public use of tobacco as well as other more  personal activities, including what age you need to be to do so legally. ‎I don't think it is entirely unreasonable for people to abstain for 6 days from personal activities legal in their own country that may be against local laws in order to attend an IETF meeting regardless of how unreasonable or obnoxious  those laws may be to us.

I think we need to accept that different places in the world have different cultures and different laws and so long as those laws don't actually prevent you entering the country or obtaining suitable accommodation or cause you to have  to lie in order to do so or significantly affect your personal safety these shouldn't completely rule out a location although they may be a consideration when evaluating between locations .

Having been to Singapore once before I am certain there are no room police patrolling the hotel corridors trying to ascertain what activities the guests are up to in their own rooms. There were also no personal questions asked at hotel registration as far as I recall ( I am sure I would have remembered that) so I don't see it as an especially hostile environment.‎ I think the IETF should confirm with the meeting hotels that there will be no issues in that regard and also a check with the Singapore authorities that there will be no threat to IETF participants because of their orientation or marital status would be a sensible measure.

I understand that certain laws and cultural ‎attitudes in some places may make some feel uncomfortable. As a British citizen seeing Malvinas Son Arentinas posters all over Buenos Aires was not the most welcome sight to me and to a degree offends some of my particular sensibilities and if I walked around Plaza de Mayo wearing a union jack t- shirt I think I might get a hostile reaction but that doesn't mean Argentina should be off limits to IETF. When visiting another country you are a guest there and you need to be willing to conform your public behavior in order to not offend the hosts and not violate local laws and that you may have to accept that you may not always have the same freedoms you enjoy at home. When in Rome.....

I don't think the IETF should boycott locations just because the community doesn't like some of the laws of that country or aspects of that countries governments policies‎.  That is a very slippery slope that could significantly reduce the number of possible meeting locations and also distract from the IETF mission.

I think the hard and fast criteria should be is the location  in practice open for every‎body to attend and will the attendees be reasonably safe there.

Andrew

Sent from my BlackBerry 10 smartphone.
From: David Conrad
Sent: Thursday, April 7, 2016 17:20
To: Dhruv Dhody
Cc: [email-masked] Discussion
Subject: Re: Concerns about Singapore

For reference:

Regards,
-drc

---

From: Yoav Nir <[email-masked]>
Date: Sat, 9 Apr 2016 19:15:21 +0200

Hi, Andrew

> Having been to Singapore once before I am certain there are no room police patrolling the hotel corridors trying to ascertain what activities the guests are up to in their own rooms. There were als…

I’m sure they didn’t ask *you* any questions. But you might have gotten some response if you tried to check in with another man into a room that had just one bed.  I’m not saying that you would. I don’t know, having never been in Singapore, but I can understand that it would be a concern. 

Yoav

---

From: Melinda Shore <[email-masked]>
Date: Sat, 9 Apr 2016 09:33:07 -0800

On 4/9/16 9:15 AM, Yoav Nir wrote:
> I’m sure they didn’t ask *you* any questions. But you might have gotten
> some response if you tried to check in with another man into a room that
> had just one bed.  I’m not saying that you would. I don’t know, having
> never been in Singapore, but I can understand that it would be a concern.

I was discussing this a little bit with my partner this morning
and she pointed out that in many cases where we would find the
laws ridiculous, those laws are not actually enforceable (for
example, French laws against women wearing pants).  The problem
with the situation in Singapore is that the laws that are on
the books appear to be quite enforceable, with the Singapore
Supreme Court having upheld laws banning consensual same-sex
relationships as recently as late 2014 (one of the plaintiffs
had been arrested in 2010).

To the extent that these laws appears to be enforceable and
that there is uncertainty about whether or not some of our
participants are likely to run into issues with public
accommodation, etc., I'm grateful that the IAOC is treating
this as a serious issue.

Melinda

---

From: joel jaeggli <[email-masked]>
Date: Sat, 9 Apr 2016 15:58:02 -0300

On 4/9/16 2:33 PM, Melinda Shore wrote:
> example, French laws against women wearing pants).  

"Loi interdisant la dissimulation du visage dans l'espace public" is
probably also ridiculous but readily enforced and fairly recently
upheld, so it's not like interdictions on personal freedom, self
expression or conscience are not still being readily or facilely adopted
in Europe.  Which is not to say that  one views all such restrictions
as qualitatively the same, I do not.

> The problem

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 9 Apr 2016 19:01:14 +0000

One could mention sodomy laws in Texas; we have met in Houstaon and Dalls, I believe, there times.

> On Apr 9, 2016, at 11:58 AM, joel jaeggli <[email-masked]> wrote:
>

---

From: Melinda Shore <[email-masked]>
Date: Sat, 9 Apr 2016 11:20:03 -0800

> Dalls, I believe, there times.

That goes, I think, to the question of unenforceable laws
(Lawrence v. Texas).  I'm interested in the question of where
the line is between issues that the IETF needs to deal with
and matters of personal conscience, and I tend to think it
comes down to questions of whether or not meeting participants
will be treated equally when it comes to public accommodation,
etc.

As we're seeing, businesses are responding to the recent spate of
anti-gay legislation and transphobic potty laws by announcing that
they're not  opening planned facilities in those states, not allowing
their employees to take business travel there, and so on.  So, there's
an actual question about whether or not the IETF would be able to
meet in a place that's recently passed anti-gay legislation, given
some corporate travel restrictions.  As far as I know there are
no corporate bans on travel to Singapore, but civil liberties
organizations like Civil Rights Watch have identified Singapore as
a place where LGBT people still face active legal discrimination
and it seems clear that there's a legitimate question about what
sort of treatment some meeting participants can expect to receive.

Melinda

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 10 Apr 2016 08:56:05 +1200

> will be treated equally when it comes to public accommodation,

I think that's the point, and unfortunately, like so many things, it
ends up as a judgment call.

Are transgender people treated equally when getting haircuts? Not always,
it turns out:
http://m.nzherald.co.nz/nz/news/article.cfm?c_id=1&objectid=11618046

Does this disqualify Auckland? Probably not, and it's less serious than
being denied a hotel room or worse. But my point is: this issue just goes
in the balance along with everything else, and the problem here seems to be
that the IAOC overlooked it. I sympathise, because I'd probably have
overlooked it too.

otoh, the IETF boycotting SG would not have the same impact as Springsteen
boycotting NC.

   Brian

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 09 Apr 2016 14:05:06 -0700 (PDT)

On Sat, 9 Apr 2016, Melinda Shore wrote:

> That goes, I think, to the question of unenforceable laws (Lawrence 
> v. Texas).  I'm interested in the question of where the line is 
> between issues that the IETF needs to deal with and matters of 
> personal conscience, and I tend to think it comes down to questions 
> of whether or not meeting participants will be treated equally when 
> it comes to public accommodation, etc.
> 
> their employees to take business travel there, and so on.  So, 
> there's an actual question about whether or not the IETF would be 
> able to meet in a place that's recently passed anti-gay legislation, 
> given some corporate travel restrictions.  As far as I know there 
> are no corporate bans on travel to Singapore, but civil liberties 
> organizations like Civil Rights Watch have identified Singapore as a 
> place where LGBT people still face active legal discrimination and 
> it seems clear that there's a legitimate question about what sort of 
> treatment some meeting participants can expect to receive.
> 
> Melinda

There are several sources online for this information, including the 
US State Department, but we are also actively seeking clarification 
from contacts in Singapore about these issues. So far, I am fairly
certain that our attendees won't notice any issues at all, but stay
tuned as we gather the facts.

Ole

---

From: Michael StJohns <[email-masked]>
Date: Sat, 9 Apr 2016 17:13:27 -0400

> many.  it had registration, as had maastricht.  and we have passwording
Most of these things are not like the others:

We have ietf/ietf now - mainly for the benefit of the individual users 
(per client encryption keys), not the per user userid/password that we 
had in Beijing that was only available to registered attendees.

Calling the Beijing meeting network open isn't really correct - we had a 
reverse VPN to the Internet as it exists outside of the PRC.

We did registration in Maastricht simply to figure out the details 
before we got to Beijing - I'm fairly confident that Maastricht wouldn't 
have been different from the previous IETF's without the upcoming 
Beijing meeting.
> beijing was conservative.

Beijing was the first and only time I can think of where the hotel/host 
provided us with guards (excepting watchmen for the terminal room).  It 
was also the first time that said guards actually kept out someone with 
a valid conference badge. Granted, the badge did not have the holders 
name on it, but it's really never been the IETF's policy to be overly 
concerned about who shows up as long as they are minimally dressed, not 
disruptive to the process and have attained reasonable standards of 
hygiene.  And even those standards have been waived at times.

I'll also note that we neither asked for the guards nor were asked for 
consent for the guards to be placed.  [I believe the previous statement 
to be true, but its possible that I was misinformed.]

It's a little late for this, but I'm suddenly wondering what percentage 
of the on-site registrants  in Beijing were local, and how that 
percentage compares with other meetings.

In any event, each location we've been to has had a challenge or two 
that we've either ignored or overcome.  Some candidate places will have 
challenges that we can neither ignore or overcome and should hopefully 
be down-selected in the meeting planning process.

Later, Mike

---

From: Melinda Shore <[email-masked]>
Date: Sat, 9 Apr 2016 13:20:00 -0800

> ends up as a judgment call.

Not really - Singapore has laws on the books that criminalize
gay relationships.  That's a fact, not a judgment call.  It's
also a fact that a law criminalizing consensual physical relationships
between adult men was upheld by the Singapore Supreme Court less
than two years ago and apparently has been inconsistently and
selectively enforced (that's not a good thing).

Melinda

---

From: John C Klensin <[email-masked]>
Date: Sat, 09 Apr 2016 18:35:38 -0400

--On Saturday, April 09, 2016 13:20 -0800 Melinda Shore
<[email-masked]> wrote:

>> I think that's the point, and unfortunately, like so many
>> things, it ends up as a judgment call.
 
> also a fact that a law criminalizing consensual physical
> relationships between adult men was upheld by the Singapore
> Supreme Court less than two years ago and apparently has been
> inconsistently and selectively enforced (that's not a good
> thing).

This has been said several times and I think needs to be
stressed.  There is a huge practical difference between 

	* Having an obnoxious (to use a deliberately-mild term)
	law on the books that has not been enforced for many
	years, for which there is no reasonable expectation that
	it would be enforced, _and_ for which there are
	reasonable grounds for assuming that any attempt to
	enforce it would result in the rapid elimination of the
	law itself -- rapid enough to act as a further deterrent
	to attempts to enforce it, rather than causing IETF
	community members to feel "not very much" pain and
	suffering.
	
	* Having a law that has been enforced in recent memory,
	especially if it has also been validated (or "upheld")
	in recent memory by courts or other relevant authorities
	and/or created in recent years (as in the North Carolina
	situation that has been cited as an example). 

Referring to what Pete said at the plenary, the second set of
cases should (actually MUST) never be treated as a matter of a
judgment call or balancing factors.   By analogy with the visa
issue, a situation in which regular participants from some
countries will find obtaining visas to be a major pain in the
anatomy involves a judgment call; one in which participants from
some countries cannot, under normal circumstances, obtain visas
or in-meeting-country protections as citizens of their origin
countries because the potential countries deliberately does not
maintain diplomatic recognition or relations with those origin
countries is a showstopper.

I agree with Melinda that inconsistent and selective enforcement
is bad news (and because it includes non-zero frequency of
enforcement, moves a potential venue into the second category).
I also think it is worth stressing that, especially in an area
where rights to free speech and/or assembly and/or to hold
demonstrations about a political position are even nominally
valued, the ability to hold a parade or demonstration in favor
of particular rights or legally-prohibited behavior without
interference is of approximately zero value in predicting
whether actual exercise of those rights or behavior would result
in enforcement actions.

I hope that, as the IAOC continues "actively seeking
clarification", the distinction between the ability to express
support without getting arrested and the ability to practice the
nominally-criminal behavior without getting arrested (even
occasionally) is well understood.

It may be just me, but the distinctions really seem a lot more
clear than the length of this discussion thread would seem to
imply.

     john

---

From: "Patrik Fältström" <[email-masked]>
Date: Sun, 10 Apr 2016 00:36:53 +0200

> tuned as we gather the facts.

FWIW, ICANN has met in Singapore a few times recently and I have not heard about any issues what so ever.

   Patrik

---

From: Randy Bush <[email-masked]>
Date: Sat, 09 Apr 2016 19:57:35 -0300

> Calling the Beijing meeting network open isn't really correct - we had
> a reverse VPN to the Internet as it exists outside of the PRC.

false.  and i was the noc guy working it.

> before we got to Beijing - I'm fairly confident that Maastricht
> wouldn't have been different from the previous IETF's without the
> upcoming Beijing meeting.

correct, but misleading.  maastrict was the same as beijing, though for
different reasons.

randy

---

From: John C Klensin <[email-masked]>
Date: Sat, 09 Apr 2016 19:03:04 -0400

--On Sunday, April 10, 2016 00:36 +0200 Patrik Fältström
<[email-masked]> wrote:

>> There are several sources online for this information,
>> including the US State Department, but we are also actively
>> seeking clarification from contacts in Singapore about these
>> issues. So far, I am fairly certain that our attendees won't
>> notice any issues at all, but stay tuned as we gather the
>> facts.
> 
> FWIW, ICANN has met in Singapore a few times recently and I
> have not heard about any issues what so ever.

Patrik,

This has been mentioned several times.  Let me make an
observation about ICANN meetings.  Especially in recent years,
they are very political.  Especially in smaller or less
developed countries, they usually occur at the invitation of the
government or with the fairly explicit permission and
involvement of the government.  Part of selective enforcement
(see Melinda's recent note) is that attendees at such meetings
are rarely messed with unless their behavior is impossible to
ignore and sometimes not then.  ICANN is further down that scale
than actual UN or diplomatic meetings: I've been in countries
where, had I come (to tried to come) as, e.g., a tourist or
random meeting attendee, I would have been a prohibited person
but, because I was traveling on UN papers, I had great
confidence that no one was going to interfere with me.

Singapore, for better or worse, has a well-established
reputation as a rather pragmatic place.  Because of the above,
an attendee at an ICANN meeting is less likely to be interfered
with than, e.g., one at an APNIC or Apricot one.   I suspect the
latter are less likely to be interfered with than an IETF
attendee just because of different relationships between the
organizations and their members and the long-term interests of
the country.  An IETF attendee is less likely to be interfered
with than a permanent resident of the country.  But the laws are
there, they are apparently intermittently enforced, and no IETF
participant should need to worry about whether they or their
families are going to be in the wrong place at a time when a
hotel staff member or law enforcement official is having a bad
day (or an attack of religious or other zeal) and looking for
someone to take it out on.

I could also note that ICANN, given the view of its role by some
of its leadership in recent years, had found it desirable or
necessary to cozy up to some of the world's more problematic
autocratic regimes.  Whether side deals are made with those
regimes or not, that behavior certainly should not set a
standard for the IETF to follow.

     john

---

From: Warren Kumari <[email-masked]>
Date: Sat, 09 Apr 2016 23:32:25 +0000

ICANN has also met in Sengal and Morocco recently -- while I didn't hear of
any issues there either, they are not exactly shining bastions in the human
rights areas. Just because we didn't hear about issues doesn't mean people
were comfortable there...

W

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 10 Apr 2016 13:07:20 +1200

On 10/04/2016 10:35, John C Klensin wrote:
...
> clear than the length of this discussion thread would seem to

The distinction is quite clear, but my point and the reason I broke
my silence on this thread is that even so, it's *still* a judgment
call, whether the issue is freedom of speech, freedom of behaviour,
personal risk, or even old-fashioned discrimination as in the example
I gave.

   Brian

---

From: Andrew Allen <[email-masked]>
Date: Sun, 10 Apr 2016 05:26:36 +0000

I would have thought the cost of transportation would likely more than offset the savings in terms of hotels. Not sure how practical it would be to use cheap public transportation to make that trip every day to attend a meeting .

Although Singapore may be called a city state like Hong Kong there is quite a bit more to it than just the city and the causeway to Malaysia is the other side of the island from the Metropolitan area.

In the case of HK the MTR does go all the way to the border and then the Schenzhen subway is accessible from the other side, however I wouldn't think it would be very practical to try to commute every day between HK and Schenzhen either and I expect a similar or worse situation exists between Singapore and Malaysia.

This is coming from someone who commuted every day to Yokohama from downtown Tokyo which was actually quite cheap (about $5 US each way) although it took about and hour each way.

Andrew

Sent from my BlackBerry 10 smartphone.
  Original Message
From: Michael Richardson
Sent: Friday, April 8, 2016 20:48
To: Andrew Allen
Cc: Dave Crocker; Ole Jacobsen; [email-masked] Discussion
Subject: Re: Concerns about Singapore

---

From: Andrew Allen <[email-masked]>
Date: Sun, 10 Apr 2016 05:26:40 +0000

This is coming from someone who commuted every day to Yokohama from downtown Tokyo which was actually quite cheap (about $5 US each way) although it took about an hour each way.

Andrew

---

From: Andrew Allen <[email-masked]>
Date: Sun, 10 Apr 2016 06:36:06 +0000

That's why I proposed that IETF check with the hotels that this isn't going to be an issue. The other potential issue I foresee which needs checking with the authorities is if there will be a problem with customs and immigration forms with questions regarding marital status and number of family members traveling with you.

Sent from my BlackBerry 10 smartphone.
From: Yoav Nir
Sent: Saturday, April 9, 2016 18:15
To: Andrew Allen
Cc: David Conrad; Dhruv Dhody; [email-masked] Discussion
Subject: Re: Concerns about Singapore

Hi, Andrew

Yoav

---

From: Leif Johansson <[email-masked]>
Date: Sun, 10 Apr 2016 12:42:05 +0200

Skickat från min iPhone

> correct, but misleading.  maastrict was the same as beijing, though for

That was the VAT issue, right?

---

From: <[email-masked]>
Date: Sun, 10 Apr 2016 13:08:37 +0000 (UTC)

>>Having been to Singapore once before I am certain there are no room police patrolling the hotel corridors trying to ascertain what activities the guests are up to in their own rooms. There were also >>no personal questions asked at hotel registration as far as I recall ( I am sure I would have remembered that) so I don't see it as an especially hostile environment.‎ I think the IETF should confirm >>with the meeting hotels that there will be no issues in that regard and also a check with the Singapore authorities that there will be no threat to IETF participants because of their orientation or >>marital status would be a sensible measure.

>I’m sure they didn’t ask *you* any questions. But you might have gotten some response if you tried to check in with another man into a room that had just one bed.  I’m not saying that you would. I >don’t know, having never been in Singapore, but I can understand that it would be a concern. 
 
Guys, believe me, I am not for discrimination in any form whatsoever and of course, it is wonderful if IETFers want to bring their family with them to locations but isn't it more important for the IETFer themselves to attend and to not be harassed?   Does IETF need to plan for not just attendees but attendee's families?

A lot of us have never said anything but people might want to read the section that is in Wikipedia on "White Privilege". 
https://en.wikipedia.org/wiki/White_privilege

This might help put a different perspective on this discussion.

I know at least one participant at IETF95 who was searched multiple times at the same airport because his skin was brown and we suspect that he was profiled.  You may look at compilations which have rank countries by racist attitudes and in some, the United States comes in first.

But, you do not hear us talking about this or even complaining or suggesting that we are getting an unfair deal.  We just work harder and try to support each other.

And, this kind of thing - getting hassled, ignored in restaurants, possibly physically assaulted if we are in the wrong area, etc.etc. is for IETF participants.  Not, IETFer's bringing their families - which I will add is not an option for many in the developing world because it is far too expensive.  It is hard enough for the IETFer himself / herself to attend - much less bring their family.

Don't get me wrong, I am definitely not saying that discrimination against our LGBT brothers & sisters is to be discounted.  There is a young gay man who grew up with my daughter who is like a son to me & even in the very liberal environment of Berkeley, California, there are issues with him being openly gay.  Just as there are issues with me being a woman of color.

No one has an exclusive on being treated badly.  Unfortunately.

Let's try to work with each other and support each other to bring the collaborative attitudes and openness that underlie the Internet and the openness of the IETF to the developing world.  I think that we are agents of change just as the Internet is an agent of change.  Unfortunately, sometimes, there are costs to be borne for this.  We need to look at the greater good.

Just my 2 cents.

Thanks,
Nalini

---

From: <[email-masked]>
Date: Sun, 10 Apr 2016 09:38:41 -0400

> false.  and i was the noc guy working it.

I'm curious how it was different. I was certainly was under the
impression that IETF was treated differently than the general populous,
making some/most people OK with the meeting being held there.

Thanks,
Chris.

---

From: Randy Bush <[email-masked]>
Date: Sun, 10 Apr 2016 08:56:17 -0500

> impression that IETF was treated differently than the general
> populous, making some/most people OK with the meeting being held
> there.

it was clean unfettered Internet.  some local folk stuck their necks out
very far to accomplish this.  it was definitely different than one got
outside of the ietf meeting network.  this has been a condition placed
on hosts and beijing was no exception.  

there were a few gl!tches, as there always are, but they were debugged.
ticket history is the only PII data pile we do not delete at the end of
the meeting, so we may be able to see if mike actually had a ticket and
if it was fixed.

the noc does occasionally discuss that it might be interesting for us to
experience the local internet policies, bandwidth, etc.; a little
reality therapy.  at the dubai ripe meeting, one could not reach
facebook et alia.  is that a major loss?  did riparians learn from it?
would it prevent ietfers to get useful work done?  [ an amusing side
note is that such sites are available in riyadh, which we consider a
much more conservative city. ]

btw, all traffic in and out of singapore, voice and data, has been spied
upon at the most intimate and detailed level for a very long time.
luckily the usa, land of the free, is ..., oh wait.

randy

---

From: Michael StJohns <[email-masked]>
Date: Sun, 10 Apr 2016 10:34:00 -0400

> on hosts and beijing was no exception.

This surprises me - "this has been a condition placed on hosts...". 
Could you enlighten us as to which [and I'll try to be precise here] 
other IETFs had a condition where the content accessible by the IETF 
network was markedly different from the content of say the network at a 
local Starbuck's equivalent wifi hot spot just down the street from the 
IETF and where that was mandated by the hosts and/or local laws?  I mean 
besides Beijing?   Key words "markedly different" and "content accessible".

Mike

---

From: Ole Jacobsen <[email-masked]>
Date: Sun, 10 Apr 2016 07:41:08 -0700 (PDT)

On Sun, 10 Apr 2016, Michael StJohns wrote:
> 
> This surprises me - "this has been a condition placed on hosts...". Could you
> enlighten us as to which [and I'll try to be precise here] other IETFs had a
> condition where the content accessible by the IETF network was markedly
> different from the content of say the network at a local Starbuck's equivalent
> wifi hot spot just down the street from the IETF and where that was mandated
> by the hosts and/or local laws?  I mean besides Beijing?   Key words "markedly
> different" and "content accessible".
> 
> Mike
> 

The IETF has a meeting network requirements document that specifies a 
number of parameters which includes no blocking. Markedly different in
terms of content may not apply in most places, reasonable bandwidth 
most certainly does, as does port restrictions (usually by stupid 
configuration by clueless operators). And if you've ever stayed in 
some random hotel you will know what I mean.

Ole

---

From: Randy Bush <[email-masked]>
Date: Sun, 10 Apr 2016 09:45:50 -0500

> This surprises me - "this has been a condition placed on hosts...". 

it was even in the hour of embarrassing babble fred used to prevent
people from talking about real problems at the bof

> network was markedly different from the content of say the network at
> a local Starbuck's equivalent wifi hot spot just down the street from
> the IETF and where that was mandated by the hosts and/or local laws?
> I mean besides Beijing?  Key words "markedly different" and "content
> accessible".

we don't specify it's 'different'.  among other silly distractions, it
would require a 'different from precisely what and in what ways?'

we simply specifiy open and unfettered

rndy

---

From: Michael StJohns <[email-masked]>
Date: Sun, 10 Apr 2016 10:48:20 -0400

> we simply specifiy open and unfettered

I repeat - "where" have the local hosts/laws specified conditions that 
resulted in the IETF network content access being markedly different 
than that accessible to the random local citizen?

---

From: Dave Crocker <[email-masked]>
Date: Sun, 10 Apr 2016 07:50:36 -0700

> IETF and where that was mandated by the hosts and/or local laws?

A basic issue that seems to distinguish a number of venue concerns is 
whether constraints are state-imposed or are only the choice of the 
local site operator.  Negotiating variations for site-imposed 
constraints is fundamentally different and fundamentally more 
problematic (or impossible) than for state-imposed ones.

As far as I'm aware, Beijing has been the only venue where Internet 
access issues ran into state-imposed restrictions.

If I've heard folk correctly, that distinction seems to be the essence 
of what is being expressed against Singapore.

d/

-- 

   Dave Crocker

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 10 Apr 2016 12:01:11 -0300

This has been a wide-ranging conversation that I've been content to watch
quietly, but Andrew just stepped on the land mine ...

On Apr 10, 2016 01:36, "Andrew Allen" <[email-masked]> wrote:
>
>
> That's why I proposed that IETF check with the hotels that this isn't
going to be an issue. The other potential issue I foresee which needs
checking with the authorities is if there will be a problem with customs
and immigration forms with questions regarding marital status and number of
family members traveling with you.

Bingo.

I've been coming to the IETF since 1996, and I know a fair number of GLBTQ
IETF participants, but I knew most of them for years, and in a few cases
for more than a decade, before realizing that.

For my GLBTQ friends from the US, it has been relatively recent for most of
them to live their lives openly.

The gay man who automatically came to IETF meetings even ten years ago with
no "paper trail" ten years ago is now much more likely to show up with a
paper train now.

If he shows up with another man with the same last name, the same address
on IDs, each other as emergency contacts on every form that asks for that,
and (for extra credit) one or more kids with the same last name in tow,
it's a lot harder to miss in 2016 than it was in 2006, and at least some of
that is still visible even if he leaves the family at home.

Our friends who were forced to suffer in silence until recently would have
a much more difficult time doing that today, even if they wanted to.

Spencer

---

From: Ole Jacobsen <[email-masked]>
Date: Sun, 10 Apr 2016 12:08:16 -0300

Please rest assured that we are gathering information on precisely these issues!

Ole J. Jacobsen
Editor & Publisher
The Internet Protocol Journal
Cell: +1 415 370-4628
docomo: (090) 3337 9311
http://protocoljournal.org

Sent from my iPhone

> On Apr 10, 2016, at 12:01, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> This has been a wide-ranging conversation that I've been content to watch quietly, but Andrew just stepped on the land mine ...
> 
> I've been coming to the IETF since 1996, and I know a fair number of GLBTQ IETF participants, but I knew most of them for years, and in a few cases for more than a decade, before realizing that.
> 
> For my GLBTQ friends from the US, it has been relatively recent for most of them to live their lives openly.
> 
> The gay man who automatically came to IETF meetings even ten years ago with no "paper trail" ten years ago is now much more likely to show up with a paper train now.
> 
> If he shows up with another man with the same last name, the same address on IDs, each other as emergency contacts on every form that asks for that, and (for extra credit) one or more kids with the same last name in tow, it's a lot harder to miss in 2016 than it was in 2006, and at least some of that is still visible even if he leaves the family at home.
> 
> Our friends who were forced to suffer in silence until recently would have a much more difficult time doing that today, even if they wanted to.
> 
> Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 10 Apr 2016 13:43:15 -0300

Hi, Ole,

> Please rest assured that we are gathering information on precisely these
issues!

Oh, I am. I absolutely am.

And happy birthday, I believe?

Spencer

>> This has been a wide-ranging conversation that I've been content to
watch quietly, but Andrew just stepped on the land mine ...
>>
>> Bingo.
>>
>> I've been coming to the IETF since 1996, and I know a fair number of
GLBTQ IETF participants, but I knew most of them for years, and in a few
cases for more than a decade, before realizing that.
>> The gay man who automatically came to IETF meetings even ten years ago
with no "paper trail" ten years ago is now much more likely to show up with
a paper train now.
>>
>> If he shows up with another man with the same last name, the same
address on IDs, each other as emergency contacts on every form that asks
for that, and (for extra credit) one or more kids with the same last name
in tow, it's a lot harder to miss in 2016 than it was in 2006, and at least
some of that is still visible even if he leaves the family at home.
>>
>> Our friends who were forced to suffer in silence until recently would
have a much more difficult time doing that today, even if they wanted to.

---

From: Jared Mauch <[email-masked]>
Date: Sun, 10 Apr 2016 13:53:29 -0400

I would suggest European networks have quite different content than elsewhere as a result of local censorship laws and other rights afforded to people in the region. 

Jared Mauch

> On Apr 10, 2016, at 10:48 AM, Michael StJohns <[email-masked]> wrote:
> 
> I repeat - "where" have the local hosts/laws specified conditions that resulted in the IETF network content access being markedly different than that accessible to the random local citizen?
> 
> 
>> 
>> rndy

---

From: "John Levine" <[email-masked]>
Date: 10 Apr 2016 18:19:58 -0000

>number of parameters which includes no blocking.

In London in 2014, do you know whether we were behind the national
child porn filters?

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 11 Apr 2016 08:12:31 +1200

>>> This surprises me - "this has been a condition placed on hosts...".

In the case of Beijing it was very clear from the earliest discussions,
going back to 2005 and before, to my personal knowledge.

...
> 
> I repeat - "where" have the local hosts/laws specified conditions that resulted in the IETF network content access being
> markedly different than that accessible to the random local citizen?

Why is that relevant? The criterion is: can the IETF do its work properly?
Of which a sub-criterion is: will there be clean unfettered Internet at
the meeting site?

How RFC 4084 applies in the local coffee shops is another matter.

   Brian

---

From: Dave Crocker <[email-masked]>
Date: Sun, 10 Apr 2016 13:21:36 -0700

> Of which a sub-criterion is: will there be clean unfettered Internet at

A great deal of IETF work gets done away from the meeting site.  Having 
state-imposed restrictions away from the meeting site invites basic 
productivity limitations.

It also is oddly dissonant with the IETF's general call for open and 
unfettered access.  We risk sounding a tad elitist if it means something 
like "open and unfettered for us, but we're not concerned about you 
other folk"...

To offer an intentionally extreme comparison, imagine having a desire 
that children not be recruited to be soldiers.  (Yes, I know, that's a 
controversial point of view and many reasonable people think it's ok to 
have children be slaughtered and do slaughtering in war...)  But then 
imagine choosing to go to a country that uses children that way, 
formally.  Is it reasonable to go there with the view that it's ok, as 
long as they don't recruit any of /our/ children to be solders?

d/

-- 

   Dave Crocker

---

From: Michael StJohns <[email-masked]>
Date: Sun, 10 Apr 2016 16:59:14 -0400

> going back to 2005 and before, to my personal knowledge.

This is where close reading of the chain is useful - specifically the 
meaning of "this".  What I was referring to was the "condition placed on 
the hosts" (apparently by the government) that the IETF regulate access 
to its network by implementing a per user login system, rather than 
"condition placed on the hosts" by the IETF that we get to see the real 
Internet as a requirement for going there. The former is unique in 
AFAICT.  The latter is basically business as usual for us.
> Of which a sub-criterion is: will there be clean unfettered Internet at

It's not relevant to that question exactly - this goes all the way back 
to the beginning of this chain with respect to the meaning of "open" vs 
"closed" network and from who's viewpoint you're considering the 
question.   The original poster said Beijing was a closed network, Randy 
said it was an open network.  From any one sitting inside the IETF 
looking out, it certainly was as open as what we normally get.  For 
anyone sitting outside, in country,  and unable to come in, it certainly 
was as closed as any corporate or VPN or government network as I've ever 
seen.

 From MCR's original comment, I believe he was viewing the network as 
closed using the above criteria.

Later, Mike

---

From: Robert Withers <[email-masked]>
Date: Sun, 10 Apr 2016 19:15:13 -0400

Resending to the list...and an extra thought...

If censorship rights are managed in more granularity than nationally, perhaps the neighborhood or subdivision level, it allows variance and differentiation, including mixed access within an urban setting. The nation must be the union and membership in associations may carry censorship requirements limiting one's access by agreement. This sort of approach may be welcomed by those regimes with real concerns regarding 'westernization' of their media. Countries may well allow international conference attendees free access while simultaneously protecting their children from wanting to serve the local warlord rather than sticking to the local Civil Defense Unit. I believe the idea has merit, perhaps reducing slaughter.

From the perspective of those exercising active decision, it would be termed the right to forget, another right to be sure. It's a form of BDS, yes? Quite effective.

Well I think it would be wonderful if network protocols supported filtering in both senses: filter reception from certain senders & filter transmission to certain recipients. I'm thinking of some sort of intersection of sender/receiver permission volumes specified with N dimensional Voronoi tessellations in negotiated session state at the routers, managed with multicast hashes in the traffic headers. One will literally never be in contact with said troublesome traffic and both foreign and domestic users would have that censoring/forgetting guarantee. 

best,
robert

> On Apr 10, 2016, at 16:28, Jared Mauch <[email-masked]> wrote:
> 
> Countries do their own censorship, or have rights for their citizens eg: regional/ national right to be forgotten. 
> 
> If you need some articles on these topics, let me know. 
> 
> Jared Mauch
> 
>> On Apr 10, 2016, at 2:24 PM, Robert Withers <[email-masked]> wrote:
>> 
>> Pardon me, do I understanding you to say that it is a basic right for a local region to censor content? As you put it: "local censorship laws and other rights", So to establish specific censorships in local areas, this is a fundamental right of that neighborhood?  That is a very shiny idea, very Millenarianly said.
>> 
>> Robert
>> 
>>> On 04/10/2016 01:53 PM, Jared Mauch wrote:
>> Robert
>> .  ..   ...    ^,^

---

From: <[email-masked]>
Date: Sun, 10 Apr 2016 21:16:55 -0400

> Of which a sub-criterion is: will there be clean unfettered Internet at

It's certainly relevant to me, b/c I don't personally think that IETF
meetings should be held in oppressive and censoring countries. I don't
know how to articulate this well -- others are better at it -- but I
certainly would like to skip any meetings that I feel violate IETFs
value of openness so that I can at least vote with my feet and my
dollars.

Thanks,
Chris.

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 11 Apr 2016 07:54:25 +0530

> value of openness so that I can at least vote with my feet and my

Well how does this work with Internet's (and IETF's) mission of
inclusiveness. Applying the same scale of "oppressiveness", I am
sure large parts of the world think the same about the US/UK which
has waged wars in Iraq, Afghanistan, Vietnam, Syria, Argentina
(our latest venue) and elsewhere.

The IETF doesn't seem to have a problem having meetings in
these countries. I hope the majority of participants on this list
realise that they are viewing the world through a western prism.

The notion of punishing the general populace for the mistakes of
their elected and unelected govt. seems wrong to me. Many times,
the general populace of the country is fighting their govt. through
the Internet. eg. Turkey.

-- Vinayak

---

From: John C Klensin <[email-masked]>
Date: Mon, 11 Apr 2016 03:12:28 -0400

--On Sunday, April 10, 2016 19:15 -0400 Robert Withers
<[email-masked]> wrote:

> If censorship rights are managed in more granularity than
> nationally, perhaps the neighborhood or subdivision level, it
> allows variance and differentiation, including mixed access
> within an urban setting. The nation must be the union and
> membership in associations may carry censorship requirements
> limiting one's access by agreement. This sort of approach may
> be welcomed by those regimes with real concerns regarding
> 'westernization' of their media. Countries may well allow
> international conference attendees free access while
> simultaneously protecting their children from wanting to serve
> the local warlord rather than sticking to the local Civil
> Defense Unit. I believe the idea has merit, perhaps reducing
> slaughter.
>...

On the other hand, that same kind of granularity can be used
(and often has been) to allow unrestricted access to media and
content by members of elites (or those trusted to support the
parties in power) while restricting access by those less
favored, less trusted, or with different views.  Acceptance of
it does reduce slaughter too, but does so primarily by virtue of
the principle that those who avoid expressing dissent are much
less likely to be punished for dissenting than those who do
express it.

YMMD, but I'm not very happy about the direction in which the
argument above takes us.

    john

---

From: Andrew Allen <[email-masked]>
Date: Mon, 11 Apr 2016 08:05:19 +0000

This is what I mean by slippery slope - once we go down this path it never ends - in a global community of well over 1000 active people at least one person is likely to have a problem with some aspect of most of the countries governments, policies, cultures or actions, etc.

We could be left with the only possible venue being a cruise ship sailing in international waters - but then someone will probably object because the ship is registered in Panama or Liberia!

The focus should be on choosing a location for the meeting that is open for all to attend and where it is reasonably safe to attend and meets the needs of a meeting for a large number of people and represents the regional balance of the membership. 

The mission of the IETF is to make the Internet work better by producing high quality, relevant technical documents that influence the way people design, use, and manage the Internet.

The IETF is not an organization that's mission is to be an advocate for global social, environmental or political change. The selection of a meeting location should be for the purposes of advancing the IETF's mission. I think some of the concerns raised about Singapore need to be addressed in terms of the practical impact and risk to the attendance of some in the IETF community but we shouldn’t start down the road of choosing or not choosing meeting locations based on an evaluation of a countries laws, culture and policies and whether those are acceptable to all or most of the community.

Debates over whether a location is politically or morally acceptable will only distract from the mission of the IETF and likely divide the community rather than help in making progress towards forming consensus on the future development of the internet.

Andrew

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Vinayak Hegde
Sent: Sunday, April 10, 2016 10:24 PM
To: [email-masked]
Cc: IETF discussion list <[email-masked]>
Subject: Re: Concerns about Singapore

> value of openness so that I can at least vote with my feet and my 

Well how does this work with Internet's (and IETF's) mission of inclusiveness. Applying the same scale of "oppressiveness", I am sure large parts of the world think the same about the US/UK which has waged wars in Iraq, Afghanistan, Vietnam, Syria, Argentina (our latest venue) and elsewhere.

The IETF doesn't seem to have a problem having meetings in these countries. I hope the majority of participants on this list realise that they are viewing the world through a western prism.

The notion of punishing the general populace for the mistakes of their elected and unelected govt. seems wrong to me. Many times, the general populace of the country is fighting their govt. through the Internet. eg. Turkey.

-- Vinayak

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 11 Apr 2016 09:34:49 +0000

I agree 100% with Andrew's view.

Regards
Andy

> On 11 Apr 2016, at 09:05, Andrew Allen <[email-masked]> wrote:
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 11 Apr 2016 11:23:30 +0100

On 11/04/16 09:05, Andrew Allen wrote:
> Debates over whether a location is politically or morally acceptable
> will only distract from the mission of the IETF and likely divide the
> community rather than help in making progress towards forming
> consensus on the future development of the internet.

I almost but don't agree with the above. The danger of such debates
dividing folks and being a barrier to progress is real. OTOH, there
are also dangers in the lack of such debate, or if the debate is post
facto, as happened in this case.

I think the lesson the IAOC ought learn here is to switch to a
default-open mode of operation where only those things that really
need to be kept confidential are kept confidential. (Note that I
don't only mean for f2f meeting arrangements but for all of what the
IAOC do.) That will require them (or someone) to go figure out (with
the community) which kinds of things really do need to be kept
confidential, and which can be done openly, in the normal IETF way.

I'd be fine if the IAOC announced that they will be doing the above
but also said we weren't going to work out the details until after
they have figured out whatever it is they end up doing about IETF-100.

Cheers,
S.

---

From: Rich Kulawiec <[email-masked]>
Date: Mon, 11 Apr 2016 06:45:19 -0400

On Mon, Apr 11, 2016 at 08:05:19AM +0000, Andrew Allen wrote:
> We could be left with the only possible venue being a cruise ship
> sailing in international waters - [snip]

There is another alternative -- one I've raised repeatedly.

Don't have physical meetings.  Then this entire problem space simply
vanishes, along with the need for a discusion thread that's now over a
hundred messages.  (And it's not the first one.)  YES, it's replaced by a
different problem space, which roughly works out to "how can everything
be done virtually?"  but given that this is the *Internet* engineering
task force I have no doubt that the collective expertise is more than
capable of dealing with that.  Particularly if all the discussion, effort,
and expense going into the logistics of physical meetings is redirected
into virtual ones instead.

I really can't take any of the platitudes about "inclusion" seriously
until that happens -- because as long as the IETF persists with physical
meetings, most people *will* be excluded due to cost, distance, time,
legal climate, personal safety, etc.  The IETF is, even if accidentally,
selecting for the elite few who are fortunate enough to be attend.

---rsk

---

From: Yoav Nir <[email-masked]>
Date: Mon, 11 Apr 2016 15:17:39 +0300

> On 11 Apr 2016, at 1:45 PM, Rich Kulawiec <[email-masked]> wrote:
> 
> capable of dealing with that.  

I don’t believe that this technology exists. People have been singing the praise of Meetecho in IETF 95, and yet remote participation is nothing like being in the room. And the “virtual interim” meetings are nothing like physical meetings. There is a reason why airlines make great money from business travel and don’t shut down for the winter.

> Particularly if all the discussion, effort,

Yeah, perhaps, some day when we’re all wearing virtual reality headsets and our avatars are hanging out in a virtual venue, and we all have sufficient equipment and bandwidth to handle all that. We’re not there yet.

> selecting for the elite few who are fortunate enough to be attend.

Virtual meetings with the technology we have today makes it very hard for people with mediocre English to follow the discussion. The “I don’t quite follow what you’re saying” look does not translate well to the kind of video we can use today. That extends even to people with relatively good English (for non-native speakers) like me. 

Yoav

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Apr 2016 09:01:53 -0400

Also, if you live in a country with censorship, or with low bandwidth, it's
possible that the only way to attend an IETF meeting will be in person.
It would be nice if there were a bright line to draw on one side of which
is total inclusiveness, but there is not.   We need to make both kinds of
meeting work.

What Stephen said is right--the IAOC needs to systematically, rather than
informally, analyze what it is that needs to be done in confidence, and
expose the rest to public view.   I know this is non-trivial, and I do not
say this in the spirit of bashing the IAOC, who work very hard for us with
little reward other than our complaining.

If I were on the IAOC right now, I would be thinking about how to get off
of it.   I've been in the situation of having what seemed like a big chunk
of the IETF upset at me, and it's pretty soul-crushing.   Nevertheless, I
think what Stephen proposes is the thing the IAOC can do that is most
likely to prevent future woe of this kind.

On Mon, Apr 11, 2016 at 8:17 AM, Yoav Nir <[email-masked]> wrote:

> I don’t believe that this technology exists. People have been singing the
> praise of Meetecho in IETF 95, and yet remote participation is nothing like
> being in the room. And the “virtual interim” meetings are nothing like
> physical meetings. There is a reason why airlines make great money from
> business travel and don’t shut down for the winter.
>
> Yeah, perhaps, some day when we’re all wearing virtual reality headsets
> and our avatars are hanging out in a virtual venue, and we all have
> sufficient equipment and bandwidth to handle all that. We’re not there yet.
>
> Virtual meetings with the technology we have today makes it very hard for
> people with mediocre English to follow the discussion. The “I don’t quite
> follow what you’re saying” look does not translate well to the kind of
> video we can use today. That extends even to people with relatively good
> English (for non-native speakers) like me.
>
> Yoav
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 11 Apr 2016 09:53:13 -0400

--On Monday, April 11, 2016 11:23 +0100 Stephen Farrell
<[email-masked]> wrote:

> default-open mode of operation where only those things that
> really need to be kept confidential are kept confidential.
> (Note that I don't only mean for f2f meeting arrangements but
> for all of what the IAOC do.) That will require them (or
> someone) to go figure out (with the community) which kinds of
> things really do need to be kept confidential, and which can
> be done openly, in the normal IETF way.

I agree that the above is key.  Particular meeting choices,
registration decisions, etc., aside, I see the real problem as
that the IAOC has, perhaps by accident, gotten into habits
equivalent to working in secret and then catching the community
-- including members of the community who could have pointed out
additional issues to be considered -- by surprise with "this is
done and it is too late to undo it" announcements.   Moving to
"by default open" and "need to get explicit community buy-in for
categories of things that are treated as confidential" would, I
think, make a world of difference... especially if those
categories were made as narrow as possible.

IMO, much of the hostility the IAOC periodically encounters
(including my suggestion a few weeks ago that the "surprise!
remote participants now need to register" announcement should
cause some people to consider resigning) is directly connected
to the surprise announcements with no transparency about the
decision process, much less an opportunity for community review.
Fewer surprises about possibly-problematic actions, less
hostility.

That does nothing about the sense that some requirements are
absolute (e.g., "no-go for meetings and no associated discussion
about 'balance'"), but we ought to be able to have an open
discussion about what falls into that category (and keep it as
narrow as possible), not a situation in which the IAOC or its
committees say things equivalent to "there are a lot of factors,
we can't make everyone happy, and therefore we get to decide, in
secret, how to balance things and make announcements only after
contracts (or other irreversible actions are in place".

    john

---

From: John Leslie <[email-masked]>
Date: Mon, 11 Apr 2016 09:59:22 -0400

Yoav Nir <[email-masked]> wrote:
>> vanishes...

... to be replaced by other "unsolvable" problems: but ones where progress
might be easier...

>> YES, it's replaced by a different problem space, which roughly works out
>> to "how can everything be done virtually?"

   ++

>> but given that this is the *Internet* engineering task force I have no
>> doubt that the collective expertise is more than capable of dealing
>> with that.  

   I don't 100% share that enthusiam; but I do believe we'd see visible
progress within a year or two.

> I don't believe that this technology exists.

   That makes three of us agreeing!

> People have been singing the praise of Meetecho in IETF 95, and yet
> remote participation is nothing like being in the room.

   True... I can be attending to my email, or even pouring through a
deskful of background papers, and nobody will chide me for not listening!

> And the "virtual interim" meetings are nothing like physical meetings...

   Less true... I have participated in some very effective virtual meetings.
It's a matter of how the Chair runs things. (And that _is_ variable!)

>> Particularly if all the discussion, effort, and expense going into the
>> logistics of physical meetings is redirected into virtual ones instead.
> 
> Yeah, perhaps, some day when we're all wearing virtual reality headsets
> sufficient equipment and bandwidth to handle all that.

   It really has nothing to do with such gimmicks!

   For IETF-95 I used a $500 large-screen for the first time. It certainly
didn't give me $500 of benefit over the multiple 20-inch screens I usually
use, but large-screens don't cost $500 anymore. ;^)

   I wouldn't use a V-R headset if it were a gift. Avatars would get in
the way of expressing differing attitudes. The whole field of how to show
non-local participants needs work!

> We're not there yet.

   We're not even agreed where "there" should be.

>> legal climate, personal safety, etc.

   Guilty as charged.

>> The IETF is, even if accidentally, selecting for the elite few who are
>> fortunate enough to be [able to] attend.

   Guilty as charged, again.

   I've had quite a number of high-school students working here who could
have become valuable participants at IETF. Exactly _one_ of them agreed to
attend an IETF week; and that one would never consent to attend another.
We are selecting mostly those whose employers send them in hopes of getting
a return-on-investment.

   I long for the days when we attracted lots of graduate students!

> people with mediocre English to follow the discussion.

   It's hard for them in-person on-site, too. Why aren't we discussing
tools to help them?

> The "I don't quite follow what you're saying" look does not translate
> well to the kind of video we can use today.

   False! It merely doesn't translate to the kind of video we _do_ use
today.

> That extends even to people with relatively good English (for non-native
> speakers) like me. 

   So, to fall back to my standard question: "What are you going to do
about it?"

--
John Leslie <[email-masked]>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 11 Apr 2016 17:07:03 +0300

> On 11 Apr 2016, at 4:01 PM, Ted Lemon <[email-masked]> wrote:
> 
> Also, if you live in a country with censorship, or with low bandwidth, it's possible that the only way to attend an IETF meeting will be in person.   It would be nice if there were a bright line to draw on one side of which is total inclusiveness, but there is not.   We need to make both kinds of meeting work.
> 
> What Stephen said is right--the IAOC needs to systematically, rather than informally, analyze what it is that needs to be done in confidence, and expose the rest to public view.   I know this is non-trivial, and I do not say this in the spirit of bashing the IAOC, who work very hard for us with little reward other than our complaining.
> 
> If I were on the IAOC right now, I would be thinking about how to get off of it.   I've been in the situation of having what seemed like a big chunk of the IETF upset at me, and it's pretty soul-crushing.   Nevertheless, I think what Stephen proposes is the thing the IAOC can do that is most likely to prevent future woe of this kind.

I think Dave Crocker’s suggestion that the IAOC advertise the countries / cities it is considering might go a long way to help. If we had heard two years ago that the IAOC was considering Singapore, the objection we heard at the plenary would have been voiced then. In that case, the IAOC might go elsewhere or it might get assurances from Singaporean authorities or it might even decide to go for it anyway. But they would not be caught off-guard as they were last Wednesday.

Similarly for other countries or locations. This is not enough to solve all inclusiveness issues and there are deeper issues that need addressing, but this is low-hanging fruit IMO.

Yoav

---

From: Yoav Nir <[email-masked]>
Date: Mon, 11 Apr 2016 17:07:45 +0300

+1 

> On 11 Apr 2016, at 12:34 PM, Hutton, Andrew <[email-masked]> wrote:
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Apr 2016 10:15:28 -0400

FWIW, last week was not the first time I heard Singapore mentioned,
although I don't remember the context in which it had previously been
mentioned.   We need to have both more transparency about which locations
are being considered, and also a process for registering feedback on these
locations.   E.g., feedback on the IETF mailing list probably isn't
sufficient, because it's hard to keep track of the entirety of that mailing
list even if you subscribe to it, so a comment there could very easily get
lost.

On Mon, Apr 11, 2016 at 10:07 AM, Yoav Nir <[email-masked]> wrote:

> >> This is what I mean by slippery slope - once we go down this path it
> never ends - in a global community of well over 1000 active people at least
> one person is likely to have a problem with some aspect of most of the
> countries governments, policies, cultures or actions, etc.
> >>
> sailing in international waters - but then someone will probably object
> because the ship is registered in Panama or Liberia!
> >>
> >> The focus should be on choosing a location for the meeting that is open
> for all to attend and where it is reasonably safe to attend and meets the
> needs of a meeting for a large number of people and represents the regional
> balance of the membership.
> >>
> >> The mission of the IETF is to make the Internet work better by
> producing high quality, relevant technical documents that influence the way
> people design, use, and manage the Internet.
> >>
> >> The IETF is not an organization that's mission is to be an advocate for
> global social, environmental or political change. The selection of a
> meeting location should be for the purposes of advancing the IETF's
> mission. I think some of the concerns raised about Singapore need to be
> addressed in terms of the practical impact and risk to the attendance of
> some in the IETF community but we shouldn’t start down the road of choosing
> or not choosing meeting locations based on an evaluation of a countries
> laws, culture and policies and whether those are acceptable to all or most
> of the community.
> >>
> community rather than help in making progress towards forming consensus on
> the future development of the internet.
> >>
> >> Andrew
> >>
> inclusiveness. Applying the same scale of "oppressiveness", I am sure large
> parts of the world think the same about the US/UK which has waged wars in
> Iraq, Afghanistan, Vietnam, Syria, Argentina (our latest venue) and
> elsewhere.
> >>
> >> The IETF doesn't seem to have a problem having meetings in these
> countries. I hope the majority of participants on this list realise that
> they are viewing the world through a western prism.
> >>
> >> The notion of punishing the general populace for the mistakes of their
> elected and unelected govt. seems wrong to me. Many times, the general
> populace of the country is fighting their govt. through the Internet. eg.
> Turkey.
> >>
> >> -- Vinayak
> >>
> >
>
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 11 Apr 2016 15:28:58 +0100

I would be happy if we took a boring utilitarian
attitude to meeting venues:

Find three places that more or less work and
just keep using them.

Stewart

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 11 Apr 2016 10:34:36 -0400

Surprisingly to some, it turns out that it is a real help if the host 
has local people on the ground in the meeting city.  This creates a 
noticeable drawback to trying to just use 3 cities over and over.

Yours,
Joel

---

From: Dave Crocker <[email-masked]>
Date: Mon, 11 Apr 2016 07:36:40 -0700

> noticeable drawback to trying to just use 3 cities over and over.

That makes a big difference -- at the level of being essential -- for 
new cities in challenging regions -- mostly Asia for the IETF.

It's /much/ less of an issue for places having repeat visits.

d/

-- 

   Dave Crocker

---

From: <[email-masked]>
Date: Mon, 11 Apr 2016 10:52:00 -0400

> This is what I mean by slippery slope - once we go down this path it never ends - in a global community of well over 1000 active people at least one person is likely to have a problem with some asp…

FWIW, I believe an earlier mail I sent led in part to this thread. I was
saying it was important for me to understand how and when the IETF is
being treated "specially". I wish to have this information so that I can
make informed decision on whether I will attend the meeting (i.e.,
voting with my presence and dollars).

I'm wasn't asking for anything more, and I don't think there's a
slippery slope in being transparent on this issue.

I've refrained from getting involved in debates with people trying to
convince me that my views are wrong. That's another discussion, it's not
one I wish to have on the IETF discussion list, and not relevant to the
question of transparency that I was addressing.

Thanks,
Chris.

---

From: Richard Shockey <[email-masked]>
Date: Mon, 11 Apr 2016 17:04:11 -0400

You can’t do that!  

Didn’t you get the memo. This is the Internet Engineering Travel Forum. 

— 
Richard Shockey
Shockey Consulting LLC
Chairman of the Board SIP Forum
www.shockey.us
www.sipforum.org
richard<at>shockey.us
Skype-Linkedin-Facebook rshockey101
PSTN +1 703-593-2683

---

From: Jared Mauch <[email-masked]>
Date: Mon, 11 Apr 2016 17:09:37 -0400

> On Apr 11, 2016, at 5:04 PM, Richard Shockey <[email-masked]> wrote:
> 
> 
> 
> You can’t do that!  
> 

It’s also the Internet Engineering Temperature Forum

https://www.youtube.com/watch?v=eTdn9-fqgtQ

---

From: Rich Kulawiec <[email-masked]>
Date: Mon, 11 Apr 2016 18:34:04 -0400

On Mon, Apr 11, 2016 at 03:17:39PM +0300, Yoav Nir wrote:
> I don???t believe that this technology exists. 

People have remote meetings all day, every day.   Lots of technology
exists, more is being invented all the time.  Perhaps (to follow
on your mention of Meetecho in 1995) if 20 years had been invested
in making it work for the IETF then it would be working by now.

> Yeah, perhaps, some day when we???re all wearing virtual reality
> headsets and our avatars are hanging out in a virtual venue, and we all
> have sufficient equipment and bandwidth to handle all that. We???re not
> there yet.

Nor is there any need to go there.  Meetings do not require VR.

> Virtual meetings with the technology we have today makes it very hard
> for people with mediocre English to follow the discussion.

That's (a) not a very big problem and (b) a solvable problem.  

What I'm hearing is a lot of we've-always-done-it-this-way.  Well,
that's not working very well except for the privileged elite few
(most of whom are backed by corporations).  And I understand
that those with plenty of money and time and freedom have gotten
comfortable with how-things-are-done.  It's an easy thing to do,
I've done it myself.   But it doesn't serve the long-term interests
of the IETF or the Internet well.

---rsk

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 11 Apr 2016 23:47:33 +0100

Hiya,

> of the IETF or the Internet well.

FWIW, I think you're getting a few years ahead of reality
there, but eventually reality will catch up with you. I'm
not sure when I'd predict may happen, maybe in the next
5-10 years would be my current guess.

But maybe I'm wrong - can you send details of how an approx.
1000 person virtual meeting where everyone could provide real
input has been held by anyone? I'm unaware of such but I'd
be very interested if that had happened already.

Even if we're only in the realms of speculation, that could
still be useful speculation, so I'd encourage you to write
down your ideas as to how that could work, in an I-D. (Or
however you prefer to document stuff.)

And of course, that "that" that has to work need not involve
simultaneous participation by 1000 people from all over the
world within any one or a few hours. However, it does need
to involve that large a set with some practical method for
cross-pollination and for people to establish working
personal relationships with one another.

In summary, I do think we'll get figure out ways to cut out
most of the travel in future, but I figure we're just not
there yet, and I don't see how we establish the interpersonal
relationships if we do end up with a purist non-travel scenario.
But that said, I do agree that our current expensive-travel
approach definitely does favour the well financially endowed,
which currently includes me (surprisingly, to me;-)

Cheers,
S.

---

From: <[email-masked]>
Date: Mon, 11 Apr 2016 19:01:16 -0400

Having just participated remotely for this IETF 95, and having thought
about what I was missing while doing so, I feel that nothing can really
replace the actual IETF face-to-face meeting experience. We can strive
to do as much as possible to make remote be equal as possible
participant, but remote participation can never be a 100% substitute for
100s of colleagues spending an intense week together in the same
location focused morning, noon, and night; while eating, drinking,
meeting, relaxing, on the engineering of the Internet.

Why would we want to get rid of such a rich source of inspiration and
invention?

I don't see that meetings aren't working well, instead I think we're
trying to make them work even better through enhanced remote
participation (e.g., meetecho, remote hubs, etc).

Thanks,
Chris.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Apr 2016 19:54:25 -0400

While I do not think it's true that we can entirely get away without doing
in-person meetings, I do agree with you that we can do better at doing
remote meetings.   Perhaps we should let this unfortunate event drive us to
make the attempt.

If we were to attempt such a thing, how do you think it would work?

---

From: David Farmer <[email-masked]>
Date: Mon, 11 Apr 2016 19:07:30 -0500

> be very interested if that had happened already.

It is definitely a challenge, but it has been done, just like a real
meeting with 1000 people in the room frequently ends up being mostly one
person or small group talking and then questions being asked by the
audience, this can be accomplished virtually too.

There was a recurring annual event;

http://www.megaconference.org/past.html

And in Fall of 2001 because of the events of 911, Internet2 canceled its
Member Meeting in San Antonio and held a Virtual Member Meeting in early
October 2001.  I can't find much online regarding it any longer, but it is
listed on the list of past meetings.

http://www.internet2.edu/news-events/events/past-events/past-annual-member-meetings/

These are a few examples I know of, I'm sure there are others.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: <[email-masked]>
Date: Tue, 12 Apr 2016 00:08:34 +0000 (UTC)

> in making it work for the IETF then it would be working by now.

http://recs.conf.meetecho.com/Playout/watch.jsp?recording=IETF95_DTN&chapter=chapter_1

try listening to the first twenty minutes of this.
then tell me if IETF WG meetings with remote presentation
via Meetecho are anything other than a complete waste
of time.

L.

it's not the mediocre English. It's the mediocracy.

Lloyd Wood [email-masked] http://about.me/lloydwood 

________________________________
From: Rich Kulawiec <[email-masked]>
To: [email-masked] 
Sent: Tuesday, 12 April 2016, 8:34
Subject: Re: Concerns about Singapore

---rsk

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Apr 2016 20:13:07 -0400

The challenge here is not so much that doing a 1000-person remote meeting
is impossible to do, but that doing a 1000-person remote meeting that winds
up being as effective as a 1000-person in-person meeting is hard to do.
If we decided to make it a priority, I'd be willing to bet that we could
come up with something fairly cromulent.   Of course it would not be
exactly the same as an in-person meeting; it would have things that went
better, and things that went worse.   But if we decided to do it, we could
definitely do it, and it would be worth doing.

On Mon, Apr 11, 2016 at 8:07 PM, David Farmer <[email-masked]> wrote:

>
>
> On Mon, Apr 11, 2016 at 5:47 PM, Stephen Farrell <
> [email-masked]> wrote:
>>
>>

---

From: George Michaelson <[email-masked]>
Date: Tue, 12 Apr 2016 10:18:54 +1000

> If we were to attempt such a thing, how do you think it would work?

We'd need tighter chairing. We'd need microphone floor control, and
queues and reservations and we'd adopt meeting formalisms to get the
poll of the room.

Consensus hums would be next to impossible. We'd find pressure to head
to votes. Which of course is a huge no-go for a lot of people.

Van Jacobsen talked to me 15+ years ago about the ways you might have
to police the MBONE and it was interesting to think he was looking
forward then to large attendee, widely distributed, delay-bound
interactions online which is where we're kind-of heading.

The RIR have been doing break-out meetings for a while, and training
the chairs to respect a 30 second lag for feedback from the room is
very hard. Chairs like to judge consensus with eyes in the room, not
on the screen.

-G

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 12 Apr 2016 01:27:00 +0100

> http://www.megaconference.org/past.html

Interesting! Thanks. Any idea if anyone has posted a summary
of how that went?

Ta,
S.

---

From: Mark Andrews <[email-masked]>
Date: Tue, 12 Apr 2016 10:30:25 +1000

I also have no doubt one could do a 1000 person remote meeting.

That being said, I've tried to do remote attendence at meetings
both where there is a small timezone offset and a large timezone
offset.  The small timezone offset "works" but in no way replaces
face to face meetings.  The large timezone offset only works if you
have 1 or 2 working groups to want to attend.

Face to face forces attendees to be mostly in sync with respect to
the timezone.  BA was a 10 hour shift for me but it was do able.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Miles Fidelman <[email-masked]>
Date: Mon, 11 Apr 2016 20:34:30 -0400

> the timezone.  BA was a 10 hour shift for me but it was do able.

Well, keep in mind that a 1000-person in-person meeting is pretty hard 
as well.  Sure, it works as a plenary session, but in-person working 
meetings also break down at pretty low numbers.

Now, if one thinks about multiple, simultaneous, remote meetings - of 
10-50 people each - things start to sound a more feasible.

Just a thought,

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

---

From: Jared Mauch <[email-masked]>
Date: Mon, 11 Apr 2016 20:44:03 -0400

> On Apr 11, 2016, at 8:08 PM, <[email-masked]> <[email-masked]> wrote:
> 

The NTPWG had a very successful experience, including remote presenters, and remote people going back and forth with their interaction.  

I would say your experience is atypical, and certainly not the desired outcome.

- Jared

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 12 Apr 2016 01:45:14 +0100

> 10-50 people each - things start to sound a more feasible.

"Sound more feasible"? Perhaps. Add TZ's and remote input issues
that we face with today's technology and that may no longer be
convincing.

I've been a bit involved in the session planning for the last dozen
or so IETF meetings - I reckon adding a TZ constraint for each/many
participants would have broken all of those. There are also typically
8 sessions in parallel at IETF meetings, the largest of which often
involves between one and two hundred folks in one session so things
do not in fact break down into 10-50 people sub things, at least today.

Add all that up and I think we're "sounding" utterly impractical.
(That said, I do still need to check out the David Farmer's response
in this thread.)

S.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 11 Apr 2016 20:50:16 -0400

The only thing you mentioned that can't be done with existing conferencing
software is hums, and I'm sure we could figure out a way to make that
work.  It's not rocket science.   Chairs who judge consensus by looking at
the room aren't following IETF process--consensus is judged on the mailing
list.  Hums are useful for figuring out why we _don't_ have consensus, and
for _getting_ to consensus, but if you were to judge consensus by hums or a
show of hands, then you'd be taking a vote, wouldn't you?

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 12 Apr 2016 06:28:16 +0200

The IETF is not a value-neutral organization.

Since we're citing the Mission Statement RFC here, it also contains:

>    The Internet isn't value-neutral, and neither is the IETF.  We want
>    the Internet to be useful for communities that share our commitment
>    to openness and fairness.  We embrace technical concepts such as
>    decentralized control, edge-user empowerment and sharing of
>    resources, because those concepts resonate with the core values of
>    the IETF community.  These concepts have little to do with the
>    technology that's possible, and much to do with the technology that
>    we choose to create.

That said - after doing my amateur research on the whole Singapore
thing, I'm willing to live with whatever resolution of the issue the
IAOC comes up with. It's not an open-and-shut "stay away" thing; I
regard the first IETF to be held inside the Great Firewall as a more
clearly problematic decision - but, in retrospect, agree with it.

My unhappiness with the IAOC's handling (pre-plenary) is mainly that
they were surprised that this concern needs considering.

---

From: Rich Kulawiec <[email-masked]>
Date: Tue, 12 Apr 2016 07:02:59 -0400

> If we were to attempt such a thing, how do you think it would work?

Let me preface this by saying that I think attempts to completely
mimic the current in-person meeting experience as it exists probably
won't work.  They might: but they probably won't.  But then again,
I don't think that's entirely necessary: processes and procedures
change (compare boarding a steamship in 1930 with an aircraft in 2005)
and evolve in order to work with technology.

So if I were to envision this, things I'd want to experiment with
would include:

- passive view-only, listen-only read-only access to anyone, anonymously.
(That is: no registration required.)

- levels of read-write access, perhaps (roughly speaking) distinguished
as text, audio, and video.  Participants could select based on their
available bandwidth and on the level they're comfortable with.  I think
it's reasonable to require registration for write access.

- a channel for presentation content only. Again, this is an option for
those with limited bandwidth or limited time.

- ability to delay/time-shift.

- perhaps restructuring long sessions into smaller time slots.  If people
have all travelled to the same place, then it makes sense to get a lot
done in a short time, and so a four hour session (for example) makes
sense.  But if people are in disparate locations, then maybe four one-hour
sessions make more sense.  This also better accomodate people who have
trouble carving out four hours in the middle of their day.  Or night.

- integrated storage of sessions, so that someone can watch, listen,
read, and absorb the entire experience.  Useful for someone half a
planet away who won't be (or can't be) awake for real-time participation.

- translations and/or text captioning and/or some kind of assistance
for non-native speakers and the hearing impaired.

- emphasis on the inclusion of participants who can't make it to meetings
today, either because of time, money, politics, distance, family, job, etc.

Over and above all of this: a willingness to experiment and to have
some of those expirements fail -- which they will.

---rsk

---

From: Rich Kulawiec <[email-masked]>
Date: Tue, 12 Apr 2016 07:08:39 -0400

> Why would we want to get rid of such a rich source of inspiration and

Because it works exclusively for the elite, privileged few.  (And no
doubt: it works quite well.)  But it's the antithesis of inclusion
and diversity -- and I think those qualities are increasingly necessary.

---rsk

---

From: Tim Chown <[email-masked]>
Date: Tue, 12 Apr 2016 12:15:59 +0100

> On 12 Apr 2016, at 01:50, Ted Lemon <[email-masked]> wrote:
> 
> The only thing you mentioned that can't be done with existing conferencing software is hums, and I'm sure we could figure out a way to make that work.  It's not rocket science.   Chairs who judge consensus by looking at the room aren't following IETF process--consensus is judged on the mailing list.  Hums are useful for figuring out why we _don't_ have consensus, and for _getting_ to consensus, but if you were to judge consensus by hums or a show of hands, then you'd be taking a vote, wouldn't you?

Meetecho has a ‘hum’ button, which throws ‘hmmmmmm’ into the jabber room for the WG. I did see it used, once. 

Tim

---

From: Tim Chown <[email-masked]>
Date: Tue, 12 Apr 2016 12:43:22 +0100

Hi,

To minimise the chances of a ‘Singapore’ happening again it would seem prudent to

a) re-use previous successful meeting venues for the bulk of our meetings (say, every 5 in 6 meetings); this is one criteria for meeting selection as it stands anyway; that list might include venues like Prague, Berlin, Vancouver, etc.; we’d need to be clear in what ‘successful’ means - the meeting feedback forms provide one such mechanism;

b) be transparent at an early stage about where new venues might be, whether by country or city, so there is a fair chance for people to give feedback; of course, how such feedback is weighed is an open question, but at least it would be there, and the IAOC can then make a decision ‘eyes wide open’.

In such a system, Buenos Aires would have been a ‘1 in 6’ venue. In that light, I’d note that many people have said how much they enjoyed Buenos Aires as a meeting place. And while the IAOC probably feel rather down over the comments about Singapore, they should be praised for going out on something of a limb in making the Buenos Aires selection. (And I’d add that the enthusiasm and helpfulness of the LACNIC hosts was also fantastic.)

In terms of virtual meetings, I’d suggest we try to hold more interim WG meetings, some completely virtually, and learn how to make those better. If we can regularly hold good quality wholly virtual interim meetings, then we can consider whether the same technology might be used for a larger meeting.

Tim

> On 12 Apr 2016, at 00:54, Ted Lemon <[email-masked]> wrote:
> 
> While I do not think it's true that we can entirely get away without doing in-person meetings, I do agree with you that we can do better at doing remote meetings.   Perhaps we should let this unfortunate event drive us to make the attempt.
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 07:49:02 -0400

Agree about Buenos Aires.   We already do excellent virtual interims--I
think if your standard for whether we can do a virtual IETF is that virtual
interims work, we are already there.

I think that if we want to test this idea, what we need to do is designate
some future IETF virtual _now_, and then start preparing, rather than say
"oh, we should do a virtual" and then dither about when we might be ready.
  We will never be so ready that a virtual IETF feels identical to an
in-person IETF, so let's just abandon that idea and get started on making a
virtual IETF that, while different, is still a success.

On Tue, Apr 12, 2016 at 7:43 AM, Tim Chown <[email-masked]> wrote:

> a) re-use previous successful meeting venues for the bulk of our meetings
> (say, every 5 in 6 meetings); this is one criteria for meeting selection as
> it stands anyway; that list might include venues like Prague, Berlin,
> Vancouver, etc.; we’d need to be clear in what ‘successful’ means - the
> meeting feedback forms provide one such mechanism;
>
> b) be transparent at an early stage about where new venues might be,
> whether by country or city, so there is a fair chance for people to give
> feedback; of course, how such feedback is weighed is an open question, but
> at least it would be there, and the IAOC can then make a decision ‘eyes
> wide open’.
>
> In such a system, Buenos Aires would have been a ‘1 in 6’ venue. In that
> light, I’d note that many people have said how much they enjoyed Buenos
> Aires as a meeting place. And while the IAOC probably feel rather down over
> the comments about Singapore, they should be praised for going out on
> something of a limb in making the Buenos Aires selection. (And I’d add that
> the enthusiasm and helpfulness of the LACNIC hosts was also fantastic.)
>
> In terms of virtual meetings, I’d suggest we try to hold more interim WG
> meetings, some completely virtually, and learn how to make those better. If
> we can regularly hold good quality wholly virtual interim meetings, then we
> can consider whether the same technology might be used for a larger meeting.
>
> Tim
>
> > While I do not think it's true that we can entirely get away without
> doing in-person meetings, I do agree with you that we can do better at
> doing remote meetings.   Perhaps we should let this unfortunate event drive
> us to make the attempt.
> >

---

From: <[email-masked]>
Date: Tue, 12 Apr 2016 07:57:53 -0400

> and diversity -- and I think those qualities are increasingly necessary.

But this is not how the IETF operates. In fact we mandate that the use
of mailing lists to make sure this isn't the case. The meetings are in
addition to the mailing list, and more recently the virtual interim
meetings (which I have found to be very useful as well), and we strive
to make them as accessible as possible remotely as well.

The face to face meetings add real value to the process, and b/c they
are not mandatory they should not subtract value from the process. Your
suggestion of not having them would subtract value from the process
though. I don't see the win.

It would be great if everyone who wished to could attend the meetings to
take part in that added value though. The fact that some people cannot
is not reason abandon the meetings, but rather a reason to try and make
them as easy to attend as possible. The 1+1+1 format helps here, but so
does picking affordable sites to travel to and stay in. The conference
fee could be quite high for an individual contributor I think, we should
perhaps explore a reduced fee for individuals when this would make the
difference between attending and not. In any case I think we can and
should continue to work on this front for sure.

Thanks,
Chris.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 12 Apr 2016 14:19:43 +0200 (CEST)

> I would say your experience is atypical, and certainly not the desired outcome.

+1 on this.

I have spent the past meetings doing frequent jabber scribe work. I use 
Meetecho to do this, and I place myself next to the front participant mic 
(so I can see the name tag of the person speaking), and then I type on 
jabber the name of who the person speaking in the mic. There is (I've been 
told) now a suggestion to the IETF secritariat to reserve the seat next to 
the front mic (at table) for Jabber scribe, and this would be great. Now 
we just need to teach everybody to flash their badge to the jabber scribe 
as well.

I have long offered to call out the slides (which is typically needed for 
people who are on audio+jabber only) if someone wanted it, but the past 
few meetings nobody has requested that. My guess is that most people use 
Meetecho because it gives the complete view of what's going on, you get 
chat+presentation+video+sound, and you can also ask questions (which was 
used numerous times in the sessions I participated in).

Generally, I'm very happy with Meetecho (wonders of HTML5+WEBRTC to be 
able to run this in just a browser). There were some initial sound 
problems on monday morning, but that was quickly rectified.

I also really appreciate the fact that I can call out "meetecho" in the 
jabber room to notify them of potential problems, and they immediately 
dispatch someone to fix the problem (including alerting the A/V crew if 
it's a local issue).

So while there were a few hiccups, I'd say most of the time Meetecho and 
the local A/V works great.

---

From: Tim Chown <[email-masked]>
Date: Tue, 12 Apr 2016 13:30:37 +0100

> On 12 Apr 2016, at 12:49, Ted Lemon <[email-masked]> wrote:
> 
> Agree about Buenos Aires.   We already do excellent virtual interims--I think if your standard for whether we can do a virtual IETF is that virtual interims work, we are already there.
> 
> I think that if we want to test this idea, what we need to do is designate some future IETF virtual _now_, and then start preparing, rather than say "oh, we should do a virtual" and then dither about when we might be ready.   We will never be so ready that a virtual IETF feels identical to an in-person IETF, so let's just abandon that idea and get started on making a virtual IETF that, while different, is still a success.

Sounds interesting, if something of a big leap to attempt. Is a larger wholly virtual, multiple WG interim meeting a next step then?

Btw where do we get the virtual T-shirt? ;)

Tim

> 
> On Tue, Apr 12, 2016 at 7:43 AM, Tim Chown <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> > On 12 Apr 2016, at 00:54, Ted Lemon <[email-masked] <mailto:[email-masked]>> wrote:
> >

---

From: Tim Chown <[email-masked]>
Date: Tue, 12 Apr 2016 13:35:40 +0100

> On 12 Apr 2016, at 13:19, Mikael Abrahamsson <[email-masked]> wrote:
> 
> I have spent the past meetings doing frequent jabber scribe work. I use Meetecho to do this, and I place myself next to the front participant mic (so I can see the name tag of the person speaking), and then I type on jabber the name of who the person speaking in the mic. There is (I've been told) now a suggestion to the IETF secritariat to reserve the seat next to the front mic (at table) for Jabber scribe, and this would be great. Now we just need to teach everybody to flash their badge to the jabber scribe as well.

I also do this, and agree it’s a good idea.

> I have long offered to call out the slides (which is typically needed for people who are on audio+jabber only) if someone wanted it, but the past few meetings nobody has requested that. My guess is that most people use Meetecho because it gives the complete view of what's going on, you get chat+presentation+video+sound, and you can also ask questions (which was used numerous times in the sessions I participated in).

I also noticed that remote people don’t seem to want slide numbers called out now. Might be interesting to see if we have stats on numbers of people listening to the old school audio-only streams, or on non-Meetecho participants in Jabber (the login IDs of Meetecho people is distinctive there…), just to get some data points on current trends.

> Generally, I'm very happy with Meetecho (wonders of HTML5+WEBRTC to be able to run this in just a browser). There were some initial sound problems on monday morning, but that was quickly rectified.
> 
> I also really appreciate the fact that I can call out "meetecho" in the jabber room to notify them of potential problems, and they immediately dispatch someone to fix the problem (including alerting the A/V crew if it's a local issue).

Just like Beetlejuice :)

> So while there were a few hiccups, I'd say most of the time Meetecho and the local A/V works great.

Agreed.

Tim

---

From: Rich Kulawiec <[email-masked]>
Date: Tue, 12 Apr 2016 08:46:39 -0400

On Tue, Apr 12, 2016 at 07:57:53AM -0400, [email-masked] wrote:
> Your suggestion of not having them would subtract value from the process

The win is that all of the time and effort and expense (all of which
are finite resources) that go into those could be directed elsewhere.

> The conference
> difference between attending and not.

It's not just the money, as I've said several times.  It's the time:
not everyone has the incredible luxury of being able to be away from their
job or their family.  It's the travel expense and the travel hassle/risk,
both of which are increasing.  It's the political/legal climate that
attendees are exposed to.  It's the problem of unrestricted Internet
access.  It's the increasingly-intrusive border crossings.  It's all
the factors that go into being there in person for several days.

These meetings select for a highly limited (by circumstance, by necessity,
and by choice) subset.  And once upon a time, when the 'net was much
younger and more limited in terms of geography and scope, that might
have been alright, because the subset mapped fairly well onto the larger
set of people involved in networking.  But that's no longer true.
And the difficulties/expense of travel are only going to get worse
for the forseeable future: they're not going to get better.

---rsk

---

From: Loa Andersson <[email-masked]>
Date: Tue, 12 Apr 2016 20:49:27 +0800

All,

> and diversity -- and I think those qualities are increasingly necessary.

I don't think we should entertain ideas about *replace* f-2-f meetings.

I think we could entertain ideas about IETF wide remote meetings, but
don't think that such meetings should be modeled after the f-2-f
meetings.

For example we should take the opportunity to get rid of all colliding
meetings, i.e. run just meeting (wg or other) at the time.

Let us say that we set aside enough time about half way between two IETF
meetings and schedule all the meetings, as requested by wg chairs or
people in charge of other meetings, as a long series.

Let us assume that the wg meetings is on average 1.5 hours, scheduling
100 wg meetings would require 150 hours.

/Loa

---

From: Loa Andersson <[email-masked]>
Date: Tue, 12 Apr 2016 21:18:12 +0800

Folks,

> Meetecho has a ‘hum’ button, which throws ‘hmmmmmm’ into the jabber room for the WG. I did see it used, once.

Let me return to the start of this discussion.

It seems to me that the LGBTQ peoples concern about a meeting in
Singapore is real, at least it is perceived to be real.

I don't think anything that is within our power to do can change this
perception.

Thus we need to take this seriously, the concerns is about our upcoming
meeting in Singapore. That should be our focus.

/Loa

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 09:22:54 -0400

The problem with a larger virtual interim is that it doesn't replace an
IETF, and so you're adding workload but not subtracting any workload.   I
don't see the point in that.

On Tue, Apr 12, 2016 at 8:30 AM, Tim Chown <[email-masked]> wrote:

> Sounds interesting, if something of a big leap to attempt. Is a larger
> wholly virtual, multiple WG interim meeting a next step then?
>

---

From: Alia Atlas <[email-masked]>
Date: Tue, 12 Apr 2016 09:33:12 -0400

> don't see the point in that.

It clocks those working groups at a higher rate.  Many people find it
easier to prioritize IETF work when there are specific deadlines or a loss
of face if work isn't done.

While the IETF determines consensus on mailing lists, there has been a
strong tendency in the last decade to focus on the physical meetings for
the next deadline, to have necessary talks, and so on.   I personally feel
that it is important to push back on this.

Discussing an issue on the mailing list suffers from people losing state on
the issue being talked about - for instance:
     Day 1: Alice reviews a draft and posts her review with a technical
point to consider.  Bob, an author, sees the email but is
                in the midst of a day-job priority.
     Day 4: Bob reads the email, rereads the draft section, and suggests a
fix.  Alice sees email, but is focused on day-job.
     Day 8: Alice refreshes her memory and responds with a point that
wasn't handled.
etc.

A benefit of virtual interims is that folks try to be up to speed and that
conversational back and forth can happen.
We do the same thing - aspirationally - on WGLCs on the mailing lists where
a two-week period is set aside to focus on a
particular draft.

Regards,
Alia

>> I think that if we want to test this idea, what we need to do is
>> designate some future IETF virtual _now_, and then start preparing, rather
>> than say "oh, we should do a virtual" and then dither about when we might
>> be ready.   We will never be so ready that a virtual IETF feels identical
>> to an in-person IETF, so let's just abandon that idea and get started on
>> making a virtual IETF that, while different, is still a success.
>>
>>
>>> a) re-use previous successful meeting venues for the bulk of our
>>> meetings (say, every 5 in 6 meetings); this is one criteria for meeting
>>> selection as it stands anyway; that list might include venues like Prague,
>>> Berlin, Vancouver, etc.; we’d need to be clear in what ‘successful’ means -
>>> the meeting feedback forms provide one such mechanism;
>>>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 09:34:37 -0400

I think that at this point the question of what we can do to address the
Singapore problem is in the hands of the IAOC, which has indicated a
willingness to explore going even further than Ted asked them to in
addressing the problem.   Ted asked them to not bring their families to
Singapore in solidarity with him, since he doesn't feel safe bringing his
family.   The IAOC has said they are looking into how difficult it would be
to actually move IETF 100 to a different country.   So I don't think
there's anything for us to discuss here, unless you are a member of the
LGBTQ+ community and have something to add about how you think Singapore
should be handled.

Your point about derailment makes sense, though--this is definitely a
separate issue from the "virtual IETF" issue.

On Tue, Apr 12, 2016 at 9:18 AM, Loa Andersson <[email-masked]> wrote:

>>> The only thing you mentioned that can't be done with existing
>>> conferencing software is hums, and I'm sure we could figure out a way to
>>> make that work.  It's not rocket science.   Chairs who judge consensus by
>>> looking at the room aren't following IETF process--consensus is judged on
>>> the mailing list.  Hums are useful for figuring out why we _don't_ have
>>> consensus, and for _getting_ to consensus, but if you were to judge
>>> consensus by hums or a show of hands, then you'd be taking a vote, wouldn't
>>> you?
>>>
>>

---

From: <[email-masked]>
Date: Tue, 12 Apr 2016 09:37:04 -0400

> are finite resources) that go into those could be directed elsewhere.

The meetings and their fees are income positive, they aren't a drain on
resource, the opposite in fact.

> for the forseeable future: they're not going to get better.

I think it would be useful to get some real data to measure exactly how
highly limited that subset of people are. Perhaps as a simple first
shot we could take email sent to IETF working group mailing lists over
the last year, and cross reference that against the registrations lists
of the last 3 IETFs and see what percentage of people doing IETF work
cannot or choose not to attend the on-site meetings?

Thanks,
Chris.

---

From: Tim Chown <[email-masked]>
Date: Tue, 12 Apr 2016 14:42:20 +0100

> On 12 Apr 2016, at 14:22, Ted Lemon <[email-masked]> wrote:
> 
> The problem with a larger virtual interim is that it doesn't replace an IETF, and so you're adding workload but not subtracting any workload.   I don't see the point in that.

Well, there may be a number of WGs that wish to progress their work a bit more briskly, or have one or more specific topics that need prompt discussion, and use an interim meeting to achieve that. So I’m not sure it’s adding to workload, rather it may allow us to be more efficient.  But the main issue with any virtual meeting is timezones. There’s really no way to deal with that problem satisfactorily. 

Tim

> 
> On Tue, Apr 12, 2016 at 8:30 AM, Tim Chown <[email-masked] <mailto:[email-masked]>> wrote:
>> On 12 Apr 2016, at 12:49, Ted Lemon <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 09:47:52 -0400

When I had to miss Prague, I just time-shifted for the week.   Wouldn't
work for everyone, but it seemed fine to me.

On Tue, Apr 12, 2016 at 9:42 AM, Tim Chown <[email-masked]> wrote:

> Well, there may be a number of WGs that wish to progress their work a bit
> more briskly, or have one or more specific topics that need prompt
> discussion, and use an interim meeting to achieve that. So I’m not sure
> it’s adding to workload, rather it may allow us to be more efficient.  But
> the main issue with any virtual meeting is timezones. There’s really no way
> to deal with that problem satisfactorily.
>
> Tim
>
>

---

From: Mary Barnes <[email-masked]>
Date: Tue, 12 Apr 2016 09:09:36 -0500

> resource, the opposite in fact.
[MB] I would agree when it comes to dollars, but people (i.e., the effort
to which Rich is referring) are also a resource and volunteers do the
work.  If the only volunteers you get are from large companies, I think the
IETF does lose.  With improved remote participation, individuals that
aren't sponsored by large companies can continue to contribute.  Without
it, we become ineffective.  [/MB]

> [MB] There was a separate list of registered remote attendees for this
recent meeting. You can take a look there and see a number of long time
contributors and some WG chairs (myself included) that have participated
remotely.  The very reason I did not go was due to lack of funding.  There
are a number of us that have contributed significantly over the past 15-30
years that would like to continue to do so but as independent consultants,
some of these trips are just not fiscally possible.  I went to Yokohama so
couldn't even entertain the idea of attending the meeting in BA without a
sponsor.    And, I seriously doubt I can continue as a WG chair if I can't
get funding in the future.  So, in the end, the current model self selects
and benefits the larger companies over individuals that really do want to
do work for the "good of the Internet" but just can't justify the expense.
  [/MB]

---

From: Christian Hopps <[email-masked]>
Date: Tue, 12 Apr 2016 10:20:58 -0400

> On Apr 12, 2016, at 10:09 AM, Mary Barnes <[email-masked]> wrote:
> 
> 
> 
> On Tue, Apr 12, 2016 at 8:37 AM,  <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Rich Kulawiec <[email-masked] <mailto:[email-masked]>> writes:
> 
> > On Tue, Apr 12, 2016 at 07:57:53AM -0400, [email-masked] <mailto:[email-masked]> wrote:
> [MB] I would agree when it comes to dollars, but people (i.e., the effort to which Rich is referring) are also a resource and volunteers do the work.  If the only volunteers you get are from large companies, I think the IETF does lose.  With improved remote participation, individuals that aren't sponsored by large companies can continue to contribute.  Without it, we become ineffective.  [/MB]
> 
> [MB] There was a separate list of registered remote attendees for this recent meeting. You can take a look there and see a number of long time contributors and some WG chairs (myself included) that have participated remotely.  The very reason I did not go was due to lack of funding.  There are a number of us that have contributed significantly over the past 15-30 years that would like to continue to do so but as independent consultants, some of these trips are just not fiscally possible.  I went to Yokohama so couldn't even entertain the idea of attending the meeting in BA without a sponsor.    And, I seriously doubt I can continue as a WG chair if I can't get funding in the future.  So, in the end, the current model self selects and benefits the larger companies over individuals that really do want to do work for the "good of the Internet" but just can't justify the expense.   [/MB]

I myself am on that remote list. I've heard the B.A. meeting was hard for many people (although this is anecdotal), and is a separate issue of contention for some. This is why I suggested the last 3 meetings, and a year of email so that the sample was large enough to not run in to particulars for each attendee who may not have been able to attend all, but rather some meetings.

I also think we have ways to make meetings more affordable, but Rich indicated this was only one of many concerns.

I think we need to look at a good sampling of the data at this point.

Thanks,
Chris.

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 12 Apr 2016 07:47:25 -0700 (PDT)

You said:

"I don't think anything that is within our power to do can change this
perception."

Perhaps some information from "the ground" and from frequent visitors
to Singapore who would have concerns about these issue *might* help.

Let's gather the data before we throw the baby out with the bath water
so to speak.

Ole

Ole J. Jacobsen
Editor and Publisher

---

From: Theodore V Faber <[email-masked]>
Date: Tue, 12 Apr 2016 15:02:45 +0000

On 4/12/16 04:50, Ted Lemon wrote:
> Agree about Buenos Aires.   We already do excellent virtual
> interims--I think if your standard for whether we can do a virtual
> IETF is that virtual interims work, we are already there.
> 
> designate some future IETF virtual _now_, and then start
> preparing, rather than say "oh, we should do a virtual" and then
> dither about when we might be ready.   We will never be so ready
> that a virtual IETF feels identical to an in-person IETF, so let's
> just abandon that idea and get started on making a virtual IETF
> that, while different, is still a success.

+1 on the approach.  I'm not a huge proponent of virtual meetings, but
setting deadlines motivates us.  This should not be news to anyone.

- -- 
Ted Faber <[email-masked]>
Engineering Specialist
Computer Systems Research Department
310-336-7373

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 12 Apr 2016 11:42:18 -0400

I believe that there would be a real cost in moving to remote-only 
meetings.  Even putting aside the time zone difficulties, and the 
reduced effectiveness of in-meeting interaction, there are aspects of 
face-to-face interaction taht current remote technologies simply do not 
capture.
It was very helpful in BA (and at many previous IETF meetings) to be 
able to find time to talk with a small number of people concerned about 
an aspect of one working group.  I did that over meals, breaks, etc.  It 
sorted out issues far more effectively than email conversations (in 
several cases, we had tried to sort it out via email.  10 minutes 
face-to-face clarified what was being missed, and found a good path 
forward.)

Even in-meeting, when the meeting works well it takes advantage of the 
nature of face-to-face interactions.  Admittedly, many sessions do not 
need this, but many do.

Yours,
Joel

On 4/12/16 10:09 AM, Mary Barnes wrote:
>     > On Tue, Apr 12, 2016 at 07:57:53AM -0400,[email-masked] <mailto:[email-masked]> wrote:
> [MB] I would agree when it comes to dollars, but people (i.e., the
> effort to which Rich is referring) are also a resource and volunteers do
> the work.  If the only volunteers you get are from large companies, I
> think the IETF does lose.  With improved remote participation,
> individuals that aren't sponsored by large companies can continue to
> contribute.  Without it, we become ineffective.  [/MB]
>
>
> remotely.  The very reason I did not go was due to lack of funding.
> There are a number of us that have contributed significantly over the
> past 15-30 years that would like to continue to do so but as independent
> consultants, some of these trips are just not fiscally possible.  I went
> to Yokohama so couldn't even entertain the idea of attending the meeting
> in BA without a sponsor.    And, I seriously doubt I can continue as a
> WG chair if I can't get funding in the future.  So, in the end, the
> current model self selects and benefits the larger companies over
> individuals that really do want to do work for the "good of the
> Internet" but just can't justify the expense.   [/MB]
>
>     Thanks,
>     Chris.
>
>
>      >
>      > ---rsk
>
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 12:00:59 -0400

This is all true, but the idea that it can't be replicated online is silly.
  How did you arrange to have lunch with these people?   You went looking
for them, rounded them up, and sat down to lunch.   You can do that online
as well.

It is certainly true that random conversation in the halls can also happen
and lead to useful consequences, but having taken heavy advantage of
"running into people" in BA, I can tell you that a lot of it was
deliberate, and the parts that weren't probably would have been triggered
by WG meetings even if they hadn't been triggered by just running into
someone familiar in the lobby of the Hilton.

On Tue, Apr 12, 2016 at 11:42 AM, Joel M. Halpern <[email-masked]>
wrote:

> meetings.  Even putting aside the time zone difficulties, and the reduced
> effectiveness of in-meeting interaction, there are aspects of face-to-face
> interaction taht current remote technologies simply do not capture.
> It was very helpful in BA (and at many previous IETF meetings) to be able
> to find time to talk with a small number of people concerned about an
> aspect of one working group.  I did that over meals, breaks, etc.  It
> sorted out issues far more effectively than email conversations (in several
> cases, we had tried to sort it out via email.  10 minutes face-to-face
> clarified what was being missed, and found a good path forward.)
>
> nature of face-to-face interactions.  Admittedly, many sessions do not need
> this, but many do.
>
> Yours,
> Joel
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 12 Apr 2016 12:15:00 -0400

Ted, you missed my point.  Yes, I can arrange a call with the relevant 
people.  And I frequently do.
It is harder, but that would be acceptable.

The important part is that such calls are MUCH less effective than 
face-to-face discussions.  There are lots of well-known reasons for this.

And no, inc ase it was not obvious, without the face-to-face meeting, 
there is no way to arrange such face-to-face meetings.

Yes, we should work to make remote participation more effective.  Doing 
away with the face-to-face meetings reminds me of the old SF story of 
the ballet dancers who were forced to dance wearing extra weights, to be 
"fair" to the less talented dancers.

Yours,
Joel

On 4/12/16 12:00 PM, Ted Lemon wrote:
> This is all true, but the idea that it can't be replicated online is
> silly.   How did you arrange to have lunch with these people?   You went
> looking for them, rounded them up, and sat down to lunch.   You can do
> that online as well.
>
> It is certainly true that random conversation in the halls can also
> happen and lead to useful consequences, but having taken heavy advantage
> of "running into people" in BA, I can tell you that a lot of it was
> deliberate, and the parts that weren't probably would have been
> triggered by WG meetings even if they hadn't been triggered by just
> running into someone familiar in the lobby of the Hilton.
>
>
> On Tue, Apr 12, 2016 at 11:42 AM, Joel M. Halpern <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     reduced effectiveness of in-meeting interaction, there are aspects
>     of face-to-face interaction taht current remote technologies simply
>     do not capture.
>     able to find time to talk with a small number of people concerned
>     about an aspect of one working group.  I did that over meals,
>     breaks, etc.  It sorted out issues far more effectively than email
>     conversations (in several cases, we had tried to sort it out via
>     email.  10 minutes face-to-face clarified what was being missed, and
>     found a good path forward.)
>
>     Even in-meeting, when the meeting works well it takes advantage of
>     the nature of face-to-face interactions.  Admittedly, many sessions
>     do not need this, but many do.
>
>     Yours,
>     Joel
>
>         On Tue, Apr 12, 2016 at 8:37 AM, <[email-masked]
>         <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>
>
>              Rich Kulawiec <[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>> writes:
>
>
>              > On Tue, Apr 12, 2016 at 07:57:53AM
>         -0400,[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>> wrote:

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 12 Apr 2016 13:24:26 -0300

> In London in 2014, do you know whether we were behind the national

I am not sure that they actually filter.

I think it rather more likely that if you were to surf to
kiddieporn.com from the Hilton Metropole, that you would find Mr Plod
knocking on your hotel room door 15 minutes later. That being the
driving time from New Scotland Yard.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 12:24:21 -0400

I think there was a story like that about football players too.   However,
I have not had the same experience you have.   I think that zero f2f
meetings is bad, and Iim not advocating that.   But it is quite possible to
be effective in a voice chat, and even more so in a video chat.   The idea
of a virtual meeting would be to try to set things up so that peoples
schedules are cleared and we can have informal meetings as well as formal
ones.

On Tue, Apr 12, 2016 at 12:15 PM, Joel M. Halpern <[email-masked]>
wrote:

> away with the face-to-face meetings reminds me of the old SF story of the
> ballet dancers who were forced to dance wearing extra weights, to be "fair"
> to the less talented dancers.
>
> Yours,
> Joel
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 12:52:40 -0400

The UK filter is an "opt out" filter, and I assume that we (the IETF) opted
out.   Even the "opt out" blocking is voluntary at present--an ISP is not
required by law to have a filter, but in practice the big ones do.

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 12 Apr 2016 13:55:00 -0300

Hi,

On Tue, Apr 12, 2016 at 10:34 AM, Ted Lemon <[email-masked]> wrote:

> family.

​Ted has a point and it is a concern that we (as a part of the gay
community) have to deal with it daily.

> The IAOC has said they are looking into how difficult it would be to
> actually move IETF 100 to a different country.
>

​But, to me this is interesting, that we took the discussion, from
solidarity and understanding of the difficulties that the gay community
faces, to sort of escaping it and not dealing with it. By setting this
precedence I am afraid IETF would not take place in a large part of the
world in coming years.

And isn't that excluding people (which BTW *also* includes the members of
the same gay community, but from this part of the world)?

> So I don't think there's anything for us to discuss here, unless you are a
> member of the LGBTQ+ community and have something to add about how you
> think Singapore should be handled.
>

​I talked to my openly gay friends living in Singapore and told them about
the discussions that's happening here. For what it's worth, I will pass on
details to IAOC if that helps.

Thanks!
Dhruv

​PS. I agree that getting early feedback about a new place is a good idea
and should be followed in future. ​

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 13:01:34 -0400

I suppose another way to frame it is to ask how many LGBTQ+ folks in
Singapore would be included because of an IETF in Singapore, versus how
many LGBTQ+ folks not in Singapore would feel excluded or disadvantaged
because of an IETF in Singapore.   Because I'm not personally impacted by
this, I don't really have a sense of how one could evaluate that.   I think
sharing your thoughts about this with the IAOC would be a very good idea.

On Tue, Apr 12, 2016 at 12:55 PM, Dhruv Dhody <[email-masked]> wrote:

>> So I don't think there's anything for us to discuss here, unless you are
>> a member of the LGBTQ+ community and have something to add about how you
>>>> Meetecho has a ‘hum’ button, which throws ‘hmmmmmm’ into the jabber
>>>> room for the WG. I did see it used, once.
>>>>
>>>

---

From: Melinda Shore <[email-masked]>
Date: Tue, 12 Apr 2016 09:02:44 -0800

On 4/12/16 3:57 AM, [email-masked] wrote:
> But this is not how the IETF operates.

Actually, it's very much how the IETF operates in practice,
particularly with meeting participation becoming increasingly
expensive and with increased participation from "standards
professionals."  If you've been to meetings you'll have
noticed some chairs taking votes in meetings (rather than
relying on consensus processes) and saying that they'll
ratify or confirm that decision on the mailing list (if
they remember - sometimes they don't).

In some sense the Singapore announcement felt to me as if
we'd completed the transition to plain ol' standards body,
distinguishable from the others by what we say rather than
by what we do.

One of the things I've been thinking about over the past
<n> years is how to reduce our reliance on meetings, and
I'm overdue on writing up a draft on it.  I think it's
an important question, since de-emphasizing (not eliminating)
meetings is one thing we can do to keep participation more
open and accessible.

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Tue, 12 Apr 2016 09:09:01 -0800

> I think we need to look at a good sampling of the data at this point.

Have at it.

Melinda

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 12 Apr 2016 14:17:28 -0300

That is the parental filter, if you don't opt out, you get pestered by
continuous messages asking you if you want to like it was an O/S
upgrade.

The child porn filtering is separate and I suspect is using the type
of BGP and IP intercept techniques that are commonly used to shut down
a large range of Internet crimes in pretty much every jurisdiction,
the US included.

On Tue, Apr 12, 2016 at 1:52 PM, Ted Lemon <[email-masked]> wrote:
> On Tue, Apr 12, 2016 at 12:24 PM, Phillip Hallam-Baker
> <[email-masked]> wrote:
>>

---

From: Theodore V Faber <[email-masked]>
Date: Tue, 12 Apr 2016 17:33:49 +0000

On 4/12/16 09:15, Joel M. Halpern wrote:
> Ted, you missed my point.  Yes, I can arrange a call with the
> relevant people.  And I frequently do. It is harder, but that would
> be acceptable.
> 
> And no, inc ase it was not obvious, without the face-to-face
> meeting, there is no way to arrange such face-to-face meetings.

If the goal of the IETF is to replicate the experience of an IETF
meeting using telepresence tools, that is an impossible task.
Telepresence is not being present.

To my mind, the question is if a large scale use of telepresence tools
can create a working environment that the IETF membership can use to
advance the IETF's goals.  I'm curious enough about that question to
support an assessment of how expensive and difficult it would be to
replace one IETF meeting with a large scale telepresence experiment.

I think we should evaluate that experiment (should it occur) based on
whether or not the broader goals advance (standards and documents
advance, new ideas are sparked, the membership is appropriately
updated), not how they are advanced (discussions at the Scotch BOF,
plenary and BA, speaking at the mic in WG meetings).

I seems to me that a successful experiment would mean that we use more
large scale telepresence.  It may someday turn out that such events
replace some IETF meetings; it may not.  I don't know of any
organizations of the scale of the IETF that have historically relied
on face to face meetings and transitioned solely to large scale
telepresence, so my expectation is that IETF meetings will continue.

(Just to forestall the question: Anonymous seems to run entirely on
large scale telepresence (for some definition thereof).  It's got a
whole set of procedures and traditions that enable that.  It's a
fascinating situation, but I see little inspiration or intuition for
changing IETF procedures from it.)

> 
> Yes, we should work to make remote participation more effective.
> Doing away with the face-to-face meetings reminds me of the old SF
> story of the ballet dancers who were forced to dance wearing extra
> weights, to be "fair" to the less talented dancers.

Paging Harrison Bergeron.
https://en.wikipedia.org/wiki/Harrison_Bergeron

- --

---

From: Miles Fidelman <[email-masked]>
Date: Tue, 12 Apr 2016 13:41:59 -0400

On 4/12/16 1:33 PM, Theodore V Faber wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>

I would think that a major open source project might be more of an 
example - perhaps Debian?

---

From: Theodore V Faber <[email-masked]>
Date: Tue, 12 Apr 2016 17:58:15 +0000

On 4/12/16 10:42, Miles Fidelman wrote:
>> (Just to forestall the question: Anonymous seems to run entirely
>> on large scale telepresence (for some definition thereof).  It's
>> got a whole set of procedures and traditions that enable that.
>> It's a fascinating situation, but I see little inspiration or
>> intuition for changing IETF procedures from it.)
>> 
> 

I don't want to get too far down this particular rathole, but in my
experience a lot of those organizations do have a significant
component of their interactions at conventions/conferences.  (Not in
the sense that total time is spent there, but that key interactions
occur there.) Most organizations (probably even Anonymous) sit
somewhere on a spectrum between face-to-face and online interactions.
 I'd rather not build a taxonomy, though.

- --

---

From: Melinda Shore <[email-masked]>
Date: Tue, 12 Apr 2016 09:51:03 -0800

> example - perhaps Debian?

A standards body example would be the W3C, which meets 1x/year,
but whose working groups have frequent teleconferences.

Melinda

---

From: <[email-masked]>
Date: Tue, 12 Apr 2016 14:01:16 -0400

> they remember - sometimes they don't).

I know for a fact it is not how I and my co-chair run the IS-IS WG. I
can't speak to whether other WGs are being run incorrectly. It's the
responsibility of the participants and the ADs to make sure the
chairs are not violating our own standards process though.

Thanks,
Chris.

---

From: <[email-masked]>
Date: Tue, 12 Apr 2016 14:07:26 -0400

>> I think we need to look at a good sampling of the data at this point.

I would like to actually. :) I'm wondering how I might go about getting
all the email From addresses from every WG archive for the last year.
I'm thinking if all archives are now hosted by mailman there's probably
a way to script this.

Thanks,
Chris.

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 12 Apr 2016 18:32:37 +0000

I encourage people who have suggestions on how to do remote meetings to join the conversation in [email-masked].

	Tony Hansen

---

From: Melinda Shore <[email-masked]>
Date: Tue, 12 Apr 2016 10:33:53 -0800

> chairs are not violating our own standards process though.

Well, I participate in working groups other than the ones
I chair and yes, there are working group chairs taking votes
and making decisions in meetings.  This is the way things are.
Ignoring how things are and hewing unreflectively to the ought-
to-be is one of the major things that got us to where we are
with NAT, among other problems.

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Tue, 12 Apr 2016 10:37:10 -0800

> I'm thinking if all archives are now hosted by mailman there's probably

I believe the IMAP interface is now available, and there's
always the option to screen-scrape the text archives:
http://ietf.org/mail-archive/text/

Melinda

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 12 Apr 2016 19:56:34 +0100

Note I did say "as far as I was concerned".

The only reason I go to IETF is to work F2F with people
to design protocols. All I am looking for in a venue
is to do that and nothing else for five and a half days.

Stewart

---

From: Andy Bierman <[email-masked]>
Date: Tue, 12 Apr 2016 12:08:38 -0700

Hi,

I agree that f2f meetings are best.
If not for the ad-hoc meetings, many of us would have
stopped going to IETFs a long time ago.  The official
meeting slots have devolved into status updates and slide presentations.

But don't think for a second that 20 hours of travel each way and thousands
of dollars in expenses are easy on anybody, As the remote tools keep getting
better, many of us will be asking if IETF travel is really worth it.

Andy

---

From: Ted Lemon <[email-masked]>
Date: Tue, 12 Apr 2016 15:20:49 -0400

True.   I flew to BA, got to speak a little bit of Spanish (badly) and a
lot of english, then flew home.   I took some pictures of El Puente de la
Mujer, but basically didn't get more than a quarter mile from the hotel
more than once the whole time I was there.   But the point of going to
different places is for the people who live there, not for us (except to
the extent that we live there).

On Tue, Apr 12, 2016 at 2:56 PM, Stewart Bryant <[email-masked]>
wrote:

>> On 4/11/16, 10:28 AM, "ietf on behalf of Stewart Bryant" <
>> [email-masked] on behalf of [email-masked]> wrote:
>>

---

From: "John R Levine" <[email-masked]>
Date: 12 Apr 2016 16:17:02 -0400

> out. ...

This isn't the parental filter, this is the child porn filter, which I am 
fairly sure is mandatory, at last on consumer ISPs.

A few years ago they listed a Wikipedia page which had an image of an old 
rock record cover with a small nude girl behind a cracked pain of glass. 
They eventually backed down when people pointed out why that particular 
entry was silly, e.g., the record had been available in used record stores 
for decades.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail.

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 12 Apr 2016 23:09:49 +0200

Den 12. april 2016 18:52, skrev Ted Lemon:
> The UK filter is an "opt out" filter, and I assume that we (the IETF)
> opted out.   Even the "opt out" blocking is voluntary at present--an ISP
> is not required by law to have a filter, but in practice the big ones do.

The particular case that made the blacklist famous in at least some
fora, and exposed quite a bit on how it worked:

https://en.wikipedia.org/wiki/Internet_Watch_Foundation_and_Wikipedia

"the action also had some indirect effects on Wikipedia, namely
temporarily preventing all editors using said ISPs in the UK from
contributing to any page of the encyclopaedia, and preventing anonymous
edits from these ISPs while the URL remained on the blacklist. This was
described by the IWF as unintended "collateral damage".[7] This was due
to the proxies used to access Wikipedia, as Wikipedia implements a
blocking policy whereby contributors can be blocked if they vandalise
the encyclopaedia. Therefore, all vandalism coming from one ISP would be
directed through one proxy—hence one IP—and all of the ISP's customers
using that proxy would be barred from editing."

> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     On Sun, Apr 10, 2016 at 3:19 PM, John Levine <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     kiddieporn.com <http://kiddieporn.com> from the Hilton Metropole,
>     that you would find Mr Plod

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 12 Apr 2016 17:27:44 -0400

> temporarily preventing all editors using said ISPs in the UK from
​this ​

​is PROBABLY also for 'consumer isp connections' mostly and not 'business
isp' links, which the IETF uses at meetings. I suspect, anyway.. else you
may filter on the dsl/ftth/dial network AND re-filter on the backbone-isp
network and again if there's a third tier...

so the IETF simply sidestepped by pretending to be an 'enterprise' network.​

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Apr 2016 14:08:47 +1200

Cherry-picking a few points:
On 13/04/2016 00:46, Rich Kulawiec wrote:
...
> for the forseeable future: they're not going to get better.

That is indisputable.

> people in charge of other meetings, as a long series.

That won't work with 4-monthly meetings as today. It might work with
6-monthly meetings.

> 100 wg meetings would require 150 hours.

I think that's optimistic. Remote meetings go more slowly due to technology
glitches and the need for more formal patterns of Q/A. It's still faster than
email though (see Alia's message).

On 13/04/2016 03:42, Joel M. Halpern wrote:

> I believe that there would be a real cost in moving to remote-only meetings.
> Even putting aside the time zone difficulties, and the reduced effectiveness
> of in-meeting interaction, there are aspects of face-to-face interaction
> taht current remote technologies simply do not capture.

Yes. I've been on a one-meeting-per-year model once or twice for personal
reasons and it is *inferior* to attending every meeting. Some people
can manage to time shift their lives for a week for remote participation,
but most people can't; family, day job, and sunshine combine against it.
The time zone issue is exclusionary. Also, there is nothing like the
intensity of being on site with everybody.

Not to say that we shouldn't improve even more on what we can do
with Meetecho. But an important part of being able to make the best
use of remote participation is *knowing* the people at the other
end from previous in-person meetings.

> for them, rounded them up, and sat down to lunch. You can do that online

You can, but it's a much more deliberate action and you're less
likely to get serendipity effects. I would probably have been in
some of those discussions in BA that Joel mentioned, but unfortunately
I was on the wrong side of the world and fast asleep.

IMHO we need the right blend of in-person and virtual meetings, and
we'll find that blend by progressive change, not by revolution.

   Brian

---

From: Alia Atlas <[email-masked]>
Date: Tue, 12 Apr 2016 22:42:28 -0400

What I would love to see is some brainstorming on how to recreate the
serendipity of IETF hallway interactions.

For instance, could we have people sign up for "random 15-minute
conversations"
while indicating a general area (or set of WGs) of interest?   Think sort
of like
"speed-mentoring" but for all?   It could include video to get closer to
in-person
and maybe start with some suggested ice-breakers (favorite IETF meeting
site,
preferred beverage, best snack, first IETF meeting....)?

I can't beat the benefits of randomly seeing someone who didn't come
immediately
to mind - and knowing precisely who to go talk to (ok - I'm an AD -
encourage into
volunteering to do something).

Until we can recreate some of that randomness and recognition that we are
all
people who care about technology and the Internet (and have families,
opinions
on books, etc), I can't see that decreasing physical IETF meetings would be
at
all productive.

Regards,
Alia

On Tue, Apr 12, 2016 at 10:08 PM, Brian E Carpenter <
[email-masked]> wrote:

> several
> silly.

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 13 Apr 2016 09:17:55 +0200

>> > for the forseeable future: they're not going to get better.

Difficulties, yes. Expense - not so much.

http://www.rita.dot.gov/bts/airfares/programs/economics_and_finance/air_travel_price_index/html/AnnualFares.html

Average US domestic itinerary cost has gone down 30% over the last 20
years (inflation-adjusted); they seem to have hit a floor after 2009.

Note: Virtual interims tend towards more frequent meetings. Once you
pass the once-a-month level and move towards the once-a-week level, that
form of participation *severely* restricts the ability to participate of
the timezone-challenged compared to an email-heavy style of interaction.

---

From: Tim Chown <[email-masked]>
Date: Wed, 13 Apr 2016 10:49:04 +0100

> On 12 Apr 2016, at 22:09, Harald Alvestrand <[email-masked]> wrote:
> 
> using that proxy would be barred from editing.”

The broader context is here (with all the usual caveats over Wikipedia accuracy):

https://en.wikipedia.org/wiki/Internet_censorship_in_the_United_Kingdom

See the section on the Introduction of Cleanfeed.

The other controversy, as mentioned in the link above, is that in 2011 a judge ordered Cleanfeed be used to block access to a p2p filesharing system called Newzbin2, hence concern over creeping and unaccountable scope of filtering (because the filter list is not viewable due to the primary use of the system), see http://www.bbc.co.uk/news/technology-14322957. 

Tim

---

From: Tony Finch <[email-masked]>
Date: Wed, 13 Apr 2016 11:06:08 +0100

> fairly sure is mandatory, at last on consumer ISPs.

As I understand it this kind of filtering only applies to the largest
consumer ISPs. We don't have any filtering of that kind on the academic
network I help to look after, for example. The IETF network would not have
any filtering unless the IETF NOC put it in.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/  -  I xn--zr8h punycode
South Utsire: Easterly 4 or 5 decreasing 3. Moderate at first in west,
otherwise slight. Showers. Good.

---

From: tom p. <[email-masked]>
Date: Wed, 13 Apr 2016 12:09:18 +0100

----- Original Message -----
From: "Tony Finch" <[email-masked]>
To: "John R Levine" <[email-masked]>
Cc: "Phillip Hallam-Baker" <[email-masked]>; "IETF Discussion
Mailing List" <[email-masked]>
Sent: Wednesday, April 13, 2016 11:06 AM

> any filtering unless the IETF NOC put it in.

Well, applies to the consumer access supported by the ISP; get a
business contract with the ISP and AFAICT there is no filtering.  (Well,
there is, but of e-mail, not web access, based on rules on what is and
is not an acceptable e-mail, rules which are confidential and customers
are not allowed to know. I came across them when I sent an e-mail with
no subject and a three word body - this contravenes the AUP of the
ISP:-(

On the other hand, my local council filters web access heavily and
denies access to a number of wholy innocent sites, such as a bed and
breakfast in the country.  I have viewed the site from an academic
network and cannot see what it is the council have latched on to.

Tom Petch

---

From: Yoav Nir <[email-masked]>
Date: Wed, 13 Apr 2016 14:31:35 +0300

> On 13 Apr 2016, at 5:08 AM, Brian E Carpenter <[email-masked]> wrote:
> 

OK, I’ll bite. 

Expense goes up and down with the price of oil, competition, regulation and a zillion other factors. 

Difficulty?  Why do you think that is getting worse?  There was an increase in hassle shortly after 9/11, but I haven’t experienced any greater difficulties now as opposed to 10 years ago. Why do you think it’s set to become more difficult?

Yoav

---

From: Loa Andersson <[email-masked]>
Date: Wed, 13 Apr 2016 19:50:48 +0800

Brian,

> That won't work with 4-monthly meetings as today. It might work with

I'm inclined to agree. It would be, unless we are willing to throw
over board the tradition with 3 f2f meetings per year the same as saying
that remote IETF meetings are not on the agenda.

There are many reasons why we need the f2f meetings, I would not be
willing to give that mode of operation up.

/Loa

---

From: Rich Kulawiec <[email-masked]>
Date: Wed, 13 Apr 2016 07:53:36 -0400

> I encourage people who have suggestions on how to do remote meetings to join the conversation in [email-masked].

That'd be great, but at the moment the subscription form on this page:

	https://www.ietf.org/mailman/listinfo/vmeet

does not work.  (It results in a "403: Forbidden" error.  I've hit this
a bunch of times over the past few years with various IETF mailing lists,
so let me suggest that someone running the Mailman instance should step
through all of them and make sure that all the subscription pages work.)

---rsk

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 13 Apr 2016 09:09:48 -0400

> Let's gather the data before we throw the baby out with the bath water

My point much earlier on. :-)

-- Jeff

---

From: Ted Lemon <[email-masked]>
Date: Wed, 13 Apr 2016 10:46:41 -0400

Hm.  Beware of the Leopard.   However, it did work for me when I tried it
yesterday.

---

From: Theodore V Faber <[email-masked]>
Date: Wed, 13 Apr 2016 14:49:43 +0000

On 4/13/16 04:53, Rich Kulawiec wrote:
>> I encourage people who have suggestions on how to do remote
>> meetings to join the conversation in [email-masked].
> 
> does not work.

As another data point, I was able to subscribe by following that link.
 FWIW I even had to go through an http proxy (corporate config, not
choice).

- --

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 14 Apr 2016 09:10:11 +1200

> Difficulty?  Why do you think that is getting worse?  There was an increase in hassle shortly after 9/11, but I haven’t experienced any greater difficulties now as opposed to 10 years ago. Why do y…

You live in a country that's had very strict airport security since the 1970s
(and since I lived in Geneva then, I also remember when Geneva airport was
almost a military encampment, caused by exactly the same events). London got
tough in the 1970s too, for a different reason. It slowly spread across Europe
and the world, with the US remaining amazingly lax until 2001. There was certainly
a step function after 9/11 but it's really been a constant trend since ~1970.
I think you'll find that Paris and Brussels have recently got a lot tougher.
Now it's becoming an issue for long-distance trains in Europe. Expect more.

Regards
   Brian

On 13/04/2016 23:31, Yoav Nir wrote:
> .