Subject: Re: Last Call on draft-bradner-rfc3979bis-08.txt ("Intellectual Property Rights in IETF Technology")

From: John C Klensin <[email-masked]>
Date: Tue, 12 Apr 2016 05:29:08 -0400

--On Monday, April 11, 2016 15:33 -0700 Alissa Cooper
<[email-masked]> wrote:

>> Personally, I'd love to see the draft talk about AD
>> participation just like it talks about other people's
>> participation. If I really haven't participated in WG X,
>> well, I haven't, even if my co-AD owns the group :-) And if
>> I did participate, well, I should declare the IPR that I know
>> of :-)
> 
> +1
> This is what did not make sense to me about the draft. 

Alissa,

I'm fine with the above, but I think there is a delicate line
involved.  Let me try to explain it this way.  As a random
member of the community, whether I'm participating in a WG, or
even actively monitoring it, is fairly clear.  If, for example,
I'm attending its meetings (f2f or remotely) or signed up for
its mailing list, the community should be able to assume that
I'm watching the work in that WG and should be required to make
relevant IPR disclosures even if I don't actually say anything
or otherwise generate Contributions.    If I do none of those
things but occasionally check on mailing list archives, read
Last Call announcements, I think the community needs to take my
word for it if I claim to be "not participating".

I think things are a little different (but only a little) if
there is management involvement.  If you are the AD responsible
for a WG, then I think the community gets to assume that you
know what its work items are, have approved document editors,
and have at least read the abstracts of the various drafts,
i.e., that you are participating.  If you are some other AD in
the same area, well, areas differ a lot and over time.  In some
cases, ADs shadow each other as a mutual backup arrangements and
I'd expect to be able to treat all ADs in the same area as
"participating" in all WGs.  In others, WGs get divided up among
ADs, after which the area might as well be as many separate ones
as there are ADs.  At IETF evaluation time, any ADs who record a
position other that "abstain" on a spec, or to engage in any
IESG discussion about it, has presumably studied that spec
closely enough to incur disclosure obligations if IPR is known
to them because making a decision to adopt (or not) is clearly
"participation".  The same issue might exist with Co-chairs of a
WG with many tasks.  I'd normally assume that each one is
familiar with and participating in every work item, but it isn't
hard to imagine situations in which work might be split up along
clear boundaries with one co-chair getting involved in the work
of the other only at around the time of Last Call if then.

All of that said, I think that trying to create a collection of
very specific rules or definitions to cover each case and
variations on it is almost certain to cause more harm than good.
I think the intent of the rules -- that anyone who has
contributed to a spec or put themselves in a position in which
they influence an IETF decision to adopt (or not) or publish (or
not) has disclosure obligations (whether direct or third-party
as discussed in the I-D). My expectation is that WG Chairs and,
to even a greater extent, ADs, will be sensitive to the intent
of the rules.  To do otherwise would be a breach of the trust
the community placed in them and that would be at least as
serious, perhaps more, than breaching the letter of the IPR
rules.   

If we need rule changes in that area, they probably lie in
making recalls more feasible rather than more case analysis in
the IPR document(s).   If the latter documents need anything
extra, perhaps it is an explicit statement to the effect of
"Because of the trust the community places in them and the
consensus-determination and decision authority associated with
their positions, IETF Leadership including WG Chairs and Nomcom
appointees are expected to be especially diligent in observing
the intent of these rules".  

best.
     john

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 12 Apr 2016 09:50:38 -0700

> On Apr 12, 2016, at 2:29 AM, John C Klensin <[email-masked]> wrote:
> 
> 
> 
> the intent of these rules”.  

WFM
Alissa

---

From: Michael Cameron <[email-masked]>
Date: Tue, 12 Apr 2016 17:33:17 +0000

John said:

As a random member of the community, whether I'm participating in a WG, or even actively monitoring it, is fairly clear.  If, for example, I'm attending its meetings (f2f or remotely) or signed up for its mailing list, the community should be able to assume that I'm watching the work in that WG and should be required to make relevant IPR disclosures even if I don't actually say anything or otherwise generate Contributions.    

My response:

I appreciate that some are advocating for what they want the rules to be, but let's level set as to what they are.  Attending meetings, being signed up for mailing lists or watching work in a WG does not obligate one to make any IPR disclosures.  That was discussed in detail at the last IETF meeting when the IPR Group met (Orlando, IIRC). The IPR disclosure obligation arises only with respect to known IPR reading on Contributions (for Contributors) and for non-Contributors, the disclosure obligation only applies to known IPR reading on a draft on which such non-Contributor actively seeks to influence the outcome of the disposition of a draft (active participation).

John said:

If you are the AD responsible for a WG, then I think the community gets to assume that you know what its work items are, have approved document editors, and have at least read the abstracts of the various drafts, i.e., that you are participating.  If you are some other AD in the same area, well, areas differ a lot and over time.  In some cases, ADs shadow each other as a mutual backup arrangements and I'd expect to be able to treat all ADs in the same area as "participating" in all WGs.  In others, WGs get divided up among ADs, after which the area might as well be as many separate ones as there are ADs.  At IETF evaluation time, any ADs who record a position other that "abstain" on a spec, or to engage in any IESG discussion about it, has presumably studied that spec closely enough to incur disclosure obligations if IPR is known to them because making a decision to adopt (or not) is clearly "participation".  The same issue might exist with Co-chairs of a WG with many tasks.  I'd normally assume that each one is familiar with and participating in every work item, but it isn't hard to imagine situations in which work might be split up along clear boundaries with one co-chair getting involved in the work of the other only at around the time of Last Call if then.

My response:

We need to be careful not to place on Area Directors unreasonable burdens and obligations.  Further, there needs to be certainty as to what the obligations are.   The obligations imposed on Area Directors to declare known IPR should be limited to those activities in which they actively participate.  I'll defer to the ADs, but I would think that an AD acting on a recommendation or advice from a WG as to how to proceed on a Specification, without more, does not necessarily rise to the level of active participation.

Best, Mike

---

From: S Moonesamy <[email-masked]>
Date: Fri, 15 Apr 2016 04:03:43 -0700

Hi Mike,
At 10:33 12-04-2016, Michael Cameron wrote:
>My response:
>
>We need to be careful not to place on Area Directors unreasonable 
>burdens and obligations.  Further, there needs to be certainty as to 
>what the obligations are.   The obligations imposed on Area 
>Directors to declare known IPR should be limited to those activities 
>in which they actively participate.  I'll defer to the ADs, but I 
>would think that an AD acting on a recommendation or advice from a 
>WG as to how to proceed on a Specification, without more, does not 
>necessarily rise to the level of active participation.

 From what I read, the duty to disclose in the U.S. "does not extend 
to typists, clerks, and similar personnel".

There is the following text in Standards Track RFCs: "It has received 
public review and has been approved for publication by the Internet 
Engineering Steering Group (IESG)".

In the last sentence of the text quoted above there is the following: 
"I'll defer to the ADs".  Would a reasonable person conclude that an 
IETF participant with a good understanding of the IETF "Note Well" 
defer to a typist on a matter which is important?  Furthermore, would 
an Area Director describe his/her work as being similar to a clerk in 
his/her biography?

Does the fact that an Area Director has the authority to share the 
responsibility for the approval of a Standards Track RFC constitute 
"active participation"?

Regards,
S. Moonesamy