Subject: Tracking IANA protocol registry changes

From: Florian Weimer <[email-masked]>
Date: Tue, 08 Nov 2016 12:23:31 +0100

As far as I can tell, some IANA protocol registries change
occasionally, without any IETF paper trail.

Is there a way to subscribe to all such changes?  How can I access
older contents of the registry?

---

From: "John Dickinson" <[email-masked]>
Date: Tue, 08 Nov 2016 11:34:00 +0000

> older contents of the registry?

+1

I would also like to see some visibility into the registries and things like new TLD’s (grouped by type and sorted by date of entry). I would like a query mechanism as well as a subscription.

John Dickinson

http://sinodun.com

Sinodun Internet Technologies Ltd.
Magdalen Centre
Oxford Science Park
Robert Robinson Avenue
Oxford OX4 4GA
U.K.

---

From: John C Klensin <[email-masked]>
Date: Tue, 08 Nov 2016 08:34:52 -0500

--On Tuesday, November 08, 2016 11:34 +0000 John Dickinson
<[email-masked]> wrote:

>...
> I would also like to see some visibility into the registries
> and things like new TLD's (grouped by type and sorted by
> date of entry). I would like a query mechanism as well as a
> subscription.

Take this up with ICANN -- not an IETF problem.

Rhetorical question, please do not clutter up this list with an
answer:  Out of curiosity, what would you be prepared to pay for
such services, which would involve both development and ongoing
costs, however small?  Or are you somehow entitled to free
lunches?

Note, too, that IANA staff, especially staff associated with the
TLD registry, do not work for the IETF and may not carefully
follow this list.   If you want to contact them, try
[email-masked].

   john

---

From: S Moonesamy <[email-masked]>
Date: Tue, 08 Nov 2016 06:14:36 -0800

Hi Florian,
>older contents of the registry?

There is usually an IETF paper trail for changes to protocol 
registries.  It looks like you are interested in the IANA end.  I 
suggest sending an email to IANA about that and the second question.

Regards,
S. Moonesamy

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 8 Nov 2016 15:18:25 +0000

John and Florian,

Thank you for your feedback and suggestions below.  This is something we also received comments on in our customer satisfaction survey.  We are going to explore options for making this possible.

If you or any other community member has any additional feedback, please send directly to [email-masked].

Thank you!

Michelle Cotton
Protocol Parameters Engagement Manager
PTI

-----Original Message-----
From: ietf <[email-masked]> on behalf of John Dickinson <[email-masked]>
Date: Tuesday, November 8, 2016 at 3:34 AM
To: <[email-masked]>
Cc: Florian Weimer <[email-masked]>
Subject: Re: Tracking IANA protocol registry changes

    
    +1

    John Dickinson
    
    http://sinodun.com

---

From: "Marco Davids (Private)" <[email-masked]>
Date: Tue, 8 Nov 2016 17:03:30 +0100

> Take this up with ICANN -- not an IETF problem.

True. The solution lies with ICANN.

But still; Florian asked an interesting and valid question. The IETF
community should perhaps care about this issue or at least be made aware
of it. It that sense I appreciated the e-mail.

> Out of curiosity, what would you be prepared to pay for

You're not serious are you?

Please allow me to clutter up the list with an opinion on this:

Free lunches happen to be ICANN's specialty; go ask the folk currently
in Hyderabad. In my mind there must be some room in ICANN's / IANA's
budget to pay for this relatively simple task as well. Frankly I would
say it is a very logical part of their responsibility. After all, they
already publish the protocol registries online. It should be rather
simple to send out a signal with every change or make an even better
system like John suggested.

But you are right, this list is not the right place for that discussion.

-- 
Marco

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 8 Nov 2016 16:19:13 +0000

On 2016-11-08, at 12:23, Florian Weimer <[email-masked]<mailto:[email-masked]>> wrote:
As far as I can tell, some IANA protocol registries change
occasionally, without any IETF paper trail.

https://github.com/larseggert/iana-assignments

I sync this at least every couple of days, sometimes more frequently. Github offers notifications.

Lars

---

From: Julian Reschke <[email-masked]>
Date: Tue, 8 Nov 2016 17:29:09 +0100

> Github offers notifications.

...I was going to suggest something like that. Now all that's left is a 
cronjob, I guess...

---

From: Emily Shepherd <[email-masked]>
Date: Tue, 8 Nov 2016 21:06:50 +0000

>I sync this at least every couple of days, sometimes more frequently. Github offers notifications.

Or you can skip the middle man:

    rsync -avzH rsync.iana.org::assignments .

Emily

-- 
Emily Shepherd
Computer Science Graduate, MEng (Hons)
W: https://emilyshepherd.me/
M: +44(0)7575 721 231

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 9 Nov 2016 04:54:27 +0000

>   rsync -avzH rsync.iana.org::assignments .

But that gives you neither a history of changes nor notifications.

Lars

---

From: [email-masked]
Date: Wed, 09 Nov 2016 08:30:37 -0800 (PST)

> > date of entry).

Given that ICANN regularly updates a single file list of TLDs, this
isn't too hard to automate. (Not that this should be necessary, mind you.)

Of course this doesn't extend to registries. There are too many of them
and too much complexity as to their structure to make remote automation
viable.

> > I would like a query mechanism as well as a
> > subscription.

> Take this up with ICANN -- not an IETF problem.

I'm afraid I'm going to have to disagree here. The IETF, as a user/consumer of
the registry services IANA/ICANN provides, most definitely should have a say in
the capabilites of the interface to those services. (In fact I believe the IETF
was involved in if not the instigator of the push to make registry data
available in structured form.)

As such, I think it's perfectly legitimate to ask why the IETF isn't
collectively asking IANA to provide registry creation and update notifications.

And I have to say it's a bit embarassing that there's no way to get, say,
an RSS feed out of IANA. Something I get for free from most content
management software these days - in fact in many cases it's on by default.

Of course it's possible that there's no consensus in the IETF that this
is an issue worth worrying about. But determining that requires discussion.

				Ned

---

From: Julian Reschke <[email-masked]>
Date: Wed, 9 Nov 2016 17:57:31 +0100

+1

+1

Best regards, Julian