Subject: Topic IPv6

From: Alexander Nevalennyy <[email-masked]>
Date: Mon, 21 Nov 2016 15:49:20 +0300

Hi Jordi,

I have presented my ideas at some forums already.
I would like to share my ideas to be fit in topic and mail list. I will be
happy if somebody advice section of conversation.

My ideas (simply), all parts must be used together:

1. Denying NAT technology in way of stopping all anonymous action in the
Internet.
I am not sure how is possible to change different RFC.
2. Dividing pool of IPv6 between countries like it done in telephone
industry. For example prefix  for Los-Angeles 1213::/16, Moscow 7495::/16
3. Usage SLAAC for all devices making IPv6 address
4. Making international deals to regulate Internet job (ICANN maybe like
regulator and Interpol like central cyber - police)

Something like that...

Regards, Alexander Nevalenniy

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 21 Nov 2016 14:00:45 +0100

Hi Alexander,

My takes on your points:

1. This will be against privacy … Even if the IETF want to do that, not sure if law in different countries will accept it.
2. The addressing space, for both IPv4 and IPv6 can’t depend on geographical allocation. ISPs can be multinational, etc.
3. SLAAC is already present in IPv6, not sure what do you mean here.
4. I don’t think this is in the scope of IETF …

Basically, all the topics that you are proposing here may be related to different WGs, and I don’t think (very personal opinion), they are good ideas at all … even do, I’m sure others will provide inputs and if you want to keep going on, as suggested in my first email, read the IETF TAO and documents for newcomers, to understand the IETF process and start with the work.

If you have link to documents that you presented in other places, it will be probably good to provide the links (don’t attach documents).

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Alexander Nevalennyy <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 21 de noviembre de 2016, 13:49
Para: <[email-masked]>
Asunto: Topic IPv6

    Hi Jordi,
    I have presented my ideas at some forums already.
    I would like to share my ideas to be fit in topic and mail list. I will be happy if somebody advice section of conversation.

    1. Denying NAT technology in way of stopping all anonymous action in the Internet.
    I am not sure how is possible to change different RFC.
    2. Dividing pool of IPv6 between countries like it done in telephone industry. For example prefix  for Los-Angeles 1213::/16, Moscow 7495::/16
    3. Usage SLAAC for all devices making IPv6 address
    4. Making international deals to regulate Internet job (ICANN maybe like regulator and Interpol like central cyber - police)     
    
    Something like that...

    

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 21 Nov 2016 15:10:51 +0100

Den 21. nov. 2016 13:49, skrev Alexander Nevalennyy:
> I would like to share my ideas to be fit in topic and mail list. I will
> be happy if somebody advice section of conversation.
> 

That's a bug not a feature.
Please read RFC 7721 for some considerations of things we have done to
enable people to use the Internet without revealing their identity to
passive listeners.

> regulator and Interpol like central cyber - police) 

ICANN is not a regulator of content. And IETF has no control over them
anyway.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Nov 2016 11:39:30 +1300

One more message, and then this subject header goes into
my filters.
On 22/11/2016 01:49, Alexander Nevalennyy wrote:
...
> 1. Denying NAT technology in way of stopping all anonymous action in the

Meaningless. Many of us here have hated NAT for 20+ years, but we are
not the protocol police and cannot get rid of it.

> I am not sure how is possible to change different RFC.

Changing RFCs will not get rid of NAT.

> industry. For example prefix  for Los-Angeles 1213::/16, Moscow 7495::/16

Internet routing goes by topology, not geography, so this is a bad idea.

> 3. Usage SLAAC for all devices making IPv6 address

Some operators prefer DHCPv6 so that they can control host behaviour.
And in some cases there are other alternatives.

> regulator and Interpol like central cyber - police)

ICANN is in no sense a regulator; it's a clerical service that allocates
names and numbers to registries. Apart from that, governance issues are
way out of the IETF's scope (and have nothing much to do with the IP
version number).

   Brian

---

From: Alexander Nevalennyy <[email-masked]>
Date: Tue, 22 Nov 2016 13:12:50 +0300

That is not about politicians and not about tracking peoples.
It is about stopping of anonymous actions of both malefactors and cyber
crime's persons.

I will make Internet-draft and be back as soon as it possible.
Thanks everybody for their opinions.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 22 Nov 2016 22:23:36 +0200

> I will make Internet-draft

Thanks.

(And that is also the right answer for most non-trivial topics.)

Jari