Subject: No draft upload? ("An exception occurred when trying to process the XML file: 'X509' object has no attribute '_x509'")

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 20 Nov 2016 18:22:25 +0100

[Already reported to ietf-action [www.ietf.org/rt #149401], I just
mention it here so people do not waste time doing it again.]

I cannot upload the new version of a draft. .txt has been produced by
xml2rfc, without any error message but the datatracker refuses it:

An exception occurred when trying to process the XML file: 'X509'
object has no attribute '_x509'

I have no clue what it can mean.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 21 Nov 2016 13:06:07 +0000

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Stephane
> Bortzmeyer
> Sent: Sunday, November 20, 2016 12:22 PM
> To: [email-masked]
> Subject: No draft upload? ("An exception occurred when trying to
> process the XML file: 'X509' object has no attribute '_x509'")
>

I just ran into this same error. It might be a pyOpenSSL issue:

https://github.com/kennethreitz/requests/issues/3701

Scott

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 22 Nov 2016 16:18:04 +0100

On Mon, Nov 21, 2016 at 01:06:07PM +0000,
 Hollenbeck, Scott <[email-masked]> wrote 
 a message of 24 lines which said:

> I just ran into this same error.

And it is still broken today :-(

I observed that some I-D are published so I tried to find workarounds
and it seems one possibility, if you're in a hurry to publish, is to
submit only the TXT, not the XML source.

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 23 Nov 2016 14:42:37 +0100

On Tue, Nov 22, 2016 at 04:18:04PM +0100,
 [email-masked] <[email-masked]> wrote 

> And it is still broken today :-(

Now fixed.