Subject: IPv10.

From: Khaled Omar <[email-masked]>
Date: Fri, 11 Nov 2016 13:08:12 +0000

Hi all IETF members and the discussion panel,

Hope you are all fine,

I wish I'm not bothering you by my e-mails, but all what I'm asking you is to find a free time on your calendars so we can discuss, suggest, and participate in making the final version of the IPv10 draft and start experimenting its work, and once it will work efficiently and we find that it will bring a great value to the Internet, it can be standardized by the IETF.

I'm not in rush in this sequence of work (maybe you have another sequence as I'm new to the IETF mailing list) but I'm curious to receive comments, suggestions, and modifications that will make a progress and eventually bring a value to the Internet.

Thanks for welcoming me,

Best regards,

Khaled Omar

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 11 Nov 2016 22:29:19 +0900

On Fri, Nov 11, 2016 at 01:08:12PM +0000,
 Khaled Omar <[email-masked]> wrote 
 a message of 111 lines which said:

> in making the final version of the IPv10 draft

Where is the current version?
<https://datatracker.ietf.org/doc/search/?name=ipv10&sort=&rfcs=on&activedrafts=on&by=group&group=>
finds nothing. On <http://internetprotocolv10.blogspot.jp/>, there is
a just one short blog post, without any detail.

> I'm curious to receive comments, suggestions, and modifications

Today, there are not enough substance in this proposal to allow any
commenting.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 11 Nov 2016 14:33:34 +0100

Hi Khaled,

Do you have a pointer to an ID?

I’ve found only this http://internetprotocolv10.blogspot.co.uk/

To be honest, I’m very sceptical to what I’ve read there. I think we have IPv6 already, and there is no sense to work on something new … However, you may need to work in a BoF for this. Are you coming to the next meeting?

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Khaled Omar <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 11 de noviembre de 2016, 14:08
Para: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: IPv10.

    Hope you are all fine,
     
    I wish I’m not bothering you by my e-mails, but all what I’m asking you is to find a free time on your calendars so we can discuss, suggest, and participate in making the final version of the IPv10 draft and start experimenting its work,
     and once it will work efficiently and we find that it will bring a great value to the Internet, it can be standardized by the IETF.
     
    I’m not in rush in this sequence of work (maybe you have another sequence as I’m new to the IETF mailing list) but I’m curious to receive comments, suggestions, and modifications that will make a progress and eventually bring a value to
     the Internet.
     
    Thanks for welcoming me,  
     
    Best regards,
     
    Khaled Omar

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 11 Nov 2016 15:33:36 +0100

Hi Khaled,

> I wish I’m not bothering you by my e-mails, but all what I’m asking you
> is to find a free time on your calendars so we can discuss, suggest, and
> participate in making the final version of the IPv10 draft and start
> experimenting its work, and once it will work efficiently and we find
> that it will bring a great value to the Internet, it can be standardized
> by the IETF.

Most of the time :-) the IETF works problem oriented.
Right now it seems that you have got a solution proposal
for a problem, that is IMHO not very clearly described.
I have not understood the point of your solution either,
it looks like having IPv4-Compatible IPv6 Addresses in
an IPv6 header. Such solutions were considered as
not being useful long time ago.

Suggestion:
- Check the material for newcomers to the IETF
  https://www.ietf.org/newcomers.html
- Describe the problem that you want to solve
  in an individual Internet-Draft (I-D) https://www.ietf.org/id-info/
  along with a statement why existing technologies
  do not solve it sufficiently, probably also give a
  sketch of your solution. The I-D is accessible by
  everyone from a central repository.
- You can then solicit discussion of the I-D on certain
  mailing lists that are related to the topic.

Coming back to your proposal, the statement
"IPv10 allows hosts from two IP versions to be able to communicate, and
this can be accomplished by having an IPv10 packet containing a mixture
of IPv4 and IPv6 addresses in the same IP packet header."
is contradictory in itself since neither IPv4-_only_ nor IPv6-only_
hosts will understand your "new" IPv10 format by definition.

Best regards,
 Roland

---

From: Antonio Prado <[email-masked]>
Date: Fri, 11 Nov 2016 15:42:21 +0100

On 11/11/16 2:08 PM, Khaled Omar wrote:
> I’m curious to receive comments

hi,

well I don't dislike the name: IPv10 sounds okay to me

--
antonio

---

From: Musa Stephen Honlue <[email-masked]>
Date: Fri, 11 Nov 2016 21:21:40 +0400

Hi Khaled I read your blog post and are curious to see what value we gain
in trying to save the IPv4 pool.
Correct me if I didn't understand the problem you are addressing with this
new IP standard.

On Nov 11, 2016 17:08, "Khaled Omar" <[email-masked]> wrote:

> I wish I’m not bothering you by my e-mails, but all what I’m asking you is
> to find a free time on your calendars so we can discuss, suggest, and
> experimenting its work, and once it will work efficiently and we find that
> it will bring a great value to the Internet, it can be standardized by the
> IETF.
>
>
>
> I’m not in rush in this sequence of work (maybe you have another sequence
> as I’m new to the IETF mailing list) but I’m curious to receive comments,
> suggestions, and modifications that will make a progress and eventually
> bring a value to the Internet.
>
>
>
> Thanks for welcoming me,
>
>
>
> Best regards,
>
>
>
> Khaled Omar
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

---

From: James R Cutler <[email-masked]>
Date: Fri, 11 Nov 2016 14:43:04 -0500

> I’m curious to receive comments

I did not know we had given up on IPv8.

(I’m not that James)
James R. Cutler
[email-masked]
PGP keys at http://pgp.mit.edu

---

From: Khaled Omar <[email-masked]>
Date: Fri, 11 Nov 2016 19:50:51 +0000

I was curious to receive comments and suggestions regarding improving the IPv10 role through your expertise, not to receive comments regarding that this function has no value, and I’m trying to solve a problem that is not existing.

Khaled Omar (Independent)

From: James R Cutler [mailto:[email-masked]]
Sent: Friday, November 11, 2016 9:43 PM
To: [email-masked]
Cc: Khaled Omar; [email-masked]
Subject: Re: IPv10.

(I’m not that James)
James R. Cutler
[email-masked]<mailto:[email-masked]>
PGP keys at http://pgp.mit.edu

---

From: Randy Bush <[email-masked]>
Date: Sat, 12 Nov 2016 10:15:21 +0900

> for a problem, that is IMHO not very clearly described.

how about ipv4 and ipv6 are incompatible on the wire and this
has created a multi-decade ipv6 charlie foxtrot?

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 12 Nov 2016 14:43:09 +1300

> has created a multi-decade ipv6 charlie foxtrot?

Yes, I suggest mentioning that to Vint, Bob and a few others in 1977,
so that they can design IPv4 with extensible addresses. People in
2016 will be grateful.

   Brian

---

From: Mark Smith <[email-masked]>
Date: Sat, 12 Nov 2016 13:58:39 +1100

> so that they can design IPv4 with extensible addresses. People in

It looks like the first version of TCP from 1974 had them.

"SPECIFICATION OF INTERNET TRANSMISSION CONTROL PROGRAM"
https://tools.ietf.org/rfc/rfc675.txt

"4 bits: Length of destination network address in 4 bit units (current
   value is 1)

   4 bits: Destination network address

      1010-1111 are addresses of ARPANET, UCL, CYCLADES, NPL, CADC, and
      EPSS respectively.

 ...

   4 bits: length of source network address in 4 bit units (current
   value is 1)

   4 bits: source network address (as for destination address)"

or up to 60 bit addresses.

>From what I've read, there were proposals to do variable length
addresses in IPv6 as CLNS did, however there was a concern that it
would be harder to cope with them in hardware, and the observation
that even though CLNS supported them, everybody just used the same
length.

More recently, I've heard of few organisations here in .au that have
run out of RFC1918s because they've been using /24s everywhere -
previously I only knew of Comcast running out for their cable modem
management network. I've also seen /24s universally being
"unnecessarily" used in virtual networks used to build virtual server
stacks.

It seems most people will choose simple and consistent when they can
even though it is less efficient. There's operational value in that -
if all subnets are /24s or /64s, then one with an incorrect length
sticks out like a sore thumb. Less variables means less opportunity
for error and errors being far more obvious.

Regards,
Mark.

---

From: "Latif LADID [IPv6-based Internet]" <[email-masked]>
Date: Sat, 12 Nov 2016 08:17:43 +0100

Jon Postel will swizel in his grave if v10 is not assigned by IANA first.
Let's not confuse the market. A working group at ETSI has been formed 6
months ago called NGP ( Next Gereation Protocols) lashing at v4 and v6 to
invent a new one.  Also the ITU will jump on this one to occupy the v10
space :-)

Latif

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: 12 November 2016 02:43
To: Randy Bush <[email-masked]>
Cc: Khaled Omar <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: IPv10.

On 12/11/2016 14:15, Randy Bush wrote:
>> Right now it seems that you have got a solution proposal for a 
>> problem, that is IMHO not very clearly described.
> 
> how about ipv4 and ipv6 are incompatible on the wire and this has 
> created a multi-decade ipv6 charlie foxtrot?

Yes, I suggest mentioning that to Vint, Bob and a few others in 1977, so
that they can design IPv4 with extensible addresses. People in
2016 will be grateful.

   Brian

---

From: Bob Braden <[email-masked]>
Date: Sat, 12 Nov 2016 11:44:56 -0800

Brian et al,

I have not been paying attention to this thread, but Brian's answer got 
my attention. I was in the room in 1977 when the decision was made to 
use fixed-length 32 bit IP addresses. I did not have a strong opinion at 
the time, but at least two members of the Internet research group, Jon 
Postel and Danny Cohen, strongly urged variable length IP addresses. As 
manager of ARPA's Internet Research program, Vint Cerf made the call for 
fixed length addresses. His argument was that if we were to have any 
hope that the DoD might accept the experimental protocols, TCP must not 
be too complex to program. He thought that variable-length addresses 
would scare off our possible customers.

Incidentally, the OSI folks did adopt variable -length network 
addresses; this was one of the advantages of OSI that later led the IAB 
to suggest that the Internet shou ld consider adapting the OSI 
protocols. Which caused the famous Kobe lynching of the (original) IAB.

Good heavens, 1977 was 40 years ago!

Bob Braden

for a problem, that is IMHO not very clearly described.ally,

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 13 Nov 2016 09:04:12 +1300

Hi Latif,

On 12/11/2016 20:17, Latif LADID [IPv6-based Internet] wrote:
> invent a new one.  

How incredibly foolish of them.

   Brian

> Also the ITU will jump on this one to occupy the v10
> space :-)
> 
> Latif
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sat, 12 Nov 2016 15:04:36 -0500

see also - http://www.sobco.com/ipng/big_ten/big_ten_packet_format.txt
and
http://www.sobco.com/ipng/big_ten/big_ten_address_format.txt

variable length addresses were considered for IPng (now IPv6) - for various reasons,
including the same issue Int raised of perceived programming complexity in the hosts, the idea was not adopted

Scott

> On Nov 12, 2016, at 2:44 PM, Bob Braden <[email-masked]> wrote:
> 
> Brian et al,
> 
> I have not been paying attention to this thread, but Brian's answer got my attention. I was in the room in 1977 when the decision was made to use fixed-length 32 bit IP addresses. I did not have a strong opinion at the time, but at least two members of the Internet research group, Jon Postel and Danny Cohen, strongly urged variable length IP addresses. As manager of ARPA's Internet Research program, Vint Cerf made the call for fixed length addresses. His argument was that if we were to have any hope that the DoD might accept the experimental protocols, TCP must not be too complex to program. He thought that variable-length addresses would scare off our possible customers.
> 
> Incidentally, the OSI folks did adopt variable -length network addresses; this was one of the advantages of OSI that later led the IAB to suggest that the Internet shou ld consider adapting the OSI protocols. Which caused the famous Kobe lynching of the (original) IAB.
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sat, 12 Nov 2016 15:05:58 -0500

but consistent?

Scott

> On Nov 12, 2016, at 3:04 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi Latif,
>

---

From: "Latif LADID [IPv6-based Internet]" <[email-masked]>
Date: Sat, 12 Nov 2016 21:23:49 +0100

http://www.etsi.org/technologies-clusters/technologies/next-generation-protocols

I guess a rebuttal is still possible.

Latif

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: 12 November 2016 21:04
To: Latif LADID [IPv6-based Internet] <[email-masked]>; 'Randy Bush' <[email-masked]>
Cc: 'Khaled Omar' <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: IPv10.

Hi Latif,

On 12/11/2016 20:17, Latif LADID [IPv6-based Internet] wrote:
> Let's not confuse the market. A working group at ETSI has been formed 
> 6 months ago called NGP ( Next Gereation Protocols) lashing at v4 and 
> v6 to invent a new one.

   Brian

> Also the ITU will jump on this one to occupy the v10 space :-)
> 
> Latif
>

---

From: "Latif LADID [IPv6-based Internet]" <[email-masked]>
Date: Sat, 12 Nov 2016 21:27:29 +0100

The IETF/3GPP endorsement agreement can be used to stop them as it clearly
states that ETSI should not be involved in IETF work but just endorse it.

Latif

-----Original Message-----
From: Scott O. Bradner [mailto:[email-masked]] 
Sent: 12 November 2016 21:06
To: IETF discussion list <[email-masked]>
Cc: Latif LADID [IPv6-based Internet] <[email-masked]>; [email-masked]
Subject: Re: IPv10.

but consistent?

Scott

---

From: "Latif LADID [IPv6-based Internet]" <[email-masked]>
Date: Sat, 12 Nov 2016 21:40:47 +0100

The next one to look into is the new NGI initiative of the European
Commission to start working on new Internet protocols, although this is just
research, after the failure of the Future Internet research program and GENI
in the US (though Openflow was funded at Stanford) so not really a threat
but could be used to put some sanity in researchers in quest of inventing
something new :-)

https://ec.europa.eu/digital-single-market/en/next-generation-internet-initi
ative

https://twitter.com/NGI4eu

Latif

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Latif LADID
[IPv6-based Internet]
Sent: 12 November 2016 21:27
To: 'Scott O. Bradner' <[email-masked]>; 'IETF discussion list'
<[email-masked]>
Cc: [email-masked]
Subject: RE: IPv10.

Latif

-----Original Message-----
From: Scott O. Bradner [mailto:[email-masked]]
Sent: 12 November 2016 21:06
To: IETF discussion list <[email-masked]>
Cc: Latif LADID [IPv6-based Internet] <[email-masked]>; [email-masked]
Subject: Re: IPv10.

but consistent?

Scott

---

From: "Latif LADID [IPv6-based Internet]" <[email-masked]>
Date: Sat, 12 Nov 2016 22:02:52 +0100

3GPP-IETF Standardization Collaboration
https://tools.ietf.org/html/rfc3113

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Latif LADID
[IPv6-based Internet]
Sent: 12 November 2016 21:24
To: 'Brian E Carpenter' <[email-masked]>; 'Randy Bush'
<[email-masked]>
Cc: [email-masked]; 'Khaled Omar' <[email-masked]>;
[email-masked]
Subject: RE: IPv10.

http://www.etsi.org/technologies-clusters/technologies/next-generation-proto
cols

Latif

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]]
Sent: 12 November 2016 21:04
To: Latif LADID [IPv6-based Internet] <[email-masked]>; 'Randy Bush'
<[email-masked]>
Cc: 'Khaled Omar' <[email-masked]>; [email-masked];
[email-masked]
Subject: Re: IPv10.

Hi Latif,

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 13 Nov 2016 10:50:51 +1300

I believe it can all be safely ignored, but it does seem like a silly
waste of resources that they bother to work on it at all.

Regards
   Brian

---

From: Peter Tattam <[email-masked]>
Date: Sun, 13 Nov 2016 01:25:12 +0000

While I have yet to see any fleshy details, it does sound similar to my
idea which got thrown out (IPv6 targets direct from IPv4 using header
options and not tunnelling) I believe I still have a bet to collect
regarding IPv6 uptake though ;)

Peter

---

From: Michal Krsek <[email-masked]>
Date: Sun, 13 Nov 2016 10:31:51 +0900

Working in organisation who is submitting proposals into those EU 
initiatives for about 20 years I can say:

Keep working on IPv6 deployment and do not use those as argument to stop 
working on IPv6.

                     Michal

P.S: Some of NGI/NGN (specially for video) mean: let's do brilliant new IPv4

P.P.S: Some of NGI/NGN mean: let's do circuit switching (sometimes over 
http over IPv4 :-) )

On 13/11/2016 10:25, Peter Tattam wrote:
> While I have yet to see any fleshy details, it does sound similar to 
> my idea which got thrown out (IPv6 targets direct from IPv4 using 
> header options and not tunnelling) I believe I still have a bet to 
> collect regarding IPv6 uptake though ;) Peter
>
> On Sun., 13 Nov. 2016 at 8:51 am, Brian E Carpenter 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     > From: ipv6 [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Latif LADID
>     > [IPv6-based Internet]
>     > To: 'Scott O. Bradner' <[email-masked] <mailto:[email-masked]>>;
>     'IETF discussion list'
>     > <[email-masked] <mailto:[email-masked]>>
>     > Cc: [email-masked] <mailto:[email-masked]>
>     > Subject: RE: IPv10.
>     >
>     > From: Scott O. Bradner [mailto:[email-masked] <mailto:[email-masked]>]
>     > To: IETF discussion list <[email-masked] <mailto:[email-masked]>>
>     > Cc: Latif LADID [IPv6-based Internet] <[email-masked]
>     <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>     > Subject: Re: IPv10.
>     >
>     > but consistent?
>     >
>     > Scott
>     >
>     >> On Nov 12, 2016, at 3:04 PM, Brian E Carpenter
>     > <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >>
>     >> Hi Latif,
>     >>
>     >>> From: ipv6 [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Brian E
>     >>> Carpenter
>     >>> To: Randy Bush <[email-masked] <mailto:[email-masked]>>
>     >>> Cc: Khaled Omar <[email-masked]
>     <mailto:[email-masked]>>; [email-masked]
>     <mailto:[email-masked]>;
>     >>> [email-masked] <mailto:[email-masked]>
>     >>> Subject: Re: IPv10.
>     >>>
>     >>> [email-masked] <mailto:[email-masked]>
>     >>> Administrative Requests:
>     https://www.ietf.org/mailman/listinfo/ipv6
>     >>>
>     > [email-masked] <mailto:[email-masked]>
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Michal Krsek <[email-masked]>
Date: Sun, 13 Nov 2016 10:31:57 +0900

Michal

---

From: Michel Py <[email-masked]>
Date: Sun, 13 Nov 2016 02:34:30 +0000

> Peter Tattam wrote :
> I believe I still have a bet to collect regarding IPv6 uptake though ;)

If interest counts, you must be a millionaire by now :P

Michel.