Subject: FW: License File for Open Source Repositories

From: IETF Chair <[email-masked]>
Date: Wed, 4 Jan 2017 18:20:22 +0200

With the holidays over, this is a re-send of the request to
review the suggested license file.

Jari

----

> The IESG has observed that many working groups work with open source
> repositories even for their work on specifications. That's great, and
> we're happy to see this development, as it fits well the working style
> of at least some of our working groups. This style is also likely to be
> more popular in the future.
> 
> As always, we'd like to understand areas where we can either be helpful
> in bringing in some new things such as tooling, or where we need to
> integrate better between the repository world and the IETF process. As
> an example of the latter, we're wondering whether it would be helpful to
> have a standard boilerplate for these repositories with respect to the
> usual copyright and other matters. The intent is for such text to be
> placed in a suitable file (e.g., "CONTRIBUTING"), probably along with
> some additional information that is already present in these files in
> many repositories. The idea is that people should treat, e.g., text
> contributions to a draft-foo.xml in a repository much in the same way as
> they treat text contributions on the list, at least when it comes to
> copyright, IPR, and other similar issues.
> 
> We have worked together with the IETF legal team and few key experts
> from the IETF who are actively using these repositories, and suggest the
> following text.
> 
> We're looking to make a decision on this matter on our January 19th,
> 2017 IESG Telechat, and would appreciate feedback before then. This
> message will be resent after the holiday period is over to make sure it
> is noticed. Please send comments to the IESG ([email-masked]) by 2017-01-17.
> 
> The IESG
> 
> ——
> 
> This repository relates to activities in the Internet Engineering Task
> Force(IETF). All material in this repository is considered Contributions
> to the IETF Standards Process, as defined in the intellectual property
> policies of IETF currently designated as BCP 78
> (https://www.rfc-editor.org/info/bcp78), BCP 79
> (https://www.rfc-editor.org/info/bcp79) and the IETF Trust Legal
> Provisions (TLP) Relating to IETF Documents
> (http://trustee.ietf.org/trust-legal-provisions.html).
> 
> Any edit, commit, pull-request, comment or other change made to this
> repository constitutes Contributions to the IETF Standards Process. You
> agree to comply with all applicable IETF policies and procedures,
> including, BCP 78, 79, the TLP, and the TLP rules regarding code
> components (e.g. being subject to a Simplified BSD License) in
> Contributions.
>

---

From: Ted Hardie <[email-masked]>
Date: Wed, 4 Jan 2017 10:03:11 -0800

> review the suggested license file.
Thanks for the reminder.  My only question is with this text:

"Any edit, commit, pull-request, comment or other change made to this
repository constitutes Contributions to the IETF Standards Process."

At least in the Github repositories used by RTCWEB and ACME, work often
proceeds by someone raising an issue, tracking comments on it, and then
generating a pull request.  I believe this flow is covered by the text
above because issues are a type of comment.  It might be slightly clearer,
though, if raising an issue were explicitly called out; it might be
otherwise argued that comments on issues were covered by the issues
themselves were not.

This is likely just an abundance of caution, but I see no harm in
explicitly including issue in the list above, hence the suggestion.

regards,

Ted

---

From: Nadeau Thomas <[email-masked]>
Date: Wed, 4 Jan 2017 16:27:07 -0500

I have no issues with the license text, but will suggest a clarification or
two. We have been using basically the same text for IETF models on the Yang repo on github for about 
2 years with no issues.   I’ll note that that we hashed through these in great detail with the 
netmod/conf community and arrived at how we operate. We also work with the IEEE/MEF/ODL communities
on the same repo, and everyone seems to get along happily with these rules in place. The license 
statement we have been using for about 2 years is available here if you are interested.

	https://github.com/YangModels/yang

	The first clarification I think is necessary is around how “repository” is
defined. In the case of github, that might be taken to mean the *entire* repository, which
practically speaking is not how things work, at least in our case because the repository 
holds files created by various organizations (and vendors for that matter). Instead, the approach we 
have taken is to require that each main/top-level subdirectory contain a license statement
that applies to all files and subdirectories therein. Committers explicitly agree to those terms
by virtue of checking in a file (or posting a comment/issue on that file).

	This also reveals a finer point about the license statement pertaining to comments.
Again, our statement defines comments as falling under whatever licensing terms are defined
for the file in question.  This is a gray area in our case due to having multiple files that fall under
multiple licenses. So for example, one comment about one file might refer to another file covered by 
another license.  Does that mean that now the first file falls under the licensing terms of the other
file?  Let me give you an example. We have IEEE models that do rely on advice given from Yang doctors 
either explicitly or via references to some of the guiding documents/RFCs that exist. In discussing the 
IEEE model, there might be a discussion around such a recommendation for how to build a model. In this 
case, is this IEEE model suddenly now under the IETF’s license (or the part of the model being discussed)?  
The working assumption by us is that it is not. However, this is something you might want to clarify.

	—Tom

> On Jan 4, 2017:11:20 AM, at 11:20 AM, IETF Chair <[email-masked]> wrote:
>