Subject: RE: New Non-WG Mailing List: NetSlices - Network Slicing

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 13 Jan 2017 14:21:51 -0000

I hate to be a killjoy, but...

Once upon a time the IESG used to supply a little text to include in this sort of announcement under the "Purpose" heading to allow us to work out whether we wanted to subscribe to the list. Since network slicing seems to be something that is done in a number of ways already, it would be nice to get a handle on what the purpose of this discussion forum is.

Thanks,
Adrian

> -----Original Message-----
> From: IETF-Announce [mailto:[email-masked]] On Behalf Of
> IETF Secretariat
> Sent: 12 January 2017 21:19
> To: IETF Announcement List
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: New Non-WG Mailing List: NetSlices - Network Slicing
> 
> 
> A new IETF non-working group email list has been created.
> 
> List address: [email-masked]
> To subscribe: https://www.ietf.org/mailman/listinfo/netslices
> 
> Purpose:
> 
> 
> For additional information, please contact the list administrators.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 13 Jan 2017 15:39:18 +0000

I am not sure why there was no significant purpose text.

In the note to subscribers we say:

This list is intended for discussion of network slicing to determine
an agreed IETF definition of the term Network Slicing, problems and
gaps to be covered with an aim to facilitate interoperation across
different operator and vendor solutions. The list also determines (and
assimilates) which elements of the slicing problems are already
covered by existing IETF designs or work in progress.

- Stewart

---

From: Sarah B <[email-masked]>
Date: Fri, 13 Jan 2017 08:15:29 -0800

It's worth pointing out that the 2 links that link to archives from the subscription page, to get a better idea of what this list is for, either show no info (the first link) or returns a 404 (the second link)

https://www.ietf.org/mailman/listinfo/netslices <https://www.ietf.org/mailman/listinfo/netslices>

/S

> On Jan 13, 2017, at 7:39 AM, Stewart Bryant <[email-masked]> wrote:
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 13 Jan 2017 12:16:52 -0500

--On Friday, January 13, 2017 14:21 +0000 Adrian Farrel
<[email-masked]> wrote:

> Once upon a time the IESG used to supply a little text to
> include in this sort of announcement under the "Purpose"
> heading to allow us to work out whether we wanted to subscribe
> to the list. Since network slicing seems to be something that
> is done in a number of ways already, it would be nice to get a
> handle on what the purpose of this discussion forum is.

+1

To say this a little more strongly, not only have we had
examples of abuses involving IETF-hosted lists but the IESG has
some responsibility to consider the time of the community a
valuable resource and to be as protective of it when creating
these lists as when proposing a WG.  There are lots of other
places where lists can be created for discussions that interest
the proposer; IETF non-WG lists should be created and announced
only if they add value to the IETF community or (probably "and")
the work of the IETF.   IMO, the IESG and individual ADs need to
consider themselves accountable for the creating of non-WG lists
and provide clear explanations of why the lists are being
created and what they are about.

I hope it doesn't take appeals of list announcements to
re-establish that principle.

    john

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 13 Jan 2017 17:26:04 +0000

> re-establish that principle.
John

I am sure the omission of a full statement of purpose was an accident or 
an oversight.

The Secretariat re-posted the announcement with the purpose stated in the
normal way at 1644Z.

The subject is clearly within IETF scope.

Stewart

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 13 Jan 2017 17:37:07 -0000

Thanks Stewart and Alex.

> covered by existing IETF designs or work in progress.

It's good to discuss stuff.

How will agreement of "an IETF definition" be measured?
Or maybe you mean to attempt to agree a definition among the people subscribed to the list and propose that as a definition for use by the IETF?
But still, who on the list will call consensus?

Why is this something to be petty about?
Because I need to know whether this is a list I have to join and monitor in case I don't agree the definition, or whether that definition will come up for IETF review in the normal way.

Perhaps the AD who granted this list with this charter could speak up?

Adrian

---

From: Terry Manderson <[email-masked]>
Date: Tue, 17 Jan 2017 01:49:21 +0000

Since you asked Adrian :)

I granted approval of this list, as a list, so that the definition of network slicing could be discussed in an IETF context.

Really, it boils down to the (on list) discussion of what is a proposed network slicing definition that could see the IETF doing work on. So really about presenting a better formed definition to the IETF, for the IETF to consider at some future point in time. As we know with most "I have a problem that I think the IETF should work on" proposals we tend to ask for the problem to be defined in a way that does communicate the depth and breadth of the issue or the idea before a BOF is considered. This is where I see network slicing now. Showing that this very amorphous concept has the hope of some agreed shape and also that there are sufficient bodies to form that shape, whatever it is.

As a mailing list (and JUSTa mailing list!) the work for the interested parties on that mailing list is to try to put words together that is actually meaningful in the IETF context. To be brutally honest I have doubts that this is possible from what I read to date but I do commit (as AD) to allowing discussion to occur as I'm neither the magistrate of taste nor the gate of interest.

Cheers
Terry

On 14/01/2017, 3:37 AM, "ietf on behalf of Adrian Farrel" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks Stewart and Alex.

    

    
    Adrian

---

From: Lou Berger <[email-masked]>
Date: Mon, 16 Jan 2017 21:17:22 -0500

On 1/16/2017 8:49 PM, Terry Manderson wrote:
> Really, it boils down to the (on list) discussion of what is a proposed network slicing definition that could see the IETF doing work on. So really about presenting a better formed definition to the IETF, for the IETF to consider at some future point in time. As we know with most "I have a problem that I think the IETF should work on" proposals we tend to ask for the problem to be defined in a way that does communicate the depth and breadth of the issue or the idea before a BOF is considered. This is where I see network slicing now. 

well, there was an opportunity for some discussion an IETF context that
began and then went unanswered...

https://www.ietf.org/mail-archive/web/teas/current/msg01808.html

> Showing that this very amorphous concept has the hope of some agreed shape and also that there are sufficient bodies to form that shape, whatever it is.
>
Well there seems to be a trend to having a low bar for mailing lists
which means that folks with new ideas (at least to them) don't have much
motivation to research on going work to see how theirs fits in...  BTW
this is a general comment -- even if perhaps applicable in this case.

Lou

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 17 Jan 2017 03:10:43 -0000

Hello Terry,

This all seems fine and dandy, but there is a disconnect between what you say there "discussing a proposed definition" and "presenting a better formed definition to the IETF" (admirable intentions for a mailing list), and "determining an agreed IETF definition" as indicated by some of the participants on the list as well as in the revised mailing list announcement.

I hope I am not needlessly picking at words, but it seems that this disconnect could be the source of some future uncomfortable moments.

As Lou mentions, the topic seems to have avoided discussion on the TEAS list where it was invited to take place. That need not be a bad thing if the proponents need to self-organise a bit. And I see no harm in providing an archived mailing list under IETF "note well" terms for that self-organisation to take place. It's just about setting expectations of where the results of the organisation need to be taken.

Cheers,
Adrian
(The benefits of a low bar include being able to reach your drink while in a sedentary position)

> Really, it boils down to the (on list) discussion of what is a proposed network
> slicing definition that could see the IETF doing work on. So really about presenting
> a better formed definition to the IETF, for the IETF to consider at some future
> point in time. As we know with most "I have a problem that I think the IETF
> should work on" proposals we tend to ask for the problem to be defined in a way
> that does communicate the depth and breadth of the issue or the idea before a
> BOF is considered. This is where I see network slicing now. Showing that this very
> amorphous concept has the hope of some agreed shape and also that there are
> sufficient bodies to form that shape, whatever it is.
> 
> As a mailing list (and JUSTa mailing list!) the work for the interested parties on
> that mailing list is to try to put words together that is actually meaningful in the
> IETF context. To be brutally honest I have doubts that this is possible from what I
> read to date but I do commit (as AD) to allowing discussion to occur as I'm neither
> the magistrate of taste nor the gate of interest.
> 
> Cheers
> Terry
> 
>     Or maybe you mean to attempt to agree a definition among the people
> subscribed to the list and propose that as a definition for use by the IETF?
>     Because I need to know whether this is a list I have to join and monitor in case I
> don't agree the definition, or whether that definition will come up for IETF review
> in the normal way.
>

---

From: Terry Manderson <[email-masked]>
Date: Tue, 17 Jan 2017 03:33:14 +0000

Hi Adrian,

Avoidance of discussion happens everywhere on many topics in the IETF, and as we know silence does not equal consensus. We also all know why that occurs. Having the list specifically for this topic is to ensure that sane discussion does happen, and happens in a location that easy for anyone (esp the IESG) to find at some point down the track when (invariably) an ask comes forward about a having BOF. So yes, the interested parties do need to self-organize to get that "agreed' definition.

Please don't read any weight into the term "agreed IETF definition". This mailing list does not get to say this is THE definition for the IETF. the wording is to scopes the discussion such that the definition needs to be in scope for the IETF. Could it have been said better, yep. Mea culpa. (Although I really thought how the IETF forms consensus is well known. Will ensure to be far more explicit in future)

Where it goes from here depends on what happens on the mailing list and that is simply no different to most of the other bodies of work that comes into the IETF.

Cheers
Terry
(Dammit, the single malt is on the top shelf!)

On 17/01/2017, 1:10 PM, "Adrian Farrel" <[email-masked]> wrote:

    Hello Terry,

    
    
    Cheers,
    Adrian

---

From: Loa Andersson <[email-masked]>
Date: Tue, 17 Jan 2017 11:44:06 +0800

Terry and Adrian,

Can't we simple update the mailing list charter as Terry explained he 
see the purpose of the list, and then go on with the discussion.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Terry Manderson <[email-masked]>
Date: Tue, 17 Jan 2017 03:48:55 +0000

Hi Loa,

Updating the charter is easy, but I get the sense there is something deeper that hasn't yet come out yet. And I intentionally choose not to cut the discussion short and miss an important point that I'm not grasping that might inform me or the IESG on an underlying process fix for future work in the IETF.

Cheers
T.

On 17/01/2017, 1:44 PM, "Loa Andersson" <[email-masked]> wrote:

    Terry and Adrian,

    /Loa

    --

---

From: Loa Andersson <[email-masked]>
Date: Tue, 17 Jan 2017 12:00:03 +0800

Terry,

OK - your call, but if we don't get this "deep point" within a week or 
so I'd suggest update, to leave the people that want to come up with a
proposed definition to do so. And try to drill for whatever is in the
depth in a separate discussion.

/Loa

--

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 17 Jan 2017 16:38:41 +0000

Hi,

While we all are holding our drinks in the low bar position waiting for the outcome, as Lou and Adrian noted, work is continuing on in both teas (where they now explicitly use the term network slices to help those not familiar with the work) and detnet. So advocates of this work, if interested in real-time progress, should realize as that famous quote goes "you've got to know when to hold'em, know when to fold'em" or there won't be enough time to have impact now. Advice myself, the Chairs, authors, and others already relayed when the list was first discussed.

It's advice for any new mailing list kickoff - while herding, be sure to participate in work on-going.

Deborah

> From: ietf [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Monday, January 16, 2017 10:11 PM
> To: 'Terry Manderson' <[email-masked]>
> Cc: [email-masked]
> Subject: RE: New Non-WG Mailing List: NetSlices - Network Slicing
> 
> Hello Terry,
> 
> This all seems fine and dandy, but there is a disconnect between what you say
> there "discussing a proposed definition" and "presenting a better formed
> definition to the IETF" (admirable intentions for a mailing list), and
> "determining an agreed IETF definition" as indicated by some of the
> participants on the list as well as in the revised mailing list announcement.
> 
> I hope I am not needlessly picking at words, but it seems that this disconnect
> could be the source of some future uncomfortable moments.
> 
> As Lou mentions, the topic seems to have avoided discussion on the TEAS list
> where it was invited to take place. That need not be a bad thing if the
> proponents need to self-organise a bit. And I see no harm in providing an
> archived mailing list under IETF "note well" terms for that self-organisation to
> take place. It's just about setting expectations of where the results of the
> organisation need to be taken.
> 
> Cheers,
> Adrian
> > I granted approval of this list, as a list, so that the definition of network
> slicing
> > could be discussed in an IETF context.
> >
> > On 14/01/2017, 3:37 AM, "ietf on behalf of Adrian Farrel" <ietf-
> [email-masked]
> > on behalf of [email-masked]> wrote:
> >
> >     Thanks Stewart and Alex.
> >