Subject: Re: I-D Action: draft-leiba-cotton-iana-5226bis-19.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Jan 2017 08:44:49 +1300

Hi,

> For IETF protocols, that role is filled by the
> Internet Assigned Numbers Authority (IANA) Services.
...
> For IETF protocols, that role is filled by the
> Internet Assigned Numbers Authority (IANA) Services [RFC2860].

Sorry, but I find the replacement of "IANA" by "IANA Services" throughout
the draft to be both ugly and plain wrong.

Ugly, because it reads badly in almost every sentence where it occurs.
Sentences such as "IANA Services prefers that..." are bad English at best.

Wrong, because as far as the IETF and the IAB are concerned, the function
is performed by the Internet Assigned Numbers Authority, abbreviated as IANA.

The draft doesn't explain, what "IANA Services" is or are.
But it doesn't matter: this document is about what IANA does.

One part of the document is now simply absurd:

> 9.1.  When There Are No Actions
> 
>    Before an Internet-Draft can be published as an RFC, IANA Services
>    needs to know what actions (if any) it needs to perform.  Experience
>    has shown that it is not always immediately obvious whether a
>    document has no actions, without reviewing the document in some
>    detail.  In order to make it clear to IANA Services that it has no
>    actions to perform (and that the author has consciously made such a
>    determination), such documents should, after the authors confirm that
>    this is the case, include an IANA Considerations section that states:
> 
>       This document has no actions.

Um, no, if the document has no actions it shouldn't be published.
This needs to either revert to its previous version

       This document has no IANA actions.

or for better style:

       This document requests no actions by IANA.

(The other changes in this version are fine.)

Regards
   Brian Carpenter

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 10 Jan 2017 15:00:19 -0500

I agree with Brian below. I've recently seen other stuff muddled up by
this silly global replacement of "IANA" by "IANA Services".

In the case of the draft in question, it seems to me that at most one
statement like "IANA is instantiated by an IANA Services contractor."
or the like would be plenty. All other references can just be "IANA".

On the no IANA actions case, my understanding was that IANA wanted the
IANA Considerations section saying that no IANA actions were required
to stay in the document and subsequent RFC but that the IESG wanted it
removed on publication. I don't care. But if that disagreement is
still the same, then IESG should prevail. What I say in my documents,
which seems to work fine, is

          This document requires no IANA actions. RFC Editor: Please
remove this section before publication.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 10 Jan 2017 15:19:14 -0500

Hi,

> the draft to be both ugly and plain wrong.

Well, we need something other than "IANA", because the IETF is but one
user of that mark, and the license that the IETF Trust gave to PTI
does not permit them to refer to themselves as "IANA".

Would "IANA Services Operator" do?

> But it doesn't matter: this document is about what IANA does.

I think that's not quite correct.  It's about what the IANA Services
Operator for the protocol parameters registries (and other registries
for which the IETF is policy authority) does.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Tue, 10 Jan 2017 12:47:10 -0800

Andrew,

> On Jan 10, 2017, at 12:19 PM, Andrew Sullivan <[email-masked]> wrote:
> 
> Hi,
> 
> does not permit them to refer to themselves as "IANA”.

Well, according to their web site, they are still “IANA”.  See:

http://www.iana.org

It says:

"The global coordination of the DNS Root, IP addressing, and other Internet protocol resources is performed as the Internet Assigned Numbers Authority (IANA) functions.”

If their web page can abbreviate this as “IANA”, then I think we can as well.

Bob

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 10 Jan 2017 16:04:16 -0500

> "The global coordination of the DNS Root, IP addressing, and other Internet protocol resources is performed as the Internet Assigned Numbers Authority (IANA) functions.”

Their web page _doesn't_ abbreviate it as "IANA".  It says "the IANA
functions", and it also says, "As of 1 October 2016, the IANA
functions are being provided …". It talks about "IANA functions", not "IANA".  

I believe that the IETF Trust's legal counsel agrees about this, but I
am copying the Trust to confirm.  In any case, see restriction 5 under
exhibit D of
http://trustee.ietf.org/documents/License_Agreement09-21-2016Protocolclean.htm.
Since the new document did not exist as of the Effective Date, we
should follow those rules.

Finally,

> If their web page can abbreviate this as “IANA”, then I think we can as well.

the problem with trademarks is that normally-sensible things that one
can do with language are just now allowed.  So one's sense of these
things is no guide, only one's lawyer's sense.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 10 Jan 2017 16:05:47 -0500

Uh, _this_ time I'm copying trustees.

Finally,

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Tue, 10 Jan 2017 14:57:49 -0800

Andrew,

> On Jan 10, 2017, at 1:05 PM, Andrew Sullivan <[email-masked]> wrote:
> 
> functions are being provided …". It talks about "IANA functions", not "IANA”.

That not the way I read "Internet Assigned Numbers Authority (IANA) functions”.  I see “IANA” quite clearly.  [Nit: it’s also not compliant with license agreement, since “functions” is not in upper case].

> should follow those rules.

Thanks for the link, I assume we are discussing Exhibit D “IETF Trust Style Requirements” sentence 5.

    The mark shall not be used to describe products or services in a generic or
    descriptive manner.  For example, services should always be referred to as
    “IANA Services” or “IANA Functions”, not as “IANA”.  This requirement shall
    not apply, however, to archived or legacy web pages or documents existing as
    of the Effective Date.

Based on this shouldn't the title of the document be:

     Guidelines for Writing an IANA Functions Considerations Section in RFCs
or
     Guidelines for Writing an IANA Services Considerations Section in RFCs

and all future RFC should have an

     IANA Functions Considerations Section in RFCs
or
     IANA Services Considerations Section in RFCs

By my reading, this version the document is inconsistent.  If we are not required to change the name of the Considerations section to “IANA Functions…”, then we should not have to change it everyone else.

> things is no guide, only one's lawyer's sense.

While I am certainly not a trademark lawyer, I would think that if the last sentence in the first paragraph of Introduction in the draft is changed to:

    For IETF protocols, that role is filled by the Internet Assigned Numbers
    Authority (IANA) Services [RFC2860] described in this document as IANA.

I would think this is not a trademark violation, since it is clear what IANA is referring to.

Thanks,
Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Jan 2017 14:37:01 +1300

> does not permit them to refer to themselves as "IANA".

I don't care what they call themselves. *WE* are writing this document,
we own the IANA trademark, and we can do exactly what we want with it.

> Would "IANA Services Operator" do?

It is clumsy and pointless, but at least it's grammatical.

> for which the IETF is policy authority) does.

The distinction escapes me. Anyway, as Bob Hinden suggested, this can
all be taken care by a simple sentence at the beginning.

    Brian

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 10 Jan 2017 20:43:24 -0500

Sorry about the top post, but there's an important correction to be made here. 

_We_ do not own the IANA trademark.  The IETF Trust does.  Moreover, the Trust has certain agreements with other organizations and those constrain what the Trust may do. Finally, the Trust can't actually do exactly what it wants with the trademark, because there are rules about how trademarks must be handled in order to remain valid.  

The Trust agreed to take on the IANA ipr as part of the transition, as a service to the Internet operational communities affected.  That doesn't mean we get just to do whatever we would like.  

Best regards,

A

-- 
Andrew Sullivan 
Please excuse my clumbsy thums. 

> On Jan 10, 2017, at 20:37, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 11 Jan 2017 01:57:51 +0000

Hiya,

On 11/01/17 01:43, Andrew Sullivan wrote:
> _We_ do not own the IANA trademark.  The IETF Trust does.  Moreover,
> the Trust has certain agreements with other organizations and those
> constrain what the Trust may do. Finally, the Trust can't actually do
> exactly what it wants with the trademark, because there are rules
> about how trademarks must be handled in order to remain valid.
> 
> The Trust agreed to take on the IANA ipr as part of the transition,
> as a service to the Internet operational communities affected.  That
> doesn't mean we get just to do whatever we would like.

I'm not saying you're wrong, but I thought a part of the reason
that we (IETF/IETF trust) took on the so-called "ipr" was because
we were best placed in terms of having the most healthily sceptical
attitude to the (lack of) value supposedly-inherent in that "ipr"?

I don't think we ought disturb that impression by being overly
serious about any of this, even if (or particularly if:-) others
appear to be that serious.

IANA folks do a fine job with protocol registries but I figure
it'd be a fail for us to accidentally treat the concepts involved
as being so precious that Lars' github repo starts to appear
significantly more attractive.

Bringing it back to the draft in question, my substantive comment
is that I don't care about the IETF trust issues and conclude that
reasonable grammar ought win in this case.

Cheers,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Jan 2017 15:12:46 +1300

On 11/01/2017 11:57, Bob Hinden wrote:
...
> I would think this is not a trademark violation, since it is clear what IANA is referring to.

Regardless, we must not issue a document with such absurd, ugly and ungrammatical
phrasing. It would make us a laughing stock.

> _We_ do not own the IANA trademark.  The IETF Trust does. 

Don't care. Ultimately the Trust does what the IETF tells it to do. I understand
that lawyers sometimes give very cautious advice, but it's our choice whether
we take that advice after due consideration. Making this document read absurdly
is simply not OK. Putting in some introductory legalese is OK.

    Brian

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 10 Jan 2017 21:34:22 -0500

> attitude to the (lack of) value supposedly-inherent in that "ipr"?

There may be different reasons around the community why different
people thought it was ok for the Trust to end up holding this.
Perhaps a public mailing list is not the ideal place for me to vent^W
express my feelings about trademarks on "IANA" or related logos.
Nevertheless,

> reasonable grammar ought win in this case.

whether you care about IETF Trust issues makes no difference, because
the IETF Trustees, and only the IETF Trustees, are indivudually on the
hook for making sure their fiduciary duty with respect to the Trust
property is fulfilled.  Therefore, I believe the Trust will insist
that the trademark on IANA be handled according to the agreements the
Trust has with various parties (including the IETF, note).

Full disclosure: until March or the IAB removes me (whichever comes
first), I'm IAB chair, which means I'm on the IAOC, which means I'm a
Trustee.  I'm offering my personal opinion, but it is informed by what
I understood IETF Trust counsel advised.  Because of a bad decision
when I was younger, I am not a lawyer, and this opinion is worth what
you paid for it :)

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 11 Jan 2017 02:49:28 +0000

Hiya,

On 11/01/17 02:34, Andrew Sullivan wrote:
> whether you care about IETF Trust issues makes no difference, 

It does make a difference to me. I don't care if it makes no
difference to you/the IETF trust. (I mean that respectfully.)

> because

I also don't care about that. I respect that folks serving on
the IETF trust are doing what seems correct, but nonetheless
when correct fiduciary attitudes are just silly, I'll happily
call out and then ignore the silliness.

To be clear though, I very much do care if someone claims that
we have new rules related to IANA meaning that I-Ds have to use
language approved by the IETF trust. At that point, I do object
to the trust's actions.

But I assume you are not saying that the IETF trust's recently
inherited so-called "ipr" wins out over clear language in
I-Ds, so I'm sure it's all ok. If in fact you do think that
the so-called "ipr" infringes on I-D authors' freedom to
choose descriptive language then I really would like you to
say that clearly and to point at the IETF-consensus RFC that
specifies exactly which restrictions you claim apply.

> when I was younger, I am not a lawyer, and this opinion is worth what

I'll take my -0$ back then please:-)

Again, no disrespect to you or other trustees intended, but we
really ought not treat inherited silliness too nicely. And we
also ought not make a mountain out of this so-called "ipr"
molehill.

Cheers,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Jan 2017 17:48:48 +1300

Apologies, my 2nd quote below was from Andrew, not Bob.

Regards
   Brian

---

From: "James Gannon" <[email-masked]>
Date: Wed, 11 Jan 2017 09:22:50 -0000

I agree with Andrew here, it would be a pity to run into this just a few
months after assuming the IPR in trust on behalf of all 3 communities, and
having agreed to the stewardship that came along with that. It may be just
issues of grammar or legalese, but it has background and relationships with
the two other communities behind those words.

-J

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Andrew Sullivan
Sent: Wednesday, January 11, 2017 1:43 AM
To: [email-masked]
Subject: Re: I-D Action: draft-leiba-cotton-iana-5226bis-19.txt

Sorry about the top post, but there's an important correction to be made
here. 

_We_ do not own the IANA trademark.  The IETF Trust does.  Moreover, the
Trust has certain agreements with other organizations and those constrain
what the Trust may do. Finally, the Trust can't actually do exactly what it
wants with the trademark, because there are rules about how trademarks must
be handled in order to remain valid.  

The Trust agreed to take on the IANA ipr as part of the transition, as a
service to the Internet operational communities affected.  That doesn't mean
we get just to do whatever we would like.  

Best regards,

A

>>> Sorry, but I find the replacement of "IANA" by "IANA Services" 
>>> throughout the draft to be both ugly and plain wrong.
>> 
>> Well, we need something other than "IANA", because the IETF is but 
>> one user of that mark, and the license that the IETF Trust gave to 
>> PTI does not permit them to refer to themselves as "IANA".
> 
> I don't care what they call themselves. *WE* are writing this 
> document, we own the IANA trademark, and we can do exactly what we want
with it.