Subject: KHALED Routing Protocol (KRP).

From: Khaled Omar <[email-masked]>
Date: Tue, 25 Apr 2017 23:27:14 +0000

Hi All,

I think you all received the notification regarding the KRP ID submission, so here is the link for this Internet Draft:

https://datatracker.ietf.org/doc/draft-omar-krp/

For those who are interested in it, you will be welcomed to discuss it directly with me.

Looking for your thoughts, suggestions, comments, modifications or any kind of positive participation.

If you are not interested in the idea after reading the draft, please ignore this e-mail.

Best Regards,

---

From: Lloyd Wood <[email-masked]>
Date: Fri, 28 Apr 2017 06:40:34 +0000 (UTC)

"KRP"?
How do you pronounce the name? Lloyd Wood http://about.me/lloydwood 

      From: Khaled Omar <[email-masked]>
 To: "[email-masked]" <[email-masked]> 
 Sent: Wednesday, 26 April 2017, 9:27
 Subject: KHALED Routing Protocol (KRP).
   
 <!--#yiv9873945094 _filtered #yiv9873945094 {font-family:"Cambria Math";panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv9873945094 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv9873945094 #yiv9873945094 p.yiv9873945094MsoNormal, #yiv9873945094 li.yiv9873945094MsoNormal, #yiv9873945094 div.yiv9873945094MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:"Calibri", "sans-serif";}#yiv9873945094 a:link, #yiv9873945094 span.yiv9873945094MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv9873945094 a:visited, #yiv9873945094 span.yiv9873945094MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv9873945094 span.yiv9873945094EmailStyle17 {font-family:"Calibri", "sans-serif";color:windowtext;}#yiv9873945094 .yiv9873945094MsoChpDefault {font-family:"Calibri", "sans-serif";} _filtered #yiv9873945094 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv9873945094 div.yiv9873945094WordSection1 {}-->Hi All,    I think you all received the notification regarding the KRP ID submission, so here is the link for this Internet Draft:    https://datatracker.ietf.org/doc/draft-omar-krp/    For those who are interested in it, you will be welcomed to discuss it directly with me.    Looking for your thoughts, suggestions, comments, modifications or any kind of positive participation.    If you are not interested in the idea after reading the draft, please ignore this e-mail.    Best Regards,

---

From: Khaled Omar <[email-masked]>
Date: Fri, 28 Apr 2017 06:56:15 +0000

Step by step, Khaled Routing Protocol, KRP.

-------- Original Message --------
Subject: Re: KHALED Routing Protocol (KRP).
From: Lloyd Wood
To: Khaled Omar ," [email-masked]"
CC:

"KRP"?

How do you pronounce the name?

Lloyd Wood http://about.me/lloydwood

________________________________

Hi All,

Best Regards,

---

From: Artem Pleschenko <[email-masked]>
Date: Fri, 28 Apr 2017 10:13:16 +0300

A phonetic transcription would be very useful

On 28 April 2017 at 09:56, Khaled Omar <[email-masked]> wrote:

> ------------------------------
> *From:* Khaled Omar <[email-masked]>
> *To:* "[email-masked]" <[email-masked]>
> *Sent:* Wednesday, 26 April 2017, 9:27
> *Subject:* KHALED Routing Protocol (KRP).
>
> Hi All,
>
> I think you all received the notification regarding the KRP ID submission,
> so here is the link for this Internet Draft:
>

---

From: Khaled Omar <[email-masked]>
Date: Fri, 28 Apr 2017 07:26:03 +0000

-------- Original Message --------
From: Khaled Omar
To: Artem Pleschenko
CC:

Check this out https://m.youtube.com/watch?v=YGepfaCpa8c

-------- Original Message --------
From: Artem Pleschenko
To: Khaled Omar
CC: Lloyd Wood ,ietf

On 28 April 2017 at 09:56, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Step by step, Khaled Routing Protocol, KRP.

-------- Original Message --------
Subject: Re: KHALED Routing Protocol (KRP).
From: Lloyd Wood
To: Khaled Omar ," [email-masked]<mailto:[email-masked]>"
CC:

"KRP"?

________________________________
From: Khaled Omar <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, 26 April 2017, 9:27
Subject: KHALED Routing Protocol (KRP).

Hi All,

Best Regards,

---

From: Khaled Omar <[email-masked]>
Date: Fri, 28 Apr 2017 07:41:58 +0000

I prefer the first pronounciation, because the KH is a letter in arabic not existing in english.

https://m.youtube.com/watch?v=Xc1bqY7eyXU

-------- Original Message --------
Subject: Re: KHALED Routing Protocol (KRP).
From: Lloyd Wood
To: Khaled Omar ," [email-masked]<mailto:[email-masked]>"
CC:

"KRP"?

Hi All,

Best Regards,

---

From: Khaled Omar <[email-masked]>
Date: Fri, 28 Apr 2017 08:18:08 +0000

All,

Please lets focus on the core value regardless what is the new protocol's name because this name can be changed based on what will be added more and who will add, choosing a new name requires a discussion and I don't mind, but first we need to discuss how to make the draft in the best form before it is being published.

-------- Original Message --------
Subject: Re: KHALED Routing Protocol (KRP).
From: Lloyd Wood
To: Khaled Omar ," [email-masked]<mailto:[email-masked]>"
CC:

"KRP"?

Hi All,

Best Regards,

---

From: Dave Cridland <[email-masked]>
Date: Fri, 28 Apr 2017 10:00:33 +0100

> https://datatracker.ietf.org/doc/draft-omar-krp/

I like this idea, but I think it's sufficiently similar to the
original aim of EGP/BGP that it's already been proven impractical, and
moving to it would also be impractical. I am not a routing expert, so
I'll cheerfully wait being shot down by others, but this is my
rationale:

The reason why we have large routing tables within BGP routers is
mostly that ASNs now consist of many more prefixes than were
originally expected, and so the prefixes do not aggregate well enough.

This proposal involves, essentially, renumbering the entire internet
(which is very difficult in practical terms), such that aggregation
then works more efficiently. However, history has shown that while
this would work for the short term, it would require continuous
renumbering in response to many factors (new addresses, corporate
mergers, etc) in order to maintain its efficiency.

Since we have not solved renumbering very effectively in the first
place, I feel that this is not worth working on.

I would, however, suggest that addressing renumbering would be an
excellent use of your time. A viable solution to renumbering large
public networks would mean that the BGP table would shrink, by the
same logic as above.

That is, if we had a method for renumbering continuously, then it
would improve the efficiency of BGP as well, to almost the same
extent, without incurring the initial internet-wide renumbering
effort.

Finally, I would note that while routing tables are large, the
internet still functions - this may not be the best use of your time
therefore.

Dave.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 28 Apr 2017 12:08:56 +0000

-------- Original Message --------
To: Dave Cridland
CC:

Dave,

Regarding the difference between tables, KRP within each region uses a table of only RBRs and RRs, the table is not listing prefixes because KRP uses the information stored on every single IP address and the IGP routing table, also, the Forwarding table details of one region is not advertised to other regions because they don't need to know it, enough to know how to reach the RBR and then it can deliver the packet faster and correctly.

KRP will not require renumbering (reallocation) of IP addresses after the modification made to the 1st version of the draft that used the 1st two groups of IPv6 addresses as the KRP ASN, but the 2nd version used the middle two groups, and that will make the usage of KRP easier.

Finally, don't stop on what you think is not applicable, share your thoughts to add a solution to make things applicable thats the aim of the discussion, because KRP can route packets successfully from the source to the destination using the Best best route and with the lowest table entries for faster routing decisions.

-------- Original Message --------
Subject: Re: KHALED Routing Protocol (KRP).
From: Dave Cridland
To: Khaled Omar
CC: [email-masked]

Dave.

---

From: Lee Howard <[email-masked]>
Date: Fri, 28 Apr 2017 08:42:09 -0400

From:  ietf <[email-masked]> on behalf of Khaled Omar
<[email-masked]>
Date:  Friday, April 28, 2017 at 8:08 AM
To:  ietf <[email-masked]>
Subject:  Fw: KHALED Routing Protocol (KRP).
> 
> Regarding the difference between tables, KRP within each region uses a table
> of only RBRs and RRs, the table is not listing prefixes because KRP uses the
> information stored on every single IP address and the IGP routing table, also,
> the Forwarding table details of one region is not advertised to other regions
> because they don't need to know it, enough to know how to reach the RBR and
> then it can deliver the packet faster and correctly.

Sorry, you¹re carrying full routes for every /32 and every /128 in your IGP?

> 
> 
> KRP will not require renumbering (reallocation) of IP addresses after the
> modification made to the 1st version of the draft that used the 1st two groups
> of IPv6 addresses as the KRP ASN, but the 2nd version used the middle two
> groups, and that will make the usage of KRP easier.

What about IPv4?

> 
> 
> Finally, don't stop on what you think is not applicable, share your thoughts
> to add a solution to make things applicable thats the aim of the discussion,
> because KRP can route packets successfully from the source to the destination
> using the Best best route and with the lowest table entries for faster routing
> decisions.

Define ³Best best.²
Shortest AS hops? Fewest intermediate devices? Cheapest link? Least
saturated link? Hot potato? Lowest packet one-way latency?

I agree with Dave; the 6renum WG published rfc7010 IPv6 Site Renumbering Gap
Analysis and then shut down; filling those gaps would be useful.

Lee

---

From: Khaled Omar <[email-masked]>
Date: Fri, 28 Apr 2017 13:12:12 +0000

KRP router Forwarding Table (FT):

Local KRP ASN

Remote KRP ASN

RBR KRP ASN

Best AS Path

Output Interface

Next-hop IP address

This is the used KRP Forwarding Table, it lists KRP ASNs and the Best AS path from the local KRP ASN and every single destination KRP ASN.

When the packet travels between KRP ASNs, it uses the already existing IGP Routing Table that lists full local prefixes/subnets within this local KRP ASN until reaching the RR or the RBR.

Regarding IPv4, the 1st two octets are used as KRP ASN for ISPs but still an issue for enterprises because the KRP ASN must be unique and this is under development.

The Best best route means respectively:

1)      The shortest AS path.

2)      The lowest IGP metric route.

From: Lee Howard [mailto:[email-masked]]
Sent: Friday, April 28, 2017 2:42 PM
To: Khaled Omar; ietf
Subject: Re: KHALED Routing Protocol (KRP).

From: ietf <[email-masked]<mailto:[email-masked]>> on behalf of Khaled Omar <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 28, 2017 at 8:08 AM
To: ietf <[email-masked]<mailto:[email-masked]>>
Subject: Fw: KHALED Routing Protocol (KRP).

Sorry, you're carrying full routes for every /32 and every /128 in your IGP?

What about IPv4?

Define "Best best."
Shortest AS hops? Fewest intermediate devices? Cheapest link? Least saturated link? Hot potato? Lowest packet one-way latency?

I agree with Dave; the 6renum WG published rfc7010 IPv6 Site Renumbering Gap Analysis and then shut down; filling those gaps would be useful.

Lee

-------- Original Message --------
Subject: Re: KHALED Routing Protocol (KRP).
From: Dave Cridland
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>

Dave.