Subject: Khaled Routing Protocol (KRP) ID Submission.

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Apr 2017 16:13:30 +0000

Hi Jasmine,

Please upload the 2nd ID attached.

Looking for an advanced discussion to take this ID forward.

Best Regards,

Khaled Omar

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 12 Apr 2017 18:47:04 +0200

Hi Khaled,

Speaking as sergeant-at-arms.

Several folks, including myself, have explained you, several times, that it is inappropriate to send documents to this list, even less when they have a specific venue for their discussion.

If you want to participate and contribute, you should read the chapter of this list:

https://tools.ietf.org/html/rfc3005

As you’re submitting a document to the int-area (according to the document naming), this probably is the right list for that document discussion, but in any case the document should not be forwarded to any list, just the links once published by the RFC editor.

If you keep insisting, I will have no other option than restricting your posting rights in this list, hopefully we can avoid that.

Hat off.

I think if you’re working in a routing document, the right place is the routing-area or a more specific WG, not int-area.

By the way, if that’s useful for you, the submission of the documents is done automatically here:

https://datatracker.ietf.org/submit/

You can check your XML file here:

https://xml2rfc.tools.ietf.org/

Last, but not least, you should read with care https://www.ietf.org/tao.html, and more generic link at https://www.ietf.org/newcomers.html.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Khaled Omar <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 12 de abril de 2017, 18:13
Para: "[email-masked]" <[email-masked]>
CC: "[email-masked]" <[email-masked]>
Asunto: Khaled Routing Protocol (KRP) ID Submission.

    Hi Jasmine,

     
    Best Regards,
     
    Khaled Omar 

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Apr 2017 20:17:05 +0000

Hi,

I sent my 2nd ID to all the ietf list as well so I can find a suggestion where this ID should be discussed and those on the list can know about KHALED Routing Protocol (KRP) so maybe someone is interested in my new draft as there are things expected to be added to make this ID in the best form.

Best regards,

Khaled Omar

-------- Original Message --------
Subject: Re: Khaled Routing Protocol (KRP) ID Submission.
From: JORDI PALET MARTINEZ
To: [email-masked]
CC: [email-masked]

Hi Khaled,

Hat off.

Regards,
Jordi

-----Mensaje original-----
De: ietf en nombre de Khaled Omar
Responder a:
Fecha: miércoles, 12 de abril de 2017, 18:13
Para: "[email-masked]"
CC: "[email-masked]"
Asunto: Khaled Routing Protocol (KRP) ID Submission.

Hi Jasmine,

Best Regards,

Khaled Omar

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 12 Apr 2017 20:58:20 +0000

Khaled:

Hi!

I took a quick look at your draft.  It seems to be proposing a way to assign IP addresses so that they contain information about regions and autonomous systems – and then suggesting that forwarding can be done based on that.  But you are not proposing a routing protocol (packet formats, protocol details, etc.)...

Note that the IETF has been responsible for defining IPv4/IPv6, but it is not responsible for the assignment of IP addresses, which seems to be the central point of your proposal.  IANA is responsible for allocating address blocks to the regional registries [1], but the allocation has already been such that it is too late to change the policies (which are not set by the IETF either) to match what you propose.

I recommend that you review the existing policies and what each organization is in charge of doing before writing another proposal.

If you want to have further discussions on this topic, please feel free to contact me directly.

Regards,

Alvaro.

[1] https://www.iana.org/numbers

On 4/12/17, 4:17 PM, "ietf on behalf of Khaled Omar" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

---

From: John C Klensin <[email-masked]>
Date: Wed, 12 Apr 2017 17:14:20 -0400

Khaled,

You have been asked repeatedly, on and off list, to not try to
post I-Ds to this mailing list.  If you want comments on a
draft, get that draft posted, then ask for  comments and input
(something Jordi's note mentioned but that has also been said
before).

If you are unwilling or unable to do that, you should reasonably
expect that people will become annoyed at you, something that
does not encourage them to study and review the draft, and that
people will reach the conclusion that you are being
intentionally disruptive and request that your posting rights be
suspended sooner rather than later.

As before, if you need help getting drafts posted or otherwise
navigating the IETF system, there are several of us who are
willing to try to help if you write us off list.    But, at
least for me and perhaps others, a condition for that help is
that you try to understand the IETF's way of working and conform
to it.

regards,
   john

--On Wednesday, April 12, 2017 20:17 +0000 Khaled Omar
<[email-masked]> wrote:

> Hi,
> 
> I sent my 2nd ID to all the ietf list as well so I can find a
> suggestion where this ID should be discussed and those on the
> list can know about KHALED Routing Protocol (KRP) so maybe
> someone is interested in my new draft as there are things
> expected to be added to make this ID in the best form.

---

From: Randy Bush <[email-masked]>
Date: Thu, 13 Apr 2017 10:22:21 +0900

> I took a quick look at your draft.  It seems to be proposing a way to
> assign IP addresses so that they contain information about regions and
> autonomous systems – and then suggesting that forwarding can be done
> based on that.  But you are not proposing a routing protocol (packet
> formats, protocol details, etc.)...

landmark routing, tla/nla, ...  we have seen ideas in this area none of
which flew.  i agree that this needs more specifics before we can really
judge.

khaled, if you need help dealing with the ietf's obscure methods for
naming, posting, ... drafts, feel free to write to me.

randy