Subject: Re: IAOC requesting input on (potential) meeting cities

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sat, 1 Apr 2017 13:16:33 -0500

If you haven't seen it, there's also a surveymonkey link about border
crossing experiences at IETF 98 that is also appropriate for people who
stayed home because of concerns and for US attendees who didn't cross
borders, and the last question on the questionnaire is roughly "do you have
concerns about future US meetings".

I sent my comments there.

https://www.surveymonkey.com/r/WMNH9PS

I assume the survey entries will become publicly available at some point -
attendee surveys usually do.

Thanks,

Spencer

On Mar 31, 2017 18:58, "Stewart Bryant" <[email-masked]> wrote:

>
>
> On 31/03/2017 15:42, Eliot Lear wrote:
>
>> Hi,
>>
>>
>> On 3/31/17 9:18 AM, IAOC Chair wrote:
>>
>>> The IAOC remains committed to soliciting input on future IETF meeting
>>> locations. With this mail, we are soliciting input on some potential IETF
>>> locations, including one where we have met before, but for which conditions
>>> may have changed.
>>>
>>> Specifically, we seek community input on reasons we could not have a
>>> successful meeting in any of the following cities, or of any limits to
>>> attendee accessibility or inclusiveness that should be considered:
>>>
>>> Ottawa
>>> San Francisco
>>> Austin, TX
>>> Barcelona
>>> Boston
>>> Busan - looks expensive to get to
>>> Calgary - also looks expensive to get to
>>> Denver
>>> Helsinki
>>> Houston
>>> New Orleans
>>> Osaka
>>> Philadelphia
>>> Washington DC
>>>
>>
>> To save everyone doing it, it would be good to show representative
> airfares and times from a major hub in Europe, East and West Coast, and Asia
>
> I am sure cost and travel time will impact acceptability.
>
> - Stewart
>
>

---

From: Rich Kulawiec <[email-masked]>
Date: Mon, 3 Apr 2017 11:26:24 -0400

On Fri, Mar 31, 2017 at 11:59:49AM -0500, Paul Wouters wrote:
> I don't know when I will be refused entry for not handing out
> passwords or pins.

This is worth noting on an equal basis with the question of
whether travelers will be refused entry or only permitted entry
after considerable delays, interrogation, and abuse.  There is
at this moment no articulated, consistent, and uniform policy
in place specifying:

	- who will be asked for passwords
	- why they'll be asked
	- who will do the asking
	- under what circumstances they'll be asked
	- what the ramifications of refusal are
	- what the ramifications of not remembering them are
	- what the ramifications of agreement are
	- what use will be made of them
	- what use will be made of any data they provide access to
	- if they'll be retained
	- if the data they provide access to will be retained
	- if they'll be shared with other US agencies
	- if they'll be shared with other non-US agencies
	- if computing devices will be confiscated
	- if computing devices will be searched
	- if computing devices will be returned
	- if the contents of computing devices will be copied
	- who will have access to that data
	- what use will be made of that data
	- if that data will be retained
	- if that data will be shared with US agencies
	- if that data will be shared with non-US agencies
	- what auditing controls (if any) exist to prevent mis-use
	- when any retained passwords/data will be destroyed (if ever)
	- etc.

Moreover, the ad hoc policies that are in place are used very
inconsistently -- at the personal whims of those enforcing them --
and are subject to change not only without advance notice,
but without any notice of any kind.

Because of this, asking anyone to come to the US at this time is
equivalent to asking them to incur unknown but possibly very large
privacy and security risks, as well the financial risk of losing
any/all computing devices they bring with them.

---rsk

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 4 Apr 2017 04:23:21 +1200

>> I don't know when I will be refused entry for not handing out
...
> any/all computing devices they bring with them.

What is specific to the US in all that? Afaik, customs or immigration
officers have similar rights in many, if not most, countries. And they
use them from time to time, at random or as a result of profiling.

Before you formally enter the country, your rights are limited
in most cases, not only in the US.

    Brian

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 03 Apr 2017 18:39:32 +0200

I’m not convinced (despite laws may say it), if computer inspection, even “temporal” confiscation, is being used in EU. At least I never heard about that, and even less in my own country, though I may be missing cases in other EU countries.

Definitively if that happens to me in EU, I will not provide passwords even if I don’t have anything to hide, but just because customer’s info confidentiality, signed NDAs, etc. I don’t think that will bring me to the jail. However, in US, detention is a fact, right?

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Brian E Carpenter <[email-masked]>
Organización: University of Auckland
Responder a: <[email-masked]>
Fecha: lunes, 3 de abril de 2017, 18:23
Para: <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    ...

    
        Brian

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 3 Apr 2017 18:30:23 +0100

Sadly it has happened in the UK.

http://www.msnbc.com/all/uk-unlawfully-detained-partner-snowden

Adrian

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
> Sent: 03 April 2017 17:40
> To: [email-masked]
> Subject: Re: IAOC requesting input on (potential) meeting cities
> 
> I’m not convinced (despite laws may say it), if computer inspection, even
> “temporal” confiscation, is being used in EU. At least I never heard about that,
> and even less in my own country, though I may be missing cases in other EU
> countries.
> 
> Definitively if that happens to me in EU, I will not provide passwords even if I
> don’t have anything to hide, but just because customer’s info confidentiality,
> signed NDAs, etc. I don’t think that will bring me to the jail. However, in US,
> detention is a fact, right?

---

From: Christian Huitema <[email-masked]>
Date: Mon, 3 Apr 2017 10:32:04 -0700

> I’m not convinced (despite laws may say it), if computer inspection, even “temporal” confiscation, is being used in EU. At least I never heard about that, and even less in my own country, though I…
You are indeed missing something.

Here is one pretty famous case, happened in Heathrow: Greenwald's
partner detained, thumb drives confiscated.
http://www.thedrum.com/news/2013/08/19/snowden-documents-seized-heathrow-intimidation-says-greenwald-his-partner-detained

Here is a clip about Canada's refusal to disclose laptop search policy:
http://boingboing.net/2010/02/09/canadian-customs-ref.html

Article 60 of French custom code authorizes inspection of anything you
carry, can be interpreted as authorizing search of laptops or cell phones:
https://www.legifrance.gouv.fr/affichCode.do;jsessionid=AA678D3E2AC873493D4025F33776856A.tpdila20v_2?idSectionTA=LEGISCTA000006138841&cidTexte=LEGITEXT000006071570&dateTexte=20130315

Various European countries, including the UK and France, have passed
inquisitive snooping laws. Maybe they are less visible than what happens
in the US, but I would not hold my breath...

-- Christian Huitema

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 03 Apr 2017 19:50:58 +0200

I think the “border” line between what is being done in EU and US is that in EU this is only done under a terrorism classification ?

I can ask about this to a Spanish State Lawyer that I will be able to talk at the end of the week …

I knew about the UK case, but I no longer consider UK part of the EU, never has been “totally”, and clearly it should be considered also when we plan new meetings.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Christian Huitema <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 3 de abril de 2017, 19:32
Para: <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    

    
    
    -- Christian Huitema

---

From: Sarah B <[email-masked]>
Date: Mon, 3 Apr 2017 11:39:01 -0700

FWIW, i think all of this has been true, well before Trump took office, and made these changes to the current travel policies... 

/S

> On Apr 3, 2017, at 8:26 AM, Rich Kulawiec <[email-masked]> wrote:
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 3 Apr 2017 13:44:24 -0500

> in most cases, not only in the US.

+1

Behcet

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 4 Apr 2017 09:51:32 +1200

Jordi,

It won't happen when travelling between two "Schengen" countries, I suppose.
But when you enter or leave the Schengen zone, you go through an immigration
checkpoint.

That's a more important distinction than EU/non-EU in this particular case.

    Brian

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 04 Apr 2017 00:11:15 +0200

Hi Brian,

I was considering the EU “borders” to outside-EU, not internal among EU countries.

When I come back from US, Latin America, Africa, AP, to the EU, I feel much safer than when I go to US.

When I travel to *ANY* region or country in the world, except US, I feel very safe.

And is not just how I feel, but how I see people coming to EU feels relatively safe (of course unless they aren’t trying to bypass immigration laws).

I feel each time less and less safe going to US and I see people from other regions outside EU, even people from Canada, feeling unsafe as well.

It is a matter of facts and stats, despite whatever laws say, despite what are the human rights, privacy rights, etc., definitively, US reputation for any non-US citizen is going darker and darker.

I need to see if I still feel safe when traveling to UK next time … after Brexit gets completed.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Brian E Carpenter <[email-masked]>
Organización: University of Auckland
Responder a: <[email-masked]>
Fecha: lunes, 3 de abril de 2017, 23:51
Para: <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    Jordi,

    
        Brian

---

From: tom p. <[email-masked]>
Date: Tue, 4 Apr 2017 11:20:33 +0100

---- Original Message -----
From: "Brian E Carpenter" <[email-masked]>
To: <[email-masked]>
Sent: Monday, April 03, 2017 5:23 PM

> use them from time to time, at random or as a result of profiling.

Fly into the UK from Middle Eastern countries and you are now required
to place any electronic device larger than an iPad into the hold, where
it will not be covered by most insurance policies.  This was introduced
at short notice.

The press reports say that other European countries and Canada are
considering similar restrictions.

I am reminded of the inkjet cartridge bombs of a few years ago.

Tom Petch

---

From: Nico Williams <[email-masked]>
Date: Tue, 4 Apr 2017 13:15:07 -0500

On Mon, Apr 03, 2017 at 06:39:32PM +0200, JORDI PALET MARTINEZ wrote:
> Definitively if that happens to me in EU, I will not provide passwords
> even if I don’t have anything to hide, but just because customer’s
> info confidentiality, signed NDAs, etc. I don’t think that will bring
> me to the jail. However, in US, detention is a fact, right?

It's not.  If you're a U.S. person (citizen, national, or permanent
resident) you cannot be refused entry on account of refusal to provide
passwords to your devices (though, if Customs believes you're carrying
contraband and has sufficient probable cause you might be charged and
arrested, but failure to provide passwords alone is insufficient).  If
you're NOT a U.S. person you may be refused entry, but cannot be
detained indefinitely, and you cannot be refused the right to go home.

The reports of harassment are worrisome, and even more so reports that
lack of devices, or having clean devices, is taken as suspicious.

Employees of many companies simply can't carry non-clean devices if
*credentials* compromise at borders would have negative consequences for
them.  But if carrying clean devices (or no devices) can lead to denial
of entry, then why bother going at all?

All that said, I've been harassed by Customs in Japan and Canada, and I
have heard harassment stories in Argentina (where I hail from) and
elsewhere.  My impression and experience is that Europeans customs are
the least likely to harass visitors.

Nico
--

---

From: Andrew Newton <[email-masked]>
Date: Tue, 4 Apr 2017 13:43:12 -0500

> the least likely to harass visitors.

If we are going to base our decision on anecdotal experiences, my
worst encounters have all been in Europe. I don't think that means
anything other than my worst encounters have an an odd pattern. I also
know people who have been detained and denied entry into Canada
because the Canadians believed them to be violent criminals. They
weren't, but because the Canadians have arrest records but not
conviction/acquittal records from other countries there tend to be
misunderstandings (btw, the US does this as well, not picking on
Canada).

In my opinion, statistics will better inform this discussion.

-andy

---

From: Nico Williams <[email-masked]>
Date: Tue, 4 Apr 2017 15:24:47 -0500

> In my opinion, statistics will better inform this discussion.

My unstated point was that the US border situation is not really
different from anywhere else.  YMMV.  Stats would be nice, but I suspect
there are no reliable stats available, though individual organizations
like the IETF can probably track how many of *its* participants are
harassed at the various countries where it has held conferences.

Perhaps the IETF could gather and publish such statistics going forward.
Though given the relatively fickle nature of border enforcement (I
imagine it tends to be reactive as well as proactive, so recent events
probably tend to affect policy), stats may not be terribly predictive.

Nico
--

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 4 Apr 2017 21:42:57 +0100

Hi Nico,

On 04/04/17 21:24, Nico Williams wrote:
> different from anywhere else.

I disagree. I think that as of now, of the places in which
we're likely to have face-to-face meetings, the uncertainty
with respect to rule-changes involved in future US meetings
is much higher than other places. Again, that's only in terms
of places in which we're likely to meet in the next N years.
That's a mega-negative for US-based meetings IMO.

S.

---

From: Jared Mauch <[email-masked]>
Date: Tue, 4 Apr 2017 16:46:17 -0400

> That's a mega-negative for US-based meetings IMO.

	I welcome the data that is being collected vs all the
armchair responses.

	This reminds me of the IPv6-only question, there's the
zero users that were on the IPv6-only ssid in chicago.  This may
be a real issue, or not.

	I think the thread can end until the data is reported
and we can then provide our commentary on that.

	- Jared

-- 
Jared Mauch  | pgp key available via finger from [email-masked]
clue++;      | http://puck.nether.net/~jared/  My statements are only mine.

---

From: Andrew Newton <[email-masked]>
Date: Tue, 4 Apr 2017 16:03:10 -0500

> and we can then provide our commentary on that.

I agree with Nico and Jared on this point.
-andy

---

From: Yoav Nir <[email-masked]>
Date: Wed, 5 Apr 2017 00:11:49 +0300

> On 4 Apr 2017, at 23:46, Jared Mauch <[email-masked]> wrote:
> 

There is not going to be data. There are going to be the results of a web questionnaire filled out by a self-selected sample.

Heavily biased data is not necessarily better than anecdote and conjecture.

Yoav

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 Apr 2017 23:12:48 +0200

> In my opinion, statistics will better inform this discussion.

Statistics is useful for reasoning about stable countries.

(It may also be useful to remember that the US is unsafe beyond its borders.
Chicago has the murder rate Colombia had in 2013, before the peace process fully set in.
Statistically, the chance of any IETFer being killed last week was about 1.5 %.)

Grüße, Carsten

---

From: Rich Kulawiec <[email-masked]>
Date: Tue, 4 Apr 2017 17:15:26 -0400

On Tue, Apr 04, 2017 at 03:24:47PM -0500, Nico Williams wrote:
> Stats would be nice, but I suspect there are no reliable
> stats available [...]

There aren't, because FOIA requests attempting to learn them have not
been answered.  And that's why there's now a lawsuit filed by the
Knight First Amendment Institute at Columbia University against the
US DHS and ICE:

	https://www.documentcloud.org/documents/3525562-Complaint-03-27-2017.html

However, any number of organizations, e.g., the EFF, the ACLU, etc.,
have independently noted the recent sharp uptick.  In addition, the Wall
Street Journal is reporting today that a new set of procedures under
consideration will include demanding the phone passwords from *all*
foreigners entering the US.

---rsk

---

From: Eliot Lear <[email-masked]>
Date: Tue, 4 Apr 2017 23:56:42 +0200

Jared, man, read the newspapers.

> and we can then provide our commentary on that.

How do you gather data when the circumstances are changing day in and
day out?  Here's the latest fun.

https://www.theguardian.com/us-news/2017/apr/04/trump-extreme-vetting-visitors-to-us-share-contacts-passwords

The implication being that someone could be turned away at the border
based on private political views.

Eliot

---

From: Nico Williams <[email-masked]>
Date: Tue, 4 Apr 2017 17:10:42 -0500

On Wed, Apr 05, 2017 at 12:11:49AM +0300, Yoav Nir wrote:
> There is not going to be data. There are going to be the results of a
> web questionnaire filled out by a self-selected sample.

When an IETF participant is turned away at some border, or has their
devices inspected, or is presented with demands for their passwords,
they should inform the IETF so that the IETF can count such incidents.

I suppose a participant could be told not to tell, but it's very
difficult to ignore absence.  At the very least it should be possible to
count entry denial events.

I do suspect that the U.S. will be a more difficult location for more
attendees than other locations.  Certainly the news we all see is not
encouraging as to hosting IETF meetings in the U.S.  This I don't deny.
Though it's also possible that this is becoming a self-reinforcing meme
and that we're just not seeing incidents in other countries in the news.
In any case, the U.S. certainly does not have a monopoly on the border
harasment business.

Some people may wish to boycott the U.S. by refusing to host events
there.  There is some precedent for such a boycott.  For example, some
time back an obscure agency of the Texas state government decided to
guard its surplus budget by policing public drunkenness at hotel bars,
which led to a number of conferences pulling out of Texas, and the
ensuing bad PR led the legislature to rein in said agency.

However, at the scale of a state/province the politics of boycotts is
generally not partisan, but at a national/global scale it tends to be
rankly partisan, and boycotts may not be productive and may be divisive,
and should be approached with care.  Here "care" means: get some
evidence of negative impact on participation.  Reducing frequency of
U.S. meetings is not a boycott, and is something the IETF has been doing
for a long time anyways.  Further reducing that frequency in the short
term would be perfectly fine, though it would also reduce opportunities
for gather the stats we really need to make a sound, non-partisan
decision to boycott if the stats warrant it.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Tue, 4 Apr 2017 17:19:13 -0500

> foreigners entering the US.

*That* would be a huge deal.  I don't quite believe it likely to happen
though: it would require lots of new hardware and staffing to do
anything useful with every visitor's devices and password _and_ keep
entry bandwidth as high as today (_and_ keep tourism and business travel
to the U.S. from collapsing).

(I wouldn't necessarily mind traveling with a clean phone everywhere,
but the problem with that is that there have been reports where having a
clean phone has been used as rationale for sending the visitor back.)

If a country starts demanding access to and passwords for every
visitor's every device (and then making use of said access and
credentials) then certainly the IETF must avoid holding meetings in that
country -- not so much (or only) as a political statement, but (also) to
protect its participants.  Especially so if having a clean phone is then
considered suspicious enough to send participants back.

Nico
--

---

From: Jared Mauch <[email-masked]>
Date: Tue, 4 Apr 2017 18:33:53 -0400

Thanks. I do. 

I wait to see what set of the IETF population actually reported an issue vs what you think the IETF population faces. 

I happen to have been least inconvenienced by this meeting as it was within the fly:drive decision radius. 

Singapore (for me) will have the highest RTT as its 24h or so one way. 

I'm aware of the overall trends and detailed issues that have transpired and have family members who work for US CBP and am having regular contact with them. 

Jared Mauch

> On Apr 4, 2017, at 5:56 PM, Eliot Lear <[email-masked]> wrote:
>

---

From: Melinda Shore <[email-masked]>
Date: Tue, 4 Apr 2017 14:56:04 -0800

> Jared, man, read the newspapers.

Well, there's certainly that (the Canadian paper, the Globe and
Mail, has done a lot of excellent work on tracking down incidents
where Canadians have had problems entering the US, as one example).

I think the broader problem is that there's just a lot of uncertainty
and inconsistency, and even if it were possible to collect an
authoritative list of incidents it wouldn't capture the problem that
many people crossing the border in and out of the US these days don't
really know what to expect.  It's one thing when you're not sure
whether or not your bag of dog food will be permitted in and an
entirely different one when you're not sure whether or not you'll
be turned back.

I don't know how to capture that uncertainty in a way that will
satisfy the skeptics but it does seem to me to be a very serious
problem with respect to planning.

Melinda

---

From: mike stJohns <[email-masked]>
Date: Tue, 4 Apr 2017 19:06:20 -0400

Carsten, you're off by very large factor.   The Chicago murder rate reported last year was 27 deaths per 100000 for the entire year.   That works out to be about .5 deaths per week per 100000 or .005 deaths per week per 1000( the number of people attending the IETF) Or .0005% of the IETF population for the week we were there.  

I'm doing this math in my head while having a glass of wine so it's possible I've dropped or added a zero or two but it is definitely not 1.5%.   It's worse than it should be, but it's irresponsible to suggest that the level of risk was that high.  

Mike

Sent from my iPad

> On Apr 4, 2017, at 17:12, Carsten Bormann <[email-masked]> wrote:
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 4 Apr 2017 16:34:47 -0700

At least once, I was questioned extensively when going from the US to a
meeting in Canada. I had to show evidence of the meeting and my itinerary
and convince them that I wasn’t entering Canada to take work away from a
Canadian. That said, I still support holding meetings in Canada.

Cheers,
Andy

---

From: Melinda Shore <[email-masked]>
Date: Tue, 4 Apr 2017 15:50:50 -0800

On 4/4/17 3:34 PM, Andrew G. Malis wrote:
> meeting in Canada. I had to show evidence of the meeting and my
> itinerary and convince them that I wasn’t entering Canada to take work
> away from a Canadian. That said, I still support holding meetings in Canada.

That's not comparable.  We know what the policy is concerning
Americans working in Canada, and that how you describe "meeting"
can affect whether or not it's considered to be work.  People
without the appropriate papers (whether it's citizenship, residence,
or a visa) are not permitted to work in Canada, period.  You should
know that before entering Canada.  (That said, I'm truly sorry you were
asked for evidence supporting the reason you gave for entering the
country).

Here, we're talking about uncertainty about whether or not Canadian
citizens (for example) will be permitted to enter the US based on
religious beliefs or (in the case of naturalized citizens) country of
birth.  Sometimes they are, sometimes they're not, and it appears to be
independent of any publicly-announced policy.  Similarly, US citizens
do not have the right to enter the US (that's not that widely-known,
unfortunately) and some citizens and green card holders have been
turned away or detained when trying to re-enter the US because of
their religion or country of birth.  This is not comparable to a
situation in which someone trying to enter a country is asked to
provide evidence supporting their assertions about why they're entering.

Melinda

---

From: james woodyatt <[email-masked]>
Date: Tue, 4 Apr 2017 17:40:54 -0700

> 	- if the data they provide access to will be retained

		- if the data protected by the password will be modified or deleted
		- if the software on the protected device will be modified or deleted

--james woodyatt <[email-masked] <mailto:[email-masked]>>

---

From: "John Levine" <[email-masked]>
Date: 5 Apr 2017 00:53:47 -0000

>can affect whether or not it's considered to be work. ...

But it's not consistent.  In nearly every case when I show up at the
Canadian border, show my NEXUS card and tell them I'm going to a
meeting, they wave me through.  One time when I got bored of the usual
route, I entered Canada via ferry on a rural island in the St
Lawrence, and it rapidly became obvious that I was the high point of
their week, as they wasted the better part of an hour searching my
car, getting all suspicious about the papers I had for a presentation
at the meeting, and even calling headquarters to see if I needed a
visa.

I agree that Canada is a fairly easy country to get in and out of
(unless you have a DUI arrest) but it varies a lot so anecdotes about
entering Canada or any other country don't tell you much.

R's,
John

---

From: Jared Mauch <[email-masked]>
Date: Tue, 4 Apr 2017 22:13:31 -0400

> entering Canada or any other country don't tell you much.

	Agreed.  When I received my NEXUS card they explicity told me
if I was traveling to a conference and was presenting that I would
require additional paperwork, possibly including a letter of invitation,
and/or a visa.  I presume if I were presenting at an IETF WG I would
check the appropriate box when registering as well and I would get
the paperwork.

	I've also been detained upon re-entering the US for more than 
an hour with my entire family recently crossing the land border.  This
was not a fun experience.

	Either way, I'm waiting to hear the report from Leslie et al
from people based on the survey questions asked.  They seemed quite
comprehensive.

	- Jared

---

From: Eliot Lear <[email-masked]>
Date: Wed, 5 Apr 2017 06:39:24 +0200

Nico,

> In any case, the U.S. certainly does not have a monopoly on the border

Certainly people have had trouble getting into other countries, most
notably Canada where an IAB member was refused entry.  But this isn't
just news.  It is a series of declarations by the U.S. government of
their intentions, and the IAOC has to plan ahead.  That's why Jared's
request for data is simply not tenable *at this stage*.  If it turns out
that things aren't so bad, the IAOC can react accordingly.  However, as
I wrote in my original email, there is now good reason to believe that
things will get worse, due to the European Parliament’s decision to
require visas from U.S. citizens.

> evidence of negative impact on participation.  

We ALREADY have evidence, as some people couldn't make Chicago, and said
so on this very list (and, by the way, were shamefully attacked and
dismissed (no, it certainly wasn't you)).  What we don't have is an
understanding of the order of magnitude of the impact, and that is going
to be very hard to gather in so  fluid a situation with so long a
lookahead.  The point, by the way, as I see it, is not to punish the
U.S. but to hold a successful meeting (that is what the mtgvenue draft
states as well).

> Reducing frequency of

Turn this around: suppose we do keep the meeting in San Francisco, for
instance, and some number of people cannot get there for whatever
reason, or cannot otherwise function on an equal footing.  Would the
IAOC then be attacked for having ignored the vast number of warnings
that have been signaled?

Eliot

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 Apr 2017 07:56:21 +0200

On Apr 5, 2017, at 01:06, mike stJohns <[email-masked]> wrote:
> 
> .005 deaths per week per 1000

Right, the 270 micromorts per year (~ 5 micromorts per week) you cited would lead to a ~ 0.5 % chance of anyone of the ~ 1000 IETFers getting killed — a factor three less than the 1.5 % that my numbers result in, but not off by a large factor.
(Still, I wonder where that factor three comes from.)

Luckily, we hit the other 98.5 % this week.

(I’m not that worried by the ~ 15 micromorts of risk I personally was subjected to, given that I spent on the order of 250 microlives for the time that went into this meeting.
But my wife, who had been planning our wonderful vacation in Colombia earlier this year, definitely was.)

Grüße, Carsten

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 5 Apr 2017 08:11:06 +0000

Chicago is a big city, and the murder rate varies widely between different
areas. So, if you do your maths based on the numbers in the areas where
IETFers are likely to move around, and the kind of activities IETFers are
likely to participate in (much of the violence is related to
gang/drug-related activities), I¹m sure the result is going to be even
smallerŠ 

On 05/04/17 08:56, "ietf on behalf of Carsten Bormann"
<[email-masked] on behalf of [email-masked]> wrote:

>Right, the 270 micromorts per year (~ 5 micromorts per week) you cited
>would lead to a ~ 0.5 % chance of anyone of the ~ 1000 IETFers getting
>killed ‹ a factor three less than the 1.5 % that my numbers result in,
>but not off by a large factor.
>(I¹m not that worried by the ~ 15 micromorts of risk I personally was
>subjected to, given that I spent on the order of 250 microlives for the
>time that went into this meeting.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 05 Apr 2017 10:25:54 +0200

One important question here, same as we had in the case of Singapore.

If we cancel San Francisco, how much that is going to cost to the IETF for each of two planned meetings?

Furthermore, can the IAOC respond to this:

Can we cancel the actual hotel contract considering the new US situation? If not, has this been considered for new contracts to avoid this problem?

I think the relevant information in the contract need to be disclosed and have it now on the table, otherwise we will be wasting the time discussing possibilities that are actually impossible to assume for the IETF …

My general position is:
1) I will prefer not cancelling already planned meetings.
2) I will prefer not “blocking” any regions or countries from future meetings, including US.
3) However, for already contracted meetings, if this is going to cost IETF thousands of dollars, we can’t afford that.
4) We must work with authorities to avoid people being banned for attending the meetings.

Maybe I’ve missed responses to some of my answers already, in any case, can the IAOC provide urgently those with a complete summary of the situation?

Regards,
Jordi

-----Mensaje original-----
De: Eliot Lear <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 5 de abril de 2017, 6:39
Para: Nico Williams <[email-masked]>, Yoav Nir <[email-masked]>
CC: IETF <[email-masked]>, JORDI PALET MARTINEZ <[email-masked]>, Jared Mauch <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    Nico,

    

    
    
    Eliot

---

From: Dick Franks <[email-masked]>
Date: Wed, 5 Apr 2017 10:46:29 +0100

>8

> 3) However, for already contracted meetings, if this is going to cost IETF
> thousands of dollars, we can’t afford that.
>

If the entire foreign contingent votes with its feet and stays home,
strikes me that IETF can't afford that either.

And further to your earlier remark:

The UK is, and will remain, a part of the EU until March 2019 in accordance
with Lisbon Treaty, Article 50.

PS  The Treaty of Utrecht has no equivalent of Article 50.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 05 Apr 2017 11:55:21 +0200

Agree, but we should have the figures to make a right and balanced decision, right?

Is not the same if it cost 100.000 USD than 10.000 or 200.000 for each of those meetings …, despite the risk of having 50% of the participants not attending, which in terms of just “money” (not saying is the only thing that matters), 550 participants (half of regular attendance) means 440.000 USD at 800 USD registration fee.

Regarding UK, yeah, I should have said Schengen, I think somebody else already mention that point before.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Dick Franks <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 5 de abril de 2017, 11:46
Para: Jordi Palet Martinez <[email-masked]>
CC: IETF <[email-masked]>, <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    On 5 April 2017 at 09:25, JORDI PALET MARTINEZ <[email-masked]> wrote:

    

    
    
    If the entire foreign contingent votes with its feet and stays home, strikes me that IETF can't afford that either.

    
    The UK is, and will remain, a part of the EU until March 2019 in accordance with Lisbon Treaty, Article 50.

---

From: Rich Kulawiec <[email-masked]>
Date: Wed, 5 Apr 2017 06:33:49 -0400

On Tue, Apr 04, 2017 at 05:19:13PM -0500, Nico Williams wrote:
> anything useful with every visitor's devices and password [...]

It would.  But it would require neither new hardware nor staffing to
do something useful with *some* visitors' devices and passwords and to
merely engage in security theater with the rest.  It appears that
this policy is intended to be comprehensive in order to avoid subsequent
court challenges based on the selection of certain groups of people.

> [...] _and_ keep entry bandwidth as high as today (_and_ keep tourism
> and business travel to the U.S. from collapsing).

It's not at all clear that either of these are policy objectives.

---rsk

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 Apr 2017 12:37:34 +0200

On Apr 4, 2017, at 23:15, Rich Kulawiec <[email-masked]> wrote:
> the Wall

https://www.wsj.com/articles/trump-administration-considers-far-reaching-steps-for-extreme-vetting-1491303602?mod=e2tw

Whoa.  *Not stable*.

San Francisco/West Coast (including Hawaii) used to be a better destination than the rest of the USA, as it is governed by the Ninth Circuit, which seemed to keep a remnant of rule of law alive.  Not sure that privileged status will remain.

Grüße, Carsten

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 5 Apr 2017 12:23:56 +0100

On 04/04/2017 23:19, Nico Williams wrote:
> visitor's every device

.. hopefully they will accept a list of possible passwords plus password 
recovery as an answer, because for anything that I rarely use such as 
facebook, I work my way down a list of possible passwords and more often 
than not end up using password recovery.

Stewart

---

From: Rich Kulawiec <[email-masked]>
Date: Wed, 5 Apr 2017 07:37:16 -0400

> 		- if the software on the protected device will be modified or deleted

You're absolutely right, those should be on the list.  Let me also add
two more.  (1) Given the long, steady, depressing history of massive breaches
of various governments' databases, there is no way to know if passwords
acquired and data siphoned off will be adequately protected.  (2) There's
also no way to know what any enterprising person will independently
choose to do with this veritable goldmine of saleable information --
doubly so given the lack of checks and balances, audits, controls, etc.

---rsk

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 5 Apr 2017 08:46:39 -0400

The core problem here is that the Trump administration has followed through
on campaign pledges to implement rules that are irrational and
unpredictable. At this point in time, nobody can know for certain what the
rules will be in six months time, let alone the two year planning horizon
for meetings.

What we face here is a situation of predictable unpredictability. In such a
situation, it is necessary to always plan for the worst case scenario. That
the situation 'might' be OK is irrelevant in the context of a two year
planning window for a meeting costing roughly a million dollars a time.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 Apr 2017 09:23:14 -0400

Andrew G. Malis <[email-masked]> wrote:
    > At least once, I was questioned extensively when going from the US to
    > a meeting in Canada. I had to show evidence of the meeting and my

IETF98 was among the only times I was *NOT* asked questions like that when
entering the US.   I did enter at Midway.   That none of are asked such
questions when entering europe always surprises me.

I'm not sure what "extensively" means; if that means you were taken aside, or
not.  I've been through that at the US border.

"Chair of work group" would always be a bad thing to say, since it has the
word "work" in it.  Never talk about customers.  The IETF is a meeting of
peers.

(Once because it was 5am, and I was just really loud since I was really still
asleep).

But, in all cases I felt confident that I would be treated with respect,
(even by the border guard who didn't seem to believe that e-tickets were
real).

I did *not* feel that way while preparing to travel to IETF98.
My fears were not realized; but as Eliot has said, it's *exactly* the
uncertainty that is a problem.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 05 Apr 2017 09:25:54 -0400

> check the appropriate box when registering as well and I would get

No!  Only if you have been paid to present.
     i.e. you are Al Gore coming to talk at the Air Canada center in Toronto.

We don't do presentations like that at the IETF.
The IETF is not like most non-technical "conferences".

---

From: mike stJohns <[email-masked]>
Date: Wed, 5 Apr 2017 09:49:54 -0400

Let's try this one more time

27 deaths in 100 would be 27%
27 deaths in 1000 would be 2.7%
27 deaths in 10000 would be .27%
27 deaths in 100000 would be a rate of .027%
The above are all expected deaths per year for the given population - so divide .027% by 52 to get .00051% per week.  That's roughly the chance per individual to die during the week from murder.   That's *my* risk for a week of the IETF and that's what should matter to each individual.   

If you take that and multiply it by the IETF population you get .005 expected deaths within the IETF for the entire week.   

Now you're using the "at least one" criteria, which works out to be 1-(1-.0000051)^1000 = .005 or .5% of at least one person dying in the week so your numbers are somewhat reasonable, but don't actually mean anything.  E.g this is basically the birthday paradox which grows the probability quickly with the size of the set.   

 I'll give you an example.  The death rate per 1000 in Germany per year for all causes is about 11.  That works out to about a 20% chance of at least one person dying in the IETF during the week from all causes including murder if we all lived in Germany.   The equivalent statistic for the US is 8 per 1000 which works out to 15% for the IETF for the week.  But we don't seem to be dropping at anywhere close to that rate ( e.g. A death at the meting every 5 meetings).  

Death probabilities are *highly* dependent on the specific populations you're looking at and actuaries get paid a lot of money to calculate them.  The actual probabilities for the IETF would benefit from affluence, age, medical care, education, location, etc. 

Mike

Sent from my iPad

>> On Apr 5, 2017, at 01:56, Carsten Bormann <[email-masked]> wrote:
>>

---

From: Michael StJohns <[email-masked]>
Date: Wed, 5 Apr 2017 10:26:20 -0400

I meant to include (damn iPad):

Carsten's original email was
> Statistically, the chance of any IETFer being killed last week was about 1.5 %.

"Any IETFer being killed" (I read the above as "Any [given] IETFer")  is 
the .00051% chance.  "At least one IETFer" is the .5% chance.  "Anyone 
in the IETF" could mean either - precision is important and I still 
don't actually know which Carsten meant.

Later, Mike

---

From: Bob Hinden <[email-masked]>
Date: Wed, 5 Apr 2017 08:13:47 -0700

> On Apr 5, 2017, at 7:26 AM, Michael StJohns <[email-masked]> wrote:
> 
> "Any IETFer being killed" (I read the above as "Any [given] IETFer")  is the .00051% chance.  "At least one IETFer" is the .5% chance.  "Anyone in the IETF" could mean either - precision is important and I still don't actually know which Carsten meant.

I am happy that no IETFer got killed.  We did have some heated debates :-)

Bob

---

From: Michael StJohns <[email-masked]>
Date: Wed, 5 Apr 2017 11:17:29 -0400

> I am happy that no IETFer got killed.  We did have some heated debates :-)
I once saw Dave Clark after a particularly contentious side meeting at 
an early IETF and said that I was glad I didn't see blood. His response 
was classic Dave: "It was the kind of meeting where the only blood came 
from biting your tongue."

Mike

The IETF - 30 years of Standards by Combat!

---

From: Andrew Allen <[email-masked]>
Date: Wed, 5 Apr 2017 17:52:08 +0000

Most of all the homicides in Chicago take place in a few square miles in certain areas a little outside the downtown district which is itself relatively safe. As Christer says most of those incidents are related to narcotics and the associated gang turf wars.

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, April 5, 2017 4:11 AM
To: Carsten Bormann <[email-masked]>; mike stJohns <[email-masked]>
Cc: IETF <[email-masked]>
Subject: Re: IAOC requesting input on (potential) meeting cities

Chicago is a big city, and the murder rate varies widely between different areas. So, if you do your maths based on the numbers in the areas where IETFers are likely to move around, and the kind of activities IETFers are likely to participate in (much of the violence is related to gang/drug-related activities), I¹m sure the result is going to be even smallerŠ

---

From: Benjamin Damm <[email-masked]>
Date: Wed, 5 Apr 2017 17:58:47 +0000

On my last day of the IETF I visited the Museum of Science and Industry after the IETF sessions were done and before my flight from Chicago Midway airport. The journey from the museum to Chicago Midway went through the area described, which was evidenced by about 2 or 3km where every single home and business had all windows covered in plywood. Uncomfortable, but fortunately not fatal.

Benjamin Damm
O: 669-770-4000
E: [email-masked]  www.ssni.com

________________________________________
From: ietf <[email-masked]> on behalf of Andrew Allen <[email-masked]>
Sent: Wednesday, April 5, 2017 10:52 AM
To: Christer Holmberg; Carsten Bormann; mike stJohns
Cc: IETF
Subject: RE: IAOC requesting input on (potential) meeting cities

---

From: Nico Williams <[email-masked]>
Date: Wed, 5 Apr 2017 13:49:05 -0500

> Here, we're talking about uncertainty about whether or not Canadian

Uncertainty and a high rate of change without public comment/review
periods is actually concerning indeed.

It's nice to see this sort of thing:

http://thehill.com/policy/cybersecurity/327246-bipartisan-bill-would-end-warrantless-searches-of-digital-devices-at

though it's probably not going to pass right away, and it wouldn't
really protect non-U.S.-persons (since other reasons could still be used
to refuse entry).

I still think that we're not likely to see much impact on IETF
participants, but it's certainly fine to schedule fewer meetings in the
U.S. for the time being until we have more experience (possibly from
other conferences' sharing theirs).

Nico
--

---

From: Rich Kulawiec <[email-masked]>
Date: Mon, 10 Apr 2017 14:05:55 -0400

> https://www.wsj.com/articles/trump-administration-considers-far-reaching-steps-for-extreme-vetting-1491303602?mod=e2tw

The Guardian is now reporting that not only will passwords be demanded, but so
will financial information and that travelers may face ideological questioning:

	UK tourists to US may get asked to hand in passwords or be denied entry
	https://www.theguardian.com/us-news/2017/apr/09/uk-tourists-to-us-may-get-asked-to-hand-in-passwords-or-be-denied-entry

Further, as the secondary headline says:

	Although mitigation options exist, lawyers warn attempts to
	protect personal data may be seen as "probable cause" for searching

---rsk

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 10 Apr 2017 20:54:48 +0200

Another salient passage from the article:

“In the short to medium term, I think the answer is going to be avoiding all but absolutely essential travel to the United States,” Hall [a UK lawyer] added. “I’m aware of at least one conference on cyber security and ethical hacking which switched to Toronto at short notice because of these concerns.”

When I returned from Chicago, my wife (also a computer science professor) asked me: 
“So how was the final visit you will ever have made to the USA?”
She may have been more right than I thought at the time.

Grüße, Carsten

---

From: Dave Crocker <[email-masked]>
Date: Mon, 10 Apr 2017 15:01:42 -0700

> “In the short to medium term, I think the answer is going to be avoiding all but absolutely essential travel to the United States,” Hall [a UK lawyer] added. “I’m aware of at least one conference o…

That is, arguably looking like the safest, reasonable line of advice.

However for an organization like the IETF that seeks to meet in a 
variety of places around the globe, things could get even more 
challenging if there is a pattern of retaliatory actions by other 
countries, against visitors from the US.

(This is separate from the existing concern for long-term visitors to 
the US' question of leaving for a meeting and having problems returning 
to the US.)

It is fast looking as if the ability to sustain a large and very 
well-attended network of interconnected remote hubs might become a 
necessity rather than merely an appealing alternative...

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 11 Apr 2017 13:11:34 +0200

Can we get an answer from the IAOC to the questions below?

Otherwise there is any reason that can justify the lack of transparency in this?

Regards,
Jordi

-----Mensaje original-----
De: JORDI PALET MARTINEZ <[email-masked]>
Fecha: miércoles, 5 de abril de 2017, 10:26
Para: <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    

    
    My general position is:

    Regards,
    Jordi

    -----Mensaje original-----
    De: Eliot Lear <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: miércoles, 5 de abril de 2017, 6:39
    Para: Nico Williams <[email-masked]>, Yoav Nir <[email-masked]>
    CC: IETF <[email-masked]>, JORDI PALET MARTINEZ <[email-masked]>, Jared Mauch <[email-masked]>
    Asunto: Re: IAOC requesting input on (potential) meeting cities
    
        Nico,

        

        
        
        Eliot

---

From: John Leslie <[email-masked]>
Date: Tue, 11 Apr 2017 19:24:08 -0400

+1

   (and this will require some formal process for mike queuing at
the "interconnected remote hubs".)

   IMHO, what's lacking is _only_ the will to make it happen. ;^)

--
John Leslie <[email-masked]>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 11 Apr 2017 22:55:23 -0400

>    (and this will require some formal process for mike queuing at the
    > "interconnected remote hubs".)

Agreed.

Don't cancel SFO; just renegotiate it for much a smaller group of west-coast
"locals".   Maybe we can do this with minimal impact to the contract.

So we have 99, 100, and 101 to get all the mike queue and remote hubs working.

---

From: Loa Andersson <[email-masked]>
Date: Wed, 12 Apr 2017 12:12:14 +0800

Michael,

> So we have 99, 100, and 101 to get all the mike queue and remote hubs working.
It is hard to see the logic. I've just had the experience of "attending"
an IETF meeting remotely.

Let me first say that I very much appreciate the effort made by e.g. the
meetecho people. The experience of listening to a meeting on meetecho
and sitting in the room listening is very close. All the time until
someone that sits in the middle of the room don't care to go the mike
to make a comment, but just shout it out. When this happens you just
don't lose the comment, but you also lose much of the context for the
continued discussion.

Participate in the discussion remotely, is just not there yet. This is
not (primarily) technology, but queue management and queue discipline.

I know that this is getting better, but to work smoothly I think we need
the set uo e.g. ITU-T have in Geneva where every participant has his/her
own microphone and the management of the for remote participants and
people attending in the room would be the same.

It quite often happens (it has happened to me) that someone notify the
chairs that "there is someone wanting to say something on the meetecho",
only when that happens that particular discussion is already "taken to
the list".

But an IETF meeting is so much more than the moderate number of hours
you spend in meeting rooms, if you participate remotely you miss what
is probably the most important aspect of an IETF F2F - the 10-15
corridor meetings you have each day.

I'd say cancel SFO and move to place where we all have an equal chance
to attend, even if you have made a business trip to Iran or somewhere
else in the Middle East, and where we don't have to give out passwords
to e.g. laptops that may contain business critical information.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 12 Apr 2017 10:53:26 +0200

Are we going to have an answer on this NOW or next year?

Do we need to ask again and again every day?

I don’t feel the IETF members are being respected by the IAOC which the lack of response. Again, I may understand not disclosing the full details, but a simple answer with some of the info is needed.

If the IAOC don’t want to provide answers, it may be better that they step down and we look for more transparent people, the community is plenty of them.

Regards,
Jordi

-----Mensaje original-----
De: JORDI PALET MARTINEZ <[email-masked]>
Fecha: martes, 11 de abril de 2017, 13:11
Para: IETF Discussion <[email-masked]>, <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    

    Regards,
    Jordi

    -----Mensaje original-----
    De: JORDI PALET MARTINEZ <[email-masked]>
    Fecha: miércoles, 5 de abril de 2017, 10:26
    Para: <[email-masked]>
    Asunto: Re: IAOC requesting input on (potential) meeting cities

        

        
        My general position is:

        Regards,
        Jordi

        -----Mensaje original-----
        De: Eliot Lear <[email-masked]>
        Responder a: <[email-masked]>
        Fecha: miércoles, 5 de abril de 2017, 6:39
        Para: Nico Williams <[email-masked]>, Yoav Nir <[email-masked]>
        CC: IETF <[email-masked]>, JORDI PALET MARTINEZ <[email-masked]>, Jared Mauch <[email-masked]>
        Asunto: Re: IAOC requesting input on (potential) meeting cities
        
            Nico,

            

            
            
            Eliot

---

From: Ted Lemon <[email-masked]>
Date: Wed, 12 Apr 2017 09:26:14 -0400

> Do we need to ask again and again every day?

Has the IAOC met since the first time you asked?

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 12 Apr 2017 16:01:23 +0200

So, you mean they don’t use email?

Sounds surprising to me, despite for sure they had some time in Chicago to decide about what can be said to the community about the SF meeting. If they haven’t considered that, I guess we need an IAOC with more focus on what is the most relevant and important topic right now for the community.

By the way, it seems that they haven’t met anyway since August 2015, as they promised me to respond to one of my emails regarding some spam/email bouncing issues and the way we are managing so, and I’ve been waiting since them. Really nice and respectful way to support the community.

Regards,
Jordi

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Apr 2017 10:30:55 -0400

I've done remote meetings going back to the days of when we had to
make mbone work first. (it worked once!!!)
I've probably done a dozen or so remote meetings.

Loa Andersson <[email-masked]> wrote:
    > Let me first say that I very much appreciate the effort made by
    > e.g. the meetecho people. The experience of listening to a meeting on
    > meetecho and sitting in the room listening is very close. All the time
    > until someone that sits in the middle of the room don't care to go the
    > mike to make a comment, but just shout it out. When this happens you
    > just don't lose the comment, but you also lose much of the context for
    > the continued discussion.

Right, so this is why it's better for everyone to be remote.

    > chairs that "there is someone wanting to say something on the
    > meetecho", only when that happens that particular discussion is already
    > "taken to the list".

Yes, bad chair discipline.

    > corridor meetings you have each day.

I totally agree.

    > to e.g. laptops that may contain business critical information.

If we can do that, I agree. Lets do that.

If we can't outright cancel, but can renegotiate significantly, my suggestion
stands.  Move the meeting and make SFO a US left-coast remote hub.

---

From: joel jaeggli <[email-masked]>
Date: Wed, 12 Apr 2017 09:14:15 -0700

> By the way, it seems that they haven’t met anyway since August 2015, as they promised me to respond to one of my emails regarding some spam/email bouncing issues and the way we are managing so, and…
As a mailing list moderator who sees a fair amount of bounces, It is
notable that you mta routinly bounces messages to various lists for
reasons that from from the header appear to be disliking the sender. How
you run your MTAm since it is yours, is obviously up to you.

joel

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 12 Apr 2017 18:32:26 +0200

Hi Joel,

I’ve checked right now the stats of my MTA about *ietf.org and *irtf.org, and I don’t see any bounces. Actually, those are in a special white list since many years ago. So, if you have contradictory information it will be helpful to get that in private.

Yes, I use DNS-BL and spamassassin to score and eventually reject emails which score extremely high (not just bounce them), but this is not related to the way IETF mail servers were accepting and/or bouncing emails in 2015, and NOT RELATED AT ALL to the lack of response from the IAOC, especially if they promised to come back about that.

The point here is the lack of response, not the specific matter.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de joel jaeggli <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 12 de abril de 2017, 18:14
Para: JORDI PALET MARTINEZ <[email-masked]>, <[email-masked]>, IETF Discussion <[email-masked]>
Asunto: Re: IAOC requesting input on (potential) meeting cities

    joel

---

From: Fernando Gont <[email-masked]>
Date: Fri, 14 Apr 2017 17:04:12 +0100

> necessity rather than merely an appealing alternative...

FWIW, for the developing world, remote participation has possibly always
been a necessity.

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Dave Crocker <[email-masked]>
Date: Fri, 14 Apr 2017 09:11:49 -0700

> FWIW, for the developing world, remote participation has possibly always

Indeed.  I hadn't understood how extensive this had become until seeing:

    https://tools.ietf.org/html/draft-elkins-ietf-remote-hubs-00#section-3

However, there is a significant difference between their current mode of 
integration with the 'main' venue site, versus what we will need to have 
remote sites able to have nearly seamless participation in sessions.

Some of this is functional, such as a single queue for everyone wanting 
to speak, no matter where they are.  Some of this is much more robust 
performance and reliability (within obvious networking limitations.)

I suspect the easiest bit will be improved usability design, since the 
Meetecho folk tend to start with reasonable design and make improvements 
quickly, as experience is gained.  But yes, from some comments over the 
last two meetings, there's probably room for that improvement.

d/

---

From: Michal Krsek <[email-masked]>
Date: Fri, 14 Apr 2017 18:22:29 +0200

Hi,
> Some of this is functional, such as a single queue for everyone 
> wanting to speak, no matter where they are.  Some of this is much more 
> robust performance and reliability (within obvious networking 
> limitations.)
>
> Meetecho folk tend to start with reasonable design and make 
> improvements quickly, as experience is gained.  But yes, from some 
> comments over the last two meetings, there's probably room for that 
> improvement.

there are more universities across the globe who do remote lectures 
using "lecture hall to lecture hall" concept. I can ask CESNET "remote 
collaboration" team during Prague meeting to discuss stuff and avoid 
dead ends already found.

                     Michal

---

From: Fernando Gont <[email-masked]>
Date: Fri, 14 Apr 2017 17:32:16 +0100

>    https://tools.ietf.org/html/draft-elkins-ietf-remote-hubs-00#section-3

I haven't checked the I-D. However, no matter what it says, there's
remote participation with meet echo, without hubs. For instance, I
participated (and presented) remotely in two wgs during the Chicago
IETF, without "attending" any hub.

> remote sites able to have nearly seamless participation in sessions.

What I tried to note is that the situation for part of the participants
is such that remote participation is already necessary.

>From the pov of participants of North America or Europe, this *might* be
different and the current situation might be a game changer. But for us
in latin maerica, remote participation has always been a need, even if
we managed to attend one or more meetings (that's kind of like "the
exception to the rule").

> to speak, no matter where they are.

Agreed.

>  Some of this is much more robust

I must say that modulo issues with the network (which were probably
local on my side), the experience was great, and I must say that the
meetecho folks provided "online" help in a very timely manner (thanks!).

There's room for improvements.. but in some cases they seem to be more
about integration of local and remote participants, than with "bugs" in
the tools themselves. e.g., as you've correctly noted, it would be great
if there was a means for managing the mic queue, such that there's a
single queue, that includes remote participants.

Thanks!

Cheers,

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 14 Apr 2017 17:38:06 +0100

> Right, so this is why it's better for everyone to be remote.

Except that the IETF funding model requires attendees to pay their 
meeting fee.

- Stewart

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 14 Apr 2017 12:44:52 -0400

There is a lot of value in face-to-face interaction.
While we can not always get the interactions we want, virtual 
interaction is no replacement for face-to-face.  Being able to chat with 
people between meetings.  Having folks in the same place to set up 
high-interaction discussions.  And multiple additional benefits.

Yes, funding matters.  But in my view that is secondary to the actual 
benefit of the meetings.  Which is why I attend.

Yours,
Joel

---

From: Michal Krsek <[email-masked]>
Date: Fri, 14 Apr 2017 18:46:04 +0200

Hi Stewart,

> Except that the IETF funding model requires attendees to pay their 

I believe that the model can be changed, for example remote 
participation may require some small fee too. We need to make remote 
participation as productive as the local one and prepare financial models.

I believe if IETF has meeting to Sydney, at least some local communities 
in Europe or South America prepare their side meetings interconnected 
with the main meeting - and those side meeting organizers may need to 
pay a participation fee - this is just an idea.

             Michal

---

From: Michael Richardson <[email-masked]>
Date: Fri, 14 Apr 2017 14:20:01 -0400

> Except that the IETF funding model requires attendees to pay their

That's orthogonal, but a very good point.

And it's why turning SFO into a large "remote hub" (with a fee, and cookies) might make sense.

---

From: Christian Hopps <[email-masked]>
Date: Sat, 15 Apr 2017 05:52:26 -0400

Joel M. Halpern <[email-masked]> writes:

> While we can not always get the interactions we want, virtual interaction is no
> replacement for face-to-face.  Being able to chat with people between meetings.
> Having folks in the same place to set up high-interaction discussions.  And
> multiple additional benefits.
>
> Yes, funding matters.  But in my view that is secondary to the actual benefit of
> the meetings.  Which is why I attend.

+1

Whenever I read messages that advocate for switching to remote only
meetings, I have to wonder, are those people just not getting what I get
out of f2f meetings? I find the meetings invaluable for the reasons you
list above.

Thanks,
Chris.

---

From: Michael Richardson <[email-masked]>
Date: Sat, 15 Apr 2017 10:01:41 -0400

> meetings, I have to wonder, are those people just not getting what I
    > get out of f2f meetings? I find the meetings invaluable for the reasons
    > you list above.

Oh, I get it completely!
And there is a fax effect on f2f meetings.  This is why we are willing to put
up with the hassle of travel in the first place.

My argument is as follows:  if a significant number of people can not attend
in person due to visa, travel, etc. issues, then the value of the meeting
declines.   The people that we interact with a high bandwidth become the same
set of people who can get through.  Our views become myopic.

So in the case where we can not have everyone in the same place, then it
would be fairer to have "everyone" remote.

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 18 Apr 2017 23:22:54 +0200

> set of people who can get through.  Our views become myopic.

I will contend that there more easier ways to improve the value of the meeeting
than trying to figure out which city/country might score a bit better on the
visaa-trouble/pricing/convenience scale.

For example, there is a lot of death by powerpoint in meetings that pushes off
high bandwidth discussions ("oh, we're out of time"). AFAIK, most active work
on drafts during IETF meeting week happens outside of the WG meetings. I think that
a) was not the original plan, and b) i have not seen IAOC sending around questionaires
what/how to improve the quality of the meetings in this respect.

Cheers
    toerless

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Apr 2017 22:34:00 +0100

Hiya,

> what/how to improve the quality of the meetings in this respect.

I agree with the criticism, but not sure I agree about surveys being
the best next step.

One suggestion I made before I exited the IESG was that we consider
changing (or experimenting with) how the meeting week is structured,
for example, only having formal WG sessions in the afternoons, and
leaving the full mornings free for hackathons or informal meetings.
(Partly, that's because I hate getting out of bed early, which sadly
was not considered sufficient justification:-)

Anyway, I think it'd be good if the IESG/IAOC encouraged experiments
in such ways of organising ourselves when loads of us do end up in
one place for a week or so.

Cheers,
S.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Apr 2017 10:43:09 +1200

On 19/04/2017 09:34, Stephen Farrell wrote:
>> on drafts during IETF meeting week happens outside of the WG meetings.

It's true. And that is *exactly* the problem with meetings where a large fraction
or even a majority of attendees are remote. They are automatically excluded from
that informal active work. So, be careful what you wish for.

>> I think that

Exactly why it should be the other way round: meetings start at 09:00
sharp, and informal sessions after 14:00.  People are deadline driven...
 
> one place for a week or so.

Certainly, nudging everybody away from "I came to the IETF to make my
presentation" would be a Good Thing.

    Brian

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Apr 2017 23:52:51 +0100

> sharp, and informal sessions after 14:00.  People are deadline driven...

Actually, yes, you're right. Now that I don't need to be at so many
formal meetings, I would happily snooze corrected:-)

S.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 18 Apr 2017 16:08:46 -0700

Toerless,

Responding with this thread as it’s not about meeting locations.

> On Apr 18, 2017, at 2:34 PM, Stephen Farrell <[email-masked]> wrote:
> 
> Hiya,
> 

Regarding powerpoint, the problem isn't the use of slides, it the w.g., chairs not dealing with presenters who shows up with 20 slides for a 10 minutes slot, and the chairs not allocating enough time for a real discussions.

I think the meetings would be a lot more productive if a w.g. could have a meeting at the start of the week, work on the the issues during the week, send updates to the mailing list, have email and face to face discussions, and then have a second session at the end of the week to get consensus.  Clearly, impossible to schedule this with our current number of working groups, but I think it would make for a more productive week.

Bob

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 19 Apr 2017 01:44:50 +0200

> Regarding powerpoint, the problem isn't the use of slides, it the w.g., chairs not dealing with presenters who shows up with 20 slides for a 10 minutes slot, and the chairs not allocating enough ti…

Right.

So how about we experiment with allowing recordings of presentations to be added to
the meeting material upfronts. Aka: you can have a long detailled presentation, but not
during the WG time slot, but upload it eg: one week in before. Then during your 10 min slot
you can have only <= 4 slides.

Not sure what our current tooling would say about presentation recording files.
Whats the best current "standard" for that, eg: file format with slides and audio
that can be created by multiple apps...

I know what you're thinking "another idiot that thinks technology can improve the world".
Guilty.

> I think the meetings would be a lot more productive if a w.g. could have a meeting at the start of the week, work on the the issues during the week, send updates to the mailing list, have email and…

Thats what we try to do in anima where we luckily did get two meetings so far.
This is non-applicable to more WGs because the cost for more smaller rooms goes up,
or multitaskers could not multiplex enough work anymore ??

Toerless

-- 
---
[email-masked]

---

From: "Tobias Gondrom" <[email-masked]>
Date: Wed, 19 Apr 2017 01:53:38 +0200

<IAOC hat = "off">
Ps.: and I would like to add that at least in my personal understanding the content and format of the WG meetings is under the mandate of the WG chairs, the IESG and IETF chair. Same like the IETF meeting agenda is also not set by the IAOC. Of course the IAOC could (and I assume would be happy to) include questions from the IESG into the usual meeting survey, but I don't think it is the IAOC's place to discuss the content or how many Powerpoints are used within the WG meeting. IMHO that is for WG chairs and IESG to decide. And with these expectations, it is the IAOC task to arrange for an environment that is supporting to fulfill the expectations from the WG chairs, IETF and the IESG. 

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Wednesday, April 19, 2017 1:09 AM
To: Toerless Eckert <[email-masked]>
Cc: Michael Richardson <[email-masked]>; Bob Hinden <[email-masked]>; IETF <[email-masked]>
Subject: Re: Structure of IETF meeting weeks (was: Re: IAOC requesting input on (potential) meeting cities)

Toerless,

>> For example, there is a lot of death by powerpoint in meetings that 
>> pushes off high bandwidth discussions ("oh, we're out of time"). 
>> AFAIK, most active work on drafts during IETF meeting week happens 
>> outside of the WG meetings. I think that
>> a) was not the original plan, and b) i have not seen IAOC sending 
>> around questionaires what/how to improve the quality of the meetings in this respect.

Bob

---

From: 'Toerless Eckert' <[email-masked]>
Date: Wed, 19 Apr 2017 02:14:48 +0200

Which is why BC (thanks!) changed the subject of this sub-thread.

But re. IAOC responsibilities: Q: Is it true that the revenue from IETF
meetings does cross-fund other activities like RFC editor etc.. ?

If the goal is not to create the best meeting for the folks helping in producing documents,
but to attract the maximum number of attendees, then we should be clear about it.

I would guess 50% of participants are consuming only. These folks are certainly
well served through death by powerpoint rich dog & pony shows (just me guessing what
i like myself when i go to a WG where i just want to learn). If we focus on work
instead of education and we loose participants and therefore money... Oh well,
then the optimum IETF meeting structure seems to be difficult to define.

Toerless

On Wed, Apr 19, 2017 at 01:53:38AM +0200, Tobias Gondrom wrote:
> Responding with this thread as it???s not about meeting locations.
>

---

From: joel jaeggli <[email-masked]>
Date: Wed, 19 Apr 2017 07:53:56 -0700

> was not considered sufficient justification:-)
In my time I had tended to view the increased structural demands of side
meetings, bar bofs and what have you (isoc briefings, lunch trainings
and so on) that infill all the available time as detrimental to the
available supply of unstrctured time.

Time to meet and space work with your co-authors and collaborators is a
pretty important part of why IETF meetings have any value at all to me
as an individual contributor. You are at a rather signficant
disadvantage if you're remote, given that for me at least this is why
you come together.

---

From: Dave Crocker <[email-masked]>
Date: Wed, 19 Apr 2017 08:02:31 -0700

On 4/19/2017 7:53 AM, joel jaeggli wrote:
> as an individual contributor.

If there is serious interest in having more unstructured time available, 
remove less-productive wg sessions and reconsider carefully each of the 
ewstablished 'extra-curricular' time slots that are scheduled -- my own 
favorite target is Bits-n-Bites -- for possible elimination.

There is relatively little filtering on working group slot requests, and 
worse there's no real aid for working group chairs, to help them plan 
and manage sessions more effectively.

We periodically have public discussions about this latter issue and 
there are documents that say the right things. However chairs often have 
little experience with such 'project' management and few have -- or 
should be expected to have -- natural talents in that arena.

Professional project planning and management assistance for chairs, and 
careful vetting of wg progress as a filter for wg time requests, would 
produce fewer and shorter sessions and better use of time.

d/

---

From: Aaron Falk <[email-masked]>
Date: Wed, 19 Apr 2017 11:43:47 -0400

On 19 Apr 2017, at 11:02, Dave Crocker wrote:

> If there is serious interest in having more unstructured time 
> available, remove less-productive wg sessions and reconsider carefully 
> each of the ewstablished 'extra-curricular' time slots that are 
> scheduled -- my own favorite target is Bits-n-Bites -- for possible 
> elimination.
>

Not this is a significant problem.  I manage this by not going to 
meetings that have uninteresting agendas.  Same for Bits-n-Bytes.  C.f.  
George Michaelson’s 
[talk](http://snaggletooth.akam.ai/Chicago-videos/05-george-michaelson-8.mp4) 
about having IETF meetings in the hallways…

—aaron

---

From: Ted Lemon <[email-masked]>
Date: Wed, 19 Apr 2017 11:47:13 -0400

On Apr 19, 2017, at 11:43 AM, Aaron Falk <[email-masked]> wrote:
> Not this is a significant problem. I manage this by not going to meetings that have uninteresting agendas. Same for Bits-n-Bytes. C.f. George Michaelson’s talk <http://snaggletooth.akam.ai/Chicago-videos/05-george-michaelson-8.mp4> about having IETF meetings in the hallways…
> 
I don't think it's possible for us to say on behalf of the IETF which meetings are more and which are less beneficial, because that will be different for different people.   However, a structure that allows for collaborative work to be done when there are no meetings happening would have the benefit that not only you, but also the people you want to talk to, would potentially not be in meetings for extended periods of time.

Of course, the risk is that people will take these time periods for sightseeing rather than gathering.

---

From: Dave Crocker <[email-masked]>
Date: Wed, 19 Apr 2017 08:49:54 -0700

On 4/19/2017 8:43 AM, Aaron Falk wrote:
> George Michaelson’s talk 
> <http://snaggletooth.akam.ai/Chicago-videos/05-george-michaelson-8.mp4> 

The general form of this philosophy if full-blown libertarianism, 
placing all the responsibility for time management on the individual and 
no filters on scheduling any of the events.

Among other things, this model ignores the group effects of scheduling 
without regard for importance or utility.

d/

---

From: joel jaeggli <[email-masked]>
Date: Wed, 19 Apr 2017 09:16:03 -0700

On 4/19/17 08:02, Dave Crocker wrote:
> There is relatively little filtering on working group slot requests,
> and worse there's no real aid for working group chairs, to help them
> plan and manage sessions more effectively.
fwiw, slot requests are considerably earlier in the pipeline then agenda
formation.

As an AD I was relatively assiduous at working with my chairs to cancel
working group slots where the agenda/acitivity didn't justify meeting
(beyond the case of the empty agenda that's probably somewhat subjective).
> there are documents that say the right things. However chairs often
> have little experience with such 'project' management and few have --
> or should be expected to have -- natural talents in that arena.
>
> Professional project planning and management assistance for chairs,
> and careful vetting of wg progress as a filter for wg time requests,
> would produce fewer and shorter sessions and better use of time.
>
>
> d/

---

From: Dave Crocker <[email-masked]>
Date: Wed, 19 Apr 2017 09:22:48 -0700

> (beyond the case of the empty agenda that's probably somewhat subjective).

Thanks for checking off that script requirement in this sequence.  When 
discussing such management issues on the we always get one or more 
postings following the template "my management oversight did/does what 
you are suggesting".

As always, individual anecdotes have nothing to do with patterns of 
concern.  It's not that they are untrue, it's that they are a single 
datum, which never explains or resolves a pattern.

Note, for example Ted Lemon's view that meaningful filtering isn't 
possible due to individual differences in defining an applying criteria.

All of this, of course, provides continuing comfort in taking no action 
to manage the week's time better.

d/

---

From: Eliot Lear <[email-masked]>
Date: Wed, 19 Apr 2017 18:28:18 +0200

Hi Dave,

> datum, which never explains or resolves a pattern.

The converse is also true: are we quite certain that meeting time isn't
being used effectively, and how do we know? (I'm sure this is part of
the script as well, mind you.  I just don't recall what the next line is ;-)

Eliot

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Apr 2017 10:04:57 -0400

Toerless Eckert <[email-masked]> wrote:
    > pushes off high bandwidth discussions ("oh, we're out of time"). AFAIK,
    > most active work on drafts during IETF meeting week happens outside of

I am among those who pushes back on death by powerpoint, so I agree with you
strongly.  Presentations are very easily supported through completely remote
attendance.  Concurrent jabber back-channel discussion among the participants
can often bring out points that are sometimes lost in the foreground presentation.

{Maybe we should dispense with the meeting rooms, just wire the hotel rooms
for GbE, and all be on-site, but "remote".  Then the critical criteria for
which city to meet in is reduced to where the best beer can be had.  (And so
Prague wins?)}

But, on somewhat more serious note [note lack of :-) above], I have been told
the following features about the deathly powerpoints:
  1) provides a record of thoughts for later on.
  2) permits non-english speakers to understand what is being said by
     other non-english speakers!!!
  3) can be pushed through google-translate.
  4) can be read ahead of time by chairs and participants so that they
     can ask intelligent questions, and/or can allocate appropriate amounts
     of time.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Apr 2017 10:08:04 -0400

Bob Hinden <[email-masked]> wrote:
    > I think the meetings would be a lot more productive if a w.g. could
    > have a meeting at the start of the week, work on the the issues during
    > the week, send updates to the mailing list, have email and face to face
    > discussions, and then have a second session at the end of the week to
    > get consensus.  Clearly, impossible to schedule this with our current
    > number of working groups, but I think it would make for a more
    > productive week.

I have repeatedly suggested this to the IESG, most recently last week...

Every WG gets a 1hr slot Mon/Tue (Wed), with *FULL* consideration of
conflicts.  Then a second (1-2h) slot later in the week, with much more
minimal concern for conflicts.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 26 Apr 2017 10:17:13 -0400

Whether in the IETF or elsewhere, there is one aspect you do not mention 
that I find useful asa presenter, and one aspect that I find useful in 
well-done presentations as a participant.

1) As a Presenter, if I have managed to do my presentation right, it 
helps me get the important points covered in the right order.  yes, I 
usually remember them.  But not always.  And it helps in getting back on 
track after useful discussions of particular points.

2) As a participant, I find it very helpful if the slide tells me what 
the presenter considers the critical points for me to think about. 
(There are also the not uncommon cases where a diagram helps me 
understand the point the speaker is trying to make.)

Yours,
Joel

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Apr 2017 08:41:05 +1200

> understand the point the speaker is trying to make.)

Both points are true, and neither requires the slides to be read out loud.
Perhaps we could add to the standard question "Has everybody read the
draft?" a new question "Has everybody read the slides? Good, so we'll go
straight to the open issues."

Ideally, meetings should discuss either new work items or open issues on
unfinished work items.

   Brian