Subject: Call for Participation, Workshop on Internet naming systems

From: IAB Chair <[email-masked]>
Date: Thu, 22 Jun 2017 13:53:20 -0700

Call for Participation

IAB workshop on Explicit Internet Naming Systems

Internet namespaces relyon Internet connected systems sharing a common 
set of assumptions on the scope, method of resolution, and uniqueness of 
the names.    That set of assumption allowed the creation of URIs and 
other systems which presumed that you could authoritatively identify a 
service using an Internet name, a service port, and a set of 
locally-significant path elements.

There are now multiple challenges to maintaining that commonality of 
understanding.

  * Some naming systems wish to use URIs to identify both a service and
    the method of resolution used to map the name to a serving node.
      Because there is no common facility for varying the resolution
    method in the URI structure, those naming systems must either mint
    new URI schemes for each resolution service or infer the resolution
    method from a reserved name or pattern.  Both methods are currently
    difficult and costly, and the effort thus scales poorly.
  * Users’ intentions to refer to specific names are now often expressed
    in voice input, gestures, and other methods which must be
    interpreted before being put into practice.  The systems which carry
    on that interpretation often infer which intent a user is
    expressing, and thus what name is meant, by contextual elements.
      Those systems are linked to existing systems who have no access to
    that context and which may thus return results or create security
    expectations for an unintended name.

  * Unicode allows for both combining characters and composed characters
    when local language communities have different practices.  When
    these do not have a single normalization, context is required to
    determine which to produce or assume in resolution.  How can this
    context be maintained in Internet systems?

While any of these challenges could easily be the topic of a stand-alone 
effort, this workshop seeks to explore whether there is a common set of 
root problems in the explicitness of the resolution context, heuristic 
derivation of intent, or language matching. If so, it seeks to identify 
promising areas for the development of new, more explicit naming systems 
for the Internet.

We invite position papers on this topic to be submitted by July 28, 2017 
[email-masked] <mailto:[email-masked]>.    Decisions on accepted 
submissions will be made by August 11, 2017.

Proposed dates for the workshop are September 28th and 29th, 2017 and 
the proposed location is in the Pacific North West of North America. 
  Finalized logistics will be announced prior to the deadline for 
submissions.

Ted Hardie

for the IAB

---

From: Börje Ohlman <[email-masked]>
Date: Thu, 29 Jun 2017 21:48:56 +0200

Dear All,

The topic of this IAB workshop is very closely related to the research area Information-centric Networking (ICN) which is addresses by the IRTF ICNRG. We therefore think it is very unfortunate that the proposed dates coincide with the major conference in the ICN field, ACM ICN-2017 which takes place in Berlin, Germany September 26-28, 2017, http://conferences2.sigcomm.org/acm-icn/2017/
We are also planning an ICNRG interim meeting in Berlin September 29, 2017, as a followup to the conference, https://trac.ietf.org/trac/irtf/wiki/icnrg
We would therefore ask you to consider some alternative dates for this IAB workshop.

Best regards,
			Dirk, Dave & Börje (IRTF ICNRG co-chairs)

> On 22 Jun 2017, at 22:53, IAB Chair <[email-masked]> wrote:
> 
> Call for Participation
> Internet namespaces rely on Internet connected systems sharing a common set of assumptions on the scope, method of resolution, and uniqueness of the names.    That set of         assumption allowed the creation of URIs and other systems which presumed that you could authoritatively identify a service using an Internet name, a service port, and a set of locally-significant path elements.  
> There are now multiple challenges to maintaining that commonality of understanding.  
> Some naming systems wish to use URIs to identify both a service and the method of resolution used to map the name to a serving node.  Because there is no common facility for varying the resolution method in the URI structure, those naming systems must either mint new URI schemes for each resolution service or infer the resolution method from a reserved name or pattern.  Both methods are currently difficult and costly, and the effort thus scales poorly.
> Users’ intentions to refer to specific names are now often expressed in voice input, gestures, and other methods which must be interpreted before being put into practice.  The systems which carry on that interpretation often infer which intent a user is expressing, and thus what name is meant, by contextual elements.  Those systems are linked to existing systems who have no access to that context and which may thus return results or create security expectations for an unintended name.
> Unicode allows for both combining characters and composed characters when local language communities have different practices.  When these do not have a single normalization, context is required to determine which to produce or assume in resolution.  How can this context be maintained in Internet systems?
> While any of these challenges could easily be the topic of a stand-alone effort, this workshop seeks to explore whether there is a common set of root problems in the explicitness of the resolution context, heuristic derivation of intent, or language matching.   If so, it seeks to identify promising areas for the development of new, more explicit naming systems for the Internet.
> We invite position papers on this topic to be submitted by July 28, 2017 to [email-masked] <mailto:[email-masked]>.    Decisions on accepted submissions will be made by August 11, 2017.
> Proposed dates for the workshop are September 28th and 29th, 2017 and the proposed location is in the Pacific North West of North America.  Finalized logistics will be announced prior to the deadline for submissions.
> Ted Hardie
> for the IAB
>