Subject: Which is the right "RFC2119" Boilerplate?

From: Stewart Bryant <[email-masked]>
Date: Mon, 26 Jun 2017 16:14:05 +0100

I diligently included in a draft the updated "RFC2119" boilerplate 
which includes the reference to RFC8174.

Nits then complains that it does not like the RFC2119 text (which is cut 
and paste from a very recent RFC).

So which is right, nits or the RFC Editor?

=================

  == The document seems to lack the recommended RFC 2119 boilerplate, even if
      it appears to use RFC 2119 keywords -- however, there's a paragraph with
      a matching beginning. Boilerplate error?

      RFC 2119, paragraph 2:
         The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
         "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in
         this document are to be interpreted as described in RFC 2119.

      ... text found in draft:
         The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
         "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY",
................................................^
         and "OPTIONAL" in this document are to be interpreted as
         described in BCP 14 [RFC2119] [RFC8174] when, and only when, they
         appear in all capitals, as shown here.

      (The document does seem to have the reference to RFC 2119 which the
      ID-Checklist requires).

=================

- Stewart

---

From: Julian Reschke <[email-masked]>
Date: Mon, 26 Jun 2017 18:12:39 +0200

On 2017-06-26 17:14, Stewart Bryant wrote:
> ...

Seems that idnits needs an update.

Best regards, Julian

PS: would be good if it also accepted non-ASCII characters, at least 
optionally per opt-in...

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 26 Jun 2017 22:29:26 -0500

> Seems that idnits needs an update.

Seems that it does, indeed.

And perhaps Stewart should look at the Errata for RFC 2119, if he has not already.

-Ben

---

From: Gmail <[email-masked]>
Date: Tue, 27 Jun 2017 09:17:15 +0100

Sent from my iPad

> On 27 Jun 2017, at 04:29, Benjamin Kaduk <[email-masked]> wrote:
> 

It has been my long standing concern that for all practical purposes no one look at errata! Indeed I doubt that many will until the RFC Editor appends the verified errata to RFCs, or takes some similar approach with them.

In this case I looked at the errata and could not see anything, what did I miss?

At a different level maybe we need an xml tag that  includes the 2119 boilerplate?

Stewart

---

From: Barry Leiba <[email-masked]>
Date: Tue, 27 Jun 2017 10:45:39 +0200

Henrik is aware that idnits needs to be updated, and is working on
that.  He's been in contact with me about it.  (I actually thought
he'd already put the fix up, but I guess not.)

Barry

On Mon, Jun 26, 2017 at 5:14 PM, Stewart Bryant
<[email-masked]> wrote:
>  I diligently included in a draft the updated "RFC2119" boilerplate which
> includes the reference to RFC8174.
>
> Nits then complains that it does not like the RFC2119 text (which is cut and
> paste from a very recent RFC).
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 27 Jun 2017 20:16:00 -0500

> It has been my long standing concern that for all practical purposes no one look at errata! Indeed I doubt that many will until the RFC Editor appends the verified errata to RFCs, or takes some sim…

Part of why I always use the https://tools.ietf.org/html/rfcNNNN URLs is that
they do indicate when errata exist.

> In this case I looked at the errata and could not see anything, what did I miss?

Hmm, there are more errata here than I remembered; sorry for making you do
guesswork.  I was thinking of EID 499, which adds "NOT RECOMMENDED" to
the list in the boilerplate, and is the first difference that idnits was
complaining about, if I was reading its output correctly.

> At a different level maybe we need an xml tag that  includes the 2119 boilerplate?

Seems useful.

-Ben

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Jun 2017 09:01:46 +0200

> they do indicate when errata exist.

If the RFC Editor provided the errata in a machine readable format, we 
could optionally inline them in the future RFC HTML format.

P.o.c.: <https://www.greenbytes.de/tech/webdav/rfc7230.html#http.uri>

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Jun 2017 10:12:47 +0200

> he'd already put the fix up, but I guess not.)

Is accepting non-ASCII characters on the TODO list as well?

Best regards, Julian