Subject: Revamp of the www.ietf.org website

From: Russ Housley <[email-masked]>
Date: Sat, 15 Jul 2017 05:21:10 -0400

I am pleased to report that there has been a lot of progress on the project to revamp of the www.ietf.org website. The updated website will be the “front door” for the IETF, not only for for active IETF participants, but also provides an onramp for potential participants, and helps explain the work of the IETF to people who are not directly involved in developing Internet standards. The complete Scope of Work for the project is available at:

   https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf

Based on recent feedback, including the demo table at IETF 98, the initial design and features of the website have been improved in many ways. For example, in response to the feedback provided, there is now a single page that provides links to tools and resources commonly used by active IETF participants.

The project is now entering the next phase of the website development. The goal for this phase is to gather input more broadly. While there are still a few features to be implemented and some content still needs to be fine tuned, the general organization and the look-and-feel of the website has been implemented based on the initial research and input received to date. Of course, there will be some additional significant work before the site is ready for production; for example, before the website is final, we will implement methods to ensure that well-known URLs continue to work as expected. 

The site is now accessible at:

   https://beta.ietf.org

Please take a look. We will be tracking issues that need addressing at:

   https://github.com/ietf/www.ietf.org/issues

Feedback can also be emailed directly to: [email-masked]

At IETF 99 in Prague, there will be a table near meeting registration to demonstrate the beta website with “office hours" posted on a sign by the table. Please stop by if you are in Prague!  The office hours will be at least:

   Monday, July 17, 08:30-09:30 and 17:15-17:45

   Tuesday, July 18, 08:30-09:30

   Wednesday, July 19, 08:30-9:30

   Friday, July 12, 08:30-9:30

Thanks,
Russ Housley
IETF Website Revamp Project Manager

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 15 Jul 2017 12:08:00 +0200

I think a missing aspect of the web site, which should be prominent in both the home page and also the “contact” page, is all the social media.

I see there is a “share this page” at the right of the main picture, but in my opinion, is not clearly visible and is not enough (the logos of the social networks should be recognized without needing to pass over the share this page text, for example, and allow to open a new windows to each of the social networks when you click on them).

We need to make sure that we increase our participation in social networks, at least as a way to share news about IETF, contents announced in the announcements mailing list, etc.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Russ Housley <[email-masked]>
Responder a: <[email-masked]>
Fecha: sábado, 15 de julio de 2017, 11:21
Para: IETF <[email-masked]>
Asunto: Revamp of the www.ietf.org website

    

    
       https://beta.ietf.org

    

    

    
    Thanks,
    Russ Housley

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: [email-masked] (Martin Rex)
Date: Mon, 17 Jul 2017 17:31:47 +0200 (CEST)

JORDI PALET MARTINEZ wrote:
>
> I think a missing aspect of the web site, which should be prominent in
> both the home page and also the ?contact? page, is all the social media.
> 
> I see there is a ?share this page? at the right of the main picture,
> but in my opinion, is not clearly visible and is not enough
> (the logos of the social networks should be recognized without...

Cough, cough, WHAT???

Please get rid of the "social media" crap entirely.  I thought that
there was an IETF consensus that privcay is sensible and useful, and
strong privacy protections should be the default.

Facebook, Twitter and other "social media" crap is the far opposite of
strongy privacy, so none of this should be encouraged or promoted by
the IETF.

Comparing the bandwidth necessary to load the entire homepage,
I notice the following issues:

  https://www.ietf.org/    Total 188176 bytes (mainly by accident, it seems)
                           The visible page _contents_ are just fine,

    but the page designer goofed the photo in the meeting information,
    because the picture is transferred at size 640x427 taking up 150270 bytes,
    although it is actually being displayed at just 200x133, where a
    pre-scaled image would need just 17 KBytes.

    Even on my 5" Smartphone, the https://www.ietf.org/ loads just fine,
    I get the whole picture immediately, and can zoon into my area of interest.

  http://www.ietf.org/     Total 1195800 bytes (ouch ouch ouch ouch).

    is a completely botched page design. it needs multi-page scrolldown
    even on a big desktop screen, and finding stuff has become extremely
    difficult.

    This page even manages to provide *ZERO* intelligible information
    when loaded on my SmartPhone

    only shows the Welcome / Revamp <Learn More>  + Social Media Crap Buttons

    and when scrolling down the multiple pages of crap on my SmartPhone,
    very close to zero of the links _that_used_to_be_ on https://www.ietf.org
    pass by.

    Normally I close such bloated ad & nag screens immediately, though
    nowadays uBlock saves my health by ensuring that most of such crap
    does not even get displayed on any of my screens (desktop & mobile)
    in the first place.

    The huge background picture (IETF-Past-Meetings.max-4000x4000.jpg)
    with 763216 Bytes is just crazy.  Is this about a party/festival?
    A *HUGE* waste of network bandwidth and memory (RAM and on-disk cache)
    and writing text over photos also make reading difficult (poor contrast).

All in all, my personal summary for https://beta.ietf.org/

disgusting and extremly bloated, usless and highly confusing.

-Martin

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 17 Jul 2017 21:35:10 +0200

I disagree on this.

Having our announcements for last calls, RFC, STDs, major events, etc., in social media, helps to disseminate IETF activities, and we like or not social networks (I’m personally not a fan of them), is an obligation today. Many folks will not use a mailing list to know about “new” IETF work, but they will happily subscribe to a facebook or tweeter account.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Martin Rex <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 17 de julio de 2017, 17:32
Para: <[email-masked]>
CC: IETF <[email-masked]>
Asunto: Re: Revamp of the www.ietf.org website

    Cough, cough, WHAT???

    

    

    

    

    

    -Martin

---

From: Yoav Nir <[email-masked]>
Date: Mon, 17 Jul 2017 21:52:45 +0200

> On 17 Jul 2017, at 17:31, Martin Rex <[email-masked]> wrote:
> 

I disagree about social media. I believe those links are useless but mostly harmless. Really, nobody is going to get interested in Internet standardization because some friend shared the front page, but I don’t lose any privacy because somebody was sent a link to a public page.

I agree about the design.

Yoav

---

From: Ted Lemon <[email-masked]>
Date: Mon, 17 Jul 2017 22:10:49 +0200

The links are harmless if they aren't cross-site images.   The reason
people complain about "share" links for the various social media sites is
because they are usually embedded images loaded from those sites, which
allows those sites to track page views.

On Mon, Jul 17, 2017 at 9:52 PM, Yoav Nir <[email-masked]> wrote:

> I disagree about social media. I believe those links are useless but
> mostly harmless. Really, nobody is going to get interested in Internet
> standardization because some friend shared the front page, but I don’t lose
> any privacy because somebody was sent a link to a public page.
>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 17 Jul 2017 22:23:43 +0200

Well, the facebook and Twitter icons seem to be embedded in the web page, not loaded from the social media websites, so we don’t need to worry about that at least.

> On 17 Jul 2017, at 22:10, Ted Lemon <[email-masked]> wrote:
> 
> The links are harmless if they aren't cross-site images.   The reason people complain about "share" links for the various social media sites is because they are usually embedded images loaded from those sites, which allows those sites to track page views.
> 
> On Mon, Jul 17, 2017 at 9:52 PM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > On 17 Jul 2017, at 17:31, Martin Rex <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >  https://www.ietf.org/ <https://www.ietf.org/>    Total 188176 bytes (mainly by accident, it seems)
> >    Even on my 5" Smartphone, the https://www.ietf.org/ <https://www.ietf.org/> loads just fine,
> >  http://www.ietf.org/ <http://www.ietf.org/>     Total 1195800 bytes (ouch ouch ouch ouch).
> >
> >    very close to zero of the links _that_used_to_be_ on https://www.ietf.org <https://www.ietf.org/>
> >    pass by.
> >
> >
> > All in all, my personal summary for https://beta.ietf.org/ <https://beta.ietf.org/>
> >

---

From: John C Klensin <[email-masked]>
Date: Mon, 17 Jul 2017 17:08:50 -0400

Jordi,

Three observations.  

* Noting that assorted social media are, from time to time, more
or less effectively blocked in assorted countries, I think we
need to be sure that all IETF participants are able to get to
all IETF announcements and materials on an equal basis unless
the IETF itself is blocked.  If someone wants to reflect IETF
announcements into some social media or supplemental mailing
list, that is fine and has been going on for years, but
substantive announcements and discussions need to stay on IETF
mailing lists and be archived on IETF facilities or we end up
with big openness and transparency problems. 

* Precisely because the IETF has some very large vendors among
its supporters, our being able to continue to claim that we are
not biased toward those vendors and that our standards decisions
are not for sale, we need to be careful about not forcing people
to contribute to the bottom line of those companies in order to
participate.  We've been reasonably careful (much more careful
than some other SDOs) to not require someone to purchase some
particular work processing package or office suite to
participate.   I suggest that, if the IETF is going to get tied
up with Social Media, the system(s) used must be ones that do
not have business models involving  "user as product", targeted
advertising to users, permission to spam users, or requirements
that users give up significant privacy in order to join, get
feeds. or equ9ivalent.  Again, if someone wants to re-{post,
chirp, tweet, vomit, etc.} materials from an IETF mailing list,
I think we have always allowed thet.  However, IMO, the IETF
needs to be really careful about getting more directly involved.

* I share Martin's concern about page size, complexity, and load
times, especially if we are serious about trying to involve
people in developing countries and otherwise with with marginal
connections. 

best,
    john

--On Monday, July 17, 2017 21:35 +0200 JORDI PALET MARTINEZ
<[email-masked]> wrote:

> I disagree on this.
> 
> Having our announcements for last calls, RFC, STDs, major
> events, etc., in social media, helps to disseminate IETF
> activities, and we like or not social networks (I'm
> personally not a fan of them), is an obligation today. Many
> folks will not use a mailing list to know about "new" IETF
> work, but they will happily subscribe to a facebook or tweeter
> account.
> 
> Regards,
> Jordi
>  
> 
> De: ietf <[email-masked]> en nombre de Martin Rex
> <[email-masked]> Responder a: <[email-masked]>
>     > I think a missing aspect of the web site, which should
> be prominent in     > both the home page and also the
> ?contact? page, is all the social media.     > 
>     > I see there is a ?share this page? at the right of the
> main picture,     > but in my opinion, is not clearly visible
> and is not enough     > (the logos of the social networks
> should be recognized without...     
>     Cough, cough, WHAT???
>     
>     Please get rid of the "social media" crap entirely.  I
> thought that     there was an IETF consensus that privcay is
> sensible and useful, and     strong privacy protections should
> be the default.     
>     
>     Facebook, Twitter and other "social media" crap is the far
> opposite of     strongy privacy, so none of this should be
> encouraged or promoted by     the IETF.
>     
>     
>     
>     Comparing the bandwidth necessary to load the entire
> homepage,     I notice the following issues:
>     
>       https://www.ietf.org/    Total 188176 bytes (mainly by
> accident, it seems)                                The visible
> page _contents_ are just fine,     
>         but the page designer goofed the photo in the meeting
> information,         because the picture is transferred at
> size 640x427 taking up 150270 bytes,         although it is
> actually being displayed at just 200x133, where a
>         Even on my 5" Smartphone, the https://www.ietf.org/
> loads just fine,         I get the whole picture immediately,
> and can zoon into my area of interest.     
>     
>         is a completely botched page design. it needs
> multi-page scrolldown         even on a big desktop screen,
> and finding stuff has become extremely         difficult.
>     
>         This page even manages to provide *ZERO* intelligible
> information         when loaded on my SmartPhone
>     
>         and when scrolling down the multiple pages of crap on
> my SmartPhone,         very close to zero of the links
> _that_used_to_be_ on https://www.ietf.org         pass by.
>     
>     
>         Normally I close such bloated ad & nag screens
> immediately, though         nowadays uBlock saves my health by
> ensuring that most of such crap         does not even get
> displayed on any of my screens (desktop & mobile)         in
> the first place.
>     
>         The huge background picture
> (IETF-Past-Meetings.max-4000x4000.jpg)         with 763216
> Bytes is just crazy.  Is this about a party/festival?
> A *HUGE* waste of network bandwidth and memory (RAM and
> on-disk cache)         and writing text over photos also make
> reading difficult (poor contrast).     
>     
>     
> This electronic message contains information which may be
> privileged or confidential. The information is intended to be
> for the use of the individual(s) named above. If you are not
> the intended recipient be aware that any disclosure, copying,
> distribution or use of the contents of this information,
> including attached files, is prohibited.
> 
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Jul 2017 14:42:56 +1200

On 15/07/2017 21:21, Russ Housley wrote:
...
> For example, in response to the feedback provided, there is now a single page that provides links to tools and resources commonly used by active IETF participants.

Thank you for that. The only thing is, it's not really a single page; I had to hit Page Down 4 times to see everything. On the current page (https://www.ietf.org/content.html) there's all that on one screen. Surely there must be a way to present the content more compactly, when not on a tiny screen, and with a default font size.

I mention that here because I think it's a very general point. I've entered tickets for some details, and I would encourage everybody to do that, because inevitably there will be errors in content conversion, and the more eyes looking for them, the better.

Thanks
    Brian

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 18 Jul 2017 08:30:59 +0200

> On 17 Jul 2017, at 11:08 pm, John C Klensin <[email-masked]> wrote:
> 
> participate.

How does linking to social media accounts constitute "forcing people... in order to participate"?

No one is suggesting that one be required to tweet in order to register an objection.

>  We've been reasonably careful (much more careful
> feeds. or equ9ivalent.

You seem to be making a pretty big leap from "we don't require you to use proprietary tools in order to participate" (something that I very much agree with) to "we don't even want the *appearance* of (very) indirect endorsement of large companies." 

I could understand a complaint that (for example) Sina Weibo isn't in that list, but banning all such links seems to ignore how much of the Internet is used today -- which isn't such a good look for the body that purports to oversee the Internet's protocols.

> Again, if someone wants to re-{post,

I'm not sure why you bring that up; how would we stop it?

--
Mark Nottingham   https://www.mnot.net/

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 18 Jul 2017 10:17:33 +0200

To make it short. I disagree. I’m not asking to change the way IETF procedures work or anything similar.

I think we need to be in the “market” and that means that many operators (or other communities) that don’t have the time or the resources, or just they aren’t willing to subscribe to a mailing list, keep informed of our announcements, in an automated way, by means of as many social networks we can. Just informative, not as part of the “contribution” process, not replacing actual mail exploders, etc.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de John C Klensin <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 17 de julio de 2017, 23:09
Para: <[email-masked]>
CC: IETF <[email-masked]>
Asunto: Re: Revamp of the www.ietf.org website

    Jordi,
    
    Three observations.  

    
    
    best,
        john

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 18 Jul 2017 09:06:31 +0000

Everything I want on the existing IETF website in in a panel on the left. I rarely even look at the rightmost three quarters of the screen. That panel can be used to take me straight to where I want to go. The new site at it appears as linked below appears to have seriously reduced the usability of the site for people who know what they want and want to go straight to it. Put the panel back (or maybe it's always intended to be there, and this is just the main pane being considered) and I don't really mind what you do there (as long as it loads quickly).

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 3300 467500  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: 15 July 2017 10:21
To: IETF
Subject: Revamp of the www.ietf.org website

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

   https://beta.ietf.org

Thanks,
Russ Housley
IETF Website Revamp Project Manager
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Yoav Nir <[email-masked]>
Date: Tue, 18 Jul 2017 11:13:10 +0200

> On 18 Jul 2017, at 11:06, Dearlove, Christopher (UK) <[email-masked]> wrote:
> 
> Everything I want on the existing IETF website in in a panel on the left. I rarely even look at the rightmost three quarters of the screen.

That’s because you don’t come to meetings. Around meetings the right half of the screen becomes useful.

> That panel can be used to take me straight to where I want to go. The new site at it appears as linked below appears to have seriously reduced the usability of the site for people who know what they want and want to go straight to it. Put the panel back (or maybe it's always intended to be there, and this is just the main pane being considered) and I don't really mind what you do there (as long as it loads quickly).

The new site is focused not on the existing people active in the IETF. It’s focused on the general public.  The place where work gets done these days is datatracker.

Yoav

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 18 Jul 2017 09:23:51 +0000

I've been to many meetings (my first was IETF 55), though not very recently. And you can get to meetings off the leftmost panel too in about the same time.

> The new site is focused not on the existing people active in the IETF. It’s focused on the general public. 

Let the general public have three quarters of the page. Let us have the other quarter.

> The place where work gets done these days is datatracker.

And that's one of the places one can easily get to. But there are others too. But sorry, this is not the sort of response that's useful - don't care about people doing the work  (I'm just trying to finish my fifteenth RFC as an author) and what works for them. And "you don't come to meetings" as a dismissive comment isn't helpful either. In addition there's an inherent contradiction in your comments. If the page is intended for the general public, who really don't come to meetings, then the value you currently see in the right hand part of the page about meetings will also go. (And meetings are a place for work that isn't the datatracker.)

-----Original Message-----
From: Yoav Nir [mailto:[email-masked]] 
Sent: 18 July 2017 10:13
To: Dearlove, Christopher (UK)
Cc: Russ Housley; IETF
Subject: Re: Revamp of the www.ietf.org website

Yoav

---

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Jul 2017 11:39:23 +0200

The response is not "we don't care about the people who do the work."   It
is "people who do the work have a really awesome tool to use, the
datatracker, so they don't need IETF.org to address their use case."

So a better approach to this, if you feel the datatracker is not actually
addressing your needs, your efforts would be better aimed at working that
issue.   I think at the moment the side bar on datatracker has everything
that you need that was in the sidebar on ietf.org.

So can you say what is missing here?

On Tue, Jul 18, 2017 at 11:23 AM, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> I've been to many meetings (my first was IETF 55), though not very
> recently. And you can get to meetings off the leftmost panel too in about
> the same time.
>
> And that's one of the places one can easily get to. But there are others
> too. But sorry, this is not the sort of response that's useful - don't care
> about people doing the work  (I'm just trying to finish my fifteenth RFC as
> an author) and what works for them. And "you don't come to meetings" as a
> dismissive comment isn't helpful either. In addition there's an inherent
> contradiction in your comments. If the page is intended for the general
> public, who really don't come to meetings, then the value you currently see
> in the right hand part of the page about meetings will also go. (And
> meetings are a place for work that isn't the datatracker.)
>
> --
> Christopher Dearlove
> > Everything I want on the existing IETF website in in a panel on the
> left. I rarely even look at the rightmost three quarters of the screen.
>
> > That panel can be used to take me straight to where I want to go. The
> new site at it appears as linked below appears to have seriously reduced
> the usability of the site for people who know what they want and want to go
> straight to it. Put the panel back (or maybe it's always intended to be
> there, and this is just the main pane being considered) and I don't really
> mind what you do there (as long as it loads quickly).
>
> The new site is focused not on the existing people active in the IETF.
> It’s focused on the general public.  The place where work gets done these
> days is datatracker.
>
> Yoav
>
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 18 Jul 2017 05:47:27 -0400

Mark,

You (and Jordi) are at least partially right and I was probably
overreacting.  So let me back up a little bit (inline below).

--On Tuesday, July 18, 2017 08:30 +0200 Mark Nottingham
<[email-masked]> wrote:

>> its supporters, our being able to continue to claim that we
>> are not biased toward those vendors and that our standards
>> decisions are not for sale, we need to be careful about not
>> forcing people to contribute to the bottom line of those
>> companies in order to participate.
> 

With the qualification below, I can live with feeding
announcements through to selected social media sites in addition
maintaining the current announcement lists.  The main thing that
concerns me (as usual) is slippery slopes, in which those
announcements segue into discussions in non-IETF forums that we
are all expected to track.  That concern parallels my concern
about shifting mailing list discussions to github or various
wikis (and I know we might disagree about that).

> No one is suggesting that one be required to tweet in order to

My reaction was just because we've seen other cases in which we
use some other system to announce or log or keep information and
it promptly leads a a subset of the community pointing out how
much more convenient they find that tool relative to, e.g.,
mailing lists and calls to make that use normal or required.
If we are agreed, and will stay agreed, that we won't go there,
then I have no problem.

>> participate.   I suggest that, if the IETF is going to get
>> tied up with Social Media, the system(s) used must be ones
>> that do not have business models involving  "user as
>> product", targeted advertising to users, permission to spam
>> users, or requirements that users give up significant privacy
>> in order to join, get feeds. or equ9ivalent.
> 
> You seem to be making a pretty big leap from "we don't require
> you to use proprietary tools in order to participate"
> (something that I very much agree with) to "we don't even want
> the *appearance* of (very) indirect endorsement of large
> companies." 

See above.
 
> I could understand a complaint that (for example) Sina Weibo
> isn't in that list, but banning all such links seems to ignore
> how much of the Internet is used today -- which isn't such a
> good look for the body that purports to oversee the Internet's
> protocols.

That is the other issue.  Are we willing to feed
announcement-type information through to any plausible social
media site/ system for which there is a request?  If not, what
is the stopping rule or criterion?

>> chirp, tweet, vomit, etc.} materials from an IETF mailing
>> list, I think we have always allowed thet.  However, IMO, the
>> IETF needs to be really careful about getting more directly
>> involved.
> 

Because I think there actually is a big difference between the
IETF doing something and some individual or organization picking
something up and carrying it elsewhere.  If nothing else, there
is a question of how IPR rules, etc., would apply to reposted
materials given that they are not obviously IETF Contributions.
Again, if we confined this to announcements, I don't see a
problem either way.  

If we wanted to --and I think it would be a disasterously bad
idea -- we could at least partially stop it the same way other
SDOs do -- imposing copyright or proprietary information rules
on access to the information and insisting it not be further
distributed and then making it clear that we would enforce those
rules.  I hope we never go there or anywhere near it.

Again, apologies for the initial overreaction.

    best,
    john

---

From: Tim Chown <[email-masked]>
Date: Tue, 18 Jul 2017 11:02:29 +0100

> On 18 Jul 2017, at 03:42, Brian E Carpenter <[email-masked]> wrote:
> 

I sent a very similar response to the feedback address.  It’s really frustrating to have both the main page, and the Tools page, so inefficient that you have to scroll, and scroll, and scroll.

The front page seems to be in the same style as many web sites now, and is clearly aimed much more at non-IETF people than those doing work in the IETF.  I get that, but it’s then frustrating that the page for IETF participants is also inefficient.

Can we not make the Tools page (button top right) more like the current IETF home page, which pretty much renders in one screen, and has all the links that IETF participants would commonly want, including the next meeting panel.

> I mention that here because I think it's a very general point. I've entered tickets for some details, and I would encourage everybody to do that, because inevitably there will be errors in content…

The response I got was basically “come and discuss it in person in Prague” - the new site designer(s) are here, near the registration desk.  It’s not clear what feedback is sticking, or not :)

Tim

---

From: Rich Kulawiec <[email-masked]>
Date: Tue, 18 Jul 2017 06:34:33 -0400

On Mon, Jul 17, 2017 at 05:31:47PM +0200, Martin Rex wrote:
> Please get rid of the "social media" crap entirely.  

Strongly seconded.  The IETF should not be aiding and abetting
some of the world's worst security and privacy offenders; instead,
it should be scrupulously avoiding using or advocating any of
these mass surveillance/data acquisition operations, particularly
in light of RFC 7258.  Doubly so because some of them are
chronic, relentless spammers who use web bugs to conduct even
*more* surveillance and tracking.

> disgusting and extremly bloated, usless and highly confusing.

I really want to be less harsh than this, but unfortunately I also
strongly concur with this point: it's trendy-looking junk that's
horribly overrun by enormous, pointless graphics.  (I see zero reason
for just about *any* graphics [1]: there's no functional need
to accomodate illiterate people.)  This is a horribly-bloated
major downgrade from the current site and it should be discarded.

It looks to me like far more like an exercise in ego-gratifying graphic
design than an efficient, lightweight/minimal design intended for
professional use by technical personnel.  Economy and conciseness are
particularly important to those who don't have the privilege of cheap
high-speed connectivity and/or the wealth to pay the usurious rates
charged by some ISPs.  As the IETF seeks increased involvement and
diversity around the world (a goal I strongly support) I think it's
critical to ensure that the resources required for participation are
kept minimal.

I recommend rendering it in a text-only browser (e.g., w3m) to see what
the page would look like when stripped down to functional essentials.
There's about 5K of actual content plus 20K-ish of markup buried in about
1M of cruft: in other words, the page as it is right now is roughly 40X
the size it needs to be to get the job done.  That's ridiculous.

Let me also note that passing that page through validators like
tidy or the W3C validator yields quite a few errors and warnings.
No, it's not necessary to obsessively clobber every last one of
those, but a lot of them would just go away if all of the useless
cruft was stripped out.

---rsk

[1] Small, isolated, occasional exceptions -- let's say, a graph or
an illustration -- might be acceptable.  But they should probably be
thumbnails that link to the actual image, so that only those who are
interested in that particular item need to load it.

---

From: Tim Chown <[email-masked]>
Date: Tue, 18 Jul 2017 12:21:25 +0100

> On 18 Jul 2017, at 10:39, Ted Lemon <[email-masked]> wrote:
> 
> The response is not "we don't care about the people who do the work."   It is "people who do the work have a really awesome tool to use, the datatracker, so they don't need IETF.org to address their use case."
> 
> So a better approach to this, if you feel the datatracker is not actually addressing your needs, your efforts would be better aimed at working that issue.   I think at the moment the side bar on datatracker has everything that you need that was in the sidebar on ietf.org.
> 

The datatracker site sidebar is certainly useful. But a few things are presented rather differently, the meetings section being one notable example.

It seems the main IETF page/site is becoming the IETF corporate web site, and will look like many other such sites out there, and the IETF participant area is the “intranet”, in the form of the datatracker and tools pages, for which to do many things you need to sign in.  That’s OK, and understood, and participants will learn to go to the different site in place of the main IETF site, but the functionality isn’t quite the same, yet.

Tim

> On Tue, Jul 18, 2017 at 11:23 AM, Dearlove, Christopher (UK) <[email-masked]> wrote:

---

From: Yoav Nir <[email-masked]>
Date: Tue, 18 Jul 2017 13:38:48 +0200

> On 18 Jul 2017, at 11:23, Dearlove, Christopher (UK) <[email-masked]> wrote:
> 

Or let the general public have a whole page for themselves and another for all our tools.

> And that's one of the places one can easily get to. But there are others too. But sorry, this is not the sort of response that's useful - don't care about people doing the work  (I'm just trying to finish my fifteenth RFC as an author) and what works for them. And "you don't come to meetings" as a dismissive comment isn't helpful either.

It’s not dismissive. The current main page has all the important links for the *current* meeting: registration, agenda, wiki, remote participation, hackathon. That’s two layers deep going from the box on the left. If you’re not here, none but perhaps the agenda matter.  But since I am at the meeting, this works (to use a 90s term) as a portal.

> In addition there's an inherent contradiction in your comments. If the page is intended for the general public, who really don't come to meetings, then the value you currently see in the right hand part of the page about meetings will also go. (And meetings are a place for work that isn't the datatracker.)

The current site (www.ietf.org <http://www.ietf.org/>) is meant for us. The new page (current beta.ietf.org <http://beta.ietf.org/>) is IMO not. Most of the links on the left side of the current page are to pages under datatracker. This probably needs to be our new portal to the IETF.

Yoav

---

From: S Moonesamy <[email-masked]>
Date: Tue, 18 Jul 2017 05:02:03 -0700

Hi Rich,
>critical to ensure that the resources required for participation are

I did a quick test[1].  The current web site loads in under 5 seconds 
while the posh version takes around 20 seconds.  I would look at the 
revamp in terms of audience [2] and purpose.  From a UX perspective, 
it would be good if a participant could in one click from the "front 
door" reach the datatracker.

In a non-IETF meeting which I attended recently, there were comments 
about a topic being too technical [3].  Does the posh web site makes 
IETF content less technical and more accessible?

The posh web pages include support for Twitter summary cards [4] and 
Facebook OpenGraph tags [5].  Is that necessary?

Regards,
S. Moonesamy

1. Throttled to "slow ADSL".
2. That is covered in the SOW.
3. I would rate the level as well below the average level of an IETF 
technical discussion.
4. https://dev.twitter.com/cards/types/summary
5. https://developers.facebook.com/docs/sharing/overview

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 18 Jul 2017 10:12:03 -0700

Hi -

On 7/18/2017 2:39 AM, Ted Lemon wrote:
> The response is not "we don't care about the people who do the work."   
> It is "people who do the work have a really awesome tool to use, the 

Then why were *we* asked to even bother looking at this abomination?
If we are *not* the intended audience, and we're not in Prague to
meet with the culprits to elaborate on our feedback, what was the
point of this exercise?  Pfui.

Randy

---

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Jul 2017 19:55:44 +0200

You were asked to look at it on the theory that you are internet-literate
and might provide useful feedback.   Which several people seem to have
done!   :)

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 18 Jul 2017 11:21:54 -0700

Hi -

On 7/18/2017 10:55 AM, Ted Lemon wrote:
> You were asked to look at it on the theory that you are 
> internet-literate and might provide useful feedback.   Which several 
> people seem to have done!   :)

Since I'm apparently not internet-literate,
and since the feedback I provided (as requested)
to [email-masked] is apparently not deemed useful,
I'll stop wasting my time with this.

Randy

---

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Jul 2017 20:43:04 +0200

Why do you think it wasn't useful?

---

From: Eric C Rosen <[email-masked]>
Date: Tue, 18 Jul 2017 17:41:56 -0400

On 7/15/2017 5:21 AM, Russ Housley wrote:
> the general organization and the look-and-feel of the website has been implemented based on the initial research and input received to date.

I've been waiting to hear somone say "I love the new web page.  It makes 
it much easier to quickly find the information I need".

I'm still waiting.

What I'm actually hearing is "The new web page makes it more difficult 
to find the information I need.  I can't tell where the information is 
hidden, and I'm always scrolling through screens and screens of 
content-free graphics to find it.  And then it takes longer to access it".

But there's a good response to this: "The new web page isn't supposed to 
make it easier to find the information you need, use the datatracker for 
that.  The new web page is supposed to look pretty to folks who don't 
actually use it regularly."

Of course, this is almost always what happens when a useful web page is 
redesigned so as to be more modern.

Now if we could just replace all our RFCs with youtube videos ...

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Jul 2017 10:25:36 +1200

> redesigned so as to be more modern.

True. It happened once before, less badly, when the original home page
(approximately https://www.ietf.org/content.html) was replaced by
the current one, which I don't find useful. If https://beta.ietf.org/links/
can't be made to fit in a single screen, I'll be making my own private
equivalent of https://www.ietf.org/content.html anyway. We shouldn't
be afraid of having our web site look geeky.

Alternatively, it would be fine if the sidebar on the tracker
included everything currently covered by the sidebar on www.ietf.org.

> Now if we could just replace all our RFCs with youtube videos ...

Why, when everything worth saying can be said in a tweet?

       Brian

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jul 2017 09:16:42 -0400

FWIW, +1

Suggestion: If the IESG is convinced that we need a page at
www.ietf.org that is designed for prettiness and attraction for
newcomers and those who are just browsing, would it be possible
to have an easily-remembered URL (and link from that home page
for those who forget) that essentially reflects the information
in the current sidebar plus maybe the "news" and "next meeting"
and "related web pages" panels, with zero images and no
animation or automation?   For those of us who use IETF web
pages only to get work done, attractiveness is often measured in
ease of navigation and minimizing the number of clicks needed to
reach something, goals that may be incompatible with "pretty",
"clever", or "attractive to those who are just browsing".

    john

--On Wednesday, July 19, 2017 10:25 +1200 Brian E Carpenter
<[email-masked]> wrote:

>>> the general organization and the look-and-feel of the
>>> website has been implemented based on the initial research
>>> and input received to date.
>> 
>> I've been waiting to hear somone say "I love the new web
>> page.  It makes  it much easier to quickly find the
>> information I need".
>> 
>> I'm still waiting.
>> 
>> What I'm actually hearing is "The new web page makes it more
>> difficult  to find the information I need.  I can't tell
>> where the information is  hidden, and I'm always scrolling
>> through screens and screens of  content-free graphics to find
>> it.  And then it takes longer to access it".
>> 
>> But there's a good response to this: "The new web page isn't
>> supposed to  make it easier to find the information you need,
>> use the datatracker for  that.  The new web page is supposed
>> to look pretty to folks who don't  actually use it regularly."
>> 
>> Of course, this is almost always what happens when a useful
>> web page is  redesigned so as to be more modern.
> 
> True. It happened once before, less badly, when the original
> home page (approximately https://www.ietf.org/content.html)
> was replaced by the current one, which I don't find useful. If
> https://beta.ietf.org/links/ can't be made to fit in a single
> screen, I'll be making my own private equivalent of
> https://www.ietf.org/content.html anyway. We shouldn't be
> afraid of having our web site look geeky.
>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 19 Jul 2017 14:03:16 +0000

On 7/18/17, 5:41 PM, "ietf on behalf of Eric C Rosen" <[email-masked] on behalf of [email-masked]> wrote:

    
    I'm still waiting.

If datatracker is to be the new “real” ietf.org page, then there needs to be a QUICK step to get to it from beta.ietf.org. Right now, a link to it is found only under the Tools menu, but I had to search for it. And on my iPhone, I could NOT FIND the Tools menu, and subsequently couldn’t get to the datatracker from it.

I also did not spot a link to tools.ietf.org. I figured that would be under the Tools menu as well.

The datatracker.ietf.org page would need some rework to be as useful as the current www.ietf.org page. And perhaps a diet to eliminate some scrolling to find the info?

The IETF 99 Prague page linked to from beta.ietf.org SEEMS like it has all of the information currently found on www.ietf.org for the current meeting. But I had to click on a gazillion down arrows to open up each to verify that statement. There doesn’t seem to be an easy to open up ALL of the submenus to get the equivalent “meeting at a glance” jump page that we currently have.

	Tony Hansen

---

From: "Paul Hoffman" <[email-masked]>
Date: Wed, 19 Jul 2017 16:21:07 +0200

> "clever", or "attractive to those who are just browsing".

This seems like a good, serious proposal. https://www.ietf.org/basic or 
something like that would likely greatly help some of us who often have 
slow connections.

--Paul Hoffman

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 21 Jul 2017 04:32:16 -0400

Dear colleagues,

> The new site is focused not on the existing people active in the IETF. It’s focused on the general public.  The place where work gets done these days is datatracker.

I have had a look at the beta site, and it seems to me that we have at
least three possible audiences:

    1.  People who wonder what an IETF is and how it might be useful
    to them.  That actually is an important function of a website, and
    despite the arguments about how the IETF isn't about marketing
    organization (and the xkcd observations about university websites)
    we cannot ignore this function.  To some extent, we are competing
    with other ways of developing the Internet -- "living standards",
    code as standard, multilateral standards bodies, &c -- and if we
    think our way is good for some cases we do in fact need to market
    that.  I think the beta site is obviously better at that than our
    current site, which appears to be designed with a MEMBERS ONLY
    sign on the front.  We are the hardest club to join given that we
    don't have membership. I think the beta site is trying to make
    that burden a little less, and I believe it is a good thing.

    2.  People who already are familiar with the IETF and are working
    here.  The beta site says it's supposed to be the "new front
    door".  I don't know about all of you, but in my own house I also
    know how to enter by the other doors.  Maybe we just need to use a
    different entrance?

    3.  People whose connectivity makes the more graphically intense
    and somewhat larger site less useful.  I think it would be useful
    to analyse the extent to which this is a real problem, and whether
    the trade-off is adequate for the particular use case we have in
    mind.  After all, loading this (still not huge) web page is hardly
    the most bandwidth-intensive thing a plausible IETF participant is
    likely to do.  Moreover, it's not clear whether the problem in
    this case is slow backhaul links or slow local/last-mile links; if
    it's the latter, more IXes (and CDNs) are likely good enough
    mitigations.  This seems like an issue that could use some
    empirical data, but I am not sure how to get it.  Perhaps the
    participants of GAIA would hae some ideas.

I appreciate the effort to make these changes in public with lots of
consultation: I know how much harder it is to run a project this way,
but I think it's a good sign that the tools are as usual being
developed this way.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Sat, 22 Jul 2017 16:09:13 -0400

Andrew,

I very much agree on categories.  My thought had been that, if
we construct an easily-accessed and easily-remembered page for
the second group with a minimum of decoration, images, etc., it
would largely deal with the third issue as a side effect, but
that is probably worth more consideration.

And yes to the effort and consultation -- much appreciated.

   john

--On Friday, July 21, 2017 04:32 -0400 Andrew Sullivan
<[email-masked]> wrote:

>> The new site is focused not on the existing people active in
>> the IETF. It's focused on the general public.  The place
>> where work gets done these days is datatracker.
>> 
> 
> I have had a look at the beta site, and it seems to me that we
> have at least three possible audiences:
> 
>     1.  People who wonder what an IETF is and how it might be
> useful     to them.  That actually is an important function of
> a website, and     despite the arguments about how the IETF
> isn't about marketing     organization (and the xkcd
> observations about university websites)     we cannot ignore
> this function.  To some extent, we are competing     with
> other ways of developing the Internet -- "living standards",
> code as standard, multilateral standards bodies, &c -- and if
> we     think our way is good for some cases we do in fact need
> to market     that.  I think the beta site is obviously better
> at that than our     current site, which appears to be
> designed with a MEMBERS ONLY     sign on the front.  We are
> the hardest club to join given that we     don't have
> membership. I think the beta site is trying to make     that
> burden a little less, and I believe it is a good thing.
> 
>     2.  People who already are familiar with the IETF and are
> working     here.  The beta site says it's supposed to be the
> "new front     door".  I don't know about all of you, but in
> my own house I also     know how to enter by the other doors.
> Maybe we just need to use a     different entrance?
> 
>     3.  People whose connectivity makes the more graphically
> intense     and somewhat larger site less useful.  I think it
> would be useful     to analyse the extent to which this is a
> real problem, and whether     the trade-off is adequate for
> the particular use case we have in     mind.  After all,
> loading this (still not huge) web page is hardly     the most
> bandwidth-intensive thing a plausible IETF participant is
>     this case is slow backhaul links or slow local/last-mile
> links; if     it's the latter, more IXes (and CDNs) are likely
> good enough     mitigations.  This seems like an issue that
> could use some     empirical data, but I am not sure how to
> get it.  Perhaps the     participants of GAIA would hae some
> ideas.
> 
> I appreciate the effort to make these changes in public with
> lots of consultation: I know how much harder it is to run a
> project this way, but I think it's a good sign that the tools
> are as usual being developed this way.
> 
> Best regards,
> 
> A

---

From: John C Klensin <[email-masked]>
Date: Sat, 22 Jul 2017 16:45:23 -0400

--On Tuesday, July 18, 2017 11:02 +0100 Tim Chown
<[email-masked]> wrote:

>> I mention that here because I think it's a very general
>> point. I've entered tickets for some details, and I would
>> encourage everybody to do that, because inevitably there will
>> be errors in content conversion, and the more eyes looking
>> for them, the better.
> 
> The response I got was basically "come and discuss it in
> person in Prague" - the new site designer(s) are here, near
> the registration desk.  It's not clear what feedback is
> sticking, or not :)

Especially for a web page that has to be used by the entire
participant community to do work (independent of whatever other
functions it serves), I am increasingly convinced that we need a
front/home page that is basically and index, which nothing but
(maybe slightly annotated) links.  If we need to have a
marketing- or PR-oriented page (I can see the argument for it
but am not sure I'm convinced), the participant-oriented page
might be at partcipant.ietf.org or even useful.ietf.org, either
of which would pass an "easy to remember" test.

Drawing comments in some other notes together, I think the
criteria for that page should be ability to be rendered in a
single panel on a normal screen (i.e., no scrolling required)
and should strive for zero images and dynamic content or a least
rendering well in a text-only browser.

I don't think the current Datatracker page does that job.
Because it is basically a search page with a sidebar, its use of
screen real estate is very poor for a index-like or
dispatching-like home page (including requiring scrolling) and
when, for example, I'm looking for the membership list and
contact info for the IESG, unlike the sidebar on the current
IETF home page, I have to know to scroll to the bottom, find the
"IESG" link, and then use it to pull up a page than then permits
me to get the the Member list.  IMO, that is a scrolling effort
and several clicks too many.

That is not a criticism of the Datatracker page as such -- I
think it is rather good for its purpose -- only the notion that,
as it currently stands, it is a good approximation to an ideal
home page for getting work done.

Finally, our usual assumption is that the participant list for
the IETF is the union of the number of people who attend
meetings, plus many of most of those on the IETF discussion
list, plus many or most of those on all of the active WG and
former WG lists.  That is a very large number compared to the
set of people who happen to be present in person at give f2f
IETF meeting.  My guess is that even the number of people who,
in the course of a year, contribute to at least one WG mailing
list, review at least one document, or author an I-D is many
times larger than physical meeting attendance.    If I am right
about that, if "come and discuss it in person in Prague" was
actually a response, it is fairly insulting to most of the
community as well as a violation of the spirit of our "decide on
the mailing list" rules.  So I hope that Tim misinterpreted the
response he got and that, whoever the "new site designer(s)"
are, they are following comments on this list very carefully.

    john

---

From: Ray Pelletier <[email-masked]>
Date: Wed, 26 Jul 2017 07:22:13 +0200

+ 1

Ray

> On Jul 21, 2017, at 10:32 AM, Andrew Sullivan <[email-masked]> wrote:
> 
> Dear colleagues,
>

---

From: Jari Arkko <[email-masked]>
Date: Tue, 25 Jul 2017 23:51:39 -0700

FWIW, I also agree with Andrew.

But I had an added comment about the front or other entrances.
If I look at the current IETF website, I don’t think it would be too
hard for the “front door” to be an entrance for everybody. Most
of us don’t need an explanation of what the IETF is or the like,
but even on the current website, there aren’t too many things
that I normally click. I click on the “next meeting”, “next meeting’s
agenda” a *lot*. I don’t remember if the datatracker is hiding
somewhere on the current website, but I certainly go to the
datatracker a lot. I also go to the WG list quite often, to
look up something that I don’t remember from an unfamiliar
area etc. I click on the blog now and then. But that’s about
it.

If those things were one click from the new web site…
and the rest would be neatly organised, that would certainly
do it for me. I don’t see how adding those to the otherwise
more “information about the IETF” website would be hard.

For added bonus, maybe the most recent last
call / most recent blog article / most recent call for
hotel reservations opening or the like were to be also
displayed, the front door would give me an added
benefit of possibly stumbling on information that I
needed.

Jari

---

From: Tim Chown <[email-masked]>
Date: Wed, 26 Jul 2017 10:22:27 +0100

Hi,

> On 26 Jul 2017, at 07:51, Jari Arkko <[email-masked]> wrote:
> 

Mentally I have already retreated from beta.ietf.org as a useful page for a participant. But I can accept that; the current page is unwelcoming or an “outsider”, and we could use a better public “face”.

> more “information about the IETF” website would be hard.

Well, if it’s “one click away”, participants will just bookmark or go directly to that page, and not www.ietf.org. I know I will.  Just like I sometimes also go directly to the datatracker. 

> benefit of possibly stumbling on information that I

Put all that on a one screen, participant oriented “index” page that we can go directly to.  Leave www.ietf.org to be the public shop window.

Tim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 26 Jul 2017 11:40:30 +0200

I think we need to have a “nice” and attractive “public face” for anyone NOT being an actual participant, and in general I like the beta (adding the social networks thing that I already mention in a previous email).

I also agree that most of the frequent “participants/contributors”, often go directly to the page they want (bookmarks or just start typing “datatra …” in the URL space, or go to the home and click “next meeting” or whatever.

I think there are several ways to do that, for example (just to mention a few) and they can be combined easily:

1) The beta “tools” section can have more “direct” links (may be instead of Tools rename it to “frequent sections” or something similar) to actual subdomains such as datatracker, blog, rfc-editor, email archive, iesg, iab, irtf, iaoc, ipr, liaisons, secretariat, etc.
2) Have a “customize” section so you can choose what is your “default” entry page.
3) Have a “customize” section so you can choose your “preferred” home page and default “top” links / menu.
4) Use cookies or something else to remember what was your last visit.
5) etc

It should not be a big issue for an existing participant to “adjust” the first time the beta is moved to production, to adjust what he prefers to get, but definitively our front door should be nice for anyone contacting IETF for a first time or non-frequently visitors.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Tim Chown <[email-masked]>
Responder a: <[email-masked]>
Fecha: miércoles, 26 de julio de 2017, 11:24
Para: Arkko Jari <[email-masked]>
CC: IETF Discussion <[email-masked]>
Asunto: Re: Revamp of the www.ietf.org website

    Hi,

    

    
    
    Tim

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 26 Jul 2017 12:30:55 +0200 (CEST)

>   https://github.com/ietf/www.ietf.org/issues

The new page follows the tragic becoming-common-everywhere of using font 
size that is way too big. In Chrome on MacOS the old page looks great, 
font size is perfect, lots of information.

The new one, I need to use my CSS plugin to bring it down to 75% or less 
before it even starts to become remotely useful.

If I go to for instance:

https://beta.ietf.org/about/who/

There is a useful "about" list of articles to the right. If I click on 
some of those, I get a similar page with the same list of articles, some 
other items in that list doesn't contain this.

Same thing at https://beta.ietf.org/standards/rfcs/

I also chime in with earlier comments about scrolling and lack of 
information. If the new IETF page is going to be this devoid of 
information collected in a single place, where is my "expert mode" button? 
The left list of things on the old web page was excellent.

The current page seems to be all about introducing new people to the IETF. 
This is great, but I know a lot of this already, and I want a good, dense, 
overview page of everything available.

If I go to https://beta.ietf.org/how/meetings/upcoming/99/ this seems to 
be close to what I need, but I just HATE the extra step of clicking on 
"Agendas and Meeting materials" to have a submeny float out (slowly) and 
then I have to click again. I don't like text moving around, especially 
not scrolling around, in its own little thingies.

Old work flow:

Go to http://ietf.org. Press meeting link. Press agenda (html). Boom, 
done.

New work flow:

Go to http://beta.ietf.org (wait noticably longer for page to load). Press 
tools. Watch popup. Press "IETF99 Prague". Wait. Scroll. Press "Agendas 
and Meeting materials". Watch animation. Press "Agenda (HTML)". Done.

So while the new web page looks nicer and probably is a lot less daunting 
to newcomers, it's a considerably worse tool to actually get to 
information you need.

So if this is going to become the new web page, can I please at least have 
a densely packed "expert mode" page with all the links densly packed, just 
like the old page. Please?

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Wed, 26 Jul 2017 10:15:22 -0400

On Jul 26, 2017, at 6:30 AM, Mikael Abrahamsson <[email-masked]> wrote:
> The new page follows the tragic becoming-common-everywhere of using font size that is way too big. In Chrome on MacOS the old page looks great, font size is perfect, lots of information.

You are fortunate to have such good eyesight.   For my eyes, the new fonts are a huge improvement.   The fonts on the old IETF web site are legible, but really too small, and the information density is too high, so that it requires a close look to sort out what one needs from among the things one doesn't.

The goal of a web page isn't to put as much information as possible on one page.   It's to communicate effectively.   I don't claim to be an expert on what it means to communicate effectively, but in fact looking at the main page, the only real problem I see is that the responsive design allows the main image to be too large, and this produces the "have to scroll" effect that people have complained about.   That image is way too big for the page.   It sort of works on a 1080p display, because there's room for all the content despite the huge image, but it would be better to reduce it to about half its presented height in all the other responsive sizes (no more than a quarter of the screen height).

On the other hand, the tools pulldown has the exact three things I am most interested in when I personally go to the IETF web site: a link to the datatracker, a link to the current meeting, and, well, okay, I never search the mailing list archive that way, but it would be great if that were swapped out for a link to the meeting agenda for the current meeting.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 26 Jul 2017 17:24:25 +0200 (CEST)

On Wed, 26 Jul 2017, Ted Lemon wrote:

> You are fortunate to have such good eyesight.  For my eyes, the new 
> fonts are a huge improvement.  The fonts on the old IETF web site are 
> legible, but really too small, and the information density is too high, 
> so that it requires a close look to sort out what one needs from among 
> the things one doesn't.

Yes, I have good eyesight. I set my default appearence that is comfortable 
for me. I expect all applications and web sites to follow that. If I had 
worse eye sight, I would set the default so the text was rendered in 
larger font size on my screen.

Screenshot from my screen:

http://imgur.com/a/iJCLV

This is with the CSS scaling turned off, so it's rendered with default 
font size. The old IETF website is approximately in between the font size 
of the "about mac" window text, and the MacOS menu text. The new 
beta.ietf.org web site is significantly larger in font size and row 
spacing compared to the other windows.

It's not the work of web site developers to cater for people with bad 
eyesight, it's the job of operating system developers to give people the 
possibility to set default settings that fit each and every one, and then 
it's up to the browser to give the user the default font size that user 
has chosen. If some web sites start to increase the web site "because 
there might be some people with bad eyesight out there who have chosen 
small font sizes in their OS", this is going to be a race with increasing 
font sizes in absurdum.

---

From: [email-masked] (Martin Rex)
Date: Wed, 26 Jul 2017 23:25:51 +0200 (CEST)

> Screenshot from my screen:

Here is what the sites look like on my mobile phone:

https://beta.ietf.org  ->  http://imgur.com/a/gFJLe

https://www.ietf.org   ->  http://imgur.com/a/iguEO

For me, the https://beta.ietf.org, besides wasting a considerable
amount of my monthly data volume, is pretty much completely useless,
whereas the old site comes up quickly, in an extremely familiar fashion,
and I can easily and quickly zoom into my area of interest.

The https://beta.ietf.org is like a toddler coming into a big
ballroom in search for his parents.  He can not see over tables,
so he has to run through the entire room around every table to
check all the chairs for his parents.

As an (6"4) adult, I'm more used to looking into a room,
glancing over all tables without _having_ to run through
the room.   The https://beta.ietf.org is forcing the
poor toddlers perspective of the world on me, forces
me to run through every passage and corner of a poorly
readable graphical maze, having to pick up every stone
and look below for what I'm interested in, making me
wait for the slowly loading page, wasting my mobile
internet volume, and wasting my time trying to discover
what is new or (ir)relevant.

:-(((((((

-Martin

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Jul 2017 10:32:56 +1200

On 26/07/2017 21:22, Tim Chown wrote:
...
> Put all that on a one screen, participant oriented “index” page that we can go directly to.  Leave www.ietf.org to be the public shop window.

I seem to see a lot of people saying roughly the same thing: we need
an index page for active participants which is
  - static content only
  - very low on graphics
  - a typical font size (legible but not enormous)
  - displays in several columns on a laptop/desktop screen
  - displays in one column on a smartphone**
  - has links to the stuff we use daily

** which possiibly means making two versions.

And for me the exemplar is still https://www.ietf.org/content.html,
updated with links to the new site.

    Brian

---

From: George Michaelson <[email-masked]>
Date: Thu, 27 Jul 2017 08:59:47 +1000

I think there is a stylistic cliff in website design. One kind, the
older kind, uses a simple model of HTML which could be made more
overtly structured (use of id= tags) to make machine processing
simpler, but is in design and intent, a single load.
 * Its highly cacheable.
 * It makes little or no use of client-side drivers to direct
point-and-click because embedded URLs are literals, not
machine-generated on the fly.
 * It trivially meets vision impaired or voice-translation goals.
 * It trivially can be translated

It has one major drawback: a lot of people think its ugly.

The newer kind, the responsive reactive javascript kind, is far
simpler to navigate for anyone used to that template driven design, it
has a number of behaviours which in CHI terms a lot of people are
clued into and will react well to. It looks nice.

I think we've got ourselves caught on a cusp. The older kind suits
people who want to use the IETF web to conduct work, are in the
system, and have little concern for aesthetics. I think most of this
is met by the datatracker and like sites. That said, its a pain to
have to move to a different URL to get this kind of outcome for anyone
who is using the current site.

The new one is better suited to a world where we're trying to sell
something, or convince somebody. I can't help feeling this is one of
those 'what were we fighting for?' moments, if we feel we have to
adopt an aesthetic, distinct from operate a portal in our own
interest.

Do I think its possible we could use more modern responsive, js
enabled, template driven methods to update a website we run for our
own interest? I am not sure. I note that the things which I actually
USE on a day-to-day level like gitlabs, github, have really low levels
of use of this kind of feature to conduct work, and mostly it relates
to user-administration or introspection functions, of the site itself:
the primary role, to catalog and list artifacts under change and track
their differences and submissions, is pretty bereft of markup of THIS
kind. It has other markup, colorizing, denotation of state, which is
obviously using CSS and JS somehow.

isn't that actually close to what we want? Aren't we actually closer
to github, a wiki, and a calendar, than anything else?

---

From: Tim Chown <[email-masked]>
Date: Thu, 27 Jul 2017 00:32:53 +0100

> On 26 Jul 2017, at 23:32, Brian E Carpenter <[email-masked]> wrote:
> 

Yes, that page is a great example. 

Tim

---

From: Narelle <[email-masked]>
Date: Thu, 27 Jul 2017 10:40:25 +1000

Thanks Russ and team
I'm sure a huge amount of work has gone into this and I imagine you
have done the obvious traffic analysis to determine where the most
frequently accessed information needs to be.

I asked my accessibility expert to have a quick look and a blind user
to check it. The latter observed that he didn't find any obvious
issues (great! he uses a fairly current Jaws which is the dominant
screen reader), but my developer and site manager was more critical:

--- begin comments ----

Without going into a full accessibility check;

The navigation is a bit all over the place visually.  Using keyboard
it goes from IETF logo to the other side of the screen for News &
Blog, to Contact, skips search,  then goes to tools, then goes back to
the other side of the screen for  About, etc, etc.  I couldn’t see how
to get into the submenus using only key-strokes.

Images don’t seem to have Alt text or Titles.

The link colour, Light blue (#1BAEDD), is not WCAG 2.0AA compliant.

No breadcrumbs.

I could probably find another hundred things but I think the basic
message is that it hasn’t been designed with WCAG in mind.

Putting the non-compliance to WCAG aside, it’s a pretty standard run
of the mill site.  I don’t see anything that stands out as needing
massive adjustment. Although, the choice of images is pretty boring.

----- end coments ---

There are some very good accessible CSS, joomla etc templates around.
We have implemented one at accan.org.au and while this is a site for a
very different purpose, note the accessibility menu (top right from a
desktop, top line from a mobile) that allows resetting to
mobile/desktop, night mode, text size and contrast. This is a really
useful feature for accessibility and allows people a lot of useful
control.

Note also all our images have alt tags, and all documents are
available in an accessible marked up form.

Some of that can be time consuming for humans, but until image
recognition goes commodity, that's what is needed.

regards

Narelle

-- 

Narelle
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Jul 2017 13:05:36 +1200

...
> Although, the choice of images is pretty boring.

That is definitely a plus point (and I'm not joking, not even slightly).

    Brian

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 27 Jul 2017 10:39:42 +0100

> Yes, that page is a great example.

Indeed, as a tool to do the job this and the original page are far 
better than the PR centric new version.

As an introduction to the IETF they are better since I don't have to go 
exploring bits of the page to find out what might be their.

- Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 27 Jul 2017 08:12:57 -0400

> updated with links to the new site.

I also like the content page, but I find that most (but not all) of the
links are duplicated between the left and right parts of the page, but
there are some that are unique to each, so you have to search both sides. I
would prefer a single set of links, perhaps formatted like the right side
of the page, that’s a complete union of the two sides.

Cheers,
Andy

---

From: Michael Richardson <[email-masked]>
Date: Fri, 28 Jul 2017 13:33:23 -0400

> Yes, that page is a great example.

That page works for me too.
I tried beta.ietf.org/content.html, and it didn't work.
So I think, if it worked, it would be perfect.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Fri, 28 Jul 2017 13:47:08 -0400

> It has one major drawback: a lot of people think its ugly.

I don't think it has to be that way.

    > The newer kind, the responsive reactive javascript kind, is far

You use a bunch of words with are not always forced together.
I understand responsive web sites to mean that they look good on different
size screens.  This means doing layout with CSS and div rather than tables.
(HTML4 vs HTML5).
www.ietf.org currently uses a mix of methods.

beta.ietf.org seems to rely on JS for menus and the like (I could be wrong),
while in fact there are pure CSS methods to do this.

The industry has moved beyond JS for many of these things and back to CSS for
reasons of mobile devices, loading time and the like.

I think we could move forward, and I don't mind the new site as I hardly ever
use the old site. But we do need to make sure that we are using the
technology in appropriate moderation.

    > to github, a wiki, and a calendar, than anything else?

For datatracker, I think we are.