Subject: Slides, eye charts, and a beg for readability

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 19 Jul 2017 10:59:38 +0200

Dear IETF participants who are mostly younger than I am ...

I've been routinely using Meetecho *in the room* so that I could read
slides with fonts too small to read from the back of the room. I'm fine
with that, although I don't know that everyone is.

I'm seeing a couple of presentations where the font is so small that I can
barely read it with reading glasses on Meetecho.

If people could ask themselves if they care about being understood enough
to use a font large enough to read, that would be great.

Thanks,

Spencer, who's 20/20, after surgery, so it shouldn't be this hard!

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 Jul 2017 10:03:49 +0100

Spencer,
 
Aren't all the slides posted in the meeting materials at least 24 hours ahead of time to allow us to download them, use our own preferred tools, struggle with English not being our native language, and so on?
 
Adrian
 
From: ietf [mailto:[email-masked]] On Behalf Of Spencer Dawkins at IETF
Sent: 19 July 2017 10:00
To: [email-masked]
Subject: Slides, eye charts, and a beg for readability

I've been routinely using Meetecho *in the room* so that I could read slides with fonts too small to read from the back of the room. I'm fine with that, although I don't know that everyone is.
 
I'm seeing a couple of presentations where the font is so small that I can barely read it with reading glasses on Meetecho. 
 
If people could ask themselves if they care about being understood enough to use a font large enough to read, that would be great.
 
Thanks,

---

From: Michael Richardson <[email-masked]>
Date: Wed, 19 Jul 2017 14:16:56 +0200

Spencer Dawkins at IETF <[email-masked]> wrote:
    > I'm seeing a couple of presentations where the font is so small that I
    > can barely read it with reading glasses on Meetecho.

E-TooManyWordsOnScreen

Many presenters need to read Presentation Zen.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 19 Jul 2017 16:22:32 +0200

Hi, Adrian,

On Wed, Jul 19, 2017 at 11:03 AM, Adrian Farrel <[email-masked]> wrote:

> Spencer,
>
>
>
> Aren't all the slides posted in the meeting materials at least 24 hours
> ahead of time to allow us to download them, use our own preferred tools,
> struggle with English not being our native language, and so on?
>

Well, MINE were in TSVAREA, but that's not always true. I sat in one
meeting that had no slides uploaded at all. Not naming names, because the
responsible person supervising that meeting was sitting in front of me, and
was also noticing that lack of meeting materials.

Alternatively, if we were going to tell people it's a good plan to listen
to the audio and try to stay synchronized on their own copies of the
slides, we could save the Meetecho people a lot of aggravation, and ISOC a
fair amount of money.

But let's not do that, OK?

Spencer

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 Jul 2017 15:44:35 +0100

Well,
 
I do think that if the slides were available to be posted ahead of time, the chairs could make sure they are appropriate, sufficiently few in number, in the right font, etc., and the participants who want to could look at the slides in advance.
 
To be honest, posting slides ahead of time is not rocket science and wen it doesn't happen it is often (barring the usual excuses) pretty unprofessional.
 
Am I being overly smug?
 
Adrian

Well, MINE were in TSVAREA, but that's not always true. I sat in one meeting that had no slides uploaded at all. Not naming names, because the responsible person supervising that meeting was sitting in front of me, and was also noticing that lack of meeting materials.
 
Alternatively, if we were going to tell people it's a good plan to listen to the audio and try to stay synchronized on their own copies of the slides, we could save the Meetecho people a lot of aggravation, and ISOC a fair amount of money.

---

From: Loa Andersson <[email-masked]>
Date: Wed, 19 Jul 2017 17:06:41 +0200

Adrian,

I agree that it is not rocket science to get the slides in on time,
but that might be the very reason we don't see them in time.

This is in the "soon" domain!

/Loa

On 2017-07-19 16:44, Adrian Farrel wrote:
> Well,
>
>
>
> I do think that if the slides were available to be posted ahead of time,
> the chairs could make sure they are appropriate, sufficiently few in
> number, in the right font, etc., and the participants who want to could
> look at the slides in advance.
>
>
>
> To be honest, posting slides ahead of time is not rocket science and wen
> it doesn't happen it is often (barring the usual excuses) pretty
> unprofessional.
>
>
>
> Am I being overly smug?
>
>
>
> Adrian
>
>
>
> meeting that had no slides uploaded at all. Not naming names, because
> the responsible person supervising that meeting was sitting in front of
> me, and was also noticing that lack of meeting materials.
>
>
>
> Alternatively, if we were going to tell people it's a good plan to
> listen to the audio and try to stay synchronized on their own copies of
> the slides, we could save the Meetecho people a lot of aggravation, and
> ISOC a fair amount of money.
>
>
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jul 2017 11:51:21 -0400

--On Wednesday, July 19, 2017 15:44 +0100 Adrian Farrel
<[email-masked]> wrote:

> Well,
>  
> I do think that if the slides were available to be posted
> ahead of time, the chairs could make sure they are
> appropriate, sufficiently few in number, in the right font,
> etc., and the participants who want to could look at the
> slides in advance.  
> To be honest, posting slides ahead of time is not rocket
> science and wen it doesn't happen it is often (barring the
> usual excuses) pretty unprofessional.  
> Am I being overly smug?

In at least two ways, possibly so, but I'd describe it less as
"smug" than as missing part of the problem.

First, although it is rare (more rare than it should be, IMO),
there are meeting sessions in which parts of slides are
highlighted during a presentation and, more important, are
marked up in real time as the presentation goes forward.  Static
slides posted pre-meeting are a fairly poor approximation to
that.

Second, while I sympathize with Spencer's problem (and, being
both older and dimmer of vision than he is, have definitely had
it at meetings), there is another complication.  If one needs to
simultaneously follow, e.g., a Jabber session and look at the
slides, there is often a size and screen real estate management
and focus-maintaining problem with a typical laptop setup,  At
some meetings I've dealt with the problem by downloading
important the slides and printing them out, then balancing a
pile of paper on the laptop keyboard, but that has disadvantages
too (tree-killing not being the only one).

Speaking personally, while it is not high on the list of reasons
I'm not there in person, I'm actually better off from the
standpoint of slide readability when I'm sitting at home with a
desktop machine and two fairly large screens than I am in many
IETF meeting rooms.  But, even then, if I can't read the slides
through Meetecho, I start feeling as if I need three screens,
one for slides, one for Jabber, and one for whatever is going on
in Meetecho.   That is partially an element of what I thing are
some unfortunate screen layout choices with Meetecho that I
discussed with that team on and off for years but it is today's
reality.

However, more important than Spencer's vision issues (and mine),
every study of effective presentations I know of suggests
strongly that one minimize the number of text on slides, using
them to highlight only an outline or most important points, and
that slides dense enough to be read the whole presentation from
them, full-text documents, etc., tend to be distracting rather
than helpful.  I understand (and have taken advantage of) the
advantages of having relatively full text if one is trying to
work limitations in ability to understand the speaker, but that
is really something that should be dealt with as a separate
problem (and can be if we are really convinced it is important
enough).

best,
    john

---

From: Scott Brim <[email-masked]>
Date: Wed, 19 Jul 2017 12:03:57 -0400

Can't you just sit in front?

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 20 Jul 2017 05:28:57 +0000 (UTC)

> in the right font,

the correct single font choice for the IETF is original
twelve-point monospace Courier.

obviously. 
Lloyd Wood [email-masked] http://about.me/lloydwood 

________________________________
From: Adrian Farrel <[email-masked]>
To: 'Spencer Dawkins at IETF' <[email-masked]> 
Cc: [email-masked]
Sent: Thursday, 20 July 2017, 0:45
Subject: RE: Slides, eye charts, and a beg for readability

Well,

 
Am I being overly smug?
 
Adrian

---

From: Narelle <[email-masked]>
Date: Fri, 21 Jul 2017 10:47:15 +1000

Font size, colour contrast, animations are all just some of the things that
go to good slideware so that people with vision impairments can use them.

There is a good guide to powerpoint accessibility generally here:
http://webaim.org/techniques/powerpoint/

It goes to adding alt tags, reading order and (briefly) to contrast in
colour etc.

As does this overview:
https://www.slidegenius.com/blog/making-your-powerpoint-accessible-for-the-visually-impaired

Frankly all our materials should take these things into account...
Usability by design goes to not just the technology but how we communicate
about the technology.

regards

-- 

Narelle Clark
[email-masked]

---

From: Mary B <[email-masked]>
Date: Fri, 21 Jul 2017 02:44:07 -0500

I also think one of the issues is the lighting in the meeting rooms.  I'm
in Barcelona/Athens and the lights are quite bright at the front of the
room which makes it much harder to see the slides.  Also, it looks like the
projector isn't the brightest - the slides have a yellowish tint and it's
not the slides themselves but the projector (although the screen may also
be contributing to that).

Mary.

On Thu, Jul 20, 2017 at 7:47 PM, Narelle <[email-masked]> wrote:

>
> Font size, colour contrast, animations are all just some of the things
> that go to good slideware so that people with vision impairments can use
> them.
>
> As does this overview: https://www.slidegenius.com/
> blog/making-your-powerpoint-accessible-for-the-visually-impaired
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 21 Jul 2017 10:22:48 +0200

Hi, Scott,

On Jul 19, 2017 6:04 PM, "Scott Brim" <[email-masked]> wrote:

"Does not scale" ;-)

I see that several of us are griping in this thread, which is what one
would expect, given the nature of this mailing list.

I'm not hearing people saying, "I never have problems, must be you", which
I interpret as the visual equivalent of "if the music is too loud, you're
too old".

So, I'll probably bring this up on the working group chairs mailing list,
for their discussion and possible action.

Thanks, everyone, for your thoughts.

Spencer

Spencer

---

From: Ted Lemon <[email-masked]>
Date: Fri, 21 Jul 2017 10:45:39 +0200

FWIW, presbyopia doesn't make it difficult to read things that are
distant.  What does that is myopia.   I've had myopia since I was a kid.
There is just a limit to how much we can cram onto a slide, and it's
actually really difficult to know what that limit is when you are
_preparing_ the slides.

I suspect there is standards work to be done here.   E.g., is it the case
that the relative size of the screen when seen from the back of small rooms
is the same as from the back of large rooms?   If not, can we fix?   Can we
give people a suggestion as to what size fonts will be legible to a person
with corrected vision from the back of the room in the worst case?   I
think this would have to be part of the mtgvenue work.

I say this slightly tongue-in-cheek, but it's a real problem that I really
had to think about when preparing my slides.   I was not able to come up
with a definite answer.   I don't know how well I did, to be honest, but I
did increase the font size above the default, which seemed pretty
eye-chart-ish to me.

---

From: Tim Chown <[email-masked]>
Date: Fri, 21 Jul 2017 09:59:26 +0100

> On 21 Jul 2017, at 09:45, Ted Lemon <[email-masked]> wrote:
> 
> FWIW, presbyopia doesn't make it difficult to read things that are distant.  What does that is myopia.   I've had myopia since I was a kid.   There is just a limit to how much we can cram onto a slide, and it's actually really difficult to know what that limit is when you are _preparing_ the slides.
> 
> I suspect there is standards work to be done here.   E.g., is it the case that the relative size of the screen when seen from the back of small rooms is the same as from the back of large rooms?   If not, can we fix?   Can we give people a suggestion as to what size fonts will be legible to a person with corrected vision from the back of the room in the worst case?   I think this would have to be part of the mtgvenue work.
> 
> I say this slightly tongue-in-cheek, but it's a real problem that I really had to think about when preparing my slides.   I was not able to come up with a definite answer.   I don't know how well I did, to be honest, but I did increase the font size above the default, which seemed pretty eye-chart-ish to me.

Perhaps we can pull together a page somewhere within the IETF online material giving guidance to authors, and perhaps examples of good decks, through people nominating them to be archived as such.  Then if we also get the in-roo projection systems right, we should head towards a better place.  I did notice the screen in Barcelona this week was “wavy” so all the text was equally wavy; far from ideal.

I’ve seen quite a few good examples this week, one being Stuart’s deck for DNS-SD, though we only have the non-animated PDF version online
https://www.ietf.org/proceedings/99/slides/slides-99-dnssd-dns-sd-update-and-new-work-items-00.pdf

There is also the question of accessibility of decks and other meeting materials content. Animations such as the above probably aren’t so good there.

Tim

> On Fri, Jul 21, 2017 at 10:22 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> Hi, Scott,
> 
> I see that several of us are griping in this thread, which is what one would expect, given the nature of this mailing list. 
> 
> I'm not hearing people saying, "I never have problems, must be you", which I interpret as the visual equivalent of "if the music is too loud, you're too old".
> 
> So, I'll probably bring this up on the working group chairs mailing list, for their discussion and possible action.
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 21 Jul 2017 12:44:30 -0400

--On Friday, July 21, 2017 10:45 +0200 Ted Lemon
<[email-masked]> wrote:

> FWIW, presbyopia doesn't make it difficult to read things that
> are distant.  What does that is myopia.   I've had myopia
> since I was a kid. There is just a limit to how much we can
> cram onto a slide, and it's actually really difficult to know
> what that limit is when you are _preparing_ the slides.

Ted, in the last several years, I've gotten a rather
comprehensive set of personal lessons in things that can go
wrong with vision.  More than presbyopia can be age-related or
at least have age as significant risk factors.   I hope no one
else in this community finds out first-hand about any of the
others, but they are out there.   My knowledge is still
incomplete and I hope to never complete it, at least in the same
way).    For those reasons and reasons that relate more closely
to our policies about treating each other professionally and
with respect, I suggest that, if someone says they can't see
something, I think we need to take them at their word and start
figuring out what to do about it rather than probing diagnoses
or terminology.  

Narelle's note is very helpful in that regard: While, if slides
are simple black type on white backgrounds, type size and choice
of type styles are usually the major readability issues, there
are, as she says, others (and good choices of style and contrast
can mitigate size issues to a certain extent).  Contrast and
glare are, as Nary more or less pointed out, are room
environmental factors over which presentation designers usually
have little control (if one wanted a way to overconstrain site
selection very quickly, take specific requirements about that to
MTGVENUE although we often have control over dimmers and whether
spotlights are on or off and probably don't take enough
advantage of it).

> I suspect there is standards work to be done here.   E.g., is
> it the case that the relative size of the screen when seen
> from the back of small rooms is the same as from the back of
> large rooms? 
>...

There has actually been a good deal of research work, whether
"standards" or not, done on this.   The links in Narelle's note
are a reasonably starting point (I would have suggested others,
but they are no better, just different).  For more general
discussions about avoiding clutter and distractions that
interfere with rapid and accurate understanding, see Ed Tufte's
work (what works well for the somewhat visually impaired does
not always correlate with clutter reduction, but they are often
linked).  However, a warning: Tufte has often made comments to
the effect that Powerpoint should be treated as a disease.

> I say this slightly tongue-in-cheek, but it's a real problem
> that I really had to think about when preparing my slides.   I
> was not able to come up with a definite answer.   I don't know
> how well I did, to be honest, but I did increase the font size
> above the default, which seemed pretty eye-chart-ish to me.

In my experience, even thinking about the issues is a huge step
forward and improves the results.   If one is composing slides
on a typical laptop screen and one has roughly normal vision,
simply stepping away and trying to see if they those slide be
read and understood from two or three meters away can be very
instructive.  Again, it is possible to do much better than
thinking plus that test will yield, but they are big steps.

   john

p.s. I've been thinking about a room setup in which 300-500
people could all sit AT the front.  It is actually an
interesting design exercise even though I don't think I've ever
seen a meeting space in which rows of seats are arranged above
each rather than front to back (a few opera house might come
close, but AFAIK we haven't considered those for meeting venues
yet.  :-)

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 21 Jul 2017 10:42:27 -0700

Hi -

On 7/21/2017 1:45 AM, Ted Lemon wrote:
> distant.

Did you double-check with an optometrist?
It can, and I have the trifocals to prove it.

One can have an eye shaped to be rather
far-sighted (at-rest focus beyond infinity)
but also have sufficient strength and flexibility
to pass as 20/20 or better.  With presbyopia, that
eye is stuck focused past infinity, so no distance
is clear without correction.  Welcome to my world.

Randy

---

From: Michael Richardson <[email-masked]>
Date: Fri, 21 Jul 2017 19:44:04 +0200

> environmental factors over which presentation designers usually

for instance, Karlin I/II was silly.
The Karlin II side couldn't be seen by the chairs due to pillars.
Still, it would have been small to have just Karlin I.

    > people could all sit AT the front.  It is actually an

My suggestion is to remove 1/3 of the chairs and put more space between the
rows.   We could also just have a few stacks of chairs available.
We *RARELY* fill every chair in the room, usually many chairs go unused
because of difficulty in stepping over people.   When we *DO* fill every
chair (for an unexpectedly popular BOF), we also overflow out of the room and
onto the floor.

That way, more people could sit closer.
Many times, I've wanted to just remove the back 5 rows of chairs to
force people to sit closer...

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ted Lemon <[email-masked]>
Date: Fri, 21 Jul 2017 21:18:31 +0200

Thanks all for the schooling on what I have to look forward to.   I thought
presbyopia sucked.   Also thanks for the advice about standing back from
the laptop screen, John--I will try that next IETF.

---

From: Lee Howard <[email-masked]>
Date: Sat, 22 Jul 2017 18:19:51 +0200

I have a talk for the EDU team on presentation skills a couple of years ago, and included short, easy notes on slides. Find it on their page. 

Document authors don't reliably send in slides ahead of time, even with badgering. They're volunteers; the only thing chairs could do would be threaten to yank their slot, which weakens the WG's work. 

Similarly, authors aren't generally bothering to look for advice on how the improve their slides. Resources exist. Rather, they write notes on pages and consider it done. 

I think all we can really do is complain about it so this meeting's presenters hear about it and do better next time. 

Lee

Sent from my iPhone

> On Jul 21, 2017, at 10:22 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Scott,
>

---

From: John C Klensin <[email-masked]>
Date: Sat, 22 Jul 2017 16:51:39 -0400

Lee,

I agree, with two qualifications:

(1) That this can be difficult and often doesn't work doesn't
mean we should not try.  To me, that means making sure good
advice is available (even if we have to repeat this thread every
few years and/or add an explicit link about the importance of
good materials and how to make them to the meetings page or even
ubiquitous pester-ware documents like the Note Well).   It may
even be worth encouraging WG Chairs to badger people even if it
doesn't always work.

(2) Because this really is a [dis?]ability issue for some of us,
perhaps it is time for the community to start treating people
who can't be bothered to make slides readable or to submit
materials in advance as being a community problem and make them
candidates for advice and education by the ombusdteam.   I don't
think "unreadable slides" fall into the same category referred
to in some cultures as putting stumbling blocks in the path of
the blind, but it would seem to trend in the same direction.

best,
    john

--On Saturday, July 22, 2017 18:19 +0200 Lee Howard
<[email-masked]> wrote:

> I have a talk for the EDU team on presentation skills a couple
> of years ago, and included short, easy notes on slides. Find
> it on their page. 
> 
> Document authors don't reliably send in slides ahead of time,
> even with badgering. They're volunteers; the only thing chairs
> could do would be threaten to yank their slot, which weakens
> the WG's work. 
> 
> Similarly, authors aren't generally bothering to look for
> advice on how the improve their slides. Resources exist.
> Rather, they write notes on pages and consider it done. 
> 
> I think all we can really do is complain about it so this
> meeting's presenters hear about it and do better next time.

---

From: Narelle <[email-masked]>
Date: Mon, 24 Jul 2017 11:35:13 +1000

I'm giving a preso at an upcoming major IEEE conference and they run
training for their speakers, distribute a training pack and template.
Amongst all of that was this guidance:

"• 10/20/30 Rule
• (10 slides - 20 minutes presentation - 30pts font)"

Now it wasn't perfect either and we also had the accessibility
conversation about the colours chosen in the template.

This is just FYI - I'm not expecting the equivalent but food for thought.

-- 

Narelle
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Sun, 23 Jul 2017 22:40:01 -0400

--On Monday, July 24, 2017 11:35 +1000 Narelle
<[email-masked]> wrote:

> I'm giving a preso at an upcoming major IEEE conference and
> they run training for their speakers, distribute a training
> pack and template. Amongst all of that was this guidance:
> 
> "• 10/20/30 Rule

Narelle,

Thanks. IMO helpful.  As another guideline/ rule of thumb, I've
often been told that, if any given slide takes appreciably less
than one minute or more than two to present, something is
probably wrong.  At the lower bound, one is running the slides
too rapidly for the audience to see, read, and absorb what is on
them.  At the upper one, there is probably too much information
(or too much clutter or other "stuff") on the slide.   The
relationship between that rule and "10 slides - 20 minutes
presentation" is probably not a coincidence.  Personally, I
prefer to put less on each slide and run them a little faster --
I would have said 10 slides and 12 to 15 minute presentation --
but it is a bit of a matter of taste, audience, speaking speed
and clarity, etc.

On the other hand, if one treats a more or less standard A4 or
8.5x11 page in landscape orientation as the baseline, 30 point
type allows, depending on the leading (or inter-line spacing)
about 18 lines on the slide.  That would generally be too much,
not because of the type size, but because it allows too much
material to be squeezed in.

best,
    john