Subject: normative references to IANA registries

From: Michael Richardson <[email-masked]>
Date: Mon, 31 Jul 2017 15:55:16 -0400

I'm implementing draft-ietf-ipsecme-rfc4307bis.
It basically sets MUST/SHOULD/etc. values for various algorithms. The IPsec(ME)
WG updates things as the world evolves.

   "References to the specification
   defining these algorithms are in the IANA registry."

It would be nice if it gave the actual name of the Registry.
But, I think in this hyperlinked internet, it really should reference the
registry itself directly.

So I wonder out loud: shouldn't all of the IANA registries have clear
reference files that could be normatively referenced?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 31 Jul 2017 21:10:46 +0100

> reference files that could be normatively referenced?

Yes

- Stewart

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 31 Jul 2017 22:16:51 +0200

> reference files that could be normatively referenced?

Try referencing, say, {{!IANA.cbor-tags}} — it just works :-)

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Mon, 31 Jul 2017 20:45:33 -0400

> Try referencing, say, {{!IANA.cbor-tags}} — it just works :-)

wow. I'm sure it's documented in some place so obvious I can't see it.
Is the "cbor-tags" part the last part of the IANA registry URL?