Subject: Genart last call review of draft-kille-ldap-xmpp-schema-05

From: Stewart Bryant <[email-masked]>
Date: Wed, 20 Sep 2017 03:56:19 -0700

Reviewer: Stewart Bryant
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-kille-ldap-xmpp-schema-05
Reviewer: Stewart Bryant
Review Date: 2017-09-20
IETF LC End Date: 2017-09-27
IESG Telechat date: Not scheduled for a telechat

Summary: A well written document, however it uses an example email address that
might be allocated in the future, rather than one for the example range.

Major issues: None

Minor issues:

"[email-masked] representing a user) "

That is a really cool example! However I can imagine .lit eventually being
allocated so we ought to use one of the RFC6761 example TLDs.

Nits/editorial comments:  None

---

From: "Steve Kille" <[email-masked]>
Date: Wed, 20 Sep 2017 14:39:35 +0100

Stewart,

These Shakespearean style addresses are conventionally used in XMPP XEPs, and I followed that style here.

I've discussed with XMPP colleagues, and we agree that although the convention is cool, you are right that a safe address should be used.

I have fixed this in 06, which I just submitted

Regards

Steve 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: 20 September 2017 11:56
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Genart last call review of draft-kille-ldap-xmpp-schema-05
> 
> Reviewer: Stewart Bryant
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair.  Please treat these comments just like any other last call
> comments.
> 
> Summary: A well written document, however it uses an example email
> address that might be allocated in the future, rather than one for the
> example range.
> 
> Major issues: None
> 
> Minor issues:
>

---

From: Dave Cridland <[email-masked]>
Date: Wed, 20 Sep 2017 15:00:26 +0100

shakespeare.example is a fine domain to use - the XMPP community (mostly
due to Peter Saint-Andre) has used these inventive domains to express
examples with more clarity - montague.lit, capulet.lit, and so on provide
usefully recognisable domains. But .example is just as good as .lit, and
just as clear.

On 20 Sep 2017 14:39, "Steve Kille" <[email-masked]> wrote:

Stewart,

These Shakespearean style addresses are conventionally used in XMPP XEPs,
and I followed that style here.

I've discussed with XMPP colleagues, and we agree that although the
convention is cool, you are right that a safe address should be used.

Regards

Steve

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 20 Sep 2017 15:26:14 +0100

Thanks for doing the update.

- Stewart

On 20/09/2017 15:00, Dave Cridland wrote:
> shakespeare.example is a fine domain to use - the XMPP community 
> (mostly due to Peter Saint-Andre) has used these inventive domains to 
> express examples with more clarity - montague.lit, capulet.lit, and so 
> on provide usefully recognisable domains. But .example is just as good 
> as .lit, and just as clear.
>
> On 20 Sep 2017 14:39, "Steve Kille" <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Stewart,
>
>     These Shakespearean style addresses are conventionally used in
>     XMPP XEPs, and I followed that style here.
>
>     I've discussed with XMPP colleagues, and we agree that although
>     the convention is cool, you are right that a safe address should
>     be used.
>
>     > From: Stewart Bryant [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     > To: [email-masked] <mailto:[email-masked]>
>     > Cc: [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>     > <https://trac.ietf.org/trac/gen/wiki/GenArtfaq
>     <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>>.
>     >