Subject: Considerations Considerations Section

From: Dave Cridland <[email-masked]>
Date: Fri, 29 Sep 2017 15:14:57 +0100

All,

Given that the solution to all problems seems always to have a new
Considerations Section, I'd like to propose that all new I-Ds
published have a Considerations Considerations Section, which provides
considerations over what else might be considered when considering the
considerations not yet considered in the other considerations
sections.

I believe this can only help us consider many problems solved.

Dave.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 29 Sep 2017 10:17:28 -0400

> considerations not yet considered in the other considerations

Hm.   Maybe something to work on in London, for an early April release.

---

From: Dave Aronson <[email-masked]>
Date: Fri, 29 Sep 2017 10:53:53 -0400

On Fri, Sep 29, 2017 at 10:14 AM, Dave Cridland <[email-masked]> wrote:

> I'd like to propose that all new I-Ds
> published have a Considerations Considerations Section,

How considerate!  Consider it considered.

-The Other Other Dave

-- 
Dave Aronson, software development consultant at www.Codosaur.us

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 29 Sep 2017 11:02:08 -0400

> I believe this can only help us consider many problems solved.

​All that the considerations sections do is to break out material that has
to be called out to the attention of different groups so that they don't
have to read the entire draft every time.

As the IETF becomes more process driven and the processes make more sense,
this is expected and an improvement.​

I would like to move to a machine readable IANA section at some future
incarnation of xml2rfc.

---

From: Dave Cridland <[email-masked]>
Date: Fri, 29 Sep 2017 16:08:38 +0100

On 29 September 2017 at 16:02, Phillip Hallam-Baker
<[email-masked]> wrote:
> All that the considerations sections do is to break out material that has to
> be called out to the attention of different groups so that they don't have
> to read the entire draft every time.
>
> this is expected and an improvement.
>
>

This sounds like a fine idea, all things considered.

Dave.

---

From: "Mehmet Ersue" <[email-masked]>
Date: Fri, 29 Sep 2017 19:39:15 +0200

Dear Dave,

to be able to consider all considerations not yet considered and should be considered in potential considerations sections, would you please consider to provide a considerations draft for discussion.

Mehmet

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Dave Cridland
> Sent: Friday, September 29, 2017 5:09 PM
> To: Phillip Hallam-Baker <[email-masked]>
> Cc: [email-masked] Discussion <[email-masked]>
> Subject: Re: Considerations Considerations Section
> 
> >> published have a Considerations Considerations Section, which
> >> provides considerations over what else might be considered when
> >> considering the considerations not yet considered in the other
> >> considerations sections.
> >>
> > All that the considerations sections do is to break out material that
> > has to be called out to the attention of different groups so that they
> > don't have to read the entire draft every time.
> >
> > As the IETF becomes more process driven and the processes make more
> > sense, this is expected and an improvement.
> >
> >

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 29 Sep 2017 20:36:22 +0200

On Fri, Sep 29, 2017 at 11:02:08AM -0400, Phillip Hallam-Baker wrote:
> ???All that the considerations sections do is to break out material that has
> this is expected and an improvement.???

Gee! I would have never guessed that that as the intention of considerations.

To be more inclusive of non-native english speakers, i demand this
terminology is changed to more readily understood terms used by everyday people,
for example those in speechees, emails or twitter to address the target
audience!

I mean, who starts an email with "Madam/Sir considerations", "IRS considerations"
or "congregation considerations" ?

How about:

"To whom it may concern"
  for the main part of the document where you really don't care who reads it,
  Especially all that boring normative stuff everybody wants to ignore.

"Dear security experts"
  For the most important part of any RFC

"#IANA", "#IPV6", "#TSV"
  Why even have sections if we can make RFCs operate like twitter ?
  And AFAIK, we already use some tagging ([RFC-Editor: ...]!).

"Fellow privacy activist, policy makers"
  Obviously the term to emphasize your fraternization
  with communities you want to suck up to.

"ATTN: coders, product managers, buyers"
  We always forget about these because they do not have their own
  card carrying group recognition in the IETF, although coders
  are kinda getting there via hackathons. Maybe rather use
  twitter #HACK to highlight important implementation aspects
  that MUST be messed up to support followup IETF work.

Well, those are my considerations. To whom it may concern.

Toerless

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 30 Sep 2017 08:15:20 +1300

We should consider adding this by default to all draft templates:

<section anchor="cestcon" title="Considerations Considerations">
 <t>Considerations considerations are not considered in this memo.</t>
</section>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 29 Sep 2017 15:24:36 -0400

But, isn't that a paradox?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Miles Fidelman <[email-masked]>
Date: Fri, 29 Sep 2017 15:15:48 -0700

This should be referred to whomever promoted Major Major.

-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 30 Sep 2017 10:21:56 +1000

If I read that with the voice of Sir Humphrey Appleby, it makes sense. 

Sent from my iPhone

> On 30 Sep 2017, at 3:39 am, Mehmet Ersue <[email-masked]> wrote:
> 
> Dear Dave,
>