Subject: Re: IETF Website Status Update

From: Stewart Bryant <[email-masked]>
Date: Wed, 1 Nov 2017 10:49:16 +0000

Hi Russ,

I must say I still prefer the original in terms of utility, clarity and 
information density.

I am not sure if the font being used is mandated, but I find it far less 
crisp, almost blurry compared to the smaller font of the original. I 
find such lack of crispness on web pages irritating and when I see it I 
am distracted by wondering if there is a technical failure in my system. 
People like 4K for a reason, and I see no reason why this preference 
would not be carried over to web pages.

Whilst I understand the need to provide an accessible interface I don't 
see why there cannot simply be a parallel high efficiency interface as 
well.

A useful addition to both the original and to this would be a direct 
link to id-nits right next to (well right before) the submit tag.

- Stewart

On 31/10/2017 21:36, Russ Housley wrote:
> I want to share an update on progress on the IETF website revamp project. In particular I’d like to highlight what has been done to respond to feedback from the IETF community received around IETF 99.
>
> A. Provide a landing page dedicated to current IETF participants
>
> A draft is currently posted at https://beta.ietf.org/links/
>
> That page includes links to:
> - items on the left-side at www.ietf.org (or a subset thereof)
> - information about the next IETF meeting
> - links to functions at datatracker.ietf.org
>
> The goal is to make this page:
> - viewable in a single screen on a desktop/laptop display
> - reachable via a short, memorable URL
>
> The current content includes changes implemented based on suggestions received via email after IETF 99. Of course, this page will be updated further based on input from the community.
>
> B. Ensure WCAG 2.0 compliance
>
> Since IETF 99, we have worked with the website developer to improve compliance. This is a requirement of the Statement of Work (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf). We believe that has been accomplished. However, ensuring and improving accessibility must be part of ongoing editorial practices, so it will continue to be an area of focus for the website.
>
> C. Conduct review with other key audiences, especially potential participants and non-participants
>
> Additional interviews with members of the key audiences have been conducted to gather input. In general, response to the beta.ietf.org site was positive.  IETF newcomers say that the new site makes it easier to understand what the IETF is all about. Some specific suggestions have been incorporated into the project, and they are included at https://github.com/ietf/www.ietf.org/issues
>
> D. Improve data use and load times
>
> Since IETF 99, the beta.ietf.org site was placed behind the Cloudflare CDN. This has significantly improved load times. Of note, in interviews (see item C above), new or non-IETF participants located in Latin America and Africa did not report load time as a significant issue. However, as the new site moves to production, the editorial process will continue to fine tune how images and other elements are handled to further improve performance.
>
> Next steps:
>
> We are continuing to fine tune content and are aiming to move to production after IETF 100. One significant task remaining is to ensure continuity for important URLs, as specified in the Statement of Work. We expect to tackle that after IETF 100.
>
> We welcome input and suggestions. We held "office hours" at IETF 98 and IETF 99, and we will hold "office hours” at IETF 100.  If you will be in Singapore, please take this opportunity to share feedback in person. Details will be posted on a sign around the IETF meeting registration desk. And, of course, questions or issues can always be raised at https://github.com/ietf/www.ietf.org/issues
>
> Sincerely,
>    Russ Housley
>    IETF Website Revamp Project Manager

---

From: Tim Chown <[email-masked]>
Date: Thu, 2 Nov 2017 15:30:41 +0000

Hi,

> On 1 Nov 2017, at 10:49, Stewart Bryant <[email-masked]> wrote:
> 
> Hi Russ,
> 
> I must say I still prefer the original in terms of utility, clarity and information density.

I must say I agree. It certainly should be possible to lay out the links page so that you can see where to go at a glance, rather than feeling you have to read the page line by line. 

> I am not sure if the font being used is mandated, but I find it far less crisp, almost blurry compared to the smaller font of the original. I find such lack of crispness on web pages irritating and when I see it I am distracted by wondering if there is a technical failure in my system. People like 4K for a reason, and I see no reason why this preference would not be carried over to web pages.
> 
> Whilst I understand the need to provide an accessible interface I don't see why there cannot simply be a parallel high efficiency interface as well.

I would second this request. As per the discussion at IETF99, I accept that www.ietf.org is essentially conceded to IETF ‘comms and marketing’, but there’s no reason we can’t have alternative well-laid out index pages as well.

There’s much of course that can be done simply by only using the datatracker and tools pages, which have gone from strength to strength over recent years.

> A useful addition to both the original and to this would be a direct link to id-nits right next to (well right before) the submit tag.

One other point is that I don’t think I’ve yet seen what a meeting page would look like in the new “glossy" format. 
Under the new system, what would https://www.ietf.org/meeting/100/index.html look like?  If it’s https://beta.ietf.org/how/meetings/upcoming/100/, that’s not really comparable, yet.
That’s a really useful, and clearly laid out, page for finding info at meetings.
I assume there’s a change coming, as meeting pages fall under www.ietf.org.

Thanks,
Tim

---

From: Pat Thaler <[email-masked]>
Date: Thu, 2 Nov 2017 12:23:36 -0700

On Thu, Nov 2, 2017 at 8:30 AM, Tim Chown <[email-masked]> wrote:

> I must say I agree. It certainly should be possible to lay out the links
> page so that you can see where to go at a glance, rather than feeling you
> have to read the page line by line.
>

Agreed. One problem is the horizontal lists of items in a string. I find
the lists much easier to read if they are column lists where each item
starts on a new line. The string of items format makes one have to scan
across the whole list to find the item you want.

> crisp, almost blurry compared to the smaller font of the original. I find
> such lack of crispness on web pages irritating and when I see it I am
> distracted by wondering if there is a technical failure in my system.
> People like 4K for a reason, and I see no reason why this preference would
> not be carried over to web pages.
> >
> see why there cannot simply be a parallel high efficiency interface as well.
>
> I would second this request. As per the discussion at IETF99, I accept
> that www.ietf.org is essentially conceded to IETF ‘comms and marketing’,
> but there’s no reason we can’t have alternative well-laid out index pages
> as well.
>
Agree. Also, is there going to be a link to this page from www.ietf.org?
There should be but there isn't one on the current beta top.

>
> There’s much of course that can be done simply by only using the
> datatracker and tools pages, which have gone from strength to strength over
> recent years.
>
> One other point is that I don’t think I’ve yet seen what a meeting page
> would look like in the new “glossy" format.
> Under the new system, what would https://www.ietf.org/meeting/
> 100/index.html look like?  If it’s https://beta.ietf.org/how/
> meetings/upcoming/100/, that’s not really comparable, yet.
> >> I want to share an update on progress on the IETF website revamp
> project. In particular I’d like to highlight what has been done to respond
> to feedback from the IETF community received around IETF 99.
> >>
> >> The current content includes changes implemented based on suggestions
> received via email after IETF 99. Of course, this page will be updated
> further based on input from the community.
> >>
> >> Since IETF 99, we have worked with the website developer to improve
> compliance. This is a requirement of the Statement of Work (
> https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf). We
> believe that has been accomplished. However, ensuring and improving
> accessibility must be part of ongoing editorial practices, so it will
> continue to be an area of focus for the website.
> >>
> >> Additional interviews with members of the key audiences have been
> conducted to gather input. In general, response to the beta.ietf.org site
> was positive.  IETF newcomers say that the new site makes it easier to
> understand what the IETF is all about. Some specific suggestions have been
> incorporated into the project, and they are included at
> https://github.com/ietf/www.ietf.org/issues
> >>
> >> Since IETF 99, the beta.ietf.org site was placed behind the Cloudflare
> CDN. This has significantly improved load times. Of note, in interviews
> (see item C above), new or non-IETF participants located in Latin America
> and Africa did not report load time as a significant issue. However, as the
> new site moves to production, the editorial process will continue to fine
> tune how images and other elements are handled to further improve
> performance.
> >>
> >> Next steps:
> >>
> >> We are continuing to fine tune content and are aiming to move to
> production after IETF 100. One significant task remaining is to ensure
> continuity for important URLs, as specified in the Statement of Work. We
> expect to tackle that after IETF 100.
> >>
> >> We welcome input and suggestions. We held "office hours" at IETF 98 and
> IETF 99, and we will hold "office hours” at IETF 100.  If you will be in
> Singapore, please take this opportunity to share feedback in person.
> Details will be posted on a sign around the IETF meeting registration desk.
> And, of course, questions or issues can always be raised at
> https://github.com/ietf/www.ietf.org/issues
> >>
> >> Sincerely,
> >>   Russ Housley

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Nov 2017 21:07:47 +0100

Russ,

Thanks for bringing this to ietf ML.

You are referring to feedback. Are there publically accessible written versions
of all that feedback so that i could read up on it ? So far i can only see
the github issues, but i guess that that is not the only or not even
primary feedback channel, or is it ?

I did post my opinion into github issue #95.

Cheers
    Toerless

On Tue, Oct 31, 2017 at 05:36:00PM -0400, Russ Housley wrote:
> I want to share an update on progress on the IETF website revamp project. In particular I???d like to highlight what has been done to respond to feedback from the IETF community received around IETF 99.
> 
> We welcome input and suggestions. We held "office hours" at IETF 98 and IETF 99, and we will hold "office hours??? at IETF 100.  If you will be in Singapore, please take this opportunity to share feedback in person. Details will be posted on a sign around the IETF meeting registration desk. And, of course, questions or issues can always be raised at https://github.com/ietf/www.ietf.org/issues  
> 
> Sincerely,
>   Russ Housley

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Nov 2017 12:01:04 +1300

> - viewable in a single screen on a desktop/laptop display

In that, it fails, compared to https://www.ietf.org/content.html :
a) at least 5cm vertical space is wasted with pointless blurb.
b) because of the lack of columns and empty space, it is much
harder to spot individual items.

On the other hand, it's usable on a smartphone, which the old
page hardly is.

So there's the basic question: do we want to make the site
harder to use on a laptop or desktop so that it's easier to use
on a smartphone? That goes for pretty much every page on the beta
site, I think, although it seems to be a rather noticeable issue
for this particular page.

Regards
    Brian

---

From: Tim Chown <[email-masked]>
Date: Mon, 13 Nov 2017 12:58:14 +0000

> On 10 Nov 2017, at 23:01, Brian E Carpenter <[email-masked]> wrote:
> 

Do we have an example meeting page in the new “beta” format?

Tim

---

From: Tim Chown <[email-masked]>
Date: Tue, 14 Nov 2017 08:33:50 +0000

Hi,

> On 13 Nov 2017, at 21:41, Greg Wood <[email-masked]> wrote:
> 
> Hi Tim,
> 
>> On Nov 13, 2017, at 8:58 PM, Tim Chown <[email-masked]> wrote:
>> 
> I believe the best example is:
> 
> https://beta.ietf.org/how/meetings/past/99/

This appears to be a significant drop in usability compared to 

https://www.ietf.org/meeting/99/index.html

Not least having to click to see the details under each heading.

The beauty of the current meeting page is that everything is easy to see and easily reached in one click.

> The IETF 100 meeting hasn’t yet been fully synced, but it is available at:
> 
> https://beta.ietf.org/how/meetings/100/

The same applies here, sadly.

Tim

> -Greg

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 14 Nov 2017 22:40:25 +1300

On 14/11/2017 21:33, Tim Chown wrote:
...
> Not least having to click to see the details under each heading.

Plus wasted vertical space in the top and bottom banners, larger
font than is useful for some text, and general signs of having
been designed to meet some aesthetic criteria rather than
just laying out the material in the simplest practical way.

And why is there that annoying bouncy thing at the right hand
side for "sharing" the link with social media?  I can't imagine
ever wanting to do that, and I would really want an option to
get rid of this, for ever, on all IETF pages.

The tourist photo of Prague is sadly lacking, too. That is a
nice touch of vanity in the old format.

> The same applies here, sadly.

Yes.
   Brian