Subject: Re: On audio quality requirements for IETF meetings

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 17 Nov 2017 10:42:49 +0800

Hi all,

I’ve got the below question from Ingemar (confirmed with him that is ok to respond in the list).

This document:

https://datatracker.ietf.org/doc/draft-palet-ietf-meeting-network-requirements/

is mainly about the network, but also “other” technical requirements, so I think it will be fine to include audio specs.

I’m sure we have some audio experts in the list that can figure out what will be the correct wording for our criteria on this?

I want to take the opportunity to ask the list for:
1) Please review the document, specially the NOC team and secretariat, but in general in case there are other technical requirements that aren’t being considered.
2) IETF chair/IESG, as the mtgvenue WG believes there is not good expertise there to evaluate this document, what is the path forward?

I don’t want to have the same experience as I had in 2006 with this document and the original draft-palet-ietf-meeting-venue-selection-criteria, which after hard work were silently ignored and we started the work from scratch in mtgvenue without even mentioning them.

This is another topic, but I want to mention it as it is a perfect example: I think this is a global IETF problem and we should somehow correct it. People do some work … is not considered by IETF, fine, but then after some time, somebody else take on that work and the original authors aren’t referenced. I think is a matter of basic politeness and acknowledgment.

Regards,
Jordi

-----Mensaje original-----
De: Ingemar Johansson S <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 17 de noviembre de 2017, 10:17
Para: "[email-masked]" <[email-masked]>
Asunto: On audio quality requirements for IETF meetings

    Hi
    Tried to find the RFC that describes the requirements for the IETF meeting rooms, still not lucky in my search. I would be interested to see if there are any stated requirements on the audio quality.
    
    I personally suffer from degraded hearing since childhood and quite often have problems to hear what people say. The reasons are :
    + High noise from AC and ventilation
    + Low  audio level (sometimes close to 0dB S/N)
    + Long reverberation times (boomy acoustics)
     
    Some of these issues are relatively easy to fix (requirements on audio levels), others can be involve more work. I don’t have all the answers right now but for instance.
    + Line array loudspeakers are generally better than point sources and built in ceiling speakers, as the line arrays control the audio dispersion better, a great benefit in venues with boomy acoustics.
    
    + Requirements on e.g RT60 and noise levels. 
    + Audio monitors should face the WG/AD/* chairs and the presenter
     
    I believe that improved acoustics would non only benefit people with bad hearing, it would also reduce fatigue for people with good hearing
     
    Is there any document that can be updated with recommendations, unless there are any requirements/recommendations available already ?

    Regards
    Ingemar
     
    ==================================
    Ingemar Johansson  M.Sc.
    
    Master Researcher
     
    Ericsson Research
    Network Protocols & E2E Performance
    Labratoriegränd 11
    971 28, Luleå, Sweden
    Phone +46-1071 43042
    SMS/MMS +46-73 078 3289
    [email-masked]
    www.ericsson.com
     
    The world is full of magical things patiently
    
        waiting for our wits to grow sharper
                   Bertrand Russell
    ==================================

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 17 Nov 2017 10:46:19 +0800

By the way … maybe I’m starting to suffer hearing problems, don’t noticed before, but in this meeting, I’ve real difficulties to heard and consequently understand people at the mike when I was presenting.

I think it will be interesting to know if Ingemar and I, are alone on this …

Regards,
Jordi

-----Mensaje original-----
De: JORDI PALET MARTINEZ <[email-masked]>
Fecha: viernes, 17 de noviembre de 2017, 10:42
Para: "<[email-masked]>" <[email-masked]>
CC: <[email-masked]>
Asunto: Re: On audio quality requirements for IETF meetings

    Hi all,

    This document:

    

    
    
    Regards,
    Jordi

    -----Mensaje original-----
    De: Ingemar Johansson S <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: viernes, 17 de noviembre de 2017, 10:17
    Para: "[email-masked]" <[email-masked]>
    Asunto: On audio quality requirements for IETF meetings
    
        Hi

        

        Regards
        Ingemar

        Master Researcher
         
        Ericsson Research

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 17 Nov 2017 03:14:49 -0000

You are not alone!
Conference centre PA not good.
Mics very distance-sensitive.
Not so bad that unusable, but hard work.
Adrian

> By the way … maybe I’m starting to suffer hearing problems, don’t noticed
> before, but in this meeting, I’ve real difficulties to heard and consequently
> understand people at the mike when I was presenting.
>

---

From: Ted Lemon <[email-masked]>
Date: Fri, 17 Nov 2017 11:21:07 +0800

> Not so bad that unusable, but hard work.

Another issue is that the microphones kept running out of power, and there's no way to charge them.   Either we need someone other than the participants doing this, or else there needs to be resources in each room that chairs or others can use to get microphones working when they fail.

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 17 Nov 2017 18:03:29 +0800

I also find my aging and decreasingly capable ears had a hard time in this 
venue.  I wonder whether this might better be discussed on the meeting 
list, however.

A

Please excuse my clumbsy thums

----------

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 17 Nov 2017 19:15:03 +0800

Because I’m trying to find the right text to put in the document, from audio experts, and having a bigger audience list will make it easier?

Just forgot to say to contact me unicast, if we want to avoid noise, to provide inputs on that.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Andrew Sullivan <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 17 de noviembre de 2017, 18:21
Para: <[email-masked]>, <[email-masked]>, <[email-masked]>
Asunto: RE: On audio quality requirements for IETF meetings

    A

    
    ----------

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 17 Nov 2017 11:23:47 +0000

+1

I know my hearing is not as good as it once was but it is normally OK at 
IETF. Not so this time. It was hard to hear the presenter at times and 
partiularly hard to hear the questions from the Mic when I was 
presenting. We need much clearer audion going forwards.

- Stewart

---

From: John C Klensin <[email-masked]>
Date: Fri, 17 Nov 2017 11:07:43 -0500

--On Friday, November 17, 2017 11:21 +0800 Ted Lemon
<[email-masked]> wrote:

> Another issue is that the microphones kept running out of
> power, and there's no way to charge them.   Either we need
> someone other than the participants doing this, or else there
> needs to be resources in each room that chairs or others can
> use to get microphones working when they fail.

One difficulty is that every equipment requirement we impose is
likely to turn into another box (crate? but see below) of stuff
the secretariat or other provider has to drag to meetings, which
means more aggravation, higher costs and more customs risks,
etc.  A hotel that tells us exactly what audio and video
equipment they will have on hand as far in advance as we seem to
make decisions is probably lying, or at least saying something
for which they could reasonably say "things change and we had to
replace some gear when the meeting rolls around.   And testing
equipment several years in advance and making a facility
decisions on that basis is likely to be a really good, but not
particularly useful, way to overconstrain the choices.

That said, two observations:

(1) I know wires are unfashionable these days, but traditional
wired microphones rarely have problems with either running out
of power or with in-room EMI, including EMI caused by WiFi,
Bluetooth, and lots of other wireless things.  I have not yet
found out what a conference room or plenary would be like with
500 people running Wifi and Bluetooth keyboards, headsets, or
mice, but I'm fairly sure I don't want to.

(2) It appears to me that an increasing number of wireless
microphones, like many other wireless things, are either
USB-powered or USB-charged.  If we could somehow prefer, or
restrict ourselves to, such devices, preferably ones that can
run off external power rather than just requiring that the
batteries be charged, a small collection of "portable chargers"
might allow prevention and/or quick fixes to microphones with
dead or dying batteries.   

However, remember that such chargers and probably even the
microphones themselves typically use Li-ion batteries that are
increasingly restricted in transit because of fire concerns.
I've also been through airports that try to ban batteries over
some fairly low capacity entirely, whether in checked or
carry-on baggage.  So there may be significant constraints on
ways to address the problem.   At the same time, Jordi, you
could write a requirement that a facility have sufficient spares
or alternatives on hand to run however many microphones we need
all day, every day, for a week... or we could require wired
microphones with no internal batteries.   Not saying either
would be a good idea, but, if you are looking for something to
write down, that wouldn't be too hard.

best,
   john

---

From: Ted Lemon <[email-masked]>
Date: Sat, 18 Nov 2017 01:06:00 +0800

These are all good points, John.   What I'm really arguing for is that whatever equipment is present at the venue, there should be sufficient information in the room, available to the chairs and their deputies, to manage it.   We wind up engaging in ad-hoc debugging when the mics go down anyway, so might as well empower us to actually fix them.   I think a lot of them just use 9-volt batteries or stacks of AA batteries anyway, so that's very easy to facilitate and relatively cheap as well.   Just a matter of doing that inventory before the meeting starts, in the secretariat's copious and not-at-all-constrained free time during that period.   Or getting a volunteer to do it.   :)

---

From: Michael Richardson <[email-masked]>
Date: Fri, 17 Nov 2017 13:08:40 -0500

> make decisions is probably lying, or at least saying something

The NOC team visits a month or so in advance of each meeting, and maybe they
could verify what the audio situation is, and if really unacceptable, could
tell the secretariat to bring the extra box of stuff.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: John C Klensin <[email-masked]>
Date: Fri, 17 Nov 2017 13:11:14 -0500

Ted,

I think we are on exactly the same page.  Dead batteries are
something that we can predict and have seen many times before.
There is little excuse for not being prepared to adjust and
repair in very close to real time rather than treating each
incident as new and then starting to scramble.  .  

And, yes, if the batteries are 9 volt or AAs, the issues I'm
concerned about with built-in rechargeables don't apply and
supplies can be obtained locally almost anywhere in the world,
so the logistical problems I mentioned really are no impediments.

Partially because of the time difference and unrelated
exhaustion, I got to fewer sessions than I usually do, but my
own impression was of things working nearly flawlessly from an
audio and video transmission and receipt standpoint.

   john

--On Saturday, November 18, 2017 01:06 +0800 Ted Lemon
<[email-masked]> wrote:

> These are all good points, John.   What I'm really arguing for
> is that whatever equipment is present at the venue, there
> should be sufficient information in the room, available to the
> chairs and their deputies, to manage it.   We wind up engaging
> in ad-hoc debugging when the mics go down anyway, so might as
> well empower us to actually fix them.   I think a lot of them
> just use 9-volt batteries or stacks of AA batteries anyway, so
> that's very easy to facilitate and relatively cheap as well.
> Just a matter of doing that inventory before the meeting
> starts, in the secretariat's copious and
> not-at-all-constrained free time during that period.   Or
> getting a volunteer to do it.   :)

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 18 Nov 2017 02:18:21 +0800

Depending on what and the quantity that you need to bring it may not be possible in one month, may need a customs process (temporary import and then cancelling that via export).

If is only batteries, make sense probably sourcing locally, or even on-line (amazon, e-bay, etc.). Otherwise, a local audio company.

But what I was asking was more on the line of “what audio quality” we need for our meetings, in whatever terms an audio expert can define … There must be a way to fix that in the document.

I think all that is contracted by the secretariat, probably as part of the venue contract, but we are missing defining some more concrete “audio quality” parameters.

I will ask directly the secretariat what is the actual “model” for this.

Regards,
Jordi

---

From: Eric Gray <[email-masked]>
Date: Fri, 17 Nov 2017 20:27:25 +0000

+1

I was trying to attend meeting this week remotely.  In spite of the fact that I have very good audio equipment at my end, the audio for remote participants varied from nearly non-existent to almost audible in at least a few of the meetings for at least some of the meeting time.

Of course, this was compounded by network issues.  I found it was necessary to attend only as an observer in order to keep from dropping my connection every 10-20 minutes or so.

But I found the overall experience somewhat more rewarding than I expected, in spite of the fact that the timing made attendance a 1:1 replacement for sleep (most meetings were between 8:30 PM and 5:00 AM Eastern US time).  Crowding, power and seating was much better, for instance.  😊

--

Eric

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Friday, November 17, 2017 6:24 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: On audio quality requirements for IETF meetings

+1

I know my hearing is not as good as it once was but it is normally OK at IETF. Not so this time. It was hard to hear the presenter at times and partiularly hard to hear the questions from the Mic when I was presenting. We need much clearer audion going forwards.

- Stewart

>> By the way … maybe I’m starting to suffer hearing problems, don’t

>> noticed before, but in this meeting, I’ve real difficulties to heard

>> and consequently understand people at the mike when I was presenting.

>> I think it will be interesting to know if Ingemar and I, are alone on

>> this …

---

From: Michael Richardson <[email-masked]>
Date: Fri, 17 Nov 2017 17:02:16 -0500

JORDI PALET MARTINEZ <[email-masked]> wrote:
    > But what I was asking was more on the line of “what audio quality” we
    > need for our meetings, in whatever terms an audio expert can define …
    > There must be a way to fix that in the document.

So you are thinking about things like:
   1) dB of absorption by walls (to prevent echo)
   2) dB of audio isolation between rooms
   3) amount of phase that the PA amplifier can echo cancel

?? (and that's the most technical I can get)

I was half thinking that we should have IPv6 enabled microphones in every
badge, and then:
  a) we don't have to run the mic
  b) jabber scribe will know who is in the "line"
  c) the badge/mic can be professional positioned each morning so that
     everyone can be "levelled"

Only half of of me thought it was a bad idea.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 18 Nov 2017 09:06:22 +0800

I’ve not seen mics with IPv6 … however there are IPv6 IP cameras, so may be the point is replacing the mics with those and instead of mic holder we need red boxes for the location where the cameras are pointing (by default). Depending on the camera mic capabilities, the problem may be the distance for having a good audio.

As the badges have the name in both sides … I guess using IP cameras with zoom, pant and tilt, could be a way for the scribes to look for the name and a very small software modification to allow them to zoom in-read-zoom out.

What I’m not sure is if we can rely on the WiFi for that, or a specific access point/radio, or if we use RJ45 for all those.

Regards,
Jordi

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 18 Nov 2017 10:37:30 +0100

>    I believe that improved acoustics would non only benefit people with bad hearing, it would also reduce fatigue for people with good hearing

+100.  I’ve been using English in a professional context for more than 35 years now, but English via bad audio really exhausts me.

I don’t think we should meddle with the actual A/V engineering (although the DECT microphones that Telefonica had for the STRINT workshop in 2014 were amazing).  But we can show that we care about audio by asking for some simple specifications (RT60 was suggested, maybe frequency response if installed ceiling speakers are to be used — a high pass might help with some rooms).

ISTR that the microphones I looked at in Singapore said they were SM58s, so unless they were cheap fakes, the problems with them were mostly lack of training (you need to be very close to those, and unless you are an accomplished singer, this means you need to hold them as opposed to using them on a stand).  There were some microphones though that needed to be tapped or shaken now and then, pointing to badly maintained battery contacts.  And battery discipline apparently was lacking as well — batteries need to be replaced in a regular process and not after they finally fail.

There were some serious speaker placement problems in some rooms, with no direct sound at all in significant parts of the room (including the presenter and chair areas themselves).  Maybe we can complement the presenter TV with a monitor speaker (which would also help the presenter with knowing when they are close enough to the microphone), but the speaker placement for the rest of the room simply needs to be checked in place and corrections made where needed.

If we really want to help people who can benefit from that, there could be a monitor frequency per room that can be picked up by a receiver (I’ve used those with specific students in large-room lectures).  Those of course require additional planning, as they are regional and licensed; instead of doing it per room there could also be a set per person needing it, with a place in the room to plug the transmitter in.  (I have used meetecho as a cheap version of that when I happened to sit down in a bad area of the room, but the delay is generally too high compared to an analog solution.)

At least the leakage from adjacent rooms (another spec we could ask for) was limited this time.

Audio problems excepted, this was definitely one of the better venues we had.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 18 Nov 2017 11:23:05 +0100

On Nov 17, 2017, at 21:27, Eric Gray <[email-masked]> wrote:
> 
> the audio for remote participants varied from nearly non-existent to almost audible in at least a few of the meetings for at least some of the meeting time

When listening to the IETF audio, I run it through a dynamics compressor(*) (also very useful for the very irregular levels you get with WebEx audio in interim meetings).  That does not help with noise, but it sure does with bad levels.

I have always wondered if the dynamics compression could not be done at the source.

Grüße, Carsten

(*) For those with a Mac: Install soundflower and a VST tool of your choice (I use Audio Hijack), run the system audio to soundflower, and run the VST plugin AUDynamics (comes with the Mac) from that to the speaker output you want to use.
Configure AUDynamics for an about 40 dB (I’m not joking) knee.  Don’t forget to reset system audio to your speaker output when you switch back to a sane audio source…