Subject: IETF 100 MeetEcho connectivity

From: Hector Santos <[email-masked]>
Date: Sun, 12 Nov 2017 20:36:59 -0500

Hi, I was perusing the IETF 100 agenda and proceeded to click a 
meeting video.

First, with javascript off (my security default), it thinks I need a 
new browser. It should just say "This site requires javascript to 
function."

Second, with javascript now enabled and the website white listed, it 
took me to a series of clicks where I think I am required to register 
even under "Read Only" mode.   I didn't click the Read/Write 
(participant mode) option.

Is this read-only registration necessary?

-- 
HLS

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 12 Nov 2017 19:59:19 -0600

> Is this read-only registration necessary?

It was conscious choice, yes.

There was previous discussion on (IIRC) this list.

Note that the audio-only stream does not require this registration.

-Ben

---

From: Hector Santos <[email-masked]>
Date: Wed, 15 Nov 2017 11:42:55 -0500

On 11/12/2017 8:59 PM, Benjamin Kaduk wrote:
>   In particular, the thread starting at
>   https://www.ietf.org/mail-archive/web/ietf/current/msg102867.html
>

Thanks for the link.

I've always been an advocate for a "Basic Remote Member ietf.org" 
registration system, it would resolve all sorts of things and maybe 
good for recruiting.

But in this case, at that moment, it killed the interest I had to 
continue.

The videos (archive?) 
https://ietf100.conf.meetecho.com/index.php/Recordings
here doesn't required log in.  Good material.

-- 
HLS

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 16 Nov 2017 12:21:35 +1300

Here's a modest suggestion. At https://www.ietf.org/meeting/100/index.html,
even though there is a "Registration" link under "Remote Participation",
it isn't apparent that this is a required step. This is made clear behind
the "Info" link. So if the "Registration" link was removed, and "Info" link
renamed as "Start Here", people would not miss the registration step.

(The same applies to https://beta.ietf.org/how/meetings/100/ of course.)

Regards
   Brian

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Nov 2017 19:26:08 -0500

--On Thursday, November 16, 2017 12:21 +1300 Brian E Carpenter
<[email-masked]> wrote:

> Here's a modest suggestion. At
> https://www.ietf.org/meeting/100/index.html, even though there
> is a "Registration" link under "Remote Participation", it
> isn't apparent that this is a required step. This is made
> clear behind the "Info" link. So if the "Registration" link
> was removed, and "Info" link renamed as "Start Here", people
> would not miss the registration step.
> 

If we are going to design this by committee, a useful
alternative of addition would be to make the link text for the
main "Register" link under "General" read "Register (On-site and
remote)" and then be sure the registration form layout was
remote participant friendly.    

The problem with removing the "Register" link under "Remote
Participation" is that those of us who have participated
remotely many times are fairly unlikely to click on an "Info"
link unless we think something is different.   To demonstration
this, if the "Register" link under "General" were replaced with
"Info", how often do you think you would click on it, at least
before you got frustrated looking in all the other obvious and
non-obvious places.

Another way to deal with the problem would be to move the
"Remote Participation" category up so it immediately followed
"General" and maybe create a new title in that column for "On
Site Participation" and make "Additional Events", "Social
Event", "Venue and...", and "On the Ground..." subsidiary to it.

It actually took me a while to find the remote participation
registration link because the location of that category at the
lower right, under the rather specialized "New Attendees" and
"Session Chair Tools" categories was counterintuitive.

   john
   (remotely)

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Nov 2017 10:16:26 +0800

what is the threat model which makes any sort of registration needed?

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 16 Nov 2017 15:47:44 +1300

> what is the threat model which makes any sort of registration needed?

Dunno. Ask meetecho? I do understand that they need a registration
in order for a remote attendee to speak, and that may be a last-minute
decision.

  Brian

---

From: Alia Atlas <[email-masked]>
Date: Wed, 15 Nov 2017 22:02:01 -0500

Understanding our participation and having those remote participants clearly
acknowledge the Note-Well is useful for the IETF.

I do not believe that a threat model is necessary for justification.

Regards,
Alila

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Nov 2017 11:02:19 +0800

I think this was done mostly to be able to count how many remote attendees we have (as opposed to someone who just listens in on one or two sessions)

> On 16 Nov 2017, at 10:16, Randy Bush <[email-masked]> wrote:
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Nov 2017 11:04:56 +0800

> in order for a remote attendee to speak, and that may be a last-minute

i happen to be sitting next to the meetecho folk in the noc.  they say
it is what they were told to do; just following orders.  reminding them
of nurenberg did not seem appropriate.

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Nov 2017 11:11:11 +0800

> Understanding our participation

sorry, i do not understand what you intend here

> having those remote participants clearly acknowledge the Note-Well is
> useful for the IETF.

this i understand.  and we are all used to the Ts&Cs checkboxes none of
us read.

we talk about open blah blah.  this makes merely listening daunting.  i
almost gave up on trying to watch last night's plenary (felt i should be
in noc).

randy

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 Nov 2017 06:02:30 -0500

--On Thursday, November 16, 2017 15:47 +1300 Brian E Carpenter
<[email-masked]> wrote:

> Dunno. Ask meetecho? I do understand that they need a
> registration in order for a remote attendee to speak, and that
> may be a last-minute decision.

AFAIK, there are two issues, at least if one accepts that anyone
was is going to speak or otherwise attempt to influence
decisions needs to be registered and, insofar as is possible and
reasonable, registered with an identity that is understandable
by others.  Note that should apply to entering anything into a
Jabber room (with a "MIC" request or not) as well as using the
Meetecho queue request mechanism.

One is the rapid switching Brian mentions above. If one
concludes, midway in a WG session, that one needs to speak up or
say something on Jabber, the odds are high that the conversation
will have passed the topic by if one has to pause and go through
a registration procedure rather than just switching modes.  That
is, IMO, the important issue on a short-term basis.

THe other is the cost of doing this remote participation stuff,
costs that are going to rise if things some of us have discussed
to make things work better or more smoothly are implemented.
ISOC's generosity notwithstanding, even some of us who are
happily taking advantage of the free ride are uncomfortable
about doing so.   If, as a community, we are going to understand
the costs and plan for the future, we need to have some
understanding of who is using the real time facilities and how.
Passive listening or video-watching hours or days later is
another matter -- we want to have the recordings for historical
and documentation purposes and the marginal cost of an extra
person downloading or streaming them is rather small.   But
real-time remote participant, and even remote observer, costs
are another matter.   

IIR, the registration form does have an "I prefer to not
register" box.  That presumable locks one into Observer mode
with no possibility of a real-time switch to Participant.  IMO,
that is reasonable, important to have as an option, and should
accommodate anyone whose privacy concerns outweigh any desire
they might have to switch over to active participation.

   john

---

From: Michael Richardson <[email-masked]>
Date: Thu, 16 Nov 2017 15:53:52 -0500

> what is the threat model which makes any sort of registration needed?

Bluesheet/IPR concerns.
You have to read the Note Well if you want to contribute/speak.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: S Moonesamy <[email-masked]>
Date: Thu, 16 Nov 2017 13:59:55 -0800

Hi John,
>is, IMO, the important issue on a short-term basis.

Over the years it was possible to comment in a Jabber room without 
having to click through a "Note Well" and it is still like that 
today.  Meetecho Observer mode is audio only; it used to be audio and 
video after Meetecho was introduced.

>to make things work better or more smoothly are implemented

The expenses for remote participation is 4.7% of meeting expenses.

Regards,
S. Moonesamy

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 Nov 2017 18:02:27 -0500

--On Thursday, November 16, 2017 13:59 -0800 S Moonesamy
<[email-masked]> wrote:

>...
>> concludes, midway in a WG session, that one needs to speak up
>> or say something on Jabber, the odds are high that the
>> conversation will have passed the topic by if one has to
>> pause and go through a registration procedure rather than
>> just switching modes.  That is, IMO, the important issue on a
>> short-term basis.
 
> Over the years it was possible to comment in a Jabber room
> without having to click through a "Note Well" and it is still
> like that today.

Yes.  And from the standpoint of the IETF being able to document
who is influencing decisions about standards is a bad idea.
How bad is a question for lawyers and may depend on one's
assessment of the likelihood of someone getting upset about, or
feeling that they have been hurt by, IETF decisions to challenge
the fairness and openness of the process.   What situation we
would be in if someone mounted that sort of challenge and we
couldn't document participants, balance, etc., is also a
question for lawyers, preferably ones with a crystal ball
supply, but other SDOs who have found themselves with that sort
of problem have not found it to be pleasant experience.

>  Meetecho Observer mode is audio only; it
> used to be audio and video after Meetecho was introduced.

If that has actually changed, I think it is very problematic.  I
don't recall any discussions or decisions that should have
changed it.
 
>> THe other is the cost of doing this remote participation
>> stuff, costs that are going to rise if things some of us have
>> discussed to make things work better or more smoothly are
>> implemented
> 

That depends on how and what one counts.  And that isn't a topic
I want to get drawn into especially outside IASA 2.0 discussions
about how transparent the IAOC has been and whether the
community cares.

best,
   john

---

From: Meetecho IETF support <[email-masked]>
Date: Fri, 17 Nov 2017 04:02:58 +0100

> don't recall any discussions or decisions that should have

It hasn't. Meetecho "Observer" mode still has audio + video + slides + 
jabber + etherpad. The only thing that is missing is the possibility to 
raise your hand to make comments through the virtual queue.

More info here:

	https://ietf100.conf.meetecho.com/index.php/Remote_Participation

Cheers,
the Meetecho team

---

From: S Moonesamy <[email-masked]>
Date: Thu, 16 Nov 2017 20:53:07 -0800

Hi John,
At 07:02 PM 16-11-2017, Meetecho IETF support wrote:
>It hasn't. Meetecho "Observer" mode still has audio + video + slides 
>+ jabber + etherpad. The only thing that is missing is the 
>possibility to raise your hand to make comments through the virtual queue.

The change where registration is required for Observer mode occurred 
as from IETF99.  Prior to that, registration was optional.

Regards,
S. Moonesamy

---

From: Mark Andrews <[email-masked]>
Date: Fri, 17 Nov 2017 16:23:18 +1100

> On 17 Nov 2017, at 3:53 pm, S Moonesamy <[email-masked]> wrote:
> 
> Hi John,
>> It hasn't. Meetecho "Observer" mode still has audio + video + slides + jabber + etherpad. The only thing that is missing is the possibility to raise your hand to make comments through the virtual queue.
> 
> The change where registration is required for Observer mode occurred as from IETF99.  Prior to that, registration was optional.
> 
> Regards,
> S. Moonesamy  

I suspect that is more a terminology clash than anything else.

Meetecho as a observer mode vs being a observer rather than a registrant.

(echoes of what IPv6-only means)

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]

---

From: John C Klensin <[email-masked]>
Date: Fri, 17 Nov 2017 10:30:16 -0500

--On Thursday, November 16, 2017 20:53 -0800 S Moonesamy
<[email-masked]> wrote:

>> It hasn't. Meetecho "Observer" mode still has audio + video +
>> slides  + jabber + etherpad. The only thing that is missing
>> is the  possibility to raise your hand to make comments
>> through the virtual queue.
> 
> The change where registration is required for Observer mode
> occurred as from IETF99.  Prior to that, registration was
> optional.

That is a different issue (see Mark Andrew's note).  

That change was made for the reasons Brian and I described in
earlier notes plus, IIR< a desire to get a little better handle
on who was using Meetecho and for what.  In particular, it may
make some difference -- in planning in prioritization of some
possible features -- what the proportions are between people who
are using it and actually remote and people using it while
sitting in a different WG meeting, an on-site hotel room, even
in the meeting room to get a better view of the slides, or the
NOC or some conference area.   The granularity by which those
distinctions can be made by distinguishing between people with
onsite registration IDs and those whose registration numbers are
offsite only are very poor; I assume we will sooner or later ask
at least the latter to check a "where are you" box.

Personally, because I'm very concerned about the issues of not
being able to identify those who are influencing decisions, if I
could choose to require that anyone making comments over an
official jabber  channel (e.g., a jabber room that is accessible
via the agenda, kept archivally as part of IETF activities,
and/or tracked by a jabber scribe) should be required to be
registered.  That is probably infeasible technically or more
trouble than it is worth, but that does not affect the
preference.  YNMD, especially if you see the risks differently.

best,
    john