Subject: Intdir early review of draft-ietf-dhc-rfc3315bis-10

From: Zhen Cao <[email-masked]>
Date: Wed, 01 Nov 2017 00:40:37 -0700

Reviewer: Zhen Cao
Review result: Ready with Issues

I am an assigned INT directorate reviewer for this draft. These
comments were written primarily for the benefit of the Internet Area
Directors. Document editors and shepherds should treat these comments
just like they would treat comments from any other IETF contributors
and resolve them along with any other Last Call comments that have
been received. For more details of the INT directorate, see
<http://www.ietf.org/iesg/directorate.html>.

This version is quite ready to go, with a small issue that I would like to
discussion:

In Section. 15 (Reliability of Client Initiated Message Exchanges), I strongly
recommend that implementation MUST NOT set both MRC or MRD to ZERO, which
attaches a possible risk that the client continues to send this message without
a stop.    So I would like to propose the following change:

s/
" If both MRC and MRD are zero, the client continues to transmit the
   message until it receives a response."
/
"The client must be informed with a limit of its retransmission behavior, and
MUST NOT set both MRC and MRD to zero"

-zhen

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 1 Nov 2017 13:27:14 +0000

Hi Zhen:

First, thanks for the Int-Dir review.

Regarding your comment, the cases where both MRC and MRD are zero is for a Solicit and Information-Request. And, for those particular cases, the client should probably retransmit "forever" at a hopefully low rate (SOL_MAX_RT and INF_MAX_RT are 3600 seconds*) to locate a  DHCP server. This of course depends on the RA M & O bits (indicating a DHCP server is available) or the manual configuration of the client (to explicitly run DHCP).

* - RFC 3315 used 120 seconds for these values, but that was updated by RFC 7083.

- Bernie

-----Original Message-----
From: Int-dir [mailto:[email-masked]] On Behalf Of Zhen Cao
Sent: Wednesday, November 01, 2017 3:41 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Int-dir] Intdir early review of draft-ietf-dhc-rfc3315bis-10

Reviewer: Zhen Cao

I am an assigned INT directorate reviewer for this draft. These comments were written primarily for the benefit of the Internet Area Directors. Document editors and shepherds should treat these comments just like they would treat comments from any other IETF contributors and resolve them along with any other Last Call comments that have been received. For more details of the INT directorate, see <http://www.ietf.org/iesg/directorate.html>.

In Section. 15 (Reliability of Client Initiated Message Exchanges), I strongly recommend that implementation MUST NOT set both MRC or MRD to ZERO, which attaches a possible risk that the client continues to send this message without
a stop.    So I would like to propose the following change:

s/
" If both MRC and MRD are zero, the client continues to transmit the
   message until it receives a response."
/
"The client must be informed with a limit of its retransmission behavior, and MUST NOT set both MRC and MRD to zero"

-zhen

_______________________________________________
Int-dir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-dir

---

From: Zhen Cao <[email-masked]>
Date: Thu, 2 Nov 2017 11:30:02 +0800

Hi Bernie,

> First, thanks for the Int-Dir review.
My pleasure as always.

> Regarding your comment, the cases where both MRC and MRD are zero is for a Solicit and Information-Request. And, for those particular cases, the client should probably retransmit "forever" at a hop…

Then depending on this information, it is up to you to see if there is
a need of an affordable better description than the current text.

Cheers,
zhen

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 2 Nov 2017 13:33:52 +0000

Hi:

I think this text is fine as is. It is also text that was moved from RFC 3315 (last paragraph of Section 14) and has caused no issues (well, it did result in RFC7083 to change SOL_MAX_RT and INF_MAX_RT defaults to reduce the frequency of retransmissions -- so perhaps we can consider that to have addressed the issue?).

- Bernie

-----Original Message-----
From: Zhen Cao [mailto:[email-masked]] 
Sent: Wednesday, November 01, 2017 11:30 PM
To: Bernie Volz (volz) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Int-dir] Intdir early review of draft-ietf-dhc-rfc3315bis-10

Hi Bernie,

My pleasure as always.

> Regarding your comment, the cases where both MRC and MRD are zero is for a Solicit and Information-Request. And, for those particular cases, the client should probably retransmit "forever" at a hop…

Then depending on this information, it is up to you to see if there is a need of an affordable better description than the current text.

Cheers,
zhen