Subject: 20 versions in 31 minutes?

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Nov 2017 08:18:52 +1300

I realise that (D)TLS1.3 is controversial, but 20 versions of the draft
within 31 minutes seems a bit excessive. I'm curious about the mechanics
of how this happened, especially the confirmation process.

(The -03 version had some actual changes. The only changes in versions
-04 to -22 are the version numbers. A robot at play?)

Subject: I-D Action: draft-ietf-tls-dtls13-03.txt
Date: Wed, 29 Nov 2017 08:05:09 -0800
From: [email-masked]
...

Subject: I-D Action: draft-ietf-tls-dtls13-22.txt
Date: Wed, 29 Nov 2017 08:36:01 -0800
From: [email-masked]

Regards
   Brian Carpenter

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Nov 2017 14:20:36 -0500

> of how this happened, especially the confirmation process.

Apparently the goal was to sync the dtls and tls draft versions.  I'm sure there is a reason why this was important.   I am however at a loss to actually say why.   :)

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 30 Nov 2017 06:47:09 +1100

I'm assuming it's because when implementers do interop work, they talk about what draft they're using, and if the numbers are out of sync, this can be confusing.

> On 30 Nov 2017, at 6:20 am, Ted Lemon <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Sean Turner <[email-masked]>
Date: Wed, 29 Nov 2017 14:51:19 -0500

Note the PSA:
https://mailarchive.ietf.org/arch/msg/tls/p9sQ_srqEaA-gYBAP1Iwib6P1fE

---

From: Warren Kumari <[email-masked]>
Date: Wed, 29 Nov 2017 14:54:55 -0500

> https://mailarchive.ietf.org/arch/msg/tls/p9sQ_srqEaA-gYBAP1Iwib6P1fE

Ugh. I'm sympathetic to wanting the have the numbers in sync, but I
really think it would have been polite to include a note in versions
04-21 explaining what is happening. The current Appendix A. History
would have been a fine place for this.

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Sean Turner <[email-masked]>
Date: Wed, 29 Nov 2017 14:57:48 -0500

> On Nov 29, 2017, at 14:54, Warren Kumari <[email-masked]> wrote:
> 

That can be arranged ;)

spt

---

From: John C Klensin <[email-masked]>
Date: Wed, 29 Nov 2017 15:10:43 -0500

--On Wednesday, November 29, 2017 14:54 -0500 Warren Kumari
<[email-masked]> wrote:

> Ugh. I'm sympathetic to wanting the have the numbers in sync,
> but I really think it would have been polite to include a note
> in versions 04-21 explaining what is happening. The current
> Appendix A. History would have been a fine place for this.

Unless we have gotten so tangled up by our tools as to make
doing sensible things entirely impossible, I would assume that a
simple explanation and requiest to the Secretariat would have
permitted posting an I-D with a chosen non-consecutive sequence
number as long as sequence numbers remained monotone increasing.
If the Secretariat were being suitably cautious, I imagine they
might ask for some AD to sign off, but I assume it wouldn't be
too hard to find one of those :-(

   john

---

From: Glen <[email-masked]>
Date: Wed, 29 Nov 2017 12:16:40 -0800

> number as long as sequence numbers remained monotone increasing.

Under the old ID submit tools that might have been possible, but we use the
same tools to post drafts now that the community does, and I am given to
understand (and told the original requestor, when their original ticket got
escalated to me) that we did not have that ability.

Even were I to modify the database by hand, I assume that such a
modification would break the Datatracker in glorious ways.

(And, moreover, I'm sure that the community would have noticed the gap, and
mentioned it, just as they noticed the many duplicates.)

I referred them to the Tools Team to discuss this as a possible enhancement.

I agree there should be a good way to handle this.

Glen

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 29 Nov 2017 12:26:50 -0800

> number as long as sequence numbers remained monotone increasing.

I was told this was impossible with the current tools, so I opted for this.

-Ekr