Subject: consolidation

From: Jari Arkko <[email-masked]>
Date: Mon, 5 Mar 2018 19:05:29 +0200

One of the topics we’ve discussed recently at the IAB are
consolidation trends in various Internet services, and how
architecture be affected by those trends or vice versa. And
whether there might be IETF work that would be useful
due to all this.

Here’s a blog article on this topic:

https://www.ietf.org/blog/consolidation/ <https://www.ietf.org/blog/consolidation/>

Thoughts?

One good location for discussion of this topic would be
the architecture-discuss list
(https://www.ietf.org/mailman/listinfo/Architecture-discuss <https://www.ietf.org/mailman/listinfo/Architecture-discuss>)

Jari Arkko for the IAB

---

From: Josh Howlett <[email-masked]>
Date: Thu, 8 Mar 2018 15:00:41 +0000

I think this is an important topic. I believe the main drivers for consolidation are the pursuit of greater cost-efficiencies and revenue. I’m not really sure that either of these can be addressed through de jure standardisation, unless a standard is able to change the underlying economics to the detriment of consolidation.

Federation for the sake of federation is also a dead end: all other things being equal, operational subsidiarity reduces the scope for economies of scale. Federation is best employed where subsidiarity creates opportunities to extract value that exceeds the benefits realisable from consolidation.

A good example is identity federation, where a single identity can be reused across multiple domains. The need for Enterprises to know their employees to a high degree of confidence (e.g., to comply with employment or taxation law) provides a “free” pool of highly-assured identities that can be reused for purposes that would be inappropriate for less-assured identities asserted by a provider of social identities.

Other drivers for federation include sovereignty and compliance, which stem from political or legal considerations. Given the increasingly global character of governance and regulation (e.g., the extraterritoriality of the GDPR), I suspect that we will see an increasingly homogenous environment. I would argue that this is a positive development, as federation within a heterogenous environment tends to increases costs and complexity, and reduces the capabilities of the entire system to that supported by the lowest common denominator. To that end, I think an argument could be made that the internet architecture needs to a greater extent with the regulatory environment (and ideally take a lead in helping to define that, rather than follow with heels dragging), as that both facilitates federation and reduces compliance costs for users.

Josh.

From: ietf <[email-masked]> On Behalf Of Jari Arkko
Sent: 05 March 2018 17:05
To: IETF <[email-masked]>
Subject: consolidation

https://www.ietf.org/blog/consolidation/

Thoughts?

One good location for discussion of this topic would be
the architecture-discuss list
(https://www.ietf.org/mailman/listinfo/Architecture-discuss)

Jari Arkko for the IAB

Jisc is a registered charity (number 1149740) and a company limited by guarantee which is registered in England under Company No. 5747339, VAT No. GB 197 0632 86. Jisc’s registered office is: One Castlepark, Tower Hill, Bristol, BS2 0JA. T 0203 697 5800.

Jisc Services Limited is a wholly owned Jisc subsidiary and a company limited by guarantee which is registered in England under company number 2881024, VAT number GB 197 0632 86. The registered office is: One Castle Park, Tower Hill, Bristol BS2 0JA. T 0203 697 5800.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 8 Mar 2018 15:20:53 -0500

​Since we are about to meet in London participants from the larger Internet
behemoths might like to consider the fact that much of the wealth of London
was created by the East India company, a corporation which did not merely
rival nation states in its power, it eclipsed all but a handful of the
nation states of its day. The nabobs of the East India company were
wealthier than the crown.

It took four years for the company to go from being the dominant political
power in the country to bankrupt.

Berkeley Square, where Robert Clive died (believed to be by suicide) is a
shortish walk from the hotel. You can also find the house of his
contemporary John Byng, the Admiral who was shot 'to encourage the others'.

There is a lot of hubris in our industry and there is also a lot of hubris
in the current political environment. Folk on both sides have a habit of
assuring themselves that things must remain as they are since they find it
unthinkable that they could be different.

The fact that seven of the ten largest companies in the world by market cap
are IT companies does not make us invulnerable. As far as many are
concerned, it makes us a target.

---

From: Dave Cridland <[email-masked]>
Date: Thu, 8 Mar 2018 20:47:30 +0000

On 8 March 2018 at 20:20, Phillip Hallam-Baker <[email-masked]> wrote:
> Since we are about to meet in London participants from the larger Internet

Somewhat fittingly, given the rest of your email, the docks they once
operated have been filled in for years, and are now home to Telehouse,
as well as several other data centres...

Dave.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 8 Mar 2018 16:23:02 -0500

> as well as several other data centres...

​That was the result of containerized transport rather than ​a political
cataclysm.

IT companies tend to make the mistake that political circumstances are
irrelevant to them. They are on the look out for emergent technologies.

Governments were not. Not only did HMG not understand the impact of
containerization and fail to plan for it, they entirely failed to realize
the impact until a decade after it had occurred. The cost of shipping goods
dropped by two orders of magnitude because of the box. That is why it is
now possible to build cars in the UK using parts from Japan.

Many policy makers have yet to catch up to the impact of containerization.
They are cheerfully trying to rewrite the rules of the modern trading
system while understanding exactly nothing about its workings.

Arguments of the form 'they can' possibly do X because the result would be
Y' are inoperative.

---

From: Lloyd Wood <[email-masked]>
Date: Fri, 9 Mar 2018 00:00:36 +0000 (UTC)

Consider this while visiting the exhibitions at the Museum of London Docklands.

https://www.museumoflondon.org.uk/museum-london-docklands/permanent-galleries

(Clive's biographers did not believe he suicided.)
 
Lloyd Wood [email-masked] http://about.me/lloydwood 

________________________________
From: Phillip Hallam-Baker <[email-masked]>
To: Jari Arkko <[email-masked]> 
Cc: IETF <[email-masked]>
Sent: Friday, 9 March 2018, 7:21
Subject: Re: consolidation

​Since we are about to meet in London participants from the larger Internet behemoths might like to consider the fact that much of the wealth of London was created by the East India company, a corporation which did not merely rival nation states in its power, it eclipsed all but a handful of the nation states of its day. The nabobs of the East India company were wealthier than the crown.

It took four years for the company to go from being the dominant political power in the country to bankrupt.

Berkeley Square, where Robert Clive died (believed to be by suicide) is a shortish walk from the hotel. You can also find the house of his contemporary John Byng, the Admiral who was shot 'to encourage the others'.

There is a lot of hubris in our industry and there is also a lot of hubris in the current political environment. Folk on both sides have a habit of assuring themselves that things must remain as they are since they find it unthinkable that they could be different.

The fact that seven of the ten largest companies in the world by market cap are IT companies does not make us invulnerable. As far as many are concerned, it makes us a target.

>https://www.ietf.org/blog/ consolidation/
>
>
>Thoughts?
>
>
>(https://www.ietf.org/mailman/ listinfo/Architecture-discuss)
>
>
>Jari Arkko for the IAB
>
>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 9 Mar 2018 12:10:59 +0200

> ​That was the result of containerized transport rather than ​a political cataclysm.
> 
> IT companies tend to make the mistake that political circumstances are irrelevant to them. They are on the look out for emergent technologies.
> 
> Governments were not. Not only did HMG not understand the impact of containerization and fail to plan for it, they entirely failed to realize the impact until a decade after it had occurred. The cost of shipping goods dropped by two orders of magnitude because of the box. That is why it is now possible to build cars in the UK using parts from Japan.
> 
> Many policy makers have yet to catch up to the impact of containerization. They are cheerfully trying to rewrite the rules of the modern trading system while understanding exactly nothing about its workings. 

Containerization? For some reason your story brings to my mind some shifts in cloud computing and their ongoing effects in the industry :-)

Jari

---

From: Rich Kulawiec <[email-masked]>
Date: Fri, 9 Mar 2018 06:56:37 -0500

> concerned, it makes us a target.

This is one reason (of several reasons) why I think it's very improbable
that large cloud computing operations are secure.

---rsk

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 9 Mar 2018 08:50:32 -0500

On Fri, Mar 9, 2018 at 5:10 AM, Jari Arkko <[email-masked]> wrote:

> Containerization? For some reason your story brings to my mind some shifts
> in cloud computing and their ongoing effects in the industry :-)
>

​I always suspected that the reason Docker chose the name
'Containerization' was an allusion to the impact of multi-mode
containerized transport, aka the shipping container, aka the Box. Either it
is a very happy coincidence or it is a deliberate and brilliant explanation
of the benefits of the technology.

​EKR mentioned the book on The Box on his blog, I recommended it to my
colleagues at​ VeriSign. I don't know if I mentioned it to Ben Golub though.

Before the shipping container, cargos had to be loaded and unloaded piece
by piece on each ship. Ships spent weeks in port and vast amounts of cargo
was stolen. The shipping container meant that the cargo could be loaded and
unloaded in hours and no 'shrinkage'.

Docker containers are almost the same concept. Instead of loading your
entire application and O/S build onto each machine, you put it into a
'container'.

And the impact of Docker is likely to be very similar. The traditional way
of running a data center meant that the administration staff were often the
only people who understood the hardware/software interdependencies. Moving
a service from one machine to another might take a week as the entire
platform had to be built. Or you ended up standardizing your hardware
platform down to the board revision so that you could image drives and
guarantee that the services would work.

Containers do away with all that by introducing a standardized interface.