Subject: Closing this issue: [netmod] choice/case in tree diagrams (draft-ietf-netmod-yang-tree-diagrams-06)

From: Benoit Claise <[email-masked]>
Date: Tue, 6 Mar 2018 22:49:37 +0100

Dear all,

The document draft-ietf-netmod-yang-tree-diagrams-06 is in AUTH48.
It's time to close this issue, let me copy [email-masked].
If you object to the change below, let me know before the end of the week.

The changes are to the text, so that the text is adapted to what the tools do.  No need to change the examples, or tooling.

OLD:
            <flags> is one of:
            rw  for configuration data
            ro  for non-configuration data, output parameters to rpcs
                and actions, and notification parameters
            -w  for input parameters to rpcs and actions
            -u  for uses of a grouping
            -x  for rpcs and actions
            -n  for notifications
            mp  for nodes containing a "mount-point" extension statement
   NEW:
            <flags> is one of:
            rw  for configuration data- and choice nodes
            ro  for non-configuration data- and choice nodes,
                output parameters to rpcs and actions, and
                notification parameters
            -w  for input parameters to rpcs and actions
            -u  for uses of a grouping
            -x  for rpcs and actions
            -n  for notifications
            mp  for nodes containing a "mount-point" extension statement
              case nodes do not have any <flags>.

and

OLD:

      <name> is the name of the node
        (<name>) means that the node is a choice node
       :(<name>) means that the node is a case node

        If the node is augmented into the tree from another module,
        its name is printed as <prefix>:<name>, where <prefix> is the
        prefix defined in the module where the node is defined.

NEW:

      <name> is the name of the node
        (<name>) means that the node is a choice node
       :(<name>) means that the node is a case node

        If the node is augmented into the tree from another module,
        its name is printed as <prefix>:<name>, where <prefix> is the
        prefix defined in the module where the node is defined.

        If the node is a case node, there is no space before the
        <name>.

Regards, Benoit

> Juergen Schoenwaelder <[email-masked]> writes:
>
>> On Tue, Mar 06, 2018 at 10:44:11AM +0100, Martin Bjorklund wrote:
>>> OLD:
>>>
>>>         <flags> is one of:
>>>           rw  for configuration data
>>>           ro  for non-configuration data, output parameters to rpcs
>>>               and actions, and notification parameters
>>>           -w  for input parameters to rpcs and actions
>>>           -u  for uses of a grouping
>>>           -x  for rpcs and actions
>>>           -n  for notifications
>>>           mp  for nodes containing a "mount-point" extension statement
>>>
>>> NEW:
>>>
>>>         <flags> is one of:
>>>           rw  for configuration data
>>>           ro  for non-configuration data, output parameters to rpcs
>>>               and actions, and notification parameters
>>>           -w  for input parameters to rpcs and actions
>>>           -u  for uses of a grouping
>>>           -x  for rpcs and actions
>>>           -n  for notifications
>>>           mp  for nodes containing a "mount-point" extension statement
>>>
>>>           case nodes do not have any <flags>.
>> I still think that it should be 'data node' instead of just
>> 'data'. While not formally imported, the term 'data node' has a
>> definition in RFC 7950.
>>
>> NEWER:
>>
>>          <flags> is one of:
>>            rw  for configuration data nodes
> If we keep it also for choices, then it has to be "schema nodes".
>
>>            ro  for non-configuration data nodes, output parameters to rpcs
>>                and actions, and notification parameters
> Same here.
>
> Lada
>
>>            -w  for input parameters to rpcs and actions
>>            -u  for uses of a grouping
>>            -x  for rpcs and actions
>>            -n  for notifications
>>            mp  for nodes containing a "mount-point" extension statement
>>
>>            case nodes do not have any <flags>.
>>   
>> /js
>>
>> -- 
>> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
>> Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
>> Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>
>>
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod

---

From: Benoit Claise <[email-masked]>
Date: Sat, 10 Mar 2018 10:06:50 +0100

Thanks all.
This issue is closed and we will apply this change right now, part of 
the AUTH48 process.

Regards, Benoit
> The changes are to the text, so that the text is adapted to what the 
> tools do.  No need to change the examples, or tooling.
>
> OLD:
>            <flags> is one of:
> .