Subject: Looking for appropriate place to ask a DKIM question

From: "Fazzina, Angelo" <[email-masked]>
Date: Mon, 17 Dec 2018 16:31:28 +0000

Please ignore if I posted in the wrong mailing list as I am have trouble find one for DKIM that is active.

Hi, I am trying to test my TXT records for the ability to report failures. Talking about RFC 6651

These are my records

dkim1._domainkey.mta5.uits.uconn.edu    text = "v=DKIM1\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
catzd6/iutxWbAiY51rRAvVdBs2YIoGO6Glzeev66ft8IfMnHgxND438KIsdOjUmJZuglFJUWGzCYDSC1eq/zqDVncFwTxWkKW/qtxQIDAQAB"

_report._domainkey.mta5.uits.uconn.edu  text = "ra=dkim-errors\; rp=100\; rr=all"

Here is a test email sig header
v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu; s=dkim1; t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=; h=To:From:Subject:Date:From; b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=

Here is a test email result header
spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu; uconn.mail.onmicrosoft.com; dkim=fail (invalid public key) header.d=mta5.uits.uconn.edu;uconn.mail.onmicrosoft.com; dmarc=none action=none header.from=appmail.uconn.edu;compauth=pass reason=105

So I can simulate a failure, but cannot seem to get a report emailed to [email-masked]<mailto:[email-masked]> ?

I made sure account exists on server:
[root@mta5 home]# ls -l /home/|grep dkim
drwx------. 2 dkim-errors       dkim-errors         78 Dec 10 16:21 dkim-errors

How often are the failure reports generated ? did not see that mentioned in the RFC's ?

Does anyone see anything obvious that I am doing wrong ?
Thank you.

-ANGELO FAZZINA

ITS Service Manager:
Spam and Virus Prevention
Mass Mailing
G Suite/Gmail

[email-masked]
University of Connecticut,  ITS, SSG, Server Systems
860-486-9075

---

From: Thiago Souza <[email-masked]>
Date: Mon, 17 Dec 2018 14:41:28 -0200

Angelo,

It's DMARC that report failures. Usually daily.

The record for your domain is:
*Type:* TXT
*Host/Name:* _DMARC.mta5.uits.uconn.edu
*Value:* v=DMARC1; p=*none*; rua=mailto:[email-masked];
ruf=mailto:[email-masked]; fo=1

You should be getting e-mails at: [email-masked] and
not  [email-masked].

Thiago

Em seg, 17 de dez de 2018 às 14:32, Fazzina, Angelo <
[email-masked]> escreveu:

> *These are my records*
> dkim1._domainkey.mta5.uits.uconn.edu    text = "v=DKIM1\; k=rsa\;
> p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
>
>
> *Here is a test email sig header*
>
> v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu; s=dkim1;
> t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=;
> h=To:From:Subject:Date:From;
> b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA
> ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0
> 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=
>
>
>
> *Here is a test email result header*
>
> spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu;
> uconn.mail.onmicrosoft.com; dkim=fail (invalid public key) header.d=
> mta5.uits.uconn.edu;uconn.mail.onmicrosoft.com; dmarc=none action=none
> header.from=appmail.uconn.edu;compauth=pass reason=105
>
>
>
>
>
> So I can simulate a failure, but cannot seem to get a report emailed to
> [email-masked] ?
>
>
>
> *I made sure account exists on server:*
>
> How often are the failure reports generated ? did not see that mentioned
> in the RFC’s ?
>
>
>
> *ITS Service Manager:*

---

From: "Fazzina, Angelo" <[email-masked]>
Date: Mon, 17 Dec 2018 16:47:31 +0000

Hi, thank you. I did not realize that RFC 6651 was not being implemented.
I will try to get DMARC working.

Everything I read says get SPF working, then DKIM, then DMARC.  I suppose if DMARC sends reports no need for DKIM to do it as well.

Thanks.

-ANGELO FAZZINA

ITS Service Manager:

[email-masked]

From: Thiago Souza <[email-masked]>
Sent: Monday, December 17, 2018 11:41 AM
To: Fazzina, Angelo <[email-masked]>
Cc: [email-masked]
Subject: Re: Looking for appropriate place to ask a DKIM question

Angelo,

The record for your domain is:
Type: TXT
Host/Name: _DMARC.mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031756120&sdata=Gf6fqKfxSOrYNFZVF3HImgnCyT0v02GcAOTGmznlC9w%3D&reserved=0>
Value: v=DMARC1; p=none; rua=mailto:[email-masked]<mailto:[email-masked]>; ruf=mailto:[email-masked]<mailto:[email-masked]>; fo=1

You should be getting e-mails at: [email-masked]<mailto:[email-masked]> and not  [email-masked]<mailto:[email-masked]>.

Thiago

Em seg, 17 de dez de 2018 às 14:32, Fazzina, Angelo <[email-masked]<mailto:[email-masked]>> escreveu:
Please ignore if I posted in the wrong mailing list as I am have trouble find one for DKIM that is active.

These are my records

dkim1._domainkey.mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdomainkey.mta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031756120&sdata=UpZWSqG0wYsENJKMmP1kzrJpDgp25Tny0X5dxRIfhIk%3D&reserved=0>    text = "v=DKIM1\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC/YIuJIABa9M7Ox5AXs6CP6z26d/i9JDrHW58YU/OzfsEr6yADboIOydCaiiVaNuwtkbx
catzd6/iutxWbAiY51rRAvVdBs2YIoGO6Glzeev66ft8IfMnHgxND438KIsdOjUmJZuglFJUWGzCYDSC1eq/zqDVncFwTxWkKW/qtxQIDAQAB"

_report._domainkey.mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdomainkey.mta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031766125&sdata=a1zC8BIqa13dTZ34VAPdLFKkL86mL%2BUI0qsha%2B2DduI%3D&reserved=0>  text = "ra=dkim-errors\; rp=100\; rr=all"

Here is a test email sig header
v=1; a=rsa-sha256; c=relaxed/simple; d=mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031766125&sdata=hNGzCJr%2Fp3WbNcs%2BsQAbZaNDpoJE2iSvKDjdghQUrhg%3D&reserved=0>; s=dkim1; t=1544820643; r=y; bh=9ZoLOUiYT9ubu7ykLiU305ZLqHeoTNV83po4QgGRepU=; h=To:From:Subject:Date:From; b=uPOMfVq7Ilr0/e2GEwEIiRotuX1gacod2Tmk7c1lfcYUpNTUznjUXPyNidTlbhrLA ylDHc1xE1P/B1NBo0awxBN4Qbwjz8UWUC1vQpQsrenWnhr+Rp46g7KKqWWZ2Sjw0O0 0RV2EF9aD1UP5bd7qLtuQHQ9gye5cVCBv6uVdM7g=

Here is a test email result header
spf=none (sender IP is 137.99.25.249) smtp.mailfrom=appmail.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fappmail.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031776134&sdata=2RrmjKmR4kRF44BmJniJFSzLfhSScIKksT02le3QsB0%3D&reserved=0>; uconn.mail.onmicrosoft.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fuconn.mail.onmicrosoft.com&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031776134&sdata=rrEuSpQOTTo%2F4pUDDU2bNyViSwqn2yqTYPuYs3gBr9Y%3D&reserved=0>; dkim=fail (invalid public key) header.d=mta5.uits.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmta5.uits.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031786143&sdata=60rt%2F147GLBptwLjiDpbNVh7yc6Hb1482h75IqczOiA%3D&reserved=0>;uconn.mail.onmicrosoft.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fuconn.mail.onmicrosoft.com&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031786143&sdata=3XB6VRcQdOc29JP03ey1i2fcQ7K5V9F9zeNP8YZ66PU%3D&reserved=0>; dmarc=none action=none header.from=appmail.uconn.edu<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fappmail.uconn.edu&data=02%7C01%7Cangelo.fazzina%40uconn.edu%7C06dd14dacaa34181c89308d6643e85c2%7C17f1a87e2a254eaab9df9d439034b080%7C0%7C0%7C636806617031796143&sdata=4q9pMQaupxodIZt1mUBksHy8MopZ2Z3yMykZroyGyqU%3D&reserved=0>;compauth=pass reason=105

How often are the failure reports generated ? did not see that mentioned in the RFC’s ?

-ANGELO FAZZINA

ITS Service Manager:

[email-masked]<mailto:[email-masked]>
University of Connecticut,  ITS, SSG, Server Systems
860-486-9075

---

From: Thiago Souza <[email-masked]>
Date: Mon, 17 Dec 2018 14:48:39 -0200

I'm sorry. You do not have a DMARC record. I used a online tool to check,
and it suggested one since you do not have.

Create a record like:

TXT
_DMARC.mta5.uits.uconn.edu

v=DMARC1; *p=none*; rua=[email-masked];
ruf=mailto:[email-masked]; rf=afrf; fo=1; pct=100;
adkim=s; aspf=s

Note the *p=none*, to do not lose any e-mails at first.

After your configuration is checked and correct. Change to quarentine or reject.

And you should get the e-mails.

Thiago

Em seg, 17 de dez de 2018 às 14:41, Thiago Souza <[email-masked]>
escreveu:

> *Value:* v=DMARC1; p=*none*; rua=mailto:
> [email-masked]; ruf=mailto:
> [email-masked]; fo=1
>