Subject: Tsvart last call review of draft-ietf-v6ops-transition-ipv4aas-11

From: Martin Stiemerling <[email-masked]>
Date: Tue, 18 Dec 2018 00:13:28 -0800

Reviewer: Martin Stiemerling
Review result: Ready with Issues

This document has been reviewed as part of the transport area review team's
ongoing effort to review key IETF documents. These comments were written
primarily for the transport area directors, but are copied to the document's
authors and WG to allow them to address any issues raised and also to the IETF
discussion list for information.

When done at the time of IETF Last Call, the authors should consider this
review as part of the last-call comments they receive. Please always CC
[email-masked] if you reply to or forward this review.

General issues:
- I have an issue with using RFC 2119 language in informative RFCs, as it is unclear
what normative language means in informative documents. However, I understand
that there is legacy from older documents in particular, but not limited to, RFC 7084.

- The document is in parts hard to read, even for someone who has a background in
IPv4/IPv6 transition. E.g. Section 1, 2nd paragraph, about what IP version is used
where. A figure could help here. 

Issues: 
- Remove the DEFAULT word and replace it with default. It is very confusing to add
capital letters normative language here. 

- Section 5: UPnP

This section is posing requirements in an IETF document that incorporates non-IETF
standards for a matter that is solely a recommendation. Can this be MUST at all? 

- Section 6: Code Considerations
This section is a collection of unfounded points without any hard proof that the
numbers are correct and tangible. Either there is a hard example on required
changes and added code size or remove it. This is an engineering document and not
a marketing document, isn't it?

Thanks,
 
  Martin Stiemerling

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 18 Dec 2018 10:13:06 +0100

Hi Martin,

Thanks for your review!

I'm working today in a new version including the comments from the SECDIR, OPSDIR and RTGDIR, so definitively will take care as well of your own comments.

Responses below, in-line.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Martin Stiemerling <[email-masked]>
Fecha: martes, 18 de diciembre de 2018, 9:13
Para: <[email-masked]>
CC: <[email-masked]>, <[email-masked]>, <[email-masked]>
Asunto: [v6ops] Tsvart last call review of draft-ietf-v6ops-transition-ipv4aas-11

    
    
    General issues:

I think if we accepted this format, which in my opinion, even in an informative RFC, is very clarifying about what is expected from an implementor of this document, should not change our view now, unless we decide to review this in all the documents and from now on. In our case we have a "Special Note" in the section title, to remark it.

Good point, definitively will include a small figure.
    
    Issues: 

As we have defined the "DEFAULT" word in the requirements language as well, I think it is a correct usage, in order to make it easy to differentiate it from other usages of "default" across the document.
    
    - Section 5: UPnP

Not exactly, we are defining how the CE should react in a specific situation, but in my understanding,  this is not changing the UPnP specifications. We had long debates on this in v6ops before reaching consensus this concrete text.

I guess you meant here section 7. This is based on practical experience with OpenWRT and with co-authors (vendors), so very tangible, and it can be confirmed if you look at the source code. I don't think is right to have references to each of the code pieces for each transition mechanism and how they share "code parts", it will become a long document. Instead there is reference to the OpenWRT page with all the packages which allows to check exact code size if you start adding one or several mechanisms.
    
    Thanks,
     
      Martin Stiemerling

    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.