Subject: Genart last call review of draft-ietf-idr-te-pm-bgp-15

From: Erik Kline <[email-masked]>
Date: Wed, 12 Dec 2018 23:30:26 -0800

Reviewer: Erik Kline
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-idr-te-pm-bgp-??
Reviewer: Erik Kline
Review Date: 2018-12-12
IETF LC End Date: 2018-12-12
IESG Telechat date: Not scheduled for a telechat

Summary: Seems like a fairly straightforward detailing of TLVs the meanings of
which are defined elsewhere.

Major issues:  [obvious] A primary normative reference is itself still a draft.
 I expect they'll get published together.

Minor issues: None.

Nits/editorial comments: Some wording on Section 3 could use some readability
cleanup, perhaps.

[1] "represent the state and resources availability" does not somehow scan well
for me. "state and resource availability"? "state and availability of
resources"?

[2] "are assumed to have all the required security and authentication
mechanism" also seems like it could read more smoothly.  "are assumed to have
implemented all require security and authentication mechanisms..."?

I'm sure the editors will have better ideas.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 13 Dec 2018 08:26:09 +0000

Erik -

Thanx for the review.
Responses inline.

> -----Original Message-----
> From: Erik Kline <[email-masked]>
> Sent: Wednesday, December 12, 2018 11:30 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Genart last call review of draft-ietf-idr-te-pm-bgp-15
> 
> Reviewer: Erik Kline
[Les:] The reference to draft-ietf-lsr-isis-rfc7810bis (rather than current RFC7810) was put in at the request of the AD. 
You are correct that this introduces a dependency between this document and 7810bis and this document will remain in MISSREF state until 7810bis is published.
As both drafts are in the review process we do not expect there to be a significant delay.

In any case this isn't a "major" issue is it? It seems worthwhile to have the reference be to the newer version of 7810 - and this certainly isn’t the only case where one document is dependent on another which has yet to be published.

> for me. "state and resource availability"? "state and availability of
[Les:] "state and resource availability" is fine with me.

> implemented all require security and authentication mechanisms..."?
[Les:] How about "assumed to support all the required..."
??

If you are OK with the suggestions I will publish an updated version very soon.

   Les

---

From: Erik Kline <[email-masked]>
Date: Thu, 13 Dec 2018 14:12:51 -0800

On Thu, 13 Dec 2018 at 00:26, Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> > Summary: Seems like a fairly straightforward detailing of TLVs the
> meanings
> > of
> [Les:] The reference to draft-ietf-lsr-isis-rfc7810bis (rather than
> current RFC7810) was put in at the request of the AD.
> You are correct that this introduces a dependency between this document
> and 7810bis and this document will remain in MISSREF state until 7810bis is
> published.
> In any case this isn't a "major" issue is it? It seems worthwhile to have
> the reference be to the newer version of 7810 - and this certainly isn’t
> the only case where one document is dependent on another which has yet to
> be published.
>
>
>
Not a major issue for me; I marked the document as Ready with Nits.  I just
felt like "major" was the section where this trivially obvious observation
would belong.

> > [1] "represent the state and resources availability" does not somehow
> scan
> > well
Anything is fine. I think it just read ~funny~ to me, grammatically.
"assumed to meet all security and authentication requirements", sounds
good.