Subject: Genart telechat review of draft-ietf-ntp-bcp-10

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Dec 2018 15:12:12 -0800

Reviewer: Robert Sparks
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-ntp-bcp-10
Reviewer: Robert Sparks
Review Date: 2018-12-13
IETF LC End Date: 2018-10-08
IESG Telechat date: 2018-12-20

Summary: Ready (but with nits that should be considered) for publication as a
BCP RFC

Nits/editorial comments:

With a couple of exceptions, the changes between -07 and -10 are very helpful -
the document reads much more naturally.

One of the changes was to be more specific with actors - many uses of "you" or
"your" were replaced with "the operator" for example. But this wasn't done
throughout the document ("you" and "your" still appear frequently), and in at
least one place the change caused a sentence to stop making sense: "If the time
on your network has to be correct close to 100% of the time, then even if you
are using a satellite-based system, operators need to plan for those rare
instances when the system is unavailable (or wrong!)."

I strongly encourage yet another pass focusing on removing "you" and "your" to
the extent possible.

The changes also included using 2119 keywords much more often. Unfortunately
many of the new uses are not appropriate. "Vendors MUST" and several instances
of "It is RECOMMENDED" are particularly jarring. Moving 2119 to be an
Informational reference is also incorrect if you are going to use those terms
in this document.

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 17 Dec 2018 10:51:56 +0100

>>> Robert Sparks <[email-masked]> schrieb am 14.12.2018 um 00:12 in
Nachricht <[email-masked]>:
> I am the assigned Gen‑ART reviewer for this draft. The General Area
> Review Team (Gen‑ART) reviews all IETF documents being processed
> Document: draft‑ietf‑ntp‑bcp‑10
> Reviewer: Robert Sparks
> Review Date: 2018‑12‑13
> IETF LC End Date: 2018‑10‑08
> IESG Telechat date: 2018‑12‑20
> 
> Summary: Ready (but with nits that should be considered) for publication as

> a
> BCP RFC
> 
> Nits/editorial comments:
> 
> With a couple of exceptions, the changes between ‑07 and ‑10 are very
helpful ‑
> One of the changes was to be more specific with actors ‑ many uses of "you"

> or
> are using a satellite‑based system, operators need to plan for those rare

Independent of the "you issue", I think the sentence ("If the time on your
network
has to be correct close to 100% of the time, then even if you are using a
satellite-based system, operators need to plan for those rare instances when
the system is unavailable (or wrong!).") is too complicated anyway. Maybe it's
as simple as "Operators should be aware that even high quality time sources may
fail."

> 
> I strongly encourage yet another pass focusing on removing "you" and "your"

> to
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 18 Dec 2018 15:23:56 -0500

Robert, thanks for your reviews of this document. I’ve flagged some of your specific comments in my ballot. I entered a DISCUSS ballot to ensure that RFC 2119 and RFC 8174 get changed to normative references.

Thanks,
Alissa

> On Dec 13, 2018, at 6:12 PM, Robert Sparks <[email-masked]> wrote:
> 
> Reviewer: Robert Sparks
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Denis Reilly <[email-masked]>
Date: Wed, 19 Dec 2018 20:32:17 +0000

Hello, Robert! Thanks for your review.

Your comments prompted one more read-through of the draft, with specific attention to your points, both to be more specific with actors and to refine the 2119 keywords. Karen O'Donoghue has been very helpful in helping us sort this out, and you can expect everything to be tighter in the next revision.

Also, your point specifically about the sentence
"If the time
on your network has to be correct close to 100% of the time, then even if you
are using a satellite-based system, operators need to plan for those rare
instances when the system is unavailable (or wrong!)."

We plan on changing this to:
Depending on the application requirements, operators may need to consider backup scenarios in the rare circumstance when the satellite system is faulty or unavailable.

Best Regards,

--
Denis Reilly  |  Technical Lead  |  [email-masked]  (585)321-5837

-----Original Message-----
From: Robert Sparks <[email-masked]> 
Sent: Thursday, December 13, 2018 6:12 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Genart telechat review of draft-ietf-ntp-bcp-10

Reviewer: Robert Sparks

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Summary: Ready (but with nits that should be considered) for publication as a BCP RFC

Nits/editorial comments:

With a couple of exceptions, the changes between -07 and -10 are very helpful - the document reads much more naturally.

One of the changes was to be more specific with actors - many uses of "you" or "your" were replaced with "the operator" for example. But this wasn't done throughout the document ("you" and "your" still appear frequently), and in at least one place the change caused a sentence to stop making sense: "If the time on your network has to be correct close to 100% of the time, then even if you are using a satellite-based system, operators need to plan for those rare instances when the system is unavailable (or wrong!)."

I strongly encourage yet another pass focusing on removing "you" and "your" to the extent possible.

The changes also included using 2119 keywords much more often. Unfortunately many of the new uses are not appropriate. "Vendors MUST" and several instances of "It is RECOMMENDED" are particularly jarring. Moving 2119 to be an Informational reference is also incorrect if you are going to use those terms in this document.

ATTENTION: This email came from an external source.
Do not open attachments or click on links from unknown senders or unexpected emails.