Subject: RE: [ifmib] Configuration of an IP address

From: Dan Romascanu <[email-masked]>
Date: Tue, 10 Oct 2000 11:22:34 +0200

Just for the seek of statistics ... can we have a 'show of hands' about how
many vendors implement extensions in their proprietary MIBs, which allow for
SNMP configuration of the IP addresses at least on part of the interfaces?

One hand is already up.

Regards,

Dan

> -----Original Message-----
> From:	Keith McCloghrie [SMTP:[email-masked]]
> Sent:	Tue October 10 2000 3:08
> To:	[email-masked]
> Cc:	[email-masked]; [email-masked]
> Subject:	Re: [ifmib] Configuration of an IP address
> 
> > we would like to ask a clarification about how it is possible to 
> > configure the IP address of an interface.
> > 
> > Looking at the IP-MIB (RFC 2011), there is a table that associate to an 
> > IP address the corresponding interface's ifIndex. Unfortunately, this 
> > IP address is the index of the table, and the RowStatus is missing.
> > 
> > In the IF-MIB there is no object where we can configure the interface's 
> > IP address.
>  
> All information in the IF-MIB is below layer-3, and so it would not be
> appropriate to have IP-addresses in the IF-MIB.
> 
> RFC 2011's ipAddrTable was originally defined in MIB-I (RFC 1066) and
> has always been read-only, and there's has never been any strong demand
> to provide a read-create capability.  My theory for the lack of such
> demand is because configuring IP addresses via SNMP is problematic: if
> the system is a host which only has one IP address, then it can't be
> configured by SNMP (over UDP/IP) until it already has an IP address: a
> chicken-and-egg scenario; even if the system is a router, with an IP
> address on each interface, it would not be possible to configure all
> of its addresses via SNMP.
> 
> Keith.
> 
> _______________________________________________
> ifmib mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/ifmib

_______________________________________________
ifmib mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ifmib

---

From: Ilana Schvetz <[email-masked]>
Date: Tue, 10 Oct 2000 11:44:26 +0200

Hi,
I've added a host IP interface table, but the purpose was different: we 
enable the user to determine more than one host interface IP per device.

Best Regards,

> > of its addresses via SNMP.

  Ilana Schvetz
   RAD Data Communications LTD.
   Network Management System: SW Requirements Engineer
   E-mail: [email-masked]
   Tel: 972-3-765-7549
   Fax: 972-3-644-0930

---

From: Ilana Schvetz <[email-masked]>
Date: Tue, 10 Oct 2000 14:21:53 +0200

sure,

>From: Dan Romascanu <[email-masked]>
>To: 'Ilana Schvetz' <[email-masked]>
>Subject: RE: [ifmib] Configuration of an IP address
>Date: Tue, 10 Oct 2000 12:55:49 +0200
>X-Mailer: Internet Mail Service (5.5.2650.21)
>
>Thanks. Can you clarify this to the list? (it was not clear for me at
>least).
>
>Regards,
>
>Dan
>
>
> > From: Ilana Schvetz [SMTP:[email-masked]]
> > Sent: Tue October 10 2000 12:14
> > To:   Dan Romascanu
> > Subject:      RE: [ifmib] Configuration of an IP address
> >
> > Hi Dan,
> > It is read/create. As I've wrote, the user is allowed to add entries to
> > the
> > table, which are IP interface of the managed device.
> >
> > Bye,
> >
> >
> > At 12:00 10/10/2000 +0200, you wrote:
> > >Ilana,
> > >
> > >Is this table read-only or does it allow for the creation/configuration
> > of
> > >new interfaces?
> > >
> > >Dan
> > >
> > >
> > > > From: Ilana Schvetz [SMTP:[email-masked]]
> > > > Sent: Tue October 10 2000 11:44
> > > > To:   Dan Romascanu
> > > > Cc:   [email-masked]
> > > > Subject:      RE: [ifmib] Configuration of an IP address
> > > >
> > > > Hi,
> > > > >Just for the seek of statistics ... can we have a 'show of hands'
> > about
> > > > how
> > > > >many vendors implement extensions in their proprietary MIBs, which
> > allow
> > > > for
> > > > > > > Looking at the IP-MIB (RFC 2011), there is a table that
> > associate to
> > > > an

  Ilana Schvetz