Subject: RE: [ifmib] Configuration of an IP address

From: Dan Romascanu <[email-masked]>
Date: Tue, 10 Oct 2000 12:00:45 +0200

Ilana,

Is this table read-only or does it allow for the creation/configuration of
new interfaces?

Dan

> -----Original Message-----
> From:	Ilana Schvetz [SMTP:[email-masked]]
> Sent:	Tue October 10 2000 11:44
> To:	Dan Romascanu
> Cc:	[email-masked]
> Subject:	RE: [ifmib] Configuration of an IP address
> 
> Hi,
> I've added a host IP interface table, but the purpose was different: we 
> enable the user to determine more than one host interface IP per device.
> 
> Best Regards,
> 
> 
> 
> At 11:22 10/10/2000 +0200, you wrote:
> >Just for the seek of statistics ... can we have a 'show of hands' about
> how
> >many vendors implement extensions in their proprietary MIBs, which allow
> for
> >SNMP configuration of the IP addresses at least on part of the
> interfaces?
> >
> >One hand is already up.
> >
> >Regards,
> >
> >Dan
> >
> >
> > > -----Original Message-----
> > > From: Keith McCloghrie [SMTP:[email-masked]]
> > > Sent: Tue October 10 2000 3:08
> > > To:   [email-masked]
> > > Cc:   [email-masked]; [email-masked]
> > > Subject:      Re: [ifmib] Configuration of an IP address
> > >
> > > > we would like to ask a clarification about how it is possible to
> > > > configure the IP address of an interface.
> > > >
> > > > Looking at the IP-MIB (RFC 2011), there is a table that associate to
> an
> > > > IP address the corresponding interface's ifIndex. Unfortunately,
> this
> > > > IP address is the index of the table, and the RowStatus is missing.
> > > >
> > > > In the IF-MIB there is no object where we can configure the
> interface's
> > > > IP address.
> > >
> > > All information in the IF-MIB is below layer-3, and so it would not be
> > > appropriate to have IP-addresses in the IF-MIB.
> > >
> > > RFC 2011's ipAddrTable was originally defined in MIB-I (RFC 1066) and
> > > has always been read-only, and there's has never been any strong
> demand
> > > to provide a read-create capability.  My theory for the lack of such
> > > demand is because configuring IP addresses via SNMP is problematic: if
> > > the system is a host which only has one IP address, then it can't be
> > > configured by SNMP (over UDP/IP) until it already has an IP address: a
> > > chicken-and-egg scenario; even if the system is a router, with an IP
> > > address on each interface, it would not be possible to configure all
> > > of its addresses via SNMP.
> > >
> > > Keith.
> > >
> > > _______________________________________________
> > > ifmib mailing list
> > > [email-masked]
> > > http://www1.ietf.org/mailman/listinfo/ifmib
> >
> >_______________________________________________
> >ifmib mailing list
> >[email-masked]
> >http://www1.ietf.org/mailman/listinfo/ifmib
> 
> 
> 
> 
>   Ilana Schvetz
>    RAD Data Communications LTD.
>    Network Management System: SW Requirements Engineer
>    E-mail: [email-masked]
>    Tel: 972-3-765-7549
>    Fax: 972-3-644-0930 

_______________________________________________
ifmib mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ifmib

---

From: Jon Saperia <[email-masked]>
Date: Tue, 10 Oct 2000 08:11:08 -0400

> Is this table read-only or does it allow for the creation/configuration of

Dan, I know of at least 3 vendors that are doing this now with more on the
way. Though I am sure there are others that are in announced products I do
no know their names. They will have to 'raise their own hands.'

/jon