Subject: [IEE] We're now a working group....

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 17 Mar 2006 16:24:13 +0100

As you saw from today's announcement, we are now officially a working group.

This doesn't make much of a practical difference - but it DOES mean that we 
don't have to discuss what the WG should do any more; we can concentrate on 
doing it.

See a lot of you in Dallas!

                   Harald

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Martin Duerst <[email-masked]>
Date: Sun, 19 Mar 2006 16:38:35 +0900

Hello Harald,

Great! Thanks for all your work.

Any chance that we can reduce the number of acronyms from three
(ima, iee, eai) to two (ima, eai)?

Regards,    Martin.

At 00:24 06/03/18, Harald Tveit Alvestrand wrote:
 >This doesn't make much of a practical difference - but it DOES mean that 
we don't have to discuss what the WG should do any more; we can concentrate 
on doing it.

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 19 Mar 2006 14:00:21 +0100

> (ima, iee, eai) to two (ima, eai)? 
don't forget i18mail, imaa and a lot of other acronyms that have been 
used..... I think we could rename the mailing list in addition to 
changing the subject tag, leaving us with eai as the name for the effort.

I have a linking for i18mail as a name for the technology, since that's 
easier to remember - EAI has zero mnemonic value....

             Harald

---

From: Yangwoo Ko <[email-masked]>
Date: Sun, 19 Mar 2006 22:34:12 +0900

Harald Alvestrand wrote:
> I have a linking for i18mail as a name for the technology, since 
> that's easier to remember - EAI has zero mnemonic value....
To make the matters worse, EAI is fairly commonly used as an acronym
of Enterprise Application Integration.

---

From: Eric Brunner-Williams <[email-masked]>
Date: Sun, 19 Mar 2006 11:10:39 -0500

unfortunately, "i18" as in "i18n" isn't technology specific.

as this w.g. is, of necessity, being an ietf chartered w.g., it is technology
specific.

a meaningless name is better than one that means something that isn't what
is actually ment.

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 19 Mar 2006 10:14:34 -0600

> a meaningless name is better than one that means something that isn't what
i18mail is somewhat technology specific...

---

From: John C Klensin <[email-masked]>
Date: Sun, 19 Mar 2006 12:15:20 -0500

--On Sunday, March 19, 2006 10:14 -0600 Harald Alvestrand 
<[email-masked]> wrote:

>> as this w.g. is, of necessity, being an ietf chartered w.g.,
>> it is technology specific.
>>
>> a meaningless name is better than one that means something
>> that isn't what is actually ment.

and, if it doesn't violate some Secretariat length-of-name rule, 
"i18nemail" is even more so.

    john

---

From: John C Klensin <[email-masked]>
Date: Sun, 19 Mar 2006 15:27:57 -0500

--On Sunday, March 19, 2006 14:00 +0100 Harald Alvestrand 
<[email-masked]> wrote:

>> Any chance that we can reduce the number of acronyms from
>> three (ima, iee, eai) to two (ima, eai)?
> don't forget i18mail, imaa and a lot of other acronyms that
> have been used..... I think we could rename the mailing list
> in addition to changing the subject tag, leaving us with eai
> as the name for the effort.
>
> I have a linking for i18mail as a name for the technology,
> since that's easier to remember - EAI has zero mnemonic
> value....

And some name-conflict issues as well.  Entering "EAI" into 
Google is enlightening and a fairly good argument for something 
else.  And my candidate at this point is i18nmail or i18nemail 
(no preference between them).

     john

---

From: Yangwoo Ko <[email-masked]>
Date: Tue, 21 Mar 2006 07:24:39 +0900

As pointed out in our framework document, we need to cleanup 
terminologies quite soon. Let me start to roll the ball.

1. Name for working scope -- (E)mail i18n vs. (e)mail address i18n vs. EAI

The scope of work we are doing is (e)mail address i18n. However, current 
approach requires more than that (e.g. utf-8 encoding support at 
headers). Thus we may call it (e)mail i18n. However, this seems to be 
broader than what we are actually doing. I will choose (without any 
preference) to use EAI in the following paragraphs.

2. Name for resulting addresses -- IMA vs. i18(n)(e)mail address

These are names for (e)mail addresses that are EAI-compliant. These 
addresses include old ASCII only addresses as well. At least for me (non 
English native), internationalized email address sound more natural than 
internationalization email address. Since I don't have any idea how to 
make "internationalized email address" shorter, I prefer to use IMA. (IEA?)

3. Name for resulting things (except addresses)

For example, what will be the name for EAI-compliant mail contents? We 
may call them as internationalized mail contents though it is still 
broader than wanted.

4. Others

There are several other terminologies (e.g. all-ASCII address) used in 
the documents discussed in this WG. I hope that if there were consensus 
on above terms, it could be easier to generate other terms based on them.

Regards

---

From: John C Klensin <[email-masked]>
Date: Mon, 20 Mar 2006 17:37:28 -0500

--On Tuesday, March 21, 2006 07:24 +0900 Yangwoo Ko 
<[email-masked]> wrote:

> The scope of work we are doing is (e)mail address i18n.
> However, current approach requires more than that (e.g. utf-8
> encoding support at headers). Thus we may call it (e)mail
> i18n. However, this seems to be broader than what we are
> actually doing. I will choose (without any preference) to use
> EAI in the following paragraphs.

Hmm.  One of the points you make below suggests i15demail :-)

> These are names for (e)mail addresses that are EAI-compliant.
> These addresses include old ASCII only addresses as well. At
> least for me (non English native), internationalized email
> address sound more natural than internationalization email
> address. Since I don't have any idea how to make
> "internationalized email address" shorter, I prefer to use
> IMA. (IEA?)

i15dEA?

> For example, what will be the name for EAI-compliant mail
> contents? We may call them as internationalized mail contents
> though it is still broader than wanted.

MIME non-ASCII body parts?    And note, following a piece of the 
apps area discussion this morning, that content 
internationalization applies only to text/ body parts.

> 4. Others
>
> There are several other terminologies (e.g. all-ASCII address)
> used in the documents discussed in this WG. I hope that if
> there were consensus on above terms, it could be easier to
> generate other terms based on them.

Clearly, I am sympathetic to the problem, I just don't know 
quite what to do about it.  I am, however, resistant to using 
abbreviations or acronyms that have specific and widely-used 
meanings elsewhere.

regards,
     john