Subject: Re: [EAI] Comments on draft-yao-ima-smtpext-02.txt

From: "YAO Jiankang" <[email-masked]>
Date: Tue, 4 Apr 2006 10:48:11 +0800

----- Original Message ----- 
From: "Alexey Melnikov" <[email-masked]>
To: <[email-masked]>
Sent: Monday, April 03, 2006 2:07 AM
Subject: [EAI] Comments on draft-yao-ima-smtpext-02.txt

> Hi,
> I have a couple of comments on draft-yao-ima-smtpext-02.txt. (Please 
> kindly point me to the archive if this was already discussed)

thanks a lot. comments below.
> 
> 1) I think the document needs to describe its interaction with the DSN 
> SMTP extension, for example, what should be put into ORCPT parameter on 
> forwarding to a single recipient alias, when the next hop supports both 

I have read through the SMTP DSN extensions[RFC3461] in detail.
It seems that  IMA address will have influence on many email related RFC documents.
RFC3461 is one of them. is it good that this problem is described or specified in other documents.
in next version of ima-smtpext, we may refer this problem.

> the IEmail and the DSN SMTP extensions. I.e. should it be the downgraded 
> address or the I18N address?

for IMA capablility smtp servers, should use I18N address.
for non-IMA capability smtp servers, may downgrade address.

> 
> 2). The WG should discuss if changes to Delivery Status Notification 
> format are in scope for the WG, in particular extensions to allow for 
> I18N addresses. This ties to John's comment about bounces containing 
> addresses which are not meaningful for the sender.

yes, may consider. but currently, we may considr the main problem of this WG first.

> 
> 3). (Ignoring for the moment the discussion about whether ATOMIC should 
> be removed from the spec or not) Minor comment about the ATOMIC 
> parameter name. I think "ATOMIC" as a parameter name is misleading, as 
> it brings associations with [database] transaction atomicity, maybe 
> something like "AUTODERIVED" would be better.

we may consider "ATOMIC" as flag. if "ATOMIC"  flag is set, it means that it can be downgraded. otherwise, not.

> 
> Also, there are a couple of places where ATOMIC is misspelled as ATMOIC.

thanks. we will correct it in the next version.

> 
> Regards,
> Alexey
> 
> 
> 
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ima
> 

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 06 Apr 2006 18:39:24 +0100

>in next version of ima-smtpext, we may refer this problem.
Sounds good. A short sentence saying that this is a work to be done 
would suffice for now.

>for non-IMA capability smtp servers, may downgrade address.
The document can't just say that it changes email addresses in all other 
SMTP extensions to be I18N. It needs to examine interaction with such 
SMTP extensions and update them.