Subject: [EAI] help to define Ucharacter and sub-domain by ABNF

From: "YAO Jiankang" <[email-masked]>
Date: Fri, 28 Apr 2006 11:14:40 +0800

Dear all,
   
    Could some kind experts help to refine the below definition of Ucharacter and sub-domain by ABNF in the IMA SMTP extension document?
   It seems  not easy to find a very good appropriate definition.

  thanks a lot.

--------------------------------------------------------------------------  

 According to the description above, define the syntax of an IMA
   mailbox with ABNF [RFC4234] as

         Mailbox = Local-part "@" Domain

         Local-part = Dot-string / Quoted-string
               ; MAY be case-sensitive

         Dot-string = Atom *("." Atom)

         Atom = 1*Ucharacter
         Ucharacter = <any UNICODE character,
             except ASCII characters that are not permitted in "atext" and characters that can not pass Stringprep>

         Quoted-string = DQUOTE *qcontent DQUOTE

         Domain = (sub-domain 1*("." sub-domain)) / address-literal
         sub-domain = Let-dig [Ldh-str] /
             <any internationalized domain label specified by IDNA>

YAO Jiankang
Best Regards
Tel:86-10-58813007
Fax:86-10-62559892
--------------------------------------------------
China Internet Network Information Center (CNNIC)
4, South 4th Street, Zhongguancun,
Haidian district,
Beijing 100080, China
POB: Beijing 349, Branch 6
http://www.cnnic.cn
Email: [email-masked]
[email-masked]
_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: "Jeff Yeh" <[email-masked]>
Date: Fri, 28 Apr 2006 13:39:08 +0800

Frank Ellermann had reference some nice ABNF in RFC 4282 in earlier post
http://www1.ietf.org/mail-archive/web/ima/current/msg00129.html.
Maybe we can start from that. 

Jeff

  _____  

From: YAO Jiankang [mailto:[email-masked]] 
Sent: Friday, April 28, 2006 11:15 AM
To: [email-masked]
Subject: [EAI] help to define Ucharacter and sub-domain by ABNF

Dear all,
   
    Could some kind experts help to refine the below definition of
Ucharacter and sub-domain by ABNF in the IMA SMTP extension document?
   It seems  not easy to find a very good appropriate definition.
 
  thanks a lot.

 

         Atom = 1*Ucharacter
         Ucharacter = <any UNICODE character,
             except ASCII characters that are not permitted in "atext" and
characters that can not pass Stringprep>

YAO Jiankang
Best Regards
Tel:86-10-58813007
Fax:86-10-62559892