Subject: [EAI] Proposed Received header "for" clause encodings

From: [email-masked]
Date: Thu, 11 May 2006 14:07:36 +0900 (JST)

Proposed Received header "for" clause encodings

There are 4 encoding idea.

Terminology:
	ima:		utf8@utf8
	ascii-address:	ascii mail address (RFC2821)
	alt-ascii:	ascii address which is specified by ALT-ADDR parameter
	atomic-ascii:	ascii address which is converted from ima
			  with punycode and IDNA. (punycode@IDNA)

(1) not use "for" when the address is non-ASCII
	for ascii-address		without ima
	<empty>				with ima

(2) for ima (Alt-Addr + Atomic information)
	for ascii-address		without ima
	for ima (ALT-ADDR alt-ascii)	ima with ALT-ADDR
	for ima (ATOMIC y)		ima with ATOMIC y
	for ima				ima without ALT-ADDR, ATOMIC

(3) for ascii-address (ima)
	for ascii-address		without ima
	for alt-ascii (ima)		ima with ALT-ADDR
	for atomic-ascii (ima)		ima without ALT-ADDR, with ATOMIC y
	for (ima)			ima without ALT-ADDR, without ATOMIC

(4) for ascii-adress (toascii_conversion of ima)
    a variation of (3), comment field is always converted to ascii.

toascii_conversion method needs more consideration.
it is used in (4) and downgrading with header conversion method.
	RFC2047@IDNA:	using RFC2047 before @, IDNA punycode after @
	RFC2047:	using RFC2047 entire ima
	pynycode@IDNA:	using punycode before @, IDNA punycode after @

--
Kazunori Fujiwara, JPRS

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 11 May 2006 08:18:29 +0200

A very good presentation of alternatives. I hope we can discuss the 
tradeoffs more in Beijing.

One nit:

>	for (ima)			ima without ALT-ADDR, without ATOMIC
in the last case, I think it has to be "(for ima)" to be syntactically 
valid - the syntax does not allow a missing address after the "for" keyword.

                  Harald

---

From: [email-masked]
Date: Fri, 12 May 2006 18:53:54 +0900 (JST)

> From: Harald Alvestrand <[email-masked]>

> valid - the syntax does not allow a missing address after the "for" keyword.

I understand. "(for ima)" may be ID field's CFWS in the ABNF.

--
Kazunori Fujiwara, JPRS