Subject: [EAI] ISSUE: smtpext-08 2.4 ABNF

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 24 Sep 2007 12:50:35 +0200

2.4: Two ABNF oddities:

-|  "RCPT TO:" ("<Postmaster@" domain ">" / "<Postmaster>" /
 |            uForward-Path) [ SP Rcpt-parameters ] CRLF
+|  "RCPT TO:" ("<Postmaster@" uDomain ">" / "<Postmaster>" /
 |            uForward-Path) [ SP Rcpt-parameters ] CRLF

-| ALT-ADDRESS-parameter="ALT-ADDRESS=" ALT-ADDRESS-esmtp-value
 |
-| ALT-ADDRESS-esmtp-value=xtext

That's hard to read. Proposal:

+| Alt-address-parameter = "ALT-ADDRESS=" Alt-address-value
 |
+| Alt-address-value     = xtext

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 27 Sep 2007 15:10:56 +0200

I'm classifying this issue as editorial; I don't think making the 
handling of domainname different in the special case of "postmaster" was 
the intention at any point, and the other one doesn't seem to be a 
protocol change.

Both changes are a good idea, in my opinion.

Good catch!