Subject: [EAI] ISSUE: dsn-03 utf8-text

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 24 Sep 2007 22:36:38 +0200

| utf8-text = %d1-9 /      ; Any Unicode character except for NUL,
|             %d11 /       ; CR and LF, encoded in UTF-8
|             %d12 /
|             %d14-127 /
|             UTFMB
|| UTFMB   = UTF2 / UTF3 / UTF4I don't like this, it allows NO-WS-CTL.  And the "UTFMB" isn'tused elsewhere.  How about this:utf8-text = SP / VCHAR / UTF2 / UTF3 / UTF4 Frank 

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 24 Sep 2007 23:47:41 +0200

Frank Ellermann has to learn how to tame OE, sorry, next attempt:

| utf8-text = %d1-9 /      ; Any Unicode character except for NUL,
|             %d11 /       ; CR and LF, encoded in UTF-8
|             %d12 /
|             %d14-127 /
|             UTFMB
|
| UTFMB   = UTF2 / UTF3 / UTF4

I don't like this, it allows NO-WS-CTL.  And the "UTFMB" isn't
used elsewhere.  How about this:

  utf8-text = SP / VCHAR / UTF2 / UTF3 / UTF4

 Frank

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 27 Sep 2007 15:55:48 +0200

I have recorded this as issue #1507, and given it the title

UTF8HDR/DSN: Remove NO-WS_CTL from specification?

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 27 Sep 2007 20:01:08 +0100

>  utf8-text = SP / VCHAR / UTF2 / UTF3 / UTF4
No HTAB then ;-)?

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 27 Sep 2007 22:16:38 +0200

> No HTAB then ;-)?

...oops :-)  Please s/SP/WSP/ for this proposal.  

If the utf8header I-D gets rid of utf8-quoted-pair
it doesn't need its own utf8-text anymore.

Therefore you could use a simplfied utf8-text for
your purposes (the localized diagnostics) without
fearing a conflict with the utf8header definition.

 Frank