Subject: Re: [EAI] mailto:

From: Shawn Steele <[email-masked]>
Date: Wed, 5 Aug 2009 07:23:47 +0000

I'm out of the office and didn't have network access.

Specifically I meant that I don't think the <> downgrade syntax is helpful in mailto: since nobody's enabled by it and anyone that was updated to understand the <> in mailto: wouldn't need the downgrade for mailto:.

In downgraded headers <> could be interesting, except as mentioned earlier that there are few scenarios where downgraded headers are actually round-tripped an made use of.

-Shawn

Message: 4
Date: Mon, 27 Jul 2009 11:47:39 +0100
From: "Charles Lindsey" <[email-masked]>
Subject: Re: [EAI] mailto: was RE:  Rechartering
To: IMA <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; format=flowed; delsp=yes; charset=iso-8859-1

On Fri, 24 Jul 2009 05:48:35 +0100, Shawn Steele
<[email-masked]> wrote:

> I actually find the < > downgrade syntax fairly unlikely to be helpful.
> Presumably your mail server understands the complete EAI syntax since
> you're providing both addresses.  Likewise my client knows about EAI if
> it understands <unicode <ASCII>>.  So pretty much the only place that
> <unicode <ASCII>> is going to gain anything is when my mail server is
> not EAI aware, but my client and your server are EAI aware.  It seems
> more likely to me that my server and client would both be EAI aware.
> So, to me, the most likely scenarios would be when some in-between relay
> wasn't EAI aware, yet any such sender or receiver side relay would
> necessarily be EAI aware.  Relays that aren't tightly coupled with the
> sender/receiver side tend to be blacklisted anyway.

> But the in-between server has no business looking at the headers inside
> the message, so it should not care is they contain To: <...<...>>. The

---

From: John C Klensin <[email-masked]>
Date: Wed, 05 Aug 2009 04:33:47 -0400

--On Wednesday, 05 August, 2009 07:23 +0000 Shawn Steele
<[email-masked]> wrote:

>...

> Specifically I meant that I don't think the <> downgrade
> syntax is helpful in mailto: since nobody's enabled by it and
> anyone that was updated to understand the <> in mailto:
> wouldn't need the downgrade for mailto:.

I think this (your observation and that from Charles) is a
corollary of some growing concern about forward-pointing
addresses and downgrade... see Ernie's recent note.  I also
observe that, for mailto, there is an already-deployed
alternative for two-address mailto.  We see it all the time in
messages and text, usually as

    mailto:[email-masked]  or mailto:[email-masked]

or even

    mailto:[email-masked]  (preferred) or mailto:[email-masked]

if one of them contains non-ASCII elements, e.g., 

    mailto:[email-masked]  or
      mailto:[email-masked]

nothing is lost and some small bits are gained.

That also suggests a way to do forward-pointing robustness on an
individual message basis.  Again, it is an extension of
something common.   Suppose I have two addresses for you,
[email-masked] and a hotmail address,
[email-masked] (I am obviously just making up the
second).  I know you are taking some vacation, I want to be sure
to reach you, but I don't know which one you are most likely to
read and don't even know if you are still maintaining the
hypothetical hotmail account.  To maximize the odds of something
getting through, I send the message to one address, copying the
other.  If one message gets through and the other bounces, no
problem.  The worst case is that you get two copies and I
apologize later.  On that model, the header syntax for
forward-pointing alternate addresses (without all of the
complications of downgrading) is 

   To; [email-masked]
   cc: [email-masked]

The EAI alternative is obvious.  

What disappears is the complexity of downgrading those
addresses, the security and other concerns about linked
alternative addresses (the linkage here is entirely in the mind
of the sender) and the need to change infrastructure -- not only
the <... <...>> form, but address book formats, message store
formats, etc.-- to accommodate the formal alternate addresses.

> In downgraded headers <> could be interesting, except as
> mentioned earlier that there are few scenarios where
> downgraded headers are actually round-tripped an made use of.

Yep.

    john

---

From: [email-masked]
Date: Wed, 05 Aug 2009 18:07:34 +0900 (JST)

> From: John C Klensin <[email-masked]>

I think this method is easy and enough.

But I have an another idea to add new option for the mailto.

  <mailto:[email-masked]&ALT-ADDRESS=ASCII@ASCII>

Regards,

-- 
Kazunori Fujiwara, JPRS <[email-masked]>

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 05 Aug 2009 10:36:53 +0100

>  <mailto:[email-masked]&ALT-ADDRESS=ASCII@ASCII>
That would work as well.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 05 Aug 2009 22:01:28 +0900

The problem with this is that it doesn't work for cc and bcc fields.

Regards,   Martin.

On 2009/08/05 18:36, Alexey Melnikov wrote:
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Thu, 06 Aug 2009 13:50:45 -0400

--On Wednesday, August 05, 2009 22:01 +0900 "\"Martin J.

> The problem with this is that it doesn't work for cc and bcc

It doesn't even work for "to:" fields with multiple entries --
see my prior note.  Your observation about cc and bcc obviously
makes things even worse.

   john