Subject: Re: [EAI] Chinese Standard

From: Shawn Steele <[email-masked]>
Date: Tue, 25 Aug 2009 01:00:39 +0000

Yao Jiankang said:

> Chinese standard will follow the new IETF standard or RFC. If necessay, we will update it.
> I am involved in the Chinse standard process.
> so do not care about this.

I would imagine that's OK until November when the standard's published?  Presumably if the IETF does something that breaks after the Chinese standard is published, then changing that standard would break users/software that were depending on the Chinese standard?  Or is no one going to use that standard until the IETF version is finalized?

-Shawn

---

From: "YAO Jiankang" <[email-masked]>
Date: Tue, 25 Aug 2009 14:21:57 +0800

----- Original Message ----- 
From: "Shawn Steele" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, August 25, 2009 9:00 AM
Subject: Re: [EAI] Chinese Standard

> I would imagine that's OK until November when the standard's published?  Presumably if the IETF does something that breaks after the Chinese standard is >published, then changing that standard would break users/software that were depending on the Chinese standard?  Or is no one going to use that standard until >the IETF version is finalized?

the Chinese standard is a series of standard, which includes framework, smtpextension, utf8headers, pop, imap, clients. the first standard is based on framework of rfc4952. this standard is only for framework. this standard is supposed to be published around Nov. the implementors can not depend on it to implement EAI because there are no details about how to implement it. the implementors will depend on other documents such as smtpextension and utf8header to implement it.
the smtpextension and utf8header standards are supposed to be published next year.

Yao Jiankang
CNNIC

> 
> -Shawn
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: John C Klensin <[email-masked]>
Date: Tue, 25 Aug 2009 02:53:23 -0400

--On Tuesday, August 25, 2009 14:21 +0800 YAO Jiankang
<[email-masked]> wrote:

>... 
> the Chinese standard is a series of standard, which includes
> framework, smtpextension, utf8headers, pop, imap, clients. the
> first standard is based on framework of rfc4952. this standard
> is only for framework. this standard is supposed to be
> published around Nov. the implementors can not depend on it to
> implement EAI because there are no details about how to
> implement it. the implementors will depend on other documents
> such as smtpextension and utf8header to implement it. the
> smtpextension and utf8header standards are supposed to be
> published next year.

Out of curiosity, are those documents independently developed
with reference to the IETF documents, or are they annotated
translations of them?  

Either way, it sounds as if we should proceed as quickly as
possible, but no faster.

    john

---

From: "YAO Jiankang" <[email-masked]>
Date: Tue, 25 Aug 2009 15:15:27 +0800

----- Original Message ----- 
From: "John C Klensin" <[email-masked]>
To: "YAO Jiankang" <[email-masked]>; "Shawn Steele" <[email-masked]>; <[email-masked]>
Sent: Tuesday, August 25, 2009 2:53 PM
Subject: Re: [EAI] Chinese Standard

> with reference to the IETF documents, or are they annotated

not just translate. we will keep the principal one to be same with the RFC.

> Either way, it sounds as if we should proceed as quickly as

yes, totally agree.

Yao Jiankang

---

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 25 Aug 2009 10:55:34 +0100

On Tue, 25 Aug 2009 02:00:39 +0100, Shawn Steele  
<[email-masked]> wrote:

> I would imagine that's OK until November when the standard's published?   
> Presumably if the IETF does something that breaks after the Chinese  
> standard is published, then changing that standard would break  
> users/software that were depending on the Chinese standard?  Or is no  
> one going to use that standard until the IETF version is finalized?

I think we should follow the advice of the Chinese on that one. At the  
moment they seem to be saying that things can somehow be fixed even if our  
eventual standards-track RFC differs (at least in the ways being dicussed)  
 from the present Experimental version. If that is so, then it is best to  
wait and see.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Shawn Steele <[email-masked]>
Date: Tue, 25 Aug 2009 17:37:27 +0000

Thanks for the clarification :)

________________________________________
From: YAO Jiankang [[email-masked]]
Sent: Monday, August 24, 2009 11:21 PM
To: Shawn Steele; [email-masked]
Subject: Re: [EAI] Chinese Standard

----- Original Message -----
From: "Shawn Steele" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, August 25, 2009 9:00 AM
Subject: Re: [EAI] Chinese Standard

Yao Jiankang
CNNIC