Subject: Re: [EAI] Downgrade testing - Results

From: "YAO Jiankang" <[email-masked]>
Date: Thu, 6 Aug 2009 11:10:35 +0800

we send to the following 10 address, with <eai<ascii>>
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked]
>> * [email-masked]
>> * [email-masked] 
>> * [email-masked]
>> * [email-masked]

we get the nice response from the following 6 address
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]

we get the reject information from 1 address
[email-masked]

we can not get any response from other 3 addresses.

Yao Jiankang
CNNIC

----- Original Message ----- 
From: "Ernie Dainow" <[email-masked]>
To: "Stephane Bortzmeyer" <[email-masked]>; "EAI" <[email-masked]>
Sent: Thursday, July 09, 2009 9:09 PM
Subject: Re: [EAI] Downgrade testing - Results

> These echo tests were a good suggestion. I ran a base test from an ASCII 
> address against all echo servers in the list. All responded except 
> [email-masked]. Email bounced with "unknown address", so I  eliminated 
> that server from the test, leaving a total of 9 echo servers.
> 
> The success rate for receiving a response from echo servers:
> 1) From ASCII, no downgrade      9/9      100%
> 2) From EAI, downgrade               7/9        78%
> 
> [email-masked] provided some SpamAssassin analysis:
> 1) BODY: Bayesian spam probability is 1 to 5%
> 2) BODY: Bayesian spam probability is 5 to 20%
> 
> For the downgrade test sent to individual participants the results were:
> Total Sent    11   (all on different email domains)
> Received       9    82%
> Blocked        2    18%
> 
> These are not large samples, but it is interesting to see that the 
> success rate in both tests were similar, and were in the SpamAssassin 
> range of 20% probability of spam.
> 
> I encourage other implementers to run the same set of tests so we can 
> get a larger sample and see if there are differences between Downgrade 
> implementations.
> 
>    -Ernie
> 
> 
> Stephane Bortzmeyer wrote:
>> On Mon, Jun 22, 2009 at 11:19:48AM -0400,
>>  Ernie Dainow <[email-masked]> wrote 
>>  a message of 41 lines which said:
>>
>>   
>>> The Downgrade test reported on the wiki basically tested against gmail.  
>>> It would be valuable to do more testing 'in the wild' to see how  
>>> Downgrade traverses various email systems in other organizations.
>>>     
>>
>> You can test against various auto-responders which send you back your
>> message (if you know other email addresses of auto-responders, do not
>> hesitate to publish them).
>>
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked] 
>> * [email-masked]
>> * [email-masked]
>> * [email-masked] 
>> * [email-masked]
>> * [email-masked]
>>   
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: "YAO Jiankang" <[email-masked]>
Date: Thu, 6 Aug 2009 11:14:33 +0800

btw, the implmentation is based on postfix.
could TWNIC JPRS NIDA do the similar tests and report the results?

YAO Jiankang
CNNIC

---

From: Ernie Dainow <[email-masked]>
Date: Fri, 07 Aug 2009 07:52:37 -0400

Some of your failures may be due to the environment and not the 
Downgrade. I ran a 'base' test by sending the email from an ASCII 
address to try and identify which failures are due to the environment 
(firewalls, network, etc.). 

On the Downgrade test, I received replies from all servers except these
[email-masked]
[email-masked]
[email-masked] (this address does not exist and you get a reject from  
[email-masked])

You received replies from the first two but not from three others that I 
did receive a reply from. This is a surprising difference. A base test 
might help explain it.

    -Ernie Dainow

---

From: "YAO Jiankang" <[email-masked]>
Date: Wed, 12 Aug 2009 15:16:55 +0800

----- Original Message ----- 
From: "Ernie Dainow" <[email-masked]>
To: "YAO Jiankang" <[email-masked]>
Cc: "Stephane Bortzmeyer" <[email-masked]>; "EAI" <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Friday, August 07, 2009 7:52 PM
Subject: Re: [EAI] Downgrade testing - Results

> (firewalls, network, etc.). 

today,  we use the ascii address from the same machine to these 10 addresses. all get success.

so, that is to say that it is not the environment problem. 

Yao Jiankang
CNNIC

---

From: "YAO Jiankang" <[email-masked]>
Date: Tue, 18 Aug 2009 11:31:39 +0800

We use another EAI postfix system in another machine to have more tests today.
This time we use <eai <ascii>> to send the message to these ten echo email address.
**ALL get success***.

For the last test (eai postfix in different machine), the result is 

>>>> we can not get any response from other 3 addresses.

This time, we do the new test by using another Alt-address.

the result is different:

>>>> we get the nice response from the following 8 address
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked]
[email-masked] 
[email-masked]
[email-masked]

>>>> [email-masked]

[email-masked]

reject reason:

Action: failed 
Status: 5.0.0 (permanent failure) 
Remote-MTA: dns; [163.173.128.13] 
Diagnostic-Code: smtp; 5.1.0 - Unknown address error 550-'<[email-masked]>: Recipient address rejected: User unknown in local recipient table

if  we send it directly to [email-masked]>, no response.

>>>> we can not get any response from 1 addresses.
[email-masked]

so in summary, the sending failure to these address may not due to downgrade protocol problem.
there is still a chance to reach all these address. The reason may be due to some little difference of implementation of downgrade.
different alt-address sometimes also cause different failure.

Yao Jiankang
CNNIC