Subject: Re: [EAI] Localpart normalization

From: Shawn Steele <[email-masked]>
Date: Mon, 22 Mar 2010 19:09:41 +0000

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Lāpule, Malaki 21, 2010 12:00 PM
To: [email-masked]
Subject: IMA Digest, Vol 56, Issue 11

If you have received this digest without all the individual message attachments you will need to update your digest options in your list subscription.  To do so, go to 

https://www.ietf.org/mailman/listinfo/ima

Click the 'Unsubscribe or edit options' button, log in, and set "Get MIME or Plain Text Digests?" to MIME.  You can set this option globally for all the list digests you receive at this point.

That's what I meant.  If we use NFC, the servers can still be more rigorous and use NFKC, and whatever else they need to be compliant with XMPP or whatever other form they want.

-Shawn

----------------------------------------------------------------------

Message: 1
Date: Sat, 20 Mar 2010 22:00:56 +0100
From: Harald Alvestrand <[email-masked]>
Subject: Re: [EAI] Localpart normalization (was Re: Downgrade Design
	Team Discussion Results Released)
To: Alexey Melnikov <[email-masked]>
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Alexey Melnikov wrote:
> As a side note, one of the things suggested by the EAI downgrade 
> design team should be further discussed and should be coordinated with 
> the NewPrep BOF:
>
> YAO Jiankang wrote:
>> The design team also noted that an informational RFC regarding 
>> selection of addresses (both Unicode and ASCII) would be helpful, 
>> that clients SHOULD use Unicode Normalization Form C, and that 
>> servers MUST use NFC.
>>   
> Whatever normalization we recommend, it should be consistent with 
> handling of nodes in XMPP (NodePrepBis) and SASLPrepBis.
Note:
we should be careful what we mean here when we say "MUST use NFC".

I read it as "everyone should expect mail to two left-hand-side whose name canonicalizes to the same string under NFC to end up in the same mailbox".

That's no guarantee that mail to Unicode(R with ring around it) and UnicodeR will NOT end up in the same mailbox. Any server can apply additional normalizations at will to localparts that it's responsible for.

The difference between putting NFC and NFKC in the sentence above is that no intermediate server, who's merely passing along the message, can make the assumption that (R with ring around it) and (R) are equivalent.

                        Harald

------------------------------

_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima

End of IMA Digest, Vol 56, Issue 11
***********************************

---

From: John C Klensin <[email-masked]>
Date: Mon, 22 Mar 2010 20:14:03 -0400

--On Monday, 22 March, 2010 19:09 +0000 Shawn Steele
<[email-masked]> wrote:

>> Whatever normalization we recommend, it should be consistent
>> with  handling of nodes in XMPP (NodePrepBis) and SASLPrepBis.
>> Note:
>> I read it as "everyone should expect mail to two
>> left-hand-side whose name canonicalizes to the same string
>> under NFC to end up in the same mailbox".
>> 
>> That's no guarantee that mail to Unicode(R with ring around
>> it) and UnicodeR will NOT end up in the same mailbox. Any
>> server can apply additional normalizations at will to
>> localparts that it's responsible for.
>> 
>> The difference between putting NFC and NFKC in the sentence
>> above is that no intermediate server, who's merely passing
>> along the message, can make the assumption that (R with ring
>> around it) and (R) are equivalent.

>> I read it as "everyone should expect mail to two
>> left-hand-side whose name canonicalizes to the same string
>> under NFC to end up in the same mailbox".
>> 
>> That's no guarantee that mail to Unicode(R with ring around
>> it) and UnicodeR will NOT end up in the same mailbox. Any
>> server can apply additional normalizations at will to
>> localparts that it's responsible for.
>> 
>> The difference between putting NFC and NFKC in the sentence
>> above is that no intermediate server, who's merely passing
>> along the message, can make the assumption that (R with ring
>> around it) and (R) are equivalent.

> That's what I meant.  If we use NFC, the servers can still be
> more rigorous and use NFKC, and whatever else they need to be
> compliant with XMPP or whatever other form they want.

While I disagree that NFKC is "more rigorous", the servers can
map any strings they like onto a given mailbox.  That isn't a
property of Unicode, nor of anything the WG can specify.  
For example, [email-masked] and [email-masked]
can be mapped to the same mailbox if the delivery server is so
inclined.

     john

---

From: Shawn Steele <[email-masked]>
Date: Tue, 23 Mar 2010 01:14:33 +0000

Ok, bad word choice.  I just mean that NFC doesn't prevent servers from being XMPP compliant if they wish.

- Shawn

________________________________________
From: John C Klensin [[email-masked]]
Sent: Monday, March 22, 2010 5:14 PM
To: Shawn Steele; [email-masked]
Subject: Re: [EAI] Localpart normalization

     john