Subject: Re: [EAI] Localpart Normalization

From: Shawn Steele <[email-masked]>
Date: Fri, 19 Mar 2010 19:05:00 +0000

> > Unfortunately, both Nodeprep (RFC 3920) and SASLprep (RFC
> > 4013) used NFKC, not NFC.

> So did Nameprep.  Unfortunately, NFKC is _very_ dangerous.

I think we should use NFC.  I'm not as sure about John's "_very_" for email local parts though.  John, can you give me an example so I can go "duh?" :)

Thanks,
Shawn

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 19 Mar 2010 19:35:28 +0000

On Fri, Mar 19, 2010 at 7:05 PM, Shawn Steele
<[email-masked]> wrote:
> I think we should use NFC.  I'm not as sure about John's "_very_"
>for email local parts though.  John, can you give me an example so I can go "duh?" :)

Unfortunately NodePrep and SASLPrep already seen some deployment. And
I would really hate to see email and XMPP using different
canonicalization, as there are multiple services that support both. So
people should make a better argument of why backward compatibility
should be disregarded in this case.

---

From: Shawn Steele <[email-masked]>
Date: Fri, 19 Mar 2010 19:56:32 +0000

There's nothing that prohibits admins from restricting themselves to a subset of Unicode though.  So I think that you could have an info. doc describing the advantages of using a protocol?

-Shawn

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexey Melnikov
Sent: Poʻalima, Malaki 19, 2010 12:35 PM
To: Shawn Steele
Cc: [email-masked]
Subject: Re: [EAI] Localpart Normalization

>for email local parts though.  John, can you give me an example so I 

Unfortunately NodePrep and SASLPrep already seen some deployment. And I would really hate to see email and XMPP using different canonicalization, as there are multiple services that support both. So people should make a better argument of why backward compatibility should be disregarded in this case.

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 19 Mar 2010 13:58:44 -0600

> should be disregarded in this case.

I agree that ideally we would have harmony between the email, SASL, and
jabber treatment of internationalized localparts.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/