Subject: Re: [EAI] punycode approach

From: Shawn Steele <[email-masked]>
Date: Thu, 25 Mar 2010 22:24:29 +0000

> Indeed, but I think the intention is that within the EAI world, things  
> would remain in utf-8 throughout. But if alt-addresses are to be abolished  
> (and that seems to be the intention), some such downgrade will be needed.  
> Not much use for delivery of an original message, but suppose that such a  
> UFF-8 address appears in a Reply-To, or in a Return-Path. Then the  
> recipient may see that ugly punycoded format (he may even enter that ugly  
> version in his address book). Now, when he wants to reply, or when the  
> message is to be bounced up the Return-Path, it will indeed get sent to  
> the correct (EAI-aware) server, using the existing protocols.

I think fallback can be separate from the core docs though.  Some places don't need fallback (like everyone internal to a company or at the same university, or maybe on the same cellular provider, etc.).

> So we then need an extension to our transmission document to say that  
> EAI-aware servers need to be prepared to accept messages in that form and  
> pass them to the intended recipient (either by prestoring the punycoded  
> version of all their local users or, more likely, by unscrambling any  
> punycoded local-part before attemptiong to deliver it). That doesn't sound  
> too difficult.

I think it should be an optional thing that the client & server would have to both support to get it to work.  In that case, the EAI docs clearly state that mapping, etc. happens on the server, so the server'd have to decode and reencode it.

Punycode fallback approach DOES allow for the messy mixed environment that is my concern with DNS, however UTF8SMTP provides a way that "eventually", the fallback is no longer required, which is a huge advantage over the pure-punycode approach.  App devs are able to work in only a UTF8SMTP environment if they want, and don't have to worry about complicated edge cases if fallback wasn't important to them.

-Shawn

---

From: "YAO Jiankang" <[email-masked]>
Date: Fri, 26 Mar 2010 07:54:56 +0800

----- Original Message ----- 
From: "Shawn Steele" <[email-masked]>
To: <[email-masked]>
Sent: Friday, March 26, 2010 6:24 AM
Subject: Re: [EAI] punycode approach

> I think fallback can be separate from the core docs though.  Some places don't need fallback (like everyone internal to a company or at the same university, or maybe on the same cellular provider,…

+1