Subject: [EAI] EAI Agenda for IETF 77 in Anaheim

From: "YAO Jiankang" <[email-masked]>
Date: Wed, 17 Mar 2010 15:32:51 +0800

Dear all,

  The EAI agenda for IETF 77 is released, pls take a look.

http://www.ietf.org/proceedings/10mar/agenda/eai.txt

Jiankang Yao
------------------------------------------------------------------------------

------------------------------------------------------------------------------------
Email Address Internationalization (EAI) WG meeting in Anaheim

Meeting: IETF77, Monday, March 22,2010,  1740-1940
Place: Room Huntington, Hilton, Anaheim, CA, USA
Chairs: Harald Alvestrand <[email-masked]>, Xiaodong Lee [email-masked]

=====================================================
1740 - Scribe, blue sheet, agenda bashing

1750 - Documents status update
  
  draft-ietf-eai-pop                           RFC 5721 
  draft-ietf-eai-imap-utf8                     RFC 5738    
  draft-ietf-eai-downgraded-display            RFC Ed Queue 
  draft-ietf-eai-mailinglist                   AD Evaluation 

1800 - Downgrade discussion  
  Downgrade Design Team (DDT) membership introduction
  DDT results introduction
  DDT results discussion
  Downgrade summary or conclusion 

1910 - New charter discussion 

   The proposed charter is below

1940 - meeting adjourn

-------------------------------------------------------
Description of Working Group:
The email address has two parts, local part and domain part. The email address internationalization 
needs to deal with them. This working group's previous experimental efforts investigated the
use of UTF-8 as a general approach to email internationalization.
That approach is based on the use of an SMTP extension to enable
both the use of UTF-8 in envelope address local-parts and optionally
in domain-parts and the use of UTF-8 in mail headers -- both in
address contexts and wherever encoded-words are permitted today.
Other protocols were similarly extended.
 
This working group has finished all of its deliverables under the original charter.
Several of the WG's experimental RFCs based on UTF8SMTP extension have been proven
during the experimental phase and now need to be moved to standards
track.  The WG recommends the "no fallback" approach which will remove the alt-address and 
recognizes that "no fallback" provides a very minimal transition mechanism, however we feel
 that "no fallback" is better than allowing downgrade to block further progress. 
 Discoverable fallback addresses may be investigated independently of the core documents as non-standards track. 
 Any such work would be an optional MUA/submission protocol, independent of the core transport documents.
Additionally there are some other areas which may require more effort to make the smooth operation of internationalized email address.  

Deliverables

The following deliverables are foreseen in this charter. The 
WG chairs may (re)structure the deliverables into specific 
documents or document sets as needed. Adding or removing
documents outside of these deliverables will require a charter
update.
*Overview and Framework for Internationalized Email(info/standard) 
*UTF-8 SMTP extension specification (Standard) 
* Header format specification (Standard)
* UTF-8 POP specification (Standard)
* UTF-8 IMAP specification (Standard)

Additional possible documents suggested:
* Advice for MUA implementors (Info)
*Advice for EAI deployment (info)
* Advice for non-ASCII and ASCII addresses for the same mailbox (Info)
* Mailinglist(info)
* Mailto(info)

Goals and Milestones:
Mar. 2010  Discussion of Recharter for standards track
May. 2010  New charter approval from IESG
June 2010  EAI Framework to IESG 
July 2010   Headers & DSN (Standards) to IESG
July 2010   SMTP (Standard) to IESG
Aug. 2010   IMAP & POP3 (Standard) to IESG
Sep. 2010   Advice for non-ASCII & ASCII addresses (Info) to IESG
Oct. 2010   Advice for MUA implementors (Info) to IESG
Oct. 2010   Advice for EAI deployment (info) to IESG
Oct. 2010   Mailinglist (info) to IESG
Oct. 2010   Mailto(info) to IESG

---

From: "Martin J. Dürst" <[email-masked]>
Date: Thu, 18 Mar 2010 14:15:39 +0900

Hello Jiankang, others,

> * Mailto(info)

I assume that this refers to the mailto: URI.
If so, this should be clarified. Also, URI scheme definitions are
standards track, not informational. Therefore, I suggest:

* Mailto URI scheme (standards track)

There is also the question of whether to update the current(ly being
worked on, IETF last call completed) mailto: URI scheme spec, or to
define a new scheme. An earlier discussion (without much involvement
from my side) seems to have to come to the conclusion that a new scheme
is better. However, I guess we should re-examine this based on the fact
that fallback alternatives inside email addresses seem to going to be
dropped.

Either way, I'm glad to volunteer as the editor of the relevant document.

Regards,   Martin.

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: "YAO Jiankang" <[email-masked]>
Date: Fri, 19 Mar 2010 12:44:24 +0800

----- Original Message ----- 
From: ""Martin J. Dürst"" <[email-masked]>
To: "YAO Jiankang" <[email-masked]>
Cc: <[email-masked]>; "Larry Masinter" <[email-masked]>; "Jamie Zawinsky" <[email-masked]>
Sent: Thursday, March 18, 2010 1:15 PM
Subject: Re: [EAI] EAI Agenda for IETF 77 in Anaheim: mailto: URI scheme

> I assume that this refers to the mailto: URI.

yes.

> * Mailto URI scheme (standards track)

updated in the new version

----------------------------------------------------------------------------------------

  
  draft-ietf-eai-pop                           RFC 5721 
  draft-ietf-eai-imap-utf8                     RFC 5738    
  draft-ietf-eai-downgraded-display            RFC Ed Queue (AUTH48)
  draft-ietf-eai-mailinglist                   AD Evaluation 

1900 - AD's comments to WG

1905 - New charter discussion 

1935 - A.O.B (any other business) 

1940 - meeting adjourn

Deliverables

The following deliverables are foreseen in this charter. The 
WG chairs may (re)structure the deliverables into specific 
documents or document sets as needed. Adding or removing
documents outside of these deliverables will require a charter
update.
* Overview and Framework for Internationalized Email(Info/Standard) 
* UTF-8 SMTP extension specification (Standard) 
* Header format specification (Standard)
* UTF-8 POP specification (Standard)
* UTF-8 IMAP specification (Standard)

Additional possible documents suggested:
* Advice for MUA implementors (Info)
* Advice for EAI deployment (info)
* Advice for non-ASCII and ASCII addresses for the same mailbox (Info)
* Mailinglist(info)
* Mailto(info/Standard)

Goals and Milestones:
Mar. 2010   Discussion of Recharter for standards track
May. 2010   New charter approval from IESG
June 2010   EAI Framework to IESG 
July 2010   Headers (Standard) to IESG
July 2010   SMTP (Standard) to IESG
July 2010   DSN (Standard) to IESG
Aug. 2010   IMAP & POP3 (Standard) to IESG
Sep. 2010   Advice for non-ASCII & ASCII addresses (Info) to IESG
Oct. 2010   Advice for MUA implementors (Info) to IESG
Oct. 2010   Advice for EAI deployment (info) to IESG
Oct. 2010   Mailinglist (info) to IESG
Oct. 2010   Mailto(info/Standard) to IESG