Subject: [EAI] FW: IMAP Access to Mixed Maildrops

From: Shawn Steele <[email-masked]>
Date: Fri, 26 Mar 2010 15:37:24 +0000

Forwarding, Jason's mail seems to have vanished.

-Shawn

________________________________
From: Jason Nelson [[email-masked]]
Sent: Thursday, March 25, 2010 6:25 PM
To: [email-masked]'
Subject: IMAP Access to Mixed Maildrops

Is there a provision in the IMAP RFC to allow access to a mixed mailbox (both utf8 and legacy content) with native content being returned?  As I read it if access is allowed to the mailbox the server would either upconvert from 2047 encoding & friends to utf8 or down convert depending on whether or not the client enabled utf8 and selected with it. There is no “UTF8=MIXED” mode to allow applications with concern for “the message, just as it was put in” access to whatever format the message was stored in.

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 27 Mar 2010 22:14:55 +0000

Hi,

Shawn Steele wrote:
> ------------------------------------------------------------------------
> *From:* Jason Nelson [[email-masked]]
> *Sent:* Thursday, March 25, 2010 6:25 PM
> *To:* [email-masked]'
> *Subject:* IMAP Access to Mixed Maildrops
>
> Is there a provision in the IMAP RFC to allow access to a mixed 
> mailbox (both utf8 and legacy content) with native content being 
> returned?  As I read it if access is allowed to the mailbox the server 
> would either upconvert from 2047 encoding & friends to utf8 or down 
> convert depending on whether or not the client enabled utf8 and 
> selected with it. There is no “UTF8=MIXED” mode to allow applications 
> with concern for “the message, just as it was put in” access to 
> whatever format the message was stored in.
>
Correct, there is no mixed-mode access. Can you expand on why do you 
think this is need?