Subject: [EAI] A few editorial nits in RFC-to-be 5983 (draft-ietf-eai-mailinglist)

From: Julien ÉLIE <[email-masked]>
Date: Fri, 3 Sep 2010 21:18:51 +0200

Hi all,

I have just read http://www.rfc-editor.org/auth48/rfc5983
and a few editorial nits still remain in the last version:

* Section 3
    transaction. (Often, mailing lists are constructed to work in
and
    situation.) Further discussions are included in section 6 of this

=> Two spaces after the end of the previous sentence.

* Section 4
    There are also implications for the List-* headers (see below).

=> the List-* header fields

    particular, if a List-* header contains a UTF-8 mailto (even encoded

=> a List-* header field
Also check all other uses of the term in the document.  It is sometimes
written as "header" and sometimes (but less) as the correct "header field"
form.

    should use the left most protocol that it supports, or knows how

=> Well, I prefer "leftmost" in one word for clarity, but I believe it could
remain as-is (because it has not been changed after the RFC Editor review).

* Section 6
   mailing list upgrades to internationalized mail.

=> A general remark for the set of RFCs:  is there a difference of meaning
between "mail" and "email"?  I thought "internationalized email" was the
preferred term.
Maybe here, "internationalized messages" would be better?  That very notion
of internationalized messages is defined in Framework.

* Security Considerations
   sender filters, and other common list administration features. For

=> I see it is a new paragraph, added during AUTH48.  Double space after
the final dot.

I believe it is still time to take these minor editorial nits into account
during AUTH48.

Have a nice week-end,

-- 
Julien ÉLIE

« Un dictionnaire est comme une montre ; il vaut mieux en avoir un
  que pas du tout, mais le meilleur n'est jamais tout à fait exact. »
  (Georges-Bernard Shaw)

---

From: Randall Gellens <[email-masked]>
Date: Thu, 16 Sep 2010 15:56:17 -0700

Hi,

Thanks very much.  I've taken these into account, except for the following:

>  remain as-is (because it has not been changed after the RFC Editor review).

I'm thinking that "left most" might be more 
clear, but I am happy to leave it any way the RFC 
Editor chooses.

>  of internationalized messages is defined in Framework.

There has been a lot of debate over the use of 
"mail" versus "email" in the last couple of 
years.  Originally, "mail" or "message" were 
used, but now that we have many forms of 
messaging besides email, "message" is not as 
clear.  Personally, I think "mail" is good, 
because it's very clear that electronic mail is 
being discussed.  However, I am also fine with 
"email".

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Inside every large problem is a small problem struggling to get out.

---

From: John C Klensin <[email-masked]>
Date: Mon, 20 Sep 2010 13:06:05 -0400

--On Thursday, September 16, 2010 15:56 -0700 Randall Gellens
<[email-masked]> wrote:

>>  => A general remark for the set of RFCs:  is there a
>>  difference of meaning between "mail" and "email"?  I thought
>>  "internationalized email" was the preferred term.
>>  Maybe here, "internationalized messages" would be better?
>>  That very notion of internationalized messages is defined in
>>  Framework.
> 
> There has been a lot of debate over the use of "mail" versus
> "email" in the last couple of years.  Originally, "mail" or
> "message" were used, but now that we have many forms of
> messaging besides email, "message" is not as clear.

As Mike Padlipsky repeatedly points out, originally "netmail"
was used.

> Personally, I think "mail" is good, because it's very clear
> that electronic mail is being discussed.  However, I am also
> fine with "email".

I agree about avoiding "message".  "Internationalized message"
could refer to various IM things, protocol messages at lower
levels of the stack (as an exercise, check out what "ICMP"
(--which is one of our three absolutely core protocols-- stands
for), and so on, none of which are addressed in any way by EAI.

I also think the RFC Editor should establish and enforce a
standard for how "email" is spelled (note that "Authors'
Addresses" sections of RFCs spell it "EMail", which is a
spelling convention I don't believe I've seen _anywhere_ else in
recent years).  

But, for this document, the important thing to do is to get it
out.  Let's save these debates for the standards-track version
that will follow.

best,
   john