Subject: Re: [EAI] question on 5337bis

From: SM <[email-masked]>
Date: Sun, 03 Oct 2010 03:00:43 -0700

At 18:01 30-09-10, Tony Hansen wrote:
>While preparing 5337 bis, Internationalized Delivery Status and 
>Disposition Notifications, discussion with my co-authors brought up 
>the question as to whether the registered names need to be changed.

[snip]

I don't feel strongly about this.

>So the questions to the mailing list is:
>
>1) Should the address type be changed from UTF-8 to UTF8?

Yes, because to the syntax change.

>2) Should the internationalized notary media type change its name 
>from message/global-delivery-status?
>
>3) Should the internationalized message content type change its name 
>from message/global?
>
>4) Should the internationalized headers content type change its name 
>from message/global-headers?

No to the above as it is not much of a change from the original 
proposal.  It also avoids having to choose an appropriate name.

Regards,
-sm

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 05 Oct 2010 20:41:52 +0900

I'd prefer not to change UTF-8 to UTF8. Among else, UTF8 is a label for 
an encoding that's almost, but not exactly UTF-8 (they store characters 
U+10000 and beyond as a pair of surrogates, i.e. 6 bytes, instead of 4 
bytes as UTF-8 requires it) in Oracle databases.

Regards,    Martin.

On 2010/10/01 10:01, Tony Hansen wrote:
> Disposition Notifications, discussion with my co-authors brought up the
> question as to whether the registered names need to be changed.
>
> In particular, Chris wrote to me:
>
> ----
> If we assume the experiment never leaked, we can re-use names, I suppose.
>
> Otherwise, we should consider changing names to avoid conflicts.
> Changing the address type from "utf-8" to, say, "utf8" would be simple
> to make it clear the new label can never have the <addr <addr>> syntax
> -- I presently lean towards doing that.
>
> We don't have to change the notary media type
> (message/global-delivery-status), since the address type label change
> suffices.
>
> But we might choose to change the type name for "message/global" and
> "message/global-headers" if we want to create a new type that disallows
> <addr <addr>> syntax for addresses. However that change is less
> necessary since the simplified EAI proposal is a subset of the original
> media type. I'd be inclined to just live with the possibility of leaked
> <addr <addr>> in message/global* just to avoid the pain of choosing a
> new type name for that.
> ----
>
> 2) Should the internationalized notary media type change its name from
> message/global-delivery-status?
>
> Discussion please.
> Tony Hansen
> [email-masked]
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>
>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]