Subject: [EAI] Consensus Issue #1: parameter on MAIL FROM?

From: Joseph Yee <[email-masked]>
Date: Mon, 17 Jan 2011 12:15:40 -0500

Issue #1: parameter on MAIL FROM? 
http://trac.tools.ietf.org/wg/eai/trac/ticket/1

Description 
---------------

Should the WG add parameter on MAIL FROM to start EAI transaction and avoid the need for deep inspection?

---------------

Please use this thread or the issue tracker for discussion. The end date of discussion is Tuesday, Jan 25 - 9pm Pacific Time and conclusion will be drawn afterwards.    

Best,
Joseph

---

From: Troy Starr <[email-masked]>
Date: Mon, 17 Jan 2011 22:39:10 -0800

Yes, it should.

I would prefer it to be a parameter that takes a value, and that the value indicates legacy behavior or EAI behavior, because I believe that makes any potential future extensions to this standard easier to integrate.  I would prefer that the value be descriptive of the type of character encoding (ASCII/UTF-8, or whatever terminology is deemed appropriate) rather than a simple binary value, again because I believe that makes any potential future extensions to this standard easier to integrate.  If it had such a value, then a parameter name such as HEADERENCODING might be a good name.

But if there was a consensus for this parameter to have a binary value, or no value at all, I would not object.

- Troy Starr

-----Original Message-----
From: Joseph Yee [mailto:[email-masked]] 
Sent: Monday, January 17, 2011 9:16 AM
To: EAI WG
Subject: [EAI] Consensus Issue #1: parameter on MAIL FROM?

Description 
---------------

---------------

Best,
Joseph

---

From: John C Klensin <[email-masked]>
Date: Tue, 18 Jan 2011 09:24:25 -0500

yes

--On Monday, 17 January, 2011 12:15 -0500 Joseph Yee
<[email-masked]> wrote:

> Should the WG add parameter on MAIL FROM to start EAI
> transaction and avoid the need for deep inspection?
> 
>

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 19 Jan 2011 16:03:36 +0900

> http://trac.tools.ietf.org/wg/eai/trac/ticket/1

Yes. To the extent possible, the parameter should be short.

Regards,   Martin.

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jan 2011 07:42:41 -0500

--On Wednesday, 19 January, 2011 16:03 +0900 "\"Martin J.

> Yes. To the extent possible, the parameter should be short.

Out of curiousity, because?   Remember that this parameter is
part of the SMTP envelope only -- users never see these things;
most users would be unable to see them if they wanted to and
knew how to look for them (it requires either looking inside an
MTA or intercepting MTA-MTA transactions).   I don't object to
"short", but am wondering why you think it is important.

   john

---

From: "Martin J. Dürst" <[email-masked]>
Date: Thu, 20 Jan 2011 09:40:04 +0900

Hello John,

On 2011/01/19 21:42, John C Klensin wrote:
> Dürst\""<[email-masked]>  wrote:
>

I'm sorry if that sounded more important than it was intended. I just 
wanted to express that I have a preference for something like UTF-8 or 
EAI or UTF8 over something long and convoluted.

Regards,   Martin.

---

From: "Charles Lindsey" <[email-masked]>
Date: Thu, 20 Jan 2011 12:16:14 -0000

> avoid the need for deep inspection?

Yes. Ideally with the same syntax as for any other commands where we add  
parameters, and ideally using the same keyword (UTF8SMTPbis) as used in  
EHLO

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: [email-masked]
Date: Thu, 20 Jan 2011 17:45:16 -0800 (PST)

> Yes.

Agreed.

> Ideally with the same syntax as for any other commands where we add

I don't much care what the keyword is, but having it match is nice.

				Ned

---

From: [email-masked]
Date: Mon, 24 Jan 2011 21:04:54 +0900 (JST)

> From: Joseph Yee <[email-masked]>

Yes.

A message may contain nested MIME structure and may contain UTF-8
filename in a MIME header field.

Inspecting nested MIME structure and checking each MIME header field
are too expensive to impliment in MTAs, I think.

--
Kazunori Fujiwara, JPRS <[email-masked]>