Subject: Re: [EAI] Consensus Issue #1: parameter on MAIL FROM?

From: Shawn Steele <[email-masked]>
Date: Mon, 24 Jan 2011 20:45:22 +0000

In case it wasn't obvious, I also prefer (ii).

Unfortunately that doesn't help the server "downgrade" a mail, it'd still have to see if it could treat it as a legacy message.  It does, however, help the server realize that this situation might apply.

-Shawn

------------------------------

Message: 7
Date: 24 Jan 2011 13:28:13 -0500
From: "John R Levine" <[email-masked]>
Subject: Re: [EAI] Consensus Issue #1: parameter on MAIL FROM?
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed

> (i) "MUST supply the parameter if the envelope or message
> requires EAI facilities and SHOULD NOT supply it if the client
> is EAI-capable but not using EAI facilities"
>
> or
>
> (ii) "MUST supply the parameter if the envelope or message
> requires EAI facilities and MAY supply it if the client is
> EAI-capable but not using EAI facilities"

I'd go with (ii) since that's likely to match what people really do.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

------------------------------

_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima

End of IMA Digest, Vol 66, Issue 35
***********************************

---

From: John Levine <[email-masked]>
Date: 24 Jan 2011 23:14:29 -0000

>Unfortunately that doesn't help the server "downgrade" a mail, it'd
>still have to see if it could treat it as a legacy message.  It does,
>however, help the server realize that this situation might apply.

Unless someone strongly objects, can we save the downgrade discussion
for later?  Lots of worms in that can, no matter what we decide at
this point.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

---

From: Shawn Steele <[email-masked]>
Date: Mon, 24 Jan 2011 23:16:08 +0000

Bad choice of words, sorry, I meant a legacy message, which, by definition, could be forwarded without changing it.

-----Original Message-----
From: John Levine [mailto:[email-masked]] 
Sent: Monday, January 24, 2011 3:14 PM
To: [email-masked]
Cc: Shawn Steele
Subject: Re: [EAI] Consensus Issue #1: parameter on MAIL FROM?

>however, help the server realize that this situation might apply.

Unless someone strongly objects, can we save the downgrade discussion for later?  Lots of worms in that can, no matter what we decide at this point.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies", Please consider the environment before reading this e-mail. http://jl.ly