Subject: [EAI] RFC publication numbers and titles

From: Ernie Dainow <[email-masked]>
Date: Thu, 13 Jan 2011 08:59:57 -0500

Starting with RFCs 821/822 there has been a consistent pattern for publishing SMTP standards as paired documents, where the first is the SMTP protocol and the second is the Internet message format. This was continued until 5321/5322.

The EAI Experimental drafts were published in the reverse order, with 5335 being Email Headers and 5336 SMTP Extensions.

Can we reserve RFC numbers in advance to be consistent with the past and also get a 21/22 pair.
5336bis -> 6321 SMTP Extension for Internationalized Email Address
5335bis -> 6322 Internationalized Email Headers

Editorial notes:
1) The title on 5336bis should be corrected to:
      SMTP Extensions for Internationalized Email Addresses
2) 5335bis is not only email headers, it includes specifications for message bodies. The    title should be changed to conform to the previous x22 documents:
      Internet Message Format for Internationalized Email Addresses

-Ernie

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 16 Jan 2011 16:24:19 +0000

Hi Ernie,

Ernie Dainow wrote:

> Starting with RFCs 821/822 there has been a consistent pattern for 
> publishing SMTP standards as paired documents, where the first is the 
> SMTP protocol and the second is the Internet message format. This was 
> continued until 5321/5322.
>
> The EAI Experimental drafts were published in the reverse order, with 
> 5335 being Email Headers and 5336 SMTP Extensions.
>

I can talk to the RFC Editor about reserving the suggested RFC numbers, 
if that is what the WG wants.

Regards,
Alexey

---

From: Dave CROCKER <[email-masked]>
Date: Sun, 16 Jan 2011 08:32:41 -0800

On 1/16/2011 8:24 AM, Alexey Melnikov wrote:
> I can talk to the RFC Editor about reserving the suggested RFC numbers, if that
> is what the WG wants.

Why not 6336 and 6335?

But I think that reserving RFC numbers is quite exceptional and possibly not 
typically allowed.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: John C Klensin <[email-masked]>
Date: Sun, 16 Jan 2011 18:52:30 -0500

--On Sunday, 16 January, 2011 08:32 -0800 Dave CROCKER
<[email-masked]> wrote:

>> I can talk to the RFC Editor about reserving the suggested
>> RFC numbers, if that is what the WG wants.
> 
> 
> Why not 6336 and 6335?
> 
> But I think that reserving RFC numbers is quite exceptional
> and possibly not typically allowed.

Indeed.  And it is much easier to have those discussions when
one has a clear understanding / good prediction of when the
documents will be finished.

FWIW, I do agree with Ernie that having them in the order SMTP
(as in 821, 2821, 5321) and then headers (822, 2822, 5322) would
probably be wiser.

    john

---

From: Bill McQuillan <[email-masked]>
Date: Sun, 16 Jan 2011 23:41:23 -0800

> (as in 821, 2821, 5321) and then headers (822, 2822, 5322) would

I don't disagree with changing the ordering, but I would point out that the
x21/x22 series are complete replacements whereas the EAI docs are
extensions.

-- 
Bill McQuillan <[email-masked]>

---

From: John C Klensin <[email-masked]>
Date: Mon, 17 Jan 2011 02:54:55 -0500

--On Sunday, 16 January, 2011 23:41 -0800 Bill McQuillan
<[email-masked]> wrote:

>> (as in 821, 2821, 5321) and then headers (822, 2822, 5322)
>> would probably be wiser.
> 
> I don't disagree with changing the ordering, but I would point
> out that the x21/x22 series are complete replacements whereas
> the EAI docs are extensions.

Of course.  It seems to me that might be an argument against
trying to make the EAI documents 6321/6322 or equivalent.  But
the order should be independent of that.  Right now, knowing
that SMTP is before Headers in the base document but the order
is reversed in the EAI ones has already caused some confusion
and mistakes to be made.  Nothing serious, but it seems like a
problem best avoided, with no particular downside.

   john