Subject: [EAI] Consensus Issue #5: keep nested encodings for message/global?

From: Joseph Yee <[email-masked]>
Date: Mon, 17 Jan 2011 12:15:46 -0500

Issue #5: keep nested encodings for message/global?

http://trac.tools.ietf.org/wg/eai/trac/ticket/5

Description 
---------------

Should the WG keep the decision about nested encodings and the use of message/global as described in RFC5336 and RFC5336bis? Or is a different model needed?

---------------

Please use this thread or the issue tracker for discussion. The end date of discussion is Tuesday, Jan 25 - 9pm Pacific Time and conclusion will be drawn afterwards.    

Best,
Joseph

---

From: John C Klensin <[email-masked]>
Date: Tue, 18 Jan 2011 09:34:57 -0500

Yes, keep message/global and move on.

With one exception, I do not see any way to avoid this and still
be able to forward EAI-style messages with addresses in header
fields to EAI-unaware environments.  Even then, message/rfc822
clearly does not permit headers containing characters outside
the ASCII repertoire that are expressed using a coding that
requires octets with the high bit on.

The exception would be some "downgrade" encoding for that
purpose that would expand the scope in which encoded words can
be used to include addresses and perhaps additional header
fields and then used some downgrade procedure to make valid
message/rfc822 body parts from arbitrary messages that depended
on EAI facilities.  

Such a proposal would also take us backwards, away from the goal
of simply using UTF-8 where appropriate and into the domain of
yet more long-term use of IETF-protocol-specific encodings.

In any event, the  WG does not have such a proposal in front of
it; I believe that writing one that gets all of the cases right
would require some skill and considerable work by the WG and I
just do not see avoiding message/global as important enough to
justify the delay the effort to generate such a proposal would
cause.. to say nothing of the disadvantages of inventing and
deploying yet another kludge.

--On Monday, 17 January, 2011 12:15 -0500 Joseph Yee
<[email-masked]> wrote:

> Should the WG keep the decision about nested encodings and the
> use of message/global as described in RFC5336 and RFC5336bis?
> Or is a different model needed?

---

From: John Levine <[email-masked]>
Date: 18 Jan 2011 16:10:38 -0000

>Yes, keep message/global and move on.

+1

If over-eager gateways want to downgrade some subset of message/global
message parts to message/rfc822, they can do it without our help.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

---

From: "Charles Lindsey" <[email-masked]>
Date: Thu, 20 Jan 2011 12:31:44 -0000

+1

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Tony Hansen <[email-masked]>
Date: Thu, 20 Jan 2011 14:23:04 -0500

+1