Subject: Re: [EAI] Consensus Issue #???: Media types that support multiple charsets SHOULD employ utf-8

From: Shawn Steele <[email-masked]>
Date: Thu, 20 Jan 2011 00:27:44 +0000

I'd agree to this question, though I'd suggest "should employ UTF-8".

	Media types that support multiple charsets SHOULD employ UTF-8

- or -
	Media types that support multiple charsets SHOULD employ UTF-8 or ASCII.

Or is there something that's restricted to ASCII-only for a really good reason?

-Shawn

-----Original Message-----
From: Ned Freed [mailto:[email-masked]] 
Sent: Poʻakolu, Ianuali 19, 2011 11:02 hours
To: Shawn Steele
Cc: [email-masked]
Subject: Re: [EAI] Consensus Issue #1: parameter on MAIL FROM?

> Nothing requires UTF-8, but we certainly strongly suggest that EAI 
> messages are entirely UTF-8.  IMO you'd be a pretty ugly EAI 
> implementation if that wasn't your default.

I think this is a very good point worthy of a separate consensus call - the format document needs to say something like:

    Media types that support multiple charsets SHOULD employ either
    utf-8 or us-ascii.

As Shown wells knows, the continued use of charsets other than utf-8, especially some of the multibyte ones whose definitions vary depending on the software you're using, represent a significant ongoing interoperability problem for email. Given that you have to support utf-8 to support EAI, there is absolutely no reason for EAI to condone this nonsense.

				Ned

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jan 2011 23:36:33 -0500

--On Thursday, 20 January, 2011 00:27 +0000 Shawn Steele
<[email-masked]> wrote:

>...

We have a very general design rule that protocol elements of
various sorts stay ASCII-only.  They aren't seen by end users,
the complexities of Unicode comparisons and collations aren't
worth the trouble, nor is worrying about ambiguities brought
about by font availability and rendering, etc.  

If one had a media type whose purpose was to transmit a
collection of such protocol elements, we would certainly want it
to be ASCII-only.

    john

---

From: Claudio Allocchio <[email-masked]>
Date: Fri, 21 Jan 2011 12:15:54 +0100 (CET)

> about by font availability and rendering, etc.

they are the IETF-style version of "binary" protocol elements, for the 
sake of human readability. Machines do not need to emulate humans complex 
behaviours :-)

+1

> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>

------------------------------------------------------------------------------
Claudio Allocchio             G   A   R   R          [email-masked]
                         Senior Technical Officer
tel: +39 040 3758523      Italian Academic and       G=Claudio; S=Allocchio;
fax: +39 040 3758565        Research Network         P=garr; A=garr; C=it;

            PGP Key: http://www.cert.garr.it/PGP/keys.php3#ca

---

From: John C Klensin <[email-masked]>
Date: Fri, 21 Jan 2011 07:22:05 -0500

--On Friday, January 21, 2011 12:15 +0100 Claudio Allocchio
<[email-masked]> wrote:

> they are the IETF-style version of "binary" protocol elements,
> for the sake of human readability. Machines do not need to
> emulate humans complex behaviours :-)
> 
> +1

Good analogy.  Yes.
   john