Subject: [EAI] FYI: I-D Action:draft-duerst-eai-mailto-00.txt

From: Shawn Steele <[email-masked]>
Date: Wed, 9 Mar 2011 20:11:38 +0000

I don't like the MUST on % encoding for non-ASCII.  In practice even current systems don't rely on that for mailto.  (eg: mailto: an EAI address will invoke Outlook on an IE machine today.  You're stuck after that, but mailto "works").

I realize why the MUST seems useful, but, in practice, I don't see how it helps at all.  Unaware systems get gibberish either way, and it's trivial to allow EAI-aware systems to use UTF-8 natively, so the compatibility concerns seem like a red herring to me.

(Let's not let this distract from the core docs though)

-Shawn

----------------------------------------------------------------------

Message: 1
Date: Wed, 09 Mar 2011 18:12:45 +0900
From: "Martin J. D?rst" <[email-masked]>
Subject: [EAI] FYI: I-D Action:draft-duerst-eai-mailto-00.txt
To: "[email-masked]" <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="utf-8"; Format="flowed"

This draft may be of interest to some WG participants, as it is in the long-term part of the charter. I have asked the Co-Chairs to put it on the agenda of the WG meeting in Prague if they feel there may be enough time and energy left.

I have tried to address earlier comments (in particular also from John
K.) regarding hidden encoding/decoding complexity by explicitly renaming ABNF rules. As an example, the addr-spec rule has been renamed to addr-spec-enc, to make clear that while it is *almost* the same as addr-spec in the main email-related RFCs, it's *not* the same.

Regards,   Martin.

-------- Original Message --------
Subject: I-D Action:draft-duerst-eai-mailto-00.txt
Date: Mon, 07 Mar 2011 00:00:01 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : The 'mailto' URI/IRI Scheme
	Author(s)       : M. Duerst, et al.
	Filename        : draft-duerst-eai-mailto-00.txt
	Pages           : 20
	Date            : 2011-03-06

This document defines the format of Uniform Resource Identifiers
(URIs) and Internationalized Resource Identfiers (IRIs) to identify resources that are reached using Internet mail.  It adds the possibility to use Email Address Internationalization (EAI) email addresses (RFC4952bis) to the previous syntax of 'mailto' URIs (RFC 6068).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-duerst-eai-mailto-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 11 Mar 2011 11:54:18 +0900

Hello Shawn,

Thanks for your comments.

On 2011/03/10 5:11, Shawn Steele wrote:
> I don't like the MUST on % encoding for non-ASCII.

Just to make sure, do you mean some of the MUSTs in point 4 and 5 in 
section 2 
(http://tools.ietf.org/html/draft-duerst-eai-mailto-00#section-2), 
essentially of the form

                    non-ASCII characters MUST first be encoded according
        to UTF-8 [STD63], and then each octet of the corresponding UTF-8
        sequence MUST be percent-encoded to be represented as URI
        characters

> In practice even current systems don't rely on that for mailto.

That's fine. That just means that they don't use URIs, they use IRIs. 
The document is defined in terms of URIs, where non-ASCII characters are 
forbidden. In order to also work with IRIs, the above text is the 
necessary "secret formula" or "magic keyword".

> (eg: mailto: an EAI address will invoke Outlook on an IE machine today.  You're stuck after that, but mailto "works").

It's great to know that mailto: already works with IRIs!

> I realize why the MUST seems useful, but, in practice, I don't see how it helps at all.

Do you think it would be easier to write the spec in terms of IRIs?

> Unaware systems get gibberish either way, and it's trivial to allow EAI-aware systems to use UTF-8 natively,

Yes, of course, but please remember that mailto: is used both for 
EAI-aware and non-EAI-aware systems.

> so the compatibility concerns seem like a red herring to me.
>

Yes indeed. For general discussions about URIs vs. IRIs, please move 
them to the IRI WG (mailing list [email-masked]).

Regards,   Martin.

> From: "Martin J. D?rst"<[email-masked]>
> To: "[email-masked]"<[email-masked]>
> Message-ID:<[email-masked]>
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>
>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: Shawn Steele <[email-masked]>
Date: Fri, 11 Mar 2011 03:17:00 +0000

Yes, I think it'd be easier to spec it as IRIs.  (Do the IRI/URI RFCs cover converting from IRI to URI?  In that case we don't have to cover that part again).

IMO anyone implementing draft-duerst-eai-mailto-00.txt will be able to handle IRIs.  I'm sure there're a few edge cases tunneling through older systems, but I think we should lean toward plain Unicode (IRIs).  (And then they'd be in the encoding of the doc/app, right?  Since a mailto could be embedded anywhere?  The UTF-8 language is only necessary for the % encoding language).  Eg: if this were a .Net string, it'd be UTF-16, not UTF-8.

- Shawn

http://blogs.msdn.com/shawnste

-----Original Message-----
From: "Martin J. Dürst" [mailto:[email-masked]] 
Sent: Thursday, March 10, 2011 6:54 PM
To: Shawn Steele
Cc: [email-masked]
Subject: Re: [EAI] FYI: I-D Action:draft-duerst-eai-mailto-00.txt

Hello Shawn,

> I don't like the MUST on % encoding for non-ASCII.

Just to make sure, do you mean some of the MUSTs in point 4 and 5 in section 2 (http://tools.ietf.org/html/draft-duerst-eai-mailto-00#section-2),
essentially of the form

That's fine. That just means that they don't use URIs, they use IRIs. 
The document is defined in terms of URIs, where non-ASCII characters are forbidden. In order to also work with IRIs, the above text is the necessary "secret formula" or "magic keyword".

> EAI-aware systems to use UTF-8 natively,

Yes, of course, but please remember that mailto: is used both for EAI-aware and non-EAI-aware systems.

> (Let's not let this distract from the core docs though)

Yes indeed. For general discussions about URIs vs. IRIs, please move them to the IRI WG (mailing list [email-masked]).

Regards,   Martin.