Subject: Re: [EAI] Chinese email address

From: Shawn Steele <[email-masked]>
Date: Fri, 19 Dec 2014 20:25:34 +0000

The 2nd link got messed up by encodings on the forum.  Makes me wonder what the tinyurl type services do if they see IDN?

----------------------------------------------------------------------

Message: 1
Date: Fri, 19 Dec 2014 23:27:33 +0800
From: Jiankang Yao <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: [EAI] Chinese email address
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="gb2312"

Dear all, 

    For those who can recognize the Chinese character, you can log on the    Following link to register a Chinese email address. You can also have an opportunity to get iPhone 6 as a prize.

http://mp.weixin.qq.com/s?__biz=MjM5NzM3Mjg2Mw==&mid=202089804&idx=1&sn=741bffe6eb1882be4fe7f548d602cf1a&scene=2&from=timeline&isappinstalled=0#rd

http://????.??/mail/register.jsp

>From my phone

---

From: "Jiankang Yao" <[email-masked]>
Date: Sat, 20 Dec 2014 10:31:05 +0800 (GMT+08:00)

I think that MIME encode any non-ASCII character in the email content as base64.

MIME does not treat "http://non-ascii.non-ascii" as the IDN.

Your EMACS also treat it only as the non-ascii character, but not u-label or IDN.

my safari in phone works. copy and paste it into safari, and works as the idn.

Jiankang Yao

> -----原始邮件-----
> 发件人: [email-masked]
> 发送时间: 2014-12-20 
> 收件人: "[email-masked]" <[email-masked]>
> 抄送: 
> 主题: Re: [EAI] Chinese email address

>On Fri, Dec 19, 2014 at 08:25:34PM +0000, Shawn Steele wrote:
>> The 2nd link got messed up by encodings on the forum.  Makes me wonder what the tinyurl type >>services do if they see IDN?
>> 

>Well, I cut and pasted from emacs and got this:

---%<---cut here---

The following URL:

http://&#20013;&#25991;&#37038;&#31665;.
&#32593;&#32476;
has a length of 56 characters and resulted in the following TinyURL which has a length of 26 characters:
http://tinyurl.com/kwfwhrn

--->%---cut here---

>So the first problem, apparently, is getting the U-labels past the
>form submission.

>A

>-- 
>Andrew Sullivan
>[email-masked]

---

From: "Jiankang Yao" <[email-masked]>
Date: Sat, 20 Dec 2014 10:38:36 +0800 (GMT+08:00)

A-label format:

http://xn--fiQ228CmvPbgT.xn--io0A7I 

U-label format:

http://中文邮箱.网络/

> -----原始邮件-----
> 发件人: "Shawn Steele" <[email-masked]>
> 发送时间: 2014-12-20 04:25:34 (星期六)
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima