Subject: [imapext] I-D Action: draft-ietf-imapmove-command-02.txt

From: [email-masked]
Date: Sat, 20 Oct 2012 08:20:32 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IMAP MOVE extension Working Group of the IETF.

	Title           : The IMAP Move Extension
	Author(s)       : Arnt Gulbrandsen
                          Ned Freed
	Filename        : draft-ietf-imapmove-command-02.txt
	Pages           : 9
	Date            : 2012-10-20

Abstract:
   This document defines an IMAP extension consisting of two new
   commands, MOVE and UID MOVE, that are used to move messages from one
   mailbox to another.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-imapmove-command

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-imapmove-command-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-imapmove-command-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jan Kundrát <[email-masked]>
Date: Mon, 29 Oct 2012 15:08:35 +0100

> The QUOTA extension (defined by [RFC2087]) may interact with MOVE, on
> some servers, in the sense that a MOVE command may succeed where COPY
> would cause a quota overrun.  This may be user-visible, but should
> not be MUA-visible.

Hi Arnt, it isn't clear to me what this paragraph actually means -- what's the difference between "MUA-visible" and user-visible?

Apart from that, I don't see any errors in this draft.

With kind regards,
Jan

-- 
Trojita, a fast e-mail client -- http://trojita.flaska.net/

---

From: Ned Freed <[email-masked]>
Date: Mon, 29 Oct 2012 09:29:52 -0700 (PDT)

> Hi Arnt, it isn't clear to me what this paragraph actually means -- what's the difference between "MUA-visible" and user-visible?

Irrespective of what it means or is intended to mean, I don't think commenting
on MUA/user behavior is appropriate. I suggest deleting the sentence.

				Ned

---

From: Timo Sirainen <[email-masked]>
Date: Mon, 29 Oct 2012 23:35:29 +0200

>    capability     =/ "MOVE"
> 
>    command-select =/ move
>    move = "MOVE" SP sequence-set SP mailbox
>    uid = "UID" SP (copy / fetch / search / store / move)

This is the only "problem" that I see. Whitespacing being a bit inconsistent.

---

From: Ned Freed <[email-masked]>
Date: Mon, 29 Oct 2012 14:55:06 -0700 (PDT)

> This is the only "problem" that I see. Whitespacing being a bit inconsistent.

Consider it fixed.

				Ned

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 30 Oct 2012 12:20:03 +0000

On 29/10/2012 14:08, Jan Kundrát wrote:
> Hi Arnt, it isn't clear to me what this paragraph actually means -- 
> what's the difference between "MUA-visible" and user-visible?

I am agreeing with you and Ned that removing the last quoted sentence is 
the best way forward.

> Apart from that, I don't see any errors in this draft.

Good.