Subject: Re: [imapext] I-D Action: draft-ietf-imapmove-command-05.txt

From: Thomas Dressler <[email-masked]>
Date: Mon, 03 Dec 2012 10:35:52 +0100

On 29.11.2012 22:04, Timo Sirainen wrote:
> I guess I should have read this more closely earlier:
>
>>     When a message is moved to a target mailbox, if the server is capable	
>>   	   of storing modification sequences for the mailbox, the server MUST	
>>   	   generate a new modification sequence that is higher than the highest	
>>   	   modification sequence of all messages in the mailbox and assign it to	
>>   	   the moved message.
> This seems to mean each moved message MUST have a new different modification sequence. My server gives the same new modseq for all of them.
>
> In general, maybe there shouldn't be any MUSTs at all in section 4? They may unintentionally add extra restrictions that aren't in the base documents. I now see another problem:
>
>> 4.3.  RFC 4315, UIDPLUS
>>
>>     Servers supporting UIDPLUS [RFC4315] MUST send COPYUID in response to
>>     a UID MOVE command.
> This shouldn't be a MUST, since it adds a restriction not present in RFC 4315:
>
>     [RFC2359] implied that a server must always return COPYUID/APPENDUID
>     data; thus suggesting that in such cases the server should return
>     arbitrary data if the destination mailbox did not support persistent
>     UIDs.  This document adds the UIDNOTSTICKY response code to indicate
>     that a mailbox does not support persistent UIDs, and stipulates that
>     a UIDPLUS server does not return COPYUID/APPENDUID data when the COPY
>     (or APPEND) destination mailbox has UIDNOTSTICKY status.
>
>
>
also if no mail was moved?

example:
C: a SELECT a
S: * 1 EXISTS
S: * 1 RECENT
S: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
S: * OK [PERMANENTFLAGS (\Answered \Flagged \Draft \Deleted \Seen \*)] 
Unlimited
S: * OK [UIDNEXT 2] Predicted next UID
S: * OK [UIDVALIDITY 1354526937] UIDs valid
S: a OK [READ-WRITE] SELECT completed
... someone else remove this one mail.
C: b UID MOVE 1 b
S: * 1 EXPUNGE
S: * 0 EXISTS
S: * 0 RECENT
S: b OK UID MOVE completed

can we add an complete example with some asynchronus expunged mails? 
(one for UID MOVE and one with MOVE).

-- 
Thomas Dressler
Software-Entwickler

1&1 Internet AG - Mail System Development
Brauerstrasse 48 DE-76135 Karlsruhe
Telefon: +49 721 91374-6790
[email-masked]

Amtsgericht Montabaur / HRB 6484
Vorstaende: Henning Ahlert, Ralph Dommermuth, Matthias Ehrlich, Thomas Gottschlich, Robert Hoffmann, Markus Huhn, Hans-Henning Kettler, Dr. Oliver Mauss, Jan Oetjen
Aufsichtsratsvorsitzender: Michael Scheeren

---

From: Timo Sirainen <[email-masked]>
Date: Mon, 3 Dec 2012 11:56:26 +0200

On 3.12.2012, at 11.35, Thomas Dressler wrote:

> S: * OK [PERMANENTFLAGS (\Answered \Flagged \Draft \Deleted \Seen \*)] Unlimited
> can we add an complete example with some asynchronus expunged mails? (one for UID MOVE and one with MOVE).

I think the server should return NO [EXPUNGEISSUED] reply in that case just like it would for COPY (mine does). But yeah, the current move draft itself allows OK reply as well.