Subject: [imapext] [IMAP] International mailbox names

From: Jayantheesh S B <[email-masked]>
Date: Tue, 11 Nov 2014 23:21:23 +0000

Dear All,

As per RFC 3501, for international mailbox names, MODIFIED UTF 7 CHARSET format should be used.

we see Yahoo IMAP server is not honoring the request with this charset, whereas other ISP like, Gmail, AOL, Isode supports it.

We are not sure how many providers available in the market really honoring this format.

Is there any way email client can know, all the charset supported by the IMAP server?  So, that client can ignore the particular charset format with that server.

Please find the log snippet below.

Yahoo:
---------
>>> 114 CAPABILITY
<<< #null# ["CAPABILITY", "IMAP4rev1", "ID", "NAMESPACE", "X-ID-ACLID", "UIDPLUS", "LITERAL+", "CHILDREN", "XAPPLEPUSHSERVICE", "XYMHIGHESTMODSEQ", "AUTH=PLAIN", "AUTH=LOGIN", "AUTH=OAUTH2", "AUTH=XYMCOOKIE", "AUTH=XYMECOOKIE", "AUTH=XYMCOOKIEB64", "AUTH=XYMPKI"]

>>> 77 STATUS "&C4cLqAvNC6QLvwuvC74-" (UIDVALIDITY)
<<< #77# ["NO", ["CANNOT"], "STATUS Mailbox name(s) cannot be encoded using the specified charset"]

>>> 79 CREATE "&C4cLqAvNC6QLvwuvC74-"
<<< #79# ["NO", ["CANNOT"], "CREATE Mailbox name(s) cannot be encoded using the specified charset"]

action=create newMailboxName=இந்தியா result=failure reason=#79# ["NO", ["CANNOT"], "CREATE Mailbox name(s) cannot be encoded using the specified charset"]

Gmail:
---------

>>> 74 CAPABILITY
<<< #null# ["CAPABILITY", "IMAP4rev1", "UNSELECT", "IDLE", "NAMESPACE", "QUOTA", "ID", "XLIST",  "CHILDREN", "X-GM-EXT-1", "UIDPLUS",  "COMPRESS=DEFLATE", "ENABLE", "MOVE",  "CONDSTORE", "ESEARCH", "UTF8=ACCEPT"]

>>> 49 STATUS "&C4cLqAvNC6QLvwuvC74-" (UIDVALIDITY)
<<< #49# ["NO", ["NONEXISTENT"], "Invalid folder: &C4cLqAvNC6QLvwuvC74- (Failure)"]

>>> 51 CREATE "&C4cLqAvNC6QLvwuvC74-"
<<< #51# ["OK", "Success"]

action=create newMailboxName=இந்தியா result=success

Regards,
Jay

---

From: Chris Newman <[email-masked]>
Date: Wed, 12 Nov 2014 14:23:44 -1000

This is the first time I've heard of a server that behaves in such a
user-hostile fashion when provided with a valid MUTF-7 mailbox name. Have you
investigated reporting this as a bug to Yahoo? It's possible they've just never
tested with a valid Tamil mailbox name.

In the meantime, I'd suggest end-users who care about non-ASCII mailbox names
avoid using service providers that are hostile to such names. And if you want
your mail client to behave more gracefully, you could detect when a service
provider gives such an inappropriate error to a standards-compliant mailbox
name and report it to the end-user as a service provider limitation.

		- Chris

--On November 11, 2014 23:21:23 +0000 Jayantheesh S B <[email-masked]>
wrote:

> we see Yahoo IMAP server is not honoring the request with this charset,
> whereas other ISP like, Gmail, AOL, Isode supports it.
> 
> Is there any way email client can know, all the charset supported by the IMAP
> server?  So, that client can ignore the particular charset format with that
> server.
> 
> <<< #null# ["CAPABILITY", "IMAP4rev1", "ID", "NAMESPACE", "X-ID-ACLID",
> "UIDPLUS", "LITERAL+", "CHILDREN", "XAPPLEPUSHSERVICE", "XYMHIGHESTMODSEQ",
> "AUTH=PLAIN", "AUTH=LOGIN", "AUTH=OAUTH2", "AUTH=XYMCOOKIE",
> "AUTH=XYMECOOKIE", "AUTH=XYMCOOKIEB64", "AUTH=XYMPKI"]
> 
> action=create newMailboxName=இந்தியா result=failure reason=#79#
> ["NO", ["CANNOT"], "CREATE Mailbox name(s) cannot be encoded using the
> specified charset"]
> 
> 
> Gmail:
> ---------
> 
>>>> 74 CAPABILITY
> <<< #null# ["CAPABILITY", "IMAP4rev1", "UNSELECT", "IDLE", "NAMESPACE",
> "QUOTA", "ID", "XLIST",  "CHILDREN", "X-GM-EXT-1", "UIDPLUS",
> "COMPRESS=DEFLATE", "ENABLE", "MOVE",  "CONDSTORE", "ESEARCH", "UTF8=ACCEPT"]
>

---

From: Jayantheesh S B <[email-masked]>
Date: Thu, 13 Nov 2014 16:21:04 +0000

Thanks Chris for your response. 

We will escalate the issue to Yahoo IMAP protocol team.

Time being, we will handle this scenario in our email client itself.

Regards,
Jay
-----Original Message-----
From: Chris Newman [mailto:[email-masked]] 
Sent: Wednesday, November 12, 2014 7:24 PM
To: Jayantheesh S B; [email-masked]'
Subject: Re: [imapext] [IMAP] International mailbox names

This is the first time I've heard of a server that behaves in such a user-hostile fashion when provided with a valid MUTF-7 mailbox name. Have you investigated reporting this as a bug to Yahoo? It's possible they've just never tested with a valid Tamil mailbox name.

In the meantime, I'd suggest end-users who care about non-ASCII mailbox names avoid using service providers that are hostile to such names. And if you want your mail client to behave more gracefully, you could detect when a service provider gives such an inappropriate error to a standards-compliant mailbox name and report it to the end-user as a service provider limitation.

		- Chris

--On November 11, 2014 23:21:23 +0000 Jayantheesh S B <[email-masked]>
wrote:

> we see Yahoo IMAP server is not honoring the request with this 
> charset, whereas other ISP like, Gmail, AOL, Isode supports it.
> 
> Is there any way email client can know, all the charset supported by 
> the IMAP server?  So, that client can ignore the particular charset 
> format with that server.
> 
> <<< #null# ["CAPABILITY", "IMAP4rev1", "ID", "NAMESPACE", 
> "X-ID-ACLID", "UIDPLUS", "LITERAL+", "CHILDREN", "XAPPLEPUSHSERVICE", 
> "XYMHIGHESTMODSEQ", "AUTH=PLAIN", "AUTH=LOGIN", "AUTH=OAUTH2", 
> "AUTH=XYMCOOKIE", "AUTH=XYMECOOKIE", "AUTH=XYMCOOKIEB64", 
> "AUTH=XYMPKI"]
> 
> action=create newMailboxName=இந்தியா result=failure reason=#79# ["NO", 
> ["CANNOT"], "CREATE Mailbox name(s) cannot be encoded using the 
> specified charset"]
> 
> 
> Gmail:
> ---------
> 
>>>> 74 CAPABILITY
> <<< #null# ["CAPABILITY", "IMAP4rev1", "UNSELECT", "IDLE", 
> "NAMESPACE", "QUOTA", "ID", "XLIST",  "CHILDREN", "X-GM-EXT-1", 
> "UIDPLUS", "COMPRESS=DEFLATE", "ENABLE", "MOVE",  "CONDSTORE", 
> "ESEARCH", "UTF8=ACCEPT"]
>

---

From: Paul Smith <[email-masked]>
Date: Thu, 13 Nov 2014 08:49:25 +0000

> tested with a valid Tamil mailbox name.
I agree.

I'd expect most *servers* to be able to handle ANY valid MUTF-7 mailbox 
name. The MUTF-7 encoding means that the name is essentially ASCII, so 
can be stored and handled in exactly the same way as a US-ASCII name.

On the other hand, I wouldn't be surprised if some *clients* can't 
support some valid MUTF-7 mailbox names, as those have to convert it to 
a user-readable form. Maybe that is why Yahoo's server rejects the name. 
They know that their web-based mail client will have to display it, and 
it is a limitation with their client. Their server is just rejecting the 
name because they are considering the limitations of their web-based client.

-

Paul Smith Computer Services
Tel: 01484 855800
Vat No: GB 685 6987 53

Sign up for news & updates at http://www.pscs.co.uk/go/subscribe

---

From: Dave Cridland <[email-masked]>
Date: Thu, 13 Nov 2014 17:52:18 +0000

On 13 November 2014 08:49, Paul Smith <[email-masked]> wrote:

> name. The MUTF-7 encoding means that the name is essentially ASCII, so can
> be stored and handled in exactly the same way as a US-ASCII name.
>
> On the other hand, I wouldn't be surprised if some *clients* can't support
> some valid MUTF-7 mailbox names, as those have to convert it to a
> user-readable form. Maybe that is why Yahoo's server rejects the name. They
> know that their web-based mail client will have to display it, and it is a
> limitation with their client. Their server is just rejecting the name
> because they are considering the limitations of their web-based client.
>

... or the rest of their mail system, which probably knows how to handle
native unicode or something. Yahoo's IMAP is just a gateway into their mail
system after all.

Not that I'm excusing them from having to follow the standard, mind.

Dave.