Subject: [imapext] IMAP COMPRESS DEFLATE

From: Jayantheesh S B <[email-masked]>
Date: Tue, 8 Sep 2015 20:27:35 +0000

HI All,

We have observed below IMAP COMPRESS DEFLATE feature issue with Naver.com (Korean email provider).

Issue:
During the mail sync with COMPRESS DEFALTE feature enabled, randomly we are receiving "BAD" response for various IMAP commands.
It's happening randomly, not regularly. Same implementation is working fine with Gmail accounts.  Please find the log snippet below.

Kindly throw some light on this issue.

NOTE: This random issue is not happening when I disable the IMAP COMPRESS DEFLATE feature.

Log Snippet:
09-08 15:39:33.345 11988 12246 D MailTransport: >>> 91 NOOP
09-08 15:39:34.705 11988 12246 D Email   : <<< #null# ["OK", ["CAPABILITY", "IMAP4rev1", "LITERAL+", "SASL-IR", "ID", "AUTH=PLAIN"], "Naver Imap Server ready."]

09-08 15:39:34.715 11988 12246 D MailTransport: >>> 92 CAPABILITY
09-08 15:39:34.985 11988 12246 D Email   : <<< #null# ["CAPABILITY", "IMAP4rev1", "LITERAL+", "SASL-IR", "ID", "UNSELECT", "CHILDREN", "UIDPLUS", "LIST-EXTENDED", "I18NLEVEL=1", "WITHIN", "MOVE", "QUOTA", "SPECIAL-USE", "AUTH=PLAIN"]
09-08 15:39:34.995 11988 12246 D Email   : <<< #92# ["OK", "Capability completed."]

09-08 15:39:35.015 11988 12246 D MailTransport: >>> 93 ID ("name" "com.samsung.android.email.sync" "os" "android" "os-version" "5.0; LRX21T" "vendor" "samsung" "x-android-device-model" "SM-G900V" "x-android-mobile-net-operator" "Verizon Wireless" "AGUID" "31B9plZ+dEt5o/0dhRWihc+AcfQ=")
09-08 15:39:35.275 11988 12246 D Email   : <<< #null# ["ID", ]
09-08 15:39:35.295 11988 12246 D Email   : <<< #93# ["OK", "ID completed."]

09-08 15:39:35.305 11988 12246 D MailTransport: >>> 94 LOGIN yaho2kgo XXXXX
09-08 15:39:35.615 11988 12246 D Email   : <<< #94# ["OK", ["CAPABILITY", "COMPRESS=DEFLATE", "IMAP4rev1", "LITERAL+", "SASL-IR", "ID", "UNSELECT", "CHILDREN", "UIDPLUS", "LIST-EXTENDED", "I18NLEVEL=1", "WITHIN", "MOVE", "QUOTA", "SPECIAL-USE"], "Logged in"]

09-08 15:39:35.625 11988 12246 D MailTransport: >>> 95 COMPRESS DEFLATE
09-08 15:39:35.865 11988 12246 D Email   : <<< #95# ["OK", "Begin compression."]

09-08 15:39:35.885 11988 12246 D MailTransport: >>> 96 SELECT "INBOX"
09-08 15:39:36.425 11988 12246 D Email   : <<< #null# ["FLAGS", ["\Answered", "\Flagged", "\Deleted", "\Seen", "\Draft"]]
09-08 15:39:36.435 11988 12246 D Email   : <<< #null# ["OK", ["PERMANENTFLAGS", ["\Answered", "\Flagged", "\Deleted", "\Seen", "\Draft", "\*"]], "Flags permitted."]
09-08 15:39:36.435 11988 12246 D Email   : <<< #null# ["538", "EXISTS"]
09-08 15:39:36.435 11988 12246 D Email   : <<< #null# ["0", "RECENT"]
09-08 15:39:36.435 11988 12246 D Email   : <<< #null# ["OK", ["UNSEEN", "3"], "First unseen."]
09-08 15:39:36.445 11988 12246 D Email   : <<< #null# ["OK", ["UIDVALIDITY", "0"], "UIDs valid"]
09-08 15:39:36.445 11988 12246 D Email   : <<< #null# ["OK", ["UIDNEXT", "1168"], "Predicted next UID"]
09-08 15:39:36.445 11988 12246 D Email   : <<< #null# ["OK", ["NOMODSEQ"], "No permanent modsequences"]
09-08 15:39:36.455 11988 12246 D Email   : <<< #96# ["OK", ["READ-WRITE"], "Select completed."]

09-08 15:39:36.485 11988 12246 D MailTransport: >>> 97 UID STORE 1166 +FLAGS.SILENT (\FLAGGED)
09-08 15:39:36.755 11988 12246 D Email   : <<< #97# ["BAD", "Error in IMAP command UID: Empty command line"

Regards,
Jay

---

From: [email-masked]
Date: Wed, 9 Sep 2015 20:46:11 +0200

Clearly a bug. I suggest taking to Naver directly about it.

BTW I am 
disappointed that Naver advertises 13 extensions, but only four by me 
;)

Arnt