Subject: [imapext] I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

From: [email-masked]
Date: Wed, 07 Oct 2015 15:04:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IMAP APPEND Extensions Working Group of the IETF.

        Title           : The IMAP APPENDLIMIT Extension
        Authors         : Samsung Telecommunications America
                          Narendra Singh Bisht
	Filename        : draft-ietf-imapapnd-appendlimit-extension-04.txt
	Pages           : 7
	Date            : 2015-10-07

Abstract:
This memo defines an extension to the IMAP service whereby a server can
advertise its capability, to support maximum mail upload size using
CAPABILITY, STATUS and LIST commands.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-imapapnd-appendlimit-extension/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-imapapnd-appendlimit-extension-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-imapapnd-appendlimit-extension-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jayantheesh S B <[email-masked]>
Date: Wed, 7 Oct 2015 22:08:21 +0000

Hi All,

Please find the updated IMAP APPENDLIMIT draft version 04 with SM's and Timo's review comments addressed. 

Kindly go through the same and share your response.

Regards,
Jay
-----Original Message-----
From: imapext [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, October 07, 2015 6:05 PM
To: [email-masked]
Cc: [email-masked]
Subject: [imapext] I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Abstract:
This memo defines an extension to the IMAP service whereby a server can advertise its capability, to support maximum mail upload size using CAPABILITY, STATUS and LIST commands.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
imapext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/imapext

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 08 Oct 2015 13:23:04 +0100

Hi Jay,

The changes mostly look good, but one thing I would like to discuss:

> 2. APPENDLIMIT Extension
>
>
> An IMAP server that supports APPENDLIMIT extension advertises this by
> including the name APPENDLIMIT in its capability list. IMAP server
> SHOULD advertise this capability after user has logged in.
I was thinking that this would be better as a MAY, because it alerts 
implementations to the possibility, but doesn't have any effect in 
interoperability. Clients need to handle that no matter when the 
capability is sent.
> IMAP server
> can publish the APPENDLIMIT capability in two formats.

---

From: Jayantheesh S B <[email-masked]>
Date: Thu, 8 Oct 2015 15:15:40 +0000

Hi Alexey,

Thanks for reviewing the document.

We will wait for other comments as well and address your review comments in the next version of the document. 

Regards,
Jay
-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Thursday, October 08, 2015 8:23 AM
To: Jayantheesh S B; [email-masked]
Subject: Re: [imapext] FW: I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Hi Jay,

> SHOULD advertise this capability after user has logged in.
I was thinking that this would be better as a MAY, because it alerts implementations to the possibility, but doesn't have any effect in interoperability. Clients need to handle that no matter when the capability is sent.

---

From: Jayantheesh S B <[email-masked]>
Date: Mon, 12 Oct 2015 15:01:28 +0000

Hi All,

Apart from Alexey's comments, if anybody has any comments, kindly share it to conclude the draft. 

Regards,
Jay
-----Original Message-----
From: imapext [mailto:[email-masked]] On Behalf Of Jayantheesh S B
Sent: Thursday, October 08, 2015 11:16 AM
To: Alexey Melnikov; [email-masked]
Subject: Re: [imapext] FW: I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Hi Alexey,

Regards,
Jay
-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]]
Sent: Thursday, October 08, 2015 8:23 AM
To: Jayantheesh S B; [email-masked]
Subject: Re: [imapext] FW: I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Hi Jay,

---

From: Jayantheesh S B <[email-masked]>
Date: Wed, 14 Oct 2015 14:46:11 +0000

Hi All,

I will be publishing the next version of the draft with Alexey's comments addressed today.

Kindly let me know, if anything needs to be changed in the next version. 

SM,

Kindly check this version and make sure all of your concerns are addressed.

Regards,
Jay
-----Original Message-----
From: Jayantheesh S B 
Sent: Monday, October 12, 2015 11:01 AM
To: Jayantheesh S B; Alexey Melnikov; [email-masked]
Subject: RE: [imapext] FW: I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Hi All,

Regards,
Jay
-----Original Message-----
From: imapext [mailto:[email-masked]] On Behalf Of Jayantheesh S B
Sent: Thursday, October 08, 2015 11:16 AM
To: Alexey Melnikov; [email-masked]
Subject: Re: [imapext] FW: I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Hi Alexey,

Regards,
Jay
-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]]
Sent: Thursday, October 08, 2015 8:23 AM
To: Jayantheesh S B; [email-masked]
Subject: Re: [imapext] FW: I-D Action: draft-ietf-imapapnd-appendlimit-extension-04.txt

Hi Jay,

---

From: S Moonesamy <[email-masked]>
Date: Wed, 14 Oct 2015 14:22:11 -0700

Hi Arnt, Timo,

Are you okay with draft-ietf-imapapnd-appendlimit-extension-04 [1]?

Regards,
S. Moonesamy

1. https://tools.ietf.org/html/draft-ietf-imapapnd-appendlimit-extension-04

---

From: [email-masked]
Date: Fri, 16 Oct 2015 23:56:42 +0200

Hi,

I still do not see any rationale or justification.

Arnt