Subject: [imapext] [Errata Verified] RFC7889 (5726)

From: RFC Errata System <[email-masked]>
Date: Mon, 20 May 2019 15:35:59 -0700 (PDT)

The following errata report has been verified for RFC7889,
"The IMAP APPENDLIMIT Extension". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5726

--------------------------------------
Status: Verified
Type: Editorial

Reported by: Stan Kalisch <[email-masked]>
Date Reported: 2019-05-20
Verified by: Barry Leiba (IESG)

Section: 3.2

Original Text
-------------
   C: t1 LIST "" % RETURN (STATUS (APPENDLIMIT))
   S: * LIST () "."  "INBOX"
   S: * STATUS "INBOX" (APPENDLIMIT 257890)
   S: t1 OK List completed.

Corrected Text
--------------
   C: t1 LIST "" % RETURN (STATUS (APPENDLIMIT))
   S: * LIST () "." "INBOX"
   S: * STATUS "INBOX" (APPENDLIMIT 257890)
   S: t1 OK List completed.

Notes
-----
Line 198 contains two spaces between ""."" and ""INBOX"" instead of one.  While I had the instinct to mark this as editorial, this sample server response, whose genesis appears to be RFC 5819, ended up in two IDs (which were corrected before they became RFCs) as well.  In any event, given that this response also violates the ABNF, and given the RFC Ed.'s guideline on ambiguity, I'm just marking it as technical.  I'll leave it to others more familiar with the practical issues for various implementers to make the final determination on how to label it.

----- Verifier notes -----
Yes, this is an error: it comes from a combination of the RFC Editor style of double-spacing between sentences, the construction of the examples in XML in a manner that doesn't distinguish them from sentences, and the fact that it's nearly impossible to notice the situation when one is giving a final review.

Editorial, though, because it's in examples.  The ABNF is the authoritative place, and that's correct.

--------------------------------------
RFC7889 (draft-ietf-imapapnd-appendlimit-extension-10)
--------------------------------------
Title               : The IMAP APPENDLIMIT Extension
Publication Date    : May 2016
Author(s)           : J. SrimushnamBoovaraghamoorthy, N. Bisht
Category            : PROPOSED STANDARD
Source              : IMAP APPEND Extensions
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: "Stan Kalisch" <[email-masked]>
Date: Mon, 20 May 2019 19:09:44 -0400

> Editorial, though, because it's in examples. The ABNF is the authoritative place, and that's correct.

This is helpful to know, and when you put it like that, makes complete sense to me. I suppose part of my confusion stems from the fact that I reported an erratum for an example in an RFC about two years ago and it was verified as technical. Is this something that varies across disciplines? This may be helpful information for those who report errors but are not as familiar as others with the IETF and RFC Editor's process.

Thanks,
Stan

---

From: Barry Leiba <[email-masked]>
Date: Mon, 20 May 2019 19:59:24 -0400

> This is helpful to know, and when you put it like that, makes complete sense to me.  I suppose part
> of my confusion stems from the fact that I reported an erratum for an example in an RFC about two
> years ago and it was verified as technical.  Is this something that varies across disciplines?

No, I think it's something that varies according to the judgment of
different ADs.

The IESG errata guidelines
<https://www.ietf.org/blog/iesg-processing-rfc-errata-ietf-stream/>
say this:

<< Only errors that could cause implementation or deployment problems
or significant confusion should be Verified. >>

That's kind of vague.  This AD takes that to mean that an error in an
example should be "Verified" (rather than "Held for Document Update"),
but that it's editorial, not technical.  Other ADs have different
interpretations.

Perhaps it'd be nice if there was complete consistency, but
individuals are individuals, and we don't agree on
<strike>anything</strike> everything.

Barry