Subject: Re: [IMRG] Measurement TCPs

From: k claffy <[email-masked]>
Date: Thu, 17 Oct 2002 10:23:43 -0700

eeps, folks, i just found out about this 
mailing list yesterday; i likely should
have chimed in by now; will try to catch up.

  > > How will be able to build a measurements community when the "raw
  > > material" of our work (i.e., traces) is only available to a 
  > few research labs?
  
  As we all know most of the BGP data is  archived and got from
  oregon, RIPE and geoff's pages. It is difficult for service 
  providers to give such data for intra-domain stuff. But, they 
  can always remove/filter sensitive details and put on a public 
  server. 
  
  Other possibilities:
  
  1. we can form a measurement repository with the help of caida,
  or any other lab and submit our data (on which  one's research 
  work is based) to them.

i have mentioned this to a few folks on the list,
but nsf just (partially) funded a project to
do something similar:
http://www.caida.org/projects/proposals/nsf98120/

(it was submitted to NSF in august 2001
but only funded last week,  so we haven't
formally started the project yet.  
now is the time to let folks know about it
and gather interest.  it is a project that
is supposed to leave such a meta-data repository as
a deliverable to the research community,
which means we need folks involved from the beginning
to help define [attributes/schemas] and populate it)

btw i haven't seen vern's great talk mentioned 
on this list (maybe it was and i missed it)
but it's well worth keeping a copy on your laptop
	http://www.icir.org/vern/talks/vp-nrdm01.ps.gz
(i heard this talk shortly after i'd submitted the
above proposal, and i was all `geez, i hope vern
is one of the reviewers...')

  2. Service providers can put their data in a public server after
  proning sensitive details. Sprintlabs page on data analysis
  is starting point to such a initiative. 

christophe and his group have worked hard for
years to get the community closer to where we
need to be and his efforts are starting to show/shine,
many kudos.

what-used-to-be-MFN (vix and stephen stuart) have also
gone to great lengths to help [email-masked] 
(who has gone to even greater lengths) 
get oc48 traces for caida and caida AUP-ed 
visitors to use. more kudos.
(joerg also has some commercial-ish NZIX traces:
bottom of http://pma.nlanr.net/Traces/long/)

but all admittedly baby steps.  const
wants us to dance faster. i too.
  
  3. Universities can share their data through their lab pages like
  MIT LCS lab intiative (http://bgp.lcs.mit.edu/)
  
  or
  
  we should make it a condition that all measurement related paper's 
  published by SIGCOMM has to submit their data to 
  http://www.acm.org/sigcomm/ITA/index.html :-)

see vern's talk above

  But, again it depends on what type of information one prefers. If it
  is some kind of VoIP quality testing, it is pretty difficult.

not sure what that means exactly.
that some data is easier to fudge than others?

k

  > a lot of cool stuff (not everything, i agree) can be done from the
  > sidelines (as you demonstrated in your sigcomm talk), and 
  > that is actually
  > part of the fun and challenge in measurement work.
  
  It might be a case for BGP and some of the active measurement stuff. 
  But, one has to accept Constantinos views for getting/sharing some 
  of intra-domain data and product oreinted traces (VoIP etc.) Hope you
  remember that i have contacted you once for a particular data and your
  response:
  > -----Original Message-----
  > From: Ratul Mahajan [mailto:[email-masked]]
  > Sent: Saturday, May 25, 2002 10:03 PM
  > To: Ayyasamy, Senthilkumar (UMKC-Student)
  > Subject: Re: BGP/nanog
  > 
  > we never got into archiving traffic. not aware of anyone else who 
  > does and shares. 
  _______________________________________________
  IMRG mailing list
  [email-masked]
  https://www1.ietf.org/mailman/listinfo/imrg
_______________________________________________
IMRG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imrg

---

From: k claffy <[email-masked]>
Date: Thu, 17 Oct 2002 10:39:13 -0700

don't forget jun/jinliang et al gatech/sprintlabs paper 

http://citeseer.nj.nec.com/xu01design.html
code at
http://www.cc.gatech.edu/fac/Mostafa.Ammar/#research
i think mostafa's group is still doing work in this area.

k

On Mon, Sep 16, 2002 at 01:23:37PM -0500, Ethan Blanton wrote:
  Remco van de Meent spake unto us the following wisdom:
  > One of the issues with releasing raw data is privacy of users.
  > 
  > I'm wondering if people out there have standard tools or algorithms for
  > anonymization of packet traces? Preferably while keeping the tcpdump
  > file format?
  
  I can't claim it's standard, or even that anyone but a few people at
  Ohio University use it, but I have a simple tool at
  http://irg.cs.ohiou.edu/~eblanton/tcpurify/ that is intended to do
  just this.  The anonymization algorithm currently distributed with it
  is, unfortunately, too weak for many uses; I have plans for several
  more powerful algorithms, but they are all held up by either
  intellectual property (who patents crypto? :-P) or computational
  complexity issues.  In the miraculous chance that I should get some
  free time, some strong-crypto-based anonymization methods will be
  going in there.
  
  At any rate, in the meantime it is a simple-to-use framework if
  nothing else.
  Ethan
  
  -- 
  And if I claim to be a wise man / it surely means that I don't know.
                  -- Kansas, "Carry on Wayward Son"

---

From: "Ayyasamy, Senthilkumar (UMKC-Student)" <[email-masked]>
Date: Thu, 17 Oct 2002 13:17:43 -0500

> i think mostafa's group is still doing work in this area.

More relevant link:
http://www.cc.gatech.edu/computing/Telecomm/cryptopan/

(Note: Myself and marcelo are scanning the web for tools, 
projects, and papers relating to measurements for putting up 
in the IMRG site. So, If anyone has some pointers please sent
to me or marcelo <[email-masked]>.

- Senthil.