Subject: [imss] RE: re-view: T11-FC-FABRIC-LOCK-MIB in draft-ietf-imss-fc-zs-mib-01.txt

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Tue, 2 Jan 2007 13:06:40 +0200

Thanks, Bert for the review. 

A couple of observations:

> -----Original Message-----
> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> 
> - Since you use RFC3584 in a REFERENCE clause, you may want to add
>   it in the references section. I am not sure I would want it
>   to be a normative ref, but at least an informative one I think.

I would like to support this. New versions of id-nits issue warnings for
such situations, so there are good chances that you will get comments
later in the process if you do not add this reference now. 

> 
> - I wonder about:
>    t11FLockInitiatorIpAddrType OBJECT-TYPE
>     SYNTAX          InetAddressType
>     MAX-ACCESS      read-only
>     STATUS          current
>     DESCRIPTION
>            "This object specifies the type of IP address contained
>            in the corresponding instance of t11FLockInitiatorIpAddr.
>            If the IP address of the location of the initiator is
>            unknown or not applicable, this object is either not
>            instantiated or has the value: 'unknown'."
> 
>    Would it not be better to use "unknown" instead of allowing a
>    not instantiated case? That just creates gaps in the table and
>    I believe that such is just (unneeded) extra complexity for
>    NM applications.
> 
>    Same for: t11FLockInitiatorIpAddr
> 

Are not instantiated objects in a row in a table legal at all SMI-wise? 

Dan

_______________________________________________
imss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imss

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Tue, 2 Jan 2007 13:03:35 +0100

Inline 

> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: dinsdag 2 januari 2007 12:07
> To: Wijnen, Bert (Bert); [email-masked]
> Subject: [imss] RE: re-view: T11-FC-FABRIC-LOCK-MIB 
> indraft-ietf-imss-fc-zs-mib-01.txt
> 
> I would like to support this. New versions of id-nits issue 
> warnings for such situations, so there are good chances that 
> you will get comments later in the process if you do not add 
> this reference now. 
> 
> > 
> > - I wonder about:
Yes, I believe they are legal. a GET request would return a 
noSuchInstance. But I know that many NM APPS have trouble
with the HETNEXT (or GETBULK) when such entries are just
skipped.

Bert