Subject: [imss] WG Action: RECHARTER: Internet and Management Support for Storage (imss)

From: IESG Secretary <[email-masked]>
Date: Tue, 24 Apr 2007 15:50:02 -0400

The charter of the Internet and Management Support for Storage (imss)
working group in the Operations and Management Area of the IETF has been
updated. For additional information, please contact the Area Directors
or the working group Chairs.

+++

Internet and Management Support for Storage (imss)
--------------------------------------------------

Current Status: Active Working Group 

Additional information is available at tools.ietf.org/wg/imss 

Chair(s):
David Black <[email-masked]> 

Operations and Management Area Director(s):
Dan Romascanu <[email-masked]> 
Ronald Bonica <[email-masked]> 

Operations and Management Area Advisor:
Dan Romascanu <[email-masked]> 

Technical Advisor(s):
Keith McCloghrie <[email-masked]> 
Margaret Wasserman <[email-masked]> 

Mailing Lists:
General Discussion: [email-masked]
To Subscribe: https://www1.ietf.org/mailman/listinfo/imss
Archive: http://www.ietf.org/mail-archive/web/imss/index.html

Description of Working Group:
Fibre Channel is a high speed network technology primarily used for
storage networking (i.e., Storage Area Networks [SANs]). Two important
aspects of Fibre Channel interact with the Internet:
- Fibre Channel can encapsulate and carry IP protocol traffic
- Fibre Channel devices can be managed via SNMP

The Internet and Management Support for Storage WG (imss) is chartered
to address two areas, specifically:
- IPv4 over Fibre Channel has been specified in RFC 2625. A
corresponding specification for IPv6 is needed.
- An initial Fibre Channel Management MIB has been developed by
the IP Storage (ips) WG; extensions are needed to encompass
management of additional aspects of Fibre Channel, such
as zoning.

In the future, other storage related MIBs for other storage transports
such as INCITS T10 Serial Attached SCSI (SAS) or SCSI command specific
MIBs may be proposed. This group would work with the appropriate
technical committee(s) in a manner similar to that described for INCITS
T11 below.

As Fibre Channel standardization is handled by the INCITS T11 Technical
Committee (http://www.t11.org), a close working relationship with T11 is
essential to the WG's success. In particular:
- The IPv6 over Fibre Channel specification will be based on
draft-desanti-ipv6-over-fibre-channel-02.txt. This draft
was originally developed within a T11 study group and T11
has officially recommended this draft to the IETF.
- The WG will not standardize management of Fibre Channel 
features ahead of their incorporation into appropriate T11 
Fibre Channel standards.
- The WG will work closely with T11, specifically Task Group 
T11.5, on the functionality and structure of the MIBs it 
develops for management of Fibre Channel.

In addition to working closely with the INCITS T11 Technical Committee,
this Working Group will work closely with IETF IPv6 Working Group as
appropriate. In particular, the IPv6 Working Group will be kept informed
on the progress and status of the IPv6 over Fibre Channel specification.
The IMSS Working Group Last Call announcement will be cross-posted to
the IPv6 WG mailing list.

Goals and Milestones:
Done Submit IPv6 over Fibre Channel draft to IESG for consideration
as Proposed Standard 
Done Submit Fibre Channel Fabric Address Manager MIB to IESG for
consideration as Proposed Standard 
Done Submit Fibre Channel Name Server MIB to IESG for consideration
as Proposed Standard 
Done Work with T11.5 to determine what additional MIB modules are
needed 
Done Submit Routing Information, FSPF and Virtual Fabrics MIBs to
IESG for consideration as Proposed Standard 
Done Submit Fibre Channel Zone Server, RSCN, and Fabric Configuration
Server MIBs to IESG for consideration as Proposed Standard 
Done Review working group charter and determine what additional work,
if any, should be undertaken by working group 
December 2007 Submit Fibre Channel Security MIB modules to IESG for
consideration as proposed standard

_______________________________________________
imss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imss

---

From: [email-masked]
Date: Wed, 25 Apr 2007 11:44:31 -0400

FYI - this charter update is to add the work item for the FC
Security MIB modules.  The body of the charter is unchanged.

Many thanks to Dan Romascanu (our AD) for making this happen.

Thanks,
--David 

-----Original Message-----
From: IESG Secretary [mailto:[email-masked]] 
Sent: Tuesday, April 24, 2007 3:50 PM
To: [email-masked]
Cc: Black, David; [email-masked]
Subject: WG Action: RECHARTER: Internet and Management Support for
Storage (imss) 

+++

Chair(s):

Technical Advisor(s):

Mailing Lists:

Goals and Milestones: