Subject: [Insipid] draft-dawes-dispatch-logme-reqs after IETF#88

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Thu, 16 Jan 2014 17:31:19 +0000

Hello All,
Following up from IETF#88 I have uploaded a revised logme requirements draft (version -04). 

https://datatracker.ietf.org/doc/draft-dawes-dispatch-logme-reqs/

As per the comments in Vancouver, version -04 does not include REQ9 regarding a logging server address and the related sub-clause 6.2.2. Also, clause 7 on potential solutions has been removed. These requirements seem to be stable now. 

I will upload a related solutions draft by the end of next week (Friday 24) at the latest and I hope we can discuss solution options here on the list and then later on at IETF#89 at the beginning of March.

Regards,
Peter

---

From: James Polk <[email-masked]>
Date: Thu, 16 Jan 2014 14:19:25 -0600

Peter

To be blunt, if you seriously want this draft to be considered for 
INSIPID WG adoption you need to put "-insipid-" in the filename, and 
stop putting "-dispatch-" in the filename.

Linking the drafts is simple work for the chairs to do, if that's your concern.

James

At 11:31 AM 1/16/2014, Dawes, Peter, Vodafone Group wrote:
>As per the comments in Vancouver, version -04 does not include REQ9 
>regarding a logging server address and the related sub-clause 6.2.2. 
>Also, clause 7 on potential solutions has been removed. These 
>requirements seem to be stable now.
>
>I will upload a related solutions draft by the end of next week 
>(Friday 24) at the latest and I hope we can discuss solution options 
>here on the list and then later on at IETF#89 at the beginning of March.
>
>Regards,
>Peter
>_______________________________________________
>insipid mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/insipid

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Thu, 16 Jan 2014 21:22:27 +0000

Thanks James, now submitted as draft-dawes-insipid-logme-reqs-00:

http://datatracker.ietf.org/doc/draft-dawes-insipid-logme-reqs/

Peter

-----Original Message-----
From: insipid [mailto:[email-masked]] On Behalf Of James Polk
Sent: 16 January 2014 20:19
To: Dawes, Peter, Vodafone Group
Cc: DRAGE, Keith (Keith) ([email-masked]); [email-masked]; Gonzalo Salgueiro ([email-masked])
Subject: Re: [Insipid] draft-dawes-dispatch-logme-reqs after IETF#88

Peter

To be blunt, if you seriously want this draft to be considered for INSIPID WG adoption you need to put "-insipid-" in the filename, and stop putting "-dispatch-" in the filename.

James

At 11:31 AM 1/16/2014, Dawes, Peter, Vodafone Group wrote:
>I will upload a related solutions draft by the end of next week (Friday 
>24) at the latest and I hope we can discuss solution options here on 
>the list and then later on at IETF#89 at the beginning of March.
>
>Regards,
>Peter

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Thu, 23 Jan 2014 03:38:52 +0000

Hello All,
I have submitted the draft below which describes a solution to the log me requirements and gives a few specific protocol options (the ones that were in clause 7 of the requirements draft reviewed in Vancouver) that could be used to code a log-me marker.

http://www.ietf.org/id/draft-dawes-insipid-logme-solutions-00.txt

This draft has more protocol description than was previously in the requirements draft and tries to give a complete picture of what user agents and SIP proxies need to do to provide log-me marking. It would be good if I could present this solutions draft at IETF#89 for insipid to discuss.  

Rgds,
Peter

-----Original Message-----
From: Dawes, Peter, Vodafone Group 
Sent: 17 January 2014 05:22
To: 'James Polk'
Cc: DRAGE, Keith (Keith) ([email-masked]); [email-masked]; Gonzalo Salgueiro ([email-masked])
Subject: RE: [Insipid] draft-dawes-dispatch-logme-reqs after IETF#88

Peter

-----Original Message-----
From: insipid [mailto:[email-masked]] On Behalf Of James Polk
Sent: 16 January 2014 20:19
To: Dawes, Peter, Vodafone Group
Cc: DRAGE, Keith (Keith) ([email-masked]); [email-masked]; Gonzalo Salgueiro ([email-masked])
Subject: Re: [Insipid] draft-dawes-dispatch-logme-reqs after IETF#88

Peter

James

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Jan 2014 11:12:50 -0500

Some questions about this draft:

Solution A:

    User agents and SIP proxies may send logged information to a debug
    server.

And how do they discover where to send it, and what protocol to use to 
do so?

Solution B:

    Call-Info: mailto:"SIP logging"<[email-masked]>;
               purpose="debug"

Is the use of a mailto URL normative, or just an example?

How do the servers establish trust in this destination when sending 
logs? Is 6.2.2 the whole story? (That doesn't seem very practical.)

Since you have said the logs are to be encrypted, *how* are they 
encrypted so that the server can decode and others cannot?

How should the log be formatted within the mail? How is the test case 
name included in the mailed log?

Solution C:

As with solution A, how is the log sent?

	Thanks,
	Paul