Subject: [Insipid] Review of draft-ietf-insipid-logme-reqs-02

From: Georg Mayer <[email-masked]>
Date: Mon, 08 Jun 2015 11:41:59 +0200

Hello,

I finally managed to review draft-ietf-insipid-logme-reqs-02. I have no 
technical comments on it and support all the requirements therein. In my 
view the draft can progress as is.

Cheers,
Georg

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 10 Jun 2015 13:04:58 +0000

Hi,

I have read the draft. In general it looks ok, but I have a few questions on the requirements.

Q1 (editorial):

In REQ3, I suggest to place the "A "log me" marker SHOULD be removed at trust domain boundaries." sentence before the rest of the text.

Q2 (editorial/technical):

I don't understand REQ4, saying "SIP entities SHOULD log SIP requests or responses with a "log me" marker."

Also, in e.g. REQ6 it is then said that proxies MAY insert the marker, which seems to contradict.

Q3 (editorial/technical):

Regarding REQ5, does that also apply to UAs that do NOT support the mechanism? If so, I think that should be explicitly stated, because it will have big impact on the technical solution.

Regards,

Christer

-----Original Message-----
From: insipid [mailto:[email-masked]] On Behalf Of Georg Mayer
Sent: 8. kesäkuuta 2015 12:42
To: [email-masked]
Cc: [email-masked]
Subject: [Insipid] Review of draft-ietf-insipid-logme-reqs-02

Hello,

I finally managed to review draft-ietf-insipid-logme-reqs-02. I have no technical comments on it and support all the requirements therein. In my view the draft can progress as is.

Cheers,
Georg

_______________________________________________
insipid mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/insipid

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Thu, 11 Jun 2015 12:38:56 +0000

Hi Christer, thanks a lot for your comments and questions, I have replied in-line below.

Best regards,
Peter

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: 10 June 2015 14:05
> To: [email-masked]
> Cc: Dawes, Peter, Vodafone Group
> Subject: RE: [Insipid] Review of draft-ietf-insipid-logme-reqs-02
> 
> Hi,
> 
> In REQ3, I suggest to place the "A "log me" marker SHOULD be removed at
> trust domain boundaries." sentence before the rest of the text.

I agree that the text will read better if I move the final sentence to the beginning, I will do this in the next version.

> Also, in e.g. REQ6 it is then said that proxies MAY insert the marker, which
REQ4 could be re-written slightly more clearly as "SIP entities SHOULD log SIP requests or responses that contain a "log me" marker." The SIP entity checks for the presence of a "log me" marker and writes any request or response that contains a "log me" marker to a log file. 
REQ 6 allows a SIP proxy to insert a "log me" marker to allow the mechanism to work even if the UE does not support this draft, so this talks about inserting a "log me" marker and not checking for its presence. 

> Regarding REQ5, does that also apply to UAs that do NOT support the
> mechanism? If so, I think that should be explicitly stated, because it will have
> big impact on the technical solution.
> 
UEs that do not support the mechanism are not expected to echo the "log me" marker because they don't know about it. However, if the "log me" marker solution is a header field parameter of the Session-ID header field, as currently proposed, then I guess that even UEs that do not support inserting a "log me" marker will echo it if it echoes the whole Session-ID header field.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 11 Jun 2015 17:12:20 +0000

Hi Peter,

See inline.

Q2 (editorial/technical):
 
> REQ4 could be re-written slightly more clearly as "SIP entities SHOULD log SIP requests 
> or responses that contain a "log me" marker." The SIP entity checks for the presence of 
> a "log me" marker and writes any request or response that contains a "log me" marker 
> to a log file. 

I think it would be good to say "SIP entities that support the mechanism SHOULD...", to make it clear that we don't expect certain behaviour from SIP entities that do not support the mechanism. Some people may say it's obvious, but I think it's good to have it explicit :)

> REQ 6 allows a SIP proxy to insert a "log me" marker to allow the mechanism to work even if the UE 
> does not support this draft, so this talks about inserting a "log me" marker and not checking for its presence. 

Got it. Thanks for the clarification.

Q3 (editorial/technical):
 
>> mechanism? If so, I think that should be explicitly stated, because it 
>> will have big impact on the technical solution.
>> 
> UEs that do not support the mechanism are not expected to echo the "log me" marker because
> they don't know about it. However, if the "log me" marker solution is a header field parameter 
> of the Session-ID header field, as currently proposed, then I guess that even UEs that do not 
> support inserting a "log me" marker will echo it if it echoes the whole Session-ID header field. 

Sure, but that is irrelevant as far as the requirements are concerned :)

So, if we don't REQUIRE anything from UAs that don't support the mechanism, I again think it's good to explicitly talk about UAs that support the mechanism.

Regards,

Christer

> I finally managed to review draft-ietf-insipid-logme-reqs-02. I have 
> no technical comments on it and support all the requirements therein. 
> In my view the draft can progress as is.
> 
> Cheers,
> Georg
> 
>

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Fri, 12 Jun 2015 14:16:32 +0000

Thanks Christer, I will make these improvements in the next (-03) version, probably early July.

Regards,
Peter

> Sent: 11 June 2015 18:12
> To: Dawes, Peter, Vodafone Group; [email-masked]
> > REQ4 could be re-written slightly more clearly as "SIP entities SHOULD
> > log SIP requests or responses that contain a "log me" marker." The SIP
> > entity checks for the presence of a "log me" marker and writes any
> > request or response that contains a "log me" marker to a log file.
> 
> I think it would be good to say "SIP entities that support the mechanism
> SHOULD...", to make it clear that we don't expect certain behaviour from SIP
> entities that do not support the mechanism. Some people may say it's
> obvious, but I think it's good to have it explicit :)
> 
> > REQ 6 allows a SIP proxy to insert a "log me" marker to allow the
> > mechanism to work even if the UE does not support this draft, so this talks
> about inserting a "log me" marker and not checking for its presence.
> 
> >> mechanism? If so, I think that should be explicitly stated, because
> >> it will have big impact on the technical solution.
> >>
> > UEs that do not support the mechanism are not expected to echo the
> > "log me" marker because they don't know about it. However, if the "log
> > me" marker solution is a header field parameter of the Session-ID
> > header field, as currently proposed, then I guess that even UEs that do not
> So, if we don't REQUIRE anything from UAs that don't support the
> mechanism, I again think it's good to explicitly talk about UAs that support
> the mechanism.
> 
> Regards,
> 
> Christer
> 
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 12 Jun 2015 14:24:49 +0000

Hi,

>Thanks Christer, I will make these improvements in the next (-03) version, probably early July.

Great.

Note that the draft submission window will close some time before the IETF Prague meeting, though.

Regards,

Christer

> >> I don't understand REQ4, saying "SIP entities SHOULD log SIP 
> >> requests or responses with a "log me" marker."
> >>
> > REQ4 could be re-written slightly more clearly as "SIP entities 
> > SHOULD log SIP requests or responses that contain a "log me" 
> > marker." The SIP entity checks for the presence of a "log me" marker 
> > and writes any request or response that contains a "log me" marker to a log file.
> 
> I think it would be good to say "SIP entities that support the 
> mechanism SHOULD...", to make it clear that we don't expect certain 
> behaviour from SIP entities that do not support the mechanism. Some 
> people may say it's obvious, but I think it's good to have it explicit 
> :)
> 
> > "log me" marker because they don't know about it. However, if the 
> > "log me" marker solution is a header field parameter of the 
> > Session-ID header field, as currently proposed, then I guess that 
> > even UEs that do not
> mechanism, I again think it's good to explicitly talk about UAs that 
> support the mechanism.
> 
> Regards,
> 
> Christer
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Jun 2015 14:59:45 -0400

> Note that the draft submission window will close some time before the IETF Prague meeting, though.

The cutoff is July 6.