Subject: [Int-area] discussion of the ISP shared address idea

From: Jari Arkko <[email-masked]>
Date: Thu, 31 Jul 2008 13:42:05 +0100

I forgot to say this in the meeting, but discussion of

    http://tools.ietf.org/html/draft-shirasaki-isp-shared-addr

should continue here on the intarea list. Please review and comment.

Jari

_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Thu, 31 Jul 2008 16:21:00 +0300

>     http://tools.ietf.org/html/draft-shirasaki-isp-shared-addr

One thing I am afraid of is, some applications do compute the scope of the 
address of the host they're running on. One well-known example is automatic 
6to4 tunnel setup in some operating systems. By essentially extending the 
RFC1918 space, these applications will break.

The counter argument is of course, that these applications are already 
terminally broken due to widespread statefull firewalls, as well as public IP 
space behind NATs (!) today. I totally agree with that counter-argument.

Nevertheless, unless/until someone writes a "Using IPv4 address scopes 
considered harmful" document, I am not very comfortable going forward with 
draft-shirasaki-isp-shared-addr.

-- 
Rémi Denis-Courmont
Maemo Software, Nokia Devices R&D
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 01 Aug 2008 01:46:21 +1200

> should continue here on the intarea list. Please review and comment.

I don't understand why a customer using Net 10 can't be NATted (at the CPE)
into an ISP using Net 10. Since NATs completely separate two address
realms, I can't see any reason this would work any differently than
by inventing Net10bis.

In any case, if we refer to the parable of the slowly boiling frog,
I see this mechanism as allowing the frog to get even closer to
death before noticing that the water is getting too hot. It will
allow carriers to continue pretending that they don't need to route
IPv6 for a whole investment cycle, by which time the IPv4 stock
will have depleted completely.

    Brian

---

From: Shin Miyakawa <[email-masked]>
Date: Thu, 31 Jul 2008 23:02:59 +0900 (JST)

From: Rémi_Denis-Courmont <[email-masked]>
Subject: Re: [Int-area] discussion of the ISP shared address idea
Date: Thu, 31 Jul 2008 16:21:00 +0300

> RFC1918 space, these applications will break.

True.

> space behind NATs (!) today. I totally agree with that counter-argument.

Correct :-) I like this too.

> draft-shirasaki-isp-shared-addr.

Then, still I can not understand this logic actually.

If RFC or some authorative doument tells "here is the space for it" formally,
those application can use IPv4 address scopes to change their behavior, isn't it ?

Or, if you do not like such action,  please do not wait and 
write such a document by yourself, do not let someone else do :-)

Or, very simply, just we should remember that there is some limitation on this 
adress space.

So, in either way, there is no reason to stop our proposal by this discussion,
we think.

Of course, not just only this, there may exist some "cons" of this proposal.
Even in that case, please solve that problems directly, not by stopping this.

Please let me repeat what I talked in the sesssin again today.
If we can not define such a shared space, what ISPs will do is 
going to RIR to get global IPv4 address space for the section
between CGN and CPE, independently. We're afraid of such a waste of usage.
                     =============

Best wishes,

Shin Miyakawa

---

From: Shin Miyakawa <[email-masked]>
Date: Thu, 31 Jul 2008 23:05:54 +0900 (JST)

From: Brian E Carpenter <[email-masked]>
> into an ISP using Net 10. 

Because today's CPE can not do this.
Reason why we need this, to avoid CPE replacement.

Shin Miyakawa

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 01 Aug 2008 02:34:17 +1200

> Because today's CPE can not do this.

Really? I don't quite understand how anyone could design a NAT
with that restriction. Can you explain this?

I also understood that in some countries, ISPs were already
forced to use nested NATs, so what address space do they use?

   Brian

---

From: Shin Miyakawa <[email-masked]>
Date: Thu, 31 Jul 2008 23:48:16 +0900 (JST)

From: Brian E Carpenter <[email-masked]>
Subject: Re: [Int-area] discussion of the ISP shared address idea
Date: Fri, 01 Aug 2008 02:34:17 +1200
> with that restriction. Can you explain this?

Because, often a CPE is a router with NAT function with single routing table.
> forced to use nested NATs, so what address space do they use?

As talked in the meeting, in this case, they just simpley restrict 
cusutomers not to use 10.0.0.0/8 in cutomer premises.
But as just it is told in the meeting, sometime small
companies and/or brach offices run 10.0.0.0/8 in the LAN.

Regards,

Shin Miyakawa

---

From: <[email-masked]>
Date: Thu, 31 Jul 2008 16:19:31 +0100

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Shin Miyakawa
> Sent: 31 July 2008 15:06
> To: [email-masked]
> Cc: [email-masked]

How often does the average Japanese consumer replace their CPE?

Mat

---

From: <[email-masked]>
Date: Thu, 31 Jul 2008 16:25:26 +0100

> Sent: 31 July 2008 15:03
> To: [email-masked]
> Cc: [email-masked]

Your 'waste of usage' is my 'price to be paid for not doing the right
thing'.

I just don't buy the argument that says 'we need the time this buys us
to implement v6 on our CPE'. You have time, if you start now.

Regards,
Mat

---

From: Shin Miyakawa <[email-masked]>
Date: Fri, 01 Aug 2008 01:06:17 +0900 (JST)

From: <[email-masked]>
Subject: RE: [Int-area] discussion of the ISP shared address idea
Date: Thu, 31 Jul 2008 16:19:31 +0100
> How often does the average Japanese consumer replace their CPE?

Sorry I have no data about this.
But some people keep using the machine for 10 years.
For example, still some customer uses Windows 98 to subsribe the Internet.
But again, we can not enforce them to upgrade or replace it.

Best wishes,

Shin Miyakawa

---

From: Shin Miyakawa <[email-masked]>
Date: Fri, 01 Aug 2008 01:20:26 +0900 (JST)

Matthew,

> Your 'waste of usage' is my 'price to be paid for not doing the right thing'.

ahaha.

> to implement v6 on our CPE'. You have time, if you start now.

We have already started. How about you in BT network ? :-)

..........

By the way,

Please read my extended version of the slides of plenary on Yesterday at
http://www.nttv6.jp/~miyakawa/IETF72/

(also please try http://www.nttv6.jp/~miyakawa with IPv6
to see a funny picture of Dr.Steve Deering.)

One of the strong reasons why we need do CGN is that
However IE on Windows XP SP3 with IPv6 enabled can reach IPv6 only server like
http://ipv6.google.com/ ,
this Windows XP SP3 in the market today needs IPv4 transport to resolve 
its AAAA record.

Please understand that we need CGN
to let IPv6 move forward strongly and fastly in the real world.

Best regards,

Shin Miyakawa @ one of the close friends of Itojun
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: <[email-masked]>
Date: Thu, 31 Jul 2008 17:23:32 +0100

> We have already started. How about you in BT network ? :-)

BT has time too :)