Subject: Re: [Int-area] new I-D available - tunnel issues

From: [email-masked] (Noel Chiappa)
Date: Mon, 21 Jul 2008 11:18:51 -0400 (EDT)

> From: Joe Touch <[email-masked]>

    > There are basically known variations of state; these aren't new to tunnels:
    >   - preshared, static
    >   - negotiated, hard
    >   - negotiated, soft

Every time I see mention of 'hard' and 'soft' state, I am reminded of my rant
here:

  http://www.chiappa.net/~jnc/tech/hard_soft.html

which makes a number of points about these two terms.

	Noel
_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Joe Touch <[email-masked]>
Date: Mon, 21 Jul 2008 09:17:23 -0700

Noel Chiappa wrote:
|     > From: Joe Touch <[email-masked]>
|
|     > There are basically known variations of state; these aren't new
to tunnels:
|     >   - preshared, static
|     >   - negotiated, hard
|     >   - negotiated, soft
|
| Every time I see mention of 'hard' and 'soft' state, I am reminded of
my rant
| here:
|
|   http://www.chiappa.net/~jnc/tech/hard_soft.html
|
| which makes a number of points about these two terms.

Hi, Noel,

Although I appreciate your notes on this issue, IMO these terms are
generall understood, and we could include these for clarity:

	Hard:	state persists indefinitely
		i.e., this implies state is
		managed only by explicit message
		exchanges

	Soft:	state is "removed" (active associations
		are changed to idle or non-existent)
		as result of time passing
		i.e., this implies state is
		managed by implicit actions,
		such as the passing of time in the
		absence of an explicit refresh

This doesn't address the nuance of your discussion, e.g., whether state
is a prerequisite to services. There are also other dimensions in which
protocol machines differ, such as implicit vs. explicit messaging,
in-band vs out-of-band, etc., but this doc isn't intended to address the
general field of protocol mechanisms (or existing confusion therein).

Joe