Subject: Re: [Int-area] Last Call: <draft-ietf-intarea-shared-addressing-issues-02.txt> (Issues with IP Address Sharing) to Informational RFC

From: "Richard L. Barnes" <[email-masked]>
Date: Tue, 15 Feb 2011 11:51:13 -0500

One late comment on this: Section 7 discusses the impact of address sharing on geolocation and geo-proximity use cases.  (Nit: common usage is "geolocation", not "geo-location")  This section does a good job of describing the impact of address sharing on the common case where an IP address is used as a key into a generic "IP geo" database.

However, there are several emerging systems that provide much more than these generic databases.  Typically, these systems tap into network management infrastructure to map an IP address to the physical resource to which it is assigned, using things like RADIUS databases and DHCP lease tables. This is an important use case, for example, for ECRIT emergency services [draft-ietf-ecrit-framework] using the HELD location protocol [RFC5985].  (Also an issue that Law Enforcement agencies have been known to care deeply about.)

It would be good for this draft to comment on the impact of address sharing for these high-precision IP-geo systems.  Suggested text for after the first paragraph of Section 7:
"
IP addresses are also used as input to higher-fidelity geolocation services that resolve an IP address to a physical location using information from the network infrastructure.  Current systems rely on resources such as RADIUS databases and DHCP lease tables.  The use of address sharing will prevent these systems from resolving the location of a host based on IP address alone.  It will be necessary for users of such systems to provide more information (e.g., TCP or UDP port numbers [I-D.ietf-geopriv-held-identity-extensions]), and for the systems to use this information to query additional network resources (e.g., NAT-PT binding tables).  Since these new data elements tend to be more ephemeral than those currently used for geolocation, their use by geolocation systems may require them to be cached  for some period of time.
" 

On Jan 18, 2011, at 10:04 AM, The IESG wrote:

> 
> The IESG has received a request from the Internet Area Working Group WG
> (intarea) to consider the following document:
> - 'Issues with IP Address Sharing'
>  <draft-ietf-intarea-shared-addressing-issues-02.txt> as an
> Informational RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2011-02-01. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-intarea-shared-addressing-issues/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-intarea-shared-addressing-issues/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Feb 2011 10:27:05 +1300

Richard,

Restraining myself from commenting whether high-precision geolocation has a
finite probability of working at all...

> (e.g., NAT-PT binding tables)

NAT-PT has been obsolete for several years. Do you mean NAPT?

   Brian

On 2011-02-16 05:51, Richard L. Barnes wrote:
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>