Subject: [Int-area] Call for confirming adoption of draft-boucadair-intarea-nat-reveal-analysis-04 as intarea working group draft

From: Suresh Krishnan <[email-masked]>
Date: Thu, 1 Dec 2011 16:32:45 -0500

Hi all,
  During the intarea WG meeting at IETF82 an adoption call in the
meeting room indicated that the sense of the room was in favor of
adopting draft-boucadair-intarea-nat-reveal-analysis-04 as an intarea WG
draft. There were also several people who raised some serious concerns
about the privacy implications of the draft both during the meeting and
later on the mailing list.

We have requested Alissa Cooper to go over the draft and provide input
about the privacy implications along with some text proposals to
document them in the draft. This text should be available early next week.

This call is being initiated to confirm whether there is WG consensus
towards adoption of draft-boucadair-intarea-nat-reveal-analysis-04 as an
intarea WG draft. Please state whether or not you're in favor of the
adoption by replying to this email. If you are not in favor, please also
(re)state your objections in your response. The call will complete at
midnight PST on 2011-12-15.

Regards
Suresh & Julien

---

From: Fred Baker <[email-masked]>
Date: Thu, 1 Dec 2011 14:26:50 -0800

From my perspective, the draft addresses the right set of issues. I personally am concerned about asking host vendors (or for that matter NAT and proxy vendors) to do extra work to keep IPv4 running; I'm personally very happy to use the issue as leverage to press for IPv6 deployment and adoption. But yes, the draft is useful in both directions and will identify operational needs.

On Dec 1, 2011, at 1:32 PM, Suresh Krishnan wrote:

> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 5 Dec 2011 16:16:12 +0200

Hi Suresh, 

it would also be useful to state that the scope of the document has been changed with the discussions at the meeting. Without the clarified scope the call for adoption does not make sense (unless you have been at the IETF meeting in the int-area meeting and have not forgotten the discussion there). 

draft-boucadair-intarea-nat-reveal-analysis-04 states a number of things that have been declared out of scope during the meeting, such as the stated goal of the draft in the abstract:
"
   The ultimate goal is to assess the viability of proposed solutions
   and hopefully to make a recommendation on the more suitable
   solution(s).
"

It was explicitly said during the meeting (by you) that the document will not provide any recommendations.

I also did not got a response about what the authors are actually trying to accomplish with this work. Here is my mail:
http://www.ietf.org/mail-archive/web/int-area/current/msg02998.html

I am still waiting for a response to my questions. Instead of clarifying the scope the discussions moved into the territory of privacy, which I believe is secondary. I am saying secondary because without a clear scope it is mood to discuss more details. 

To be more specific, during the meeting it was said that these analysed mechanisms are for the purpose of authentication of the host (or the user?). 

Ciao
Hannes

---

From: <[email-masked]>
Date: Mon, 5 Dec 2011 15:46:04 +0100

Dear Hannes, all,

The scope of the document is to analyze solutions which allow to ** uniquely distinguish a host among those sharing the same IP address **: This is called HOST_ID. This HOST_ID is to be injected by an address sharing function (e.g., CGN, NAT64, NPTv6, proxy, etc.).

This identifier does not reveal a user identity.

The current version of the document identifies implicit identification (BTW, the document does not use "authentication" word for this usage) as one of the service use cases. Other uses cases such as denial of service are also listed as examples.

Cheers,
Med

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Hannes Tschofenig
> Envoyé : lundi 5 décembre 2011 15:16
> À : Suresh Krishnan
> Cc : Julien Laganier; Internet Area
> Objet : Re: [Int-area] Call for confirming adoption of 
> draft-boucadair-intarea-nat-reveal-analysis-04 as intarea 
> working group draft
> 
> Hi Suresh, 
> 
> it would also be useful to state that the scope of the 
> document has been changed with the discussions at the 
> meeting. Without the clarified scope the call for adoption 
> does not make sense (unless you have been at the IETF meeting 
> in the int-area meeting and have not forgotten the discussion there). 
> 
> draft-boucadair-intarea-nat-reveal-analysis-04 states a 
> number of things that have been declared out of scope during 
> the meeting, such as the stated goal of the draft in the abstract:
> "
> It was explicitly said during the meeting (by you) that the 
> document will not provide any recommendations.
> 
> I also did not got a response about what the authors are 
> actually trying to accomplish with this work. Here is my mail:
> I am still waiting for a response to my questions. Instead of 
> clarifying the scope the discussions moved into the territory 
> of privacy, which I believe is secondary. I am saying 
> secondary because without a clear scope it is mood to discuss 
> more details. 
> 
> To be more specific, during the meeting it was said that 
> these analysed mechanisms are for the purpose of 
> authentication of the host (or the user?). 
> 
> Ciao
> Hannes
> 
> > towards adoption of 
> draft-boucadair-intarea-nat-reveal-analysis-04 as an

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 5 Dec 2011 17:12:03 +0200

Hi Med, 

the slides at http://www.ietf.org/proceedings/82/slides/intarea-0.ppt say: 
"
•Some IP servers need source IP address of incoming traffic for specific treatment
"

In order to do an analysis of individual proposals it is useful to know what the purpose of this identification is. For example, if you want to identify the host for the purpose of single-sign-on / charging* then it would be useful to consider various other proposals currently not described in the document as well. 

In addition, as other publications already illustrate (such as RFC 6302), you may not only use the source IP address but also the source port number. 

Ciao
Hannes

(*): From the meeting minutes at http://www.ietf.org/proceedings/82/minutes/intarea.txt it seems that there is at least a mismatch among the draft authors about the scope of the work. Here is a quote about what it does from the presentation:
 "there are use cases for the source address being used for authentication without having to re-enter username/password."

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 5 Dec 2011 14:55:30 -0600

+1

Behcet

On Thu, Dec 1, 2011 at 4:26 PM, Fred Baker <[email-masked]> wrote:

> From my perspective, the draft addresses the right set of issues. I
> personally am concerned about asking host vendors (or for that matter NAT
> and proxy vendors) to do extra work to keep IPv4 running; I'm personally
> very happy to use the issue as leverage to press for IPv6 deployment and
> adoption. But yes, the draft is useful in both directions and will identify
> operational needs.
>

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 5 Dec 2011 23:50:00 -0500

Hi Hannes,

> It was explicitly said during the meeting (by you) that the document will not provide any recommendations.

Correct. This was stated by Joe Touch, who is one of the authors of the
document and I agreed that it was the right way to go.

> I am still waiting for a response to my questions. Instead of clarifying the scope the discussions moved into the territory of privacy, which I believe is secondary. I am saying secondary because w…

That is a good point. My understanding is that the scope of the document
is to analyze multiple proposed solutions for disambiguating hosts
behind a CGN that share the same IP address, and to discuss the pros and
cons of each of the solutions.

Of course, the pros and cons depend on the use cases being covered and
this is really up to the wg to decide what use cases to cover. But that
is related to the content of the document, and not the scope.

Thanks
Suresh

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 6 Dec 2011 16:43:19 -0800

I support adoption of draft-boucadair-intarea-nat-reveal-analysis as an
INTAREA working group document.

-d

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Suresh Krishnan
> Sent: Thursday, December 01, 2011 1:33 PM
> To: Internet Area
> Cc: Julien Laganier
> Subject: [Int-area] Call for confirming adoption of draft-boucadair-
> intarea-nat-reveal-analysis-04 as intarea working group draft
> 
> Hi all,

---

From: Benson Schliesser <[email-masked]>
Date: Tue, 6 Dec 2011 18:51:55 -0600

Support.

---

From: Tina TSOU <[email-masked]>
Date: Wed, 07 Dec 2011 01:18:46 +0000

Support.

Tina

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Tuesday, December 06, 2011 4:52 PM
To: Julien Laganier; Suresh Krishnan
Cc: Internet Area
Subject: Re: [Int-area] Call for confirming adoption of draft-boucadair-intarea-nat-reveal-analysis-04 as intarea working group draft

Support.

---

From: Alain Durand <[email-masked]>
Date: Tue, 6 Dec 2011 18:01:33 -0800

+1