Subject: [Int-area] WG: New Version Notification for draft-fleischhauer-ipv4-addr-saving-02.txt

From: <[email-masked]>
Date: Tue, 28 Feb 2012 22:13:52 +0100

Dear all,

we have just uploaded version 02 of draft-fleischhauer-ipv4-addr-saving
http://www.ietf.org/id/draft-fleischhauer-ipv4-addr-saving-02.txt

Based on feedback from this and the PPPEXT-WG list, bilateral discussions as well practical experience in testing (Yes, there is running code available :) )
the document contains the following major changes:

1. New chapter "2.1.  Illustrative service provider use case"
        - describes a typical use case

2. Modification of "Figure 1: PPP Dual-Stack architecture"
        - the CPE/CER is now divided in 3 functional parts
        - the text in chapter 2.2 reflects this changes

3. New chapter "4.  Potential for optimization"
        - describes options to increase the efficiency and success of the mechanism

@Tina, Vernon, Joel, Alan & Wes:
We hope that the new draft reflects completely your comments and suggestions?

We'd appreciate any further feedback.
A discussion of the draft in Paris might be helpful.

Best

Olaf & Karsten

Olaf Bonneß
Karsten Fleischhauer

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]
> Gesendet: Dienstag, 28. Februar 2012 21:39
> An: Fleischhauer, Karsten
> Cc: Bonneß, Olaf
> Betreff: New Version Notification for
> draft-fleischhauer-ipv4-addr-saving-02.txt
>
> A new version of I-D,
> draft-fleischhauer-ipv4-addr-saving-02.txt has been
> successfully submitted by Karsten Fleischhauer and posted to
> the IETF repository.
>
> Filename:      draft-fleischhauer-ipv4-addr-saving
> Revision:      02
> Title:                 On demand IPv4 address provisioning in
> Dual-Stack PPP deployment scenarios
> Creation date:         2012-02-28
> WG ID:                 Individual Submission
> Number of pages: 18
>
> Abstract:
>    Today the Dual-Stack approach is the most straightforward and the
>    most common way for introducing IPv6 into existing systems and
>    networks.  However a typical drawback of implementing Dual-Stack is
>    that each node will still require at least one IPv4
> address.  Hence,
>    solely deploying Dual-Stack does not provide a sufficient
> solution to
>    the IPv4 address exhaustion problem.  Assuming a situation
> where most
>    of the IP communication (e.g. always-on, VoIP etc.) can be provided
>    via IPv6, the usage of public IPv4 addresses can significantly be
>    reduced and the unused public IPv4 addresses can under certain
>    circumstances be returned to the public IPv4 address pool of the
>    service provider.  New Dual-Stack enabled services can be
> introduced
>    without increasing the public IPv4 address demand, when
> IPv6 will be
>    the preferred network layer protocol.  This document
> describes such a
>    solution in a Dual-Stack PPP session network scenario and explains
>    the protocol mechanisms which are used.
>
>
>
>
>
> The IETF Secretariat
>

---

From: Tina TSOU <[email-masked]>
Date: Thu, 01 Mar 2012 00:34:45 +0000

Olaf & Karsten,
Yes the draft does include the service provider use case in a newly added section 2.1.
My comments and suggestions are solved.
Thank you for your good work.

Tina

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, February 28, 2012 1:14 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; Tina TSOU;
> [email-masked]; [email-masked]; [email-masked]
> Subject: WG: New Version Notification for draft-fleischhauer-ipv4-addr-
> saving-02.txt
> 
> 
> Dear all,
> 
> Based on feedback from this and the PPPEXT-WG list, bilateral discussions
> as well practical experience in testing (Yes, there is running code
> available :) )