Subject: [Int-area] I-D Action: draft-ietf-intarea-nat-reveal-analysis-07.txt

From: [email-masked]
Date: Wed, 10 Apr 2013 01:58:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Internet Area Working Group Working Group of the IETF.

	Title           : Analysis of Solution Candidates to Reveal a Host Identifier (HOST_ID) in Shared Address Deployments
	Author(s)       : Mohamed Boucadair
                          Joe Touch
                          Pierre Levis
                          Reinaldo Penno
	Filename        : draft-ietf-intarea-nat-reveal-analysis-07.txt
	Pages           : 22
	Date            : 2013-04-10

Abstract:
   This document is a collection of solutions to reveal a host
   identifier (denoted as HOST_ID) when a Carrier Grade NAT (CGN) or
   application proxies are involved in the path.  This host identifier
   could be used by a remote server to sort out the packets by sending
   host.  The host identifier must be unique to each host under the same
   shared IP address.

   This document analyzes a set of solution candidates to reveal a host
   identifier; no recommendation is sketched in the document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-intarea-nat-reveal-analysis

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-intarea-nat-reveal-analysis-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-intarea-nat-reveal-analysis-07

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 10 Apr 2013 13:20:11 +0200

Dear all,

This version integrates the first set of comments received during the IESG review. The main changes are:

* Add a sentence to clarify why no recommendation is included
* Add a sentence to clarify a host can be any computer located behind a CPE or directly connected to an address-sharing function
* Remove Section 1.1 and dispatch the bullets in the core text of Section 3
* Add a sentence to the privacy section to say an address-sharing function can be configured with different end-users policies
* Clarify what is meant by "encrypted traffic" in Table 1
* Add a sentence to the privacy section to request specification document to check whether location information may/may not be exposed using HOST_ID solutions
* Add a new items for the TCP option to mention it may interfere with the use of Fast Open extension
* Add some pointers to behave documents.
* Other minor edits.

Cheers,
Med

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De la
>part de [email-masked]
>Envoyé : mercredi 10 avril 2013 10:58
>À : [email-masked]
>Cc : [email-masked]
>Objet : [Int-area] I-D Action: draft-ietf-intarea-nat-reveal-analysis-
>07.txt
>
>
>	Title           : Analysis of Solution Candidates to Reveal a Host
>Identifier (HOST_ID) in Shared Address Deployments
>_______________________________________________
>Int-area mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/int-area