Subject: [Int-area] Comments and suggestiosn to draft-ietf-intarea-flow-label-balancing-00

From: Linda Dunbar <[email-masked]>
Date: Fri, 5 Apr 2013 20:53:38 +0000

Sheng, Brian, el at: 

I reviewed draft-ietf-intarea-flow-label-balancing-00

Here are my comments:
-------------------------------------

The draft is to suggest using IPv6 header's flow label field to identify different flows from IPv6 hosts. The draft tries to emphasize that the flow label can help devices along the way between Source & destination to achieve better flow separation or finer tuned traffic balancing if there are multiple paths. 

However, the Section 3 devotes so much to various LB schemes. But many are irrelevant. There are many different types of Load Balance, the DNS based load balancing, which is often called global LB,  has nothing to do with LB in front of a cluster of servers. 

Some description about LB in Section 3 is not quite to the point. For example, the second bullet you stated: "Another method, for HTTP servers, is to operate a layer 7 reverse proxy in front of the server farm." The LB in front of a cluster of servers is orthogonal to DNS based global LB. 

Your draft didn't even mention "Direct Server Return (DSR)" LB scheme which is used heavily in DC to balance load among a cluster of servers. In this scheme, all the servers in a cluster share a common IP address which is same as the LB, or use floating IP address for hosts. 

The figure in Page 7 is has some errors too. The DNS based Load Balancing is usually in the Access network. (I really think this figure is not necessary because it doesn't help the draft at all). 

The LB for Server Cluster is more likely located in a Data Center. 

Therefore, I suggest that you replace Section 3 with following:

3. Summary of Load Balancing Techniques:

There are many different types of Load Balancing in networks. There is DNS based global LB, typically placed closer to clients, there are also LB for a cluster of servers who share same IP address as the LB, there are other LB. 

This draft is to describe how flow label can further optimize load balancer in front of a cluster of servers. 

Highlight of Load Balancing Algorithms:

Typical industry standard load balancing algorithms available today include:

Round Robin 
Least Connections 
Fastest Response Time 
Weighted Round Robin 
Weighted Least Connections 
Custom values assigned to individual servers in a pool based on SNMP or other communication mechanism

4. An improved Load Balancing Algorithms using Flow Label
(you can describe how Flow Label improve the LB algorithms currently being deployed"). 

Linda   

> -----Original Message-----
> From: Sheng Jiang
> Sent: Monday, April 01, 2013 9:04 PM
> To: Linda Dunbar
> Subject: RE: Reviewing of flow label balancing
> 
> http://tools.ietf.org/html/draft-ietf-intarea-flow-label-balancing-00
> 
> Many thank,
> 
> Sheng
> 
> >-----Original Message-----
> >From: Linda Dunbar
> >Sent: Monday, April 01, 2013 10:14 PM
> >To: Sheng Jiang
> >Subject: RE: Reviewing of flow label balancing
> >
> >Sheng,
> >
> >Sorry for slipping through my mind.
> >Can you send me the link?
> >
> >Linda
> >
> >> -----Original Message-----
> >> From: Sheng Jiang
> >> Sent: Monday, April 01, 2013 2:02 AM
> >> To: Linda Dunbar
> >> Cc: Brian E Carpenter; Suresh Krishnan
> >> Subject: Reviewing of flow label balancing
> >>
> >> Hi, Linda,
> >>
> >> You volunteered to review our flow label balancing document during
> the
> >> IntArea meeting in Orlando. Could you please confirm when we can get
> >> your feedback?
> >>
> >> Many thanks and best regards,
> >>
> >> Sheng

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 06 Apr 2013 08:13:47 +0100

Linda,

Thanks for the review. Some comments in line.

I have added our co-author in cc because I'm not sure whether
he's on the list.

On 05/04/2013 21:53, Linda Dunbar wrote:
> Here are my comments: -------------------------------------
> 
> 
> The draft is to suggest using IPv6 header's flow label field
> to identify different flows from IPv6 hosts. The draft tries
> to emphasize that the flow label can help devices along the
> way between Source & destination to achieve better flow
> separation or finer tuned traffic balancing if there are
> multiple paths.
> 
> However, the Section 3 devotes so much to various LB schemes.
> But many are irrelevant. There are many different types of
> Load Balance, 

True, but as far as I can tell this topic is quite badly known
in the IETF and it's useful to give an overview for people.

> the DNS based load balancing, which is often
> called global LB,  has nothing to do with LB in front of a
> cluster of servers.

It can be used to select members of a single cluster, in fact I
remember that technique being used in the very early days of
cluster computing. I agree that today it's normally used for
wide area LB, so we can clarify that in the text.

> 
> Some description about LB in Section 3 is not quite to the
> point. For example, the second bullet you stated: "Another
> method, for HTTP servers, is to operate a layer 7 reverse
> proxy in front of the server farm." The LB in front of a
> cluster of servers is orthogonal to DNS based global LB.

Yes, maybe the text needs to be broken up into separate paragraphs.

> Your draft didn't even mention "Direct Server Return (DSR)"
> LB scheme which is used heavily in DC to balance load among a
> cluster of servers. In this scheme, all the servers in a
> cluster share a common IP address which is same as the LB, or
> use floating IP address for hosts.

We didn't think this was relevant because it is part of the
magic *behind* the load balancing point (i.e. the flow label
has already been analysed before sending the packet on to the
individual server). We can certainly explain that point.

Similarly we didn't think that the actual LB algorithm
(round robin etc.) was relevant.

> 
> The figure in Page 7 is has some errors too. The DNS based
> Load Balancing is usually in the Access network. 

See above - we are not talking about DNS for wide-area LB, but
for flipping the address within one site.

> (I really
> think this figure is not necessary because it doesn't help
> the draft at all).

See above - we think it helps people who are new to the topic.

> The LB for Server Cluster is more likely located in a Data

More likely than what? We don't say anything about where the
server cluster lives.

Regards

    Brian

> There are many different types of Load Balancing in networks.
> There is DNS based global LB, typically placed closer to
> clients, there are also LB for a cluster of servers who share
> same IP address as the LB, there are other LB.
> 
> 
> This draft is to describe how flow label can further optimize
> load balancer in front of a cluster of servers.
> 
> Round Robin Least Connections Fastest Response Time Weighted
> Round Robin Weighted Least Connections Custom values assigned
> to individual servers in a pool based on SNMP or other
> communication mechanism
> 
>> -----Original Message----- From: Sheng Jiang Sent: Monday,
>> April 01, 2013 9:04 PM To: Linda Dunbar Subject: RE:
>> Reviewing of flow label balancing
>> 
>>> -----Original Message----- From: Linda Dunbar Sent:
>>> Monday, April 01, 2013 10:14 PM To: Sheng Jiang Subject:
>>> RE: Reviewing of flow label balancing
>>> 
>>> Sheng,
>>> 
>>> Sorry for slipping through my mind. Can you send me the
>>> link?
>>> 
>>> Linda
>>> 
>>>> -----Original Message----- From: Sheng Jiang Sent:
>>>> Monday, April 01, 2013 2:02 AM To: Linda Dunbar Cc:
>>>> Brian E Carpenter; Suresh Krishnan Subject: Reviewing
>>>> of flow label balancing
>>>> 
>>>> Hi, Linda,
>>>> 
>>>> IntArea meeting in Orlando. Could you please confirm
>>>> when we can get your feedback?
>>>>