Subject: [Int-area] What is a wireless link?

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 30 Jul 2013 09:24:12 -0700

Hello folks,

Emmanuel and I have a draft discussing the nature of wireless links and
adjacency.  As it turns out, it can be a source of great confusion as we 
have
learned in past discussions.

Please take a look at our draft:
http://tools.ietf.org/html/draft-baccelli-manet-multihop-communication-01

If there is interest, we would like to submit it as an Int-Area draft.

The draft underwent extensive discussion in the autoconf working group
and is relevant to work in wireless-oriented working groups such as
[manet] and [roll].  We think it belongs in Int-Area because it does not
deal with routing.

If there is still room on the agenda this week, I would be happy to make
a 5 minute presentation on the draft.

-- 
Regards,
Charlie P.

---

From: Joe Touch <[email-masked]>
Date: Tue, 30 Jul 2013 10:08:27 -0700

You might take a look at RFC 3819, esp. the section on multicast and 
broadcast.

Joe

---

From: Emmanuel Baccelli <[email-masked]>
Date: Tue, 30 Jul 2013 23:51:50 +0200

Hi Joe,
the sections you point out do not seem to be applicable to the case of
spontaneous wireless networks which are described in the draft, where
multicast or broadcast does not work in the usual sense (I suggest you look
at the draft).
Best
Emmanuel
On Jul 30, 2013 7:09 PM, "Joe Touch" <[email-masked]> wrote:

>> http://tools.ietf.org/html/**draft-baccelli-manet-multihop-**
>> communication-01<http://tools.ietf.org/html/draft-baccelli-manet-multihop-communication-01>
>>

---

From: Joe Touch <[email-masked]>
Date: Tue, 30 Jul 2013 14:55:48 -0700

Hi, Emmanuel,

The point of the RFC I cited is that "this is what the Internet 
expects". When your RF link doesn't support it, it will be in trouble 
and need some sort of emulation layer.

Joe

On 7/30/2013 2:42 PM, Emmanuel Baccelli wrote:
> multicast or broadcast does not work in the usual sense (I suggest you
> look at the draft).
> Best
> Emmanuel
>
> On Jul 30, 2013 7:09 PM, "Joe Touch" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>         http://tools.ietf.org/html/__draft-baccelli-manet-multihop-__communication-01
>         <http://tools.ietf.org/html/draft-baccelli-manet-multihop-communication-01>
>

---

From: Joe Touch <[email-masked]>
Date: Tue, 30 Jul 2013 15:19:25 -0700

Re-sending with corrected email for Julien.

Joe

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 30 Jul 2013 21:21:12 -0700

Hello Joe,

At minimum, you might say that our draft would help
to understand the nature of any such adaptation layer.

However, for work along the lines done in manet and
roll and elsewhere, you might also say that "the internet"
expects "too much".  For instance, making link-layer
addresses come true across a population of mobile
wireless devices might take more bandwidth than is
really available.  Or it could cause more rapid battery
depletion.  These outcomes have been noted in the
past, and it would be a good idea to try to avoid them
in the future.

Regards,
Charlie P.

On 7/30/2013 3:19 PM, Joe Touch wrote:
>>>         The draft underwent extensive discussion in the autoconf 
>>> working
>>>         group
>>>         If there is still room on the agenda this week, I would be 
>>> happy
>>>         to make
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

-- 
Regards,
Charlie P.

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 31 Jul 2013 08:59:16 +0200

Le 30/07/2013 23:51, Emmanuel Baccelli a écrit :
> Hi Joe, the sections you point out do not seem to be applicable to
> the case of spontaneous wireless networks which are described in the
> draft, where multicast or broadcast does not work in the usual sense
> (I suggest you look at the draft).

That is right.

On some wireless links that dont have link structure (802.11p, outside
the context of a bssid, no ass'n req/resp) the very meaning of broadcast
is confusing: broadcast reaches whoever is physically nearby (as in "TV
broadcast"), and not necessarily those who are in the same link/bssid
(as in "link broadcast").

Alex

> Best Emmanuel
> Emmanuel and I have a draft discussing the nature of wireless links
> and adjacency.  As it turns out, it can be a source of great
> confusion as we have learned in past discussions.
>
> The draft underwent extensive discussion in the autoconf working
> group and is relevant to work in wireless-oriented working groups
> such as [manet] and [roll].  We think it belongs in Int-Area because
> it does not deal with routing.
>
> If there is still room on the agenda this week, I would be happy to
> make a 5 minute presentation on the draft.
>
>
>
> _______________________________________________ Int-area mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Emmanuel Baccelli <[email-masked]>
Date: Tue, 30 Jul 2013 23:42:19 +0200

Hi Joe,

---

From: Joe Touch <[email-masked]>
Date: Wed, 31 Jul 2013 08:33:07 -0700

Hi, Charlie,

> to understand the nature of any such adaptation layer.

I agree, but it clearly ought to be put into the context of that RFC, which is currently not discussed.

> past, and it would be a good idea to try to avoid them

Sure, but my view is that this means that some wireless systems are (alone) insufficient to be Internet subnets. We've seen this before - e.g., ATM required LANE because of a lack of a broadcast capability, and emulated it to support ARP.

I'm not sure whether you're also arguing that the Internet expectations ought to change. In some cases this makes sense (dealing with adjustable BW), but in other cases (lack of broadcast) it argues more that wireless can't act as an Internet L2 subnet. Either another layer (in the spirit of LANE or AAL) needs to be added to wireless nets to support what the Internet expects of L2, or the wireless switches need to act more like Internet routers (in which case some wireless nets cannot be Internet subnets).

Joe

---

From: Joe Touch <[email-masked]>
Date: Wed, 31 Jul 2013 08:40:56 -0700

> (as in "link broadcast").

Agreed, which is why such wireless either needs to include L3 routers or to emulate broadcast (e.g., see ATM LANE for an example). Simply "not having" broadcast basically means that an L2 technology cannot operate as an Internet subnet. 

I.e., although even pigeons can be Internet point-to-point links, but not everything can be an Internet subnet.

Joe