Subject: [Int-area] Comments on draft-baccelli-manet-multihop-communication

From: Emmanuel Baccelli <[email-masked]>
Date: Fri, 7 Mar 2014 10:39:12 +0100

Hi all,

To respond to comments during the int-area meeting on
draft-baccelli-manet-multihop-communication:  this draft is (and in my
opinion should remain) agnostic to architectural considerations or
router/host distinctions.

In particular, whether the wireless communication channel available through
a physical interface is asymmetric, or transitive, or time varying,
does not depend on whether the interface is inserted into a router, or into
a host-only device.

The goal of the draft is only to document basic characteristics of wireless
communication so as to:

(i) educate the wider community, i.e. provide useful information about the
beast you are dealing with on various types of spontaneous wireless
networks targeted in working groups including not only MANET, but also 6lo,
ROLL, 6tisch, Homenet...

(ii) provide referable context for present and future discussions on IP
architecture and protocol design targeting such networks,

(iii) improve convergence time for AUTOCONF-like discussions which might
reappear in a number of working groups.

Some may argue that there is more to say about with these networks e.g.
considerations on solution space and architectural aspects. But in my
opinion, these considerations belong in separate, subsequent documents.

Best regards,

Emmanuel

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 7 Mar 2014 14:22:38 +0000

At the simplest, this document explains that radio transmission is not transitive. Should be obvious, but experience has shown that it's only obvious after it's said.

Why is that important? Because it means that simple broadcast wireless transmissions do not satisfy the assumptions that e.g. ND is built on.

So you can't just hook a host up to a broadcast wireless tranceiver and expect it to work. A router, on the other hand, might work. (Each assuming other such devices.)

So that's an important difference between hosts and routers in this environment. And I think this document needs to say it, at least at some level, as that's a key motivation for some things it says. Without making that point there's a danger of a reader saying "Radio transmission isn't transitive. So what?"

How to make host devices (as opposed to hosts on devices that also have router functions) work is another matter, which may or may not be considered here. Having a little bit of router, maybe just enough to ignore some direct communication with other host devices, might work, for example.

All in my opinion of course.

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************