Subject: [Int-area] FW: New Version Notification for draft-lishi-ipngwg-dbnetlayer-00.txt

From: 李实 <[email-masked]>
Date: Fri, 21 Mar 2014 14:05:25 +0800

Dear all, especially the DNS experts and the IPv6 experts:

    Although IPv6 has been selected as IPng for over 20 years, it has been proved that it was very difficult to promote. I think the reason is simply because IPv6 is incompatible with IPv4.

    I just submitted a new proposal named 'dbnetlayer' as IPng. Compared to IPv6, my proposal not only extends the address space, but also is highly compatible with IPv4. Thus only very few devices are required to upgrade (most L3 devices need not to upgrade).  This proposal achieves this by adding a Domain Name layer above the IP layer in the protocol stack, which means the DNS must make a little modification to fit the protocol stack. 

    This is a very simple proposal, and I hope you will have interest to have a glance at it. 

    The draft is at: http://www.ietf.org/internet-drafts/draft-lishi-ipngwg-dbnetlayer-00.txt

    Thanks.

Lishi
China TeleCom

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2014年3月5日 14:18
收件人: Shi Li; Shi Li
主题: New Version Notification for draft-lishi-ipngwg-dbnetlayer-00.txt

A new version of I-D, draft-lishi-ipngwg-dbnetlayer-00.txt
has been successfully submitted by Shi Li and posted to the IETF repository.

Name:		draft-lishi-ipngwg-dbnetlayer
Revision:	00
Title:		Double Network Layer solution as IPng
Document date:	2014-03-04
Group:		Individual Submission
Pages:		10
URL:            http://www.ietf.org/internet-drafts/draft-lishi-ipngwg-dbnetlayer-00.txt
Status:         https://datatracker.ietf.org/doc/draft-lishi-ipngwg-dbnetlayer/
Htmlized:       http://tools.ietf.org/html/draft-lishi-ipngwg-dbnetlayer-00

Abstract:
   This document describes a new proposal for IPng. Compared to IPv6,
   this proposal has bigger address space, and most importantly, is
   HIGHLY COMPATIBLE with IPv4.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Joe Touch <[email-masked]>
Date: Fri, 21 Mar 2014 18:10:41 -0700

Hi, Lishi,

First, you should consider some of the previous "4+4" or "8+8" proposals 
that use two layers of IP in ways similar to your approach, and you 
should address how yours is distinct. The same is true for I3 
(Cheriton's DNS-based forwarding), for similar reasons.

There are many issues that are not yet addressed in this proposal:

	- impact on DNS: how does this proposal affect the following:

		- current DNS delegations do not correspond to either
		routing areas or physical locations

		- current DNS entries are intended to provide full
		flexibility with IP addresses

Equally importantly, there is a coupling between IP and various 
transports, esp. TCP, where a subset of the IP header is considered part 
of the TCP header (the pseudoheader). This doc needs to address how that 
relationship is affected.

Others will probably have additional feedback.

Joe

On 3/20/2014 11:05 PM, 李实 wrote:
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>