Subject: Re: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

From: Jeffery Hammond <[email-masked]>
Date: Wed, 1 Oct 2014 17:58:20 +0000

Hi Fred;
	Thanks for the update in tunneling technologies, looks like I have some research to do. Other than fragmentation which was the focus of draft-bonica-intarea-gre-mtu what other problems are associated with Internet tunneling.

Jeff Hammond
Samsung System Engineer

-----Original Message-----
From: Templin, Fred L [mailto:[email-masked]] 
Sent: Tuesday, September 30, 2014 4:34 PM
To: Jeffery Hammond; 'Internet Area'
Subject: RE: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

Hi Jeff,

> -----Original Message-----
> From: Int-area [mailto:[email-masked]] On Behalf Of Jeffery 
> Hammond
> Sent: Tuesday, September 30, 2014 1:08 PM
> To: 'Internet Area'
> Subject: Re: [Int-area] (REVISED) Call for adoption of 
> draft-bonica-intarea-gre-mtu-06
> 
> 	I would like to see this also. Just went back and pulled the draft 
> dated 3/5/2010 (I hope this is the latest one draft-touch- 
> intarea-tunnels-01). It would be a good starting point. As this will only continue to grow and a central base and description would be nice.

Agreed.

> 	Other than I.P. in I.P. (GTP) and IPSec what other tunneling technologies would be considered?

There are lots and lots of them; way more than just GRE. Some kinds that operate over UDP/IP are in some ways more flexible than just IP-in-IP since  the network is so ossified around TCP and UDP. But, we should be able to come up with a set of BCP recommendations that apply to all tunnel types.

Thanks - Fred
[email-masked] 

> Jeff Hammond
> Samsung System Engineer
> 
> 
> -----Original Message-----
> From: Int-area [mailto:[email-masked]] On Behalf Of 
> Templin, Fred L
> Sent: Wednesday, September 10, 2014 2:16 PM
> To: Suresh Krishnan; Internet Area
> Subject: Re: [Int-area] (REVISED) Call for adoption of 
> draft-bonica-intarea-gre-mtu-06
> 
> I will say again what I said at the microphone in Toronto. We really ought to move forward with "Tunnels in the Internet Architecture"
> first so that other documents that discuss specific tunnel types can use it as a point of departure (if necessary).
> 
> So, let's have Tunnels in the Internet Architecture brought back onto 
> the front burner first so that other documents that come later can use it as a normative reference.
> 
> Thanks - Fred
> [email-masked]
> 
> > -----Original Message-----
> > From: Int-area [mailto:[email-masked]] On Behalf Of 
> > Suresh Krishnan
> > Sent: Monday, September 08, 2014 9:17 PM
> > To: Internet Area
> > Subject: [Int-area] (REVISED) Call for adoption of
> > draft-bonica-intarea-gre-mtu-06
> >
> > Hi all,
> >     This draft has been presented at intarea face to face meetings 
> > and has received a bit of discussion. This call is being initiated 
> > to determine whether there is WG consensus towards adoption of
> > draft-bonica-intarea-gre-mtu-06 as an intarea WG draft. The draft is 
> > available at
> >
> > http://tools.ietf.org/html/draft-bonica-intarea-gre-mtu-06
> >
> > Please state whether or not you're in favor of the adoption by 
> > replying to this email. If you are not in favor, please also state 
> > your objections in your response. This adoption call will complete on 2014-09-23.
> >
> > Regards
> > Suresh & Juan Carlos
> >
> >
> >
> >
> > _______________________________________________
> > Int-area mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/int-area
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 1 Oct 2014 19:25:23 +0000

Hi Jeff,

> what other problems are associated with Internet tunneling

Wow, there's a lot. Tunnel endpoint discovery, route optimization, nested tunnels
within tunnels, security, policy, etc.

I address a number of these points in draft-templin-aerolink, which might be of
interest to mobile device manufacturers.

Thanks - Fred

> From: Jeffery Hammond [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2014 10:58 AM
> To: Templin, Fred L; 'Internet Area'
> 	Thanks for the update in tunneling technologies, looks like I have some research to do. Other than fragmentation which was
> the focus of draft-bonica-intarea-gre-mtu what other problems are associated with Internet tunneling.
> 
> Jeff Hammond
> Samsung System Engineer
> 
> 
> There are lots and lots of them; way more than just GRE. Some kinds that operate over UDP/IP are in some ways more flexible than
> just IP-in-IP since  the network is so ossified around TCP and UDP. But, we should be able to come up with a set of BCP
> recommendations that apply to all tunnel types.
> 
> Thanks - Fred

---

From: Jeffery Hammond <[email-masked]>
Date: Thu, 2 Oct 2014 11:55:56 +0000

Fred;
	Thanks. Let me read the draft before I continue to slow this work down. I do feel this could be an emerging problem.

Jeff Hammond
Samsung System Engineer

-----Original Message-----
From: Templin, Fred L [mailto:[email-masked]] 
Sent: Wednesday, October 01, 2014 2:25 PM
To: Jeffery Hammond; 'Internet Area'
Subject: RE: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

Hi Jeff,

> what other problems are associated with Internet tunneling

Wow, there's a lot. Tunnel endpoint discovery, route optimization, nested tunnels within tunnels, security, policy, etc.

I address a number of these points in draft-templin-aerolink, which might be of interest to mobile device manufacturers.

Thanks - Fred

> 	Thanks for the update in tunneling technologies, looks like I have 
> some research to do. Other than fragmentation which was the focus of draft-bonica-intarea-gre-mtu what other problems are associated with Internet tunneling.
> 
> Jeff Hammond
> Samsung System Engineer
> 
> 
> > Jeffery Hammond
> > intarea-tunnels-01). It would be a good starting point. As this will 
> > only continue to grow and a central base and description would be
> nice.
> 
> Agreed.
> 
> There are lots and lots of them; way more than just GRE. Some kinds 
> that operate over UDP/IP are in some ways more flexible than just 
> IP-in-IP since  the network is so ossified around TCP and UDP. But, we should be able to come up with a set of BCP recommendations that apply to all tunnel types.
> 
> Thanks - Fred
> > I will say again what I said at the microphone in Toronto. We really 
> > ought to move forward with "Tunnels in the Internet
> Architecture"
> > So, let's have Tunnels in the Internet Architecture brought back 
> > onto the front burner first so that other documents that come later can use it as a normative reference.
> >
> > Thanks - Fred
> > > draft-bonica-intarea-gre-mtu-06 as an intarea WG draft. The draft 
> > > is available at
> > >

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 2 Oct 2014 14:38:05 +0000

Thanks Jeff,

Also forgot to add "mobility" to my list. And, AERO already includes a comprehensive
tunnel MTU and fragmentation solution that should be adapted for general use and
included in  "intarea-tunnels" if the authors ever get around to reviving that document.

Fred

> Sent: Thursday, October 02, 2014 4:56 AM
> > IP-in-IP since  the network is so ossified around TCP and UDP. But, we should be able to come up with a set of BCP