Subject: [Int-area] FW: New Version Notification for draft-xu-intarea-ip-in-udp-01.txt

From: Xuxiaohu <[email-masked]>
Date: Thu, 23 Apr 2015 01:37:42 +0000

Hi all,

Major changes include :1) request allocating different UDP port numbers for IPv4 and IPv6 respectively; 2) add a new co-author.

Any comments are welcome.

Best regards,
Xiaohu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 23, 2015 9:34 AM
> To: Lucy yong; Yiu Lee; Xuxiaohu; Yongbing Fan; Rajiv Asati; Xuxiaohu; Lucy yong;
> Tom Herbert; Iljitsch van Beijnum; Yiu Lee; Tom Herbert; Rajiv Asati; Iljitsch van
> Beijnum; Fan Yongbing
> Subject: New Version Notification for draft-xu-intarea-ip-in-udp-01.txt
> 
> 
> A new version of I-D, draft-xu-intarea-ip-in-udp-01.txt has been successfully
> submitted by Xiaohu Xu and posted to the IETF repository.
> 
> Name:		draft-xu-intarea-ip-in-udp
> Revision:	01
> Title:		Encapsulating IP in UDP
> Document date:	2015-04-22
> Group:		Individual Submission
> Pages:		11
> URL:
> http://www.ietf.org/internet-drafts/draft-xu-intarea-ip-in-udp-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-xu-intarea-ip-in-udp/
> Htmlized:       http://tools.ietf.org/html/draft-xu-intarea-ip-in-udp-01
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-xu-intarea-ip-in-udp-01
> 
> Abstract:
>    Existing Softwire encapsulation technologies are not adequate for
>    efficient load balancing of Softwire service traffic across IP
>    networks.  This document specifies additional Softwire encapsulation
>    technology, referred to as IP-in-User Datagram Protocol (UDP), which
>    can facilitate the load balancing of Softwire service traffic across
>    IP networks.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Joe Touch <[email-masked]>
Date: Fri, 24 Apr 2015 11:23:26 -0700

On 4/22/2015 6:37 PM, Xuxiaohu wrote:
> Major changes include :1) request allocating different UDP port numbers for IPv4 and IPv6 respectively; 

There is insufficient justification for using two ports, IMO.

At the least, the checksum field already indicates whether the contents
is IPv4 or IPv6, and that field or the IP type field is sufficient for
any differential processing.

The issue of single-bit errors, as raised previously, is not relevant
esp. when using checksums.

Joe