Subject: [Int-area] Benoit Claise's Discuss on draft-ietf-intarea-gre-ipv6-11: (with DISCUSS)

From: "Benoit Claise" <[email-masked]>
Date: Wed, 05 Aug 2015 16:12:00 -0700

Benoit Claise has entered the following ballot position for
draft-ietf-intarea-gre-ipv6-11: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-intarea-gre-ipv6/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I'm confused by "It updates the GRE specification, RFC 2784." and "This
document specifies GRE procedures for IPv6, used as either the payload or
delivery protocol."

Let me take this sentence (in the GRE Header Fields)

   The GRE ingress node SHOULD set the Checksum Present field in the GRE
   header to zero. 

I don't know if it's valid for both IPv4 and IPv6.
Based on the "update" flag, I would say it's valid for both, as it
updates RFC 2784.
Based on the abstract, I would say it's only for IPv6
If the latter, it should clearly say so. Alternatively, the "update" can
be removed, to treat this RFC as an extension, specific to IPv6. However,
we would lose the forward ref from RFC 2784

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 6 Aug 2015 20:22:49 +0000

Benoit,

I see your point. This document doesn't UPDATE 2784 at all. What's more, the UPDATE flag makes the draft confusing. Later today, I will post a new version of the draft with the UPDATE flag removed.

For those of you who care about the obsessive/compulsive details, the following are reasons for removing the UPDATE flag:

- The current draft doesn't change a single word of RFC 2784. Implementations that were 2784 compliant the day before this draft was published will remain compliant the day after it is published.

- The current draft addresses only IPv6 delivery and payload headers. RFC 2784 takes great care to avoid both of these areas.

                                                                                                   Ron

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Wednesday, August 05, 2015 7:12 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; draft-ietf-intarea-gre-
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Benoit Claise's Discuss on draft-ietf-intarea-gre-ipv6-11: (with
> DISCUSS)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Based on the "update" flag, I would say it's valid for both, as it updates RFC
> 2784.
> Based on the abstract, I would say it's only for IPv6 If the latter, it should
> clearly say so. Alternatively, the "update" can be removed, to treat this RFC
> as an extension, specific to IPv6. However, we would lose the forward ref
> from RFC 2784
> 
> 
>