Subject: [Int-area] Fwd: New Version Notification for draft-nordmark-intarea-ippl-03.txt

From: Erik Nordmark <[email-masked]>
Date: Mon, 21 Mar 2016 13:15:57 -0700

Updated based on comment from Dave Thaler.

Let me know if there are any other open issues; I don't have any.

    Erik

-------- Forwarded Message --------
Subject: 	New Version Notification for draft-nordmark-intarea-ippl-03.txt
Date: 	Mon, 21 Mar 2016 11:15:29 -0700
From: 	[email-masked]
To: 	Erik Nordmark <[email-masked]>

A new version of I-D, draft-nordmark-intarea-ippl-03.txt
has been successfully submitted by Erik Nordmark and posted to the
IETF repository.

Name:		draft-nordmark-intarea-ippl
Revision:	03
Title:		IP over Intentionally Partially Partitioned Links
Document date:	2016-03-21
Group:		intarea
Pages:		11
URL:            https://www.ietf.org/internet-drafts/draft-nordmark-intarea-ippl-03.txt
Status:         https://datatracker.ietf.org/doc/draft-nordmark-intarea-ippl/
Htmlized:       https://tools.ietf.org/html/draft-nordmark-intarea-ippl-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-nordmark-intarea-ippl-03

Abstract:
    IP makes certain assumptions about the L2 forwarding behavior of a
    multi-access IP link.  However, there are several forms of
    intentional partitioning of links ranging from split-horizon to
    Private VLANs that violate some of those assumptions.  This document
    specifies that link behavior and how IP handles links with those
    properties.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Sowmini Varadhan <[email-masked]>
Date: Tue, 29 Mar 2016 06:53:39 -0400

On Mon, Mar 21, 2016 at 4:15 PM, Erik Nordmark <[email-masked]> wrote:

>
> URL:
> https://www.ietf.org/internet-drafts/draft-nordmark-intarea-ippl-03.txt

 aiui, the problem statement here is that you can have one
IP subnet broken into islands of isolated/community vlans
that are not necessarily in the same IP bcast domain, so
IP-based protocols have to factor in that consideration.

Is DHCP another example of such a protocol that might have
similar caveats (e.g., if a node in a community vlan gets
some info from the dhcp server, then the info for the default
router needs to be on the node's community vlan or a
promisc vlan)? There may also be some rules around icmp
redirect generation that cannot be based purely on IP subnet
mask checks?

--Sowmini